简介
本文档介绍启动Cisco Unified Contact Center Express(UCCX)脚本编辑器10.5(1)版时遇到的问题。
问题
您无法运行UCCX编辑器版本10.5(1)(CiscoUnifiedCCXditor.exe)。
症状
启动后,UCCX Editor窗口出现的时间不到一秒,并且消失。应用程序尝试启动,但它消失。
解决方案
要解决此问题,必须检查文件夹中是否存在CCX编辑器的文件:C:\Program文件(x86)\wfavvid_1051。要检查此项,请右键单击“编辑器”图标(快捷方式),然后导航到“属性”>“目标”。安装文件夹应直接位于C:\Program files(x86)中。
有时,路径可能不正确。例如:C:\Program文件(x86)\Cisco\Unified Serviceability\JRtmt\wfavvid_1051。
请采取以下步骤解决此问题:
- 要在工作站上卸载CCX脚本编辑器应用程序,请导航到控制面板>添加/删除程序。
- 将Editor应用程序(以管理员身份运行)直接安装到Program Files中,并明确定义路径:C:\Program文件(x86)\wfavvid_1051。
- 运行应用程序以测试。
根本原因
此问题与安装的默认位置(路径)有关。 它会查找硬编码到该位置的文件,如果未找到这些文件,则不会启动这些文件。默认情况下,CCX编辑器必须安装在以下位置:C:\Program Files(x86)\wfavvid_1051。如果情况并非如此,则编辑器将无法正确运行。为了测试这一点,如果将wfavvid_1051文件夹复制到其他位置,则可以重新创建问题。
此外,我们注意到,如果以前在工作站上安装过实时监控工具(RTMT),UCCX编辑器将提示用户将其安装在错误的路径中:C:\Program Files(x86)\Cisco\Unified Serviceability\JRtmt\wfavvid_1051。
在错误位置安装后,无法启动编辑器。此时,应采取前面提到的步骤来解决问题。虽然已经找到了解决方法,但是为了简化和解决与安装相关的问题,我们打开了一个增强缺陷:CSCur86817。