简介
本文档介绍当 Finesse Supervisor Desktop 上显示过多信息时,思科统一联系中心快捷版 (UCCX) 会遇到的问题,并介绍问题的解决方法。
先决条件
要求
思科建议您拥有与配备 Finesse Desktop 的 UCCX 版本 10.0 及更高版本相关的知识。
使用的组件
本文档中的信息基于配备 Finesse Desktop 的 UCCX 版本 10.0 及更高版本。
本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。
问题
Finesse Supervisor Desktop 显示各联系人服务队列 (CSQ) 的统计信息。在 UCCX 中,该信息在 Finesse“队列数据”选项卡的“语音 CSQ 摘要报告”下配置。此报告是嵌入式实时数据小工具,可从思科 Unified Intelligence Center (CUIC) 提取实时信息。 主管还可从 Finesse 的“团队数据”选项卡登录所有已登录的代理,而无论代理所分配到的团队。
我们发现,只有一些主管能够看到所有登录的队列和代理。由于显示的信息过多,这会成为整个联系中心环境的问题。
原因
出现该问题是因为主管也可以配置为报告用户。如果主管作为历史报告用户,则也会将其分配给 AllUsers.ReportingUsers 组,这会改变集合的可访问列表(扩大范围)。
在 Finesse Supervisor Desktop 的“队列数据”选项卡中,系统会从 CUIC 实时数据的“语音 CSQ 摘要报告”、“语音 CSQ 代理详细信息报告”和“代理统计报告”中提取数据。与主管范围相对应的 CSQ 条目都会显示,由于主管此时也是报告用户,所以显示内容将包括所有 CSQ。
在 Finesse Supervisor Desktop 的“团队数据”选项卡中,系统会从 CUIC 实时数据的“代理统计报告”中提取数据。与主管范围相对应的代理都会显示,由于主管此时也是报告用户,所以显示内容将包括所有代理。
注意:默认情况下,主管仅可访问思科统一联系中心快捷版报告用户指南 10.6(1) 中记录的实时数据报告。
解决方法
注意:此问题在思科漏洞 ID CSCus17605 下作为增强请求进行跟踪。
此问题的解决方法可缩小 Finesse Supervisor Desktop 上显示的统计信息的范围,其中涉及通过 Finesse Admininstration 页面修改 XML 布局。您必须修改各小工具的 URL。例如:
注意:请勿复制和粘贴此部分中的 XML 代码。此处仅提供解决此问题的一个示例,对 Finesse 上的 XML 代码的更改应视具体情况进行。
如果作为“蓝”队资源的主管想要查看分配给“蓝”队和“红”队的 CSQ 的 CSQ 数据,但不查看未分配给这两队的 CSQ 的其他 CSQ 数据,则应在“团队资源”选项卡的 Finesse Administration 页面上,在 Finesse 布局 XML 中编辑“蓝”队 queueData URL(如本例所示)。
<id>queueData</id>
<label>finesse.container.tabs.supervisor.queueDataLabel</label>
<columns>
<column>
<gadgets>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveData
Gadget.jsp?gadgetHeight=620&viewId_1=C8E2DB1610000140000000A60A4E5E6B&filterId_1
=VoiceIAQStats.esdName=CL%20blue,%20red&viewId_2=9A7A14CE10000140000000ED0A
4E5E6B&filterId_2=VoiceCSQDetailsStats.agentId=CL%20blue,%20red&compositeFilterId
=VoiceCSQDetailsStats.AgentVoiceCSQNames.agentVoiceCSQName=CL%20blue,%20red
&viewId_3=C8EF510810000140000000EB0A4E5E6B&filterId_3=VoiceIAQStats.esdName
=CL%20blue,%20red&viewId_4=C8EE241910000140000000C30A4E5E6B&filterId_4
=VoiceIAQStats.esdName=CL%20blue,%20red</gadget>
同样,如果“蓝”队资源的主管想要查看“蓝”队和“红”队成员的团队数据,但不查看不属于这两个团队的代理的其他团队数据,则编辑“蓝”队 teamData URL,如本例所示。
<id>teamData</id>
<label>finesse.container.tabs.supervisor.teamDataLabel</label>
<columns>
<column>
<gadgets>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=620&viewId_1=7291DCB410000140000000890A4E5B33&filterId_1=
ResourceIAQStats.resourceId=CL%20blue,%20red&viewId_2=728283C210000140000000530A4E5B33
&filterId_2=ResourceIAQStats.resourceId=CL%20blue,%20red</gadget>
以下是有关此示例的一些重要说明:
- 如果在 URL 中仅使用 CL,则报告包含主管所具有权限的所有集合的值。
- 在 URL 中使用 CL%20<Team_Name> 时,<Team_Name> 将替换为主管想要查看数据的团队的实际名称;因此,仅显示 <Team_Name> 的数据。URL 中的 <Team_Name> 是占位符,并在由 Finesse 传递给 CUIC 小工具代码的实际值替换后发送给 CUIC 服务器。如果主管想要查看多个团队的数据,比如“N”个团队,则必须使用 CL%20<Team_Name_1>,%20<Team_Name_2>,...,%20<Team_Name_N>。
- 在 URL 中使用 Cl%20blue 时(假设 blue 是实际团队名称),则系统仅显示属于 blue 集合的值。
- 在 URL 中使用 Cl%20blue,%20red 时(假设 blue 和 red 是实际团队集合),则系统仅显示属于 blue 集合和 red 集合的值。
您还必须对任何其他小工具实施这些修改。有关实时数据小工具 URL 和小工具定义的详细信息,请参阅思科 Unified CCX 管理指南,版本 10.6。
注意:使用时,应仔细评估此解决方法,因为必须在团队级别的桌面布局上完成修改。在团队级别进行编辑时,您可以覆盖系统默认布局。
注意:团队名称可以带空格,但必须使用 %20 设置 XML 布局才可显示空格。
功能介绍
为完全解决此问题,在 UCCX 11.6 中引入了一项新功能。此功能通过思科漏洞 ID CSCus17605.下的增强请求添加。
从 UCCX 11.6 开始,主管可以访问其团队的历史报告,以便无需设置其他报告用户角色。这样,主管仅会在 Finesse 实时数据报告中看到其团队,且仍可访问其团队的历史报告,而无需具有报告用户角色。如果将报告用户角色添加到任何用户,则该用户将有权查看所有报告中的所有团队的代理和 CSQ,并能够查看 Finesse 实时数据报告中的所有代理和 CSQ。