show running-config ospf

To display the running configuration for Open Shortest Path First version 2 (OSPFv2) for IPv4 networks, use the show running-config ospf command.

show running-config ospf

Syntax Description

This command has no arguments or keywords.

Command Default

None

Command Modes

EXEC mode

Command History

Release
Modification
5.0(3)N1(1)
This command was introduced.

Usage Guidelines

This command does not require a license.

Examples

This example shows how to display the running configuration for OSPF:

switch# show running-config ospf
 
!Command: show running-config ospf
!Time: Tue Apr 15 09:09:15 2008
 
version 5.0(3)N1(1)
feature ospf
 
router ospf 201
router-id 192.0.2.1
default-information originate route-map DefaultRouteFilter
area 0.0.0.10 virtual-link 192.0.2.3
authentication message-digest
authentication-key 3 15e76ee89406ccbf
message-digest-key 21 md5 3 15e76ee89406ccbf
dead-interval 50
hello-interval 25
retransmit-interval 50
transmit-delay 2
redistribute bgp 1 route-map FilterExtBGP
redistribute maximum-prefix 1000 75 warning-only
area 0.0.0.10 authentication
area 0.0.0.10 default-cost 25
area 0.0.0.10 filter-list route-map FilterLSAs in
log-adjacency-changes
maximum-paths 3
default-metric 25
 
interface Ethernet1/5
ip ospf authentication key-chain Test1
ip ospf authentication-key 3 15e76ee89406ccbf
ip ospf message-digest-key 21 md5 3 15e76ee89406ccbf
ip ospf cost 25
ip ospf dead-interval 50
ip ospf hello-interval 25
ip ospf passive-interface
ip ospf priority 25
ip ospf mtu-ignore
ip router ospf 201 area 0.0.0.15
 
switch#

Related Commands

Command
Description
router ospf
Creates an OSPF instance.