Guest

Cisco IOS Software Releases 12.0 T

IS-IS Multiarea Support

Table Of Contents

IS-IS Multiarea Support

Feature Overview

Redistribution

TARP

Benefits

Restrictions

Related Features and Technologies

Related Documents

Supported Platforms

Supported MIBs and RFCs

Configuration Tasks

Configuration Tasks for Multiarea IS-IS

Verifying Multiarea IS-IS Configuration

Monitoring and Maintaining Multiarea IS-IS

Configuration Example

Multiarea IS-IS Configuration

Command Reference

clns router isis

ip router isis

isis display delimiter

isis mesh-group

is-type

net

partition avoidance

router isis

Show Commands

show clns neighbor areas

show clns route

show isis topology

Glossary

IS-IS Multiarea Support


Feature History

Release
Modification

12.0(5)T

This feature was introduced.


Feature Overview

This feature module describes multiarea Intermediate System-to-Intermediate System (IS-IS) support for ISO Connectionless Network Service (CLNS). It also describes how to use the modified isis mesh-group command to limit link-state packet (LSP) flooding, a technique that is related to IS-IS configuration in general and is not limited to configuring multiarea IS-IS networks. Small IS-IS networks are built as a single area that includes all the routers in the network. As the network grows larger, it is usually reorganized into a backbone area made up of the connected set of all Level 2 routers from all areas, which is in turn connected to local areas. Within a local area, routers know how to reach all system IDs. Between areas, routers know how to reach the backbone, and the backbone routers know how to reach other areas.

Routers establish Level 1 adjacencies to perform routing within a local area (intra-area routing). Routers establish Level 2 adjacencies to perform routing between Level 1 areas (interarea routing).

Some networks use legacy equipment that supports only Level 1 routing. These devices are typically organized into many small areas that cannot be aggregated due to performance limitations. Cisco routers are used to interconnect each area to the Level 2 backbone.

Previously, each Cisco router could participate in only one area, performing Level 1 (intra-area) routing locally, and Level 2 (interarea) routing to other areas in the network. This limitation meant that when the network was divided into a large number of Level 1 areas, a correspondingly large number of Level 1/2 routers was required to route between all areas, as shown in the example in Figure 1. The need for redundancy increases the number of routers needed.

With this feature release, Cisco IOS software supports configuration of multiple Level 1 areas within a single router.

Figure 1 represents a telco network used to monitor the status of the switching equipment in multiple remote central offices (where the telco equipment resides) from a central monitoring point.

In this example, the CLNS network of the telco is being used to monitor the status of the switching equipment. The CLNS network is not used to perform actual circuit switching (end users making voice or data calls).

Figure 1

IS-IS Network for Monitoring Remote Equipment Status

Figure 2 shows the same network reconfigured using multiarea IS-IS. The number of local access routers has been reduced. Each router continues to provide access to the backbone, but also participates in multiple Level 1 areas.

A more powerful area router platform may be required to handle the increased load, but fewer routers are required at the access level. In this example a 3:1 reduction in the number of routers required is shown. However, if you configure more Level 1 areas on each multiarea router, further reduction in the number of routers required is possible.

Figure 2

Multiarea IS-IS Network for Monitoring Remote Equipment Status

Redistribution

IP routes learned via Level 1 routing are advertised by default into Level 2. Even when multiple Level 1 processes are configured on the same unit, this fact is still true. No additional configuration is required to redistribute all Level 1 IP routes into the Level 2 process.

In CLNS routing there is no redistribution of Level 1 host routes into Level 2. Only Level 1 addresses are advertised into Level 2. Redistribution of all area addresses of all Level 1 areas into Level 2 is implicit in IS-IS, and no additional configuration is required for this redistribution.

Redistribution of other protocols will continue to work with conventional IS-IS configurations as it does in Release 12.0.

TARP

For a conventional IS-IS configuration with a single Level 1 and a Level 2 area (or configuration with a single Level 1 area or a Level 2 area), Target Address Resolution Protocol (TARP) continues to work without any change in previous behavior.

If multiple Level 1 areas are defined, the router resolves addresses using TARP in the following way:

The the router obtains the Network Service Access Point (NSAP) of the Level 2 area, if present, from the locally assigned target identifier.

If only Level 1 areas are configured, the router uses the NSAP of the first active Level 1 area as shown in the configuration at the time of TARP configuration ("tarp run"). (Level 1 areas are sorted alphanumerically by tag name, with capital letters coming before lowercase letters. For example, AREA-1 precedes AREA-2, which precedes area-1.) Note that the target identifier NSAP could change following a reload if a new Level 1 area is added to the configuration after TARP is running.

The router continues to process all Type 1 and 2 protocol data units (PDUs) that are for this router. Type 1 PDUs are processed locally if the target identifier is in the local target identifier cache. If not, they are "propagated" (routed) to all interfaces in the same Level 1 area. (The same area is defined as the area configured on the input interface.)

Type 2 PDUs are processed locally if the specified target identifier is in the local target identifier cache. If not, they are propagated via all interfaces (all Level 1 or Level 2 areas) with TARP enabled. If the source of the PDU is from a different area, the information is also added to the local target identifier cache. Type 2 PDUs are propagated via all static adjacencies.

Type 4 PDUs (for changes originated locally) are propagated to all Level 1 and Level 2 areas (because internally they are treated as "Level 1-2").

Type 3 and 5 PDUs continue to be routed.

Type 1 PDUs are only "propagated" (routed) via Level 1 static adjacencies if the static NSAP is in one of the Level 1 areas in this router.

Benefits

Fewer Routers Required to Support the Same Number of Areas

The IS-IS Multiarea Support feature makes it possible for one Cisco router to support multiple Level 1 areas, as opposed to the single Level 1 area previously supported by each router.

Network Scaling

A single Cisco router can now participate in routing in up to 29 areas, as well as perform Level 2 (interarea) routing in the backbone. Expansion of an IS-IS network consisting of many small areas is simpler that previously, because you can configure multiple Level 1 areas in the same Cisco unit, without needing to add and configure physical units for each additional local area.

Connectivity for Local Level 1 Areas on the Same Router

This feature also provides connectivity between Level 1 areas local to the router. Previously Level 1 areas could only to be connected using the Level 2 backbone.

Restrictions

Configuration Limitations

This feature supports routing for at most one Level 2 area per router, although you can define up to 29 Level 1 areas for each Cisco unit.

An interface cannot be part of more than one Level 1 or one Level 2 area per router. You can, however, configure subinterfaces as Level 1 areas when subinterfaces can be used, such as with WAN media.

The IS-IS Multiarea Support feature is supported only for ISO CLNS.

You can configure only one process to perform Level 2 (interarea) routing. If Level 2 routing is configured on any process, all additional processes are automatically configured as Level 1. You can configure this process to perform intra-area (Level 1) routing at the same time. You can configure up to 29 additional processes as Level 1-only processes.

Redistribution

Explicit redistribution between IS-IS areas cannot be configured. Redistribution from any other routing protocol into a particular area is possible, and is configured per router instance, as in Release 12.0 of the Cisco IOS software, using the redistribute and route map commands. By default, redistribution is into Level 2.

External Area Merge

The IS-IS protocol allows you to merge areas by configuring multiple network entity titles (NETs) on a router. If these NETs define a router to be in both Area A and Area B, for example, the router can potentially merge areas A and B. The result of the merge will be one Level 1 area with two area addresses: A and B. All routers in this merged area must have NSAPs with unique system IDs.

Distinct areas defined in a multiarea router cannot share a common area address. This means that all routers in a single area must have unique system IDs. However, it is possible for two areas to be "merged" external to the router, such as when a common area number is introduced by other routers in the two areas. When this happens, the areas that now have a common area number are said to be "merged" into a single area.

If this happens, the multiarea router will see its own area data from two different areas on a single interface, and the router will display the CLNS-DUPSYSTEM warning message.

The error is a configuration error and must be corrected manually.

Related Features and Technologies

The IS-IS multiarea feature is an extension of integrated IS-IS and ISO CLNS. Integrated IS-IS is documented in Network Protocols Configuration Guide, Part 1, and the Network Protocols Command Reference, Part 1. ISO CLNS is documented in Cisco IOS Release 12.0 Network Protocols Configuration Guide, Part 3, and the Cisco IOS Release 12.0 Network Protocols Command Reference, Part 3.

Related Documents

For related information on this feature, refer to the following documents:

Cisco IOS Release 12.0 Network Protocols Configuration Guide, Part 1

Cisco IOS Release 12.0 Network Protocols Command Reference, Part 1

Cisco IOS Release 12.0 Network Protocols Configuration Guide, Part 3

Cisco IOS Release 12.0 Network Protocols Command Reference, Part 3

Supported Platforms

Cisco 2500 series

Cisco 2600 series

Cisco 3600 series

Cisco 4500 series

Cisco 7200 series

Cisco 7500 series

Supported MIBs and RFCs

None.

Configuration Tasks

There is no change to the configuration process for configuring conventional IS-IS with ISO CLNS:

The configuration procedure for configuring conventional IS-IS with ISO CLNS is described in the "Configuring ISO CLNS" chapter of the Cisco IOS Release 12.0 Network Protocols Configuration Guide, Part 3.

Unlike other routing protocols, enabling IS-IS requires that you create an IS-IS routing process and assign it to a specific interface, rather than to a network. You can specify more than one IS-IS routing process per Cisco unit, using the multiarea IS-IS configuration syntax. You then configure the parameters for each instance of the IS-IS routing process.

In general, each routing process corresponds to an area. By default, the first instance of the routing process configured performs both intra-area (Level 1) and Level 2 (interarea) routing. You can configure additional router instances, which are automatically treated as Level 1 areas. You must configure the parameters for each instance of the IS-IS routing process individually.

You can configure at most only one IS-IS routing process to perform Level 2 (interarea) routing. If Level 2 routing is not desired for a router instance, remove the Level 2 capability using the is-type command. Use the is-type command to configure a different router instance as a Level 2 router.

Configuration Tasks for Multiarea IS-IS

To configure multiarea IS-IS in integrated mode, or ISO CLNS, complete the tasks in the following sections. Enabling IS-IS and ISO CLNS is required; the remainder of the tasks in the following list are optional (although you might need to perform them, depending upon your specific application):

Enabling IS-IS and Assigning Areas (Required)

Enabling CLNS Routing for an Area on an Interface (Required for CLNS)

Modifying the Output of show Commands (Optional)

Enabling Partitioning Avoidance (Optional, but recommended)

Changing the Routing Level for an Area (Optional)

Limiting LSP Flooding (Optional)

Configuring Other IS-IS Parameters (Optional)

Limiting LSP flooding is described in this document. The other tasks are documented in Cisco IOS Release 12.0 Network Protocols Configuration Guide, Part 1 and Cisco IOS Release 12.0 Network Protocols Configuration Guide, Part 3.

Enabling IS-IS and Assigning Areas

To enable IS-IS and specify the area for each instance of the IS-IS routing process, use the following commands, starting in global configuration mode:

Step
Command
Purpose

Step 1

Routerrouter isis [area tag]

Enables IS-IS routing for the specified routing process, and places you in router configuration mode.

Use the area tag argument to identify the area to which this IS-IS router instance is assigned. A value for tag is required if you are configuring multiple IS-IS areas.

The first IS-IS instance configured is Level 1-2 by default. Later instances are automatically Level 1. You can change the level of routing to be performed by a particular routing process using the is-type command.

Step 2

Router(config)# net network-entity-title

Configures NETs for the routing process. Specify an NET for each routing process if you are configuring multiarea IS-IS. You can specify a name for a NET and for an address.


Enabling CLNS Routing for an Area on an Interface

To enable CLNS routing and specify the area for each instance of the IS-IS routing process, use the following commands, starting in global configuration mode:

Step
Command
Purpose

Step 1

Routerinterface type number

Enters interface configuration mode.

Step 2

Router(config-if)clns router isis [area 
tag]

Specifies that the interface actively routing IS-IS when the network protocol is ISO-CLNS, and identifies the area associated with this routing process on this interface.

Step 3

Router(config-if)ip address ip-address-mask

Defines the IP address for the interface.

An IP address is required on all interfaces in an area enabled for IS-IS if any one interface is configured for IS-IS routing.


Modifying the Output of show Commands

To customize display output when the multiarea feature is used, making the display easier to read, use the following EXEC command:

 
Command
Purpose
 
Router# isis display delimiter [return 
cnt |char cnt]

Specifies the delimiter to be used to separate displays of information about individual IS-IS areas.


For example, the following command causes information about individual areas to be separated by 14 dashes (-) in the display:

isis display delimiter - 14

The output for a configuration with two Level 1 areas and one Level 2 area configured is as follows:

dtp-5#show clns neighbors
--------------
Area L2BB:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
0000.0000.0009 Tu529       172.21.39.9         Up     25        L1L2 IS-IS
--------------
Area A3253-01:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
0000.0000.0053 Et1         0060.3e58.ccdb      Up     22        L1   IS-IS
0000.0000.0003 Et1         0000.0c03.6944      Up     20        L1   IS-IS
--------------
Area A3253-02:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
0000.0000.0002 Et2         0000.0c03.6bc5      Up     27        L1   IS-IS
0000.0000.0053 Et2         0060.3e58.ccde      Up     24        L1   IS-IS

Enabling Partitioning Avoidance

In ISO CLNS networks using a redundant topology, it is possible for an area to become "partitioned" when full connectivity is lost between a Level 1-2 border router, all adjacent Level 1 routers, and end hosts. In such a case, multiple Level 1-2 border routers advertise the Level 1 area prefix into the backbone area, even though any one router can reach only a subset of the end hosts in the Level 1 area.

When enabled, the partition avoidance command prevents this partitioning by causing the border router to stop advertising the Level 1 area prefix into the Level 2 backbone.

Other cases of connectivity loss within the Level 1 area itself are not detected or corrected by the border router, and this command has no effect.

To enable partitioning avoidance, use the following router configuration command:

 
Command
Purpose

Router(config)# partition avoidance

Causes an IS-IS Level 1-2 border router to stop advertising the Level 1 area prefix into the Level 2 backbone when full connectivity is lost between the border router, all adjacent Level 1 routers, and end hosts.


Changing the Routing Level for an Area

You can change the routing level configured for an area using the is-type command. If the router instance has been configured for Level 1-2 area (the default for the first instance of the IS-IS routing process in a Cisco unit), you can remove Level 2 (interarea) routing for the area using the is-type command and change the routing level to Level 1 (intra-area). You can also configure Level 2 routing for an area using the is-type command, but the instance of the IS-IS router configured for Level 2 on the Cisco unit must be the only instance configured for Level 2.

To change the routing level for an IS-IS routing process in a given area, use the following router configuration command:

 
Command
Purpose
 
Router (config)# is-type {level-1 | 
level-1-2 | level-2-only}

Configures the routing level for an instance of the IS-IS routing process.


Limiting LSP Flooding

Limiting LSP flooding is important to IS-IS networks in general, and is not limited to configuring multiarea IS-IS networks. In a network with a high degree of redundancy, such as a fully meshed set of point-to-point links over a non-broadcast multiAccess (NBMA) transport, flooding of LSPs can limit network scalability. You can reduce LSP flooding in two ways:

Blocking Flooding on Specific Interfaces

The advantage of full blocking over mesh groups is that it is easier to configure and understand, and fewer LSPs are flooded. Blocking flooding on all links permits the best scaling performance, but results in a less robust network structure. Permitting flooding on all links results in poor scaling performance.

Configuring Mesh Groups

The advantage of mesh groups over full blocking is that mesh groups allow LSPs to be flooded over one hop to all routers on the mesh, while full blocking allows some routers to receive LSPs over multiple hops. This relatively small delay in flooding can have an impact on convergence times, but the delay is negligible compared to overall convergence times.

Blocking Flooding on Specific Interfaces

You can completely block flooding (full blocking) on specific interfaces, so that new LSPs will not be flooded out over those interfaces. However, if flooding is blocked on a large number of links, and all remaining links go down, routers cannot synchronize their link-state databases even though there is connectivity to the rest of the network. When the link-state database is no longer updated, routing loops usually result.

To use Complete Sequence Number PDUs (CSNPs) on selected point-to-point links to synchronize the link-state database, configure a CSNP interval using the isis csnp-interval command on selected point-to-point links over which normal flooding is blocked. You should use CSNPs for this purpose only as a last resort.

Configuring Mesh Groups

Configuring mesh groups (a set of interfaces on a router) can help to limit redundant flooding. All routers reachable over the interfaces in a particular mesh group are assumed to be densely connected (each router has many links to other routers), where many links can fail without isolating one or more routers from the network.

Normally, when a new LSP is received on an interface, it is flooded out over all other interfaces on the router. When the new LSP is received over an interface that is part of a mesh group, the new LSP will not be flooded out over the other interfaces that are part of that same mesh group.

Mesh groups rely on a full mesh of links between a group of routers. If one or more links in the full mesh goes down, the full mesh is broken, and some routers might miss new LSPs, even though there is connectivity to the rest of the network. When you configure mesh groups to optimize or limit LSP flooding, be sure to select alternative paths over which to flood in case interfaces in the mesh group go down.

To minimize the possibility of incomplete flooding, you should allow unrestricted flooding over at least a minimal set of links in the mesh. Selecting the smallest set of logical links that covers all physical paths results in very low flooding, but less robustness. Ideally you should select only enough links to ensure that LSP flooding is not detrimental to scaling performance, but enough links to ensure that under most failure scenarios no router will be logically disconnected from the rest of the network.

Configuring Other IS-IS Parameters

You can now configure other IS-IS parameters for each area. The procedures and commands are described in the "Configuring Integrated IS-IS" chapter of the Cisco IOS Release 12.0 Network Protocols Configuration Guide, Part 1, or the "Configuring ISO CLNS" chapter of the Cisco IOS Release 12.0 Network Protocols Configuration Guide, Part 3.

Verifying Multiarea IS-IS Configuration

Output for all of the show commands used to verify IS-IS configuration is "per area" when multiarea IS-IS is configured.

The following example shows how to use the show commands to verify a dual CLNS-IP multiarea network.

1. Enter the show clns EXEC command to verify that all desired areas have been configured. Also check that NETs are well formed, and specify the correct area addresses for each configured area.

The following is sample output from the show clns command in a dual CLNS-IP network for Area 49:

dtp-5#show clns 
Global CLNS Information:
  3 Interfaces Enabled for CLNS
  NET: 49.2222.0000.0000.0005.00
  NET: 49.0553.0001.0000.0000.0005.00
  NET: 49.0553.0002.0000.0000.0005.00
  Configuration Timer: 60, Default Holding Timer: 300, Packet Lifetime 64
  ERPDU's requested on locally generated packets
  Intermediate system operation enabled (CLNS forwarding allowed)
  IS-IS level-1-2 Router: L2BB
    Routing for Area: 49.2222
  IS-IS level-1 Router: A3253-01
    Routing for Area: 49.0553.0001
  IS-IS level-1 Router: A3253-02
    Routing for Area: 49.0553.0002

2. Enter the show clns protocol EXEC command to verify that all interfaces are configured in the correct areas for the desired protocols.

The following is sample output from the show clns protocol command:

dtp-5# show clns protocol

IS-IS Router: L2BB
  System Id: 0000.0000.0005.00  IS-Type: level-1-2
  Manual area address(es): 
        49.2222
  Routing for area address(es): 
        49.2222
  Interfaces supported by IS-IS:
        Tunnel529 - OSI - IP
  Redistribute:
    static (on by default)
  Distance for L2 CLNS routes: 110
          
IS-IS Router: A3253-01
  System Id: 0000.0000.0005.00  IS-Type: level-1
  Manual area address(es): 
        49.0553.0001
  Routing for area address(es): 
        49.0553.0001
  Interfaces supported by IS-IS:
        Ethernet1 - OSI - IP
  Redistribute:
    static (on by default)
  Distance for L2 CLNS routes: 110
          
IS-IS Router: A3253-02
  System Id: 0000.0000.0005.00  IS-Type: level-1
  Manual area address(es): 
        49.0553.0002
  Routing for area address(es): 
        49.0553.0002
  Interfaces supported by IS-IS:
        Ethernet2 - OSI - IP
  Redistribute:
    static (on by default)
  Distance for L2 CLNS routes: 110

3. Enter the show clns neighbors command (for a CLNS connection) to verify that all expected adjacencies are up with all neighbors. If not, recheck the area addresses specified in both routers. If the router is running in dual CLNS-IP mode in an area, verify that a valid IP address is configured on each interface in the area. Consider using debug isis adjacency to gather additional information.

The following is sample output from the show clns neighbors command in a dual CLNS-IP network:

dtp-5# show clns neighbors
 
Area L2BB:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
0000.0000.0009 Tu529       172.21.39.9         Up     27        L1L2 IS-IS
 
Area A3253-01:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
0000.0000.0053 Et1         0060.3e58.ccdb      Up     24        L1   IS-IS
0000.0000.0003 Et1         0000.0c03.6944      Up     27        L1   IS-IS
 
Area A3253-02:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
0000.0000.0053 Et2         0060.3e58.ccde      Up     25        L1   IS-IS
0000.0000.0002 Et2         0000.0c03.6bc5      Up     27        L1   IS-IS

4. Enter the show isis topology EXEC command to verify the presence and connectivity between all routers in all areas.

The following is sample output from the show isis topology command in a dual CLNS-IP network:

dtp-5# show isis topology
 
Area L2BB:
IS-IS paths to level-1 routers
System Id       Metric  Next-Hop        Interface       SNPA
0000.0000.0005  --
0000.0000.0009  10      0000.0000.0009  Tu529           *Tunnel*        
0000.0000.0017  20      0000.0000.0009  Tu529           *Tunnel*        
0000.0000.0053  30      0000.0000.0009  Tu529           *Tunnel*        
0000.0000.0068  20      0000.0000.0009  Tu529           *Tunnel*        
 
IS-IS paths to level-2 routers
System Id       Metric  Next-Hop        Interface       SNPA
0000.0000.0005  --
0000.0000.0009  10      0000.0000.0009  Tu529           *Tunnel*        
0000.0000.0017  20      0000.0000.0009  Tu529           *Tunnel*        
0000.0000.0053  30      0000.0000.0009  Tu529           *Tunnel*        
0000.0000.0068  20      0000.0000.0009  Tu529           *Tunnel* 
Area A3253-01:
IS-IS paths to level-1 routers
System Id       Metric  Next-Hop        Interface       SNPA
0000.0000.0003  10      0000.0000.0003  Et1             0000.0c03.6944  
0000.0000.0005  --
0000.0000.0053  10      0000.0000.0053  Et1             0060.3e58.ccdb  
 
Area A3253-02:
IS-IS paths to level-1 routers
System Id       Metric  Next-Hop        Interface       SNPA
0000.0000.0002  10      0000.0000.0002  Et2             0000.0c03.6bc5  
0000.0000.0005  --
0000.0000.0053  10      0000.0000.0053  Et2             0060.3e58.ccde 

5. (For CLNS applications only) Enter either the show clns route or the show ip route isis EXEC command to display all of the destinations to which this router knows how to route packets. The show clns route command shows the IS-IS Level 2 routing table in addition to static and ISO Interior Gateway Routing Protocol (IGRP) learned prefix routes. This table stores IS-IS area addresses and prefix routes. Destinations are sorted by category.

These commands, used with ping, verify connectivity to all desired end hosts in the network.

As the display shows, neighbors are not included in the show clns route output.

The following is sample output from the show clns route command:

dtp-5# show clns route
Codes: C - connected, S - static, d - DecnetIV
       I - ISO-IGRP,  i - IS-IS,  e - ES-IS
 
C  49.0553.0002.0000.0000.0005.00 [1/0], Local IS-IS NET
C  49.0553.0001.0000.0000.0005.00 [1/0], Local IS-IS NET
C  49.2222.0000.0000.0005.00 [1/0], Local IS-IS NET
C  49.0553.0002 [2/0], Local IS-IS Area
C  49.0553.0001 [2/0], Local IS-IS Area
C  49.2222 [2/0], Local IS-IS Area

The following is sample output from the show ip route isis command:

dtp-5# show ip route isis
     11.0.0.0/24 is subnetted, 1 subnets
i L1    11.0.0.0 [115/20] via 10.0.0.9, Tunnel529, L2BB, from LSP 3
i*L1 0.0.0.0/0 [115/10] via 10.0.0.9, Tunnel529, L2BB, from LSP 0
               [115/10] via 10.2.2.53, Ethernet2, A3253-02, from LSP 0
               [115/10] via 10.1.1.53, Ethernet1, A3253-01, from LSP 0

6. Use either the ping clns or the ping ip EXEC command to send packets to test whether a remote host can be reached over an ISO CLNS or an IP network. If there is a response from the remote system, the remote host can be reached. Note that the Cisco implementation of the ping command supports PDU types that have been proposed but not yet standardized. The remote host may not recognize these packets, but will typically generate an error packet (ERPDU) as a response. This ERPDU confirms that the remote host can be reached. If the remote host is reachable, multiarea IS-IS is probably configured correctly.

Monitoring and Maintaining Multiarea IS-IS

Command
Purpose

Router# show clns es-neighbors

Displays end system (ES) neighbor adjacencies.

Router# show clns is-neighbors

Displays internal system (IS) neighbor adjacencies.

Router# show clns neighbor areas

Displays ISIS neighbors and the areas to which they belong.

Router# show clns neighbors

Displays CLNS neighbor adjacencies.

Router# show clns protocol

Displays CLNS routing protocol process information.

Router# show clns route

Displays one or all of the destinations to which the router knows how to route CLNS packets.

Router# show clns traffic

Displays CLNS protocol activity statistics.

Router# show isis database

Displays IS-IS link-state database.

Router# show isis routes

Displays IS-IS Level 1 routing table.

Router# show isis spf-log

Displays IS-IS shortest path first (SPF) log.

Router# show isis topology

Displays IS-IS paths to intermediate systems.


Configuration Example

This section provides the following configuration example:

Multiarea IS-IS Configuration

Multiarea IS-IS Configuration

The following output shows an IS-IS configuration with two Level 1 areas and one Level 1-2 area. Figure 3 illustrates this configuration.

clns routing

...

interface Tunnel529
 ip address 10.0.0.5 255.255.255.0
 ip router isis BB
 clns router isis BB

interface Ethernet1
 ip address 10.1.1.5 255.255.255.0
 ip router isis A3253-01
 clns router isis A3253-01
!
interface Ethernet2
 ip address 10.2.2.5 255.255.255.0
 ip router isis A3253-02
 clns router isis A3253-02

...

router isis BB                          ! Defaults to "is-type level-1-2"
 net 49.2222.0000.0000.0005.00
!
router isis A3253-01
 net 49.0553.0001.0000.0000.0005.00
 is-type level-1
!
router isis A3253-02
 net 49.0553.0002.0000.0000.0005.00
 is-type level-1

Figure 3 Multiarea IS-IS Configuration with Three Level 1 Areas and One Level 2 Area

Command Reference

This section documents new or modified commands. All other commands used with this feature are documented in the Cisco IOS Release 12.0 command reference publications.

clns router isis

ip router isis

isis display delimiter

isis mesh-group

is-type

net

partition avoidance

router isis

show clns neighbor areas

show clns route

show isis topology

clns router isis

To configure an Intermediate System-to-Intermediate System (IS-IS) routing process for International Standards Organization (ISO) Connectionless Network Service Protocol (CLNS) on an interface and to attach an area designator to the routing process, use the clns router isis interface configuration command. Use the no form of the command to disable IS-IS for ISO.

clns router isis [area-tag]

no clns router isis [area-tag]

Syntax Description

area-tag

Optional for conventional IS-IS configuration. Required for multiarea IS-IS configuration.

Defines a meaningful name for an area routing process. If not specified, a null tag is assumed. It must be unique among all CLNS router processes for a given router. The area-tag argument is used later as a reference to this area routing process.

Each area in a multiarea configuration should have a nonnull area tag to facilitate identification of the area.


DefaultsDefault

No routing processes are specified.

Command Modes

Interface configuration

Command History

Release
Modification

10.0

This command was introduced.

12.0(5)T

Multiarea functionality was added, changing the way the tag argument (now area-tag) is used.


Usage Guidelines

Before the IS-IS router process is useful, a network entity title (NET) must be assigned with the net command and some interfaces must be enabled with IS-IS.

If you have IS-IS running and at least one ISO-IGRP process, the IS-IS process and the ISO-IGRP process cannot both be configured without an area tag. The null tag can be used by only one process. If you run ISO-IGRP and IS-IS, a null tag can be used for IS-IS, but not for ISO-Interior Gateway Routing Protocol (IGRP) at the same time. However, each area in an IS-IS multiarea configuration should have a nonnull area tag to facilitate identification of the area.

You can configure only one process to perform Level 2 (interarea) routing. If Level 2 routing is configured on any process, all additional processes are automatically configured as Level 1. You can configure this process to perform intra-area (Level 1) routing at the same time. You can configure up to 29 additional processes as Level 1-only processes. Use the is-type command to remove Level 2 routing from a router instance. You can then use the is-type command to enable Level 2 routing on some other IS-IS router instance.

An interface cannot be part of more than one area, except in the case where the associated routing process is performing both Level 1 and Level 2 routing. On media (such as WAN media, for example) where subinterfaces are supported, different subinterfaces could be configured for different areas.

Examples

The following example enables IS-IS routing for ISO CLNS on Ethernet interface 0:

router isis cisco
 net 39.0001.0000.0c00.1111.00
interface ethernet 0
 clns router isis cisco

The following example shows an IS-IS configuration with two Level 1 areas and one Level 1-2 area:

clns routing

...

interface Tunnel529
 ip address 10.0.0.5 255.255.255.0
 ip router isis BB
 clns router isis BB

interface Ethernet1
 ip address 10.1.1.5 255.255.255.0
 ip router isis A3253-01
 clns router isis A3253-01
!
interface Ethernet2
 ip address 10.2.2.5 255.255.255.0
 ip router isis A3253-02
 clns router isis A3253-02

...

router isis BB                          ! Defaults to "is-type level-1-2"
 net 49.2222.0000.0000.0005.00
!
router isis A3253-01
 net 49.0553.0001.0000.0000.0005.00
 is-type level-1
!
router isis A3253-02
 net 49.0553.0002.0000.0000.0005.00
 is-type level-1

Related Commands

Command
Description

router isis

Enables the IS-IS routing protocol and specifies an IS-IS process. When multiarea IS-IS is configured, this command specifies the area to which the routing process belongs.


ip router isis

To configure an Intermediate System-to-Intermediate System (IS-IS) routing process for IP on an interface and to attach an area designator to the routing process, use the ip router isis interface configuration command. Use the no form of the command to disable IS-IS for IP.

ip router isis [area-tag]

no ip router isis [area-tag]

Syntax Description

area-tag

Optional for conventional IS-IS configuration. Required for multiarea IS-IS configuration for ISO CLNS.

Defines a meaningful name for an area routing process. If not specified, a null tag is assumed. It must be unique among all IP router processes for a given router. The area-tag argument is used later as a reference to this area routing process.

Each area in a multiarea configuration should have a nonnull area tag to facilitate identification of the area.


Defaults

No routing processes are specified.

Command Modes

Interface configuration

Command History

Release
Modification

10.0

This command introduced.

12.0(5)T

Multiarea functionality was added, changing the way the tag argument (now area-tag) is used.


Usage Guidelines

Before the IS-IS routing process is useful, a network entity title (NET) must be assigned with the net command and some interfaces must have IS-IS enabled.

If you have IS-IS running and at least one ISO-Interior Gateway Routing Protocol (IGRP) process, the IS-IS process and the ISO-IGRP process cannot both be configured without an area tag. The null tag can be used by only one process. If you run ISO-IGRP and IS-IS, a null tag can be used for IS-IS, but not for ISO-IGRP at the same time. However, each area in an IS-IS multiarea configuration should have a nonnull area tag to facilitate identification of the area.

You can configure only one process to perform Level 2 (interarea) routing. If Level 2 routing is configured on any process, all additional processes are automatically configured as Level 1. You can configure this process to perform intra-area (Level 1) routing at the same time. You can configure up to 29 additional processes as Level 1-only processes. Use the is-type command to remove Level 2 routing from a router instance. You can then use the is-type command to enable Level 2 routing on some other IS-IS router instance.

An interface cannot be part of more than one area, except in the case where the associated routing process is performing both Level 1 and Level 2 routing. On media (such as WAN media, for example) where subinterfaces are supported, different subinterfaces could be configured for different areas.

Examples

The following example specifies IS-IS as an IP routing protocol for a process named Finance, and specifies that the Finance process will be routed on interfaces Ethernet 0 and serial 0:

router isis Finance
 net 49.0001.aaaa.aaaa.aaaa.00
interface Ethernet 0
 ip router isis Finance
interface serial 0
 ip router isis Finance

The following example shows an IS-IS configuration with two Level 1 areas and one Level 1-2 area:

ip routing

...

interface Tunnel529
 ip address 10.0.0.5 255.255.255.0
 ip router isis BB


interface Ethernet1
 ip address 10.1.1.5 255.255.255.0
 ip router isis A3253-01
1
!
interface Ethernet2
 ip address 10.2.2.5 255.255.255.0
 ip router isis A3253-02


...

router isis BB                          ! Defaults to "is-type level-1-2"
 net 49.2222.0000.0000.0005.00
!
router isis A3253-01
 net 49.0553.0001.0000.0000.0005.00
 is-type level-1
!
router isis A3253-02
 net 49.0553.0002.0000.0000.0005.00
 is-type level-1

Related Commands

Command
Description

net

Configures a NET for the IS-IS routing process by specifying an area address and system ID for the process.

router isis

Enables the IS-IS routing protocol and specifies an IS-IS process. When multiarea IS-IS is configured, this command specifies the area to which the routing process belongs.


isis display delimiter

To make output from multiarea displays easier to read by specifying the delimiter to use to separate displays of information, use the isis display delimiter global configuration command. This command displays the output from different areas as a string or additional white space. Use the no form of the command to disable this output format.

isis display delimiter [return cnt | char cnt]

no isis display delimiter [return cnt | char cnt]

Syntax Description

return

(Optional) Delimit with carriage returns.

char

(Optional) Character to use for delimiter string.

cnt

(Optional) Number of carriage returns or length of string to use for delimiter.


Defaults

By default the isis display delimiter command is disabled.

Command Modes

Global configuration

Command History

Release
Modification

12.0(5)T

This command was introduced.


Usage Guidelines

Use this command to customize display output when the IS-IS multiarea feature is used.

Examples

The following command causes different areas in multiarea displays (such as show command output) to be delimited by a string of dashes (-):

isis display delimiter - 14

With three IS-IS neighbors configured, this command displays the following output from the show clns neighbors command:

dtp-5# show clns neighbors
--------------
Area L2BB:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
0000.0000.0009 Tu529       172.21.39.9         Up     25        L1L2 IS-IS
--------------
Area A3253-01:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
0000.0000.0053 Et1         0060.3e58.ccdb      Up     22        L1   IS-IS
0000.0000.0003 Et1         0000.0c03.6944      Up     20        L1   IS-IS
--------------
Area A3253-02:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
0000.0000.0002 Et2         0000.0c03.6bc5      Up     27        L1   IS-IS
0000.0000.0053 Et2         0060.3e58.ccde      Up     24        L1   IS-IS

Related Commands

Command
Description

show clns es-neighbors

Displays IS-IS information for ES neighbors that this router knows about.

show clns is-neighbors

Displays IS-IS information for IS neighbors that this router knows about.

show clns neighbors

Displays IS-IS information for both ES and IS neighbors that this router knows about.

show clns protocol

Displays a list of the protocol-specific information for each ISO IGRP routing process in the router.

show clns traffic

Displays a list of the CLNS packets this router has seen.

show isis database

Displays the IS-IS link-state database. A summary display is provided if no options are specified.

show isis mesh-groups

Optimizes LSP flooding in NBMA networks using highly meshed (having many links), point-to-point topologies.

show isis routes

Displays the IS-IS Level 1 forwarding table for IS-IS learned routes.

show isis spf-log

Displays a history of the SPF calculations for IS-IS.

show isis topology

Displays a list of all connected routers in all areas.


isis mesh-group

To optimize LSP flooding in nonbroadcast multiaccess (NBMA) networks with highly meshed, point-to-point topologies, use the isis mesh-group interface configuration command. To remove a (sub)interface from a mesh group, use the no form of this command.

isis mesh-group [num | blocked]

no isis mesh-group [num | blocked]

Syntax Description

standard-list-number

A standard extended community list number from 1 to 99 that identifies one or more permit or deny groups of extended community attributes.

expanded-list-number

An expanded extended community list number from 100 to 500 that identifies one or more permit or deny groups of extended community attributes.


Defaults

The interface performs normal flooding.

Command Modes

Interface configuration

Command History

Release
Modification

12.0

This command was introduced.

12.0(5)T

Command was modified to include multiarea IS-IS routing.


Usage Guidelinescr

LSPs that are first received on (sub)interfaces that are not part of a mesh group are flooded to all other (sub)interfaces in the usual way.

LSPs that are first received on (sub)interfaces that are part of a mesh group are flooded to all interfaces except those in the same mesh-group. If the "blocked" keyword is configured on a (sub)interface, then a newly received LSP is not flooded out over that interface.

To minimize the possibility of incomplete flooding, you should allow unrestricted flooding over at least a minimal set of links in the mesh. Selecting the smallest set of logical links that covers all physical paths results in very low flooding, but less robustness. Ideally you should select only enough links to ensure that LSP flooding is not detrimental to scaling performance, but enough links to ensure that under most failure scenarios no router will be logically disconnected from the rest of the network. In other words, blocking flooding on all links permits the best scaling performance, but there is no flooding. Permitting flooding on all links results in very poor scaling performance.

Examples

In the following example six interfaces are configured in three mesh groups. LSPs received are handled as follows:

LSPs received first via atm 1/0.1 are flooded to all interfaces except atm 1/0.2 (which is part of the same mesh group) and atm 1/2.1, which is blocked.

LSPs received first via atm 1/1.2 are flooded to all interfaces except atm 1/1.1 (which is part of the same mesh group) and atm 1/2.1, which is blocked.

LSPs received first via atm 1/2.1 are not ignored, but flooded as usual to all interfaces. LSPs received first via atm 1/2.2 are flooded to all interfaces, except atm 1/2.1, which is blocked.

interface atm 1/0.1
ip router isis
isis mesh-group 10

interface atm 1/0.2
ip router isis
isis mesh-group 10

interface atm 1/1.1
ip router isis
isis mesh-group 11

interface atm 1/1.2
ip router isis
isis mesh-group 11

interface atm 1/2.1
ip router isis
isis mesh-group blocked

interface atm 1/2.2
ip router isis

Related Commands

Command
Description

router isis

Enables the IS-IS routing protocol and specifies an IS-IS process. When multiarea IS-IS is configured, this command specifies the area to which the routing process belongs.


is-type

To configure the routing level for an instance of the Intermediate System-to-Intermediate System (IS-IS) routing process, use the is-type router configuration command. To reset the default value, use the no form of this command.

is-type {level-1 | level-1-2 | level-2-only}

no is-type {level-1 | level-1-2 | level-2-only}

Syntax Description

level-1

Router performs only Level 1 (intra-area) routing. This router only learns about destinations inside its area. Level 2 (interarea) routing is performed by the closest Level 1-2 router.

level-1-2

Router performs both Level 1 and Level 2 routing. This router runs two instances of the routing process. It has one link-state packet database (LSDB) for destinations inside the area (Level 1 routing) and runs an shortest path first (SPF) calculation to discover the area topology. It also has another link-state packet database (LSDB) with link-state packets (LSPs) of all other backbone (Level 2) routers, and runs another SPF calculation to discover the topology of the backbone, and the existence of all other areas.

level-2-only

Routing process acts as a Level 2 (interarea) router only. This router is part of the backbone, and does not communicate with Level 1-only routers in its own area.


Defaults

In conventional IS-IS configurations, the router acts as both a Level 1 (intra-area) and a Level 2 (interarea) router.

In multiarea IS-IS configurations, the first instance of the IS-IS routing process configured is by default a Level 1-2 (intra-area and interarea) router. The remaining instances of the IS-IS process configured by default are Level 1 routers.

Command Modes

Router configuration

Command History

Release
Modification

10.3

This command was introduced.

12.0(5)T

Multiarea IS-IS routing was included.


Usage Guidelines

It is highly recommended that you configure the type of an IS-IS routing process. If you are configuring multiarea IS-IS, you must configure the type of the router, or allow it to be configured by default. By default, the first instance of the IS-IS routing process that you configure using the router isis command is a Level 1-2 router.

If there is only one area in the network, there is no need to run both Level 1 and Level 2 routing algorithms. If IS-IS is used for Connectionless Network Service (CLNS) routing (and there is only one area), Level 1-only must be used everywhere. If IS-IS is used for IP routing only (and there is only one area), you can run Level 2-only everywhere. Areas you add after the Level 1-2 area exists are by default Level 1 areas.

If the router instance has been configured for Level 1-2 (the default for the first instance of the IS-IS routing process in a Cisco unit), you can remove Level 2 (interarea) routing for the area using the is-type command. You can also use is-type to configure Level 2 routing for an area, but it must be the only instance of the IS-IS routing process configured for Level 2 on the Cisco unit.

Examples

The following example specifies an area router:

router isis 
 is-type level-2-only

Related Commands

Command
Description

router isis

Enables the IS-IS routing protocol and specifies an IS-IS process. When multiarea IS-IS is configured, this command specifies the area to which the routing process belongs.

show clns neighbor areas

Displays information about IS-IS neighbors and the areas to which they belong.


net

To configure an Intermediate System-to-Intermediate System (IS-IS) network entity title (NET) for the routing process, use the net router configuration command. To remove a NET, use the no form of this command.

net network-entity-title

no net network-entity-title

Syntax Description

network-entity-title

NET that specifies the area address and the system ID for an IS-IS routing process. This argument can be either an address or a name.


Defaults

No NET is configured and the IS-IS process will not start. A NET is mandatory.

Command Modes

Router configuration

Command History

Release
Modification

10.0

This command was introduced.

12.0(5)T

Command was modified to include multiarea IS-IS routing.


Usage Guidelines

Under most circumstances, one and only one NET must be configured.

A NET is an Network Service Access Point (NSAP) where the last byte is always zero. On a Cisco router running IS-IS, a NET can be 8 to 20 bytes. The last byte is always the n-selector and must be zero.

The six bytes directly in front of the n-selector are the system ID. The system ID length is a fixed size and cannot be changed. The system ID must be unique throughout each area (Level 1) and throughout the backbone (Level 2).

All bytes in front of the system ID are the area ID.

Even when IS-IS is used to perform IP routing only (no Connectionless Network Service (CLNS) routing enabled), a NET must still be configured to define the router system ID and area ID.

Multiple NETs per router are allowed, with a maximum of three. In rare circumstances, it is possible to configure two or three NETs. In such a case, the area this router is in will have three area addresses. There will still be only one area, but it will have more area addresses.

Configuring multiple NETs can be temporarily useful in the case of network reconfiguration where multiple areas are merged, or where one area is split into more areas. Multiple area addresses enable you to renumber an area individually as needed.

If you are configuring multiarea IS-IS, the area ID must be unique, but the system ID portion of the NET must be the same for all IS-IS routing process instances.

Examples

The following example configures a router with system ID 0000.0c11.1110 and area ID 47.0004.004d.0001:

router isis Pieinthesky
 net 47.0004.004d.0001.0001.0c11.1111.00

The following example shows three IS-IS routing processes with three areas configured. Each area has a unique identifier, but the system ID is the same for all areas.

clns routing

...

interface Tunnel529
 ip address 10.0.0.5 255.255.255.0
 ip router isis BB
 clns router isis BB

interface Ethernet1
 ip address 10.1.1.5 255.255.255.0
 ip router isis A3253-01
 clns router isis A3253-01
!
interface Ethernet2
 ip address 10.2.2.5 255.255.255.0
 ip router isis A3253-02
 clns router isis A3253-02

...

router isis BB                          ! Defaults to "is-type level-1-2"
 net 49.2222.0000.0000.0005.00
!
router isis A3253-01
 net 49.0553.0001.0000.0000.0005.00
 is-type level-1
!
router isis A3253-02
 net 49.0553.0002.0000.0000.0005.00
 is-type level-1

Related Commands

Command
Description

is-type

Configures the routing level for an instance of the IS-IS routing process.

router isis

Enables the IS-IS routing protocol and specifies an IS-IS process. When multiarea IS-IS is configured, this command specifies the area to which the routing process belongs.


partition avoidance

To causes an Intermediate System-to-Intermediate System (IS-IS) Level 1-2 border router to stop advertising the Level 1 area prefix into the Level 2 backbone when full connectivity is lost between the border router, all adjacent Level 1 routers, and end hosts, use the partition avoidance router configuration command. This command displays the output from different areas as a string or additional white space. Use the no form of the command to disable this output format.

partition avoidance [area-tag]

no partition avoidance [area-tag]

Syntax Description

area-tag

Optional for conventional IS-IS configuration. Required for multiarea IS-IS configuration.

Meaningful name for a routing process. If it is not specified, a null tag is assumed and the process is referenced with a null tag. This name must be unique among all IP or Connectionless Network Service Protocol (CLNS) router processes for a given router.


Defaults

By default the partition avoidance command is disabled.

Command Modes

Router configuration

Command History

Release
Modification

12.0(5)T

This command was introduced.


Usage Guidelines

When the partition avoidance command is enabled, a multiarea router withdraws a Level 1 area prefix from the Level 2 backbone when it no longer has any active adjacencies to that Level 1 area. This withdrawal prevents the Level 1 area from appearing to be partitioned within the Level 2 backbone.

In International Standards Organization (ISO) CLNS networks using a redundant topology, it is possible for an area to become "partitioned" when full connectivity is lost between a Level 1-2 border router, all adjacent Level 1 routers, and end hosts. In such a case, multiple Level 1-2 border routers advertise the Level 1 area prefix into the backbone area, even though any one router can reach only a subset of the end hosts in the Level 1 area.

When enabled, the partition avoidance command prevents this partitioning by causing the border router to stop advertising the Level 1 area prefix into the Level 2 backbone.

Other cases of connectivity loss within the Level 1 area itself are not detected nor corrected by the border router, and this command will have no effect.

Examples

The following example causes the routing process Finance to stop advertising the prefix for the area named "area1" with the router no longer has any active adjacencies to area1.

router isis Finance
 partition avoidance area1

Related Commands

Command
Description

is-type

Configures the routing level for an instance of the IS-IS routing process.

router isis

Enables the IS-IS routing protocol and specifies an IS-IS process. When multiarea IS-IS is configured, this command specifies the area to which the routing process belongs.


router isis

To enable the Intermediate System-to-Intermediate System (IS-IS) routing protocol and to specify an IS-IS process, use the router isis global configuration command. This command identifies an area the router will work in and lets the router know that it will be routing dynamically rather than statically. Use the no form of the command with the appropriate tag to disable IS-IS routing for the area.

router isis [area-tag]

no router isis [area-tag]

Syntax Description

area-tag

Optional for conventional IS-IS configuration. Required for multiarea IS-IS configuration.

Meaningful name for a routing process. If it is not specified, a null tag is assumed and the process is referenced with a null tag. This name must be unique among all IP or Connectionless Network Service Protocol (CLNS) router processes for a given router.


Defaults

By default the router isis command is disabled.

Command Modes

Global configuration

Command History

Release
Modification

10.0

This command was introduced.

12.0(5)T

Multiarea functionality was added, changing the way the tag argument is used.


Usage Guidelines

This command is used to enable routing for an area. An appropriate network entity title (NET) must be configured to specify the area address of the area and system ID of the router. Routing must be enabled on one or more interfaces before adjacencies may be established and dynamic routing is possible.

If you have IS-IS running and at least one International Standards Organization Interior Gateway Routing Protocol (ISO-IGRP) process, the IS-IS process and the ISO-IGRP process cannot both be configured without an area tag. The null tag can be used by only one process. If you run ISO-IGRP and IS-IS, a null tag can be used for IS-IS, but not for ISO-IGRP at the same time. However, each area in an IS-IS multiarea configuration should have a nonnull area tag to facilitate identification of the area.

You can configure only one IS-IS routing process to perform Level 2 (interarea) routing. You can configure this process to perform Level 1 (intra-area) routing at the same time. You can configure up to 29 additional processes as Level 1-only processes. If Level 2 routing is configured on any process, all additional processes are automatically configured as Level 1.

An interface cannot be part of more than one area, except in the case where the associated routing process is performing both Level 1 and Level 2 routing. On media (such as WAN media, for example) where subinterfaces are supported, different subinterfaces could be configured for different areas.

If Level 2 routing is not desired for a given area, use the is-type command to remove Level 2. Level 2 routing can then be enabled on some other router instance.

Explicit redistribution between IS-IS instances is prohibited (prevented by the parser). In other words, you cannot issue a redistribute isis tag command in the context of another IS-IS router instance (router isis area-tag). Redistribution from any other routing protocol into a particular area is possible, and is configured per router instance, as in Release 12.0 of the Cisco IOS software, using the redistribute and route map commands. By default, redistribution is into Level 2.

If multiple Level 1 areas are defined, the Target Address Resolution Protocol (TARP) behaves in the following way:

The locally assigned target identifier gets the Network Service Access Point (NSAP) of the Level 2 area, if present.

If only Level 1 areas are configured, the router uses the NSAP of the first active Level 1 area as shown in the configuration at the time of TARP configuration ("tarp run"). (Level 1 areas are sorted alphanumerically by tag name, with capital letters coming before lowercase letters. For example, AREA-1 precedes AREA-2, which precedes area-1.) Note that the target identifier NSAP could change following a reload if a new Level 1 area is added to the configuration after TARP is running.

The router continues to process all Type 1 and 2 protocol data units (PDUs) that are for this router. Type 1 PDUs are processed locally if the specified target identifier is in the local target identifier cache. If not, they are "propagated" (routed) to all interfaces in the same Level 1 area. (The same area is defined as the area configured on the input interface.)

Type 2 PDUs are processed locally if the specified target identifier is in the local target identifier cache. If not, they are propagated via all interfaces (all Level 1 or Level 2 areas) with TARP enabled. If the source of the PDU is from a different area, the information is also added to the local target identifier cache. Type 2 PDUs are propagated via all static adjacencies.

Type 4 PDUs (for changes originated locally) are propagated to all Level 1 and Level 2 areas (because internally they are treated as "Level 1-2").

Type 3 and 5 PDUs continue to be routed.

Type 1 PDUs are only "propagated" (routed) via Level 1 static adjacencies if the static NSAP is in one of the Level 1 areas in this router.

Examples

The following example starts IS-IS routing with the optional tag argument, where Pieinthesky is the value for the tag argument:

router isis Pieinthesky

The following example specifies IS-IS as an IP routing protocol for a process named Finance, and specifies that the Finance process will be routed on interfaces Ethernet 0 and serial 0:

router isis Finance
 net 49.0001.aaaa.aaaa.aaaa.00
interface Ethernet 0
 ip router isis Finance
interface serial 0
 ip router isis Finance

Related Commands

Command
Description

net

Configures a NET for the IS-IS routing process by specifying an area address and system ID for the process.

clns router isis

Enables the IS-IS routing protocol for ISO CLNS on the specified interface. When configuring multiarea IS-IS, this command specifies the area to which the routing process belongs.

ip router isis

Enables the IS-IS routing process for IP on an interface. When configuring multiarea IS-IS, this command specifies the area to which the routing process belongs.


Show Commands

In Cisco IOS Release 12.0(1)T or later, you can search and filter the output for show and more commands. This functionality is useful when you need to sort through large amounts of output, or if you want to exclude output that you do not need to see.

To use this functionality, enter a show or more command followed by the "pipe" character (|), one of the keywords begin, include, or exclude, and an expression that you want to search or filter on:

command | {begin | include | exclude} regular-expression

Following is an example of the show atm vc command in which you want the command output to begin with the first line where the expression "PeakRate" appears:

show atm vc | begin PeakRate

For more information on the search and filter functionality, refer to the Cisco IOS Release 12.0(1)T feature module titled CLI String Search.

The syntax for the following list of show commands listed has been changed to include an area tag. For example, the old syntax for the command to show all neighbors was as follows:

show clns neighbors

The new syntax is as follows:

show clns area-tag neighbors

If the area-tag argument is null, the output shows all neighbors. If the area tag is specified, however, output is limited to the specified area. For example, the following output shows area A3253-02 neighbors:

dtp-5# show clns A3253-02 neighbors
 
Area A3253-02:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
0000.0000.0053 Et2         0060.3e58.ccde      Up     21        L1   IS-IS
0000.0000.0002 Et2         0000.0c03.6bc5      Up     28        L1   IS-IS

The following show commands (and their output) have been similarly changed to include the area-tag argument:

Command
Purpose
New Syntax

show clns es-neighbors

Displays ES neighbor adjacencies.

show clns area-tag es-neighbors

show clns is-neighbors

Displays IS neighbor adjacencies.

show clns area-tag is-neighbors

show clns neighbors

Displays CLNS neighbor adjacencies.

show clns area neighbors

show clns protocol

Displays CLNS routing protocol process information.

show clns area-tag protocol

show clns traffic

Displays CLNS protocol statistics.

show clns area-tag traffic

show isis database

Displays IS-IS link-state database.

show isis area-tag 
database

show isis routes

Displays IS-IS Level 1 routing table.

show isis area-tag routes

show isis spf-log

Displays IS-IS SPF log.

show isis area-tag spf-log


show clns neighbor areas

To display information about Intermediate System-to-Intermediate System (IS-IS) neighbors and the areas to which they belong, use the show clns neighbor areas EXEC command.

show clns area-tag neighbor areas

Syntax Description

area-tag

Optional for conventional IS-IS configuration. Required for multiarea IS-IS configuration.

Meaningful name for a routing process. If it is not specified, a null tag is assumed and the process is referenced with a null tag. This name must be unique among all IP or Connectionless Network Service Protocol (CLNS) router processes for a given router.


Command Modes

EXEC

Command History

Release
Modification

12.0(5)T

This command was introduced.


Usage Guidelines

Use the show clns neighbor areas command to verify that all expected adjacencies are up with all neighbors. If they are not, recheck the area addresses specified in both routers. If the router is running in dual CLNS-IP mode in an area, verify that a valid IP address is configured on each interface in the area. Consider using the debug isis adjacency command to gather additional information.

Examples

The following example shows output when two Level 1 and one Level 2 IS-IS areas are configured.

dtp-5# show clns neighbor areas
 
System Id      Interface   Area Name           State  Holdtime  Type Protocol
0000.0000.0009 Tu529       L2BB                Up     26        L1L2 IS-IS
0000.0000.0053 Et1         A3253-01            Up     21        L1   IS-IS
0000.0000.0003 Et1         A3253-01            Up     28        L1   IS-IS
0000.0000.0002 Et2         A3253-02            Up     22        L1   IS-IS
0000.0000.0053 Et2         A3253-02            Up     23        L1   IS-IS

The following table describes the fields shown in the display.

Field
Descriptions

System Id

Identification value of the system.

Interface

Interface on which the router was discovered.

Area Name

Name of the area in which the system is configured.

State

Adjacency state. Up and Init are the states. See the show clns neighbors description.

  Init

System is waiting for an IS-IS hello message.

  Up

Believes the system is reachable.

Holdtime

Number of seconds before this adjacency entry times out.

Type

L1, L2, and L1L2 type adjacencies.

  ES

End-system adjacency either discovered via the ES-IS protocol or statically configured.

  IS

Router adjacency either discovered via the ES-IS protocol or statically configured.

  L1

Router adjacency for Level 1 routing only.

  L1L2

Router adjacency for Level 1 and Level 2 routing.

  L2

Router adjacency for Level 2 only.

Protocol

Protocol through which the adjacency was learned. Valid protocol sources are ES-IS, IS-IS, International Standards Organization Interior Gateway Routing Protocol (ISO IGRP), static, and DECnet.


Related Commands

Command
Description

debug isis adjacency

Displays information for adjacent IS-IS routers.

show clns es-neighbors

Displays IS-IS information for ES neighbors that this router knows about.

show clns is-neighbors

Displays IS-IS information for IS neighbors that this router knows about.

show clns neighbors

Displays IS-IS information for both ES and IS neighbors that this router knows about.


show clns route

To display one or all of the destinations to which this router knows how to route Connectionless Network Service (CLNS) packets, use the show clns route EXEC command.

show clns route nsap

Syntax Description

nsap

(Optional) CLNS Network Service Access Point (NSAP) address.


Command Modes

EXEC

Command History

Release
Modification

10.0

This command was introduced.

12.0(5)T

Fields for displaying information about prefix routes were added or changed.


Usage Guidelines

The show clns route command shows the Intermediate System-to-Intermediate System (IS-IS) Level 2 routing table and static and Intermediate System-to-Intermediate System Interior Gateway Routing Protocol (ISO-IGRP) learned prefix routes. This table stores IS-IS area addresses and prefix routes.

Examples

The following example shows output from the show clns route command when the nsap argument is not used:

rips# show clns route
ISO-IGRP Routing Table for Domain 49.0002, Area 0007
System Id       Next-Hop        SNPA                Interface   Metric   State
milles          milles          *HDLC*              Se1         8476     Up
0000.0000.0007  milles          *HDLC*              Se1         10476    Up
rips            0000.0000.0000  --                  --          0        Up

ISO-IGRP Routing Table for Domain 49.0002
Area Id         Next-Hop        SNPA                Interface   Metric   State
0002            0000.0000.0000  --                  --          0        Up

Codes: C - connected, S - static, d - DecnetIV
I - ISO-IGRP,  i - IS-IS,  e - ES-IS

C  49.0002 [2/0], Local ISO-IGRP Domain
C  49.0001.0000.0000.0005.00 [1/0], Local IS-IS NET
C  49.0002.0007.0000.0000.0005.00 [1/0], Local ISO-IGRP NET
C  49.0001 [2/0], Local IS-IS Area

i  33.3333.3333 [110/10]
via bakel, Ethernet0
S  50.1234 [10/0], Discard Entry
I  55.5555.5555 [100/8476]
via milles, Serial1
S  77.7777.7777.7777 [10/0]
via Serial0
d  88.8888.8888.0007 [120/0], DecnetIV Entry
i  33.4567.8901 [110/10]
via bakel, Ethernet0
rips#

The following table describes the fields shown in the display.

Field
Description

Domain 49.0002

The ISO-IGRP routing domain for which we are displaying the routes.

Area 0007

The ISO-IGRP area in which the displayed The Level 1 host routes are.

System Id

Identification value of the system listed in the Level 1 forwarding table.

Area Id

The identification value of the area listed in the area forwarding table.

Next-Hop

System ID of the best cost next-hop to listed address.

SNPA

MAC address of the next-hop system.

Interface

Interface through which next-hop system is known.

Metric

ISO-IGRP cost to reach the destination.

State

Up (active) or Down (nonoperational).


The following table describes how information about prefix routes is displayed:

Field
Description

C (connected)

The domain, area, or NET was learned via local configuration.

S (static)

The destination was learned via a locally configured static route.

d (DECnet IV)

The destination is a converted DECnet phase IV area address.

I (ISO-IGRP)

The destination is a prefix learned via Level 2 ISO-IGRP.

i (IS-IS)

The destination is a prefix learned via Level 2 IS-IS.

e (ES-IS)

The destination is learned via end system-intermediate system (ES-IS) redirects.

33.3333.3333

Destination prefix.

[110/10]

Administrative distance/metric.

via bakel

Next-hop system via which this destination is reachable. Shown as a 6-byte system ID, or as symbolic name (if available).

Ethernet0

Outgoing interface via which this destination is reachable.

Local IS-IS NET

Prefix is the full NET configured under an IS-IS process.

Local ISO-IGRP NET

Prefix is the full NET configured under an ISO-IGRP process.

Local ISO-IGRP Domain

Prefix is the domain part of a locally configured ISO-IGRP NET. This prefix is installed for redistribution purposes.

Local IS-IS Area

Prefix is the area address of a locally configured IS-IS NET. This prefix is installed for redistribution purposes.

Discard Entry

Prefix is learned via a locally configured static discard entry.

DecnetIV Entry

Prefix is a combination of the locally configured DECnet conversion prefix and a dynamically learned DECnet IV route. This prefix is installed for redistribution purposes.


The following is an example of output showing a single CLNS route using the show clns route command with the nsap argument:

rips# show clns route 33.3333.3333
Routing entry for 33.3333.3333
Known via "isis", distance 110, metric 10, Dynamic Entry
Routing Descriptor Blocks:
via bakel, Ethernet0
isis, route metric is 10, route version is 4

The following table describes the fields shown in the display:

Field
Description

Routing entry for 33.3333.3333

The prefix route being examined.

Known via "isis", distance 110, metric 10, Dynamic Entry

This route was learned from an IS-IS routing process with the tag "aap." The administrative distance is 110. The cost to reach the destination is 10.

Routing Descriptor Blocks

Each destination in the CLNS routing table can be reached by one or more paths. Each path is stored in a Routing Descriptor Block. The maximum number of paths in CLNS is 6.

via bakel, Ethernet0

Next-hop is neighbor "bakel." Outgoing interface is Ethernet0.

Redistributing via

Protocols other than originating protocol that advertise this prefix.

isis, route metric is 10, route version is 4

Originating protocol, cost for this path, route version in case this is an IS-IS route.


Related Commands

Command
Description

debug isis adjacency

Displays information for adjacent IS-IS routers.

show clns es-neighbors

Displays IS-IS information for ES neighbors that this router knows about.

show clns is-neighbors

Displays IS-IS information for IS neighbors that this router knows about.

show clns neighbor areas

Displays information about IS-IS neighbors within specific areas.

show clns neighbors

Displays IS-IS information for both ES and IS neighbors that this router knows about.

show isis topology

Displays a list of all connected routers in all areas.


show isis topology

To display a list of all connected routers in all areas, use the show isis topology EXEC command.

show isis area-tag topology

Syntax Description

area-tag

Optional for conventional IS-IS configuration. Required for multiarea IS-IS configuration.

Meaningful name for a routing process. This name must be unique among all IP or Connectionless Network Service (CLNS) router processes for a given router. If an area tag is not specified, a null tag is assumed and the process is referenced with a null tag. If an area tag is specified, output is limited to the specified area.


Command Modes

EXEC

Command History

Release
Modification

12.0(5)T

This command was introduced.


Usage Guidelines

Use the show isis topology EXEC command to verify the presence and connectivity between all routers in all areas.

Examples

The following example shows output from the show isis topology command in a dual Connectionless Network Service (CLNS)-IP network:

dtp-5# show isis topology
 
Area L2BB:
IS-IS paths to level-1 routers
System Id       Metric  Next-Hop        Interface       SNPA
0000.0000.0005  --
0000.0000.0009  10      0000.0000.0009  Tu529           *Tunnel*        
0000.0000.0017  20      0000.0000.0009  Tu529           *Tunnel*        
0000.0000.0053  30      0000.0000.0009  Tu529           *Tunnel*        
0000.0000.0068  20      0000.0000.0009  Tu529           *Tunnel*        
 
IS-IS paths to level-2 routers
System Id       Metric  Next-Hop        Interface       SNPA
0000.0000.0005  --
0000.0000.0009  10      0000.0000.0009  Tu529           *Tunnel*        
0000.0000.0017  20      0000.0000.0009  Tu529           *Tunnel*        
0000.0000.0053  30      0000.0000.0009  Tu529           *Tunnel*        
0000.0000.0068  20      0000.0000.0009  Tu529           *Tunnel* 
Area A3253-01:
IS-IS paths to level-1 routers
System Id       Metric  Next-Hop        Interface       SNPA
0000.0000.0003  10      0000.0000.0003  Et1             0000.0c03.6944  
0000.0000.0005  --
0000.0000.0053  10      0000.0000.0053  Et1             0060.3e58.ccdb  
 
Area A3253-02:
IS-IS paths to level-1 routers
System Id       Metric  Next-Hop        Interface       SNPA
0000.0000.0002  10      0000.0000.0002  Et2             0000.0c03.6bc5  
0000.0000.0005  --
0000.0000.0053  10      0000.0000.0053  Et2             0060.3e58.ccde 

Related Commands

Command
Description

debug isis adjacency

Displays information for adjacent IS-IS routers.

show clns es-neighbors

Displays IS-IS information for ES neighbors that this router knows about.

show clns is-neighbors

Displays IS-IS information for IS neighbors that this router knows about.

show clns neighbor areas

Displays information about IS-IS neighbors within specific areas.

show clns route

Displays one or all of the destinations to which this router knows how to route CLNS packets.

show clns neighbors

Displays IS-IS information for both ES and IS neighbors that this router knows about.


Glossary

area—Group of connected routers and end systems in a routing domain (or autonomous system). All routers in the domain share topology and adjacency data. If Level 1 (intra-area) routing is enabled in the domain, all routers know how to reach all system IDs. If Level 2 routing is enabled in the domain, all routers know how to reach all other areas.

conventional IS-IS—In this feature module, a router configured to perform intra-area (Level 1) IS-IS routing in a single area is considered to be conventionally configured. That router can also be configured to perform Level 2 (interarea) routing.

Intermediate System-to-Intermediate System Routing—See IS-IS.

IP—Internet Protocol.

IS-IS—Intermediate System-to-Intermediate System Protocol as defined by ISO 10589 and RFC 1195.

Level 1—Routers that establish Level 1 adjacencies in order to form a Level 1 area and perform intra-area routing.

Level 2—Routers that establish Level 2 adjacencies in order to form a Level 2 area and perform interarea routing.

link-state packet—See LSP.

link-state packet database—See LSDB.

LSDB—link-state packet database. Database of all link-state packets from all routers in an area.

LSP—link-state packet. Packet containing information about the link state on a router instance.

Open Systems Interconnect (model)—See OSI.

OSI—Open Systems Interconnect (model). Protocol stack with ISO CLNS at Layer 3.

routing domain—Group of areas that share topology and adjacency data.

shortest path first—See SPF.

SPF—shortest path first (Dijkstra's) algorithm.