CHAPTER 1

Introducing the Bulk Administration
Tool (BAT)

The Bulk Administration Tool (BAT), aweb-based application, performs bulk
transactions to the Cisco Unified CallManager database. BAT lets you add,
update, or delete a large number of similar phones, users, or ports at the same
time. When you use Cisco Unified CallManager Administration, each database
transaction requires an individual manual operation, while BAT automates the
process and achieves faster add, update, and delete operations.

You can use BAT to work with the following types of devices and records:

» Add, update, and delete Cisco Unified I P Phones including voice gateway
chalice (VGC) phones, computer telephony interface (CTI) ports, and H.323
clients

- Add, update, and delete users

» Add, update, and delete Cisco Unified CallManager Assistant managers and
assistants

« Add, update, and delete User Device Profiles

» Add, update, and delete ports on a Cisco Catalyst 6000 FXS Analog Interface
Module

« Add or delete Cisco VG200 analog gateways and ports
- Add or delete Forced Authorization Codes

- Add or delete Client Matter Codes

- Add or delete Call Pickup Groups
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You can also work with these devices in combination with the user information.
For example, when you add CTI ports and users, BAT allows you to “Enable CTI
Application Use.” This saves time when you are adding users who have
applications that require a CTI port, such as Cisco | P SoftPhone.

An optional component of BAT, the Tool for Auto-Registered Phones Support
(TAPS), further reduces the manual labor that isinvolved in administering alarge
system. When you need to add a large block of new phones, you can use BAT to
add the devices with dummy media access control (MAC) addresses instead of
entering each MAC address in the data input file. After the phones are installed,
the phone users or the administrator can call the TAPS directory number, follow
the voice prompts, and download the correct user device profilesfor their phones.
For more information about the TAPS tool, see Chapter 12, “Working with the
Tool for Auto-Registered Phones Support.”

Use the following topics to understand how to use BAT:
- BAT Datalnput Files, page 1-2
» BAT Configuration Process, page 1-3
» Using the BAT Application, page 1-14

BAT Data Input Files

Every device includes a multitude of individual attributes, settings, and
information fields that enable the device to function in the network and provide
its telephony features. Many devices have the same attributes and settings in
common, while other values, such as the directory number, are unique to a user or
to adevice. To condense the BAT datainput file contents, BAT uses templates for
settings that devices usually have in common.

For bulk configuration transactions on the Cisco Unified CallManager database,
the BAT process uses two components: a template for the device type and a data
file in comma separated value (CSV) format that contains the unique values for
configuring anew device or updating an existing record in the database. The CSV
data file works in conjunction with the device template.

For instance, when you create a bulk transaction for a group of Cisco Unified |P
Phones, you set up the CSV datafile that contains the unique information for each
phone, such as the directory number and MAC address. In addition, you set up or
choose the BAT template that contains the common settings for all phonesin the
transaction, such as a Cisco Unified | P Phone 7960 templ ate.
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Additional Information
See the “Related Topics” section on page 1-20.

BAT Configuration Process

BAT uses a multistep process to prepare the bulk configuration transaction. BAT
uses awizard interface to guide you through the configuration tasks. The BAT
process includes these tasks:

1. Set up the template for data input.

Define aformat for the CSV datafile.

Collect the data for each device in the bulk transaction.

Validate the data input files with the Cisco Unified CallManager database.
Insert the devices into the Cisco Unified CallManager database.

o~ w D

Using the BAT Wizard

The BAT wizard provides step-by-step procedures for all the BAT tasks. When
you start BAT, the main window displays with the following menu options at the
top:

- Configure
« Applications
« Help

From the Configure menu, you can access the wizard window by choosing one of
these device or configuration options:

- Phones

e Users

- Manager/Assistants

» User Device Profiles

- Gateways

- Forced Authorization Codes
« Client Matter Codes

» Pickup Group
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« TAPS (optional, when installed)

After you choose a device or configuration option, the wizard displays alist of
configuration tasks that is specific to that option. For example, when you choose
Phones, the following list of tasks displays:

e Insert Phones—Add new phones.
- Update Phones—L ocate and modify existing phones.
» Delete Phones—L ocate and delete phones.

- Export Phones—L ocate and export specific phone records or all phone
records.

« Update Lines—L ocate and modify lines on existing phones.

« Add Lines—Add new lines to existing phones.

» Reset/Restart Phones—L ocate and reset or restart phones.

» Insert Phones with Users—Add new phones and users.

» Generate Phone Reports—Generate customized reports for phones.

» CAPF Configuration—L ocate and modify/del ete existing CAPF
configuration

After choosing the configuration task, the wizard provides a list of stepsthat is
specific to the task. For example, to guide you through the task, Insert Phones, the
wizard displays the following steps:

Step 1: Add, view, or modify existing phone templates.
Step 2: Create the CSV datafile.

Step 3: Validate phone records.

Step 4: Insert phones.

When you choose a step from the task list, you open a configuration window such
as the Phone Template Configuration window. The configuration window
provides the entry fields for defining a template.

Additional Information
See the “Related Topics” section on page 1-20.
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Using BAT Templates

As thefirst task in the BAT configuration process, you set up a template for the
devicesthat you are configuring. You specify the type of phone or device that you
want to add or modify, and then you create a BAT template that has features that
are common to all the phones or devices in that bulk transaction.

You can create BAT templates for the following types of device options:

= Phones: All Cisco Unified | P Phone models and Cisco ATA 186, Cisco VGC
phones, CTI ports, and H.323 clients.

- Gateways: Cisco VG200 and ports for the Cisco Catalyst 6000 FXS Analog
Interface Module

« User Device Profiles: Cisco Unified | P Phone 7900 series and Cisco
SoftPhone

Define a BAT template by specifying values in the template fields that will be
commonto all thedevicesin the bulk transaction. The BAT templatefieldsrequire
similar values to those that you enter when you are adding a device in Cisco
Unified CallManager Administration.

Prior to creating the BAT template, make sure settings such as device pools,
locations, calling search spaces, button templates, and softkey templates have
already been configured in Cisco Unified CallManager Administration. You
cannot use BAT to create new settings or button templates in Cisco Unified
CallManager Administration.

After you create a BAT template, you save it with aname. Later in the
configuration process, you associate the template name with the CSV datafile.
The system stores the templates, so they are reusable for future bulk transactions.
For example, you can configure a Cisco Unified IP Phone 7960 template with a
specific button template and calling search space and then configure another
Cisco Unified 1P Phone 7960 template with a different button template and the
Extension Mobility feature enabled. When you need to add a large number of
phones with the same configuration, you can reuse the existing BAT template.

Master Phone Templates

When you are adding a group of phones that have multiple lines, you can create a
master phone template that provides multiple lines and the most common values
for a specific phone model. You can use the master template to add phones that
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have differing number of lines, but do not exceed the number of linesin the master
phone template. For example, you can create a master phone template for a Cisco
Unified IP Phone 7960 that has eight lines. You can use this template to add
phones that have one line, two lines, or up to eight lines.

Additional Information
See the “Related Topics” section on page 1-20.

Working with CSV Data Files

The CSV datafile containsthe unique settings and information for each individual
device, such asits directory number, MAC address, and description. Make sure
that all phones and devicesin aCSV datafile are the same phone or device model
and match the BAT template. The CSV data file can contain duplicates of some
valuesfrom the BAT template. Valuesin the CSV datafile override any valuesthat
were set in the BAT template. You can use the override feature for special
configuration cases.

Overriding Template Values Example

If you want most of the phones in the bulk transaction to be redirected to a
Voice-messaging system, you can set the Call Forward Busy (Internal/External)
(CFB) and Call Forward No Answer (Internal/External) (CFNA) fields to the
voice-messaging number. However, if afew phones in the bulk transaction need
to be redirected to a secretary instead of to a voice messaging system, you can
specify the secretary’s directory number in the Call CFB and CFNA fieldsin the
CSV datafile. Most of the phones will use the CFB and CFNA values from the
BAT phone template, but certain phoneswill use the secretary’s directory number
as specified in the CSV datafile.

The CSV datafile for phones can contain multiple directory numbers. Keep in
mind that the number of directory numbers that are entered in the CSV datafile
must not exceed—but can be less than— the number of lines that are configured
in the BAT phone template, or an error will result.

Use the following topics to understand the different types of CSV datafiles:
- CSV DataFilesfor Adding New Devices, page 1-7
« CSV DataFilesto Update Existing Devices, page 1-7
e Customizing File Formats for CSV Data Files, page 1-8
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CSV Data Files for Adding New Devices

When you are adding new devicesto the system, you can use the Microsoft Excel
spreadsheet that was designed to use with BAT. The BAT spreadsheet assists you
with the following features:

- Datafile templates with macros for the different devices
» Customized file format definition

- Support for multiple phone lines

- Record error checking

» File conversion to CSV format

When you are creating new records, use the BAT spreadsheet, which is named
BAT.xIt, because the data gets validated automatically when you export to the
CSV format. For more information about using the BAT spreadsheet, see “Using
the BAT Spreadsheet for Gathering Data” section on page 1-11.

For experienced BAT userswho are comfortable with workingina CSV formatted
file, you can use atext editor to create a CSV data file by following the sample
text file that is provided on the device insert task window. For more information
about text-based CSV datafiles, see Appendix A, “Text-Based CSV Files”

Additional Information
See the “Related Topics” section on page 1-20.

CSV Data Files to Update Existing Devices

To modify or update existing phones and devices, you need to locate the records
for these devices. BAT provides two methods for locating phones, gateways, and
device profiles. You can search by using a customized query or by using a custom
file.

Customized Queries

BAT provides a window for defining your query criteria. You can choose the
specific device model and/or choose criteriafrom alist of device detailsand alist
of line details. To locate all devices of a specific device model, such as Cisco
Unified IP Phone 7912, you choose the model but add no other criteria for the
search. You get the records for all the Cisco Unified |P Phones 7912 that are
configured in the database.
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Custom Files

When no common attribute to use for aquery exists, BAT providesthe custom file
option. A custom file includes device names or directory numbers. You can build
acustom text file by putting each record on a separate line. The search gives you
all the records that match the criteria.

Exported Files

When you need to move a group of phones, you can use the export utility. You use
the export utility to extract existing records from the Cisco Unified CallManager
database to move them into a CSV data file. When you move phones, use the
option, Export Phones with the All Phone Details. This option generates an export
filethat contains records with all the information, including the device attributes,
line attributes, and services, that is associated with that phone. You can also
export phone records with specific details when phones have similar line
configurations and you want to use a template. For more information about using
the export utility to update devices, see Moving Records from one Cisco Unified
CallManager Server to Another, page 10-2

Related Topics
- CSV DataFilesfor Adding New Devices, page 1-7

» Customizing File Formats for CSV Data Files, page 1-8

Customizing File Formats for CSV Data Files

CSV datafiles comprise a string of device attributes and information in acomma
separated value (CSV) format. To insert data records into the Cisco Unified
CallManager database, ensure that each data file isin the CSV format. In earlier
releases of BAT, the CSV file had afixed format with two options:

» Default format—CSV filesthat have afixed and limited number of attributes
and settings for each device.

» All detailsformat—CSV files that are created by using the export utility and
include all attributes and settings for each device.

Thefirst row of every CSV datafile shows the file format by displaying the name
of each field that the CSV file includes. The file format information makes it
easier to locate the entry for a specific field in the CSV datafile. For instance, in
the following sample CSV file, USER ID represents the fifth field in the header,
and the fifth field in the CSV file for the phone shows “johns.”
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Sample CSV Data File with the Default File Format:

NUMBER OF LINES,MAC ADDRESS,DESCRIPTION, LOCATION,USER ID,DIRECTORY
NUMBER, DISPLAY, LINE TEXT LABEL, FORWARD BUSY EXTERNAL, FORWARD NO ANSWER
EXTERNAL, FORWARD NO COVERAGE EXTERNAL, FORWARD BUSY INTERNAL, FORWARD NO
ANSWER INTERNAL, FORWARD NO COVERAGE INTERNAL,CALL PICKUP GROUP, SPEED
DIAL NUMBER, SPEED DIAL LABEL

1,1231123245AB,SEP1231123245AB,Dallas, johns, 9728437154,9728437154,Mike
,9728437172,9728437196,9728437127,9728437154,9728437178,9728437189,Mar
keting, 1230000000, Helpdesk

Now, you can customize the file format for the CSV data file by using the File
Format Configuration window. You can add attributes to your file format that are
also in the BAT template. This allows you to override the template entry with a
specific attribute for a device. For instance, you can choose the route partition
attribute for your file format and enter different partitions for each phone in the
CSV datafile.

From this window, you can choose specific attributes from Devicefieldsand Line
fields

The following device attributes always remain in each file format:
» Number of Lines
- MAC Address

» Description

Ensure that the Number of Linesisthe first item in every phone CSV datafile.

The File Format Configuration dialog box makes it easy to choose the device
attribute in the Device Field box and click an arrow to move the attribute into the
Selected Device Field box. You can select multiple attributes at the same time by
holding down the Ctrl key.

You can rearrange the order of the device attribute fields and line attribute fields
in the file format by using the Up and Down arrows. You can select an attribute
and then click the Up arrow to move the item closer to the first record or click the
down arrow to move the item further away from the first record. You cannot move
line attributes before device attributes or change the order of speed dials.
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e

Tip You can customize a CSV file format so it matches the arrangement of your
employee phone information that is stored in another database. This method
simplifies exporting data between a company database and the Cisco Unified
CallManager database.

Sample CSV Data File with the Customized File Format:
Device fields—MAC Address, Description, Device Pool, Calling Search Space

Line fields—Directory number, Partition, Line Text Label (moved to position
after directory number in file)

The File Format does not include speed-dial codes. Speed-dials can be chosen by
selecting the Include Speed Dials in the CSV Format check box.

NUMBER OF LINES,MAC ADDRESS,DESCRIPTION,DEVICE POOL,CSS,DIRECTORY
NUMBER, LINE TEXT LABEL, PARTITION,

l,22349OOAEF01,SEP22349OOAEF01,DP71,CSSiRestricted,
9725098827, Lobby Phone, Partl

Associating the File Format with the CSV Data File

When you are using a text editor to create a CSV datafile, you can create a
customized file format and then enter valuesin the same order as specified by that
fileformat. Beforeinserting the text-based CSV datafile that uses the customized
file format, you must associate the file format name with the CSV datafile. You
can associate only one file format with a CSV datafile.

Use the Add File Format window to choose the name of the CSV data file
<CSVfilename>.txt from the File Name drop-down list. Next, you choose your
file format from the File Format Name drop-down list. The datain the CSV data
file must match the custom file format that you have chosen.

Additional Information
See the “Related Topics” section on page 1-20.
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Using the BAT Spreadsheet for Gathering Data

Tip

The BAT spreadsheet simplifies the creation of CSV datafiles. You can add
multiple devices and view the records for each device in a spreadsheet format. It
allows you to customize the file format within the spreadsheet and provides
validation and error checking automatically to help reduce configuration errors.
The BAT spreadsheet includes tabs al ong the bottom of the spreadsheet for access
to the required data input fields for the various devices and user combinationsin
BAT.

The CSV data file works in combination with the BAT template. For example,
when you choose the Phone tab in the BAT spreadsheet, you can leave Location,
Forward Busy Destination, or Call Pickup Group blank. The values from the BAT
phone template get used for these fields; however, if you specify values for
Forward Busy Destination or Call Pickup Group, those values override the values
for these fields that were set in the BAT phone template.

When BAT isinstalled, the Microsoft Excel file for the BAT spreadsheet gets
placed on the publisher database server; however, you probably do not have
Microsoft Excel running on the publisher database server. You must copy thefile
from the publisher database server to the local machine on which you plan to
work.

To copy thefileto alocal machine, use afloppy disk or a mapped network drive,
and open the path C:\CiscoWebs\BAT\Excel Template\ on the publisher database
server. Copy the file BAT.xlt file to alocal machine where Microsoft Excel is
installed.

To use the BAT spreadsheet to create a CSV datafile, locate and double-click the
BAT.xIt file. You must choose to “enable macros’ when you open the BAT
spreadsheet.

The spreadsheet displays a set of columns with attribute headings that specify the
BAT field names, whether the field is a required or optional, and the maximum
number of characters that are allowed in the field.

Tabsfor every device display along the bottom of the spreadsheet. When you click
the tab for the type of device with which you want to work, the columns adjust to
display all relevant fields for the chosen device. For example, to add phones and
users all at once, click the tab that is marked Phones-Users.
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Note

Note

Next, define the file format for the CSV datafile by clicking the Create File
Format button. You can use the Field Selection dialog box to choose items and
their order in your CSV datafile. When you click Update, the columnsin the
spreadsheet adjust to your new file format.

In the first row, enter data for adevice in al mandatory fields and any relevant
optional fields. You enter datain a new row for each device.

The system treats blank rows in the spreadsheet as “end of file” markers and
discards subseguent records.

After all devicerecords are completed, you export the BAT spreadsheet datato the
CSV fileformat that BAT must use to perform the bulk transaction with the Cisco
Unified CallManager publisher database.

If you enter a commain one of the fields, BAT.xIt encloses that field entry in
double quotes when you export to BAT format.

The system saves the CSV formatted file as a text file to the C:\XL SDataFiles\
folder or to another folder that you choose. The file name format follows:

<tabname><timestamp>.txt

where <tabname> represents the type of device input file that you created (such
as phones, user device profiles), and <timestamp> represents the precise date and
time that the file was created.

Next, you must move the converted CSV data file (CSV format version) back to
the Cisco Unified CallManager publisher database server where BAT can access
the CSV datafile. Using a mapped network drive or floppy disk, copy the
<tabname><timestamp>.txt file from the C:\XL SDataFiles\ folder to the
appropriate folder under C:\BATFiles\ on the publisher server.

Additional Information
See the “Related Topics” section on page 1-20.
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Validating the BAT Data Input File

In the next task in the BAT Wizard, you use the Validate File option. In this task,
you choose the name of the CSV datafile and the BAT template for the device or
the model when you have a CSV datafile with all details. You have these options
for how records are validated:

Specific Details—For validating records that follow the Default or Custom file
format.

All Details—For validating records from afile that was generated with the export
utility by using the All Details option.

When you choose Validate, the system runs avalidation routine to check for errors
against the publisher database. These checks include the following items:

» Fields, such as description, display text, and speed-dial label that do not have
a dependency on a database table, use valid characters.

» Cisco Unified CallManager shows that groups, pools, partitions, and other
referenced attributes are already configured.

« Number of linesthat are configured on a device matches the device template.
(Only for Specific Details)

Validation does not check for the existence of a user or for mandatory/optional
fields that are BAT defined, such as the dummy MAC address.

After the transaction completes, choose View L atest L og Fileto seealog filethat
displays the devices that could not be validated successfully and the error code.
For more information on log files, see Chapter 13, “ Troubleshooting BAT and
TAPS.

Additional Information
See the “Related Topics” section on page 1-20.

Inserting the BAT Data Input File

When the data input file has passed validation, you are ready to use the Insert
window to add the device records into the Cisco Unified CallManager publisher
database. During this task, you choose the name of the datainput file, the BAT
template for the device, and the model, if applicable. You have these options for
how records are validated:
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Specific Details—For inserting records that use a customized file format.

All Details—For inserting records from afile that was generated with the export
utility by using the All Details option.

After you click I nsert, amessage displays that advises you of approximately how
long it will taketo insert the recordsinto the Cisco Unified CallManager database.
You can cancel the transaction if you feel that it may cause performance
degradation.

A

Caution  UseBAT only during off-peak hours. Otherwise, bulk transactions could affect the
Cisco Unified CallManager performance, and call processing may be adversely
affected.

If you clicked OK, a Transaction Status window displays. Click the Show L atest
Status button to see the transaction in progress.

~

Note If any line information for a phone record fails, BAT does not insert that
phone record.

When the transaction completes, Click View Latest L og Fileto seealog file that
indicates the number of records that were added and the number of records that

failed, including an error code. For more information on log files, see the “BAT

Log Files’ section on page 13-1.

When you start a BAT transaction and notice a degradation in Cisco Unified
CallManager performance, you can stop the transaction. For instructions on how
to use the tool to stop a BAT transaction when it isin progress, see the “ Stopping
BAT Transactions” section on page 1-19.

Additional Information
See the “Related Topics” section on page 1-20.

Using the BAT Application

The following topics provide information about the BAT application and how to
start and use it:
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Specifications

Using the BAT Application

Specifications, page 1-15

Accessing Cisco Unified CallManager Administration and BAT, page 1-16
Starting BAT, page 1-16

Logging On to BAT, page 1-17

Navigating in BAT, page 1-17

Using Online Help, page 1-18

Stopping BAT Transactions, page 1-19

BAT Configuration Process, page 1-3

BAT Data Input Files, page 1-2

The following specifications apply to BAT Release 5.2(3):

BAT Release 5.2(3) is compatible with Cisco Unified CallManager Release
4.2(3)

BAT supports Lightweight Directory Access Protocol (LDAP) including
Cisco Unified CallManager DC Directory (DCD), Microsoft Active
Directory (AD), and Netscape Directory Server.

BAT Release 5.2(3) is compatible with Customer Response Solutions (CRS)
Version 4.0 for use with TAPS.

BAT Release 5.2(3) implements Secure HyperText Transfer Protocol
(HTTPS) for BAT/TAPS pages to ensure that the configuration changes that
are made through them are secure. The BAT installation process sets the
security setting on BAT virtual directory.

You must install BAT on the same server as the publisher database for Cisco
Unified CallManager.

The BAT application, along with the Tool for Auto-Registered Phones
Support (TAPS) application, uses approximately 53 MB of disk space for the
applications and the online documentation. (BAT uses 11 MB and TAPS uses
42 MB.)

TAPS uses approximately 1 MB of disk space on the Cisco Customer
Response Solutions (CRS) server.
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Only Cisco Unified CallManager system administrators require access to BAT;
however, end users can use TAPS when instructed to do so by the system
administrator.

Additional Information
See the “Related Topics” section on page 1-20.

Accessing Cisco Unified CallManager Administration and BAT

A

BAT, aweb-based application, requires the use of aweb browser. The Cisco
Unified CallManager Administration and BAT programs support the following
Microsoft Windows operating system browsers:

» Netscape Communicator 4.X; BAT does not support the use of Netscape 6.0
or later.

» Microsoft Internet Explorer 5 or 6

Cisco recommends that you access the BAT and Cisco Unified CallManager
Administration programsfrom aPC that is not the same machine asthe web server
or Cisco Unified CallManager server.

Caution

Note

Starting BAT

A web browser, a resource-intensive application, can consume large amounts of
system memory and CPU cycles. When the web browser takes resources away
from Cisco Unified CallManager, it adversely affects call processing. Possible
consequences of using the browser on the same machine as the web server and
Cisco Unified CallManager include delayed dial tone and dropped calls.

From any user PC in your network, you can browse into a server that is running
Cisco Unified CallManager Administration and BAT to log on with administrative
privileges.

When alarge number of userslog on to BAT, performance can suffer. Try to limit
the number of users and administrators that are logged on simultaneously.

You can start BAT by using one of the following methods:
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» From Cisco Unified CallManager Administration, choose Application >
BAT.

« From the Start menu, choose Start > Programs > Cisco Unified
CallManager 4.2> Bulk Admin Tool > BAT 5.2.3.

« Double-click the BAT desktop icon.

You can also access BAT by browsing into Cisco Unified CallManager
Administration from a remote PC. Open Cisco Unified CallManager
Administration and choose Application > BAT.

Logging On to BAT
When you start BAT, a prompt asks for user 1D and password. Log on with a user
ID and password that have administrator rights on the machine.

The BAT application does not depend on the Multilevel Administration (MLA)
feature in Cisco Unified CallManager Administration

Navigating in BAT
After you log on to BAT, the main window displays with the following menu
options at the top:
- Configure
« Applications
« Help

The Configure menu gives you access to configuration tasks for the following
device types and the TAPS toal, if installed:

- Phones

e Users

- Manager/Assistants

» User Device Profiles

- Gateways

- Forced Authorization Codes
« Client Matter Codes
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e Pickup Group
« TAPS (optional)
The Applications menu gives you direct access to the following options:
« Install Plugins
» Update Plugin URL
» Cisco Unified CallManager Administration
» Cisco Unified CallManager Serviceability
The Help menu provides the following Help information:
- Contents and Index
» For this page
« About Bulk Administration Tool

Additional Information
See the “Related Topics” section on page 1-20.

Using Online Help

To access BAT online help, choose the Help menu. The Help menu provides two
help features:

- Contentsand Index—Opensthe BAT help file and allows you to browse for
information or search the index.

» For This Page—Opens the help directly for the window that you are
currently viewing. You can still browse the remainder of the help or use the
index.

Online help provides a multivolume system that allows you to access several
different help systems, all from the same window. You can also access a
comprehensive search engine and index.

Additional Information
See the “Related Topics” section on page 1-20.
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Using the BAT Application

Finding the BAT Version

Step 1

Step 2

To find the current version of BAT, choose Help > About Bulk Administration
Tool > Details.

To find the current version of BAT from Cisco Unified CallManager
Administration, choose Help > Component Versions.

If BAT isnot currently installed, you can find the version of BAT that is available
with Cisco Unified CallManager without installing it. To do this

Download the BAT application from the Cisco Unified CallManager Install
Plugins window.

Right-click the file Bulk AdministrationTool.exe, choose Properties, and then
choose Product Version.

Additional Information
See the “Related Topics” section on page 1-20.

Stopping BAT Transactions

BAT provides atool to stop BAT transactionsthat are in progress. This capability
can prove useful when you start a BAT transaction, then notice a degradation in
Cisco Unified CallManager performance, and want to stop the transaction. You
can always run the BAT transaction later when there is less impact to Cisco
Unified CallManager performance. You might want to stop BAT if you realize that
the wrong transaction has been started or if you need to make additional changes
before running the transaction.

You can access the Stop BAT function only from the publisher database server.

To stop BAT, choose Start > Programs > Cisco Unified CallManager 4.2 >
Bulk Admin Tool > Stop BAT.

The BAT transaction halts. View the log file for details about how many BAT
processed records passed or failed. Seethe“BAT Log Files” section on page 13-1
for information on log files.

[ oL-10645-01
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~

Note  Stop BAT does not stop export transactions that are in progress.

Additional Information
See the “Related Topics” section on page 1-20.

Related Topics

- BAT Datalnput Files, page 1-2
« BAT Configuration Process, page 1-3
» Using the BAT Application, page 1-14
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