Cellular Interface
The Cisco IR800 series Industrial routers use the Sierra Wireless MC73XX and MC74XX series modems supporting MIMO on LTE. WCDMA UMTS HSPA DC-HSPA+ is diversity only, without MIMO.
Installation of the SIM card(s) and antennas is covered in the respective Hardware Installation Guides under the Cisco 800 Series Industrial Integrated Services Routers page:
The software download page can be found here:
https://software.cisco.com/download/navigator.html?mdfid=286288566&flowid=76082
The Firmware Upgrade Guide for Cellular Modems can be found here:
http://www.cisco.com/c/en/us/td/docs/routers/access/interfaces/firmware/Firmware_Upgrade.html
Cisco 4G LTE Software Installation Guide
After installing the SIM card(s) and antennas, check the cellular hardware, radio, network and SIM (Unlock SIM card if necessary).
4G LTE Dual SIM
Dual Subscriber Identity Module (SIM) provides reliability and multihoming capabilities over LTE and HSPA-based networks. With two LTE modems, the IR829 enables concurrent connectivity to two cellular networks for high reliability, enhanced data throughputs, load balancing and differentiated services.
Note |
Dual SIM active/backup mode is supported only on single LTE models of the IR829. |
The following features are provided:
-
The two SIMs operate in active/backup mode on the single LTE models of the IR829, and active/active mode with each of the two SIMs assigned to a specific cellular radio on the dual LTE models. Both mobile provider networks must be supported by the given IR829 SKU, and it must be in an applicable region.
-
By default, SIM slot 0 is the primary, and SIM slot1 is the backup. Behavior may be changed using the lte sim primary command.
-
Profiles for each SIM are assigned by using the lte sim profile command. Each SIM has an associated Internet profile and an IMS profile in the CLI.
-
Dual-SIM behavior is managed under Cellular 0 CLI configuration.
-
The fail over occurs when there is no signal from the current carrier, and generally happens depending on the fail over timer value that is set. The default value is 5 minutes. The range is from 0-7 minutes..
-
Dual active LTE radios providing Multi-carrier support for active and backup use cases. Newer cellular modems have been added (MC74xx) with FDD/TDD LTE on LA and EA 829 models.
Note |
The 7455 modems do not support dual SIM capabilities. |
AutoSim and Firmware Based Switching
The advantages of the AutoSim feature are:
-
Ease of Ordering Carrier Specific SKUs
-
Quicker failover times in dual-sim deployments
-
Ease of switchover from other service providers to Telstra network
Auto-SIM is supported in Sierra wireless firmware Version 02.20.03. A new CLI is added in the cellular controller to enable/disable Auto-SIM. The modem in Auto-SIM mode selects the right carrier firmware after a SIM slot switch and an automatic modem reset. Auto-SIM is supported on the MC7455, MC7430, EM7430, and EM7455 modems. During bootup, if the Auto-SIM configuration on the modem doesn’t match to the IOS configuration, the corresponding Auto-SIM or manual mode is pushed to the modem.
After an Auto-SIM configuration change, the modem is automatically reset; the default is “auto-sim” enabled.
Enable Auto-SIM:
router(config)#controller cellular <slot>
router(config-controller)#lte firmware auto-sim #default is auto-sim enabled
Note |
After enabling auto-sim, wait for 5 minutes until the radio comes up. Once the radio is up, issue a modem power-cycle and wait for 3 minutes for the radio to come up again. Modem Power-Cycle is mandatory for auto-sim configuration to take effect. |
Disable Auto-SIM:
router(config)#controller cellular <slot>
router(config-controller)#no lte firmware auto-sim
Note |
After disabling auto-sim, wait for 5 minutes until the radio comes up. Once the radio is up, issue a modem power-cycle and wait for 3 minutes for the radio to come up again. Modem Power-Cycle is mandatory for auto-sim configuration to take effect. |
If Auto-SIM is disabled and the modem is in manual mode, select a carrier with a new exec CLI:
cellular lte firmware-activate <firmware-index>
The following CLI example shows the firmware-index of the carrier in the modem:
router#show cellular <slot> firmware
For additional information, see the following guide:https://www.cisco.com/c/en/us/td/docs/routers/access/interfaces/NIM/software/configuration/guide/4GLTENIM_SW.html
Dual Radio Configuration and Single Radio Configuration
The following examples are of an IR800 cellular configuration using dual modems. A single modem example will look much the same, without the Cellular1/0 and Cellular1/1 entries.
DUAL-Modem> enable
DUAL-Modem# show ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0 unassigned YES NVRAM administratively down down
GigabitEthernet1 unassigned YES unset down down
GigabitEthernet2 unassigned YES unset down down
GigabitEthernet3 unassigned YES unset down down
GigabitEthernet4 unassigned YES unset down down
Wlan-GigabitEthernet0 unassigned YES unset up up
Async0 unassigned YES unset up down
Async1 unassigned YES unset up down
GigabitEthernet5 unassigned YES NVRAM administratively down down
Cellular0/0 192.168.43.237 YES IPCP up up
Cellular1/0 10.61.25.231 YES IPCP up up
Second Modem
Cellular0/1 unassigned YES TFTP down down
Cellular1/1 unassigned YES TFTP down down
Second Modem
Vlan1 unassigned YES unset up up
wlan-ap0 unassigned YES NVRAM up up
DUAL-Modem# show running-config
Building configuration...
Current configuration : 4021 bytes
!
! Last configuration change at 18:31:06 UTC Mon Oct 24 2016
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname DUAL-Modem
!
boot-start-marker
boot system flash:/ir800-universalk9-mz.SPA.156-3.M0a
boot-end-marker
!
no aaa new-model
ethernet lmi ce
service-module wlan-ap 0 bootimage autonomous
!
ignition off-timer 900
!
ignition undervoltage threshold 9
!
no ignition enable
!
no ip domain lookup
ip inspect WAAS flush-timeout 10
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
license udi pid IR829-2LTE-EA-BK9 sn FGL2032219N
!
redundancy
notification-timer 120000
controller Cellular 0
lte sim data-profile 3 attach-profile 1
#When using Verizon, use data profile 3 and attach to profile 1
#When using AT&T, use data profile 1 and attach to profile 1
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
controller Cellular 1
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
interface GigabitEthernet0
no ip address
shutdown
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface Wlan-GigabitEthernet0
no ip address
!
interface GigabitEthernet5
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0/0
#Both interfaces need to be configured in the IOS software
ip address negotiated
ip virtual-reassembly in
encapsulation slip
load-interval 30
dialer in-band
dialer string lte
dialer-group 1
no peer default ip address
async mode interactive
routing dynamic
!
interface Cellular1/0
#Both interfaces need to be configured in the IOS software
ip address negotiated
ip virtual-reassembly in
encapsulation slip
load-interval 30
dialer in-band
dialer string lte
dialer-group 1
no peer default ip address
async mode interactive
routing dynamic
!
interface Cellular0/1
no ip address
encapsulation slip
!
interface Cellular1/1
no ip address
encapsulation slip
!
interface wlan-ap0
no ip address
!
interface Vlan1
no ip address
!
interface Async0
no ip address
encapsulation scada
!
interface Async1
no ip address
encapsulation scada
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Cellular1/0
ip route 8.8.8.8 255.255.255.255 Cellular0/0
Route values added
!
dialer-list 1 protocol ip permit
ipv6 ioam timestamp
!
access-list 1 permit any
!
control-plane
!
!
line con 0
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 4
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
l
ine 8
script dialer lte
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 9
script dialer lte
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 236800
txspeed 118000
line 15
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 236800
txspeed 118000
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
login
transport input none
!
no scheduler max-task-time
!!
End
Test the modem configuration with a ping command:
DUAL-Modem# ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 30/88/292 ms
DUAL-Modem#
The following two examples show a Verizon profile followed by an AT&T profile.
Verizon Profile
DUAL-Modem# show cellular 0/0 profile
Profile 1 = INACTIVE **
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzwims
Authentication = None
Profile 2 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzwadmin
Authentication = None
Profile 3 = ACTIVE*
Profile 3 is used for Verizon
--------
PDP Type = IPv4v6
PDP address = 166.140.43.237
Access Point Name (APN) = we01.VZWSTATIC
Authentication = None
Primary DNS address = 198.224.173.135
Secondary DNS address = 198.224.174.135
Profile 4 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzwapp
Authentication = None
Profile 5 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzw800
Authentication = None
Profile 6 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzwenterprise
Authentication = None
* - Default profile
** - LTE attach profile
AT&T Profile
DUAL-Modem# show cellular 1/0 profile
Profile 1 = ACTIVE* **
Profile 1 is used for AT&T
--------
PDP Type = IPv4
PDP address = 10.61.25.231
Access Point Name (APN) = m2m.com.attz
Authentication = None
Primary DNS address = 8.8.8.8
Secondary DNS address = 8.8.4.4
* - Default profile
** - LTE attach profile
DUAL-Modem# show cellular 0/0 hardware
Modem Firmware Version = SWI9X30C_02.20.03.00
Modem Firmware built = 2016/06/30 10:54:05
Hardware Version = 1.0
Device Model ID: MC7455MOBILE
International Mobile Subscriber Identity (IMSI) = 311480166946902
International Mobile Equipment Identity (IMEI) = 352009080050110
Integrated Circuit Card ID (ICCID) = 89148000001653263375
Mobile Subscriber Integrated Services
Digital Network-Number (MSISDN) = 6692200807
Modem Status = Online
Current Modem Temperature = 34 deg C
PRI SKU ID = 1103084, PRI version = 002.024, Carrier = Verizon
Carrier identified as Verizon
OEM PRI version = 000.001
Creating a Cellular Profile for Verizon.
DUAL-Modem# cellular 0/0 lte profile create 3 we01.VZWSTATIC
Warning: You are attempting to modify a currently ACTIVE data profile.
This is not recommended and may affect the connection state
PDP Type = IPv4v6
Access Point Name (APN) = we01.VZWSTATIC
Authentication = NONE
Profile 3 already exists with above parameters. Do you want to overwrite? [confirm] <return>
Profile 3 will be overwritten with the following values:
PDP type = IPv4
APN = we01.VZWSTATIC
Authentication = NONE
Are you sure? [confirm] <return>
Profile 3 written to modem
DUAL-Modem#
Enter configuration commands, one per line. End with CNTL/Z.
DUAL-Modem(config)# controller cellular 0
DUAL-Modem(config-controller)# lte sim data-profile 3 attach-profile 1
DUAL-Modem(config-controller)#
DUAL-Modem# conf t
Enter configuration commands, one per line. End with CNTL/Z.
DUAL-Modem(config)# controller cellular 0
DUAL-Modem(config-controller)# lte sim data-profile 3 attach-profile 1
DUAL-Modem(config-controller)# end
DUAL-Modem#
DUAL-Modem# show
*Oct 24 19:43:44.841: %SYS-5-CONFIG_I: Configured from console by consolecell
DUAL-Modem# show cellular 1/0 profile
Profile 1 = ACTIVE* **
--------
PDP Type = IPv4
PDP address = 10.61.185.213
Access Point Name (APN) = m2m.com.attz
Authentication = None
Primary DNS address = 8.8.8.8
Secondary DNS address = 8.8.4.4
* - Default profile
** - LTE attach profile
Creating a Cellular Profile for AT&T
DUAL-Modem# cellular 1/0 lte profil create 1 m2m.com.attz
Warning: You are attempting to modify a currently ACTIVE data profile.
This is not recommended and may affect the connection state
PDP Type = IPv4
Access Point Name (APN) = m2m.com.attz
Authentication = NONE
Profile 1 already exists with above parameters. Do you want to overwrite? [confirm] <return>
Profile 1 will be overwritten with the following values:
PDP type = IPv4
APN = m2m.com.attz
Authentication = NONE
Are you sure? [confirm] <return>
Profile 1 written to modem
DUAL-Modem#
DUAL-Modem# conf t
Enter configuration commands, one per line. End with CNTL/Z.
DUAL-Modem(config)# controller cellular 1
DUAL-Modem(config-controller)#
DUAL-Modem(config-controller)# lte sim data-profile 1 attach-profile 1
Note: Please issue a modem reset for the modified attach-profile to take effect.
DUAL-Modem(config-controller)# end
DUAL-Modem#
Controller Cellular 0 and NAT Configuration
Controller Cellular 0 is configured with default parameters. If a profile different from Profile 1 is set-up, it must be attached to controller cellular 0.
If the SIM in slot #1 must be used as primary, it is done under controller cellular 0
Procedure
Step 1 |
Show the controller cellular 0 Example:
|
Step 2 |
If the cellular interface obtains an IPv4 private address, NAT should be configured. Example:
|
Step 3 |
Once the Cellular configuration is done, ping a well-known IP address to test the connectivity. Example:
|
Step 4 |
Attached Cellular 0 profile must become “active” and “connection” shows IP address and traffic. Example:
|
What to do next
Use the show interface cellular 0 command to display the negotiated IP address if operational.
IR800#show interfaces cellular 0
Cellular0 is up, line protocol is up
Hardware is 4G WWAN Modem - Global (Europe & Australia) Multimode LTE/DC-HSPA+/HSPA+/HSPA/U
Internet address is 10.123.161.59/32
MTU 1500 bytes, BW 384 Kbit/sec, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation SLIP, loopback not set
Keepalive not supported
Last input 00:22:41, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/10 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
12 packets input, 1128 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
51 packets output, 3364 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up
IR800#
If the negotiated IP address in not operational:
IR800#show interfaces cellular 0
Cellular0 is up (spoofing), line protocol is up (spoofing)
Hardware is 4G WWAN Modem - Global (Europe & Australia) Multimode LTE/DC-HSPA+/HSPA+/HSPA/U
Internet address will be assigned dynamically by the network
Other Useful Commands
IR800# show cell 0 hardware
Modem Firmware Version = SWI9X15C_05.05.58.00
Modem Firmware built = 2015/03/04 21:30:23
Hardware Version = 1.0
Device Model ID: MC7304
Package Identifier ID: 1102029_9903299_MC7304_05.05.58.00_00_Cisco_005.010_000
International Mobile Subscriber Identity (IMSI) = 208150103324395
International Mobile Equipment Identity (IMEI) = 352761060206340
Integrated Circuit Card ID (ICCID) = 8933150112100222053
Mobile Subscriber Integrated Services
Digital Network-Number (MSISDN) = 33695764790
Current Modem Temperature = 47 deg C
PRI SKU ID = 9903299, PRI version = 05.10, Carrier = 1
IR800# show cell 0 security
Active SIM = 0 !
SIM slot #0 active
SIM switchover attempts = 0
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3
IR800# cellular 0 lte sim unlock XXXX
!
XXXX = PIN code
IR800# show cell 0 radio
Radio power mode = ON
Channel Number = 3037
Current Band = Unknown
Current RSSI(RSCP) = -99 dBm
Current ECIO = -10 dBm
Radio Access Technology(RAT) Preference = AUTO
Radio Access Technology(RAT) Selected = UMTS ( UMTS/WCDMA )
IR800# show cell 0 network
Current System Time = Sat Oct 10 9:12:59 2015
Current Service Status = Normal
Current Service = Packet switched
Current Roaming Status = Home
Network Selection Mode = Automatic
Network = LTE
Mobile Country Code (MCC) = 208
Mobile Network Code (MNC) = 15
Packet switch domain(PS) state = Attached
Location Area Code (LAC) = 3910
Cell ID = 222094374
IR800# show cell 0 all
Note |
The output to the show cell 0 all command is extensive, and omitted from this guide for brevity. |
Accessing 4G Modem AT Commands
Note |
A password must be added to the line configuration for security. |
Get the line number associated to Cellular 0:
IR800#show line
Tty Line Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns In
I 3 3 TTY - - - - - 1 0 4/0 Ce0
Use one of the IR800 IP address along with 2000 + line number (2003)
IR800#10.15.15.1 2003
Trying 10.15.15.1, 2003 ... Open
Execute the 4G modem AT commands, for example AT!GSTATUS?:
AT!GSTATUS?
!GSTATUS:
Current Time: 213353 Temperature: 38
Bootup Time: 0 Mode: ONLINE
System mode: WCDMA PS state: Attached
WCDMA band: WCDMA 900
WCDMA channel: 3037
GMM (PS) state:REGISTERED NORMAL SERVICE
MM (CS) state: IDLE NORMAL SERVICE
WCDMA L1 state:L1M_PCH_SLEEP LAC: 0F46 (3910)
RRC state: DISCONNECTED Cell ID: 0D3CE428 (222094376)
RxM RSSI C0: -90 RxD RSSI C0: -106
RxM RSSI C1: -106 RxD RSSI C1: -106
Disconnect using “SHIFT+CONTROL+6+x”, then confirm:
IR800#disc
Closing connection to 10.2.2.2 [confirm]enter
IR800#
Checking 4G Modem Firmware through AT Commands
To check the IR800 4G modem firmware, execute the 4G modem AT commands after connecting to the modem. The following example is for an IR809G-LTE-GA-K9 loaded with FW-MC7304-LTE-GB Global firmware.
Note |
On the IR809, the PRI SKU ID= 9903299 is not representative of the GB firmware |
at!priid?
PRI Part Number: 9903299
Revision: 05.10
Carrier PRI: 9999999_9902674_SWI9X15C_05.05.58.00_00_GENEU-4G_005.026_000
OK
at!package?
1102029_9903299_MC7304_05.05.58.00_00_Cisco_005.010_000
at!gobiimpref?
!GOBIIMPREF:
preferred fw version: 05.05.58.00
preferred carrier name: GENEU-4G
preferred config name: GENEU-4G_005.026_000
current fw version: 05.05.58.00
current carrier name: GENEU-4G
current config name: GENEU-4G_005.026_000