Guest

Solutions

NEC IPX2400 R15 using T1-PRI QSIG to Cisco Unified CallManager Release 5.0

  • Viewing Options

  • PDF (3.8 MB)
  • Feedback
NEC IPX2400 R15 using T1-PRI QSIG to Cisco Unified CallManager Release 5.0
Table of Contents

Introduction

  • This is an application note for connectivity of NEC IPX2400 Release 15 PBX with Cisco Unified CallManager Release 5.0 via Cisco Communication Media Module CMM-T1 as MGCP gateway using ISO QSIG protocol.

  • The network topology diagram (Figure 1) shows the test setup for end-to-end interoperability with the Cisco Unified CallManager connected to the PBX via Communication Media Module CMM-T1 link as MGCP gateway. Connectivity is achieved by using the PRI QSIG T1 protocol type on the MGCP gateway with CallManager Service parameter QSIG variant of ISO and ISO switch type on the NEC IPX2400
  • This Application Note uses the Communication Media Module CMM-T1 voice gateway, however other Cisco voice gateways are also an option to use since CallManager QSIG implementation does not depend on the physical interface.

Network Topology

Figure 1. Network Topology or Test Setup

Limitations

  • Call Transfer by join (Consultation local Transfer), Cisco IP Phone x3000 calling to Dterm phone x4060 that is Transfered to Dterm phone x4061. Cisco IP phone x3000 display shows uknown/unknown. NEC IPX2400 sends "CallTrasnferComplete" connected name and number restricted towards CallManager.
  • Call Transfer by join (Consultation network/external Transfer), Cisco IP Phone x3000 calling to Dterm phone x4060 that is Transfered to Cisco IP phone x3001. Cisco IP phones x3000 and x3001 display unknown/unkown (SCCP IP phone) and Anonymous (SIP IP phone), respectively. NEC IPX2400 sends "CallTrasnferComplete" connected name and number restricted towards CallManager.
  • Call Transfer by join (Blind network/external Transfer), Cisco IP Phone x3000 calling to Dterm phone x4060 that is Transfered to Cisco IP phone x3001. Cisco IP phone x3001 display shows Anonymous (SIP IP phone). NEC IPX2400 sends "CallTransferComplete" calling Name and number restricted towards CallManager. This limitation is fixed when SS-Path Replacement is activated.
  • Call Forward by join (local), Cisco IP Phone x3000 calling to Dterm phone x4060 that is forwarded to Dterm phone x4061. Cisco IP phone x3000 display shows "Alerting Name" is presented onlt during `Alerting' state. When Dterm phone x4061 answers the call the display on the Cisco IP phone changes to "unknown". This behavior is due to NEC PBX sending Callforward update "notificationWithoutDivertedToNr(1)". CallManager uses the "DivertingLegInfo1" data to update the IP phone display, in this CallForward scenario. Connected number is ignored by Callmanager.
  • Call Forward by join (network/external), Dterm Phone x4060 calling to Cisco IP phone x3000 that is forwarded to Dterm phone x4061. Calling Name is not displayed on Dterm phone x4061, the diverting number is displayed (3000).
  • Call back, Busy or NR, was invoked from Dterm phone x4060 to Cisco IP phone , the original calling name is not shown on the Cisco IP phone x3000. NEC PBX does not send Calling Name on a locally originated CallBack call.
  • NEC PBX could not restrict Calling Name, however, NEC has an option to turn off/remove name display delivery, in ASYD command (system wide) or remove name from individual stations using ANDD command, or block Name display at a trunk level using ARTD command.

System Components

Hardware Requirements

Cisco Hardware

· Cisco Unified CallManager Server
· Catalyst 6500
· WS-SVC- CMM-6T1, Communications Media Module

NEC IPX2400

· Circuit card PA-24PRT

Software Requirements

· Cisco CallManager: 5.0
· Release 15
· Cisco IOS Release or 12.3 or higher

Features

Features Supported

  • CLIP-Calling Line (Number) Identification Presentation
  • CLIR-Calling Line (Number) Identification Restriction
  • CNIP-Calling Name Identification Presentation
  • COLP-Connected Line (Number) Identification Presentation
  • CONP-Connected Name Identification Presentation
  • Send Alerting Name
  • Call Back/Call Completion
  • CT-Call Transfer (by join)
  • CFU-Call Forwarding Unconditional
  • CFB-Call Forwarding Busy
  • CFNR-Call Forwarding No Reply
  • Call Forward by Reroute
  • ANF-PR-Additional Network Feature Path Replacement (for Call Transfer by join)
  • ANF-PR-Additional Network Feature Path Replacement (for Trombone connection)

Features Not Supported

  • CONR- Connected Name Identification Restriction - (NEC IPX2400 could not change connected name to restricted).
  • COLR- Connected Line (Number) Identification Restriction - (NEC IPX2400 could not change connected number to restricted).
  • Q.SIG MWI- Message Waiting Indication (lamp ON, lamp OFF), the current NEC IPX2400 North American Release 15 software does not support QSIG-MWI.
  • Overlap sending and overlap receiving are not supported on the current NEC IPX2400 North American Release 15 software.
  • ANF-PR-Additional Network Feature Path Replacement (for Call Forward by join), the current NEC IPX2400 North American Release 15 software dies not support Path Replacement on Call Forward by join

Configuration

Important Notice: It is important that the engineer/technician modifying the IPX2400 configuration be well versed in the NEC MAT command line. The NEC MAT command line is very precise and should only be changed by a person who is certified by NEC and has the in-depth knowledge on how to troubleshoot the system in case erratic behavior results.

Configuring the NEC2400 IPX PBX

Sequence

Physical Layer Set-up:

SW Mode èSW1 èSW2 èSW4
Note: You must set the switches on the PA-24PRT appropriately for QSIG operation

Enable QSIG services:

ASYD èASFC

To build the QSIG route:

ARTD èARTI èATRK èARSC èARRC èADPC èACSC èACIC1 èACIC2 èMBRT

To build the dial plan to access the QSIG route (Assumes dummy route has been built and ARRC is assigned properly):

ANPD èASPA èAMND èAFRS èAOPR èARNP

Configuration Menus and Commands

Physical Layer Set-up:

  • SW Mode
Set to 10 (A in HEX)
  • SW1
Set switch 3 to `off' (Sets 23B+D mode)
  • SW2
Set switch 4 `on' and switch 5 `on' (Sets ESF framing and B8ZS lincode)
  • SW4
Set switch 2 to `off' (This switch determines the ISDN protocol side emulation for the route Off=Network/On=User)
Note: To set other physical layer parameters such as LBO, alarm monitoring and Loss Pad settings please refer to the NEC USER GUIDE for the PA-24PRT. These parameters are not covered in this document. The value of these parameters will depend upon the installation of each individual Telephony network.

Enable QSIG services

  • ASYD
System 1, Index 186, bit 6 = 1 (ISDN service enabled)
System 1, Index 375, bit 0 = 1 (avoid Bch lockup)
  • ASFC
SFI 94 set to `0' (ANI)

Build QSIG Route

  • ARTD
Note: You must build two ARTD forms, one for the b-channels and one for the d-channel

Note 1: On the B-channel ARTD table, parameter IND must be set to `1' for Name display, to disable Name display feature on the trunk change the value of IND to `0'.

Note 2: On the B-channel ARTD table, parameter DC must be set to equal the maximum number of digits in the PBX's station numbers.

Note: The following parameters determine the state of the following QSIG-SS features: CTCF-Call forward/Call transfer, RERT-CF Reroute, PR-Path Replacement. To set the feature enabled you must set it to `1', if you want the feature disabled change the setting to `0'.

Note: Because we are using circuit card PA-24PRT, you assign the same LENS number to each CSCG number. You must assign an even CSCG number for the b-channels and an odd CSCG number for the D-channel. If you are using circuit cards PA-2DCH + PA-24DTR the LENS assignment to the B-channels and D-channels differ, please contact NEC customer support for technical assistance.

Build the dial plan to access the QSIG route (Assumes dummy route has been built and ARRC is assigned properly)

  • ANPD
  • ASPA
  • AMND
  • AFRS
  • AOPR
  • ARNP

Dterm Data (Digital Stations)

  • ASDT
  • ANND (Name display for Dterms)
  • ASFC SFI 94 (used to restrict Calling Number)

Note: To restrict `Calling Number' you assign SFC =15 (or any SFC set to `1'), under ASDT command for the Dterm station you want to restrict.

Call Back

  • ASYD
  • ASFC
SFI 2 allows/restricts CallBack feature.
Note: On each Dterm station Assign a SFC that has SFI=2 set to `1', using a SFC with SFI=2 set to `0' restricts CallBack.
  • ADSL (Assigning CallBack feature on Dterm softkey)
  • ADKS (Assigns soft key pattern to Dterm station)

Cisco CallManager Configuration

ISO Protocol Service Parameter

CCM Gateway configuration

Partitions Configuration

Calling Search Space Configuration

Enbloc Route Pattern Configuration

Overlap Sending Route Pattern

PSTN Route Pattern Configuration

Translation Pattern for Incoming Calls

CLIR Route Pattern Config

CNIR Route Pattern Config

COLR Translation Pattern Config

CONR Route Pattern Configuration

CallBack Service Parameters

CallBack Softkey Config

Path Replacement Service Parameter

MWI lamp On/Off Configuration

Note: Not Applicable. Standard QSIG SS-MWI is not supported on NEC IPX2400 R15

Forward by Reroute Service Parameter

IP phone Configuration (SCCP)

IP phone config (SIP)

Cisco CMM-T1 Configuration

CMM_Interop#sh ver

Cisco IOS Software, Cat6K-lc Software (wscmm-IPVOICE-M), Version 12.4(5a), RELEA

SE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Sat 14-Jan-06 04:52 by alnguyen

ROM: System Bootstrap, Version 12.2(1r)T2, RELEASE SOFTWARE (fc1)

CMM_Interop uptime is 2 weeks, 22 hours, 21 minutes

System returned to ROM by reload

System image file is "bootflash:wscmm-ipvoice-mz.124-5a.bin"

cisco WS-SVC-CMM Cat6k Voice Linecard (R7000) processor (revision 0xFF) with 196

608K/65536K bytes of memory.

Processor board ID SAD0825032A

R7000 CPU at 400MHz, Implementation 39, Rev 3.3, 256KB L2 Cache

Last reset from power-on

1 FastEthernet interface

1 Gigabit Ethernet interface

93 Serial interfaces

6 Channelized T1/PRI ports

32768K bytes of processor board bootflash (Read/Write)

Configuration register is 0x2

CMM_Interop#

CMM_Interop#sh run

Building configuration...

Current configuration : 2246 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CMM_Interop

!

boot-start-marker

boot-end-marker

!

enable password cisco

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

!

!

no ip domain lookup

ip host CM-CHIVAS 172.20.8.254

!

isdn switch-type primary-qsig

!

!

controller T1 1/0

pri-group timeslots 1-24 service mgcp

!

controller T1 1/1

pri-group timeslots 1-24 service mgcp

!

controller T1 1/2

!

controller T1 1/3

!

controller T1 1/4

!

controller T1 1/5

!

!

!

interface GigabitEthernet1/0

ip address 172.20.8.29 255.255.255.0

no ip proxy-arp

no negotiation auto

no keepalive

!

interface Serial1/0:23

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-qsig

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial1/1:23

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-qsig

isdn protocol-emulate network

isdn incoming-voice voice

isdn T310 120000

isdn bind-l3 ccm-manager

no cdp enable

!

ip default-gateway 172.20.8.1

ip route 0.0.0.0 0.0.0.0 172.20.8.1

!

no ip http server

!

!

control-plane

!

!

voice-port 1/0:23

compand-type u-law

!

voice-port 1/1:23

!

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server CM-CHIVAS

ccm-manager config

!

mgcp

mgcp call-agent CM-CHIVAS 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

!

!

line con 0

password cisco

line vty 0 4

password cisco

login

!

!

end

Acronyms

Acronym
Definitions

ANF-PR

Additional Network Feature Path Replacement

AOC

Advice-of-charge. Information element is sent with the connection setup information for incoming Euro-ISDN connections. The AOC IE is used for call charge calculation.

CCM

Cisco CallManager

CCBS

Call Completion to Busy Subscriber

CCNR

Call Completion on No Reply

CFB

Call Forwarding on Busy

CFNR

Call Forwarding No Reply

CFU

Call Forwarding Unconditional

CLIP

Calling Line (Number) Identification Presentation

CLIR

Calling Line (Number) Identification Restriction

CMM

Communication Media Module (CMM) is a Cisco Catalyst® 6500 Series and Cisco 7600 Series line card that provides flexible and high-density T1/E1 gateways

CNIP

Calling Name Identification Presentation

CNIR

Calling Name Identification Restriction

COLP

Connected Line (Number) Identification Presentation

COLR

Connected Line (Number) Identification Restriction

CONP

Connected Name Identification Presentation

CONR

Connected Name Identification Restriction

CT

Call Transfer

MWI

Message Waiting Indicator

PSTN

Public Switched Telephone Network

Important Information
THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.
IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Corporate Headquarters

Cisco Systems, Inc.

170 West Tasman Drive

San Jose, CA 95134-1706

USA

www.cisco.com

Tel: 408 526-4000

800 553-NETS (6387)

Fax: 408 526-4100

European Headquarters

Cisco Systems International BV

Haarlerbergpark

Haarlerbergweg 13-19

1101 CH Amsterdam

The Netherlands

www-europe.cisco.com

Tel: 31 0 20 357 1000

Fax: 31 0 20 357 1100

Americas Headquarters

Cisco Systems, Inc.

170 West Tasman Drive

San Jose, CA 95134-1706

USA

www.cisco.com

Tel: 408 526-7660

Fax: 408 527-0883

Asia Pacific Headquarters

Cisco Systems, Inc.

Capital Tower

168 Robinson Road

#22-01 to #29-01

Singapore 068912

www.cisco.com

Tel: +65 317 7777

Fax: +65 317 7799

Cisco Systems has more than 200 offices in the following countries and regions. Addresses, phone numbers, and fax numbers are listed on
the Cisco Web site at www.cisco.com/go/offices.
Argentina · Australia · Austria · Belgium · Brazil · Bulgaria · Canada · Chile · China PRC · Colombia · Costa Rica · Croatia · Czech Republic · Denmark · Dubai, UAE · Finland · France · Germany · Greece · Hong Kong SAR · Hungary · India · Indonesia · Ireland · Israel · Italy · Japan · Korea · Luxembourg · Malaysia · Mexico · The Netherlands · New Zealand · Norway · Peru · Philippines · Poland · Portugal · Puerto Rico · Romania · Russia · Saudi Arabia · Scotland · Singapore · Slovakia · Slovenia · South Africa · Spain · Sweden · Switzerland · Taiwan · Thailand · Turkey Ukraine · United Kingdom · United States · Venezuela · Vietnam · Zimbabwe
© © 2006 Cisco Systems, Inc. All rights reserved.
CCSP, CCVP, the Cisco Square Bridge logo, Follow Me Browsing, and StackWise are trademarks of Cisco Systems, Inc.; Changing the Way We Work, Live, Play, and Learn, and iQuick Study are service marks of Cisco Systems, Inc.; and Access Registrar, Aironet, BPX, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Enterprise/Solver, EtherChannel, EtherFast, EtherSwitch, Fast Step, FormShare, GigaDrive, GigaStack, HomeLink, Internet Quotient, IOS, IP/TV, iQ Expertise, the iQ logo, iQ Net Readiness Scorecard, LightStream, Linksys, MeetingPlace, MGX, the Networkers logo, Networking Academy, Network Registrar, Packet, PIX, Post-Routing, Pre-Routing, ProConnect, RateMUX, ScriptShare, SlideCast, SMARTnet, The Fastest Way to Increase Your Internet Quotient, and TransPath are registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries.
All other trademarks mentioned in this document or Website are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (0601R)

Printed in the USA