Introduction
This document describes how to resolve an issue with the Umbrella SAML configuration with the error, "Your SAML configuration needs to be verified."
Prerequisites
Requirements
There are no specific requirements for this document.
Components Used
The information in this document is based on Cisco Umbrella.
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, ensure that you understand the potential impact of any command.
Problem
During the setup for SAML/SSO for Umbrella dashboard login, you find that your configuration appears to be stuck in "Pending" and cannot be reset to default. The error,"Your SAML configuration needs to be verified" also appears. Selecting Cancel also does not put the configuration back to the original state.
Screen_Shot_2019-03-08_at_4.01.57_PM.png
Solution
If you wish to start over with the configuration:
1. Go into the SAML wizard.
2. Select Previous to return to the original screen (where you select your SAML provider).
3. Continue the configuration process from there.
If you uploaded invalid or incorrect metadata for your provider, you can also replace it in the Verify step.
Once you have passed the step where you verify the metadata, you are given another chance to confirm your configuration before the login is moved from user/password to your SAML SSO provider.
Cisco Umbrella is working on improving this experience in an upcoming version of Umbrella.
Cause
This is just a warning condition, and you can still set up your authentication.