Introduction
This document describes how to resolve webpages displaying incorrectly or not fully loading after you selected Continue in response to a Warn page.
Prerequisites
Requirements
There are no specific requirements for this document.
Components Used
The information in this document is based on Cisco Umbrella.
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, ensure that you understand the potential impact of any command.
Problem
Webpages are displaying incorrectly or do not fully load after you selected Continue in response to a Warn page being shown.
Solution
To resolve the issue, you need to identify the blocked or warned requests that are key to allowing the Warn page to display. You can add them to a Destination Allow List to allow them to be accessed, or change the policy which is causing them to be blocked or warned. You can examine your Activity Search and look for URLs with the Blocked or Warned action to determine which URLs were blocked at the same time which caused the webpage to display incorrectly.
Cause
When opening a webpage, a browser typically makes multiple HTTP requests through the Umbrella proxy. Each request is independent and processed and categorized separately by Umbrella and can match against different policies and rules.
If the webpage being Warned is powered by other websites for content like images and advertisements, then these can be categorized differently from the website being Warned. If these categories are blocked or warned elsewhere in the rules policy, then that content cannot be displayed. If the content blocked or warned is for key parts of the webpage layout, then the page can appear completely unformatted and broken.