Introduction
This document describes how to resolve the error "Failed to link mdm: 403 - Forbidden" when configuring Umbrella with Meraki MDM for Security Connector deployment.
Issue
The Cisco Security Connector (CSC) application is deployed via the Meraki MDM with a one-click link from the Umbrella dashboard. This link requires Umbrella to access the Meraki API with the API key provided. When Meraki API IP access restrictions are in place, see this error on the Umbrella Dashboard: "Failed to link mdm: 403 - Forbidden, Please see administrator"
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Resolution
To resolve this issue, temporarily remove access IP restrictions on your Meraki SM API and retry linking the CSC profile to Meraki. This is located under Organizations > Configure > Settings. This applies to both the dashboard and API.
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Cause
The CSC link requires Cisco Umbrella to access the Meraki API with the API key provided. This connection is initiated from Umbrella servers to pull and push Meraki configuration settings. Subsequently, the root cause of this error is most commonly a Meraki API access key restriction, which you can identify if it triggers this error:
{"errors":["You are trying to access Dashboard from an unauthorized IP address (x.x.x.x). Contact your network administrator for more information."]}Additional Information
Cisco Security Connector - Umbrella Setup Guide