Introduction
This document describes how to resolve the Cisco Umbrella Dashboard error, "Please enter a valid IP."
Prerequisites
Requirements
There are no specific requirements for this document.
Components Used
The information in this document is based on Cisco Umbrella.
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, ensure that you understand the potential impact of any command.
Problem
This article outlines how to resolve the error, "Please enter a valid IP" when registering a network on the Umbrella Dashboard:
valid_IP.png
Solution
The Umbrella Dashboard at this time can accept only valid CIDR notation blocks. This does not include support for CIDR-like ranges (for example, /30 is 4 IPs, so start address +4) and can return this error. Only valid, exact CIDR block matches are accepted into the Dashboard at this time. Any input that is not an exact match can yield this error.
To add your desired network that is a partial CIDR block, you must use the CIDR block that describes your network's total IP block (usable plus broadcast) or multiple blocks that form your IP range (like a /31 and two /32). You can use any third-party website to verify the CIDR notation that you are using is correct. An example is this third-party website that can provide you with the correct CIDR notation based on your network range. You can apply all registrations to the same policy to ensure consistent policy application across all IPs.
For example:
- 10.0.0.1/30 (invalid CIDR, valid IP error)
Instead, register these:
- 10.0.0.1/32
- 10.0.0.2/31
- 10.0.0.4/32
- 10.0.0.0/30 (valid CIDR, accepted)
Cause
The error can appear when the IP address range that is being registered has an invalid CIDR notation.