Introduction
This document describes how to troubleshoot "Error: HTTP Response code 401" in the Cisco Secure Client (CSC) Secure Web Gateway (SWG) Module.
Prerequisites
Requirements
There are no specific requirements for this document.
Components Used
The information in this document is based on the CSC SWG Module.
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, ensure that you understand the potential impact of any command.
Problem
You see the error "Error: HTTP Response code 401" in the Cisco Secure Client (CSC) (formerly AnyConnect) Secure Web Gateway (SWG) Module.
Solution
If this error occurs, check the last time your device was synced to the Cisco Umbrella Dashboard. The SWG Module syncs every 1-1.5 hours, and the keys are updated.
If the problem persists, please submit a ticket to the Cisco Umbrella Support Team (umbrella-support@cisco.com) with a description of the problem, any relevant screenshots, and the information from the Policy Debug and Diagnostic Tool.
Cause
HTTP Response code 401 occurs when the keys of the SWG Module are not current.
Note: Cisco announced the End-of-Life of Cisco AnyConnect in 2023. Cisco announced the End-of-Life for Umbrella Roaming Client on April 2, 2024, and the last date of support was April 2, 2025. Many Cisco Umbrella customers are already benefiting from migrating to Cisco Secure Client, and you are encouraged to begin migration as soon as possible to get a better roaming experience. Read more in this Knowledge Base article: How do I install Cisco Secure Client with the Umbrella Module?