Issue
ZTA client enrollment process completed successfully. However, the configuration synchronization did not occur after enrollment.The DART Bundle was referenced for diagnostics. The core symptom was that while enrollment was successful, the Secure Client was unable to sync configuration data.
Environment
Secure Client Version - Zero Trust Network Access
Resolution
Check the Dart
Sync fails with 403 forbidden? "2026-01-29 00:27:59.580605-0800 0x2514885 Error 0x0 32551 0 csc_zta_agent: [com.cisco.secureclient.zta:csc_zta_agent] E/ ConfigSync.cpp:283 HandleRequestComplete() received error http_status:403 "
When we enroll in ZTNA Cached config is pushed from cloud to client under C > Program data > Cisco > Cisco Secure client > ZTA > Cached Config.
Its possible that some Anti Malware Software scanning the file and causing this issue.
So ensure these folders are excluded from this software:
Exclusion List from AntiMalware
Cisco Secure Client (CSC): All Modules - System
1. Windows: C:\Program Files (x86)\Cisco\Cisco Secure Client\*
2. macOS: /opt/cisco/secureclient/*
3. Linux: /opt/cisco/secureclient/*
Cisco Secure Client (CSC): All Modules - User
1. Windows: %localappdata%\\Cisco\Cisco Secure Client\*
2. macOS: ~/.cisco/secureclient/*
3. Linux: ~/.cisco/secureclient/*
Cause
The root cause of the issue was the presence of a leftover AdGuard extension on the client system. The extension was intercepting network traffic, which prevented the Secure Client from receiving its configuration data (cached_config) after successful enrollment. Once the extension was removed, normal sync functionality was restored.
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