Introduction
This document describes problems encountered when you must pass Cisco Discovery Protocol (CDP) packets and Link Aggregation Control Protocol (LACP) packets transparently when the ML-MR-10 card is used and provides the specific configurations required in order to resolve the problems.
Prerequisites
Requirements
Cisco recommends that you have knowledge of these topics:
- Synchronous Digital Hierarchy (SDH)/SONET Multiservice Provisioning Platform (MSPP) circuit configuration
- ML-MR-10 use and configuration
- Cisco Transport Controller (CTC)
- Cisco standard IOS® commands
Components Used
The information in this document is based on these hardware and software versions:
- ONS 15454 SDH/SONET, software version 9.0 and later
- 15454-ML-MR-10
- Cisco WS-C3750G-48PS and WS-C3560G-24PS
- Cisco Standard IOS commands
- CTC
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.
Background Information
Here is some important information about the ML-MR-10 card.
- The ML-MR-10 card is a ten-port multilayer Ethernet card. The Ethernet ports support speeds of 10 Mbps, 100 Mbps, or 1000 Mbps through Small Form-Factor Pluggables (SFPs).
- The ML-MR-10 card has two Resilient Packet Ring (RPR) ports, which function in a manner similar to OC-N card ports. Each Ethernet port carries an Synchronous Transport Signal (STS) circuit with a size of STS-12c, STS-24c, STS-48c, or STS-96c. The two RPR port interfaces combine in order to support a RPR interface. The ML-MR-10 supports only frame-mapped Generic Framing Procedure (GFP-F) encapsulation for SONET. In addition to this, the ML-MR-10 can be configured in order to support up to 26 Packet Over SONET (POS) ports, each one terminating a SONET GFP-F encapsulated circuit.
- The ML-MR-10 card supports 1:1 protection at the port level. It also supports 1:1 card protection with redundant cards installed.
- The ML-MR-10 card supports the Version Up feature, which allows a user to independently upgrade ML-MR-10 cards as part of an overall software upgrade process. With this feature enabled, the user first upgrades all of the cards in the node that are not ML-MR-10 cards, and then, in a second pass, updates the ML-MR-10 cards.
- The ML-MR-10 card can be installed in Slots 1 to 6 and Slots 12 to 17 when used with the XC10G and XC-VXC-10G cards. It is not compatible with the XCVT card.
Refer to ML-MR-10 Card Overview for more information.
Problem 1
Two switches are connected to each other via a point-to-point ML-MR-10 setup. The ML-MR-10 has to be transparent in such a way that the switches should able to see each other. This means that CDP packets should also be able to pass through by ML-MR-10 cards. However, they generally are dropped and the show cdp neighbours output on the switch displays the ML-MR-10.
Topology for Problem 1

The physical connections are shown in the topology. ML-MR-10 cards are installed in both ONS 15454 nodes, the ML-MR-10 interface Gi0 is connected with an interface on the switch, and it is the same on both sides.
In order to connect two ML-MR-10 cards with each other, the SDH/SONET circuit was built from POS 0 to POS 0.
Here the requirement is to pass through CDP packets from switches over the ML-MR-10 setup transparently. This means that when the show cdp neighbours command is executed on the switch, it should not see the ML-MR-10 as the neighbor. Instead, the switch connected at the end should be seen. Basically, both switches should able to see each other.
Solution 1
This problem can be resolved with a specific configuration on the ML-MR-10 card.
Here is the required configuration:
interface GigabitEthernet0
no ip address
speed auto
duplex auto
negotiation auto
no keepalive
no cdp enable
service instance 1 ethernet
encapsulation untagged
rewrite egress tag pop 1
bridge-domain 100
interface POS0
no ip address
shutdown
pos mode gfp
no cdp enable
service instance 1 ethernet
encapsulation dot1q 101
rewrite egress tag push dot1q 101
bridge-domain 100
In this configuration, both the Gig 0 and the POS 0 interface are in the same service instance and in the same bridge-domain 100. This means that they are tied together, so packets that come on Gig 0 are passed to POS 0 and vice-versa.
Also on POS 0 port, incoming packets are added with an extra VLAN 101; this VLAN is then removed on interface Gig 0 when the packet leaves it.
With this configuration on both ML-MR-10 cards, incoming packets at the POS are always tagged with VLAN 101 (the VLAN can be changed), so there is a tunnel from POS port to POS port. When the packet leaves the card through Gig 0, this tag is removed, which makes data packets from the switch completely transparent, which includes CDP.
Here is the other configuration example that also transparently passes the data traffic and CDP.
interface GigabitEthernet0
no ip address
speed auto
duplex auto
negotiation auto
no keepalive
no cdp enable
service instance 1 ethernet
encapsulation default
bridge-domain 1
interface POS0
no ip address
no keepalive
pos mode gfp
no cdp enable
service instance 1 ethernet
encapsulation default
bridge-domain 1
In this configuration, the GigabitEthernet and POS port are part of the same service instance and are bridged together. Also encapsulation provisoned under the service instance is default, which means it passes all tagged/untagged packets.
Problem 2

In the diagram, you can see that two interfaces of a switch are connected with an ML-MR-10 card.
Assume ports Gi0 and Gi1 of ML-MR-10 are connected with ports 0/0 and 0/1 of the switch, and that the same connections are also there on the other end between the switch and the ML-MR-10 card.
Here the requirement is to configure channel-group on both switch interfaces 0/0 and 0/1, and both switches should be directly formed as peers.
ML-MR-10 has to be transparent in this case. There should be no channel-group configuration on the ML-MR-10 cards.
In order to connect two ML-MR-10 cards with each other, a SDH/SONET circuit was built from POS 0 to POS 0 and POS 1 to POS 1.
Solution 2
From the requirement in Problem 2, if this ML-MR-10 setup has to be transparent, it should be configured as if the switches are connected directly with each other via a LAN cable or optical fibre.
In order to achieve this, the setup bridges the Gi0 port on ML-MR-10 with POS 0 and the Gi1 port with POS 1, and then creates a point-to-point circuit between POS 0 to POS 0 and POS 1 to POS 1. With this setup, you facilitate switch ports to be directly connected with each other.
Also this configuration requires the use of LACP protocol.
Here is the required configuration.
Configuration for ML-MR-10
interface GigabitEthernet0
no ip address
speed auto
duplex auto
negotiation auto
no keepalive
no cdp enable
service instance 1 ethernet
encapsulation default
bridge-domain 1
!
!
interface GigabitEthernet1
no ip address
speed auto
duplex auto
negotiation auto
no keepalive
no cdp enable
service instance 2 ethernet
encapsulation default
bridge-domain 2
interface POS0
no ip address
no keepalive
pos mode gfp
no cdp enable
service instance 1 ethernet
encapsulation default
bridge-domain 1
!
!
interface POS1
no ip address
no keepalive
pos mode gfp
no cdp enable
service instance 2 ethernet
encapsulation default
bridge-domain 2
!
!
As you can see in ML-MR-10 card configuration, this creates a common service instance between the Gigabit Ethernet port and the POS Port and then the same bridge domain between them.
SDH/SONET circuit configurations are not shown here, but you do need to create circuits between POS 0 to POS 0 and POS 1 to POS 1. The bandwidth of the circuit depends on the requirements.
Configuration for the Switch
interface Port-channel1
switchport trunk encapsulation isl
switchport trunk allowed vlan 17
switchport mode trunk
interface GigabitEthernet0/0
switchport trunk encapsulation isl
switchport trunk allowed vlan 17
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/1
switchport trunk encapsulation isl
switchport trunk allowed vlan 17
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
The switch configuration is fairly simple, but one thing to notice is the switchport trunk encapsulation isl command. You must explicitly configure this command, because, without this command, the line protocol does not come up. This is because ML-MR-10 supports Inter-Switch Link Protocol (ISL) mode.
Note: The ML-MR-10 configuration given in Solution 1 can also be used.
For further queries, contact the Cisco Technical Assistance Center (TAC).
Note: Log into the Cisco Technical Support web page for more information or access the Cisco Worldwide Contacts web page in order to obtain a directory of toll-free Technical Support numbers for your country.