Under app Enterprise Security > Incident Review, more than one risk notables were displayed for the same risk object in a 24 hour period, for example, splunktest@domain.com.
6:02PM - Notable #1
10:12PM - Notable #2
However only one notable should be triggering in a 24 hour period for the same risk object.

To investigate what is happening:
1.Review the notable trigger condition by expanding the notable and click on the search link under "Correlation Search"

2. Review "Time Range", "Trigger Conditions", and "Throttling" sections, for example:
3. In this case, the conditions define that a new notable will be triggered in a 24 hour period when the below field group combination changes:

| search risk_object="*splunktest@domain.com*"
So the complete query may look like:
| tstats `summariesonly` mode(All_Risk.risk_object) as risk_object, sum(All_Risk.calculated_risk_score) as risk_score, count(All_Risk.calculated_risk_score) as risk_event_count,values(All_Risk.annotations.mitre_attack.mitre_tactic_id) as annotations.mitre_attack.mitre_tactic_id, dc(All_Risk.annotations.mitre_attack.mitre_tactic_id) as mitre_tactic_id_count, values(All_Risk.annotations.mitre_attack.mitre_technique_id) as annotations.mitre_attack.mitre_technique_id, dc(All_Risk.annotations.mitre_attack.mitre_technique_id) as mitre_technique_id_count, values(All_Risk.tag) as tag, values(source) as source, dc(source) as source_count, values(All_Risk.risk_object) as all_risk_objects, values(All_Risk.cim_entity_zone) as cim_entity_zone from datamodel=Risk.All_Risk by All_Risk.normalized_risk_object,All_Risk.risk_object_type | `drop_dm_object_name("All_Risk")` | eval "annotations.mitre_attack"='annotations.mitre_attack.mitre_technique_id', risk_threshold=100 | where risk_score > $risk_threshold$ | `get_risk_severity(risk_score)`
| search risk_object="*splunktest@domain.com*"

Following above troubleshooting steps, the behavior of triggering two notables for the same risk object is expected in this case.
https://docs.splunk.com/Documentation/ES/7.3.2/RBA/HowRBAWorks
| Revision | Publish Date | Comments |
|---|---|---|
1.0 |
29-Sep-2026
|
Initial Release |