Cisco Customer Success - Video

IPv6 Standards Uncovered Inside the RFCs

Playback confirmation!

Do you want to resume playing from last left location?

Chapter 1 Thumbnail
00:00
Welcome, session overview, and speaker introduction
Chapter 2 Thumbnail
03:10
Why IPv6: IPv4 as legacy, 1918 space, and the role of IETF standards
Chapter 3 Thumbnail
08:03
IPv6 standardization (RFC 1883) and the massive 128-bit address space
Chapter 4 Thumbnail
11:21
RFC evolution and learning: behaviors, RFC 8201, and reading the specs
Chapter 5 Thumbnail
13:17
You already use IPv6: link-local, IoT, RFC 6724 default selection, and ULA precedence
Chapter 6 Thumbnail
21:16
Happy Eyeballs (RFC 8305): preferring IPv6 with fast, seamless fallback
Chapter 7 Thumbnail
26:04
From dual-stack to IPv6-only: adoption, gaps, DNS64/NAT64, and real deployments
Chapter 8 Thumbnail
31:05
IPv6-mostly with DHCPv4 Option 108 (RFC 8925): concept and network requirements
Chapter 9 Thumbnail
36:10
Client behaviors and platform support: legacy, dual-stack, and the “cool” Option 108 clients
Chapter 10 Thumbnail
41:09
464XLAT (CLAT/PLAT) flow, verifying IPv6-mostly, recap of key RFCs, resources, and Q&A

Transcript

Oh good morning, everybody, from the Americas region, thank you for taking the time to join the session on the series. I.00:00PV six today.00:20Like, you know, we have our expert on the IPV six topic Nicole going presenting the top presenting on IPV six standards uncovered inside the RFC. I hope you all get to take the most out of the series from from our expert here. As we dive into the session, if.00:23If you have any questions, please feel free to raise your hand and we'll unmute you to ask your questions live and we can keep this as interactive as possible with Nicole and.00:42If they like if if you have any questions that you'd like to post on the chat window, you also have chat window open for you to post the questions. Nicole is our you know solution architect from sales, and she's, she's brings her, she brings her experti.00:56It's in IPv six security and different news and she's a she's a well recognized.01:16Designated speaker at Cisco Live and a couple of other events hosted across globally. So with that, I think I, I have more to speak about her but I'll give her the opportunity to like introduce herself and Nicole you know table.01:24Is yours, please go ahead. Thank you so much for that introduction. So yes, and here you can see me as well, you know, in a nice orange suit and with a very sugar rush also known as a stove waffle because as you can sort of.01:42Listen to my accent. I I am not from the Americas. However, I'm from a very tiny country from over the ponds, we call it also the known as the Netherlands. So, one of my passions is talking about IPv six and that's why we're here today for our second session.02:01But besides, you know, I also I'm sort of so technical as well, I'm also a formula one fan. So although the Formula one season has started yay, we have two races finished and I can safely say yes although my my max restopper is still in the race, I mean I.02:21I am so proud for our 1st Italian Kimiantonelli last weekend. So yes, with that, let's let's go into the today's session because I'm covering in the I'm uncovering the RFCs.02:40Because so what are we going to discuss? I mean, it's still IPV six related, right? Well, an IPV six also relates to RFCs because on behaviors that we are used to in the legacy protocol.02:55So for people that have not never met me before, I call IPV four the legacy protocol because we ran out, we don't have addresses anymore. Nobody is well using more addresses or they are abusing other people's IPV four addresses, so this is why I call it the legacy protocol.03:10And IPv six is here and the ITF, they are very active in making the IPV six address family as robust as possible, so we are ready very far ahead on this, but it's getting more and more. And just knowing about the behaviors.03:29How it's in the RFCs mentioned. This is very keeps you let's say, more comfortable and get gain you more knowledge on why certain things are happening. So 1918, by the way, so people know all about 1918, it's not related to IPv six at all, but it.03:49It's your legacy ten address space because we are so comfortable with it and it's.04:09And we really think this is the best thing, this is what I'm using and I don't need anything else nicole. Well, let me go through, you know, and let me share my excitement about including the RFCs. For people that joined us last week, I mean, they already seen this.04:15Before or for anybody that has me met me before because after this session, if you, you know, if your manager is asking, so what did you learn about Nicole? And then you can say safely say IPV six is brococaly. So all of the journey when you are starting your journey and gets really excited.04:35This is the key thing for you to remember, like really so for the people that know they know already what's happening at the end of the session, but I am leaving this here and at the end of the session, I will explain why really three six is really brochly.04:54But like I said, I mean into the RFCs because it's sort of handy to know where standards are coming from and how the thinking from the internet and task force, you know, came about, you know, making sure that, you know, we need standards because if every, you know, if.05:11The competition, you know, the two letter competition or any other competition from, from China, for instance, have their own standards. I mean, this makes it quite challenging. So how could we incorporate with each other if we can't then agree on the standard? And this is where the RTF ITF started making.05:31RFCs and they become internet standards. So 1918 address space, so this was back in the days, you know, early eighties and some of them on the call might not have been born yet, but it was about connecting.05:51Connecting computers back in the day when Cisco was was established Bosch Nickel Learner, they really wanted to communicate with each other and this is where a router or a router depending on where in the world you are living, I call it a router in Americas it's a router where that one was.06:08Let's say born, but then you needed to communicate with each other and this is where IP came. It's like, ok, you know, we're having some addresses. And so it was really nice and very handy to have, you know, nice addresses like the, the private 1918 address space because they were not publicly available. So it's sort of.06:28Felt a little bit secure and comfort and not routable towards the internet.06:48And then around, you know, I would say in the early nineties already actually late eighties, the ITF already discovered or figured out like, ok, this is not gonna work because these legacy IP addresses at some point in time, we don't know Yen, don't know.06:55When yet, we run out. So we need to think of the next level thinking as in, ok, you know, we need to do other type of addressing, and this is also where back in the eighties, you know, they started to think about, you know, ok, we need to next generation IP. So and this is where.07:14IPV six came in play because you know you can't nut everything. Not by the way, was created actually to.07:34Help the panic less towards the transition towards IPV six, but mostly people will say, Oh tho, it's secure or you know, I could use a lot of addresses because I mean then the next the RFC finally that became an internet standard 30 years ago. So December 99.07:4385 RVC 1883.08:03Came, that was the 1st one where IPv six became a standard. And so I always joke about it now because of course I had last week I had my perception versus reality where people say well Nicole, I mean IPV six is old enough old enough to drink. I mean, when are we finally.08:07Going doing this? Well.08:26I can safely say the world and not only in the Americas because in the Americas, customers are busy Europe and even in Asia, Japan very active as a was one of the, the, the continents people are making the transition because it's so much easier.08:28To deploy a network.08:48With an insane amount of IP addresses on IPV six. I mean subnetting, I mean come on that on an IPV four, geez, good luck with that. I mean it takes a couple of minutes. So 30 years yes, it's been a while because people went like well you know it's a very long address. It's scary, but actually it's quite.08:51Interesting.09:11Because 340 undeciliation addresses, you know, have, has IPV six and that is you know mind boggling because it's two to the power of hundred and 28, you know, possibilities. And so, I mean 340 40 undersillion, I mean I.09:12But I hardly use that word and as an example too, you know.09:31See how big it is. So I like the next one is it's 42 quintillion IP addresses per person on earth. So, I must say I do like the 42 and if people are not aware yet and haven't learned I mean the hitchhaggest guide to the galaxy by Douglas Adams.09:37Perfect reads because the answer to everything because they try to find the answer, it's 42. So 42 quantalling addresses I have personally available. Do I need them all? Probably not Nicole, but you know what, it's there for me available because with the.09:56AI area now happening and and things are moving so fast. Can you just imagine, you know, if a person comes to you and says, hey, I want to deploy this specific application and I need six legacy addresses. And there's an IT administrator, most likely you go like hold on six legacy addresses.10:16Not happening because I don't have them. Me as an IT administrator, why do you need them in the 1st place? You might get one if you're lucky and by the way, please fill out this paperwork, you know, giving your your thesis, I would say, explaining why you need it because.10:36Is very scarce. That's the legacy worlds. I mean because here comes Nicole, because if that same, you know, person from the the from the politic comes to me and says, Oh, you need six? I'll give you a/sixty four. So that's half because it's a hundred and 28 bit I'll give you half of a/sixty four of my prefix, so.10:5518.4 Queentilian addresses. Have fun, you know, come back when you need more.11:15So this person goes like, oh, so students, by the way are really keen to to deploy IPv six. I can safely say last week I was in Belgium and there was a lot of students they say Nicole, I really want to do this. And I said, go for it. You can do it.11:21So, like I said, 1883 was the 1st RFC where IPV six was a, a draft or a standard. And over the years, the ITF has.11:38Made new standards because they learned along the way what, what worked and what didn't work and made tweaks to the standards. So RFC 8201 hundreds and and one of the things that if you are struggling a little bit at night, you know.11:53Trying to figure out, you know, can I fall asleep or not? I would highly recommend, you know, reading an RFC because you definitely fall asleep. It's a lot of asking and you will learn a lot because you can then st trying to understand, you know, why certain behaviors are happening.12:10And we'll soon come to some, some really cool RFCs which are key for the standard behavior of IPV six. So 82 100 definitely, you know, put that on your your reading list because there you can, you know, read about, you know, the, the, the routing.12:30Packets, you know, the larger packets, you know, jumbo frames and all those things and how clients and service are are supposed to behave.12:50So, this is the best one. I always like this one as well. So you don't need to raise the hand because otherwise Bavana think you you're having a question, but think about this, right? So I always ask that say people so who has IPV six running in their network? And so let's say you are watching this now at.12:58Home and your service provider doesn't have IPv six given to you. Rule number one, call them up and saying I Nicole says I need IPV six. So please put it on your priority list so that's one.13:17Or challenge them even more or you already have IPv six, you have a global address. So then you're running IPv six even, you know, already from day one. Change service provider, that's the 3rd option. However, you probably go like Nicole, I don't have, my service provider doesn't have IPV six.13:32No way I am running IPv six in your network. Well, look at your interface, IP config or any other equivalent depending on which operating system you are using. However.13:52You have a fox echo eight zero on your interface or your wireless or wired even, because unless you physically disabled unticked IPv six, you have a link local address.14:08So that means you are IPv six capable and you are talking on the link, so in your local network or your layer two, you're talking IPv six. And if you have IoT, so I have a, a oven, I have a, a coffee machine. I have a dryer and.14:24The washing machine. Oh, and by the way, I also have electric curtains. So back in the day, I mean we always said oh NO IoT devices are not running IPv six and it's not gonna happen. What?14:44Year and a half ago I looked in my network and guess what? These devices, IoT, they are running IPv six and I can now communicate. And I actually communicate over IPv six with them, and this is where that RFC comes into play. RFC 6724.14:54Very important because RFC 6724 is also known as default address selection or a default source selection. Which source am I using to communicate? So you probably think then, well, you know what, I have some IoT devices, Nicole or you know your your.15:14X box by the way, also another one or your playstation.15:34You are definitely communicating locally on IPV six because IPV six is preferred over the legacy protocol and that's all written down in RFC 6724.15:37If you are a little bit longer in the environment and you're already, you know, using IPv six or you you've heard about it and you you listen to me or any of my colleagues, you also know something about happy eyeballs. And happy eyeballs is.15:55Complementary to the RFC 6724. Why? Because we want to make sure that everybody's happy and we don't get measurable by connecting towards the internet and making sure that if IPV six is failing, we fall back very quickly.16:14Towards the legacy protocol. And this is where happy Eyeballs comes. So the 1st RFC, so RFC 8305 is actually, 2nd version and the 3rd version is in the making as we speak, and my colleague Dan Wing and Andrew your Chenco.16:33They they they they made the 1st iteration of the RFC 66555 if you really want to go back.16:53And so those two work hand in hand. So it's not one or the other, but RC 6724 is address source selection. Very key. By the way, also good to know if you are following the ITF, 6724 is also currently in.17:00In discussion to make a update.17:20Because one of the cool things or maybe one of the other things is I am not a fan of unique local addressing, so ulas, because mostly of the people that want to transition to go like, Yeah, I love my 1918 address space and ULA is the best thing that happens on earth. No.17:23No, in a julistic environments, so legacy protocol and IPv six. So funny enough, ULA has a lower priority because of 6724. And here you can see that so because it's all about, you know, showing is believing.17:42That is a really cool site. My colleague Eric Vang made, also known as RFC 6724.Vinki.org, and it helps you to understand, to learn about the, you know, the behavior of IPv six.18:01And here you can see that the default, so if you have a linked local address or any globe mobile address, it has a higher precedence than the legacy protocol because the legacy protocol is actually hold on, let me go to ULA 1st by the way. It's the presidency.18:17It's three, and here you can see.18:37That the legacy protocol has 35, so that means linked local 1st, global 1st, and ULA has less. Okay, but what that, what does that mean? Well, remember when I said in a duel stack environment because most of the people tend to, to.18:40To say, ok, you know, I have legacy running and I want to put IPv six on top, and at some point, your goal is to do IPv six only. So you take away the legacy protocol and we have only IPv six running.19:00You really want to know if your IPv six is working properly. But in a dual stack environment, remember when I said, you know, the legacy protocol ULA has a lower priority. So now the question is, you don't know whether.19:18Source selection, right? Legacy is tried 1st to make a connection towards wherever in your network or towards the internet. And so if you take the legacy out, you don't know if you properly configured your IPv six everywhere.19:36This is where you need to really consider to yourself, ok, hold on, am I doing the right thing? So at this moment at the ITF they are trying to make the presidents of ULA higher.19:53Then the legacy protocol, but keep in mind that it's not a standard yet and that also means that at this moment there's NO client that is changing that behavior yet. So that's at least a minimum of a year out, maybe two years I don't know that I don't I don't look in my.20:08Last ball, but this is one thing you need to remember as in when does that client, so don't wait for it, I would say.20:28Use ula's in a IPv six only environment and only in corner cases where, you know, you don't need legacy IP and you can do do with IPv six only. Again, IoT devices, you know your lighting I mean that would be a perfect moment.20:36So then, you know, ok, how does this relate, you know, with the happy eyeballs? So remember that if you are having a global address, happy eyeballs comes into play because we really wanted to make sure that everybody's deploying IPv six but don't get, how do you say frustrated?20:57If something is not working because you can just imagine, you know, the fact that if I am going towards a, application that a banking or, you know, if you're trying to to google or check GBT actually it does a lot of work in the background. But let's say if you're trying to Google or go to a web.21:16And it takes minutes.21:37For your response gets because it's properly configured and the fallback takes you know standard behavior. So then potentially it could be something around, you know, 3 min. I mean, I don't know about you, but my brain cannot even handle 10 s of waiting. So let, let alone.21:4220 is already too much. So normally it's 30 s and it will try in a total of three times, so it's actually a minute and a half before it would fall back. This is the normal behavior of TCP, but.22:02With happy eyeballs which has been incorporated in, the Apple device, so on a Mac and your iPhone, it's, it's standard in the operating system, but also browsers like Chrome, folks.22:15Has impacted the happy eyeballs is that in order for me, when I go to Google, because Google I know is sort of duel stacked, it gives me a quad A record because that's your IPV six and it also gives me an A record for the legacy protocol. But again.22:31Our goal here is from the ITF based is ok we want to make sure that we 1st try IPv six because if IPv six is working, we don't need the legacy protocol. And so the IPv six, the quad A record really gets, you know, a small head start.22:51You can see it. It's a 50 milliseconds, and so that 50 milliseconds, you know, is, is enough for to see, can we attempt, you know, to connect over IPv six? And so if that's working, you know, immediately, you know.23:09The the the connection comes back and we're off to the races and we keep, you know, that connection alive. And the cool thing is about is that let's say if at some point in time, you know, the connection is actually not working again and let's say YouTube I know that for YouTube this works perfectly fine, because this is how.23:24How I tend to test my my IPv six constantly is that.23:44If it's some connection breaks, you know, the client tries to connect, but it also still has the A record and then it attempts on the legacy IP address. And most of the users, they will see initially a connection on three six and they're happy, at least Nicole's happy.23:50And the funny thing is, is that if it doesn't work it falls back and you don't even notice this only when you're really actively looking. And so this is one of those cool things I would I would say that ITF made because their goal was to make this transition to IPv six only as smooth as possible.24:09And it's a transition because it's not a migration. I always joke about it because birds migrate, so we are now in spring, right? So birds are coming in, they are ready for the summer and make warm. Birds migrate back when it comes colder.24:29And I don't want you to come back to the legacy protocol, so that's why we are transitioning to IPV six. So this is how a happy eyeball balls plays, and this makes it really comfortable, you know, as in that you don't have your IT manager sitting next to you in case of a IPV six failure.24:45For for the elderly people I mean, can you just remember back in the early 2000, you know, when we when we had wireless, people were were freaking out, it's like, oh, what if it, what if the network goes down? We need to always have a cable ready, you know, that, that was one.25:04Or, you know, telephony over IP. No, NO NO. Telephony needs always to be available. No, well, here we are 2026I mean my corporate lines I haven't been using for the at least the last 20 years, maybe longer. Yes, I was part of I thought myself, oh NO NO, this is never gonna work. Well, it.25:20This happening that transition, and so even IPV six, we.25:39Are so far ahead already. Everybody's using it. That's the other thing. Google is close to 50 %. It's Cisco Live US We are over 50 %. I mean it's almost 60, so the legacy protocol is behind us. This means that everything we are ready and we also need.25:45Need other people to come along.26:04Because like I said, transition, our goal is to go to IPv six only. And, you know, in order to do that, I mean, we all know about, you know, the legacy protocol. This is how it all started back in the eighties and then early nineties, you know, more commercial net.26:08Works came in play and then half mid nineties, everybody's like, oh, you need to get on the onto the internet. And then already, you know, when RFC 1883.26:27Came out, everybody was like, ok, why do we need this IPV six? But they sort of could understand, you know, ok, we need to do something about it and we can see by the future that we definitely need more, address space.26:39I always joke about with the youngster people, I mean, I remember I, in the early nineties, my 1st computer was a DX 40 and I had a very big hard drive, 30 MB.26:55MB not even I'm not talking gigs, right? So three zero MB and that already nowadays, I mean you got you you can't get that. You can't even install anything on that. I mean memory is already bigger.27:11But in order to make the transition, you know, back in the day that definitely in 2012 I had this famous quote saying, julestack where you can. Unnel where you must. So in 2012, when we did the IPv six World Day, we turned the legacy pro.27:26Protocol off for a while and trying to figure out, you know, what's working, what's not working. I can safely said it was very lonely because my my famous Facebook was not working. Instagram wasn't born yet. And so it felt like, yeah, we're not, we're not ready for the world yet, but.27:46Meta has not said still, they are by the way, IPV six only already but I noticed that even a lot of in the enterprises they go like, yeah, you know what, I feel comfortable with julestack. And jule Stack really makes it very handy because you can sort of always fall back if there's.28:06Immediately fall back just like that. We call it a sort of a safety net. But I would say, you know, it's 2026I would challenge you.28:25Try IPv six only or you know what, maybe in the future IPv six mostly, and I will tell soon what this IPv six mostly is about because this is your journey. So this is the journey where you need to go. So legacy environments, so some go dual stack. I would challenge you IPv six only.28:34But you know what? It's, it's quite of a challenge because IPv six only you have some challenges because if I'm IPv six only, what am I accessing? Am I going to meta? Am I going to Netflix? I mean, I.28:53Already if you go to those, I would say oh not a problem or Office 3605, they are all IPv six capable, so they are are fine. But you know what? Maybe in your environment you have GitHub, and guess what? Github is not IPv six capable yet. I mean this is all about.29:11You know peer pressure, probably more if more people are asking, you know, it probably helps, but.29:31This is, you know, could be potential issue. You think then ok but Nicole, if I need to go to GitHub I can never go to IPV six. That's not true. Because you know what? With DNS six four and net six four, you can overcome that issue.29:37And it definitely is working. So for people that have been coming to Cisco Live in Amsterdam so far for the last two years, and if you had a Android or a Apple device, I can safely say, you know, you've been running IPv six only to a host already for two years and you probably didn't know.29:54Last week in Belgium there was one teacher from the Net academy. He didn't know, so I said told you. So he's like, he was really stunned. He said, and I said it worked, right? Yeah, yeah, it worked. Still, by the way, I mean, it's not all hunky dory. Potentially you can still have DNS issues and net issues, right? So this is.30:13Still to need to consider. So just keep that in mind because on the other side, right? So it's not only from the, from the client side perspective, but it's also from the server side.30:33So if I am running an IPv six only server, and so remember, LinkedIn, I said this last week, LinkedIn, Netflix, Disney, a lot of big content providers that Meta, by the way, sorry to, they are already using IPv six only service.30:45Because they want to scale quickly and they don't want to burden, you know, these legacy IP addresses. And so remember that most of the people that come to their services, they are using IPv six. So they have already over 50 % IPv six traffic.31:05So then net issues is not a real a problem there, but still, if you have legacy people, because they they are afraid to transition to IPV six, they they potentially could get net issues because the application that and that's one of those really said let's say corner cases.31:22It's all about, well, how did your developer create that application? Something that's called IP literals. And IP literals means that the developer unfortunately hard coded the legacy IP.31:42Into the application because at that time probably they thought oh this is the best thing, this is perfectly how I can, you know, quickly it works now. So why should I, you know, use proper DNS and naming systems and to scale now boof.31:58But that makes the transition to IPV six only challenging, but that came to a solution. Oh hold on, IPv six mostly because the ITF also saw thinking, ok, how can we make that transition from a dual stack environment.32:15Requirement to the next step to IPv six only.32:35Although the enterprise has never said it literally be but but I can see the feeling. It feels like you need to make that final jump and the jump looks short, but you're sort of afraid, you know, when you are hiking through the forest and you you're coming through that small lake and that lake and you don't.32:40Don't want to get wet feet. I mean I I know that you're looking at it and think oh that's a big jump and I don't want to get my feet wet.32:59This is where, you know, the ITF also said, Well, you know what, let's make the step a little bit less bigger in in mind, and this is where RFC 8925 came. IPV six only preferred option for DHCP V four.33:08But keep in mind, four DGP V four because people might know that Android doesn't support DTP V six. That's a whole different conversation which is not covered in this session today, but they decided that, you know, Google said, well, what if, you know.33:26We are cool and we don't need that legacy protocol anymore. So it's also known as DTP V four option one oh eight. So this client says, I'm one of the cool kids, I don't need that legacy anymore in this dual stack environment.33:46So and now you know that makes a journey a little bit, you know, more comfortable because you have this little small step in the middle so you can step on there and and see if everything is working fine on your three six, and then you can turn off the legacy protocol because that makes it quite handy.34:05So in Cisco Live Amsterdam, we've been running now for two years, IPv six mostly. I'll leave it right that I will not, who knows, so fingers crossed, we will get it in the US, but that's, I cannot, we are two months out in order for me to.34:23To make that but I can only wish.34:42Because that will be really cool. So, ok, Nicole, so you're talking about RFC 8925 and ok four but ok how what's needed in my network for this? Because, ok, how does this work? You know.34:46So, you need stateless address auto configuration because we already remember we had Android devices. In this case because in this case the the clients are not capable, so Android specifically are not capable for DHCP V six to get an address.35:03Well, guess what? We are sort of trying to do, you know, an IPv six only environment. And that means in order to for me still to get to websites like GitHub or any specific social media platforms that are not IPv six capable.35:23You need net six four and DNS six four or the other way around DNS six four and net six four in order to still go to the legacy world.35:43So, because if the destination is IPv six, well guess what? We don't need NAT and DNS. So the cool thing remember that I said, I love to come back to it. We see more than 50 % IPv six. This means that Net.35:53The net six four is not a heavy box. Of course, it depends of course in your environment. Keep that in mind. However, most of the traffic will be IPv six. You will be surprised actually how much IPv six traffic you are having.36:10Because it's all about measurements and I will challenge you for sure I can safely say that at least close to 50 %, maybe even more. There was a conference last year in August in in Vegas where I measured on the, on the, on the dashboard, we had 78.36:286 % of IPV six traffic. I was like yeah I was happy. The reason was that because we went to Apple Meta, all we went all to all environments in that area where IPv six was a thing.36:48And now all of a sudden you don't need to be afraid of that net six four box because it will go on a holiday and that's the whole goal. At some point in time you don't even need the box anymore, and I dearly hope that before my retirement and that's not next year.37:07I can safely say we don't need net six four. That would be so awesome. So, those two are needed for, for legacy only destinations and so you you you actually accomplished that you know by router advertisements and then either send, you know, the press 64 or DNS 64 in.37:23Information in that router advertisement. And last but not least, you need to centralize DCP V four infrastructure because that's very key. Okay, so then how does this really work, Nicole? We have a client.37:43We have three types of clients. So the 1st client's legacy. So I mean, pretty boring, sorry to say. So that legacy client and let's say it's old IoT because remember that I said my IoT devices already support IPv six, but.38:03This per this client, you know, wants an IP address and it can happen because in your environment dual stack, your legacy IP will get a IP address from the DCP four because that's what you need. Remember, DCP four four infrastructure.38:19And then we have a client like currently my Windows machine or, you know, my IoT device. ICE support IPv six, but I don't have the option one oh eight because.38:36When I get onto the internet and I send a DHCP V four request with NO option one oh eight, I will get a IPv six address through my router advertisement, through stateless address out of configuration and my DHCP before server will respond as well, so I will also get the legacy IP.38:52So means Nicole is running dual stack. Good, we're off to the races. But now the cool kids come into play because this is the most important. The cool kids says, ah, you know what? I want my IPV six, but I'm sending a DHCP before request to option one oh eight because.39:12You know what, I don't need that legacy address. I am the cool kid. I can run IPv six only.39:32So I'm cool. Please hold it for me, right? Thank you. And so that's the cool and so who are the cool kits at this moment? So at this time in 18 March, because that's very important, at this moment, all android defi Android devices are cool.39:39IOS, Mac OS, and unfortunately, so Linux depends on the distribution. Some of them support option one oh eight already, but Windows Microsoft at this moment, they are.39:59Very close. So I, I hope it's coming in the 1st half, otherwise it for sure it's happening 2nd half, but again, I am unfortunately not Microsoft, but I've tested the C let support client lets. That's where it's happening.40:16Myself so it is coming and then I would say there, then it's the next step that everybody, you know, is making that next step to go go towards IPv six mostly. Because that's the cool thing. I mean, this is we're almost close.40:34So, you know, why not happening? Because it makes a really good path, you know, to go away on the legacy protocol. That's the cool thing. Unicorns do exist, as you can see here with the glasses.40:51But ok so we we're talking about the seat nicole, and what is that? What, what are you talking about? So let me show you how you can see, let's say if you are in specific environments.41:09If you're running IPv six mostly or not, because that's the cool thing. So remember that I said, Are you running IPv six? And so fox echo eight zero, your linked local address, this is always your 1st address on your interface.41:24And we see one here. By the way, this is an example from Cisco Live Amsterdam on a Mac. So, and this was taken last year. So folks echo eight zero, everybody has that address. You also on your machines or your clients, you at least have this address. Remember when I said?41:42On the local link, you are communicating Fox echo eight zero. No, NO matter what, if you don't like it, so it's gonna happen. And then, so stateless address auto configuration.42:01Because there's a prefix happening and my client is now configuring auto configuring a temporary address and a stable address. So that's why you see two addresses. This is normal behavior by the way, from stables address out to configuration if you get two addresses.42:17Sorry, this is standard behavior from the clients to create two addresses because this is the privacy extensions or temporary addresses nowadays it's called, so making sure that you are not trackable.42:34So on average, you will always have a minimum of three IPv six addresses. But in this case, we go a little bit further. So because this cool, this client is one of the cool kits because it's a legacy address 192002, you know, that's not gonna go anywhere. That's why it's there.42:50So that's the yeah sure fine, I'm cool, but I'm not going to do anything. And this is where your client lets comes into play. And this is a application on your device. So like I said, Android, Mac, iOS or your iPhone has the.43:10That's software already in there, so Microsoft is coming and what it does.43:30So in order to on the moment when it noticed that it doesn't get a quad A record and it sees that, hey hold on because through DNS six four it needs to synthesize, so it knows that hey hold on, I need to translate. And so.43:35What it does that the GitHub, the four.43:55Is translated or synthesized to a six address and that's sent off to the net six four and that the sealets, you know, that's so the client let it sends to the net six four and the net six four we call a P let provider let because there the six is synthesized.43:59Back.44:19Towards a IPv four, a legacy address. And so then when the communication comes back, the NAT takes it over and comes back to the client. So on the client itself, it doesn't know that it went to a legacy address because that's where this address, well if you.44:20You see it in a wire shark or in, in a sniffer Trace by the way, that's both of the same depending on your age. You will see if you see a source address, you know, B3B7, you got like, ah.44:40I go to a legacy world. So this is how this really plays, and I can safely say that the majority every time when I see, say people, you are in an IPv six only environment, the 1st time was best ever. Everybody took out their phone like, NO NO NO NO, this can't be true.44:51But this is how this works and it works quite nicely. So this is really, you know, a cool way of making, you know, your, your environment work. So let me say it again. So how does this end because this is also known in the world as 464 excellent.45:12Where on the left hand side, on your on your screen, you see this client device which is in a legacy world because it needs to send traffic towards the outside and by by making that translation on the device.45:32And traversing it through the net six four towards the plats, then onwards, you know, towards the the the V six traffic and then potentially there could be a, IP V four server, a legacy server re responding to that. So this is the the quick.45:49Translation on all that really works.46:10So in this session, right? So we, I covered a couple of RFCs which you can, let's say go through over the period of time, which RFC 6724I mean that's the most if you are trying to think, oh, you know Nicole, I really need to get, you know, my hands dirty on this.46:14The IPV six and you're starting playing, mostly I would say start at home. That's the best. Last week also I encouraged one person he said, Nicole I'm gonna turn it on. And I said it will be so boring.46:34Because it will just work. And then, but then you can comfortable, get comfortable with RC 6724, and then you will also learn about, you know, the happy eyeballs. You learn more about those as well because then you figure out, oh, hold on, you know, now it falls back to the legacy protocol.46:47And it actually still works. So that's another one. So RFC 6724, as I said, keep in mind if there is a new update in the making, but right now not there there yet. RFC 8925, an easier transition.47:07Towards the IPv six only environment because that is our end goal. We want to say goodbye to the legacy protocol. It takes a while, it won't be tomorrow, but this is our goal because once you get comfortable, you really.47:27Wondered to yourself, why did I ever get stuck and stay with the legacy protocol? Our future engineers really, really wants to turn on IPV six and I would say let's do it. Number four by the way.47:41To remember, well, there's three more sessions, session three and four, one is next week and one is in two weeks, so definitely don't forget to register. But remember, when I started this session, you know, 50 min ago, I said, you need to remember.47:57IPv six is brocalling and with the RFCs, you know, it's still the similar because IPv six is internet brokly. It's good for us in the long run but you don't get an immediate trigger, right? No stop apple by deploying it now, but it's good for the future. So.48:12Definitely with that. However, it doesn't end here today. So I created a Webex room, and this Webex room, it's called everything you always wanted to know about IPV six, but you know what? I'm still, you know, nicole, I'm scared a little bit. Can I ask questions? Well, in this room, you can.48:29Ask any questions and I post from time to time some IPV six stuff there. I would highly recommend joining this Webex room.48:49And and and learn, and don't be afraid there are NO stupid questions because by the end of the day, if you don't ask the question, how can you learn, right? So that's, that's the most important thing. And if you're really enjoying my, my IPv six talks you can follow me on LinkedIn. Don't be afraid.48:57I'm happy to accept any invites. I'll check a little bit, at least if you.49:17Are not a bot, so just to let you know, but with that, I would say, oh, yeah, next week because IPv six in action in the network, so that's happening on 25 March around the same time because that's the last week before Europe goes into summertime. So that's the most.49:22Important key. And with that I would say are there any questions?49:42Silence is always good or not. No questions on chat. Yes. Thank you Nicole for the great presentation today. And like Nicole mentioned, we have two more sessions on this series. We invite you to join the next.49:53One on next Wednesday, the same time and for those of you who may have missed the previous session, we have a recording of for that posted on the.50:13Cisco website, we will share them shortly. But if there's any questions for Nicole now, please feel free to raise your hand and I'll unmute you to ask your question.50:29It's I'm raising my hand. Good. See, everybody's running to buy vocally now, you know, but thank you thank you Nicole again for your great, for the great presentation. I personally learned good things here.50:48And we look forward to upcoming sessions in in a week's time. Thank you, everybody. Have a great time ahead. Thank you, Bhuvana. Thank you. Thank you. Bye bye.51:08

About this Video

Author : Cisco Customer Success

Uploaded : March 25, 2026

Service ProviderIOS XR FCM
AI summary icon

AI summary

Discover how Cisco IOS XR networks can accelerate the transition to IPv6 with standards-driven design. The recording demystifies key RFCs behind behavior and reachability—RFC 6724 default address and source selection, Happy Eyeballs (RFC 8305), and the path from dual-stack to IPv6-Only and IPv6 Mostly. It explains how SLAAC, DNS64 and NAT64, and 464XLAT work together, plus why DHCPv4 Option 108 (RFC 8925) smooths adoption across mixed clients. See practical guidance to validate IPv6 first, avoid ULA pitfalls, and measure real traffic gains as major content turns IPv6-first.

  • Learn how to plan and deploy IPv6 Mostly and IPv6-Only using SLAAC, DNS64 and NAT64, and 464XLAT.
  • Understand default address selection and Happy Eyeballs to troubleshoot client behavior and fast fallbacks.
  • Apply RFC 8925 (DHCPv4 Option 108) to prioritize IPv6 while preserving access to IPv4-only services.