Guest

Cisco Unified Communications Manager (CallManager)

NEC 2400 ICS PBX with CallManager using 3640-E1 MGCP Gateway

 Feedback

Table Of Contents

Application Note

Introduction

Network Diagram

Limitations

Calling Name and Number Feature

System Components

Hardware Requirements

Software Requirements

Feature

Configuration

NEC 2400 ICS Configuration

Route (ARTD) Configuration

Cisco ISDN PRI Configuration

Route Pattern Configuration

MGCP (3640) Gateway Configuration

Appendix A

CallManager Software Release

NEC Software release:

CallManager Components Release

Cisco 3640 Router Configuration

Test Configuration

Test Results


Application Note


NEC 2400 ICS PBX with CallManager using 3640-E1 MGCP Gateway

This application note illustrates connectivity for NEC 2400 ICS PBX with CallManager using 3640-E1 MGCP Gateway.

Introduction

The network topology diagram presented in Figure 1 illustrates the test set-up for end-to-end interoperability between the Cisco CallManager connected to the PBX via 3640-E1 link as MGCP Gateway.

Key test environment parameters:

Calling Name delivery and presentation features are not supported by the NEC 2400 ICS PBX.

Calling Number is displayed when calling either direction as expected. The Connected Number is not returned by CallManager nor NEC. This was verified using an ISDN protocol analyzer.

Connectivity is achieved by using the industry standard ETSI protocol. Though the NEC 2400 ICS can be configured as either NETWORK (Master) or USER (Slave) side, configuration as NETWORK is not recommended. The NEC TAC center will not resolve a case presented with NEC set as the NETWORK side.

Network Diagram

Figure 1

Network Test Topology

Limitations

Calling Name and Number Feature

1. Calling Name delivery and presentation features are not supported by the NEC 2400 ICS PBX.

2. Returning the Connected Number in the Connect message is not supported by CallManager nor NEC.

System Components

Hardware Requirements

Cisco Hardware:

Cisco 3640 Gateway with 2MFT E1 Port

Cisco Cat6K switch

Cisco CallManager 3.2

NEC 2400 ICS PBX:

Hardware: PA-30PRTB

Software Requirements

Cisco IOS software releases "c3640-js-mz.122-2.XN"

PBX Software:VERSION ISSUE DATE

J 05.80 00/06/20 Generic

F 01.00 96/04/26 Boot ROM

Cisco CallManager 3.2

Feature

Key features supported:

Calling Number

Key features not supported:

Connected Number

Calling/Called Name

Configuration

Configuration tasks consist of:

1. NEC 2400 ICS Configuration

2. Route (ARTD) Configuration

3. Cisco ISDN PRI Configuration

4. Route Pattern Configuration

5. MGCP (3640) Gateway Configuration

NEC 2400 ICS Configuration

The NEC requires a substantial amount of programming and circuit card switch settings to properly install E1 PRI. It is beyond the scope of this document to provide the entire configuration, therefore the NEC information below is mostly helpful for NEC techs. If further assistance is required, the entire configuration of our lab PBX can be found in EDCS document # EDCS-207455. The EDCS document provides the programs required for E1 ISDN circuit setup, all the switch settings for all cards on our Lab NEC and fairly complete configuration listings (List Ups).

The switch settings and software references in the EDCS document assume a familiarity with the NEC 2400. It is highly recommended to have a NEC ISDN certified technician setup the NEC portion.

Configure in the following sequence:

1. Install circuit card.

2. Configure all software.

Table 1  Circuit Card Configuration (PA-30PRTB)

Switch
Position
Description
Setting
SW00
 

Make Busy

Down

SW01

0

All Channel Make Busy

Off

 

1

External Loop Back

Off

 

2

Internal Loop Back

Off

 

3

Dch Handler Make Busy

Off

SW02 (SENSE - Rotary)
 

1 = AT&T
2 = Australia
3 = NTT Japan
4 = NEC/ETSI
5 = AT&T
6 = INS
A = Q.SIG

4

SW10

Jumper

Off = Coax
On = Twisted Pair

On

SW11

Jumper

Off = Coax
On = Twisted Pair

On

SW12

Jumper

Off = Coax
On = Twisted Pair

On

SW13

1

On = PAD ROM Special Version
Off = PAD ROM Standard Version

Off

 

2

On = ISDN BUS Not Used
Off = ISDN BUS Used

On

 

3

Not Used

Off

 

4

Not Used

Off

SW14

1

On = CCITT Signaling
Off =CEPT Signaling

On

 

2

On = Alarm Release: 2sec (Aus)
Off = Alarm Release 15 Sec.

On

 

3

PAD

On

 

4

PAD

On

 

5

PAD

On

 

6

PAD

On

 

7

PAD

On

 

8

Fixed Off

Off

SW15

1

Loopback Pattern
Off = Loopback inhibited

Off

 

2

Loopback Pattern
Off = Loopback inhibited

Off

 

3

Loopback Pattern
Off = Loopback inhibited

Off

 

4

Loopback Pattern
Off = Loopback inhibited

Off

 

5

TS16 Control:
On = Data Through (CCIS/ ISDN)
Off = Signaling

On

 

6

On = No CRC4
Off = CRC4

Off

 

7

Firmware (CCITT/China/Thailand/Aux)

On

 

8

Firmware (CCITT/China/Thailand/Aux)

On

SW16

1

Fixed Off

Off

 

2

Fixed Off

Off

 

3

All "1" Supervision
On = To be controlled
Off = Not to be controlled

Off

 

4

On = Dch User Side
Off = Dch Network Side

On

 

5

On = Dch NegativeLogic
Off = Dch Positive Logic

Off

 

6

On = Dch Packet Service On
Off = Dch Packet Service Off

Off

 

7

Fixed Off

Off

 

8

Fixed Off

Off

       

Route (ARTD) Configuration

Below are the Route settings found in ARTD. Route 12 is the B channel and Route 13 is the D channel. Please refer to EDCS document # EDCS-207455 for complete details for configuration.


    [LRTD]                CISCO TEST FACILITY      02/05/10         PAGE:  5

              *  ROUTE CLASS DATA LIST  *

                 -------  R O U T E     N U M B E R  -------
 CDN FUNCTION     11        12        13        14        15   

   1  OSGS         7         0         0         0         0
   2  ONSG         3         2         0         2         2
   3  ISGS         7         0         0         0         0
   4  INSG         3         2         0         2         2
   5   TF          3         3         3         3         3

   6   TCL         4         4         4         4         4
   7   L/T         1         1         1         1         1
   8   RLP         2         2         0         2         0
   9   TQ          0         0         0         0         0
  10  SMDR         0         1         1         1         1

  11   TD          0         0         0         0         0
  12   DR          0         0         0         0         0
  13   AC          1         1         0         1         0
  14   TNT         0         0         0         0         0
  15   LSG         5        12        13        12        13

  16 SMDR2         0         0         0         0         0
  17   H/M         0         0         0         0         0
  18   MC          0         0         0         0         0
  19   ANI         0         1         1         1         0
  20   D           0         0         0         0         0

  21   MSB         0         0         0         0         0
  22   MSW         0         0         0         0         0
  23   TR          0         0         0         0         0
  24   OC          0         0         0         0         0
  25   R/L         0         0         0         0         0

  26  RVSD         0         0         0         0         0
  27   TL          0         0         0         0         0
  28   ANS         0         1         1         1         1
  29  TELP         0         0         0         0         0
  30   PAD         0         4         7         4         7

  31  OGRL         0         1         1         1         1
  32  ICRL         0         1         1         1         1
  33   HD          0         0         0         0         0
  34 GUARD         0         1         1         1         1
  35  WINK         0         0         0         0         0

  36   VAD         0         0         0         0         0
  37   CLD         0         0         0         0         0
  38   FA          0         0         0         0         0

 [LRTD]                CISCO TEST FACILITY      02/05/10         PAGE:  6

              *  ROUTE CLASS DATA LIST  *

                 -------  R O U T E     N U M B E R  -------
 CDN FUNCTION     11        12        13        14        15   

  39   BC          0         0         0         0         0
  40   TCM         0         0         0         0         0
  41  TDMQ         0         0         0         0         0
  42  TRSC         0         0         0         0         0
  43   BT          0         1         0         1         1

  44   PRV         0         0         0         0         0
  45   A/D         0         1         1         1         1
  46   CW          0         0         0         0         0
  47   TPQ         0         0         0         0         0
  48   BL          0         0         0         0         0

  49  TRKS         0         1         1         0         0
  50  DPLY         0         1         1         1         1
  51   ACD         0         0         0         0         0
  52 2W/4W         1         0         0         0         0
  53  FAAT         0         0         0         0         0

  54   GW          0         0         0         0         0
  55  TCMA         0         0         0         0         0
  56 SMDR3         0         0         0         0         0
  57   HDT         0         0         0         0         0
  58    CD         0         0         0         0         0

  59   CCH         0         0         0         0         0
  60 TC/EC         0         0         0         0         0
  61   IRE         0         0         0         0         0
  62   SCR         0         0         0         0         0
  63 LYER1         0         1         1         1         1

  64   NET         0         1         0         0         0
  65   INT         0         4         4         4         4
  66    DC         0         4         4         4         4
  67   HKS         0         0         0         0         0
  68   SCF         0         0         0         0         0

  69 SMDR4         0         0         0         0         0

Cisco ISDN PRI Configuration

Route Pattern Configuration

MGCP (3640) Gateway Configuration

Appendix A

CallManager Software Release

NEC Software release:


DISS        02/05/10 16:06    CISCO TEST FACILITY 
MM
VERSION   ISSUE     DATE
  J       05.80   00/06/20  Generic      
MM
VERSION   ISSUE     DATE
  F_       01.00   96/04/26  Boot ROM     

DISS   END  02/05/10 16:07

CallManager Components Release

Cisco 3640 Router Configuration


MGCP_3640#sh ver
Cisco Internetwork Operating System Software 
IOS (tm) 3600 Software (C3640-JS-M), Experimental Version 12.2(20020124:013600) 
[accheung-v122_xn_throttle.build 101]
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Wed 23-Jan-02 17:57 by accheung
Image text-base: 0x60008948, data-base: 0x61608000

ROM: System Bootstrap, Version 11.1(19)AA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

MGCP_3640 uptime is 1 hour, 40 minutes
System returned to ROM by power-on
System image file is "flash:c3640-js-mz"

cisco 3640 (R4700) processor (revision 0x00) with 58368K/7168K bytes of memory.
Processor board ID 10620494
R4700 CPU at 100Mhz, Implementation 33, Rev 1.0
Channelized E1, Version 1.0.
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
Primary Rate ISDN software, Version 1.1.
2 Ethernet/IEEE 802.3 interface(s)
55 Serial network interface(s)
2 Channelized E1/PRI port(s)
2 Channelized T1/PRI port(s)
2 Voice FXO interface(s)
2 Voice FXS interface(s)
DRAM configuration is 64 bits wide with parity disabled.
125K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)
16384K bytes of processor board PCMCIA Slot0 flash (Read/Write)

Configuration register is 0x2102




MGCP_3640#sh diag
Slot 0:
Combo 2E, 2W Port adapter, 4 ports
Port adapter is analyzed 
Port adapter insertion time unknown
EEPROM contents at hardware discovery:
Hardware revision 1.2         Board revision B0
Serial number     7687836   Part number    800-01171-04
Test history      0x0         RMA number     00-00-00
EEPROM format version 1
EEPROM contents (hex):
  0x20: 01 1E 01 02 00 75 4E 9C 50 04 93 04 00 00 00 00
  0x30: 58 00 00 00 98 02 28 17 FF FF FF FF FF FF FF FF

Slot 1:
High Density Voice Port adapter
Port adapter is analyzed 
Port adapter insertion time unknown
EEPROM contents at hardware discovery:
Hardware Revision        : 1.1
Top Assy. Part Number    : 800-03567-01
Board Revision           : F1
Deviation Number         : 0-0
Fab Version              : 02
 PCB Serial Number        : JAB05080M1S
RMA Test History         : 00
RMA Number               : 0-0-0-0
RMA History              : 00
EEPROM format version 4
EEPROM contents (hex):
  0x00: 04 FF 40 00 CC 41 01 01 C0 46 03 20 00 0D EF 01
  0x10: 42 46 31 80 00 00 00 00 02 02 C1 8B 4A 41 42 30
  0x20: 35 30 38 30 4D 31 53 03 00 81 00 00 00 00 04 00
  0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

WIC Slot 0:
E1 (2 Port) Multi-Flex Trunk WAN Daughter Card
Hardware revision 1.0         Board revision B0
Serial number     18779824  Part number    800-04479-01
Test history      0x0         RMA number     00-00-00
Connector type    PCI
EEPROM format version 1
EEPROM contents (hex):
   0x20: 01 23 01 00 01 1E 8E B0 50 11 7F 01 00 00 00 00
  0x30: 58 00 00 00 00 02 25 00 FF FF FF FF FF FF FF FF

HDV firmware: Compiled Fri 23-Mar-01 00:20 by miriyala
HDV memory size 524280 heap free 175065

Slot 2:
4 PORT Voice PM for MARs Port adapter
Port adapter is analyzed 
Port adapter insertion time unknown
EEPROM contents at hardware discovery:
Hardware revision 1.1         Board revision C0
Serial number     10689987  Part number    800-02491-02
Test history      0x0         RMA number     00-00-00
EEPROM format version 1
EEPROM contents (hex):
  0x20: 01 65 01 01 00 A3 1D C3 50 09 BB 02 00 00 00 00
  0x30: 60 00 00 00 98 11 22 17 FF FF FF FF FF FF FF FF

WIC Slot 0:
FXS Voice daughter card (2 port)
Hardware revision 1.1         Board revision C0
Serial number     11291019  Part number    800-02493-01
 Test history      0x0         RMA number     00-00-00
Connector type    Wan Module
EEPROM format version 1
EEPROM contents (hex):
  0x20: 01 0E 01 01 00 AC 49 8B 50 09 BD 01 00 00 00 00
  0x30: 60 00 00 00 99 01 05 01 FF FF FF FF FF FF FF FF

WIC Slot 1:
FXO Voice daughter card (2 port)
Hardware revision 1.1         Board revision C0
Serial number     8421533   Part number    800-02495-01
Test history      0x0         RMA number     00-00-00
Connector type    Wan Module
EEPROM format version 1
EEPROM contents (hex):
  0x20: 01 0D 01 01 00 80 80 9D 50 09 BF 01 00 00 00 00
  0x30: 60 00 00 00 98 06 02 01 FF FF FF FF FF FF FF FF

Slot 3:
High Density Voice Port adapter
Port adapter is analyzed 
Port adapter insertion time unknown
EEPROM contents at hardware discovery:
 Hardware Revision        : 1.0
Top Assy. Part Number    : 800-03567-01
Board Revision           : A0
Deviation Number         : 0-0
Fab Version              : 02
PCB Serial Number        : JAB03350B9K
RMA Test History         : 00
RMA Number               : 0-0-0-0
RMA History              : 00
EEPROM format version 4
EEPROM contents (hex):
  0x00: 04 FF 40 00 CC 41 01 00 C0 46 03 20 00 0D EF 01
  0x10: 42 41 30 80 00 00 00 00 02 02 C1 8B 4A 41 42 30
  0x20: 33 33 35 30 42 39 4B 03 00 81 00 00 00 00 04 00
  0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
  0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

WIC Slot 0:
T1 (2 Port) Multi-Flex Trunk (Drop&Insert) WAN Daughter Card
Hardware revision 1.0         Board revision A0
 Serial number     19621702  Part number    800-04614-02
Test history      0x0         RMA number     00-00-00
Connector type    PCI
EEPROM format version 1
EEPROM contents (hex):
  0x20: 01 24 01 00 01 2B 67 46 50 12 06 02 00 00 00 00
  0x30: 50 00 00 00 00 05 20 00 FF FF FF FF FF FF FF FF

HDV firmware: Compiled Fri 23-Mar-01 00:20 by miriyala
HDV memory size 524280 heap free 175065

MGCP_3640#sh controller e1
E1 1/0 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20010315, FPGA: 15
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (11 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  E1 1/1 is down.
  Applique type is Channelized E1 - balanced
  Far End Block Errors Detected
  Receiver has loss of signal.
  alarm-trigger is not set
  Version info Firmware: 20010315, FPGA: 15
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (12 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 12 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 12 Unavail Secs


MGCP_3640# sh conf
Using 2266 out of 129016 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service dhcp
!
hostname MGCP_3640
!
logging rate-limit console 10 except errors
!
!
!
voice-card 1
!
voice-card 3
!
ip subnet-zero
!
!
!
no ip dhcp-client network-discovery
mgcp
mgcp call-agent 10.1.1.2 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode cisco
mgcp sdp simple
mgcp package-capability rtp-package
mgcp package-capability sst-package
no mgcp timer receive-rtcp
no mgcp explicit hookstate
isdn switch-type primary-ni
call rsvp-sync
!
!
!
!
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 10.1.1.2
ccm-manager config
!
!
controller E1 1/0
 pri-group timeslots 1-31 service mgcp
!
controller E1 1/1
!
controller T1 3/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 3/1
 framing sf
 linecode ami
!
!
!
interface Ethernet0/0
 ip address 10.1.1.200 255.255.255.0
 no ip mroute-cache
 half-duplex
!
interface Ethernet0/1
 ip address 171.69.231.23 255.255.255.0
 no ip mroute-cache
 half-duplex
!
interface Serial1/0:15
 no ip address
 no logging event link-status
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn T310 4000
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial3/0:23
 no ip address
 no logging event link-status
 isdn switch-type primary-ni
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn T306 30000
 isdn T310 40000
 isdn bind-l3 ccm-manager
 no cdp enable
!
ip classless
no ip http server
!
!
!
!
snmp-server manager
!
voice-port 1/0:15
!
voice-port 2/0/0
!
voice-port 2/0/1
!
voice-port 2/1/0
!
voice-port 2/1/1
!
voice-port 3/0:23
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 application mgcp
!
dial-peer voice 3 pots
 application mgcpapp
 port 2/0/1
!
dial-peer voice 2 pots
 application mgcpapp
 port 2/0/0
!
dial-peer voice 999200 pots
 application mgcpapp
 port 2/0/0
!
dial-peer voice 9991015 pots
 application mgcpapp
 port 1/0:15
!
dial-peer voice 9993023 pots
application mgcpapp
 port 3/0:23
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

MGCP_3640#sh run
Building configuration...

Current configuration : 2266 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service dhcp
!
hostname MGCP_3640
!
logging rate-limit console 10 except errors
!
!
!
voice-card 1
!
voice-card 3
!
ip subnet-zero
!
!
!
no ip dhcp-client network-discovery
mgcp
mgcp call-agent 10.1.1.2 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode cisco
mgcp sdp simple
mgcp package-capability rtp-package
mgcp package-capability sst-package
no mgcp timer receive-rtcp
no mgcp explicit hookstate
isdn switch-type primary-ni
call rsvp-sync
!
!
!
!
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 10.1.1.2
ccm-manager config
!
!
controller E1 1/0
 pri-group timeslots 1-31 service mgcp
!
controller E1 1/1
!
controller T1 3/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 3/1
 framing sf
 linecode ami
!
!
!
interface Ethernet0/0
 ip address 10.1.1.200 255.255.255.0
 no ip mroute-cache
 half-duplex
!
interface Ethernet0/1
 ip address 171.69.231.23 255.255.255.0
 no ip mroute-cache
 half-duplex
!
interface Serial1/0:15
 no ip address
 no logging event link-status
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn T310 4000
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial3/0:23
 no ip address
 no logging event link-status
 isdn switch-type primary-ni
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn T306 30000
 isdn T310 40000
 isdn bind-l3 ccm-manager
 no cdp enable
!
ip classless
no ip http server
!
!
!
!
snmp-server manager
!
voice-port 1/0:15
!
voice-port 2/0/0
!
voice-port 2/0/1
!
voice-port 2/1/0
!
voice-port 2/1/1
!
voice-port 3/0:23
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 application mgcp
!
dial-peer voice 3 pots
 application mgcpapp
 port 2/0/1
!
dial-peer voice 2 pots
 application mgcpapp
 port 2/0/0
!
dial-peer voice 999200 pots
 application mgcpapp
 port 2/0/0
!
dial-peer voice 9991015 pots
 application mgcpapp
 port 1/0:15
!
 dial-peer voice 9993023 pots
 application mgcpapp
 port 3/0:23
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

MGCP_3640#


Test Configuration

Figure 2

Test Topology

As shown in the diagram above, a NEC 2400 ICS PBX was connected via an ISDN E1 PRI link to a Cisco 3640 Gateway, which in turn, was connected to an Ethernet switch. The interoperability testing involved Layers 1, 2 and 3 on the ISDN PRI link between a Cisco 3640 and the PBX.

Layers 2 & 3 (Q.921 and Q.931)

Layer 2 and 3 packet exchanges were monitored using an Acacia Clarinet protocol analyzer, bridged across the PRI link in high impedance mode.

Layer 2 Q.921 packets were monitored to ensure that each PBX/3640 software configuration properly exchanged SABME/UA packets to initialize the ISDN link, and then RR packets were exchanged every 30 seconds.

Layer 3 Q.931 packets were monitored to ensure that the appropriate call setup/teardown packets were exchanged for each configuration, and that the SETUP packets contained the mandatory Information Elements with the necessary details, as well as optional IEs such as Calling Name and Number.

Telephone calls were made end-to-end in both directions through the Cisco 3640 Gateway, and a check was made to ensure that there was an audio path in both directions for each call.

User/Network Settings

The Cisco 3640 Gateway with ISDN protocol type setting of PRIMARY-NET5 supports both protocol sides by selecting "Network/User" in the protocol side field when configuring the Gateway via Callmanager.

Though the NEC 2400 ICS can be configured as either NETWORK (Master) or USER (Slave) side, configuration as NETWORK is not recommended. The NEC TAC center will not resolve a case presented with NEC set as the NETWORK side.

Test Results

Testing was performed by Test Engineer(s): Samir Batio and Bob Graves, March 11, 2002

Test Setup

Test configuration:

PBX1 configured as ETSI, emulates Network

Cisco 3640 Gateway configured as primary-net5, emulates User


Note: Configurations show PBX1 as Network with Cisco 3640 as User. Tests were actually performed both ways, but only the PBX-User results are provided because NEC does not officially support Network configuration.


Table 2  Test Setup Switch and Gateway Settings

NEC 2400 ICS Switch-type// Protocol -side Setting
Cisco 3640 ISDN Protocol-type/Protocol-side Setting

ETSI/User

isdn switch-type primary-net5

isdn protocol-emulate Network


Table 3  Basic Calls: (Enbloc Sending)

Calls Made
Call Comp?
"Calling Number" Passed to Final Destination?
"Calling Name" Passed to Final Destination?
"Called Number" Passed to Orig. Side?
"Called Name" Passed to Orig. Side?
Notes
Phone A to Phone C

Yes

Yes

No

No

No

 
Phone C to Phone A

Yes

Yes

No

Yes

No

 

Table 4  Basic Calls: (FXS Port)

Calls Made
Call Comp?
"Number" Displayed on the digital phone?
"Name" Displayed on the digital phone?
Notes
Phone E to Phone A

Yes

Yes

No

 
Phone A to Phone E

Yes

No

No

 
Phone E to Phone C

Yes

Yes

Yes

 
Phone C to Phone E

Yes

Yes

Yes

 

Table 5  Call Transfers: (Supervised Local Transfers)

Calls Made
Call Comp?
Orig. "Calling Number" displayed on Final Dest. phone?
Orig. "Calling Name" displayed on Final Dest. phone?
"Called Number" display on Orig. phone updated after transfer?
"Called Name" display on Orig. phone updated after transfer?
Notes
Phone C to Phone A Xfr to Phone B

Yes

Yes

No

No

No

 
Phone A to Phone C Xfr to Phone D

Yes

Yes

No

No

No

 

Table 6  Call Conferencing (Local)

Calls Made
Call Comp?
"Calling Number" passed to remaining conferee when the conferencing phone drops out?
"Calling Name" passed to remaining conferee when the conferencing phone drops out?
"Connected Number" updated on Orig. Caller phone display when a conferee drops out?
"Connected Name" updated on Orig. Caller phone display when a conferee drops out?
Notes
Phone C to Phone A, Phone A conf Phone B

Yes

(A Drops out) Yes

(A Drops out) No

(A Drops out) No

(A Drops out) No

 
Phone C to Phone A, Phone C conf Phone D

Yes

(C Drops out) No

(C Drops out) No

(D Drops out) No

(D Drops out) No

 
Phone A to Phone C, Phone C conf Phone D

Yes

(C Drops out) No

(C Drops out) No

(C Drops out) No

(C Drops out) No

 
Phone A to Phone C, Phone A conf Phone B

Yes

(A Drops out) No

(A Drops out) No

(B Drops out) No

(B Drops out) No

 

Table 7  Call Forward (Local)

Calls Made
Call Comp?
Original "Calling Number" passed to Final Dest.?
Original "Calling Name" passed to Final Dest.?
Forwarding "Called Number" passed to Final Dest.?
Forwarding "Called Name" passed to Final Dest.?
Final dest. "Connected Number" updated at orig. side?
Final dest. "Connected Name" updated at orig. side?
Notes
Phone C to Phone A fwd to Phone B

Yes

Yes

No

Yes

No

No

No

 
Phone A to Phone C fwd to Phone D

Yes

Yes

No

Yes

No

No

No