Guest

Cisco Unified Communications Manager (CallManager)

Alcatel 4400 Rel 3.2 PBX with CallManager using 2621-E1 PRI-NET5 Gateway

 Feedback

Table Of Contents

Application Note

Integration Description

Cisco Systems Equipment needed

PBX Hardware and Software Requirements

Features Supported

Network Diagram

Configuring the Alcatel 4400 PBX

Configure Board

Configure Digital Access Options

Configure Trunk Group

Configure Trunk Detail

Configuring Cisco CallManager

H.323 (Cisco 2621) Gateway Configuration

Route Pattern Configuration

Considerations

Calling Name and Number Feature

Appendix A

CallManager Software Release

Alcatel 4400 Software Version

Cisco 2621 Router Configuration

Test Configuration

Test Results


Application Note


Alcatel 4400 Rel 3.2 PBX with CallManager using 2621-E1 PRI-NET5 Gateway

This application note illustrates connectivity for Alcatel 4400 Release 3.2 PBX with Cisco CallManager using Cisco 2621-E1 PRI-TE5 Gateway.

Integration Description

Connectivity is achieved using the ETSI standard PRI protocol. The Alcatel 4400 can be configured as either NETWORK or USER side.

Cisco Systems Equipment needed

Hardware (Gateway): Cisco 2621 with 2MFT E1 Port

Software: CallManager Release 3.1

PBX Hardware and Software Requirements

Hardware: PRA2, 3BA23076

Software: Version R3.2

Features Supported

Key features supported:

Calling/Called Number

Key features not supported:

Calling/Called Name

Network Diagram

Figure 1

Network Test Topology

Configuring the Alcatel 4400 PBX

Configure in the following sequence:

1. "Configure Board" on page 3

2. "Configure Digital Access Options" on page 3

3. "Configure Trunk Group" on page 4

4. "Configure Trunk Detail" on page 5

Configure Board

Interface type must be set to PRA2.

\compidea\Shelf::0\Board::3

          Board Address                           3
          Interface Type                          PRA2
          Usage State                             Busy
          Operational State                       Enabled
          Main/Standby State                      Main (Master)
          Number Of Sets Being Connect.           1
          CRC4                                    YES
          Country Protocol Type                   USA
          Incidents Teleservice                   YES
          ISDN Board Layer 2 Parameters 
                Retransmission Timer              100
                TEI Identity Check Timer          100
                Polling Timer                     1000
                Nb_Of_Retransmission              3
                Max Frame Size (Bytes)            260
                Window Size In Frames SAPI S T0   1
                Window Size In Frames SAPI P T0   3
                Window Size In Frames SAPI S T2   7
                Window Size In Frames SAPI P T2   7
          Passive board                           NO
          SS7 signalling                          NO

Configure Digital Access Options

Network mode must be set to Yes for (Master/Network) or No - (Slave/User).

Access Type must be set to T2.


\compidea\Shelf::0\Board::3\Digital Access::0

          T0/T2 Access No.                  0
          Access Type                       T2
          Synchronisation Priority          255
          Network Mode                      YES
          Max Nb Of Used B Channels         30
          Max_Nb_Of_Compressed_B_Channels   0
          TieLine Mode                      NO
          With Alarm                        NO
          Reserved1                         YES
          Reserved2                         YES
          Network Date Time Update          NO
          CRC4                              

Configure Trunk Group

Q931 signal variant is used to set the protocol type to ISDN all countries.

\compidea\Trunk Groups::0

          Trunk Group Id                       0
          Trunk Group Type                     T2
          Trunk Group Name                     PRA2_EURO
          Node number                          1
          Transcom Trunk Group                 False
          Auto.reserv.by Attendant             False
          Overflow trunk group No.             -1
          Tone on seizure                      True
          Private Trunk Group                  False
          Q931 signal variant                  ISDN all countries
          Number Compatible With               -1
          Number Of Digits To Send             4
          Channel selection type               Quantum
          Remote Network                       15
          Shared Trunk Group                   False
          auto.DTMF dialing on outgoing call   NO
          T2 Specificity                       None
          Public Network Category              0
          DDI transcoding                      False
          Special Services                     Nothing
          Can support UUS in SETUP             True

Configure Trunk Detail

\compidea\Trunk Groups::0\Trunk Group::1

          Instance (reserved)                  1
          Trunk Group Type                     T2
          Public Network Ref. 
          Dialling end to end                  NO
          DTMF end to end signal.              NO
          Trunk group used in DISA             NO
          DISA Secret Code 
          VG for non-existent No.              YES
          Routing To Executive                 NO
          Trunk Category Id                    19
          Nb of digits unused (ISDN)           0
          B Channel Choice                     YES
          Channels Reserved By Attend.         0
          Dissuasion For ACD                   NO
          DTO joining                          NO
          Enquiry Call On B Channel            NO
          Automated Attendant                  NO
          Calling party Rights category        0
          Entity Number                        0
          TS Overflow                          YES
          Number To Be Added 
          Supervised by Routing                NO
          VPN Cost Limit for Incom.Calls       0
          Immediat Trk Listening For VPNCall   YES
          VPN TS %                             50
          Csta Monitored                       NO
          Max.% of trunks out CCD              0
          Charge Calling And ADN Creation      NO
          Ratio analog.to ISDN tax 
          LogicalChannel                       1__15 & 17__31
          TS Distribution on Accesses          YES
          Use Split Acces                      NO
          Heterogeneous Remote Network         NO
          Barring mode                         Not barred
          ARS class of service                 31
          Quality profile for voice on IP      Profile #1
          IP compression type                  Default
          Use of volume in system              YES

Configuring Cisco CallManager

H.323 (Cisco 2621) Gateway Configuration

Route Pattern Configuration

Considerations

Calling Name and Number Feature

Calling Name delivery and presentation features are not supported by the Alcatel 4400 PBX.

When configuring Cisco 2621 (H.323) Gateway to emulate User side (Alcatel emulate Network side), make sure that the "Display IE Delivery" box is NOT checked in CallManager H.323 Gateway Configuration, otherwise calls will not be completed. Alcatel PBX complains about the Caller ID Display information being sent in the "SETUP" message from CallManager by sending STATUS message with cause of "IE non-existent/unimplemented".

When calling from Cisco 7960 IP phone to Alcatel digital phone, Calling/Called Number is displayed on both phones after the call is answered as expected.

When calling from Alcatel digital phone to Cisco 7960 IP phone, IP phone displays Connected Number after the call is answered. Alcatel phone however does NOT get updated when the call is answered. It displays the trunk name. It was verified using ISDN protocol analyzer that the CallManager was not sending "Connected Number" information in the connect message back to PBX.

Appendix A

CallManager Software Release

Alcatel 4400 Software Version

Version Information

\compidea\Node

          Node Number (reserved)   1
          Software Version         R3.2
          Version name             c1.712
          Patch No.                5
          Notes 
          Object Identity 
          Node Number (reserved)   1
          Ethernet Notes 
                Netmask 
                Local CPU 
                      Name         x000000_tun
                      IP Address   172.30.253.253
                Twin Cpu 
                      Name 
                      IP Address 
                Main Cpu 
                      Name         xm000000
                      IP Address   10.253.253.3
                StandBy Cpu 
                      Name 
                      IP Address 
          SL Notes 
          IP/X25 Tunnel Notes 
                Netmask            255.255.0.0
                Local Node 
                      Name         x000000_tun
                      IP Address   172.30.253.253

Cisco 2621 Router Configuration


2621_B#sh version
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-JS-M), Version 12.2(3.5)T,  MAINTENANCE INTERIM S
OFTWARE
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Fri 03-Aug-01 22:45 by ccai
Image text-base: 0x80008088, data-base: 0x81631DD8

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

2621_B uptime is 16 hours, 6 minutes
System returned to ROM by power-on
System image file is "flash:c2600-js-mz.122-3.5.T"

cisco 2621 (MPC860) processor (revision 0x200) with 56320K/9216K bytes of memory
.
Processor board ID JAD051516TX (503811939)
M860 processor: part number 0, mask 49
Channelized E1, Version 1.0.
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
Primary Rate ISDN software, Version 1.1.
2 FastEthernet/IEEE 802.3 interface(s)
31 Serial network interface(s)
2 Channelized E1/PRI port(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102
2621_B#


2621_B#sh diag
Slot 0:
        C2621 2FE Mainboard Port adapter, 2 ports
        Port adapter is analyzed
        Port adapter insertion time unknown
        EEPROM contents at hardware discovery:
        Hardware Revision        : 2.0
        PCB Serial Number        : JAD051516TX (503811939)
        Part Number              : 73-3200-08
        RMA History              : 00
        RMA Number               : 0-0-0-0
        Board Revision           : A0
        Deviation Number         : 0-21249
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 00 A2 41 02 00 C1 17 4A 41 44 30 35 31
          0x10: 35 31 36 54 58 20 28 35 30 33 38 31 31 39 33 39
          0x20: 29 82 49 0C 80 08 04 00 81 00 00 00 00 42 41 30
          0x30: 80 00 00 53 01 FF FF FF FF FF FF FF FF FF FF FF
          0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

Slot 1:
        High Density Voice Port adapter
        Port adapter is analyzed
        Port adapter insertion time unknown
        EEPROM contents at hardware discovery:
        Hardware Revision        : 1.1
        Top Assy. Part Number    : 800-03567-01
        Board Revision           : F1
        Deviation Number         : 0-0
        Fab Version              : 02
        PCB Serial Number        : JAB05080LU9
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 00 CC 41 01 01 C0 46 03 20 00 0D EF 01
          0x10: 42 46 31 80 00 00 00 00 02 02 C1 8B 4A 41 42 30
          0x20: 35 30 38 30 4C 55 39 03 00 81 00 00 00 00 04 00
          0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        VIC Slot 0:
        E1 (2 Port) Multi-Flex Trunk WAN Daughter Card
        Hardware revision 1.0           Board revision B0
        Serial number     18801733      Part number    800-04479-01
        Test history      0x0           RMA number     00-00-00
        Connector type    PCI
        EEPROM format version 1
        EEPROM contents (hex):
          0x20: 01 23 01 00 01 1E E4 45 50 11 7F 01 00 00 00 00
          0x30: 58 00 00 00 00 03 09 00 FF FF FF FF FF FF FF FF

        HDV firmware: Compiled Fri 23-Mar-01 00:20 by miriyala
        HDV memory size 524280 heap free 175065


2621_B#

2621_B#sh controllers e1 1/0
E1 1/0 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20010710, FPGA: 15
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (71 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
2621_B#


2621_B#sh configuration
Using 1813 out of 29688 bytes
!
version 12.2
no parser cache
service timestamps debug datetime msec localtime show-timezone
service timestamps log uptime
no service password-encryption
!
hostname 2621_B
!
no logging buffered
enable password cisco
!
!
!
memory-size iomem 15
voice-card 1
 dspfarm
!
ip subnet-zero
!
!
no ip domain-lookup
!
isdn switch-type primary-net5
!
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
 codec preference 3 g711alaw
!
!
!
!
!
!
!
controller E1 1/0
 pri-group timeslots 1-31
!
controller E1 1/1
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.100.2 255.255.255.0
 no ip mroute-cache
 load-interval 30
 no keepalive
 speed auto
 half-duplex
!
interface FastEthernet0/1
 ip address 10.1.1.129 255.255.255.0
 no ip mroute-cache
 duplex auto
 speed auto
!
interface Serial1/0:15
 no ip address
 no logging event link-status
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn T321 40000
 isdn T203 30000
 isdn T306 60000
 isdn T310 30000
 isdn bchan-number-order ascending
 no cdp enable
!
router rip
 network 1.0.0.0
 network 192.168.100.0
!
ip classless
no ip http server
ip pim bidir-enable
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
!
snmp-server packetsize 4096
snmp-server manager
tftp-server nvram
call rsvp-sync
!
voice-port 1/0:15
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 3...
 direct-inward-dial
 port 1/0:15
 prefix 3
!
dial-peer voice 3 voip
 destination-pattern 5...
 progress_ind setup enable 1
 voice-class codec 1
 session target ipv4:10.1.1.2
 dtmf-relay h245-alphanumeric
!
!
line con 0
 exec-timeout 0 0
line aux 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
line vty 5 15
 exec-timeout 0 0
 login
!
scheduler allocate 3996 1000
!
end

2621_B#

Test Configuration

Figure 2

Test Topology

The above diagram is representative of the various configurations used for testing.

As shown in the diagram above, an Alcatel 4400 PBX was connected via an ISDN E1 PRI link to a Cisco 2621 Gateway, which in turn, was connected to an Ethernet switch. The interoperability testing involved Layers 1, 2 and 3 on the ISDN PRI link between a Cisco 2621 and the PBX.

Layer 1 (Physical Layer)

The Alcatel 4400 PBX configuration screen for the E1 trunk interface is reached using both Alcatel Board and Board\Digital Access menus, setting the E1 physical layer parameters.

Layers 2 & 3 (Q.921 and Q.931)

Layer 2 and 3 packet exchanges were monitored using an Acacia Clarinet protocol analyzer, bridged across the PRI link in high impedance mode.

Layer 2 Q.921 packets were monitored to ensure that each PBX/2621 software configuration properly exchanged SABME/UA packets to initialize the ISDN link, and then RR packets were exchanged every 30 seconds.

Layer 3 Q.931 packets were monitored to ensure that the appropriate call setup/teardown packets were exchanged for each configuration, and that the SETUP packets contained the mandatory Information Elements with the necessary details, as well as optional IEs such as Calling Name and Number.

Telephone calls were made end-to-end in both directions through the Cisco 2621 Gateway, and a check was made to ensure that there was an audio path in both directions for each call.

User/Network Settings

The Cisco 2621 Gateway with ISDN switch type setting of primary-net5 supports both protocol sides by using the isdn protocol-emulate network/user command.

The Alcatel 4400, supports both "USER" (slave) and "NETWORK" (master) protocol sides.

The following options are of particular interest:

Trunk interface type must be set to PRA2.

Network/User options are set in the Board/Digital Access Options menu. Network mode must be set to Yes for (Master/Network) or No - (Slave/User).

Access Type must be set to T2.

Q931 signal variant is used to determine Protocol type. This option was set to ISDN all countries.

Test Results

Testing was performed by Test Engineer(s): Samir Batio, October 18, 2001

Test Setup 1

Test configuration:

PBX1 configured as ETSI, emulates Network

Cisco 2621 Gateway configured as primary-net5, emulates User

Table 1  Test Setup 1 Switch and Gateway Settings

Alcatel 4400 Switch-type / Protocol-side Setting
Cisco 2621_B ISDN switch-type/Protocol-side Setting

ETSI/Network

isdn switch-type

primary-net5 /

isdn protocol-emulate user


Table 2  Basic Calls: (Enbloc Sending)

Calls Made
Call Comp?
"Calling Number" Passed to Final Destination?
"Calling Name" Passed to Final Destination?
"Called Number" Passed to Orig. Side?
"Called Name" Passed to Orig. Side?
Notes

Phone A to Phone C

Yes

Yes

No

No1

No

2

Phone C to Phone A

Yes

Yes

No

Yes

No

 

1 CallManager is not sending "Connected Number" information in the connect message back to PBX.

2 Calling Name delivery and presentation features are not supported by the Alcatel ISDN PRI Link.


Table 3  Call Transfers: (Supervised Local Transfers)

Calls Made
Call Comp?
Orig. "Calling Number" displayed on Final Dest. phone?
Orig. "Calling Name" displayed on Final Dest. phone?
"Called Number" display on Orig. phone updated after transfer?
"Called Name" display on Orig. phone updated after transfer?
Notes

Phone C to Phone A Xfr to Phone B

Yes

Yes

No

No

No

 

Phone A to Phone C Xfr to Phone D

Yes

Yes

No

No

No

 

Table 4  Call Conferencing (Local)

Calls Made
Call Comp?
"Calling Number" passed to remaining conferee when the conferencing phone drops out?
"Calling Name" passed to remaining conferee when the conferencing phone drops out?
"Connected Number" updated on Orig. Caller phone display when a conferee drops out?
"Connected Name" updated on Orig. Caller phone display when a conferee drops out?
Notes
Phone C to Phone A, Phone A conf Phone B

Yes

(A Drops out) Yes

(A Drops out) No

(A Drops out) No

(A Drops out) No

 
Phone C to Phone A, Phone C conf Phone D

Yes

(C Drops out) No

(C Drops out) No

(D Drops out) No

(D Drops out) No

 
Phone A to Phone C, Phone C conf Phone D

Yes

(C Drops out) No

(C Drops out) No

(C Drops out) No

(C Drops out) No

 
Phone A to Phone C, Phone A conf Phone B

Yes

(A Drops out) No

(A Drops out) No

(B Drops out) No

(B Drops out) No

 

Table 5  Call Forward (Local)

Calls Made
Call Comp?
Original "Calling Number" passed to Final Dest.?
Original "Calling Name" passed to Final Dest.?
Forwarding "Called Number" passed to Final Dest.?
Forwarding "Called Name" passed to Final Dest.?
Final dest. "Connected Number" updated at orig. side?
Final dest. "Connected Name" updated at orig. side?
Notes

Phone C to Phone A fwd to Phone B

Yes

Yes

No

No

No

No

No

 

Phone A to Phone C fwd to Phone D

Yes

Yes

No

No

No

No

No

 

Test Setup 2

Test configuration:

PBX1 configured as ETSI, emulates User

Cisco 2621 Gateway configured as primary-net5, emulates Network

Table 6  Test Setup 2 Switch and Gateway Settings

Alcatel 4400 Switch-type/ Protocol side setting
Cisco 2621_B ISDN Switch-type/Protocol-side Settings

ETSI / User

isdn switch-type

primary-net5 /

isdn protocol-emulate network


The test results are identical as in Test Setup 1. Refer to the tables in Test Setup 1 for details.