Guest

Cisco Unified Communications Manager (CallManager)

Lucent/Avaya Definity G3si V7 PBX with CallManager using the Cisco 2621-E1 PRI-NET5 Gateway

 Feedback

Table Of Contents

Application Note

Integration Description

Cisco Systems Equipment Needed

PBX Requirements

Features

Configuring the Lucent/Avaya Definity G3si PBX

Circuit Pack

Signaling Group

Trunk Group

Uniform Dialing Plan

Configuring Cisco CallManager

Gateway Configuration

Route Pattern Configuration

Considerations

Calling Name and Number Feature

Integration Testing

CallManager Software Release

Lucent/Avaya Definity G3si Software Release

Cisco 2621 Router Configuration

Test Configuration

Test Results


Application Note


Lucent/Avaya Definity G3si V7 PBX with CallManager using Cisco 2621-E1 PRI NET5 Gateway

This application note discusses the integration of the Lucent/Avaya Definity G3si V7 PBX with CallManager using the Cisco 2621-E1 PRI NET5 Gateway.

Integration Description

Connectivity is achieved by using the industry standard PRI protocol. The Lucent/Avaya Definity G3si can be configured as either the NETWORK or USER side. The figure below shows the general network layout for the integration.

Network Layout

Cisco Systems Equipment Needed

Hardware (Cisco 2621 Gateway): 2MFT E1 Port

Software: CallManager Release 3.1

PBX Requirements

Hardware: TN464F, DS1 INTFC 24/32.

Software: Version V7

Features

Key features supported:

Calling/Called Number

Calling Name

Key features not supported:

Connected Name

Connected Number

Configuring the Lucent/Avaya Definity G3si PBX

To configure the Lucent/Avaya Definity G3si PBX, do the following:


Step 1. Add the new circuit pack.

Step 2. Add the new signaling group.

Step 3. Add the new trunk group.

Step 4. Add the Uniform Dialing Plan.

Circuit Pack

The following figures show the configuration of the DS1 circuit pack.

DS1 Circuit Pack

Signaling Group

The following figure shows the configuration of the signaling group.

Signaling Group

Trunk Group

The following figures show the configuration of the trunk group.

Trunk Group

Trunk Group—Trunk Features

Trunk Group—Group Member Assignments

Trunk Group—Group Member Assignments Continued

Uniform Dialing Plan

The following figures show the configuration of the uniform dialing plan.

Dial Plan Record

Uniform Dialing Plan

Configuring Cisco CallManager

To configure Cisco CallManager, do the following:


Step 1. Configure the gateway.

Step 2. Configure the route pattern.

Gateway Configuration

The following figures show the configuration of the Cisco 2621 H.323 Gateway.

Cisco 2621 H.323 Gateway Configuration

Cisco 2621 H.323 Gateway Configuration Continued

Cisco 2621 H.323 Gateway Configuration Continued

Route Pattern Configuration

The following figures show the configuration of the route pattern.

Route Pattern Configuration

Route Pattern Configuration Continued

Considerations

Calling Name and Number Feature

When calling from a Cisco 7960 IP phone to a Lucent/Avaya digital phone, the Lucent/Avaya phone displays the Calling Name and Number after the call is answered as expected. The Cisco 7960 phone, however, displays only the Called Number but not the Connected Name, even though Lucent/Avaya PBX is sending both the Connected Name and the Connected Number IE information in the CONNECT message back to the Cisco 2621 Gateway.

When calling from a Lucent/Avaya digital phone to a Cisco 7960 IP phone, the IP phone displays the Connected Name and Number after the call is answered. The Lucent/Avaya phone, however, does not display the Called Name or Called Number. It displays the numbers being dialed instead (that is the Access Code and the extension number). It was verified using an ISDN protocol analyzer that the CallManager was not sending Connected Name or Connected Number information in the connect message back to PBX.

Integration Testing

This section contains information about the setup used in testing the integration of the Lucent/Avaya Definity G3si and the Cisco 2621-E1 PRI NET5 Gateway.

CallManager Software Release

The following figure shows the information about the release of CallManager being used.

CallManager Software Release

Lucent/Avaya Definity G3si Software Release

The following release of the Lucent/Avaya Definity G3si was used:

System: G3siV7

Software Version: G3V7i.01.0.343.7

Cisco 2621 Router Configuration

The following shows the configuration of the Cisco 2621 router.

2621_B#show version
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-JS-M), Version 12.2(3.5)T,  MAINTENANCE INTERIM SOFTWARE
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Fri 03-Aug-01 22:45 by ccai
Image text-base: 0x80008088, data-base: 0x81631DD8

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
2621_B uptime is 4 minutes
System returned to ROM by power-on
System image file is "flash:c2600-js-mz.122-3.5.T"

cisco 2621 (MPC860) processor (revision 0x200) with 56320K/9216K bytes of memory
.
Processor board ID JAD051516TX (503811939)
M860 processor: part number 0, mask 49
Channelized E1, Version 1.0.
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
Primary Rate ISDN software, Version 1.1.
2 FastEthernet/IEEE 802.3 interface(s)
31 Serial network interface(s)
2 Channelized E1/PRI port(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102
2621_B#
______________________________________________________________________________________

2621_B#show diag
Slot 0:
        C2621 2FE Mainboard Port adapter, 2 ports
        Port adapter is analyzed
        Port adapter insertion time unknown
        EEPROM contents at hardware discovery:
        Hardware Revision        : 2.0
        PCB Serial Number        : JAD051516TX (503811939)
        Part Number              : 73-3200-08
        RMA History              : 00
        RMA Number               : 0-0-0-0
        Board Revision           : A0
        Deviation Number         : 0-21249
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 00 A2 41 02 00 C1 17 4A 41 44 30 35 31
          0x10: 35 31 36 54 58 20 28 35 30 33 38 31 31 39 33 39
          0x20: 29 82 49 0C 80 08 04 00 81 00 00 00 00 42 41 30
          0x30: 80 00 00 53 01 FF FF FF FF FF FF FF FF FF FF FF
          0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
Slot 1:
        High Density Voice Port adapter
        Port adapter is analyzed
        Port adapter insertion time unknown
        EEPROM contents at hardware discovery:
        Hardware Revision        : 1.1
        Top Assy. Part Number    : 800-03567-01
        Board Revision           : F1
        Deviation Number         : 0-0
        Fab Version              : 02
        PCB Serial Number        : JAB05080LU9
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 00 CC 41 01 01 C0 46 03 20 00 0D EF 01
          0x10: 42 46 31 80 00 00 00 00 02 02 C1 8B 4A 41 42 30
          0x20: 35 30 38 30 4C 55 39 03 00 81 00 00 00 00 04 00
          0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
        VIC Slot 0:
        E1 (2 Port) Multi-Flex Trunk WAN Daughter Card
        Hardware revision 1.0           Board revision B0
        Serial number     18801733      Part number    800-04479-01
        Test history      0x0           RMA number     00-00-00
        Connector type    PCI
        EEPROM format version 1
        EEPROM contents (hex):
          0x20: 01 23 01 00 01 1E E4 45 50 11 7F 01 00 00 00 00
          0x30: 58 00 00 00 00 03 09 00 FF FF FF FF FF FF FF FF

        HDV firmware: Compiled Fri 23-Mar-01 00:20 by miriyala
        HDV memory size 524280 heap free 175065


2621_B#
______________________________________________________________________________________

2621_B#show controllers e1 1/0
E1 1/0 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20010710, FPGA: 15
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (62 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
2621_B#
____________________________________________________________________________________

2621_B#show configuration
Using 1785 out of 29688 bytes
!
version 12.2
no parser cache
service timestamps debug datetime msec localtime show-timezone
service timestamps log uptime
no service password-encryption
!
hostname 2621_B
!
no logging buffered
enable password cisco
!
!
!
memory-size iomem 15
voice-card 1
 dspfarm
!
ip subnet-zero
!
!
no ip domain-lookup
!
isdn switch-type primary-net5
!
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
 codec preference 3 g711alaw
!
!
!
!
!
!
!
controller E1 1/0
 pri-group timeslots 1-31
!
controller E1 1/1
 shutdown
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.100.2 255.255.255.0
 no ip mroute-cache
 load-interval 30
 no keepalive
 speed auto
 half-duplex
!
interface FastEthernet0/1
 ip address 10.1.1.129 255.255.255.0
 no ip mroute-cache
 duplex auto
 speed auto
!
interface Serial1/0:15
 no ip address
 no logging event link-status
 isdn switch-type primary-net5
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn T321 40000
 isdn T203 30000
 isdn bchan-number-order ascending
 no cdp enable
!
router rip
 network 1.0.0.0
 network 192.168.100.0
!
ip classless
no ip http server
ip pim bidir-enable
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
!
snmp-server packetsize 4096
snmp-server manager
tftp-server nvram
call rsvp-sync
!
voice-port 1/0:15
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 2...
 direct-inward-dial
 port 1/0:15
 prefix 2
!
dial-peer voice 3 voip
 destination-pattern 4...
 progress_ind setup enable 1
 voice-class codec 1
 session target ipv4:10.1.1.2
 dtmf-relay h245-alphanumeric
!
!
line con 0
 exec-timeout 0 0
line aux 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
line vty 5 15
 exec-timeout 0 0
 login
!
scheduler allocate 3996 1000
!
end

2621_B#

Test Configuration

The following figure represents the various configurations used for testing.

Testbed Network Configuration

As shown in the figure above, a Lucent/Avaya Definity G3si PBX was connected via an ISDN E1 PRI link to a Cisco 2621 Gateway, which in turn, was connected to an Ethernet switch. The interoperability testing involved Layers 1, 2 and 3 on the ISDN PRI link between a Cisco 2621 and the PBX.

Layer 1 (Physical Layer)

The Lucent/Avaya Definity G3si PBX configuration screen for the E1 trunk interface is reached using the change ds1 a12 command, which sets the E1 physical layer parameters.

Layers 2 & 3 (Q.921 and Q.931)

Layer 2 and 3 packet exchanges were monitored using an Acacia Clarinet protocol analyzer, bridged across the PRI link in high impedance mode.

Layer 2 Q.921 packets were monitored to ensure that each PBX/2621 software configuration properly exchanged SABME/UA packets to initialize the ISDN link, and then RR packets were exchanged every 30 seconds.

Layer 3 Q.931 packets were monitored to ensure that the appropriate call setup/teardown packets were exchanged for each configuration, and that the SETUP packets contained the mandatory Information Elements with the necessary details, as well as optional IEs such as Calling Name and Number.

Telephone calls were made end-to-end in both directions through the Cisco 2621 Gateway, and a check was made to ensure that there was an audio path in both directions for each call.

User/Network Settings

The Cisco 2621 Gateway with ISDN protocol type setting of primary-net5 supports both protocol sides by using the isdn protocol-emulate network/user command.

The Lucent/Avaya Definity G3si PBX supports both "USER" and "NETWORK" protocol sides by using the change ds1 a12 command.

Test Results

Testing was performed by Test Engineer(s): Samir Batio, October 10, 2001

Test 1

In test 1:

The PBX1 country-protocol is set to ETSI to emulate the Network.

The Cisco 2621 Gateway is configured as a Primary-net5 to emulate the User.

The results are shown in the following tables.

Table 1  Basic Calls (Enbloc Sending)

Calls Made
Call Comp?
Calling Number passed to final destination?
Calling Name passed to final destination?
Called Number passed to original side?
Called Name passed to the original side?

Phone A to Phone C

Yes

Yes

Yes

No1

No1

Phone C to Phone A

Yes

Yes

Yes

Yes

No

1 CallManager is not sending the Connected Name or the Connected Number information in the connect message back to PBX.


Table 2  Call Transfers (Supervised Local Transfers)

Calls Made
Call Comp?
Original Calling Number displayed on final dest phone?
Original Calling Name displayed on final dest phone?
Called Number display on original phone updated after transfer?
Called Name display on original phone updated after transfer?

Phone C to Phone A Xfr to Phone B

Yes

Yes

Yes

No

No

Phone A to Phone C Xfr to Phone D

Yes

Yes

Yes

No

No


Table 3  Call Conferencing (Local)

Calls Made
Call Comp?
Calling Number passed to the remaining conferee when the conferencing phone drops out?
Calling Name passed to the remaining conferee when the conferencing phone drops out?
Connected Number updated on original caller phone display when a conferee drops out?
Connected Name updated on original caller phone display when a conferee drops out?

Phone C to Phone A, Phone A conf Phone B

Yes

(A Drops out)

Yes

(A Drops out)

Yes

(A Drops out)

No

(A Drops out)

No

Phone C to Phone A, Phone C conf Phone D

Yes

(C Drops out)

No

(C Drops out)

No

(D Drops out)

No

(D Drops out)

No

Phone A to Phone C, Phone C conf Phone D

Yes

(C Drops out)

No

(C Drops out)

No

(C Drops out)

No

(C Drops out)

No

Phone A to Phone C, Phone A conf Phone B

Yes

(A Drops out)

No

(A Drops out)

No

(B Drops out)

No

(B Drops out)

Yes


Table 4  Call Forward (Local)

Calls Made
Call Comp?
Original Calling Number passed to final dest?
Original Calling Name passed to final dest?
Forwarding Called Number passed to final dest?
Forwarding Called Name passed to final dest
Final destination Connected Number updated at original side?
Final destination Connected Name updated at original side?

Phone C to Phone A fwd to Phone B

Yes

No

Yes

No

Yes

No

No

Phone A to Phone C fwd to Phone D

Yes

Yes

Yes

No

No

No

No


Test 2

In test 2:

The PBX1 country-protocol is set to ETSI to emulate the User.

The Cisco 2621 Gateway is configured as a Primary-net5 to emulate the Network.

The test results are identical to those in Test 1.