Cisco Gigabit-Ethernet Optimized Video Networking Solution for Cable Design and Implementation Guide, Release 3.0
Appendix A: Sample Configurations

Table Of Contents

Sample Configurations

Configuration for the Source Router

Configurations for the Aggregation Routers

Configuration for AR1

Configuration for AR2a

Configurations for the Hub Routers

Configuration for HR1a

Configuration for HR2a

Configuration for HR2b

Configuration for HR3a


Sample Configurations


This appendix presents sample configurations for the following:

Configuration for the Source Router

Configurations for the Aggregation Routers

Configurations for the Hub Routers


Note See Network Topology.


Configuration for the Source Router

The following is the configuration for SR1a.

!#################################################################
!
! Description
! ===========
! Video Networking Solution 3.0 
! SR1a running-config 
!
! Version Information
! ===================
! IOS
! ---
! 12.2(18)SXF
!
! Hardware
! --------
! 
! Mod  Port Model              Serial !    Versions
! ---- ---- ------------------ ----------- --------------------
!   1    4  WS-X6704-10GE      SAL09337DN0 Hw : 2.2
!                                          Fw : 12.2(14r)S5
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-F6700-DFC3BXL   SAL09295P6K Hw : 5.0
!   2   48  WS-X6748-GE-TX     SAL090607K5 Hw : 2.1
!                                          Fw : 12.2(14r)S5
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-F6700-DFC3BXL   SAL09295P90 Hw : 5.0
!   5    2  WS-SUP720-3BXL     SAL09137GNV Hw : 4.3
!                                          Fw : 8.1(3)
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-SUP720          SAL091279RT Hw : 2.3
!                                          Fw : 12.2(17r)S2
!                                          Sw : 12.2(18)SXF
!           WS-F6K-PFC3BXL     SAL0912725W Hw : 1.6
!
!
!#################################################################
!
!
upgrade fpd auto
version 12.2
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service internal
service counters max age 5
no service dhcp
!
hostname SR1a
!
boot system disk0:s72033-adventerprisek9_wan-mz.122-18.SXF.bin

logging snmp-authfail
logging buffered 64000 informational
no logging console
enable password cisco123
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
no ip source-route
ip spd mode aggressive
!
!
!
ip cef accounting non-recursive 
ip tftp source-interface Loopback0
no ip bootp server
ip multicast-routing 
ip igmp ssm-map enable
no ip igmp ssm-map query dns
ip igmp ssm-map static acl_SSM-map-DB 192.168.71.2
ip igmp ssm-map static acl_SSM-map-DS 192.168.72.2
ip igmp ssm-map static acl_SSM-map-DS-post-splice 192.168.160.2
ip tcp window-size 65535
ip tcp path-mtu-discovery
ip telnet source-interface Loopback0
no ip domain-lookup
vtp domain SR1a
vtp mode transparent
mls ip multicast replication-mode ingress
mls ip multicast flow-stat-timer 9
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 16 18 20 to 3
mls qos map dscp-cos 26 28 30 to 4
mls qos map dscp-cos 34 36 38 to 6
mls qos map dscp-cos 40 42 44 to 2
mls qos map dscp-cos 48 to 5
mls qos
mls rate-limit multicast ipv4 fib-miss 10000 250
mls rate-limit multicast ipv4 connected 2500 250
mls rate-limit multicast ipv4 igmp 1000 10
mls rate-limit multicast ipv4 ip-options 1000 10
mls rate-limit multicast ipv4 partial 500 250
mls rate-limit unicast acl input 1000 10
mls rate-limit unicast acl output 1000 10
no mls rate-limit unicast acl vacl-log 
mls rate-limit all ttl-failure 100 10
mls rate-limit all mtu-failure 100 10
no mls acl tcam share-global
mls cef error action freeze
!
!
! 
!
!
!
!
!
!         
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
  auto-sync standard
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1-4094
!
power redundancy-mode combined
error-detection packet-buffer action none
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
fabric buffer-reserve queue
!
vlan internal allocation policy ascending
!
class-map match-all class_voice
  match access-group name acl_voice
class-map match-all class_broadcast-video
  match access-group name acl_broadcast-video
class-map match-all class_ad-server
  match access-group name acl_ad-server
class-map match-all class_video-signaling
  match access-group name acl_video-signaling
class-map match-all class_net-mgmt
  match access-group name acl_net-mgmt
class-map match-all class_internet-access
  match access-group name acl_internet-access
class-map match-all class_suspect
  match access-group name acl_permit-any
!
!
policy-map pmap_voice-port
  class class_voice
   trust dscp
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_broadcast-video-port
  class class_broadcast-video
   set dscp af41
  class class_video-signaling
   set dscp cs3
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_ad-server-port
  class class_ad-server
   set dscp af41
  class class_video-signaling
   set dscp cs3
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_net-mgmt-port
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_internet-access-port
  class class_internet-access
   set dscp 8
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
!
!
!
interface Loopback0
 description RAN Loopback
 ip address 99.99.0.1 255.255.255.255
!
interface Loopback1
 description Local Loopback
 ip address 99.99.1.1 255.255.255.255
!
interface Loopback99
 description ASM Multicast Rendevouz Point
 ip address 99.99.99.1 255.255.255.255
 ip pim sparse-mode
!
interface Null0
 no ip unreachables
!
interface TenGigabitEthernet1/1
 description Transport between AR1 (TenGig1/1)
 ip address 192.168.250.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/2
 no ip address
 shutdown
!
interface TenGigabitEthernet1/3
 description Transport between AR2 (TenGig1/1)
 ip address 192.168.251.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/4
 no ip address
 shutdown
!
interface GigabitEthernet2/1
 description Syslog/TFTP/NTP on PC0a (Eth2) dual-homed to 1.1.1.0/24
 ip address 192.168.10.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 no cdp enable
 service-policy input pmap_net-mgmt-port
!
interface GigabitEthernet2/2
 description Voice over IP
 ip address 192.168.80.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 no cdp enable
 service-policy input pmap_voice-port
!
interface GigabitEthernet2/3
 description Internet Access
 ip address 192.168.90.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 no cdp enable
 service-policy input pmap_internet-access-port
!
interface GigabitEthernet2/4
 description CherryPicker DM0a (Port 1) - DB
 ip address 192.168.71.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 no cdp enable
 service-policy input pmap_broadcast-video-port
!         
interface GigabitEthernet2/5
 description CherryPicker DM0b (Port 1) - DS
 ip address 192.168.72.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 no cdp enable
 service-policy input pmap_broadcast-video-port
!
interface GigabitEthernet2/6
 description Ad Server Ad0a
 ip address 192.168.60.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 no cdp enable
 service-policy input pmap_ad-server-port
!
interface GigabitEthernet2/7
 no ip address
 shutdown 
!
!
!  <<< omitted interface GigabitEthernet2/8 - interface GigabitEthernet2/47 >>>
!
!
interface GigabitEthernet2/48
 no ip address
!
interface GigabitEthernet5/1
 no ip address
 shutdown
!
interface GigabitEthernet5/2
 description Management port for Syslog/TFTP/NTP
 ip address 1.1.1.1 255.255.255.0
 media-type rj45
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 router-id 99.99.0.1
 max-metric router-lsa on-startup wait-for-bgp
 log-adjacency-changes detail
 timers throttle spf 400 400 4000
 passive-interface default
 no passive-interface TenGigabitEthernet1/1
 no passive-interface TenGigabitEthernet1/3
 network 99.99.0.0 0.0.255.255 area 0
 network 192.168.250.0 0.0.0.255 area 0
 network 192.168.251.0 0.0.0.255 area 0
 maximum-paths 6
!
router bgp 100
 no synchronization
 bgp router-id 99.99.0.1
 bgp log-neighbor-changes
 redistribute connected route-map rmap_Connected-to-BGP
 neighbor rr-server peer-group
 neighbor rr-server remote-as 100
 neighbor rr-server update-source Loopback0
 neighbor rr-server version 4
 neighbor rr-server send-community
 neighbor 99.99.0.2 peer-group rr-server
 neighbor 99.99.0.2 description AR1
 neighbor 99.99.0.3 peer-group rr-server
 neighbor 99.99.0.3 description AR2
 no auto-summary
!
ip classless
!
ip bgp-community new-format
no ip http server
ip pim ssm range acl_SSM-IPmc-range
!
ip access-list standard acl_SSM-IPmc-range
 permit 239.0.0.0 0.255.255.255
ip access-list standard acl_SSM-map-DB
 remark SSM mapping for DB blue/red
 permit 239.16.0.0 0.0.0.255
ip access-list standard acl_SSM-map-DS
 remark SSM mapping for DS blue/red
 permit 239.20.0.0 0.0.255.255
ip access-list standard acl_SSM-map-DS-post-splice
 remark SSM mapping for post splice DS blue/red
 permit 239.28.0.0 0.0.255.255
!
ip access-list extended acl_voice
 remark Identify voice traffic
 permit ip any 192.168.161.0 0.0.0.255

ip access-list extended acl_broadcast-video
 remark Identify broadcast video traffic (multicast on 239.x.x.x)
 permit ip any 239.0.0.0 0.255.255.255
ip access-list extended acl_ad-server
 remark Identify ad server traffic 
 permit ip 192.168.60.0 0.0.0.255 any
ip access-list extended acl_video-signaling
 remark Identify video signaling
 permit ip any 192.168.61.0 0.0.0.255
ip access-list extended acl_net-mgmt
 remark Identify net management traffic (TFTP, Syslog, NTP, etc)
 permit ip 192.168.10.0 0.0.0.255 any
 permit ip any 192.168.10.0 0.0.0.255 
ip access-list extended acl_internet-access
 remark Identify Internet access traffic 
 permit ip 192.168.90.0 0.0.0.255 any
ip access-list extended acl_permit-any
 permit ip any any
!
!
ip prefix-list pl_Connected-to-BGP seq 5 permit 192.168.10.0/24 le 32
ip prefix-list pl_Connected-to-BGP seq 10 permit 192.168.60.0/24 le 32
ip prefix-list pl_Connected-to-BGP seq 15 permit 192.168.70.0/24 le 32
ip prefix-list pl_Connected-to-BGP seq 20 permit 192.168.71.0/24 le 32
ip prefix-list pl_Connected-to-BGP seq 25 permit 192.168.72.0/24 le 32
ip prefix-list pl_Connected-to-BGP seq 30 permit 192.168.73.0/24 le 32
ip prefix-list pl_Connected-to-BGP seq 30 permit 192.168.80.0/24 le 32
ip prefix-list pl_Connected-to-BGP seq 30 permit 192.168.90.0/24 le 32
!
logging event link-status default
logging trap debugging
logging source-interface Loopback0
logging 1.1.1.254
!         
route-map rmap_Connected-to-BGP permit 100
 match ip address prefix-list pl_Connected-to-BGP
 set metric 100
 set ip next-hop 99.99.0.1
!
!
!
control-plane
!
!
!
dial-peer cor custom
!
!
!
banner motd ^C
################################################################


 Project = Video Networking Solution
 Switch = SR1a
 Chassis = 7606
 Slot1 = WS-X6704 (3BXL)
 Slot2 = WS-X6748 (3BXL)
 Slot5 = Sup720  (3BXL)


################################################################
^C
!
line con 0
 exec-timeout 0 0
 history size 100
 transport preferred none
line vty 0 4
 exec-timeout 0 0
 password cisco123
 login
 history size 100
 transport preferred none
!
!
monitor event-trace timestamps
scheduler runtime netinput 300
ntp source Loopback0
ntp server 1.1.1.254
ntp update-calendar
no cns aaa enable
end

Configurations for the Aggregation Routers

The following configurations are presented:

Configuration for AR1

Configuration for AR2a

Configuration for AR1

!#################################################################
!
! Description
! ===========
! Video Networking Solution 3.0 
! AR1 running-config 
!
! Version Information
! ===================
! IOS
! ---
! 12.2(18)SXF
!
! Hardware
! --------
! 
! Mod  Port Model              Serial #    Versions
! ---- ---- ------------------ ----------- -------------------------------------
!   1    4  WS-X6704-10GE      SAL09295RAQ Hw : 2.2
!                                          Fw : 12.2(14r)S5
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-F6700-DFC3BXL   SAL09285CDU Hw : 5.0
!   5    2  WS-SUP720-3BXL     SAL09232FNL Hw : 4.3
!                                          Fw : 8.1(3)
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-SUP720          SAL09232GDX Hw : 2.3
!                                          Fw : 12.2(17r)S2
!                                          Sw : 12.2(18)SXF
!           WS-F6K-PFC3BXL     SAL09222CTU Hw : 1.6
!
!#################################################################
!
!
upgrade fpd auto
version 12.2
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service internal
service counters max age 5
no service dhcp
!
hostname AR1
!
boot system disk0:s72033-adventerprisek9_wan-mz.122-18.SXF.bin
logging snmp-authfail
logging buffered 64000 informational
enable password cisco123
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
no ip source-route
ip spd mode aggressive
!
!
!
ip cef accounting non-recursive 
ip tftp source-interface Loopback0
no ip bootp server
ip multicast-routing 
ip igmp ssm-map enable
no ip igmp ssm-map query dns
ip igmp ssm-map static acl_SSM-map-DB 192.168.71.2
ip igmp ssm-map static acl_SSM-map-DS 192.168.72.2
ip igmp ssm-map static acl_SSM-map-DS-post-splice 192.168.160.2
ip tcp window-size 65535
ip tcp path-mtu-discovery
ip telnet source-interface Loopback0
no ip domain-lookup
ipv6 mfib hardware-switching replication-mode ingress
vtp domain AR1
vtp mode transparent
mls ip multicast replication-mode ingress
mls ip multicast flow-stat-timer 9
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 16 18 20 to 3
mls qos map dscp-cos 26 28 30 to 4
mls qos map dscp-cos 34 36 38 to 6
mls qos map dscp-cos 40 42 44 to 2
mls qos map dscp-cos 48 to 5
mls qos
mls rate-limit multicast ipv4 fib-miss 10000 250
mls rate-limit multicast ipv4 connected 2500 250
mls rate-limit multicast ipv4 igmp 1000 10
mls rate-limit multicast ipv4 ip-options 1000 10
mls rate-limit multicast ipv4 partial 500 250
mls rate-limit unicast acl input 1000 10
mls rate-limit unicast acl output 1000 10
no mls rate-limit unicast acl vacl-log 
mls rate-limit unicast ip options 1000 10
mls rate-limit all ttl-failure 100 10
mls rate-limit all mtu-failure 100 10
no mls acl tcam share-global
mls cef error action freeze
!
!
! 
!
!
!
!
!         
!
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
  auto-sync standard
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
no spanning-tree vlan 1-4094
error-detection packet-buffer action none
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
fabric buffer-reserve queue
!
vlan internal allocation policy ascending
!
!
interface Loopback0
 description RAN Loopback
 ip address 99.99.0.2 255.255.255.255
!
interface Null0
 no ip unreachables
!
interface TenGigabitEthernet1/1
 description Transport between SR1a (TenGig1/1)
 ip address 192.168.250.2 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/2
 description Transport between AR2 (TenGig1/2)
 ip address 192.168.249.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/3
 description Transport between HR1a (TenGig1/1)
 ip address 192.168.250.5 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/4
 no ip address
 shutdown
!
interface GigabitEthernet5/1
 no ip address
 shutdown
!
interface GigabitEthernet5/2
 description Management port for Syslog/TFTP/NTP
 ip address 1.1.1.2 255.255.255.0
 media-type rj45
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 router-id 99.99.0.2
 max-metric router-lsa on-startup wait-for-bgp
 log-adjacency-changes detail
 timers throttle spf 400 400 4000
 network 99.99.0.0 0.0.255.255 area 0
 network 192.168.249.0 0.0.0.255 area 0
 network 192.168.250.0 0.0.0.255 area 0
 maximum-paths 6
 default-information originate metric-type 1
!
router bgp 100
 no synchronization
 bgp router-id 99.99.0.2
 bgp log-neighbor-changes
 network 192.168.10.0 route-map rmap_Network-Management
 network 192.168.60.0 route-map rmap_Ad-Insertion
 network 192.168.71.0 route-map rmap_IPmc-DS-Source
 network 192.168.72.0 route-map rmap_IPmc-DB-Source
 network 192.168.80.0 route-map rmap_Voice
 network 192.168.90.0 route-map rmap_Internet-Access
 network 192.168.150.0 route-map rmap_Hub1
 network 192.168.160.0 route-map rmap_Hub2
 network 192.168.170.0 route-map rmap_Hub2
 network 192.168.180.0 route-map rmap_Hub3
 neighbor rr-client peer-group
 neighbor rr-client remote-as 100
 neighbor rr-client update-source Loopback0
 neighbor rr-client version 4
 neighbor rr-client route-reflector-client
 neighbor rr-client send-community
 neighbor ibgp peer-group
 neighbor ibgp remote-as 100
 neighbor ibgp update-source Loopback0
 neighbor ibgp version 4
 neighbor ibgp send-community
 neighbor 99.99.0.1 peer-group rr-client
 neighbor 99.99.0.1 description SR1a
 neighbor 99.99.0.3 peer-group ibgp
 neighbor 99.99.0.3 description AR2
 neighbor 99.99.0.4 peer-group rr-client
 neighbor 99.99.0.4 description HR1a
 neighbor 99.99.0.5 peer-group rr-client
 neighbor 99.99.0.5 description HR2a 
 neighbor 99.99.0.6 peer-group rr-client
 neighbor 99.99.0.6 description HR2b 
 neighbor 99.99.0.7 peer-group rr-client
 neighbor 99.99.0.7 description HR3a 
 no auto-summary
!
ip classless
!
ip bgp-community new-format
no ip http server
ip pim ssm range acl_SSM-IPmc-range
!
ip access-list standard acl_SSM-IPmc-range
 permit 239.0.0.0 0.255.255.255
ip access-list standard acl_SSM-map-DB
 remark SSM mapping for DB blue/red
 permit 239.16.0.0 0.0.0.255
ip access-list standard acl_SSM-map-DS
 remark SSM mapping for DS blue/red
 permit 239.20.0.0 0.0.255.255
ip access-list standard acl_SSM-map-DS-post-splice
 remark SSM mapping for post splice DS blue/red
 permit 239.28.0.0 0.0.255.255
!
logging event link-status default
logging trap debugging
logging source-interface Loopback0
logging 1.1.1.254
!
route-map rmap_Network-Management permit 100
 set metric 100
!
route-map rmap_Ad-Insertion permit 100
 set metric 100
!
route-map rmap_IPmc-DS-Source permit 100
 set metric 100
!
route-map rmap_IPmc-DB-Source permit 100
 set metric 100
!
route-map rmap_Voice permit 100
 set metric 100
!
route-map rmap_Internet-Access permit 100
 set metric 100
!
route-map rmap_Hub1 permit 100
 set metric 100
!
route-map rmap_Hub2 permit 100
 set metric 100
!
route-map rmap_Hub3 permit 100
 set metric 100
!
!
!
control-plane
!
!
!
dial-peer cor custom
!
!
!
banner motd ^C
################################################################


 Project = Video Networking Solution
 Switch = AR1

 Chassis = 6509
 Slot1 = WS-X6704 (3BXL)
 Slot5 = Sup720  (3BXL)

################################################################
^C
!
line con 0
 exec-timeout 0 0
 history size 100
 transport preferred none
line vty 0 4
 exec-timeout 0 0
 password cisco123
 login
 history size 100
 transport preferred none
!
scheduler runtime netinput 300
ntp clock-period 17179699
ntp source Loopback0
ntp update-calendar
ntp server 1.1.1.254
no cns aaa enable
end

Configuration for AR2a

!#################################################################
!
! Description
! ===========
! Video Networking Solution 3.0 
! AR2 running-config 
!
! Version Information
! ===================
! IOS
! ---
! 12.2(18)SXF
!
! Hardware
! --------
! 
! Mod  Port Model              Serial #    Versions
! ---- ---- ------------------ ----------- ----------------------
!   1    4  WS-X6704-10GE      SAD074706G4 Hw : 1.2
!                                          Fw : 12.2(14r)S5
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-F6700-DFC3A     SAD081603HC Hw : 2.2
!   5    2  WS-SUP720-3BXL     SAL09222B4P Hw : 4.3
!                                          Fw : 8.1(3)
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-SUP720          SAL09232GEE Hw : 2.3
!                                          Fw : 12.2(17r)S2
!                                          Sw : 12.2(18)SXF
!           WS-F6K-PFC3BXL     SAL09222CUH Hw : 1.6
!
!#################################################################
!
!
upgrade fpd auto
version 12.2
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service internal
service counters max age 5
no service dhcp
!
hostname AR2
!
boot system disk0:s72033-adventerprisek9_wan-mz.122-18.SXF.bin
logging snmp-authfail
logging buffered 64000 informational
enable password cisco123
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
no ip source-route
ip spd mode aggressive
!
!
!
ip cef accounting non-recursive 
ip tftp source-interface Loopback0
no ip bootp server
ip multicast-routing 
ip igmp ssm-map enable
no ip igmp ssm-map query dns
ip igmp ssm-map static acl_SSM-map-DB 192.168.71.2
ip igmp ssm-map static acl_SSM-map-DS 192.168.72.2
ip igmp ssm-map static acl_SSM-map-DS-post-splice 192.168.160.2
ip tcp window-size 65535
ip tcp path-mtu-discovery
ip telnet source-interface Loopback0
no ip domain-lookup
vtp domain AR2
vtp mode transparent
mls ip multicast replication-mode ingress
mls ip multicast egress local
mls ip multicast flow-stat-timer 9
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 16 18 20 to 3
mls qos map dscp-cos 26 28 30 to 4
mls qos map dscp-cos 34 36 38 to 6
mls qos map dscp-cos 40 42 44 to 2
mls qos map dscp-cos 48 to 5
mls qos
mls rate-limit multicast ipv4 fib-miss 10000 250
mls rate-limit multicast ipv4 connected 2500 250
mls rate-limit multicast ipv4 igmp 1000 10
mls rate-limit multicast ipv4 partial 500 250
mls rate-limit unicast acl input 1000 10
mls rate-limit unicast acl output 1000 10
no mls rate-limit unicast acl vacl-log 
mls rate-limit all ttl-failure 100 10
mls rate-limit all mtu-failure 100 10
no mls acl tcam share-global
mls cef error action freeze
!
!
! 
!
!
!
!
!
!
!         
redundancy
 mode sso
 main-cpu
  auto-sync running-config
  auto-sync standard
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
no spanning-tree vlan 1-4094
error-detection packet-buffer action none
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
fabric buffer-reserve queue
!
vlan internal allocation policy ascending
!
!
interface Loopback0
 description RAN Loopback
 ip address 99.99.0.3 255.255.255.255
!
interface Null0
 no ip unreachables
!
interface TenGigabitEthernet1/1
 description Transport between SR1a (TenGig1/3)
 ip address 192.168.251.2 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/2
 description Transport between AR1 (TenGig1/2)
 ip address 192.168.249.2 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/3
 description Transport between HR3a (TenGig1/1)
 ip address 192.168.251.5 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/4
 no ip address
 shutdown
!
interface GigabitEthernet5/1
 no ip address
 shutdown
!
interface GigabitEthernet5/2
 description Management port for Syslog/TFTP/NTP
 ip address 1.1.1.3 255.255.255.0
 media-type rj45
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 router-id 99.99.0.3
 max-metric router-lsa on-startup wait-for-bgp
 log-adjacency-changes detail
 timers throttle spf 400 400 4000
 network 99.99.0.0 0.0.255.255 area 0
 network 192.168.249.0 0.0.0.255 area 0
 network 192.168.251.0 0.0.0.255 area 0
 maximum-paths 6
 default-information originate metric-type 1
!
router bgp 100
 no synchronization
 bgp router-id 99.99.0.3
 bgp log-neighbor-changes
 network 192.168.10.0 route-map rmap_Network-Management
 network 192.168.60.0 route-map rmap_Ad-Insertion
 network 192.168.71.0 route-map rmap_IPmc-DS-Source
 network 192.168.72.0 route-map rmap_IPmc-DB-Source
 network 192.168.80.0 route-map rmap_Voice
 network 192.168.90.0 route-map rmap_Internet-Access
 network 192.168.150.0 route-map rmap_Hub1
 network 192.168.160.0 route-map rmap_Hub2
 network 192.168.170.0 route-map rmap_Hub2
 network 192.168.180.0 route-map rmap_Hub3
 neighbor rr-client peer-group
 neighbor rr-client remote-as 100
 neighbor rr-client update-source Loopback0
 neighbor rr-client version 4
 neighbor rr-client route-reflector-client
 neighbor rr-client send-community
 neighbor ibgp peer-group
 neighbor ibgp remote-as 100
 neighbor ibgp update-source Loopback0
 neighbor ibgp version 4
 neighbor ibgp send-community
 neighbor 99.99.0.1 peer-group rr-client
 neighbor 99.99.0.1 description SR1a
 neighbor 99.99.0.2 peer-group ibgp
 neighbor 99.99.0.2 description AR1
 neighbor 99.99.0.4 peer-group rr-client
 neighbor 99.99.0.4 description HR1a
 neighbor 99.99.0.5 peer-group rr-client
 neighbor 99.99.0.5 description HR2a 
 neighbor 99.99.0.6 peer-group rr-client
 neighbor 99.99.0.6 description HR2b 
 neighbor 99.99.0.7 peer-group rr-client
 neighbor 99.99.0.7 description HR3a 
 no auto-summary
!
ip classless
!
ip bgp-community new-format
no ip http server
ip pim ssm range acl_SSM-IPmc-range
!
ip access-list standard acl_SSM-IPmc-range
 permit 239.0.0.0 0.255.255.255
ip access-list standard acl_SSM-map-DB
 remark SSM mapping for DB blue/red
 permit 239.16.0.0 0.0.0.255
ip access-list standard acl_SSM-map-DS
 remark SSM mapping for DS blue/red
 permit 239.20.0.0 0.0.255.255
ip access-list standard acl_SSM-map-DS-post-splice
 remark SSM mapping for post splice DS blue/red
 permit 239.28.0.0 0.0.255.255
!
logging event link-status default
logging trap debugging
logging source-interface Loopback0
logging 1.1.1.254
!
route-map rmap_Network-Management permit 100
 set metric 100
!
route-map rmap_Ad-Insertion permit 100
 set metric 100
!
route-map rmap_IPmc-DS-Source permit 100
 set metric 100
!
route-map rmap_IPmc-DB-Source permit 100
 set metric 100
!
route-map rmap_Voice permit 100
 set metric 100
!
route-map rmap_Internet-Access permit 100
 set metric 100
!
route-map rmap_Hub1 permit 100
 set metric 100
!
route-map rmap_Hub2 permit 100
 set metric 100
!
route-map rmap_Hub3 permit 100
 set metric 100
!
!
!
control-plane
!
!
!
dial-peer cor custom
!
!
!
banner motd ^C
################################################################


 Project = Video Networking Solution
 Switch = AR2

 Chassis = 6509
 Slot1 = WS-X6704 (3A)
 Slot5 = Sup720  (3BXL)


################################################################
^C
!
line con 0
 exec-timeout 0 0
 history size 100
 transport preferred none
line vty 0 4
 exec-timeout 0 0
 password cisco123
 login
 history size 100
 transport preferred none
!
monitor event-trace timestamps
scheduler runtime netinput 300
ntp clock-period 17179765
ntp source Loopback0
ntp update-calendar
ntp server 1.1.1.254
no cns aaa enable
end 

Configurations for the Hub Routers

The following configurations are presented:

Configuration for HR1a

Configuration for HR2a

Configuration for HR2b

Configuration for HR3a

Configuration for HR1a

!#################################################################
!
! Description
! ===========
! Video Networking Solution 3.0 
! HR1a running-config 
!
! Version Information
! ===================
! IOS
! ---
! 12.2(18)SXF
!
! Hardware
! --------
! 
! Mod  Port Model              Serial #    Versions
! ---- ---- ------------------ ----------- -----------------------
!   1    4  WS-X6704-10GE      SAL09337DQA Hw : 2.2
!                                          Fw : 12.2(14r)S5
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-F6700-DFC3BXL   SAL09274W3N Hw : 5.0
!   2   24  WS-X6724-SFP       SAL093486ND Hw : 2.3
!                                          Fw : 12.2(14r)S5
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-F6700-DFC3BXL   SAL0930689L Hw : 5.2
!   5    2  WS-SUP720-3BXL     SAL09337GL6 Hw : 4.3
!                                          Fw : 8.1(3)
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-SUP720          SAL09337FTZ Hw : 2.3
!                                          Fw : 12.2(17r)S2
!                                          Sw : 12.2(18)SXF
!           WS-F6K-PFC3BXL     SAL09337FN8 Hw : 1.6
! 
!#################################################################
!
!
upgrade fpd auto
version 12.2
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service internal
service counters max age 5
no service dhcp
!
hostname HR1a
!
boot system disk0:s72033-adventerprisek9_wan-mz.122-18.SXF.bin
logging snmp-authfail
logging buffered 64000 informational
no logging console
enable password cisco123
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
no ip source-route
ip spd mode aggressive
!
!
!
ip cef accounting non-recursive 
ip tftp source-interface Loopback0
no ip bootp server
ip multicast-routing 
ip igmp ssm-map enable
no ip igmp ssm-map query dns
ip igmp ssm-map static acl_SSM-map-DB 192.168.71.2
ip igmp ssm-map static acl_SSM-map-DS 192.168.72.2
ip igmp ssm-map static acl_SSM-map-DS-post-splice 192.168.160.2
ip tcp window-size 65535
ip tcp path-mtu-discovery
ip telnet source-interface Loopback0
no ip domain-lookup
vtp domain HR1a
vtp mode transparent
mls ip multicast replication-mode ingress
mls ip multicast flow-stat-timer 9
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 16 18 20 to 3
mls qos map dscp-cos 26 28 30 to 4
mls qos map dscp-cos 34 36 38 to 6
mls qos map dscp-cos 40 42 44 to 2
mls qos map dscp-cos 48 to 5
mls qos
mls rate-limit multicast ipv4 fib-miss 10000 250
mls rate-limit multicast ipv4 connected 2500 250
mls rate-limit multicast ipv4 igmp 1000 10
mls rate-limit multicast ipv4 ip-options 1000 10
mls rate-limit multicast ipv4 partial 500 250
mls rate-limit unicast acl input 1000 10
mls rate-limit unicast acl output 1000 10
no mls rate-limit unicast acl vacl-log 
mls rate-limit unicast ip options 1000 10
mls rate-limit all ttl-failure 100 10
mls rate-limit all mtu-failure 100 10
no mls acl tcam share-global
mls cef error action freeze
!
!
! 
!
!
!
!
!         
!
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
  auto-sync standard
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1-4094
!
power redundancy-mode combined
error-detection packet-buffer action none
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
fabric buffer-reserve queue
!
vlan internal allocation policy ascending
!
class-map match-all class_voice
  match access-group name acl_voice
class-map match-all class_broadcast-video
  match access-group name acl_broadcast-video
class-map match-all class_ad-server
  match access-group name acl_ad-server
class-map match-all class_video-signaling
  match access-group name acl_video-signaling
class-map match-all class_net-mgmt
  match access-group name acl_net-mgmt
class-map match-all class_internet-access
  match access-group name acl_internet-access
class-map match-all class_suspect
  match access-group name acl_permit-any
!
!
policy-map pmap_voice-port
  class class_voice
   trust dscp
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_broadcast-video-port
  class class_broadcast-video
   set dscp af41
  class class_video-signaling
   set dscp cs3
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_ad-server-port
  class class_ad-server
   set dscp af41
  class class_video-signaling
   set dscp cs3
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_net-mgmt-port
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_internet-access-port
  class class_internet-access
   set dscp 8
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
!
!
!
interface Loopback0
 description RAN Loopback
 ip address 99.99.0.4 255.255.255.255
!
interface Loopback1
 description Hub Loopback
 ip address 99.99.1.4 255.255.255.255
!
interface Null0
 no ip unreachables
!
interface TenGigabitEthernet1/1
 description Transport between AR1 (TenGig1/3)
 ip address 192.168.250.6 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip multicast boundary acl_Hub-only-IPmc
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/2
 no ip address
 shutdown
!
interface TenGigabitEthernet1/3
 description Transport between HR2a (TenGig1/1)
 ip address 192.168.250.9 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip multicast boundary acl_Hub-only-IPmc
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/4
 no ip address
 shutdown
!
!
!
interface GigabitEthernet5/1
 no ip address
 shutdown
!
interface GigabitEthernet5/2
 description Management port for Syslog/TFTP/NTP
 ip address 1.1.1.4 255.255.255.0
 media-type rj45
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 router-id 99.99.0.4
 max-metric router-lsa on-startup wait-for-bgp
 log-adjacency-changes detail
 timers throttle spf 400 400 4000
 passive-interface default
 no passive-interface TenGigabitEthernet1/1
 no passive-interface TenGigabitEthernet1/3
 network 99.99.0.0 0.0.255.255 area 0
 network 192.168.250.0 0.0.0.255 area 0
 maximum-paths 6
!
router bgp 100
 no synchronization
 bgp router-id 99.99.0.4
 bgp log-neighbor-changes
 redistribute connected route-map rmap_Connected-to-BGP
 neighbor rr-server peer-group
 neighbor rr-server remote-as 100
 neighbor rr-server update-source Loopback0
 neighbor rr-server version 4
 neighbor rr-server send-community
 neighbor 99.99.0.2 peer-group rr-server
 neighbor 99.99.0.2 description AR1
 neighbor 99.99.0.3 peer-group rr-server
 neighbor 99.99.0.3 description AR2
 no auto-summary
!
ip classless
!
ip bgp-community new-format
no ip http server
ip pim ssm range acl_SSM-IPmc-range
!
ip access-list standard acl_SSM-IPmc-range
 permit 239.0.0.0 0.255.255.255
ip access-list standard acl_SSM-map-DB
 remark SSM mapping for DB blue/red
 permit 239.16.0.0 0.0.0.255
ip access-list standard acl_SSM-map-DS
 remark SSM mapping for DS blue/red
 permit 239.20.0.0 0.0.255.255
ip access-list standard acl_SSM-map-DS-post-splice
 remark SSM mapping for post splice DS blue/red
 permit 239.28.0.0 0.0.255.255
!
ip access-list extended acl_voice
 remark Identify voice traffic
 permit ip any 192.168.80.0 0.0.0.255
ip access-list extended acl_broadcast-video
 remark Identify broadcast video traffic (multicast on 239.x.x.x)
 permit ip any 239.0.0.0 0.255.255.255
ip access-list extended acl_video-signaling
 remark Identify video signaling
 permit ip any 192.168.61.0 0.0.0.255
ip access-list extended acl_net-mgmt
 remark Identify net management traffic (TFTP, Syslog, NTP, etc)
 permit ip any 192.168.10.0 0.0.0.255 
ip access-list extended acl_internet-access
 remark Identify Internet access traffic 
 permit ip any 192.168.90.0 0.0.0.255
ip access-list extended acl_permit-any
 permit ip any any
!
ip access-list extended acl_qam-port
 remark Permit only video and signaling out port connected to QAM
 permit ip any any dscp af41
 permit ip any any dscp af43
 permit ip any any dscp cs3
 permit ip any any dscp cs6
 deny   ip any any
ip access-list standard acl_Hub-only-IPmc
 remark Multicast video in 239.255.0.0/16 must remain in Hub
 deny   239.255.0.0 0.0.255.255
 remark Allow all other IPmc to pass
 permit any
!
!         
ip prefix-list pl_Connected-to-BGP seq 5 permit 192.168.150.0/24 le 32
logging event link-status default
logging trap debugging
logging source-interface Loopback0
logging 1.1.1.254
!
route-map rmap_Connected-to-BGP permit 100
 match ip address prefix-list pl_Connected-to-BGP
 set metric 100
 set ip next-hop 99.99.0.4
!
!
!
control-plane
!
!
!
dial-peer cor custom
!
!
!
banner motd ^C
################################################################


 Project = Video Networking Solution
 Switch = HR1a

 Chassis = 7606
 Slot1 = WS-X6704 (3BXL)
 Slot2 = WS-X6724 (3BXL)
 Slot5 = Sup720  (3BXL)


################################################################
^C
!
line con 0
 exec-timeout 0 0
 history size 100
 transport preferred none
line vty 0 4
 exec-timeout 0 0
 password cisco123
 login    
 history size 100
 transport preferred none
!
scheduler runtime netinput 300
ntp clock-period 17179872
ntp source Loopback0
ntp update-calendar
ntp server 1.1.1.254
no cns aaa enable
end

Configuration for HR2a

!#################################################################
!
! Description
! ===========
! Video Networking Solution 3.0 
! HR2a running-config 
!
! Version Information
! ===================
! IOS
! ---
! 12.2(18)SXF
!
! Hardware
! --------
! 
! Mod  Port Model              Serial #    Versions
! ---- ---- ------------------ ----------- ----------------------
!   1    4  WS-X6704-10GE      SAL09337DN3 Hw : 2.2
!                                          Fw : 12.2(14r)S5
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-F6700-DFC3BXL   SAL09295P64 Hw : 5.0
!   2   48  WS-X6748-GE-TX     SAD0805027C Hw : 1.4
!                                          Fw : 12.2(14r)S5
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-F6700-DFC3BXL   SAD0917016G Hw : 4.0
!   5    2  WS-SUP720-3BXL     SAL09169RG7 Hw : 4.3
!                                          Fw : 8.1(3)
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-SUP720          SAL09169UAY Hw : 2.3
!                                          Fw : 12.2(17r)S2
!                                          Sw : 12.2(18)SXF
!           WS-F6K-PFC3BXL     SAL091594SL Hw : 1.6
! 
!#################################################################
!
!
upgrade fpd auto
version 12.2
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service internal
service counters max age 5
no service dhcp
!
hostname HR2a
!
boot system disk0:s72033-adventerprisek9_wan-mz.122-18.SXF.bin
logging snmp-authfail
logging buffered 64000 informational
no logging console
enable password cisco123
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
no ip source-route
ip spd mode aggressive
!
!
!
ip cef accounting non-recursive 
ip tftp source-interface Loopback0
no ip bootp server
ip multicast-routing 
ip igmp ssm-map enable
no ip igmp ssm-map query dns
ip igmp ssm-map static acl_SSM-map-DB 192.168.71.2
ip igmp ssm-map static acl_SSM-map-DS 192.168.72.2
ip igmp ssm-map static acl_SSM-map-DS-post-splice 192.168.160.2
ip tcp window-size 65535
ip tcp path-mtu-discovery
ip telnet source-interface Loopback0
no ip domain-lookup
vtp domain HR2a
vtp mode transparent
mls ip multicast replication-mode ingress
mls ip multicast flow-stat-timer 9
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 16 18 20 to 3
mls qos map dscp-cos 26 28 30 to 4
mls qos map dscp-cos 34 36 38 to 6
mls qos map dscp-cos 40 42 44 to 2
mls qos map dscp-cos 48 to 5
mls qos
mls rate-limit multicast ipv4 fib-miss 10000 250
mls rate-limit multicast ipv4 connected 2500 250
mls rate-limit multicast ipv4 igmp 1000 10
mls rate-limit multicast ipv4 ip-options 1000 10
mls rate-limit multicast ipv4 partial 500 250
mls rate-limit unicast acl input 1000 10
mls rate-limit unicast acl output 1000 10
no mls rate-limit unicast acl vacl-log 
mls rate-limit unicast ip options 1000 10
mls rate-limit all ttl-failure 100 10
mls rate-limit all mtu-failure 100 10
no mls acl tcam share-global
mls cef error action freeze
!
!
! 
!
!
!
!
!         
!
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
  auto-sync standard
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1-4094
error-detection packet-buffer action none
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
fabric buffer-reserve queue
!
vlan internal allocation policy ascending
!
class-map match-all class_voice
  match access-group name acl_voice
class-map match-all class_broadcast-video
  match access-group name acl_broadcast-video
class-map match-all class_ad-server
  match access-group name acl_ad-server
class-map match-all class_video-signaling
  match access-group name acl_video-signaling
class-map match-all class_net-mgmt
  match access-group name acl_net-mgmt
class-map match-all class_internet-access
  match access-group name acl_internet-access
class-map match-all class_suspect
  match access-group name acl_permit-any
!
!
policy-map pmap_voice-port
  class class_voice
   trust dscp
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_broadcast-video-port
  class class_broadcast-video
   set dscp af41
  class class_video-signaling
   set dscp cs3
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_ad-server-port
  class class_ad-server
   set dscp af41
  class class_video-signaling
   set dscp cs3
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_net-mgmt-port
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_internet-access-port
  class class_internet-access
   set dscp 8
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
!
!
!         
interface Loopback0
 description RAN Loopback
 ip address 99.99.0.5 255.255.255.255
!
interface Loopback1
 description Hub Loopbacks
 ip address 99.99.1.6 255.255.255.255 secondary
 ip address 99.99.1.5 255.255.255.255
 no ip redirects
!
interface Loopback99
 description Multicast Rendevouz Point
 ip address 99.99.99.5 255.255.255.255
!
interface Null0
 no ip unreachables
!
interface TenGigabitEthernet1/1
 description Transport between HR1a (TenGig1/3)
 ip address 192.168.250.10 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip multicast boundary acl_Hub-only-IPmc
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/2
 no ip address
 shutdown
!
interface TenGigabitEthernet1/3
 description Transport between HR2b (TenGig1/3)
 ip address 192.168.249.5 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/4
 no ip address
 shutdown
!
interface GigabitEthernet2/1
 description Voice over IP VoIP2a
 ip address 192.168.161.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 no cdp enable
 service-policy input pmap_voice-port
!         
interface GigabitEthernet2/2
 description Internet Access IA2a
 ip address 192.168.162.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 no cdp enable
 service-policy input pmap_internet-access-port
!
interface GigabitEthernet2/3
 description Local PEG video PEG2a
 ip address 192.168.160.13 255.255.255.252
 ip access-group acl_qam-port out
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 no cdp enable
 service-policy input pmap_broadcast-video-port
!         
interface GigabitEthernet2/4
 description CherryPicker DM2a (Port 1) - Pre/Post-splice DS
 ip address 192.168.160.1 255.255.255.252
 ip access-group acl_qam-port out
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 no cdp enable
 service-policy input pmap_broadcast-video-port
!
interface GigabitEthernet2/5
 description Motorola SEM2a (GigE 1) - DS Post-splice
 ip address 192.168.160.5 255.255.255.252
 ip access-group acl_qam-port out
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 no cdp enable
 service-policy input pmap_broadcast-video-port
!
interface GigabitEthernet2/6
 description Motorola SEM2b (GigE 1) - DB
 ip address 192.168.160.9 255.255.255.252
 ip access-group acl_qam-port out
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 no cdp enable
 service-policy input pmap_broadcast-video-port
!
interface GigabitEthernet2/7
 no ip address
 shutdown
!
!
! <<<omitted interface GigabitEthernet2/8 - interface GigabitEthernet2/47
!
!
interface GigabitEthernet2/48
 no ip address
 shutdown
!
interface GigabitEthernet5/1
 no ip address
 shutdown
!
interface GigabitEthernet5/2
 description Management port for Syslog/TFTP/NTP
 ip address 1.1.1.5 255.255.255.0
 media-type rj45
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 router-id 99.99.0.5
 max-metric router-lsa on-startup wait-for-bgp
 log-adjacency-changes detail
 timers throttle spf 400 400 4000
 passive-interface default
 no passive-interface TenGigabitEthernet1/1
 no passive-interface TenGigabitEthernet1/3
 network 99.99.0.0 0.0.255.255 area 0
 network 192.168.249.0 0.0.0.255 area 0
 network 192.168.250.0 0.0.0.255 area 0
 maximum-paths 6
!
router bgp 100
 no synchronization
 bgp router-id 99.99.0.5
 bgp log-neighbor-changes
 redistribute connected route-map rmap_Connected-to-BGP
 neighbor rr-server peer-group
 neighbor rr-server remote-as 100
 neighbor rr-server update-source Loopback0
 neighbor rr-server version 4
 neighbor rr-server send-community
 neighbor 99.99.0.2 peer-group rr-server
 neighbor 99.99.0.2 description AR1
 neighbor 99.99.0.3 peer-group rr-server
 neighbor 99.99.0.3 description AR2
 no auto-summary
!
ip classless
!
ip bgp-community new-format
no ip http server
ip pim ssm range acl_SSM-IPmc-range
!
ip access-list standard acl_SSM-IPmc-range
 permit 239.0.0.0 0.255.255.255
ip access-list standard acl_SSM-map-DB
 remark SSM mapping for DB blue/red
 permit 239.16.0.0 0.0.0.255
ip access-list standard acl_SSM-map-DS
 remark SSM mapping for DS blue/red
 permit 239.20.0.0 0.0.255.255
ip access-list standard acl_SSM-map-DS-post-splice
 remark SSM mapping for post splice DS blue/red
 permit 239.28.0.0 0.0.255.255
!
ip access-list extended acl_voice
 remark Identify voice traffic
 permit ip any 192.168.80.0 0.0.0.255
ip access-list extended acl_broadcast-video
 remark Identify broadcast video traffic (multicast on 239.x.x.x)
 permit ip any 239.0.0.0 0.255.255.255
ip access-list extended acl_video-signaling
 remark Identify video signaling
 permit ip any 192.168.61.0 0.0.0.255
ip access-list extended acl_net-mgmt
 remark Identify net management traffic (TFTP, Syslog, NTP, etc)
 permit ip any 192.168.10.0 0.0.0.255 
ip access-list extended acl_internet-access
 remark Identify Internet access traffic 
 permit ip any 192.168.90.0 0.0.0.255
ip access-list extended acl_permit-any
 permit ip any any
!
ip access-list extended acl_qam-port
 remark Permit only video and signaling out port connected to QAM
 permit ip any any dscp af41
 permit ip any any dscp af43
 permit ip any any dscp cs3
 permit ip any any dscp cs6
 deny   ip any any
ip access-list standard acl_Hub-only-IPmc
 remark Multicast video in 239.255.0.0/16 must remain in Hub
 deny   239.255.0.0 0.0.255.255
 remark Allow all other IPmc to pass
 permit any
!
!
ip prefix-list pl_Connected-to-BGP seq 5 permit 192.168.160.0/24 le 32
logging event link-status default
logging trap debugging
logging source-interface Loopback0
logging 1.1.1.254
!
route-map rmap_Connected-to-BGP permit 100
 match ip address prefix-list pl_Connected-to-BGP
 set metric 100
 set ip next-hop 99.99.0.5
!
!
!
control-plane
!
!
!
dial-peer cor custom
!
!
!
banner motd ^C
################################################################

 Project = Video Networking Solution
 Switch = HR2a

 Chassis = 7606
 Slot1 = WS-X6704 (3BXL)
 Slot2 = WS-X6748 (3BXL)
 Slot5 = Sup720  (3BXL)


################################################################
^C
!
line con 0
 exec-timeout 0 0
 history size 100
 transport preferred none
line vty 0 4
 exec-timeout 0 0
 password cisco123
 login
 history size 100
 transport preferred none
!
scheduler runtime netinput 300
ntp clock-period 17179860
ntp source Loopback0
ntp update-calendar
ntp server 1.1.1.254
no cns aaa enable
end

Configuration for HR2b

!#################################################################
!
! Description
! ===========
! Video Networking Solution 3.0 
! HR2b running-config 
!
! Version Information
! ===================
! IOS
! ---
! 12.2(18)SXF
!
! Hardware
! --------
! 
! Mod  Port Model              Serial #    Versions
! ---- ---- ------------------ ----------- ---------------------
!   1    4  WS-X6704-10GE      SAD074604B5 Hw : 1.2
!                                          Fw : 12.2(14r)S5
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-F6700-DFC3A     SAD08150203 Hw : 2.1
!   2   24  WS-X6724-SFP       SAD091503A7 Hw : 2.2
!                                          Fw : 12.2(14r)S5
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-F6700-DFC3A     SAD08140B7D Hw : 2.1
!   5    2  WS-SUP720-BASE     SAD07510A0A Hw : 3.0
!                                          Fw : 7.7(1)
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-SUP720          SAD075109GK Hw : 2.0
!                                          Fw : 12.2(14r)S9
!                                          Sw : 12.2(18)SXF
!           WS-F6K-PFC3BXL     SAD0817029M Hw : 1.2
! 
!#################################################################
!
!
upgrade fpd auto
version 12.2
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service internal
service counters max age 5
no service dhcp
!
hostname HR2b
!
boot system disk0:s72033-adventerprisek9_wan-mz.122-18.SXF.bin
logging snmp-authfail
logging buffered 64000 informational
enable password cisco123
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
no ip source-route
ip spd mode aggressive
!
!
!
ip cef accounting non-recursive 
ip tftp source-interface Loopback0
no ip bootp server
ip multicast-routing 
ip igmp ssm-map enable
no ip igmp ssm-map query dns
ip igmp ssm-map static acl_SSM-map-DB 192.168.71.2
ip igmp ssm-map static acl_SSM-map-DS 192.168.72.2
ip igmp ssm-map static acl_SSM-map-DS-post-splice 192.168.160.2
ip tcp window-size 65535
ip tcp path-mtu-discovery
ip telnet source-interface Loopback0
no ip domain-lookup
vtp domain HR2b
vtp mode transparent
mls ip multicast replication-mode ingress
mls ip multicast flow-stat-timer 9
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 16 18 20 to 3
mls qos map dscp-cos 26 28 30 to 4
mls qos map dscp-cos 34 36 38 to 6
mls qos map dscp-cos 40 42 44 to 2
mls qos map dscp-cos 48 to 5
mls qos
mls rate-limit multicast ipv4 fib-miss 10000 250
mls rate-limit multicast ipv4 connected 2500 250
mls rate-limit multicast ipv4 igmp 1000 10
mls rate-limit multicast ipv4 partial 500 250
mls rate-limit unicast acl input 1000 10
mls rate-limit unicast acl output 1000 10
no mls rate-limit unicast acl vacl-log 
mls rate-limit all ttl-failure 100 10
mls rate-limit all mtu-failure 100 10
no mls acl tcam share-global
mls cef error action freeze
!
!
!
!
!
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
  auto-sync standard
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1-4094
!
power redundancy-mode combined
error-detection packet-buffer action none
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
fabric buffer-reserve queue
!
vlan internal allocation policy ascending
!
class-map match-all class_voice
  match access-group name acl_voice
class-map match-all class_broadcast-video
  match access-group name acl_broadcast-video
class-map match-all class_ad-server
  match access-group name acl_ad-server
class-map match-all class_video-signaling
  match access-group name acl_video-signaling
class-map match-all class_net-mgmt
  match access-group name acl_net-mgmt
class-map match-all class_internet-access
  match access-group name acl_internet-access
class-map match-all class_suspect
  match access-group name acl_permit-any
!
!
policy-map pmap_voice-port
  class class_voice
   trust dscp
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_broadcast-video-port
  class class_broadcast-video
   set dscp af41
  class class_video-signaling
   set dscp cs3
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_ad-server-port
  class class_ad-server
   set dscp af41
  class class_video-signaling
   set dscp cs3
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_net-mgmt-port
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_internet-access-port
  class class_internet-access
   set dscp 8
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
!
!
!
interface Loopback0
 description RAN Loopback
 ip address 99.99.0.6 255.255.255.255
!         
interface Loopback1
 description Hub Loopbacks
 ip address 99.99.1.5 255.255.255.255 secondary
 ip address 99.99.1.6 255.255.255.255
 no ip redirects
!
interface Null0
 no ip unreachables
!
interface TenGigabitEthernet1/1
 description Transport between HR3a (TenGig1/3)
 ip address 192.168.251.10 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip multicast boundary acl_Hub-only-IPmc
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/2
 no ip address
 shutdown
!
interface TenGigabitEthernet1/3
 description Transport between HR2a (TenGig1/3)
 ip address 192.168.249.6 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/4
 no ip address
 shutdown
!         
interface GigabitEthernet5/1
 no ip address
 shutdown
!
interface GigabitEthernet5/2
 description Management port for Syslog/TFTP/NTP
 ip address 1.1.1.6 255.255.255.0
 media-type rj45
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 router-id 99.99.0.6
 max-metric router-lsa on-startup wait-for-bgp
 log-adjacency-changes detail
 timers throttle spf 400 400 4000
 passive-interface default
 no passive-interface TenGigabitEthernet1/1
 no passive-interface TenGigabitEthernet1/3
 network 99.99.0.0 0.0.255.255 area 0
 network 192.168.249.0 0.0.0.255 area 0
 network 192.168.251.0 0.0.0.255 area 0
 maximum-paths 6
!
router bgp 100
 no synchronization
 bgp router-id 99.99.0.6
 bgp log-neighbor-changes
 redistribute connected route-map rmap_Connected-to-BGP
 neighbor rr-server peer-group
 neighbor rr-server remote-as 100
 neighbor rr-server update-source Loopback0
 neighbor rr-server version 4
 neighbor rr-server send-community
 neighbor 99.99.0.2 peer-group rr-server
 neighbor 99.99.0.2 description AR1
 neighbor 99.99.0.3 peer-group rr-server
 neighbor 99.99.0.3 description AR2
 no auto-summary
!
ip classless
!
ip bgp-community new-format
no ip http server
ip pim ssm range acl_SSM-IPmc-range
!
ip access-list standard acl_SSM-IPmc-range
 permit 239.0.0.0 0.255.255.255
ip access-list standard acl_SSM-map-DB
 remark SSM mapping for DB blue/red
 permit 239.16.0.0 0.0.0.255
ip access-list standard acl_SSM-map-DS
 remark SSM mapping for DS blue/red
 permit 239.20.0.0 0.0.255.255
ip access-list standard acl_SSM-map-DS-post-splice
 remark SSM mapping for post splice DS blue/red
 permit 239.28.0.0 0.0.255.255
!
ip access-list extended acl_voice
 remark Identify voice traffic
 permit ip any 192.168.80.0 0.0.0.255   
ip access-list extended acl_broadcast-video
 remark Identify broadcast video traffic (multicast on 239.x.x.x)
 permit ip any 239.0.0.0 0.255.255.255
ip access-list extended acl_video-signaling
 remark Identify video signaling
 permit ip any 192.168.61.0 0.0.0.255
ip access-list extended acl_net-mgmt
 remark Identify net management traffic (TFTP, Syslog, NTP, etc)
 permit ip any 192.168.10.0 0.0.0.255 
ip access-list extended acl_internet-access
 remark Identify Internet access traffic 
 permit ip any 192.168.90.0 0.0.0.255
ip access-list extended acl_permit-any
 permit ip any any
!
ip access-list extended acl_qam-port
 remark Permit only video and sinaling out port connected to QAM
 permit ip any any dscp af41
 permit ip any any dscp af43
 permit ip any any dscp cs3
 permit ip any any dscp cs6
 deny   ip any any
ip access-list standard acl_Hub-only-IPmc
 remark Multicast video in 239.255.0.0/16 must remain in Hub
 deny   239.255.0.0 0.0.255.255
 remark Allow all other IPmc to pass
 permit any
!
!
ip prefix-list pl_Connected-to-BGP seq 5 permit 192.168.170.0/24 le 32
logging event link-status default
logging source-interface Loopback0
logging 1.1.1.254
!
route-map rmap_Connected-to-BGP permit 100
 match ip address prefix-list pl_Connected-to-BGP
 set metric 100
 set ip next-hop 99.99.0.6
!
!
!         
control-plane
!
!
!
dial-peer cor custom
!
!
!
banner motd ^C
################################################################


 Project = Video Networking Solution
 Switch = HR2b

 Chassis = 7606
 Slot1 = WS-X6704 (3A)
 Slot2 = WS-X6748 (3A)
 Slot5 = Sup720  (3BXL)


################################################################
^C
!
line con 0
 exec-timeout 0 0
 history size 100
 transport preferred none
line vty 0 4
 exec-timeout 0 0
 password cisco123
 login
 history size 100
 transport preferred none
!
scheduler runtime netinput 300
ntp clock-period 17179977
ntp source Loopback0
ntp update-calendar
ntp server 1.1.1.254
no cns aaa enable
end

Configuration for HR3a

!#################################################################
!
! Description
! ===========
! Video Networking Solution 3.0 
! HR3a running-config 
!
! Version Information
! ===================
! IOS
! ---
! 12.2(18)SXF
!
! Hardware
! --------
! 
! Mod  Port Model              Serial #    Versions
! ---- ---- ------------------ ----------- -------------------------------------
!   1    4  WS-X6704-10GE      SAL09337QJF Hw : 2.2
!                                          Fw : 12.2(14r)S5
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-F6700-DFC3A     SAD08240A5L Hw : 2.2
!   2   48  WS-X6748-GE-TX     SAL091052FB Hw : 2.1
!                                          Fw : 12.2(14r)S5
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-F6700-DFC3A     SAD0816029X Hw : 2.2
!   5    2  WS-SUP720-3BXL     SAL09337CES Hw : 4.3
!                                          Fw : 8.1(3)
!                                          Sw : 12.2(18)SXF
!                                          Sw1: 8.6(0.123)RFW8 
!           WS-SUP720          SAL09316T46 Hw : 2.3
!                                          Fw : 12.2(17r)S2
!                                          Sw : 12.2(18)SXF
!           WS-F6K-PFC3BXL     SAL09337FPL Hw : 1.6
! 
!#################################################################
!
!
upgrade fpd auto
version 12.2
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service internal
service counters max age 5
no service dhcp
!
hostname HR3a
!
boot system disk0:s72033-adventerprisek9_wan-mz.122-18.SXF.bin
logging snmp-authfail
logging buffered 64000 informational
enable password cisco123
!         
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
no ip source-route
ip spd mode aggressive
!
!
!
ip cef accounting non-recursive 
ip tftp source-interface Loopback0
no ip bootp server
ip multicast-routing 
ip igmp ssm-map enable
no ip igmp ssm-map query dns
ip igmp ssm-map static acl_SSM-map-DB 192.168.71.2
ip igmp ssm-map static acl_SSM-map-DS 192.168.72.2
ip igmp ssm-map static acl_SSM-map-DS-post-splice 192.168.160.2
ip tcp window-size 65535
ip tcp path-mtu-discovery
ip telnet source-interface Loopback0
no ip domain-lookup
vtp domain HR3a
vtp mode transparent
mls ip multicast replication-mode ingress
mls ip multicast flow-stat-timer 9
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 16 18 20 to 3
mls qos map dscp-cos 26 28 30 to 4
mls qos map dscp-cos 34 36 38 to 6
mls qos map dscp-cos 40 42 44 to 2
mls qos map dscp-cos 48 to 5
mls qos
mls rate-limit multicast ipv4 fib-miss 10000 250
mls rate-limit multicast ipv4 connected 2500 250
mls rate-limit multicast ipv4 igmp 1000 10
mls rate-limit multicast ipv4 partial 500 250
mls rate-limit unicast acl input 1000 10
mls rate-limit unicast acl output 1000 10
no mls rate-limit unicast acl vacl-log 
mls rate-limit all ttl-failure 100 10
mls rate-limit all mtu-failure 100 10
no mls acl tcam share-global
mls cef error action freeze
!
!
! 
!
!
!
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
  auto-sync standard
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1-4094
!
power redundancy-mode combined
error-detection packet-buffer action none
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
fabric buffer-reserve queue
!
vlan internal allocation policy ascending
!
class-map match-all class_voice
  match access-group name acl_voice
class-map match-all class_broadcast-video
  match access-group name acl_broadcast-video
class-map match-all class_ad-server
  match access-group name acl_ad-server
class-map match-all class_video-signaling
  match access-group name acl_video-signaling
class-map match-all class_net-mgmt
  match access-group name acl_net-mgmt
class-map match-all class_internet-access
  match access-group name acl_internet-access
class-map match-all class_suspect
  match access-group name acl_permit-any
!
!
policy-map pmap_voice-port
  class class_voice
   trust dscp
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_broadcast-video-port
  class class_broadcast-video
   set dscp af41
  class class_video-signaling
   set dscp cs3
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_ad-server-port
  class class_ad-server
   set dscp af41
  class class_video-signaling
   set dscp cs3
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_net-mgmt-port
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
policy-map pmap_internet-access-port
  class class_internet-access
   set dscp 8
  class class_net-mgmt
   set dscp cs2
  class class_suspect
   set dscp default
!
!
!
interface Loopback0
 description RAN Loopback
 ip address 99.99.0.7 255.255.255.255
!
interface Loopback1
 description Hub Loopback
 ip address 99.99.1.7 255.255.255.255
!
interface Null0
 no ip unreachables
!
interface TenGigabitEthernet1/1
 description Transport between AR2 (TenGig1/3)
 ip address 192.168.251.6 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip multicast boundary acl_Hub-only-IPmc
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/2
 no ip address
 shutdown
!         
interface TenGigabitEthernet1/3
 description Transport between HR2b (TenGig1/1)
 ip address 192.168.251.9 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip pim sparse-mode
 ip multicast boundary acl_Hub-only-IPmc
 ip ospf network point-to-point
 ip ospf hello-interval 1
 wrr-queue cos-map 1 3 2 
 wrr-queue cos-map 2 1 3 
 wrr-queue cos-map 2 2 4 
 mls qos trust dscp
!
interface TenGigabitEthernet1/4
 no ip address
 shutdown
!
!
interface GigabitEthernet5/1
 no ip address
 shutdown
!
interface GigabitEthernet5/2
 description Management port for Syslog/TFTP/NTP
 ip address 1.1.1.7 255.255.255.0
 media-type rj45
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 100
 router-id 99.99.0.7
 max-metric router-lsa on-startup wait-for-bgp
 log-adjacency-changes detail
 timers throttle spf 400 400 4000
 passive-interface default
 no passive-interface TenGigabitEthernet1/1
 no passive-interface TenGigabitEthernet1/3
 network 99.99.0.0 0.0.255.255 area 0
 network 192.168.251.0 0.0.0.255 area 0
 maximum-paths 6
!
router bgp 100
 no synchronization
 bgp router-id 99.99.0.7
 bgp log-neighbor-changes
 redistribute connected route-map rmap_Connected-to-BGP
 neighbor rr-server peer-group
 neighbor rr-server remote-as 100
 neighbor rr-server update-source Loopback0
 neighbor rr-server version 4
 neighbor rr-server send-community
 neighbor 99.99.0.2 peer-group rr-server
 neighbor 99.99.0.2 description AR1
 neighbor 99.99.0.3 peer-group rr-server
 neighbor 99.99.0.3 description AR2
 no auto-summary
!
ip classless
!
ip bgp-community new-format
no ip http server
ip pim ssm range acl_SSM-IPmc-range
!
ip access-list standard acl_SSM-IPmc-range
 permit 239.0.0.0 0.255.255.255
ip access-list standard acl_SSM-map-DB
 remark SSM mapping for DB blue/red
 permit 239.16.0.0 0.0.0.255
ip access-list standard acl_SSM-map-DS
 remark SSM mapping for DS blue/red
 permit 239.20.0.0 0.0.255.255
ip access-list standard acl_SSM-map-DS-post-splice
 remark SSM mapping for post splice DS blue/red
 permit 239.28.0.0 0.0.255.255
!
ip access-list extended acl_voice
 remark Identify voice traffic
 permit ip any 192.168.80.0 0.0.0.255   
ip access-list extended acl_broadcast-video
 remark Identify broadcast video traffic (multicast on 239.x.x.x)
 permit ip any 239.0.0.0 0.255.255.255
ip access-list extended acl_video-signaling
 remark Identify video signaling
 permit ip any 192.168.61.0 0.0.0.255
ip access-list extended acl_net-mgmt
 remark Identify net management traffic (TFTP, Syslog, NTP, etc)
 permit ip any 192.168.10.0 0.0.0.255 
ip access-list extended acl_internet-access
 remark Identify Internet access traffic 
 permit ip any 192.168.90.0 0.0.0.255
ip access-list extended acl_permit-any
 permit ip any any
!
ip access-list extended acl_qam-port
 remark Permit only video and sinaling out port connected to QAM
 permit ip any any dscp af41
 permit ip any any dscp af43
 permit ip any any dscp cs3
 permit ip any any dscp cs6
 deny   ip any any
ip access-list standard acl_Hub-only-IPmc
 remark Multicast video in 239.255.0.0/16 must remain in Hub
 deny   239.255.0.0 0.0.255.255
 remark Allow all other IPmc to pass
 permit any
!
ip prefix-list pl_Connected-to-BGP seq 5 permit 192.168.180.0/24 le 32
logging event link-status default
logging source-interface Loopback0
logging 1.1.1.254
!
route-map rmap_Connected-to-BGP permit 100
 match ip address prefix-list pl_Connected-to-BGP
 set metric 100
 set ip next-hop 99.99.0.7
!
!
!
control-plane
!
!
!
dial-peer cor custom
!
!
!
banner motd ^C
################################################################


 Project = Video Networking Solution
 Switch = HR3a

 Chassis = 7606
 Slot1 = WS-X6704 (3A)
 Slot2 = WS-X6748 (3A)
 Slot5 = Sup720  (3BXL)


################################################################
^C
!
line con 0
 exec-timeout 0 0
 history size 100
 transport preferred none
line vty 0 4
 exec-timeout 0 0
 password cisco123
 login
 history size 100
 transport preferred none
!
scheduler runtime netinput 300
ntp clock-period 17179820
ntp source Loopback0
ntp update-calendar
ntp server 1.1.1.254
no cns aaa enable
end