Guest

Support

Gatekeeper and Gateway Config file

  • Viewing Options

  • PDF (413.7 KB)
  • Feedback
Gatekeeper and Gateway Configurations

Table Of Contents

Gatekeeper and Gateway Configurations

Related Documentation

Reference Configuration

Network Topologies

Configuration Details

Cisco 3745 Gatekeeper Configuration

Cisco Intracluster Gatekeeper Cluster Configuration

Standard H.323 Gateway Configuration File

H323 SRST Gateway Configuration File

Voice Gateway (CMM) Configuration File

Standard MGCP Gateway Configuration File

SIP Gateway Configuration


Gatekeeper and Gateway Configurations


This topic provides a reference configuration for Gatekeepers and Gateways within a Cisco Unified Communications deployment. The information is based primarily on testing performed during Cisco Unified Communications Release 7.0(1) system testing. This topic does not contain detailed step-by-step procedures; instead, for or detailed information about installing, configuring, and administering Gatekeepers and Gateways, refer to the Gatekeepers and Gateways documentation listed in Table 1.

Related Documentation

For related information, refer to the documentation that is listed in Table 1

Table 1 Gatekeeper and Gateway Related Documentation 

Topic
Reference

Understanding Cisco IOS Gatekeeper Call Routing

http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a00800a8928.shtml

Zone Prefix Processing with Dots Versus Asterisks

http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a00800a99c4.shtml

Understanding H.323 Gatekeepers

http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a00800c5e0d.shtml

H.323 VoIP Call Preservation Enhancements for WAN Link Failures

http://www.cisco.com/en/US/products/ps6441/products_feature_guide09186a008069ad1b.html

Configuring Media Inactive Call Detection

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_administration_guide_chapter09186a0080557f7a.html


Reference Configuration

The system-wide testing of IP telephony functionality for Cisco Unified Communications Release 7.0(1) included Gatekeepers and Gateways. For general information about the tested functionality in Cisco Unified Communications Release 7.0(1), see the System Release Notes for IP Telephony for Enterprise and Midmarket: Unified Communications System, Release 7.0(1).

Network Topologies

During Cisco Unified Communications Release 7.0(1) testing, this component was installed and tested in the following site models:

Load tested in the SFO-ORD sites

Load tested in the SJC-RFD sites

Load tested in DFW site

Load tested in the ATL-YYZ sites

Load tested in the AZO site

For more information on these site models, see Tested Deployments and Site Models.

Configuration Details

This topic includes the following sections:

Cisco 3745 Gatekeeper Configuration

Cisco Intracluster Gatekeeper Cluster Configuration

Standard H.323 Gateway Configuration File

H323 SRST Gateway Configuration File

Voice Gateway (CMM) Configuration File

Standard MGCP Gateway Configuration File

SIP Gateway Configuration

Cisco 3745 Gatekeeper Configuration

The following sections show configuration for the gatekeepers that were used for gatekeeper-controlled intercluster trunks:

Primary Gatekeeper Configuration

Alternate Gatekeeper Configuration

The first configuration is for the primary gatekeeper, SJC-RFD-GK-1, from a pair of gatekeepers that form a gatekeeper cluster. A gatekeeper cluster provides alternate gatekeeper functionality if one of the gatekeepers fails. The second configuration is for the alternate gatekeeper, has a configuration that references the primary gatekeeper.

The intercluster gatekeepers were used to distribute calls for the following site models

Multi-site Centralized, Clustering over the WAN with Unified SRST (SFO-ORD)

Very Large Campus with Clustering over the WAN (SJC-RFD)

Primary Gatekeeper Configuration

The following configuration is for the primary gatekeeper, SJC-RFD-GK-1, in a pair of gatekeepers that form a gatekeeper cluster.

version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname SJC-RFD-GK-1
!
boot-start-marker
boot system flash flash:c3745-ipvoice_ivs-mz.124-15.T2.fc5
boot-end-marker
!
logging buffered 4096
no logging console
enable password 7 011F0706
!
no aaa new-model
clock timezone PST -8
clock summer-time PDST recurring
no network-clock-participate slot 1 
ip cef
!
multilink bundle-name authenticated
!
voice call carrier capacity active
!
archive
 log config
  hidekeys
!
ip rcmd rcp-enable
ip rcmd remote-host cwuser 10.9.22.34 cwuser enable
!
interface FastEthernet0/0
 ip address 10.9.12.99 255.255.254.0
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 10.3.2.27 255.255.254.0
 speed 100
 full-duplex
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.9.12.1
ip route 10.21.0.0 255.255.0.0 10.3.2.1
ip route 10.25.0.0 255.255.0.0 10.3.2.1
ip route 10.32.0.0 255.255.0.0 10.3.2.1
ip route 10.77.0.0 255.255.0.0 10.3.2.1
ip route 10.82.0.0 255.255.0.0 10.3.2.1
ip route 10.89.0.0 255.255.0.0 10.3.2.1
ip route 10.94.0.0 255.255.0.0 10.3.2.1
ip route 64.0.0.0 255.0.0.0 10.3.2.1
ip route 128.107.0.0 255.255.0.0 10.3.2.1
ip route 161.44.0.0 255.255.0.0 10.3.2.1
ip route 171.0.0.0 255.0.0.0 10.3.2.1
ip route 172.0.0.0 255.0.0.0 10.3.2.1
ip route 192.0.0.0 255.0.0.0 10.3.2.1
ip route 198.0.0.0 255.0.0.0 10.3.2.1
!
no ip http server
!
logging trap debugging
logging source-interface FastEthernet0/1
logging 10.3.2.129
snmp-server community public RO
snmp-server community private RW
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
control-plane
!
dial-peer cor custom
!
gatekeeper
 zone local SJC-GK-1 cisco.com 10.9.12.99
 zone local RFD-GK-1 cisco.com
 zone local SFO-GK-1 cisco.com
 zone local ORD-GK-1 cisco.com
 zone remote NYC-GK cisco.com 10.3.62.99 1719
 zone remote YYZ-GK cisco.com 10.3.70.99 1719
 zone remote RDU cisco.com 10.3.62.99 1719
 zone remote DFW-GK cisco.com 10.3.62.99 1719
 zone remote rxb cisco.com 10.3.98.4 1719
 zone remote SITE2-GK1 vtg2.com 10.4.24.2 1719
 zone cluster local SJC-GK-Cluster SJC-GK-1
  element SJC-GK-2 10.9.22.99 1719
 !
 zone cluster local RFD-GK-Cluster RFD-GK-1
  element RFD-GK-2 10.9.22.99 1719
 !
 zone cluster local SFO-GK-Cluster SFO-GK-1
  element SFO-GK-2 10.9.22.99 1719
 !
 zone cluster local ORD-GK-Cluster ORD-GK-1
  element ORD-GK-2 10.9.22.99 1719
 !
 no zone subnet SJC-GK-1 default enable
 no zone subnet SJC-GK-1 10.9.14.14/32 enable
 no zone subnet SJC-GK-1 10.9.12.12/32 enable
 zone subnet SJC-GK-1 10.9.10.0/23 enable
 zone subnet SJC-GK-1 10.9.14.0/23 enable
 zone subnet SJC-GK-1 10.9.20.0/23 enable
 zone subnet SJC-GK-1 10.9.12.0/23 enable
 zone subnet SJC-GK-1 10.9.16.0/23 enable
 no zone subnet RFD-GK-1 default enable
 no zone subnet RFD-GK-1 10.9.14.14/32 enable
 zone subnet RFD-GK-1 10.9.10.0/23 enable
 zone subnet RFD-GK-1 10.9.14.0/23 enable
 zone subnet RFD-GK-1 10.9.20.0/23 enable
 no zone subnet SFO-GK-1 default enable
 no zone subnet SFO-GK-1 10.9.40.11/32 enable
 zone subnet SFO-GK-1 10.9.30.0/23 enable
 zone subnet SFO-GK-1 10.9.40.0/23 enable
 no zone subnet ORD-GK-1 default enable
 no zone subnet ORD-GK-1 10.9.40.11/32 enable
 zone subnet ORD-GK-1 10.9.30.0/23 enable
 zone subnet ORD-GK-1 10.9.40.0/23 enable
 zone prefix SJC-GK-1 20335* gw-priority 10 SJC_SUB7_Trunk_9 SJC_SUB5_Trunk_7 SJC_SUB3_Trunk_5 
SJC_SUB1_Trunk_3
 zone prefix SJC-GK-1 20335* gw-priority 9 SJC_SUB8_Trunk_10 SJC_SUB6_Trunk_8 SJC_SUB4_Trunk_6 
SJC_SUB2_Trunk_4
 zone prefix RFD-GK-1 21052* gw-priority 10 SJC_SUB8_Trunk_10 SJC_SUB6_Trunk_8 SJC_SUB4_Trunk_6 
SJC_SUB2_Trunk_4
 zone prefix RFD-GK-1 21052* gw-priority 9 SJC_SUB7_Trunk_9 SJC_SUB5_Trunk_7 SJC_SUB3_Trunk_5 
SJC_SUB1_Trunk_3
 zone prefix NYC-GK 21283*
 zone prefix SITE2-GK1 325*
 zone prefix rxb 336*
 zone prefix YYZ-GK 404*
 zone prefix SJC-GK-1 40846* gw-priority 10 SJC_SUB1_Trunk_3 SJC_SUB7_Trunk_9 SJC_SUB5_Trunk_7 
SJC_SUB3_Trunk_5
 zone prefix SJC-GK-1 40846* gw-priority 9 SJC_SUB8_Trunk_10 SJC_SUB6_Trunk_8 SJC_SUB4_Trunk_6 
SJC_SUB2_Trunk_4
 zone prefix SJC-GK-1 40847* gw-priority 9 SJC_CTFTP_Trunk_1
 zone prefix SJC-GK-1 4085559991* gw-priority 10 SJC_SUB3_Trunk_5 SJC_SUB5_Trunk_7 SJC_SUB7_Trunk_9 
SJC_SUB1_Trunk_3
 zone prefix SJC-GK-1 4085559991* gw-priority 9 SJC_SUB2_Trunk_4 SJC_SUB4_Trunk_6 SJC_SUB6_Trunk_8 
SJC_SUB8_Trunk_10
 zone prefix YYZ-GK 647*
 zone prefix SJC-GK-1 808443* gw-priority 10 SJC_SUB1_Trunk_3 SJC_SUB3_Trunk_5 SJC_SUB5_Trunk_7 
SJC_SUB7_Trunk_9
 zone prefix SJC-GK-1 808443* gw-priority 9 SJC_SUB2_Trunk_4 SJC_SUB4_Trunk_6 SJC_SUB6_Trunk_8 
SJC_SUB8_Trunk_10
 zone prefix SFO-GK-1 8101* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8101* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8102* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8102* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8103* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8103* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8104* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8104* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8105* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8105* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8106* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8106* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8107* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8107* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8108* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8108* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8109* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8109* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8110* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8110* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8111* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8111* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8112* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8112* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8113* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8113* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8114* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8114* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8115* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8115* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8116* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8116* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8117* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8117* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8118* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8118* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8119* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8119* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8120* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8120* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8121* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8121* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8122* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8122* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8123* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8123* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8124* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8124* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8125* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8125* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8126* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8126* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8127* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8127* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8128* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8128* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8129* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8129* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8130* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8130* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8131* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8131* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8132* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8132* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8133* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8133* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8134* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8134* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8135* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8135* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8136* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8136* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8137* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8137* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8138* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8138* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8139* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8139* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8140* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8140* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8141* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8141* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8142* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8142* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8143* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8143* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8144* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8144* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8145* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8145* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8146* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8146* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8147* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8147* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8148* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8148* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8149* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8149* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix SFO-GK-1 8150* gw-priority 10 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8150* gw-priority 9 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8151* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8151* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8152* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8152* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8153* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8153* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8154* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8154* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8155* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8155* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8156* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8156* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8157* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8157* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8158* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8158* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8159* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8159* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8160* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8160* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8161* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8161* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8162* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8162* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8163* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8163* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8164* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8164* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8165* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8165* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8166* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8166* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8167* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8167* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8168* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8168* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8169* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8169* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8170* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8170* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8171* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8171* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8172* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8172* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8173* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8173* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8174* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8174* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8175* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8175* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8176* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8176* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8177* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8177* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8178* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8178* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8179* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8179* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8180* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8180* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8181* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8181* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8182* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8182* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8183* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8183* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8184* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8184* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8185* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8185* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8186* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8186* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8187* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8187* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8188* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8188* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8189* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8189* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8190* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8190* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8191* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8191* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8192* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8192* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8193* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8193* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8194* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8194* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8195* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8195* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8196* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8196* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8197* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8197* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8198* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8198* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8199* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8199* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix ORD-GK-1 8200* gw-priority 10 SFO_trunk7_7 SFO_trunk5_5 SFO_trunk3_3 SFO_trunk1_1
 zone prefix ORD-GK-1 8200* gw-priority 9 SFO_trunk2_2 SFO_trunk4_4 SFO_trunk6_6 SFO_trunk8_8
 zone prefix SFO-GK-1 8378* gw-priority 10 SFO_trunk8_8 SFO_trunk6_6 SFO_trunk4_4 SFO_trunk2_2
 zone prefix SFO-GK-1 8378* gw-priority 9 SFO_trunk1_1 SFO_trunk3_3 SFO_trunk5_5 SFO_trunk7_7
 zone prefix ORD-GK-1 8822* gw-priority 10 SFO_trunk1_1 SFO_trunk3_3 SFO_trunk5_5 SFO_trunk7_7
 zone prefix ORD-GK-1 8822* gw-priority 9 SFO_trunk8_8 SFO_trunk6_6 SFO_trunk4_4 SFO_trunk2_2
 zone prefix RDU 91055*
 zone prefix SJC-GK-1 93* gw-priority 10 SJC_SUB7_Trunk_9 SJC_SUB5_Trunk_7 SJC_SUB3_Trunk_5 SJC_SUB1_Trunk_3
 zone prefix SJC-GK-1 93* gw-priority 9 SJC_SUB8_Trunk_10 SJC_SUB6_Trunk_8 SJC_SUB4_Trunk_6 SJC_SUB2_Trunk_4
 zone prefix DFW-GK 97678*
 gw-type-prefix 1#* default-technology
 arq reject-unknown-prefix
 lrq reject-unknown-prefix
 lrq forward-queries add-hop-count
 no use-proxy SJC-GK-1 default inbound-to terminal
 no use-proxy SJC-GK-1 default outbound-from terminal
 no use-proxy RFD-GK-1 default inbound-to terminal
 no use-proxy RFD-GK-1 default outbound-from terminal
 no use-proxy SFO-GK-1 default inbound-to terminal
 no use-proxy SFO-GK-1 default outbound-from terminal
 no use-proxy ORD-GK-1 default inbound-to terminal
 no use-proxy ORD-GK-1 default outbound-from terminal
 bandwidth total zone SJC-GK-1 10000000
 bandwidth total zone RFD-GK-1 10000000
 bandwidth total zone SFO-GK-1 10000000
 bandwidth total zone ORD-GK-1 10000000
 no shutdown
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 60 0
 password 7 141B1309
 login
!
ntp clock-period 17179448
ntp server 10.9.12.1
!
end

Alternate Gatekeeper Configuration

The following configuration is for the alternate gatekeeper, SJC-RFD-GK-2, in a pair of gatekeepers that form a gatekeeper cluster.

gatekeeper
zone local SJC-GK-2 cisco.com 10.9.22.99
zone local RFD-GK-2 cisco.com
zone local ORD-GK-2 cisco.com
zone local SFO-GK-2 cisco.com
zone remote NYC-GK cisco.com 10.3.62.99 1719
zone remote YYZ-GK cisco.com 10.3.70.99 1719 cost 2
zone remote RDU cisco.com 10.3.62.99 1719
zone remote DFW-GK cisco.com 10.3.62.99 1719
zone remote ipip-gk cisco.com 10.3.70.99 1719 cost 1
zone remote rxb cisco.com 10.3.98.4 1719
zone cluster local SJC-GK-Cluster SJC-GK-2
element SJC-GK-1 10.9.12.99 1719
!
zone cluster local RFD-GK-Cluster RFD-GK-2
element RFD-GK-1 10.9.12.99 1719
!
zone cluster local SFO-GK-Cluster SFO-GK-2
element SFO-GK-1 10.9.12.99 1719
!
zone cluster local ORD-GK-Cluster ORD-GK-2
element ORD-GK-1 10.9.12.99 1719
!
no zone subnet SJC-GK-2 default enable
no zone subnet SJC-GK-2 10.9.12.12/32 enable
no zone subnet SJC-GK-2 10.9.14.14/32 enable
zone subnet SJC-GK-2 10.9.16.0/23 enable
zone subnet SJC-GK-2 10.9.12.0/23 enable
zone subnet SJC-GK-2 10.9.10.0/23 enable
zone subnet SJC-GK-2 10.9.14.0/23 enable
zone subnet SJC-GK-2 10.9.20.0/23 enable
no zone subnet RFD-GK-2 default enable
no zone subnet RFD-GK-2 10.9.14.14/32 enable
zone subnet RFD-GK-2 10.9.10.0/23 enable
zone subnet RFD-GK-2 10.9.14.0/23 enable
zone subnet RFD-GK-2 10.9.20.0/23 enable
no zone subnet ORD-GK-2 default enable
no zone subnet ORD-GK-2 10.9.40.11/32 enable
zone subnet ORD-GK-2 10.9.30.0/23 enable
zone subnet ORD-GK-2 10.9.40.0/23 enable
no zone subnet SFO-GK-2 default enable
no zone subnet SFO-GK-2 10.9.40.11/32 enable
zone subnet SFO-GK-2 10.9.30.0/23 enable
zone subnet SFO-GK-2 10.9.40.0/23 enable
zone prefix RFD-GK-2 21052* gw-priority 10 SJC_SUB8_Trunk_10 SJC_SUB6_Trunk_8 SJC_SUB4_Trunk_6
SJC_SUB2_Trunk_4
zone prefix RFD-GK-2 21052* gw-priority 9 SJC_SUB7_Trunk_9 SJC_SUB5_Trunk_7 SJC_SUB3_Trunk_5
SJC_SUB1_Trunk_3
zone prefix NYC-GK 21283*
zone prefix rxb 336*
zone prefix YYZ-GK 404*
zone prefix SJC-GK-2 40846* gw-priority 10 SJC_SUB1_Trunk_3 SJC_SUB3_Trunk_5 SJC_SUB5_Trunk_7
SJC_SUB7_Trunk_9
zone prefix SJC-GK-2 40846* gw-priority 9 SJC_SUB2_Trunk_4 SJC_SUB4_Trunk_6 SJC_SUB6_Trunk_8
SJC_SUB8_Trunk_10
zone prefix SJC-GK-2 40847* gw-priority 9 SJC_CTFTP_Trunk_1
zone prefix SJC-GK-2 4085559991* gw-priority 10 SJC_SUB3_Trunk_5 SJC_SUB5_Trunk_7 SJC_SUB7_Trunk_9
SJC_SUB1_Trunk_3
SJC_SUB8_Trunk_10
zone prefix YYZ-GK 647*
zone prefix SJC-GK-2 808443* gw-priority 10 SJC_SUB1_Trunk_3 SJC_SUB3_Trunk_5 SJC_SUB5_Trunk_7
SJC_SUB7_Trunk_9
zone prefix SJC-GK-2 808443* gw-priority 9 SJC_SUB2_Trunk_4 SJC_SUB4_Trunk_6 SJC_SUB6_Trunk_8
SJC_SUB8_Trunk_10
zone prefix SFO-GK-2 8101* gw-priority 10 SFO_trunk8_8 SFO_trunk6_6 SFO_trunk4_4 SFO_trunk2_2
zone prefix SFO-GK-2 8101* gw-priority 9 SFO_trunk1_1 SFO_trunk3_3 SFO_trunk5_5 SFO_trunk7_7
zone prefix SFO-GK-2 8102* gw-priority 10 SFO_trunk8_8 SFO_trunk6_6 SFO_trunk4_4 SFO_trunk2_2
zone prefix SFO-GK-2 8102* gw-priority 9 SFO_trunk1_1 SFO_trunk3_3 SFO_trunk5_5
...
zone prefix RDU 91055*
zone prefix SJC-GK-2 93* gw-priority 10 SJC_SUB7_Trunk_9 SJC_SUB5_Trunk_7 SJC_SUB3_Trunk_5 SJC_SUB1_Trunk_3
zone prefix SJC-GK-2 93* gw-priority 9 SJC_SUB8_Trunk_10 SJC_SUB6_Trunk_8 SJC_SUB4_Trunk_6 SJC_SUB2_Trunk_4
zone prefix DFW-GK 97678*
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix
lrq reject-unknown-prefix
lrq forward-queries add-hop-count
no use-proxy SJC-GK-2 default inbound-to terminal
no use-proxy SJC-GK-2 default outbound-from terminal
no use-proxy RFD-GK-2 default inbound-to terminal
no use-proxy RFD-GK-2 default outbound-from terminal
no use-proxy ORD-GK-2 default inbound-to terminal
no use-proxy ORD-GK-2 default outbound-from terminal
no use-proxy SFO-GK-2 default inbound-to terminal
no use-proxy SFO-GK-2 default outbound-from terminal
bandwidth total zone SJC-GK-2 10000000
bandwidth total zone RFD-GK-2 10000000
bandwidth total zone ORD-GK-2 10000000
bandwidth total zone SFO-GK-2 10000000
no shutdown
endpoint ttl 60
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 120 0
password 7 0703204E
login

!
ntp clock-period 17178741
ntp server 10.9.22.1
!
end

Cisco Intracluster Gatekeeper Cluster Configuration

The following sections show sample configurations for gatekeepers that handle video, Cisco Unified MeetingPlace, and Cisco Unified MeetingPlace Express in the Very Large Campus with Clustering over the WAN site model.

The first configuration is for the primary gatekeeper, SJC-RFD-VID-GK-1, from a pair of gatekeepers that form a gatekeeper cluster. A gatekeeper cluster provides alternate gatekeeper functionality if one of the gatekeepers fails. The second configuration is for the alternate gatekeeper, SJC-RFD-VID-GK-2, and has a configuration that references the primary gatekeeper.

Configuration for the First Gatekeeper in a Cluster

Configuration for the Second Gatekeeper in a Cluster

Configuration for the First Gatekeeper in a Cluster

This section shows a portion of the gatekeeper configuration for the first gatekeeper in a cluster.

version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname SJC-RFD-VID-GK-1
!
boot-start-marker
boot system flash flash:c2800nm-ipvoice_ivs-mz.124-15.T2.fc5
boot-end-marker
!
logging buffered 4096
no logging console
enable secret 5 $1$8ML0$LRsuRajXeL7c/7wwq5uBh1
!
no aaa new-model
clock timezone PST -8
clock summer-time PDST recurring
!
ip cef
!
multilink bundle-name authenticated
!
voice-card 0
 no dspfarm
!
voice call carrier capacity active
!
archive
 log config
  hidekeys
!
ip rcmd rcp-enable
ip rcmd remote-host cwuser 10.9.22.34 cwuser enable
!
interface GigabitEthernet0/0
 description To SJC-RFD-3750-1 0/37
 ip address 10.9.12.100 255.255.254.0
 duplex full
 speed 100
!
interface GigabitEthernet0/1
 description To ADMIN-4506 0/42
 ip address 10.3.2.223 255.255.254.0
 duplex full
 speed 100
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.9.12.1
ip route 10.21.0.0 255.255.0.0 10.3.2.1
ip route 10.25.0.0 255.255.0.0 10.3.2.1
ip route 10.32.0.0 255.255.0.0 10.3.2.1
ip route 10.77.0.0 255.255.0.0 10.3.2.1
ip route 10.82.0.0 255.255.0.0 10.3.2.1
ip route 10.89.0.0 255.255.0.0 10.3.2.1
ip route 10.94.0.0 255.255.0.0 10.3.2.1
ip route 64.0.0.0 255.0.0.0 10.3.2.1
ip route 128.107.0.0 255.255.0.0 10.3.2.1
ip route 161.44.0.0 255.255.0.0 10.3.2.1
ip route 171.0.0.0 255.0.0.0 10.3.2.1
ip route 172.0.0.0 255.0.0.0 10.3.2.1
ip route 192.0.0.0 255.0.0.0 10.3.2.1
ip route 198.0.0.0 255.0.0.0 10.3.2.1
!
no ip http server
!
logging trap debugging
logging facility local0
logging source-interface GigabitEthernet0/0
logging 10.3.2.129
snmp-server community public RO
snmp-server community private RW
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
control-plane
!
gatekeeper
 zone local SJC-VIDEO-GK-1 cisco.com 10.9.12.100 invia SJC-VIDEO-GK-1 outvia SJC-VIDEO-GK-1 enable-intrazone
 zone local RFD-VIDEO-GK-1 cisco.com invia RFD-VIDEO-GK-1 outvia RFD-VIDEO-GK-1 enable-intrazone
 zone local SJC-VIDEO3-GK-1 cisco.com invia SJC-VIDEO3-GK-1 outvia SJC-VIDEO3-GK-1 enable-intrazone
 zone local SJC-LMPVA-GK-1 cisco.com
 zone local SJC-MP-GK-1 cisco.com invia SJC-MP-GK-1 outvia SJC-MP-GK-1 enable-intrazone
 zone local SFO-MPX-GK-1 hq.com invia SFO-MPX-GK-1 outvia SFO-MPX-GK-1 enable-intrazone
 zone local SJC-MPE-GK-1 cisco.com invia SJC-MPE-GK-1 outvia SJC-MPE-GK-1 enable-intrazone
 zone remote SJC-RMPVA-GK-1 cisco.com 10.9.12.16 1719
 zone cluster local SJC-Video-Cluster SJC-VIDEO-GK-1
  element SJC-VIDEO-GK-2 10.9.22.100 1719
 !
 zone cluster local RFD-Video-Cluster RFD-VIDEO-GK-1
  element RFD-VIDEO-GK-2 10.9.22.100 1719
 !
 zone cluster local SJC-Video3-Cluster SJC-VIDEO3-GK-1
  element SJC-VIDEO3-GK-2 10.9.22.100 1719
 !
 zone cluster local SJC-MPVA-Cluster SJC-LMPVA-GK-1
  element SJC-LMPVA-GK-2 10.9.22.100 1719
 !
 zone cluster local SJC-MP-Cluster SJC-MP-GK-1
  element SJC-MP-GK-2 10.9.22.100 1719
 !
 zone cluster local SFO-MPX-Cluster SFO-MPX-GK-1
  element SFO-MPX-GK-2 10.9.22.100 1719
 !
 zone cluster local SJC-MPE-Cluster SJC-MPE-GK-1
  element SJC-MPE-GK-2 10.9.22.100 1719
 !
 no zone subnet SJC-VIDEO-GK-1 default enable
 zone subnet SJC-VIDEO-GK-1 10.9.80.0/23 enable
 zone subnet SJC-VIDEO-GK-1 10.9.20.0/23 enable
 zone subnet SJC-VIDEO-GK-1 10.9.14.0/23 enable
 zone subnet SJC-VIDEO-GK-1 10.9.10.0/23 enable
 no zone subnet RFD-VIDEO-GK-1 default enable
 zone subnet RFD-VIDEO-GK-1 10.9.209.240/28 enable
 zone subnet RFD-VIDEO-GK-1 10.9.10.0/23 enable
 zone subnet RFD-VIDEO-GK-1 10.9.14.0/23 enable
 zone subnet RFD-VIDEO-GK-1 10.9.20.0/23 enable
 no zone subnet SJC-VIDEO3-GK-1 default enable
 zone subnet SJC-VIDEO3-GK-1 10.9.10.0/23 enable
 zone subnet SJC-VIDEO3-GK-1 10.9.14.0/23 enable
 zone subnet SJC-VIDEO3-GK-1 10.9.20.0/23 enable
 zone subnet SJC-VIDEO3-GK-1 10.9.78.0/23 enable
 no zone subnet SJC-LMPVA-GK-1 default enable
 zone subnet SJC-LMPVA-GK-1 10.9.20.0/23 enable
 zone subnet SJC-LMPVA-GK-1 10.9.14.0/23 enable
 zone subnet SJC-LMPVA-GK-1 10.9.10.0/23 enable
 no zone subnet SJC-MP-GK-1 default enable
 zone subnet SJC-MP-GK-1 10.9.12.12/32 enable
 no zone subnet SJC-MP-GK-1 10.9.12.13/32 enable
 zone subnet SJC-MP-GK-1 10.9.10.0/23 enable
 zone subnet SJC-MP-GK-1 10.9.20.0/23 enable
 zone subnet SJC-MP-GK-1 10.9.14.0/23 enable
 zone subnet SJC-MP-GK-1 10.9.12.0/23 enable
 no zone subnet SFO-MPX-GK-1 default enable
 zone subnet SFO-MPX-GK-1 10.9.40.11/32 enable
 zone subnet SFO-MPX-GK-1 10.9.40.0/23 enable
 zone subnet SFO-MPX-GK-1 10.9.30.0/23 enable
 no zone subnet SJC-MPE-GK-1 default enable
 zone subnet SJC-MPE-GK-1 10.9.12.13/32 enable
 zone subnet SJC-MPE-GK-1 10.9.12.12/32 enable
 zone subnet SJC-MPE-GK-1 10.9.10.0/23 enable
 zone subnet SJC-MPE-GK-1 10.9.14.0/23 enable
 zone subnet SJC-MPE-GK-1 10.9.20.0/23 enable
 zone prefix SJC-LMPVA-GK-1 21052* gw-priority 10 SJC-LMPVA-Trunk_3
 zone prefix SJC-LMPVA-GK-1 21052* gw-priority 9 SJC-LMPVA-Trunk_4
 zone prefix SJC-RMPVA-GK-1 4084621*
 zone prefix SJC-LMPVA-GK-1 40846* gw-priority 10 SJC-LMPVA-Trunk_3
 zone prefix SJC-LMPVA-GK-1 40846* gw-priority 9 SJC-LMPVA-Trunk_4
 zone prefix SFO-MPX-GK-1 82222222*
 zone prefix SJC-LMPVA-GK-1 8* gw-priority 10 SJC-LMPVA-Trunk_3
 zone prefix SJC-LMPVA-GK-1 8* gw-priority 9 SJC-LMPVA-Trunk_4
 zone prefix SJC-LMPVA-GK-1 9* gw-priority 10 SJC-LMPVA-Trunk_3
 zone prefix SJC-LMPVA-GK-1 9* gw-priority 9 SJC-LMPVA-Trunk_4
 gw-type-prefix 1#* default-technology
 lrq reject-unknown-prefix
 lrq forward-queries add-hop-count
 no use-proxy SJC-VIDEO-GK-1 default inbound-to terminal
 no use-proxy SJC-VIDEO-GK-1 default outbound-from terminal
 no use-proxy RFD-VIDEO-GK-1 default inbound-to terminal
 no use-proxy RFD-VIDEO-GK-1 default outbound-from terminal
 no use-proxy SJC-VIDEO3-GK-1 default inbound-to terminal
 no use-proxy SJC-VIDEO3-GK-1 default outbound-from terminal
 no use-proxy SJC-LMPVA-GK-1 default inbound-to terminal
 no use-proxy SJC-LMPVA-GK-1 default outbound-from terminal
 no use-proxy SJC-MP-GK-1 default inbound-to terminal
 no use-proxy SJC-MP-GK-1 default outbound-from terminal
 no use-proxy SFO-MPX-GK-1 default inbound-to terminal
 no use-proxy SFO-MPX-GK-1 default outbound-from terminal
 no use-proxy SJC-MPE-GK-1 default inbound-to terminal
 no use-proxy SJC-MPE-GK-1 default outbound-from terminal
 no shutdown
!
line con 0
 exec-timeout 0 0
 password 7 09404F0B
 login
line aux 0
line vty 0 4
 exec-timeout 60 0
 privilege level 15
 password 7 060A0E23
 login
line vty 5 15
 exec-timeout 60 0
 login
!
scheduler allocate 20000 1000
ntp clock-period 17180043
ntp server 10.9.12.1
!
end

Configuration for the Second Gatekeeper in a Cluster

The following configuration is for the second gatekeeper, SJC-RFD-VID-GK-2, in a pair of gatekeepers that form a gatekeeper cluster.

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SJC-RFD-VID-GK-2
!
boot-start-marker
boot system flash flash:c2800nm-ipvoice_ivs-mz.124-15.T2.fc5
boot-end-marker
!
no logging buffered
no logging console
enable secret 5 $1$.9nz$Al5e8SgK2zNft3tZFNG9f0
!
no aaa new-model
clock timezone CST -6
clock summer-time CDST recurring
!
ip cef
!
multilink bundle-name authenticated
!
voice-card 0
 no dspfarm
!
username cisco privilege 15 secret 5 $1$mZll$BTA9ZTHGL2/sySB5jtQsG0
archive
 log config
  hidekeys
!
ip rcmd rcp-enable
ip rcmd remote-host cwuser 10.9.22.34 cwuser enable
!
interface FastEthernet0/0
 description To SJC-RFD-3750-2 0/27
 ip address 10.9.22.100 255.255.254.0
 duplex full
 speed 100
!
interface FastEthernet0/1
 ip address 10.3.2.224 255.255.254.0
 duplex full
 speed 100
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.9.22.1
ip route 10.21.0.0 255.255.0.0 10.3.2.1
ip route 10.25.0.0 255.255.0.0 10.3.2.1
ip route 10.32.0.0 255.255.0.0 10.3.2.1
ip route 10.77.0.0 255.255.0.0 10.3.2.1
ip route 10.82.0.0 255.255.0.0 10.3.2.1
ip route 10.89.0.0 255.255.0.0 10.3.2.1
ip route 10.94.0.0 255.255.0.0 10.3.2.1
ip route 64.0.0.0 255.0.0.0 10.3.2.1
ip route 128.107.0.0 255.255.0.0 10.3.2.1
ip route 161.44.0.0 255.255.0.0 10.3.2.1
ip route 171.0.0.0 255.0.0.0 10.3.2.1
ip route 172.0.0.0 255.0.0.0 10.3.2.1
ip route 192.0.0.0 255.0.0.0 10.3.2.1
ip route 198.0.0.0 255.0.0.0 10.3.2.1
!
no ip http server
!
logging trap debugging
logging facility local0
logging source-interface FastEthernet0/0
logging 10.3.2.129
access-list 23 permit 10.10.10.0 0.0.0.7
snmp-server community public RO
snmp-server community private RW
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
control-plane
!
gatekeeper
 zone local SJC-VIDEO-GK-2 cisco.com 10.9.22.100 invia SJC-VIDEO-GK-2 outvia SJC-VIDEO-GK-2 enable-intrazone
 zone local RFD-VIDEO-GK-2 cisco.com invia RFD-VIDEO-GK-2 outvia RFD-VIDEO-GK-2 enable-intrazone
 zone local SJC-VIDEO3-GK-2 cisco.com invia SJC-VIDEO3-GK-2 outvia SJC-VIDEO3-GK-2 enable-intrazone
 zone local SJC-LMPVA-GK-2 cisco.com
 zone local SJC-MP-GK-2 cisco.com invia SJC-MP-GK-2 outvia SJC-MP-GK-2 enable-intrazone
 zone local SFO-MPX-GK-2 hq.com invia SFO-MPX-GK-2 outvia SFO-MPX-GK-2 enable-intrazone
 zone local SJC-MPE-GK-2 cisco.com invia SJC-MPE-GK-2 outvia SJC-MPE-GK-2 enable-intrazone
 zone remote SJC-RMPVA-GK-1 cisco.com 10.9.12.16 1719
 zone cluster local SJC-Video-Cluster SJC-VIDEO-GK-2
  element SJC-VIDEO-GK-1 10.9.12.100 1719
 !
 zone cluster local RFD-Video-Cluster RFD-VIDEO-GK-2
  element RFD-VIDEO-GK-1 10.9.12.100 1719
 !
 zone cluster local SJC-Video3-Cluster SJC-VIDEO3-GK-2
  element SJC-VIDEO3-GK-1 10.9.12.100 1719
 !
 zone cluster local SJC-MPVA-Cluster SJC-LMPVA-GK-2
  element SJC-LMPVA-GK-1 10.9.12.100 1719
 !
 zone cluster local SJC-MP-Cluster SJC-MP-GK-2
  element SJC-MP-GK-1 10.9.12.100 1719
 !
 zone cluster local SFO-MPX-Cluster SFO-MPX-GK-2
  element SFO-MPX-GK-1 10.9.12.100 1719
 !
 zone cluster local SJC-MPE-Cluster SJC-MPE-GK-2
  element SJC-MPE-GK-1 10.9.12.100 1719
 !
 no zone subnet SJC-VIDEO-GK-2 default enable
 zone subnet SJC-VIDEO-GK-2 10.9.20.0/23 enable
 zone subnet SJC-VIDEO-GK-2 10.9.14.0/23 enable
 zone subnet SJC-VIDEO-GK-2 10.9.10.0/23 enable
 zone subnet SJC-VIDEO-GK-2 10.9.80.0/23 enable
 no zone subnet RFD-VIDEO-GK-2 default enable
 zone subnet RFD-VIDEO-GK-2 10.9.209.240/28 enable
 zone subnet RFD-VIDEO-GK-2 10.9.10.0/23 enable
 zone subnet RFD-VIDEO-GK-2 10.9.14.0/23 enable
 zone subnet RFD-VIDEO-GK-2 10.9.20.0/23 enable
 no zone subnet SJC-VIDEO3-GK-2 default enable
 zone subnet SJC-VIDEO3-GK-2 10.9.78.0/23 enable
 zone subnet SJC-VIDEO3-GK-2 10.9.20.0/23 enable
 zone subnet SJC-VIDEO3-GK-2 10.9.14.0/23 enable
 zone subnet SJC-VIDEO3-GK-2 10.9.10.0/23 enable
 no zone subnet SJC-LMPVA-GK-2 default enable
 zone subnet SJC-LMPVA-GK-2 10.9.10.0/23 enable
 zone subnet SJC-LMPVA-GK-2 10.9.14.0/23 enable
 zone subnet SJC-LMPVA-GK-2 10.9.20.0/23 enable
 no zone subnet SJC-MP-GK-2 default enable
 no zone subnet SJC-MP-GK-2 10.9.12.13/32 enable
 zone subnet SJC-MP-GK-2 10.9.12.12/32 enable
 zone subnet SJC-MP-GK-2 10.9.12.0/23 enable
 zone subnet SJC-MP-GK-2 10.9.14.0/23 enable
 zone subnet SJC-MP-GK-2 10.9.20.0/23 enable
 zone subnet SJC-MP-GK-2 10.9.10.0/23 enable
 no zone subnet SFO-MPX-GK-2 default enable
 zone subnet SFO-MPX-GK-2 10.9.40.11/32 enable
 zone subnet SFO-MPX-GK-2 10.9.30.0/23 enable
 zone subnet SFO-MPX-GK-2 10.9.40.0/23 enable
 no zone subnet SJC-MPE-GK-2 default enable
 zone subnet SJC-MPE-GK-2 10.9.12.12/32 enable
 zone subnet SJC-MPE-GK-2 10.9.12.13/32 enable
 zone subnet SJC-MPE-GK-2 10.9.20.0/23 enable
 zone subnet SJC-MPE-GK-2 10.9.14.0/23 enable
 zone subnet SJC-MPE-GK-2 10.9.10.0/23 enable
 zone prefix SJC-LMPVA-GK-2 21052* gw-priority 10 SJC-LMPVA-Trunk_3
 zone prefix SJC-LMPVA-GK-2 21052* gw-priority 9 SJC-LMPVA-Trunk_4
 zone prefix SJC-RMPVA-GK-1 4084621*
 zone prefix SJC-LMPVA-GK-2 40846* gw-priority 10 SJC-LMPVA-Trunk_3
 zone prefix SJC-LMPVA-GK-2 40846* gw-priority 9 SJC-LMPVA-Trunk_4
 zone prefix SFO-MPX-GK-2 82222222*
 zone prefix SJC-LMPVA-GK-2 8* gw-priority 10 SJC-LMPVA-Trunk_3
 zone prefix SJC-LMPVA-GK-2 8* gw-priority 9 SJC-LMPVA-Trunk_4
 zone prefix SJC-LMPVA-GK-2 9* gw-priority 10 SJC-LMPVA-Trunk_3
 zone prefix SJC-LMPVA-GK-2 9* gw-priority 9 SJC-LMPVA-Trunk_4
 gw-type-prefix 1#* default-technology
 lrq reject-unknown-prefix
 lrq forward-queries add-hop-count
 no use-proxy SJC-VIDEO-GK-2 default inbound-to terminal
 no use-proxy SJC-VIDEO-GK-2 default outbound-from terminal
 no use-proxy RFD-VIDEO-GK-2 default inbound-to terminal
 no use-proxy RFD-VIDEO-GK-2 default outbound-from terminal
 no use-proxy SJC-VIDEO3-GK-2 default inbound-to terminal
 no use-proxy SJC-VIDEO3-GK-2 default outbound-from terminal
 no use-proxy SJC-LMPVA-GK-2 default inbound-to terminal
 no use-proxy SJC-LMPVA-GK-2 default outbound-from terminal
 no use-proxy SJC-MP-GK-2 default inbound-to terminal
 no use-proxy SJC-MP-GK-2 default outbound-from terminal
 no use-proxy SFO-MPX-GK-2 default inbound-to terminal
 no use-proxy SFO-MPX-GK-2 default outbound-from terminal
 no use-proxy SJC-MPE-GK-2 default inbound-to terminal
 no use-proxy SJC-MPE-GK-2 default outbound-from terminal
 no shutdown
!
line con 0
 exec-timeout 0 0
 password 7 141B1309
 login
line aux 0
line vty 0 4
 exec-timeout 60 0
 password 7 03085A09
 login
line vty 5 15
 exec-timeout 60 0
 password 7 00081204
 login
!
scheduler allocate 20000 1000
ntp clock-period 17180092
ntp server 10.9.22.1
!
end

Standard H.323 Gateway Configuration File

This section shows the primary H.323 gateway configuration for a Cisco 3845 gateway used in the Very Large Campus with Clustering over the WAN site model during Cisco Unified Communications Release 7.0(1) testing. This gateway was also configured as a source of DSP transcoders and conferencing resources for other Cisco devices, as shown by the dspfarm profile commands.

version 12.4
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
service compress-config
!
hostname SJC-RFD-3845GW
!
boot-start-marker
boot system flash flash:c3845-ipvoicek9-mz.124-15.T2.fc5
boot-end-marker
!
card type t1 1 1
card type t1 2 1
no logging buffered
no logging console
!
no aaa new-model
clock timezone EST -5
clock summer-time EDST recurring
no network-clock-participate slot 1 
no network-clock-participate slot 2 
ip cef
!
ip domain name cisco.com
ip name-server 10.9.12.4
ip name-server 10.9.20.11
multilink bundle-name authenticated
!
isdn switch-type primary-5ess
voice-card 0
 no dspfarm
!
voice-card 1
 no dspfarm
 dsp services dspfarm
!
voice-card 2
 no dspfarm
 dsp services dspfarm
!
voice service voip 
 fax protocol pass-through g711ulaw
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
 codec preference 3 g729br8
!
voice class h323 1
 h225 timeout tcp establish 3
  call preserve limit-media-detection
!
crypto pki trustpoint TP-self-signed-1764307031
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1764307031
 revocation-check none
 rsakeypair TP-self-signed-1764307031
!
crypto pki certificate chain TP-self-signed-1764307031
 certificate self-signed 01
  30820250 308201B9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 31373634 33303730 3331301E 170D3036 30323133 30303037 
  30345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 37363433 
  30373033 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  8100CA45 72D034C6 C716C2DA 0A3E8D9F 681AD2A2 46D97097 037A45E0 71A01E3B 
  B21EA478 B80DE4A9 12F14F58 A8DDB3A3 EF2FE991 DE7EF940 A0FD0CE0 13ADE55A 
  C97C036A 1BB58C51 D6C2F72C 3EEC57BE A3FE66AE 57DBF9F9 5EEF92D5 39DBC4C4 
  DBDEF4E9 DB333AC0 96552F9D 688B0804 6ED556A6 9FEBFCB6 89A0E2C9 E0F924F7 
  EE5D0203 010001A3 78307630 0F060355 1D130101 FF040530 030101FF 30230603 
  551D1104 1C301A82 18534A43 2D524644 2D333834 3547572E 63697363 6F2E636F 
  6D301F06 03551D23 04183016 80145F6B 1707A486 7F7845EA FC701D5D 3A128D8A 
  CB92301D 0603551D 0E041604 145F6B17 07A4867F 7845EAFC 701D5D3A 128D8ACB 
  92300D06 092A8648 86F70D01 01040500 03818100 998470F7 39183A51 4D45E36B 
  BF9F0881 EC747C98 D591DE26 CEFEB800 A53E69C3 8FB36A50 3911BD7C B521A919 
  A69F9725 007D37B5 C44E14C7 79A5229E B54F013C 92D8D38A F66D7A79 DC001C84 
  543A6DB1 5F73B6FD 4B60EA03 703837D1 D589FA29 FA67B411 F47415CC 95FA889D 
  9794FB6E 51858303 A63C56FD 517A251B B2560F2A
        quit
!
archive
 log config
  hidekeys
!
controller T1 1/0
 framing esf
 linecode b8zs
!
controller T1 1/1
 framing esf
 linecode b8zs
!
controller T1 2/0
 framing esf
 linecode b8zs
 cablelength short 399
 pri-group timeslots 1-24
 description T1 going to DEFINITY PBX, 62Blue, DSX3-19-42 going to rear side of DSX3
!
controller T1 2/1
 framing esf
 linecode b8zs
!
ip rcmd rcp-enable
ip rcmd remote-host cwuser 10.9.22.34 cwuser enable
!
translation-rule 1
 Rule 1 ^450850 2
 Rule 2 ^29 29
 Rule 3 ^59 59
!
translation-rule 2
 Rule 1 ^2 4508502
!
translation-rule 3
 Rule 1 ^229 29
!
interface GigabitEthernet0/0
 description SJC-RFD-3845-GW
 ip address 10.9.128.139 255.255.255.240
 duplex full
 speed 100
 media-type rj45
 no keepalive
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.9.128.139
 ip rsvp bandwidth 2000
 ip rsvp resource-provider none
!
interface GigabitEthernet0/1
 description SJC-RFD-3845-GW-ADMIN
 ip address 10.3.2.22 255.255.254.0
 duplex full
 speed 100
 media-type rj45
 no keepalive
!
interface Serial2/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn incoming-voice voice
 isdn bchan-number-order ascending 
 isdn outgoing display-ie
 no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.9.128.129
!
no ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
ip access-list standard R0
ip access-list standard any
!
logging trap debugging
logging facility local0
logging source-interface GigabitEthernet0/0
logging 10.3.2.129
snmp-server community private RW
snmp-server community public RO
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
tftp-server usbflash1:c3500xl-c3h2s-mz.120-5.WC17.bin
!
control-plane
!
voice-port 0/1/0
 caller-id enable
!
voice-port 0/1/1
!
voice-port 2/0:23
 bearer-cap Speech
!
sccp local GigabitEthernet0/0
sccp ccm 10.9.10.5 identifier 1 version 5.0.1 
sccp ccm 10.9.20.3 identifier 2 version 5.0.1 
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 1 register CFB0013808b2fd0
 associate profile 2 register MTP0013808b2fd0
 associate profile 3 register MTP-SOFT-SJC
!
dspfarm profile 2 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729br8
 codec g729r8
 codec pass-through
 rsvp
 maximum sessions 100
 associate application SCCP
!
dspfarm profile 1 conference
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 20
 associate application SCCP
!
dspfarm profile 3 mtp
 codec g711ulaw
 codec pass-through
 rsvp
 maximum sessions software 10
 associate application SCCP
 shutdown
!
dial-peer voice 201 pots
 destination-pattern 20..
 no digit-strip
 direct-inward-dial
 port 2/0:23
!
dial-peer voice 1 voip
 preference 1
 destination-pattern .T
 voice-class codec 1
 voice-class h323 1
 session target ipv4:10.9.10.5
 incoming called-number .T
 fax protocol pass-through g711ulaw
!
dial-peer voice 2 voip
 preference 2
 destination-pattern .T
 voice-class codec 1
 voice-class h323 1
 session target ipv4:10.9.20.3
 incoming called-number .T
 fax protocol pass-through g711ulaw
!
dial-peer voice 999 voip
 description CFS
 destination-pattern 9999999
 session protocol sipv2
 session target ipv4:10.9.14.7
 session transport udp
 codec g711ulaw
 fax protocol pass-through g711ulaw
!
dial-peer voice 202 voip
 description Call from Definity(Lucent) PBX to SJC
 destination-pattern 2.....
 translate-outgoing called 3
 session target ipv4:10.9.10.5
!
dial-peer voice 100 pots
 destination-pattern 24097
 port 0/1/0
!
dial-peer voice 105 voip
 destination-pattern 8599....
 session target ipv4:10.9.10.5
!
line con 0
 exec-timeout 0 0
 password 7 151E0A0E
 login
line aux 0
line vty 0 4
 exec-timeout 60 0
 password 7 0507070D
 login
 transport input telnet ssh
line vty 5 15
 exec-timeout 60 0
 password 7 0507070D
 login
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp clock-period 17179582
ntp server 10.9.128.129
!
end

H323 SRST Gateway Configuration File

This section shows the configuration of a Cisco 2851 SRST gateway used in large financial (SFO-ORD) model during Cisco Unified Communication Release 6.1(1) testing.

version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service compress-config
!
hostname SFO-ORD-188-2851
!
boot-start-marker
boot system flash flash:c2800nm-ipvoicek9-mz.124-15.T2.fc5
boot-end-marker
!
card type t1 1 0
card type t1 1 1
logging buffered 512000000
no logging console
enable secret 5 $1$hNXb$/oQ1PBGlqbyfRk7uGogLc.
enable password 7 020A0559
!
no aaa new-model
clock timezone CST -6
clock summer-time CDT recurring
no network-clock-participate slot 1 
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.3.195.185 10.3.195.186
!
ip dhcp pool ITS
   network 10.3.195.184 255.255.255.248
   option 150 ip 10.9.40.4 10.9.30.4 
   default-router 10.3.195.186 
   dns-server 10.9.40.12 10.9.30.10 
   domain-name hq.com
!
ip domain name hq.com
ip name-server 10.9.40.12
ip name-server 10.9.30.10
ip multicast-routing 
multilink bundle-name authenticated
!
isdn switch-type primary-ni
!
voice-card 0
 dspfarm
!
voice-card 1
 no dspfarm
!
no voice hunt unassigned-number
no voice hunt invalid-number
voice rtp send-recv
!
voice service voip 
 h323
  call preserve limit-media-detection
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
voice class h323 1
 h225 timeout tcp establish 3
!
archive
 log config
  hidekeys
!
controller T1 1/0
 framing esf
 linecode b8zs
 channel-group 1 timeslots 1-24
 description Physical DSX Connection DSX5-15B-12
!
controller T1 1/1
 shutdown
 framing esf
 linecode b8zs
!
controller T1 1/0/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
 description PSTN connection 1/0 to SFO-ORD-187-2851
!
controller T1 1/0/1
 framing esf
 clock source internal
 linecode b8zs
 pri-group timeslots 1-24
 description PSTN connection 1/1 to SFO-ORD-VGW Card 5 1/1
!
ip rcmd rcp-enable
ip rcmd remote-host cwuser 10.9.22.34 cwuser enable
!
translation-rule 999
 Rule 1 ^287 287287
!
interface GigabitEthernet0/0
 description Connected to SFO-ORD-4506-3/40 VLAN 988
 ip address 10.3.195.186 255.255.255.248
 load-interval 30
 duplex full
 speed 100
 h323-gateway voip bind srcaddr 10.3.195.186
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0:1
 description WAN connection to SFO-ORD-WAN-2 port 2/1/4
 no ip address
 encapsulation frame-relay
 no keepalive
!
interface Serial1/0:1.1 point-to-point
 ip address 10.3.181.93 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 188   
!
interface Serial1/0/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
interface Serial1/0/1:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn protocol-emulate network
 isdn incoming-voice voice
 no cdp enable
!
router ospf 8
 log-adjacency-changes
 network 10.3.181.93 0.0.0.0 area 0
 network 10.3.195.184 0.0.0.7 area 188
 distribute-list 1 in
!
ip forward-protocol nd
ip route 10.3.2.0 255.255.255.0 10.3.195.185
ip route 10.3.159.192 255.255.255.192 10.3.195.185
ip route 10.3.172.184 255.255.255.248 10.3.195.185
ip route 10.21.0.0 255.255.0.0 10.3.195.185
ip route 10.25.0.0 255.255.0.0 10.3.195.185
ip route 10.32.0.0 255.255.0.0 10.3.195.185
ip route 10.76.0.0 255.255.0.0 10.3.195.185
ip route 10.77.0.0 255.255.0.0 10.3.195.185
ip route 10.82.0.0 255.255.0.0 10.3.195.185
ip route 10.83.0.0 255.255.0.0 10.3.195.185
ip route 10.89.0.0 255.255.0.0 10.3.195.185
ip route 10.94.0.0 255.255.0.0 10.3.195.185
ip route 64.0.0.0 255.0.0.0 10.3.195.185
ip route 128.107.0.0 255.255.0.0 10.3.195.185
ip route 161.44.0.0 255.255.0.0 10.3.195.185
ip route 171.0.0.0 255.0.0.0 10.3.195.185
ip route 172.0.0.0 255.0.0.0 10.3.195.185
ip route 192.0.0.0 255.0.0.0 10.3.195.185
ip route 198.0.0.0 255.0.0.0 10.3.195.185
!
no ip http server
no ip http secure-server
ip rtcp report interval 60 
!
logging facility local1
logging source-interface GigabitEthernet0/0
logging 10.3.2.129
access-list 1 deny   10.3.159.192 0.0.0.63
access-list 1 deny   10.3.172.184 0.0.0.7
access-list 1 permit any
snmp-server community public RO
snmp-server community private RW
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps frame-relay subif
snmp-server host 10.3.2.129 version2 
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
control-plane
!
voice-port 1/0/0:23
 bearer-cap Speech
!
voice-port 1/0/1:23
 bearer-cap Speech
!
dial-peer voice 100 voip
 description Outgoing VOIP Dial Peers
 preference 1
 destination-pattern 288288....
 voice-class codec 1
 voice-class h323 1
 session target ipv4:10.9.40.6
 dtmf-relay h245-signal h245-alphanumeric
 no vad
!
dial-peer voice 101 voip
 description Outgoing VOIP Dial Peers
 preference 2
 destination-pattern 288288....
 voice-class codec 1
 voice-class h323 1
 session target ipv4:10.9.30.6
 dtmf-relay h245-signal h245-alphanumeric
 no vad
!
dial-peer voice 201 pots
 description 7-digit local dialing
 destination-pattern 287....
 translate-outgoing called 999
 no digit-strip
 direct-inward-dial
 port 1/0/0:23
 forward-digits all
!
dial-peer voice 202 pots
 description 10-digit local dialing
 destination-pattern 287287....
 no digit-strip
 direct-inward-dial
 port 1/0/0:23
 forward-digits all
!
dial-peer voice 203 pots
 description 11 digit LD dialing
 destination-pattern 94T
 no digit-strip
 direct-inward-dial
 port 1/0/1:23
 forward-digits all
!
gateway 
 media-inactivity-criteria all
 timer media-inactive 5
 timer receive-rtp 1200
!
call-manager-fallback
 max-conferences 8 gain -6
 transfer-system full-consult
 ip source-address 10.3.195.186 port 2000
 max-ephones 96
 max-dn 288
 dialplan-pattern 1 288288.... extension-length 4
 voicemail 9418223500
 call-forward noan 9418223500 timeout 60
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 60 0
 password 7 03085A09
 login
!
scheduler allocate 20000 1000
ntp clock-period 17180327
ntp server 10.3.100.6
ntp server 10.3.181.250 prefer
!
end

Voice Gateway (CMM) Configuration File

This section shows the configuration of a Cisco Communications Media Module used in large financial (SFO-ORD) model during Cisco Unified Communication Release 6.1(1) testing. The site has Centralized Cisco CMM modules to aggregate PRI trunks from each remote SRST site. CMMs and 6608s are used for media services as well for centralized conferencing resources.

version 12.4
no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname SFO-ORD-VGW-1-CMM-3
!
boot-start-marker
boot system flash bootflash:wscmm-i6k9s-mz.124-15.T2.fc5
boot-end-marker
!
logging buffered 1024000
logging rate-limit 10000
no logging console
enable password 7 151E0A0E
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
ip domain name hq.com
ip name-server 10.9.30.10
!
isdn switch-type primary-ni
!
archive
 log config
  hidekeys
!
controller T1 1/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 1/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 1/2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 1/3
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 1/4
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 1/5
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 2/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 2/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 2/2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 2/3
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 2/4
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 2/5
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 3/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 3/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 3/2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 3/3
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 3/4
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 3/5
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
ip rcmd rcp-enable
ip rcmd remote-host cwuser 10.9.22.34 cwuser enable
ip tcp synwait-time 13
!
interface GigabitEthernet1/0
 ip address 10.9.34.3 255.255.254.0
 no ip proxy-arp
 no negotiation auto
 no keepalive
!
interface Serial1/0:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial1/1:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial1/2:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial1/3:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial1/4:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial1/5:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial2/0:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial2/1:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial2/2:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial2/3:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial2/4:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial2/5:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface FastEthernet3/0
 ip address 10.9.34.6 255.255.255.255
 no ip proxy-arp
 full-duplex
!
interface Serial3/0:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial3/1:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial3/2:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial3/3:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial3/4:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial3/5:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
ip default-gateway 10.9.34.1
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.9.34.1
!
no ip http server
!
logging trap debugging
logging facility local0
logging source-interface GigabitEthernet1/0
logging 10.3.2.129
snmp-server community public RO
snmp-server community private RW
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
voice-port 1/0:23
!
voice-port 1/1:23
!
voice-port 1/2:23
!
voice-port 1/3:23
!
voice-port 1/4:23
!
voice-port 1/5:23
!
voice-port 2/0:23
!
voice-port 2/1:23
!
voice-port 2/2:23
!
voice-port 2/3:23
!
voice-port 2/4:23
!
voice-port 2/5:23
!
voice-port 3/0:23
!
voice-port 3/1:23
!
voice-port 3/2:23
!
voice-port 3/3:23
!
voice-port 3/4:23
!
voice-port 3/5:23
!
ccm-manager redundant-host 10.9.30.8
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server SFO-ORD-TFTP-1  
ccm-manager config
!
mgcp
mgcp call-agent 10.9.40.8 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
mediacard 4
 resource-pool cfb dsps 2
 resource-pool mtp dsps 2
!
sccp local GigabitEthernet1/0
sccp ccm 10.9.30.8 identifier 1 version 5.0.1 
sccp ccm 10.9.40.8 identifier 2 version 5.0.1 
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 1 register C100003FEAB773E
 associate profile 2 register M120003FEAB773E
!
dspfarm
!
dspfarm profile 1 conference adhoc
 description Conference resources for MediCard 4
 rtp timeout 7200
 codec g711ulaw packetization-period 30
 codec g711alaw packetization-period 30
 codec g729r8 packetization-period 30
 codec g729ar8 packetization-period 30
 codec g723r63 packetization-period 30
 codec g723r53 packetization-period 30
 associate resource-pool cfb
!
dspfarm profile 2 transcode
 description MTP resources for MediaCard 4
 rtp timeout 7200
 codec g711ulaw packetization-period 30
 codec g711alaw packetization-period 30
 codec g729r8 packetization-period 30
 codec g729ar8 packetization-period 30
 codec g723r63 packetization-period 30
 codec g723r53 packetization-period 30
 no codec pass-thru 
 associate resource-pool mtp
!
line con 0
 exec-timeout 0 0
 password 7 03085A09
 login
line vty 0 4
 exec-timeout 0 0
 password 7 03085A09
 login
!
exception crashinfo buffersize 256
ntp clock-period 17179972
ntp server 10.3.100.6 prefer
ntp server 10.3.181.250
!
end

Standard MGCP Gateway Configuration File

This section shows a standard MGCP gateway configuration file for a Cisco 3725 gateway. This configuration does not include as many dial peers on the gateway as the H.323 gateway configuration. Dial peers are not required in most cases because all signaling on the D-channels of the Primary Rate Interface (PRI) trunks and subsequent routing decisions are backhauled to the Cisco Unified CallManager.

version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname SJC-RFD-3725-GW2
!
boot-start-marker
boot system flash flash:c3725-ipvoicek9-mz.124-15.T2.fc5
boot-end-marker
!
no logging console
enable password lab
!
no aaa new-model
memory-size iomem 30
clock timezone EDT -4
no network-clock-participate slot 2 
voice-card 2
 no dspfarm
 dsp services dspfarm
!
ip cef
!
ip domain name cisco.com
ip name-server 10.9.12.4
multilink bundle-name authenticated
isdn switch-type primary-ni
!
voice call carrier capacity active
!
voice service voip 
 fax protocol pass-through g711ulaw
 modem passthrough nse codec g711ulaw maximum-sessions 2
!
fax interface-type fax-mail
!
archive
 log config
  hidekeys
!
controller T1 2/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
 description connection to dms_trunk_59 DTCI 1x2
!
controller T1 2/1
 framing esf
 linecode b8zs
 description Trunk for Fax Testing
!
ip rcmd rcp-enable
ip rcmd remote-host cwuser 10.9.22.34 cwuser enable
!
interface FastEthernet0/0
 ip address 10.9.128.141 255.255.255.240
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 10.3.2.24 255.255.254.0
 duplex auto
 speed auto
!
interface Serial2/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.9.128.129
ip route 10.3.2.0 255.255.255.0 FastEthernet0/1
!
ip http server
no ip http secure-server
!
ip access-list standard R0
ip access-list standard any
!
logging trap debugging
logging 172.18.137.110
snmp-server community private RW
snmp-server community public RO
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
tftp-server flash:c3725-is-mz.122-13.T1
!
control-plane
!
voice-port 1/1/0
!
voice-port 1/1/1
!
voice-port 2/0:23
!
ccm-manager redundant-host sjc-rfd-sub-2
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 10.9.14.4  
ccm-manager config
!
mgcp
mgcp call-agent sjc-rfd-sub-1 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
sccp local FastEthernet0/0
sccp
sccp ccm 10.3.41.11 priority 1
sccp ccm 10.3.41.10 priority 2
!
dspfarm transcoder maximum sessions 1
dspfarm confbridge maximum sessions 4
dspfarm
!
dial-peer cor custom
!
dial-peer voice 999110 pots
 service mgcpapp
 port 1/1/0
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password lab
 login
!
ntp clock-period 17180756
ntp server 172.18.137.110
!
end

SIP Gateway Configuration

This section shows the configuration of a Cisco 3745 SIP gateway used in the Large SIP Site model during Cisco Unified Communications Release 7.0(1) testing. This gateway was also configured as a source of DSP transcoders and conferencing resources for other Cisco devices, as shown by the dspfarm profile commands.

version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service internal
!
hostname DFW-3745GW
!
boot-start-marker
boot system flash flash:c3745-ipvoicek9-mz.124-15.T2.fc5
boot-end-marker
!
card type t1 1 1
card type t1 2 1
card type t1 3 1
card type t1 4 1
logging buffered 20000000
no logging console
enable secret 5 $1$5816$IqMz0Adt90ZNSJR5VxP6Y1
!
no aaa new-model
clock timezone EDT -4
clock summer-time CDST recurring
network-clock-participate slot 1 
network-clock-participate slot 2 
network-clock-participate slot 3 
no network-clock-participate slot 4 
network-clock-select 1 T1 1/0
network-clock-select 2 T1 2/0
network-clock-select 3 T1 2/1
network-clock-select 4 T1 3/2
network-clock-select 5 T1 3/3
network-clock-select 6 T1 1/2
network-clock-select 7 T1 1/3
ip cef
!
ip domain name dfw.com
ip name-server 10.3.24.22
ip name-server 10.3.2.121
ip multicast-routing 
multilink bundle-name authenticated
isdn switch-type primary-ni
voice-card 1
 no dspfarm
!
voice-card 2
 no dspfarm
!
voice-card 3
 no dspfarm
!
voice-card 4
 dspfarm
 dsp services dspfarm
!
voice service voip 
 sip
  bind control source-interface FastEthernet0/1
  bind media source-interface FastEthernet0/1
  min-se  90 
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729br8
!
archive
 log config
  hidekeys
!
controller T1 1/0
 framing esf
 linecode b8zs
 cablelength short 133
 pri-group timeslots 1-24
 description DFW-2851GW port 0/1/0
!
controller T1 1/1
 shutdown
 framing sf
 linecode ami
!
controller T1 1/2
 framing esf
 clock source line primary
 linecode b8zs
 cablelength short 133
 pri-group timeslots 1-24
 description DFW-2801GW port 0/2/0
!
controller T1 1/3
 framing esf
 linecode b8zs
 cablelength short 133
 pri-group timeslots 1-24
 description DFW-2801GW port 0/2/1
!
controller T1 2/0
 framing esf
 linecode b8zs
 cablelength short 133
 pri-group timeslots 1-24
 description DFW-2851GW port 1/0/0
!
controller T1 2/1
 framing esf
 linecode b8zs
 cablelength short 133
 pri-group timeslots 1-24
 description DFW-2851GW port 1/0/1
!
controller T1 3/0
 shutdown
 framing sf
 linecode ami
!
controller T1 3/1
 shutdown
 framing sf
 linecode ami
!
controller T1 3/2
 framing esf
 linecode b8zs
 cablelength short 133
 pri-group timeslots 1-24
 description DFW-2851GW port 0/0/0
!
controller T1 3/3
 framing esf
 linecode b8zs
 cablelength short 133
 pri-group timeslots 1-24
 description DFW-2851GW port 0/0/1
!
controller T1 4/0
 shutdown
 framing sf
 clock source internal
 linecode ami
!
controller T1 4/1
 shutdown
 framing sf
 linecode ami
!
controller T1 4/2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
 description DMS DTCI 3 4 DSX 2-9-5
!
controller T1 4/3
 shutdown
 framing sf
 linecode ami
!
ip rcmd rcp-enable
ip rcmd remote-host cwuser 10.9.22.34 cwuser enable
!
translation-rule 1
 Rule 1 ^29 9767829
!
interface FastEthernet0/0
 description To DFW-4503 3/26
 ip address 10.3.2.19 255.255.254.0
 ip pim dense-mode
 speed 100
 full-duplex
!
interface FastEthernet0/1
 description To cat4k admin switch
 ip address 10.3.26.102 255.255.254.0
 speed 100
 full-duplex
!
interface Serial1/0:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn bchan-number-order descending 
 no cdp enable
!
interface Serial1/2:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
interface Serial1/3:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
interface Serial2/0:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn bchan-number-order descending 
 no cdp enable
!
interface Serial2/1:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn bchan-number-order descending 
 no cdp enable
!
interface Serial3/2:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn bchan-number-order descending 
 no cdp enable
!
interface Serial3/3:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn bchan-number-order descending 
 no cdp enable
!
interface Serial4/2:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-dms100
 isdn incoming-voice voice
 no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.3.26.1
!
ip http server
no ip http secure-server
ip pim ssm default
!
ip access-list standard any
!
no logging trap
snmp-server community public RO
snmp-server community private RW
snmp-server contact mahesh
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
control-plane
!
voice-port 1/0:23
!
voice-port 1/2:23
!
voice-port 1/3:23
!
voice-port 2/0:23
!
voice-port 2/1:23
!
voice-port 3/2:23
!
voice-port 3/3:23
!
voice-port 4/2:23
!
sccp local FastEthernet0/1
sccp ccm 10.3.24.3 identifier 1 version 5.0.1 
sccp ccm 10.3.24.4 identifier 2 version 5.0.1 
sccp
!
sccp ccm group 3
 description DFW MTP
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 10 register Hardware-MTP
!
sccp ccm group 2
 description DFW Conference
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 2 register CFB001360A1F2A0
!
sccp ccm group 1
 description DFW Transcoder
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 1 register MTP001360A1F2A1
!
dspfarm profile 1 transcode
 description Transcoder
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729br8
 codec g729r8
 codec pass-through
 rsvp
 maximum sessions 30
 associate application SCCP
!
dspfarm profile 2 conference
 description Conference Bridge
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 18
 associate application SCCP
!
dspfarm profile 10 mtp
 codec g711ulaw
 codec pass-through
 maximum sessions hardware 4
 associate application SCCP
!
dial-peer voice 1 pots
 description DFW to DMS PSTN
 destination-pattern 93..........
 translate-outgoing calling 1
 incoming called-number .T
 direct-inward-dial
 port 4/2:23
!
dial-peer voice 101 voip
 description To DFW-SUB-2
 preference 2
 destination-pattern .T
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.3.24.4
 session transport tcp
 incoming called-number .T
 dtmf-relay sip-kpml rtp-nte
 no vad
!
dial-peer voice 4 pots
 description DFW to 2801GW 0/2/0
 destination-pattern 197612.....
 incoming called-number 197678.....
 no digit-strip
 direct-inward-dial
 port 1/2:23
!
dial-peer voice 44 pots
 description DFW to 2801GW 0/2/1
 destination-pattern 197679.....
 incoming called-number 197621.....
 no digit-strip
 direct-inward-dial
 port 1/3:23
!
dial-peer voice 611 pots
 description DFW to 2851GW 0/1/0
 destination-pattern 197611.....
 incoming called-number 197635.....
 no digit-strip
 direct-inward-dial
 port 1/0:23
!
dial-peer voice 613 pots
 description DFW to 2851GW 1/0/0
 destination-pattern 197613.....
 incoming called-number 197637.....
 no digit-strip
 direct-inward-dial
 port 2/0:23
!
dial-peer voice 614 pots
 description DFW to 2851GW 1/0/1
 destination-pattern 197614.....
 incoming called-number 197638.....
 no digit-strip
 direct-inward-dial
 port 2/1:23
!
dial-peer voice 615 pots
 description DFW to 2851GW 0/0/0
 destination-pattern 197615.....
 incoming called-number 197633.....
 no digit-strip
 direct-inward-dial
 port 3/2:23
!
dial-peer voice 616 pots
 description DFW to 2851GW 0/0/1
 destination-pattern 197616.....
 incoming called-number 197634.....
 no digit-strip
 direct-inward-dial
 port 3/3:23
!
dial-peer voice 102 voip
 description To DFW-SUB-1
 preference 1
 destination-pattern .T
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.3.24.3
 session transport tcp
 incoming called-number .T
 dtmf-relay sip-kpml rtp-nte
 no vad
!
num-exp 9767823100 2105253100
num-exp 9767821000 2105259007
gateway 
 timer receive-rtp 1200
!
sip-ua 
 retry invite 2
 retry bye 6
!
line con 0
 exec-timeout 0 0
 password 7 03085A09
 login
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 password 7 00081204
 login
line vty 5 15
 exec-timeout 60 0
 password 7 00081204
 login
!
ntp clock-period 17180518
ntp server 10.3.24.1
!
end