Guest

Support

Cisco Unified Communications Manager Express Configuration

  • Viewing Options

  • PDF (591.3 KB)
  • Feedback
Cisco Unified Communications Manager Express Configuration

Table Of Contents

Cisco Unified Communications Manager Express Configuration

Related Documentation

Reference Configuration

Network Topologies

Focus of System Testing

Configuration Details

Basic SIP ICT Calls

Conference Calls Across an ICT

Site with SIP Phones

Site with SCCP Phones

Site with SIP and SCCP Phones


Cisco Unified Communications Manager Express Configuration


This topic provides sample configuration files for Cisco Unified CallManager Express . The information is based primarily on testing performed during Cisco Unified Communications Release 6.0(1) system testing. This topic does not contain detailed step-by-step procedures; instead, for or detailed information about installing, configuring, and administering Unified Communications Manager Express, refer to the Cisco Communications Manager Express documentation listed in Table 1.

Related Documentation

For related information about Cisco Unified Communications Manager Express, see the documents listed in Table 1.

Table 1 Cisco Unified Communications Manager Express, Cisco Unity Express and IP-to-IP Gateway Documentation 

Document
URL

General Unified Oommunications Manager Express documentation

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/tsd_products_support_series_home.html

Cisco Unified CallManager Express Command Reference

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_command_reference_book09186a00805b6c70.html

Cisco Unified CallManager Express System Administrator Guide

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_guide_book09186a00805f262e.html

Cisco Unified IP Phone User Guide for Cisco CallManager Express 3.2 and Later

http://www.cisco.com/en/US/products/hw/phones/ps379/products_user_guide09186a00802d40e3.html

Cisco CME 3.4 Configuration Guide for SIP IP Phones

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_guide_book09186a008052da6b.html


Reference Configuration

The system-wide testing of IP telephony functionality for Cisco Unified Communications Release 6.0(1) included Cisco Emergency Responder. For general information about the tested functionality in Cisco Unified Communications Release 6.0(1), see the System Release Notes.

Network Topologies

During Cisco Unified Communications Release 6.0(1) testing, this component was installed and tested in the following site models:

ATL and YYZ

For more information on these site models, see Tested Deployments and Site Models.

Focus of System Testing

The system-wide testing of IP telephony for Cisco Unified Communications Release 6.0(1) focused on the following Cisco Unified Communications Manager Express features:

Cisco Unified Communications Manager Express hardware conference resourse testing Cisco Unified Communications Manager Express to Cisco Unified Communications Manager sites.

Cisco Unified Communications Manager Express support for out of Dialog Refer

Cisco Unified Communications Manager Express hunt group funcationality

SIP and h.323 call functionality.

Configuration Details

This topic includes the following sections:

Basic SIP ICT Calls

Conference Calls Across an ICT

Site with SIP Phones

Site with SCCP Phones

Site with SIP and SCCP Phones

Basic SIP ICT Calls

This conifiguration shows how the Cisco Unified Communications Manager Express was configured for basic SIP calls through an inter-cluster trunk (ICT).

ALT-CME-3845-3#sh run 
version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname ALT-CME-3845-3
!
boot-start-marker
boot system flash flash:c3845-adventerprisek9-mz.124-15.T.fc2
boot-end-marker
!
card type t1 2 1
logging buffered 40960
no logging console
enable secret 5 $1$yrUw$xkrYh9BH36cXznAEN/sTb1
!
no aaa new-model
clock timezone EST -5
clock summer-time EDST recurring
no network-clock-participate slot 2 
no network-clock-participate slot 3 
no network-clock-participate wic 0 
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.3.82.1 10.3.82.10
!
ip dhcp pool ITS
   network 10.3.82.0 255.255.255.0
   option 150 ip 10.3.82.2 
   default-router 10.3.82.2 
!
no ip domain lookup
!
multilink bundle-name authenticated
!
stcapp ccm-group 1
stcapp
!
stcapp feature access-code
!         
stcapp call-control mode feature
!
isdn switch-type primary-ni
voice-card 0
 dspfarm
 dsp services dspfarm
!
voice-card 2
 dspfarm
 dsp services dspfarm
!
voice-card 3
 no dspfarm
!
no voice hunt unassigned-number
no voice hunt dest-incompatible
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12 advertise-only
 sip
  bind media source-interface GigabitEthernet0/0
  registrar server expires max 600 min 120
!
voice class codec 2
 codec preference 1 g711ulaw
!
voice class codec 3
 codec preference 1 g711ulaw
!
voice class codec 1
 codec preference 1 g711ulaw
!
voice class codec 5
 codec preference 1 g729r8
 codec preference 2 g711ulaw
!
voice register global
 mode cme
 source-address 10.3.82.2 port 5060
 max-dn 720
 max-pool 240
 load 7960-7940 P0S3-08-4-00
 timezone 12
 dialplan-pattern 1 404329.... extension-length 4
 voicemail 8888
 create profile sync 0000809310603243
!
voice register pool  1
 id mac 0009.7CAC.56BF
 type 7960
 number 1 5001
 dtmf-relay rtp-nte
 voice-class codec 2
!
voice register pool  2
 id mac 0009.7CEC.8E4C
 type 7960
 number 1 5002
 dtmf-relay rtp-nte
 voice-class codec 1
!
voice register pool  3
 id mac 000B.46CA.BA83
 type 7960
 number 1 5003
 dtmf-relay rtp-nte
 voice-class codec 1
!
voice register pool  209
 id mac CA71.CC71.5209
 type 7960
 number 1 5209
 voice-class codec 1
 username 5209 password lab
!
voice register pool  210
 id mac CA71.CC71.5210
 type 7960
 number 1 5210
 voice-class codec 1
 username 5210 password lab
!
voice translation-rule 1
 rule 1 /404\(...\)/ //
!
voice translation-profile cme1
 translate called 1
!!
username 5058 password 7 1042081B
username 5081 password 7 0507070D
username 5082 password 7 011F0706
username 5083 password 7 13091610
username 5084 password 7 141B1309
username 5104 password 7 020A0559
username 5217 password 7 12150415
username 5218 password 7 060A0E23
username 5219 password 7 141B1309
username 5220 password 7 12150415
username 5221 password 7 03085A09
username 5229 password 7 12150415
username 5230 password 7 09404F0B
username 5231 password 7 11051807
username 5232 password 7 00081204
username 5233 password 7 11051807
username 5234 password 7 09404F0B
username 5235 password 7 0703204E
username 5236 password 7 020A0559
username 5237 password 7 011F0706
username 5238 password 7 13091610
username 5239 password 7 020A0559
username 5240 password 7 1042081B
username cisco privilege 15 secret 5 $1$/82.$kKvNPtj.Kr7Y6tEY87lo5.
username lab password 7 011F0706
username 508087
username dave password 7 050F071924
archive
 log config
  hidekeys
!
controller T1 0/0/0
 framing esf
 linecode b8zs
 cablelength short 133
 channel-group 0 timeslots 1-24
 description MFR-link1 to 7200 t1 3/0
!
controller T1 0/0/1
 framing esf
 linecode b8zs
 cablelength short 133
 channel-group 0 timeslots 1-24
 description MFR-link2 to 7200 t1 3/1
!
controller T1 2/0
 framing esf
 linecode b8zs
!
controller T1 2/1
 framing esf
 linecode b8zs
!
controller T1 2/0/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
 description To AS5400-PSTN T1 6/4
!
controller T1 2/0/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
 description To CCME 2691
!
ip rcmd rcp-enable
ip rcmd remote-host cwuser 10.9.22.34 cwuser enable
!
translation-rule 1
 Rule 1 ^4043292001 2001
!
translation-rule 20
 Rule 1 8161 261261
 Rule 2 ^878 97678
 Rule 3 ^8599 336599
 Rule 4 ^88599 336599
 Rule 7 ^801191484484846 40846
 Rule 9 ^846 40846
 Rule 10 ^852 21052
!         
translation-rule 21
 Rule 1 ^. 404329
!
interface MFR100
 no ip address
 frame-relay multilink bid mfr-3845-7200
!
interface MFR100.1 point-to-point
 ip address 10.3.181.190 255.255.255.252
 frame-relay interface-dlci 1000   
!
interface GigabitEthernet0/0
 description ALT-3550  0/3
 ip address 10.3.82.2 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
 no keepalive
 h323-gateway voip interface
 h323-gateway voip id YYZ-GK ipaddr 10.3.70.99 1719
 h323-gateway voip h323-id alt-cme-3845
 h323-gateway voip tech-prefix 1#
 h323-gateway voip bind srcaddr 10.3.82.2
!
interface GigabitEthernet0/1
 description admin port 6 alt-3550
 ip address 10.3.2.131 255.255.254.0
 duplex auto
 speed auto
 media-type rj45
 no keepalive
!
interface Serial0/0/0:0
 no ip address
 encapsulation frame-relay MFR100
 no arp frame-relay
 frame-relay multilink lid link-1
!
interface Serial0/0/1:0
 no ip address
 encapsulation frame-relay MFR100
 no arp frame-relay
 frame-relay multilink lid link-2
!
interface Serial2/0/0:23
 description To AS5400-PSTN T1 6/4
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface Serial2/0/1:23
 description To CCME 2691
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn protocol-emulate network
 isdn incoming-voice voice
 no cdp enable
!
interface Service-Engine4/0
 ip unnumbered GigabitEthernet0/0
 shutdown
 service-module ip address 10.3.82.4 255.255.255.0
 service-module ip default-gateway 10.3.82.2
!
router ospf 1
 log-adjacency-changes
 network 10.3.82.0 0.0.0.255 area 80
 network 10.3.181.0 0.0.0.255 area 80
!
ip route 10.3.82.4 255.255.255.255 Service-Engine4/0
!
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
logging trap debugging
logging facility local0
logging source-interface GigabitEthernet0/0
logging 10.3.2.129
access-list 101 permit udp host 10.3.82.2 host 10.3.147.114
access-list 101 permit udp host 10.3.147.114 host 10.3.82.2
access-list 101 permit udp host 10.3.82.6 host 10.3.82.2 range 16000 33000
access-list 101 permit udp host 10.3.82.2 host 10.3.82.6 range 16000 33000
access-list 101 permit udp host 10.3.82.2 range 16000 33000 host 10.3.86.2
access-list 101 permit udp host 10.3.82.2 range 16000 33000 host 10.3.82.6
access-list 103 permit ip host 10.9.20.7 host 10.3.82.2
snmp-server community public RO
snmp-server community private RW
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps flash insertion removal
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server enable traps hsrp
snmp-server enable traps ipsla
snmp-server enable traps syslog
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
tftp-server flash:P00303020214.bin
tftp-server flash:P003-08-2-00.bin
tftp-server flash:P003-08-2-00.sbn
ttftp-server flash:QOVDefault.cnf
!
control-plane
!
voice-port 2/0/0:23
!
voice-port 2/0/1:23
!
voice-port 3/1/0
 mwi
 timeouts ringing infinity
 caller-id enable
!
voice-port 3/1/1
 timeouts ringing infinity
!
voice-port 3/1/2
 timeouts ringing infinity
!
voice-port 3/1/3
 mwi
 timeouts ringing infinity
 caller-id enable
!
sccp local GigabitEthernet0/0
sccp ccm 10.3.82.2 identifier 1 
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 registration retries 1
 registration timeout 1
 keepalive retries 1
 connect retries 1
 switchback method graceful
!
dspfarm profile 1 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 maximum sessions 4
 associate application SCCP
!
dial-peer voice 1234 voip
 destination-pattern 8888
 session protocol sipv2
 session target ipv4:10.3.82.4
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 1 voip
 translation-profile incoming cme1
 voice-class codec 1
 session protocol sipv2
 session transport tcp
 incoming called-number 404329....
 dtmf-relay rtp-nte sip-notify
!
dial-peer voice 2 voip
 destination-pattern 878.....
 translate-outgoing calling 21
 translate-outgoing called 20
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.3.24.3
 session transport udp
 dtmf-relay rtp-nte sip-notify
!
dial-peer voice 5 pots
 destination-pattern 9404328....
 direct-inward-dial
 port 2/0/1:23
 forward-digits 10
!
dial-peer voice 20 voip
 description Load to SJC-RFD-SUB-1 via ATL-IPIPGW
 destination-pattern 846.....
 translate-outgoing calling 21
 translate-outgoing called 20
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.3.80.5
 session transport tcp
 dtmf-relay rtp-nte sip-notify
!
dial-peer voice 6 voip
 destination-pattern 647681....
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.3.70.6
 incoming called-number 647681....
 dtmf-relay rtp-nte
!
dial-peer voice 4 voip
 destination-pattern 404328....
 session protocol sipv2
 session target ipv4:10.3.81.2
 session transport udp
 dtmf-relay sip-notify rtp-nte
 codec g711ulaw
!
dial-peer voice 100 voip
 destination-pattern 8161....
 translate-outgoing calling 21
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.9.40.5
 session transport tcp
 dtmf-relay rtp-nte
!
dial-peer voice 101 voip
 destination-pattern 8161....
 translate-outgoing calling 21
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.9.40.6
 session transport tcp
 dtmf-relay rtp-nte
!
dial-peer voice 102 voip
 destination-pattern 8161....
 translate-outgoing calling 21
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.9.40.7
 session transport tcp
 dtmf-relay rtp-nte
!
dial-peer voice 200 voip
 destination-pattern 8103....
 translate-outgoing calling 21
 translate-outgoing called 20
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.9.30.5
 session transport tcp
 dtmf-relay rtp-nte
!
dial-peer voice 201 voip
 destination-pattern 8103....
 translate-outgoing calling 21
 translate-outgoing called 20
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.9.30.6
 session transport tcp
 dtmf-relay rtp-nte
!
dial-peer voice 202 voip
 destination-pattern 8103....
 translate-outgoing calling 21
 translate-outgoing called 20
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.9.30.7
 session transport tcp
 dtmf-relay rtp-nte
!
dial-peer voice 21 voip
 destination-pattern 852.....
 translate-outgoing calling 21
 translate-outgoing called 20
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.3.80.5
 session transport tcp
 dtmf-relay rtp-nte
!
dial-peer voice 300 voip
 description TO SJC-SUB-1 for H323GW
 destination-pattern 192146.....
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.9.10.5
 session transport tcp
!
dial-peer voice 310 pots
 service stcapp
 port 3/1/0
!
dial-peer voice 311 pots
 service stcapp
 port 3/1/1
!
dial-peer voice 312 pots
 service stcapp
 port 3/1/2
!
dial-peer voice 313 pots
 service stcapp
 port 3/1/3
!
dial-peer voice 123123 pots
 shutdown
 destination-pattern 9.T
 no digit-strip
 direct-inward-dial
 port 2/0/0:23
 forward-digits all
!
dial-peer voice 30 voip
 destination-pattern 8599....
 translate-outgoing calling 21
 translate-outgoing called 20
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.3.94.5
 dtmf-relay rtp-nte
!
dial-peer voice 103 voip
 voice-class codec 2
 incoming called-number .T
!
dial-peer voice 22 voip
 destination-pattern 801191484484846.....
 translate-outgoing calling 21
 translate-outgoing called 20
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.9.20.3
 session transport tcp
 dtmf-relay rtp-nte
!
dial-peer voice 8859 voip
 destination-pattern 88599....
 translate-outgoing calling 21
 translate-outgoing called 20
 voice-class codec 1
 session target ipv4:10.3.94.5
!
dial-peer voice 3 voip
 destination-pattern 910555....
 session protocol sipv2
 session target ipv4:10.3.80.5
 codec g711ulaw
!
gateway 
 timer receive-rtp 1200
!
sip-ua 
telephony-service
 sdspfarm units 1
 sdspfarm transcode sessions 4
 sdspfarm tag 1 MTP0013808b0d00
 load 7910 P00403020214
 load 7960-7940 P0S3-08-2-00
 max-ephones 24
 max-dn 96
 ip source-address 10.3.82.2 port 2000
 auto assign 1 to 24
 max-conferences 12 gain -6
 call-forward pattern .T
 moh flash:music-on-hold.au
 web admin system name admin password ciscocisco1
 transfer-system full-consult
 transfer-pattern .T
 create cnf-files version-stamp 7960 Apr 14 2007 13:14:42
!
ephone-template  1
!
ephone-dn  1
 number 8000....
 mwi on
!
ephone-dn  2
 number 8001....
 mwi off
!
ephone-dn  3  dual-line
 number 5224
 description port 3/1/0
 name port-3-1-0
 call-forward noan 8888 timeout 20
!
ephone-dn  4
 number 5240
!
ephone-dn  5  dual-line
 number 5225
 description port 3/1/1
 name port-3-1-1
!
ephone-dn  6  dual-line
 number 5226
 description port 3/1/2
 name port-3-1-2
!
ephone-dn  7  dual-line
 number 5227
 description port 3/1/3
 name port-3-1-3
 call-forward noan 87829099 timeout 10
!
ephone-dn  8
 number 5100
 pickup-group 1234
 description skinny phone in CME-3845
 name 5100atCME-3845
!
ephone-dn  10  dual-line
 number 5200
 description vg224-2/0
 name vg224-port0
!
ephone-dn  11  dual-line
 number 5201
 description vg224-2/1
 name vg224-port1
!
ephone-dn  22  dual-line
 number 5222
 description port22 of the VG224
 name vg224-port22
!
!
ephone-dn  23  dual-line
 number 5223
 pickup-group 1234
 description vg224-2/23
 name vg224-port24
 call-forward busy 14084629002
 call-forward noan 8888 timeout 20
!
ephone-dn  50
 number 5999
 park-slot
 description parking slot number
!
ephone  1
 device-security-mode none
 mac-address 0009.7CEC.8D32
 type 7960
 button  1:8
!
ephone  2
 device-security-mode none
 mac-address CA71.CC71.5239
 type 7960
!
ephone  3
 device-security-mode none
 mac-address 3808.B0D0.0680
 type anl
 button  1:3
!
ephone  4
 device-security-mode none
 mac-address CA71.CC71.5240
 type 7960
 button  1:4
!
ephone  5
 device-security-mode none
 mac-address 3808.B0D0.0681
 type anl
 button  1:5
!
ephone  6
 device-security-mode none
 mac-address 3808.B0D0.0682
 type anl
 button  1:6
!
ephone  7
 device-security-mode none
 mac-address 3808.B0D0.0683
 type anl
 button  1:7
!
ephone  8
 device-security-mode none
 mac-address C863.875E.E416
 type anl
 keep-conference
 button  1:22
!
ephone  9
 device-security-mode none
 mac-address 0009.7CEC.8F0D
 type 7960
!
ephone  10
 device-security-mode none
 mac-address C863.875E.E400
 type anl
 button  1:10
!
ephone  11
 device-security-mode none
 mac-address C863.875E.E401
 type anl
 button  1:11
!
ephone  22
 device-security-mode none
!
ephone  23
 device-security-mode none
 mac-address C863.875E.E417
 type anl
 keep-conference
 button  1:23
!
line con 0
 exec-timeout 60 0
 password 7 09404F0B
 login
 stopbits 1
line aux 0
 stopbits 1
line 258
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 exec-timeout 60 0
 privilege level 15
 password 7 151E0A0E
 login
line vty 5 15
 exec-timeout 60 0
 privilege level 15
 password 7 1042081B
 login
!
scheduler allocate 20000 1000
ntp clock-period 17179326
ntp server 10.3.181.189
 
   
webvpn cef
 
   
!end

Conference Calls Across an ICT

The following how the Cisco Unified Communications Manager Express was configured for conference calls across an inter-cluster trunks, using SJC end points as the conference initiator.

YYZ-CME-3745-1#sh run 
version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname YYZ-CME-3745-1
!
boot-start-marker
boot system flash flash:c3745-ipvoicek9-mz.124-15.T.fc2
boot system flash flash:c3745-ipvoicek9-mz.124-15.T
boot system flash slot0:c3745-ipvoicek9-mz.124-13.9.PI6a
boot-end-marker
!
!card type command needed for slot 3
logging buffered 40960
enable password 7 09404F0B
!
no aaa new-model
clock timezone est -5
clock summer-time EDT recurring
no network-clock-participate slot 2 
no network-clock-participate slot 3 
no network-clock-participate wic 0 
voice-card 2
 dspfarm
 dsp services dspfarm
!
voice-card 3
 no dspfarm
!
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.3.70.1 10.3.70.10
ip dhcp excluded-address 10.3.70.250
!
ip dhcp pool ITS
   network 10.3.70.0 255.255.255.0
   option 150 ip 10.3.70.2 
   default-router 10.3.70.2 
!
!         
ip name-server 10.9.12.5
multilink bundle-name authenticated
frame-relay switching
isdn switch-type primary-ni
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service h450.2
 no supplementary-service h450.3
 supplementary-service h450.12 advertise-only
 h323
!
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
!
voice class codec 2
 codec preference 1 g729r8
!
voice class codec 3
 codec preference 1 g729br8
 codec preference 2 g729r8
!
archive
 log config
  hidekeys
!
!
controller T1 0/0
 framing esf
 linecode b8zs
 cablelength short 133
 channel-group 0 timeslots 1-24 speed 64
!
controller T1 0/1
 framing esf
 linecode b8zs
 cablelength short 133
 channel-group 0 timeslots 1-24 speed 64
!
controller T1 2/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
 description PSTN connection DMS100 034-red drop
!
controller T1 2/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-21,24
 description To CCME 2851
!
controller T1 3/2
 framing sf
 linecode ami
!
controller T1 3/3
 framing sf
 linecode ami
!
translation-rule 20
 Rule 1 ^8161 261261
 Rule 2 ^878 97678
 Rule 3 ^8103 203203
 Rule 9 ^846 40846
 Rule 10 ^852 21052
!
translation-rule 21
 Rule 1 ^. 404329
!
interface MFR101
 no ip address
 frame-relay multilink bid mfr-3745-7200
!
interface MFR101.1 point-to-point
 ip address 10.3.181.194 255.255.255.252
 frame-relay interface-dlci 1001   
!
interface FastEthernet0/0
 ip address 10.3.70.2 255.255.255.0
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip id YYZ-GK ipaddr 10.3.70.99 1719
 h323-gateway voip h323-id yyz-cme-3745
 h323-gateway voip tech-prefix 1#
 h323-gateway voip bind srcaddr 10.3.70.2
!
interface Serial0/0:0
 no ip address
 encapsulation frame-relay MFR101
 no arp frame-relay
 frame-relay multilink lid link-1
!
interface FastEthernet0/1
 description admin
 ip address 10.3.2.171 255.255.254.0
 duplex auto
 speed auto
!
interface Serial0/1:0
 no ip address
 encapsulation frame-relay MFR101
 no arp frame-relay
 frame-relay multilink lid link-2
!
interface Service-Engine1/0
 ip unnumbered FastEthernet0/0
 service-module ip address 10.3.70.4 255.255.255.0
 service-module ip default-gateway 10.3.70.2
!
interface Serial2/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn outgoing display-ie
 no cdp enable
!
interface Serial2/1:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
router ospf 1
 log-adjacency-changes
 network 10.3.70.0 0.0.0.255 area 70
 network 10.3.181.192 0.0.0.3 area 70
!
ip route 10.3.70.4 255.255.255.255 Service-Engine1/0
ip route 10.3.79.10 255.255.255.255 10.3.70.1
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:
!
access-list 1 permit any
snmp-server community public RO
snmp-server community private RW
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
!
tftp-server flash:P00403020214.bin
tftp-server flash:P0030702T023.bin
tftp-server flash:P0030702T023.sbn
tftp-server flash:P0030702T023.loads
tftp-server flash:P0030702T023.sb2
!
control-plane
!
voice-port 2/0:23
!
voice-port 2/1:23
!
sccp local FastEthernet0/0
sccp
sccp ccm 10.3.70.2 priority 1
!
dspfarm transcoder maximum sessions 4
dspfarm
!
dial-peer voice 300 voip
 preference 1
 destination-pattern 88..
 session protocol sipv2
 session target ipv4:10.3.70.4
 dtmf-relay sip-notify rtp-nte digit-drop
 codec g711ulaw
 no vad
!
dial-peer voice 647 pots
 description pstn
 destination-pattern 919.......
 incoming called-number 647681....
 no digit-strip
 direct-inward-dial
 port 2/0:23
 forward-digits all
!
dial-peer voice 1 voip
 description Load to SJC via YYZ-GK RFD-GK-2
 destination-pattern .T
 translate-outgoing called 20
 voice-class codec 1
 session target ras
 incoming called-number .T
 dtmf-relay rtp-nte h245-alphanumeric
!
dial-peer voice 2 pots
 destination-pattern 9647683....
 direct-inward-dial
 port 2/1:23
 forward-digits 10
!
dial-peer voice 3 voip
 destination-pattern 404329....
 session protocol sipv2
 session target ipv4:10.3.82.2
 incoming called-number .T
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 6476818 voip
 destination-pattern 6476818888
 session protocol sipv2
 session target ipv4:10.3.70.4
 dtmf-relay rtp-nte digit-drop
 codec g711ulaw
 no vad
!
dial-peer voice 200 voip
 description to AA in CUE
 destination-pattern 7777
 session protocol sipv2
 session target ipv4:10.3.70.4
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 161 voip
 destination-pattern 81.T
 session target ras
 incoming called-number .T
 dtmf-relay rtp-nte h245-alphanumeric
!
dial-peer voice 30 pots
!
dial-peer voice 201 voip
 description to AA in CUE
 destination-pattern 6666
 session protocol sipv2
 session target ipv4:10.3.70.4
 dtmf-relay rtp-nte sip-notify
 codec g711ulaw
 no vad
!
!
num-exp 6476814001 4001
num-exp 647272.... ....
gateway 
 timer receive-rtp 1200
!         
!
telephony-service
 sdspfarm units 1
 sdspfarm transcode sessions 12
 sdspfarm unregister force
 sdspfarm tag 1 MTP000b465b87a0
 load 7910 P00403020214
 load 7960-7940 P0030702T023
 max-ephones 192
 max-dn 500
 ip source-address 10.3.70.2 port 2000
 auto assign 1 to 192
 auto assign 1 to 4
 no service directed-pickup
 timeouts interdigit 2
 system message cme
 url services http://10.3.70.4/voiceview/common/login.do
 url authentication http://10.3.70.4/voiceview/authentication/authenticate.do
 dialplan-pattern 1 647681.... extension-length 4
 voicemail 8888
 max-conferences 8 gain -6
 call-forward pattern .T
 moh flash:music-on-hold.au
 multicast moh 239.10.16.4 port 2000
 web admin system name administrator password lab
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern .T
 create cnf-files version-stamp 7960 Jun 21 2007 18:21:02
!
!
ephone-dn  1
 number 1001
 pickup-group 1
 label CME-3745-1 x1001
 call-forward busy 8888
 call-forward noan 8888 timeout 8
!
ephone-dn  2
 number 1002
 pickup-group 1
 label CME-3745-1 x1002
 description 6476811002
 call-forward noan 8888 timeout 8
!
ephone-dn  189
 number 1189
!         
!
ephone-dn  190
 number 1190
!
!
ephone-dn  191
 number 1191
!
!
ephone-dn  192
 number 1192
!
!
ephone  1
 mac-address 0009.7CEC.8E18
 type 7960
 button  1:1 2:3
!
ephone  2
 mac-address 000F.23E7.1991
 type 7960
 button  1:2 2:5
!
ephone  3
 mac-address 0009.7CEC.8E10
 type 7960
 button  1:3
!
ephone  4
 mac-address 0009.7CEC.8E11
 type 7960
!
ephone  5
 mac-address 0009.7CEC.8E12
 type 7960
 button  1:5
!         
ephone  6
 description 7921 wireless phone
 mac-address 0009.3702.2871
 type 7920
 button  1:6
!
ephone  7
 mac-address 0009.7CEC.8E14
 type 7960
 button  1:7
!
ephone  36
 mac-address CA90.CC90.0026
 type 7960
 button  1:36
!
ephone  37
 mac-address CA90.CC90.0027
 type 7960
 button  1:37
!
ephone  38
 mac-address CA90.CC90.0028
 type 7960
 button  1:38
!
ephone  48
 mac-address CA90.CC90.0038
 type 7960
 button  1:48
!
ephone  191
 mac-address 0014.F2C8.73B4
 type 7960
 button  1:191
!
ephone  192
 mac-address CA90.CC90.0000
 type 7960
 button  1:192
!
line con 0
 exec-timeout 0 0
line 33
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line aux 0
line vty 0 4
 exec-timeout 0 0
 password 7 0507070D
 login
!
ntp clock-period 17179082
ntp server 10.3.24.1
!
end

Site with SIP Phones

This conifiguration shows how the Cisco Unified Communications Manager Express was configured for a site with only SIP phones.

Ely-2801-CME#sh run 
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Ely-2801-CME
!
boot-start-marker
boot system flash flash:c2801-ipvoicek9-mz.124-13.13.T4
boot-end-marker
!
logging buffered 200000
enable secret 5 $1$g4AV$3.7p3JiJH6ehAF/F78tSO0
!
no aaa new-model
network-clock-participate wic 2 
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.4.53.1 10.4.53.10
ip dhcp excluded-address 10.4.53.65 10.4.53.74
!
ip dhcp pool Ely-Data
   network 10.4.53.0 255.255.255.192
   default-router 10.4.53.1 
!
ip dhcp pool Ely-Voice
   network 10.4.53.64 255.255.255.192
   default-router 10.4.53.65 
   option 150 ip 10.4.53.65 
!
no ip domain lookup
vlan ifdescr detail
multilink bundle-name authenticated
!
isdn switch-type primary-ni
!
voice-card 0
 dsp services dspfarm
!
!         
voice service voip 
 allow-connections sip to sip
 sip
  bind control source-interface FastEthernet0/1.531
  bind media source-interface FastEthernet0/1.531
  registrar server
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
voice register global
 mode cme
 source-address 10.4.53.65 port 5060
 max-dn 48
 max-pool 24
 load 7961GE SIP41.8-3-0-29S
 load 7961 SIP41.8-3-0-29S
 load 7960-7940 P0S3-08-3-00
 load 7942 SIP41.8-3-0-29S
 load 7941GE SIP41.8-3-0-29S
 timezone 8
 dialplan-pattern 1 3193593... extension-length 4 extension-pattern 3...
 tftp-path flash:
 create profile sync 0006035542621579
!
voice register dn  1
 number 3001
 name Ely-3001
 label Ely-3001
 mwi
!
voice register dn  2
 number 3002
 name Ely-3002
 label Ely-3002
 mwi
!
voice register dn  3
 number 3003
 label fwd-3003
!
voice register template  1
 softkeys hold  Newcall Resume
 softkeys idle  Cfwdall Newcall Redial
 softkeys seized  Cfwdall Endcall Redial
 softkeys connected  Confrn Endcall Hold Trnsfer
!
voice register pool  1
 id mac 0017.593A.3D98
 type 7941GE
 number 1 dn 1
 template 1
 dtmf-relay rtp-nte sip-notify
 voice-class codec 1
!
voice register pool  2
 id mac 0012.0007.9834
 type 7940
 number 1 dn 2
 dtmf-relay sip-notify
 voice-class codec 1
!
voice register pool  3
 id mac 0011.219E.57C4
 type 7962
 number 1 dn 3
!
voice hunt-group 1 sequential
 final 83591002
 list 3001,3002
 timeout 10 
 pilot 3007 secondary 3193593007
!
archive   
 log config
 hidekeys
!
!
controller T1 0/2/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/2/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-4,24
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/1.2
 description Admin
 encapsulation dot1Q 2
 ip address 10.3.2.244 255.255.254.0
!
interface FastEthernet0/1.530
 description Ely Data
 encapsulation dot1Q 530
 ip address 10.4.53.1 255.255.255.192
!
interface FastEthernet0/1.531
 description Ely Voice
 encapsulation dot1Q 531
 ip address 10.4.53.65 255.255.255.192
 h323-gateway voip bind srcaddr 10.4.53.65
!
interface FastEthernet0/1.532
 description Ely Camelot
 encapsulation dot1Q 532
 ip address 10.4.53.129 255.255.255.192
!
interface Serial0/2/0:0
 ip address 10.4.68.49 255.255.255.252
!
interface Serial0/2/1:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
router ospf 1
 log-adjacency-changes
 area 530 range 10.4.53.0 255.255.255.0
 passive-interface default
 no passive-interface Serial0/2/0:0
 network 10.4.53.0 0.0.0.255 area 530
 network 10.4.68.48 0.0.0.3 area 0
!
ip route 10.21.0.0 255.255.0.0 10.3.2.1
ip route 10.25.0.0 255.255.0.0 10.3.2.1
ip route 10.32.0.0 255.255.0.0 10.3.2.1
ip route 10.77.0.0 255.255.0.0 10.3.2.1
ip route 10.82.0.0 255.255.0.0 10.3.2.1
ip route 10.89.0.0 255.255.0.0 10.3.2.1
ip route 10.94.0.0 255.255.0.0 10.3.2.1
ip route 64.0.0.0 255.0.0.0 10.3.2.1
ip route 128.107.0.0 255.255.0.0 10.3.2.1
ip route 161.44.0.0 255.255.0.0 10.3.2.1
ip route 171.0.0.0 255.0.0.0 10.3.2.1
ip route 172.0.0.0 255.0.0.0 10.3.2.1
ip route 192.0.0.0 255.0.0.0 10.3.2.1
ip route 198.0.0.0 255.0.0.0 10.3.2.1
!
!
ip http server
no ip http secure-server
!
logging trap warnings
logging source-interface FastEthernet0/1.2
logging 10.4.58.84
snmp-server community public RO
snmp-server community private RW
snmp-server contact mahesh
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server host 10.4.21.50 version2 
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.21.50 version2 
snmp-server host 10.9.22.34 version2 
disable-eadi
!
!
tftp-server flash:P0S3-07-4-00.sb2
tftp-server flash:P0S3-07-4-00.bin
tftp-server flash:P0S3-07-4-00.loads
tftp-server flash:P003-07-4-00.sbn
tftp-server flash:P0S3-06-3-00.bin
tftp-server flash:P0S3-06-3-00.sbn
tftp-server flash:P003-07-4-00.bin
tftp-server flash:P003-08-4-00.bin
tftp-server flash:P003-08-4-00.sbn
tftp-server flash:P0S3-08-4-00.loads
tftp-server flash:P0S3-08-4-00.sb2
tftp-server flash:P003-08-3-00.bin
tftp-server flash:P0S3-08-3-00.loads
tftp-server flash:P0S3-08-3-00.sb2
tftp-server flash:P003-08-3-00.sbn
tftp-server flash:music-on-hold.au
tftp-server flash:apps41.8-3-0-29.sbn
tftp-server flash:cnu41.8-3-0-29.sbn
tftp-server flash:cvm41sip.8-3-0-29.sbn
tftp-server flash:dsp41.8-3-0-29.sbn
tftp-server flash:jar41sip.8-3-0-29.sbn
tftp-server flash:SIP41.8-3-0-29S.loads
tftp-server flash:term41.default.loads
tftp-server flash:term61.default.loads
tftp-server flash:hipsdontlie.wav
!
control-plane
!
voice-port 0/2/1:23
!
sccp local FastEthernet0/1.531
sccp ccm 10.4.53.65 identifier 1 version 5.0.1 
!
sccp ccm group 1
 bind interface FastEthernet0/1.531
 associate ccm 1 priority 1
 associate profile 1 register hardwareconf
 associate profile 2 register xcoder
!
dspfarm profile 2 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 maximum sessions 6
 associate application SCCP
 shutdown
!
dspfarm profile 1 conference
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 associate application SCCP
!
!
dial-peer voice 92 pots
 destination-pattern 921..........
 incoming called-number .
 direct-inward-dial
 port 0/2/1:23
 prefix 1
!
dial-peer voice 8 voip
 description Outgoing IPIPGW calls
 destination-pattern 8.......
 session protocol sipv2
 session target ipv4:10.4.68.73
 dtmf-relay sip-notify
 no vad
!
dial-peer voice 319 voip
 description Incoming IPIPGW calls
 session protocol sipv2
 incoming called-number 319359....
 no vad
!
sip-ua 
 mwi-server ipv4:10.4.24.19 expires 3600 port 5060 transport udp 
 refer-ood enable
!
telephony-service
 sdspfarm units 3
 sdspfarm transcode sessions 6
 sdspfarm tag 1 hardwareconf
 sdspfarm tag 2 xcoder
 conference hardware
 load 7960-7940 P0S3-08-3-00
 load 7941 SIP41.8-3-0-29S
 load 7961 SIP41.8-3-0-29S
 max-ephones 10
 max-dn 20
 ip source-address 10.4.53.65 port 2000
 max-conferences 4 gain -6
 moh flash:hipsdontlie.wav
 transfer-system full-consult
 transfer-pattern .T
!!
ephone-template  1
 softkeys hold  Newcall Resume
 softkeys idle  Cfwdall Dnd Gpickup HLog Newcall Pickup Redial
 softkeys seized  Callback Endcall Meetme Pickup Redial
 softkeys alerting  Acct Callback Endcall
 softkeys connected  Acct Confrn Endcall Flash HLog Hold Park Trnsfer
!
ephone-template  3
 softkeys connected  Join
!
!
ephone-dn  18  dual-line
 number 4012
 conference ad-hoc
 preference 3
!
ephone-dn  19  dual-line
 number 4012
 conference ad-hoc
 preference 2
 huntstop channel
 no huntstop
!
ephone-dn  20  dual-line
 number 4012
 conference ad-hoc
 preference 1
 huntstop channel
 no huntstop
!
ephone  1
!
line con 0
 password 7 04570A04
line aux 0
line vty 0 4
 exec-timeout 0 0
 password 7 1042081B
 login
!
scheduler allocate 20000 1000
end

Site with SCCP Phones

This conifiguration shows how the Cisco Unified Communications Manager Express was configured for a site with only SCCP phones.

Robins-2801-GW#sh run 
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Robins-2801-GW
!
boot-start-marker
boot system flash flash:c2800nm-ipvoicek9-mz.124-13.13.T4
boot system flash flash:c2800nm-ipvoicek9-mz.124-13.13.T2
boot-end-marker
enable secret 5 $1$cM6Z$Miv0zX7RY9QBM0AO6x7S51
!
no aaa new-model
clock timezone NewYork -5
no network-clock-participate wic 2 
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.4.58.1 10.4.58.10
ip dhcp excluded-address 10.4.58.65 10.4.58.74
!
ip dhcp pool Robins-Data
   network 10.4.58.0 255.255.255.192
   default-router 10.4.58.1 
   dns-server 10.4.21.99 64.102.6.247 
!
ip dhcp pool Robins-Voice
   network 10.4.58.64 255.255.255.192
   default-router 10.4.58.65 
   option 150 ip 10.4.58.68 
   dns-server 10.4.21.99 64.102.6.247 
!
ip dhcp pool freddophone1
   host 10.4.58.79 255.255.255.192
   client-identifier 0100.1120.77aa.92
   default-router 10.4.58.65 
   option 150 ip 10.4.58.71 
!
ip dhcp pool freddophone2
   host 10.4.58.80 255.255.255.192
   client-identifier 0100.1955.3e34.4e
   default-router 10.4.58.65 
   option 150 ip 10.4.58.71 
!
ip dhcp pool freddophone3
   host 10.4.58.81 255.255.255.192
   client-identifier 0100.1ae2.bc3e.fb
   default-router 10.4.58.65 
   option 150 ip 10.4.58.71 
!
ip dhcp pool freddophone4
   host 10.4.58.82 255.255.255.192
   client-identifier 0100.1aa2.320b.d0
   default-router 10.4.58.65 
   option 150 ip 10.4.58.71 
!
ip dhcp pool freddophone5
   host 10.4.58.83 255.255.255.192
   client-identifier 0100.1aa1.36ce.f8
   option 150 ip 10.4.58.71 
   default-router 10.4.58.65 
!
ip dhcp pool freddophone6
   host 10.4.58.86 255.255.255.192
   client-identifier 0100.1aa1.a812.7d
   option 150 ip 10.4.58.71 
   default-router 10.4.58.65 
!
ip dhcp pool freddophone7
   host 10.4.58.88 255.255.255.192
   client-identifier 0100.1aa1.a810.68
   option 150 ip 10.4.58.71 
   default-router 10.4.58.65 
!
ip dhcp pool freddophone8
   host 10.4.58.89 255.255.255.192
   client-identifier 0100.1aa1.a812.37
   option 150 ip 10.4.58.71 
   default-router 10.4.58.65 
!
ip dhcp pool freddophone9
   host 10.4.58.90 255.255.255.192
   client-identifier 0100.14f2.c873.b2
   option 150 ip 10.4.58.71 
   default-router 10.4.58.65 
!
ip dhcp pool freddophone10
   host 10.4.58.91 255.255.255.192
   client-identifier 0100.1560.be49.7b
   option 150 ip 10.4.58.71 
   default-router 10.4.58.65 
!
ip dhcp pool freddophone11
   host 10.4.58.92 255.255.255.192
   client-identifier 0100.175a.7568.83
   option 150 ip 10.4.58.71 
   default-router 10.4.58.65 
!
vlan ifdescr detail
multilink bundle-name authenticated
!
voice-card 0
 no dspfarm
!
archive
 log config
 hidekeys
!
controller T1 0/2/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/2/1
 framing esf
 linecode b8zs
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.2
 description Admin
 encapsulation dot1Q 2
 ip address 10.3.2.249 255.255.254.0
!
interface FastEthernet0/1.580
 encapsulation dot1Q 580
 ip address 10.4.58.1 255.255.255.192
!
interface FastEthernet0/1.581
 encapsulation dot1Q 581
 ip address 10.4.58.65 255.255.255.192
!
interface FastEthernet0/1.582
 encapsulation dot1Q 582
 ip address 10.4.58.129 255.255.255.192
!
interface Serial0/2/0:0
 ip address 10.4.68.69 255.255.255.252
!
router ospf 1
 log-adjacency-changes
 area 580 range 10.4.58.0 255.255.255.0
 passive-interface default
 no passive-interface Serial0/2/0:0
 network 10.4.58.0 0.0.0.255 area 580
 network 10.4.68.68 0.0.0.3 area 0
!
ip route 0.0.0.0 0.0.0.0 10.4.68.70
ip route 10.21.0.0 255.255.0.0 10.3.2.1
ip route 10.25.0.0 255.255.0.0 10.3.2.1
ip route 10.32.0.0 255.255.0.0 10.3.2.1
ip route 10.77.0.0 255.255.0.0 10.3.2.1
ip route 10.82.0.0 255.255.0.0 10.3.2.1
ip route 10.89.0.0 255.255.0.0 10.3.2.1
ip route 10.94.0.0 255.255.0.0 10.3.2.1
ip route 64.0.0.0 255.0.0.0 10.3.2.1
ip route 128.107.0.0 255.255.0.0 10.3.2.1
ip route 161.44.0.0 255.255.0.0 10.3.2.1
ip route 171.0.0.0 255.0.0.0 10.3.2.1
ip route 172.0.0.0 255.0.0.0 10.3.2.1
ip route 192.0.0.0 255.0.0.0 10.3.2.1
ip route 198.0.0.0 255.0.0.0 10.3.2.1
!
ip http server
no ip http secure-server
!
logging trap warnings
logging source-interface FastEthernet0/1.2
logging 10.4.58.84
snmp-server community public RO
snmp-server community private RW
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server host 10.4.21.50 version2 
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
control-plane
!         
line con 0
 exec-timeout 0 0
 password lab
line aux 0
line vty 0 4
 exec-timeout 0 0
 password lab
 login
!
scheduler allocate 20000 1000
!
end

Site with SIP and SCCP Phones

This conifiguration shows how the Cisco Unified Communications Manager Express was configured for a site with both SIP and SCCP phones.

Covington-3725-CME#sh run 
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Covington-3725-CME
!
boot-start-marker
boot system flash flash:c3725-ipvoicek9-mz.124-13.13.T4
boot-end-marker
!
enable secret 5 $1$y65I$brD.SGsGfCHFP1bJM4Prh.
!
no aaa new-model
no network-clock-participate slot 1 
no network-clock-participate slot 2 
network-clock-participate wic 2 
ip cef
!
no ip domain lookup
multilink bundle-name authenticated
isdn switch-type primary-ni
voice-card 1
 dspfarm
!
voice service voip 
 allow-connections h323 to sip
 h323
  call start slow
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
voice translation-rule 7
 rule 1 /^319359\(7...\)/ /\1/
!
voice translation-profile voicemail
 translate calling 7
!
archive
 log config
 hidekeys
!
controller T1 0/0
 shutdown
 framing sf
 linecode ami
!
controller T1 0/1
 framing esf
 clock source internal
 linecode b8zs
!
controller T1 1/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
 description To GB-5800 0/6
!
controller T1 1/1
 framing esf
 linecode b8zs
 ds0-group 1 timeslots 1-9 type e&m-fgd
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.4.57.68 255.255.255.192
 speed 100
 full-duplex
!
interface Serial1/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn outgoing display-ie
 no cdp enable
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 10.4.57.65
!
ip http server
no ip http secure-server
ip http path flash:
!
logging trap warnings
logging source-interface FastEthernet0/1
logging 10.4.58.84
snmp-server community public RO
snmp-server community private RW
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server host 10.4.21.50 version2 
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
tftp-server flash:P0030702T023.bin
tftp-server flash:P0030702T023.loads
tftp-server flash:P0030702T023.sb2
tftp-server flash:P0030702T023.sbn
tftp-server flash:CVM70.2-0-2-26.sbn
tftp-server flash:Jar70.2-9-2-26.sbn
tftp-server flash:TERM70.7-0-3-0S.loads
tftp-server flash:cnu70.2-7-6-26.sbn
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:ATA030201SCCP050429A.zup
!
control-plane
!
voice-port 1/0:23
!
voice-port 1/1:1
 timing dialout-delay 300
!
dspfarm profile 1 conference
 maximum conference-participants 0
 shutdown
!
dial-peer voice 92 pots
 shutdown
 destination-pattern 921..........
 incoming called-number .
 direct-inward-dial
 port 1/0:23
 prefix 1
!
dial-peer voice 8 voip
 destination-pattern 8.......
 voice-class codec 1
 session target ipv4:10.4.68.73
 no vad
!
dial-peer voice 319 voip
 description Incoming IPIPGW calls
 voice-class codec 1
 incoming called-number 319359....
 no vad
!
dial-peer voice 7900 voip
 destination-pattern 7900
 session protocol sipv2
 session target ipv4:10.4.57.69
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 95 pots
 destination-pattern 951..........
 incoming called-number .T
 direct-inward-dial
 port 1/1:1
 forward-digits 10
!
dial-peer voice 7950 voip
 translation-profile outgoing voicemail
 destination-pattern 7950
 session protocol sipv2
 session target ipv4:10.4.57.69
 dtmf-relay sip-notify
 codec g711ulaw
!
num-exp 3193597950 7950
num-exp 3193597900 7900
!
telephony-service
 load 7960-7940 P0030702T023
 load ATA ATA030201SCCP050429A.zup
 load 7912 CP7912080001SCCP051117A
 max-ephones 24
 max-dn 24
 ip source-address 10.4.57.68 port 2000
 service phone videCapability 1
 url services http://10.4.57.69/voiceview/common/login.do
 url authentication http://10.4.57.69/voiceview/authentication/authenticate.do
 dialplan-pattern 1 3193597... extension-length 4
 dialplan-pattern 2 9513193597... extension-length 4
 voicemail 7900
 max-conferences 8 gain -6
 call-park system redirect
 web admin system name admin password cisco
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern .T
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
ephone-dn  1  dual-line
 number 7001
 label Covington-7001
 name Covington-7001
 call-forward noan 7900 timeout 12
!
ephone-dn  2  dual-line
 number 7002
 label Covington-7002
 name Covington-7002
!
ephone-dn  3  dual-line
 number 7003
 label Covington-7003
 name Covington-7003
!
ephone-dn  4  dual-line
 number 7004
 label Covington-7004
 name Covington-7004
!
ephone-dn  5  dual-line
 number 7005
 label Covington-7005
 name Covington-7005
 call-forward all 7900
 call-forward busy 7007
!
ephone-dn  6  dual-line
 number 7006
 label Covington-7006
 name Covington-7006
!
ephone-dn  7  dual-line
 number 7007
 label Covington 7007
 name Covington 7007
!
ephone-dn  8  dual-line
 number 7008
!
ephone-dn  9  dual-line
 number 7009
!
ephone-dn  10
 number 7999....
 mwi on
!
ephone-dn  11
 number 7998....
 mwi off
!
ephone  1
 no multicast-moh
 mac-address 000F.902A.3200
 type 7912
 button  1:1
!
ephone  2
 no multicast-moh
 mac-address 0011.2077.AA8C
 type 7960
 button  1:2
!
ephone  3
 no multicast-moh
 mac-address C863.AEF7.8402
 type anl
 button  1:3
!
ephone  4
 no multicast-moh
 mac-address C863.AEF7.8400
 type anl
 button  1:4
!
ephone  5
 no multicast-moh
 mac-address 0011.2077.AD4D
 type 7960
 button  1:5
!
ephone  6
 no multicast-moh
 mac-address 0018.1885.5B58
 type 7971
 button  1:6
!
ephone  7
 no multicast-moh
 mac-address 0016.CE28.FBC7
 type CIPC
 button  1:7
!
ephone  8
 no multicast-moh
 mac-address 0016.362E.3EBF
 type CIPC
 button  1:8
!
ephone  9
 no multicast-moh
 mac-address 0009.3702.2A84
!
ephone  10
 no multicast-moh
 video
 mac-address 0050.6001.54BC
 type 7985
!
ephone  24
 no multicast-moh
!
line con 0
 exec-timeout 0 0
 password 7 020A0559
 login
line aux 0
line vty 0 4
 exec-timeout 0 0
 password 7 13091610
 login
!
!
end