Guest

IP Tunneling

Configurando o Cisco VPN 5000 e um roteador para abrir um túnel GRE

Hierarchical Navigation

Introdução

Este documento fornece uma vista geral da configuração exigida para permitir um roteador Cisco que executa o software de Cisco IOS® e um concentrador da Cisco VPN 5000 Series para abrir um túnel de encapsulamento de roteamento genérico (GRE).

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco IOS Software Release 12.0(7)T

  • Versão de software do concentrador 5.2.19US do Cisco VPN 5000

  • Concentrador Cisco VPN 5002

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

vpn5k_iosgre_01.gif

Configurações

Este documento utiliza as configurações mostradas aqui.

Concentrador Cisco VPN 5002
[ General ]
 IPSecGateway             = 200.1.1.2
 DeviceName               = "omar5002"
 EthernetAddress          = 00:00:a5:
 e9:c8:00
 DeviceType               = VPN 5002/8 Concentrator
 ConfiguredOn             = Timeserver not configured
 ConfiguredFrom           = Command Line, from Console
 EnablePassword           =
 Password                 =


[ IP Ethernet 1:0 ]
 Mode                     = Routed
 SubnetMask               = 255.255.255.0
 IPAddress                = 200.1.1.1


[ IP Ethernet 0:0 ]
 Mode                     = Routed
 SubnetMask               = 255.255.255.0
 IPAddress                = 10.10.10.1


[ Tunnel Partner VPN 1 ]
 EncryptMethod            = None
 Encryption               = Off
 Authentication           = Off
 KeyManage                = Manual
 Mode                     = Main
 Partner                  = 100.1.1.1
 LocalAccess              = "10.10.10.0/24"
 BindTo                   = "ethernet1:0"
 Peer                     = "20.20.20.0/24"


[ IP Static ]
 20.20.20.0 255.255.255.0 vpn 1 1


[ IP VPN 1 ]
 Numbered                 = Off
 Mode                     = Routed
 Configuration size is 1107 out of 65500 bytes.
 omar5002#

Cisco IOS Software running do roteador
Router Configuration:
Router#show running-config
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
!
interface Tunnel0
ip unnumbered Ethernet1
no ip directed-broadcast
tunnel source 100.1.1.1
tunnel destination 200.1.1.1
!
interface Ethernet0
ip address 100.1.1.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet1
ip address 20.20.20.1 255.255.255.0
no ip directed-broadcast
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 100.1.1.2 1
ip route 10.10.10.0 255.255.255.0 Tunnel0
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • show vpn statistics verbose — Fornece a informação de túnel detalhadas.

  • relação da mostra — Fornece estatístico de interface.

Este é exemplo de saída de comando do show vpn statistics verbose tomado do Concentrador Cisco VPN 5002.

omar5002#show vpn statistic verbose
Current  In       High     Running  Tunnel   Tunnel   Tunnel
Active   Negot    Water    Total    Starts   OK       Error
--------------------------------------------------------------
Users     0        0        0        0        0        0        0
Partners  1        0        1        1        0        0        0
Total     1        0        1        1        0        0        0
Stats             VPN0:1
Wrapped              697
Unwrapped            697
BadEncap               0
BadAuth                0
BadEncrypt             0
rx IP                718
rx IPX                 0
rx Other               0
tx IP                734
tx IPX                 0
tx Other               0
IKE rekey              0
Input VPN pkts dropped due to no SA: 0
Input VPN pkts dropped due to no free queue entries: 0
ISAKMP Negotiation stats
Admin packets in        0
Fastswitch packets in   0
No cookie found         0
Can't insert cookie     0
Inserted cookie(L)      0
Inserted cookie(R)      0
Cookie not inserted(L)  0
Cookie not inserted(R)  0
Cookie conn changed     0
Cookie already inserted  0
Deleted cookie(L)       0
Deleted cookie(R)       0
Cookie not deleted(L)   0
Cookie not deleted(R)   0
Forwarded to RP         0
Forwarded to IOP        0
Bad UDP checksum        0
Not fastswitched        0

Este é exemplo de saída de comando do comando show interface tomado do roteador.

Router#show interface tunnel 0
Tunnel0 is up, line protocol is up
Hardware is Tunnel
Interface is unnumbered. Using address of Ethernet1 (20.20.20.1)
MTU 1476 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 55/255, rxload 113/255
Encapsulation TUNNEL, loopback not set
Keepalive set (10 sec)
Tunnel source 100.1.1.1, destination 200.1.1.1
Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled
Checksumming of packets disabled,  fast tunneling enabled
Last input 00:00:15, output 00:00:15, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 1 drops; input queue 0/75, 0 drops
5 minute input rate 4000 bits/sec, 5 packets/sec
5 minute output rate 11000 bits/sec, 5 packets/sec
1309 packets input, 129264 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
1348 packets output, 316468 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out 
Router#

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Informações Relacionadas