Cisco MDS 9000 シリーズ

MDS 9000 を使用したアベイラビリティの高い iSCSI 設計

ダウンロード
MDS 9000 を使用したアベイラビリティの高い iSCSI 設計

White Paper


MDS 9000 ファミリ マルチレイヤ スイッチを使用した
アベイラビリティの高い iSCSI 設計


はじめに

エンタープライズ環境では、ストレージの展開と管理を SAN ベースのモデルに移行することで、多くの利益が実現し始めています。 さまざまなアプリケーションやサーバの間でストレージ リソースを共有することにより、環境が統合され、管理費用と利用料金が大幅に低下するからです。 一方、複数のサーバを介してアクセス可能な共有ストレージ リソースに重要なデータを移行する動きが進むにつれて、ストレージに常時アクセスできる状態を確保することが不可欠になります。 IP サービス モジュールを使用して MDS ファミリの IP SAN 接続機能のアベイラビリティを強化すれば、アプリケーションの展開において今後も最大限のアベイラビリティと復元力を維持できます。 iSCSI ソリューションによって実現されるコストの削減とネットワークの簡素化は、すべての企業に恩恵をもたらします。これは、共有ストレージ リソースへの接続コストを削減するための新しい選択肢です。 ただし、データにアクセスできなくなった場合は、ビジネスに深刻な影響や損害が発生する可能性があります。 今日の企業環境では、ファイバ チャネル接続か IP(iSCSI)接続かを問わず、99.999 % のデータ アベイラビリティが求められています。

金融、製造、電気通信などの業界では、以前からミッションクリティカル アプリケーションのアベイラビリティを維持することがストレージ設計における必須条件となっていました。 従来、アベイラビリティという言葉は、耐障害システムのことだけを意味していました。 つまり、保護されているシステム コンポーネントから冗長コンポーネントへのフェールオーバーを行うことでダウンタイムを最小限に抑えるハードウェア システム構成を意味していました。 高いアベイラビリティを実現するは、次の 3 点を考慮する必要があります。

  • 計画的メンテナンスの際の稼動を停止しない。または、ダウンタイムを最小限に抑える。
  • サーバ、ネットワーク スイッチ、ストレージ サブシステム、オペレーティング システム、アプリケーションなどのエンティティで、予期せぬハードウェア障害やソフトウェア障害が発生した場合のアベイラビリティの回復。
  • 火災、地震、洪水、人為的ミスなどによる障害が発生した場合のアベイラビリティの回復。

一般的な耐障害システムは、次の 3 つの層から構成されます。

1. クラスタリングおよび代替パスによるサーバの保護(サーバまたはパスの障害時に、稼動中のサーバ プラットフォームまたはスイッチ パスにアプリケーションを移行する)

2. 冗長ネットワーキング(ハードウェア障害時の接続の信頼性を確保する。インテリジェント データ管理システムおよびストレージ管理システムを含む)

3. RAID(Redundant Array of Inexpensive Disks)テクノロジー、キャッシュ ミラーリング、データ ミラーリング、リモート複製によるストレージの保護

ネットワークのあらゆる層を冗長化することで、アベイラビリティの高い SAN を構築することができます。 ネットワーク設計の各要素は、この目的を達成するための構築単位になります。 アベイラビリティを向上させる基本形態の 1 つには、ファブリック内部で冗長化されたハードウェア コンポーネントを使用する方法があります。 ディレクタ クラス SAN ファブリック スイッチの多くは 99.999 % の稼働率をさかんにアピールしていますが、アベイラビリティは 1 台のプラットフォームだけの問題ではなく、アーキテクチャ レベルの問題です。 デュアルファブリック SAN ソリューションを展開すれば、1 箇所の障害によってシステム全体が停止することを防止できます。

サーバ側では、クラスタリングと呼ばれるハイ アベイラビリティ テクノロジーを利用して、アプリケーション レベルの冗長性を確保できます。複数のサーバで 1 つのクラスタを構成すると、ノードに障害が発生した場合のバックアップが可能になります。 この文書の範囲から外れるため、クラスタリングについての説明は割愛します。

ネットワーキングとシステムの HA 機能は個別に設定することもできますが、クラスタリングを行うと、冗長化されたネットワーク接続をマルチパス機能によって管理できるので、2 つの HA システムが統合されます。 クラスタリングを使用すると、サーバ レベルまたはアプリケーション レベルでのフェールオーバーが可能になります。 クラスタ内のスタンバイ サーバでは、必要に応じて各アプリケーションの設定を行えます。 また、クラスタ内のサーバをリモートに設置すると、特定の場所や建物における災害から保護できます。 災害が発生してローカルの機能が停止した場合は、サーバ クラスタ全体をリモートの施設にフェールオーバーすることができます。 多くの場合、SAN の設計では、最大限の保護を実現するために、階層型アーキテクチャおよび分散型アーキテクチャが採用されます。 これらのソリューションに必要なインテリジェンスは、クラスタリングやミラーリングなど、さまざまな技術によって提供されます。

一部のソフトウェア パッケージには、マルチパスと呼ばれる機能が組み込まれています。 通常、これらのパッケージには 2 つのサービスが用意されています。 通常時には、利用可能なインターフェイスおよびパスの間でデータ トラフィックのロード バランシングが行われます。 パスの障害が発生した場合は、利用可能な他のパスにトラフィックがルーティングされます。 パスが 3 つ以上存在する状況も少なくありませんが、この文書ではパスが 2 つのシナリオのみを扱います。 SAN によってストレージへの論理パスが複数提供されている場合、マルチパス機能はストレージ デバイスへのアクセスを冗長化するために使用されます。 パスを冗長化するには、複数のホスト I/O コントローラ、スイッチ、ケーブル、およびストレージ デバイス ポートを使用します。 また、冗長化によるコストの増加と、厳しいネットワーク要件を考慮して、個々のコンポーネント レベルでの冗長性のみを確保する方法もあります。 個々のコンポーネント レベルでは、強力な管理技術と監視技術をネットワークに組み入れて、スイッチオーバーを最小限のダウンタイムで実行できるようにする必要があります。

一般的なマルチパス構成では、イニシエータとターゲットの間の接続を行うために、各パスが複数のファブリックを横断しています。 いずれかのパスで障害が発生した場合は、フェールオーバー イベントが発生します。 したがって、マルチパス ソフトウェアには、パスを予防的に監視し、現在使用されているパスで障害が発生した場合にすばやくフェールオーバーを行う機能が用意されている必要があります。

障害イベントの発生時には、すべてのデバイス(ターゲットおよび LUN)へのアクセスを維持するネットワーク復旧メカニズム、または接続の障害を検出して復旧するマルチパス技術のいずれかが重要になります。 冗長設計の最大の目標は、アプリケーション層でのアクセスを維持し、ダウンタイムを最小限に抑えることです。 この文書のシナリオでは、アプリケーション層を確実に保護する手段として、マルチパス ソフトウェアおよび iSCSI ネットワークの冗長性を組み合わせる方法を使用します。

ハイ アベイラビリティ設計においては、ネットワーク、またはネットワークを使用するシステムなど、複数のレベルで考慮すべき事項があります。 たとえば、ネットワーク全体で接続を冗長化すると、障害やユーザ エラーによるネットワークの機能停止を最大限に防止できます。 冗長化された SAN ハードウェア ソリューションにも、コンポーネントやサービスの障害から復旧するためのメカニズムが組み込まれている必要があります。 また、不正アクセスによってストレージのアベイラビリティに深刻な影響が出る場合もあるため、セキュリティについても検討する必要があります。 ストレージなどの高価なリソースを共有する場合は、不正アクセスを防止するための厳重なセキュリティ対策が必要です。 ゾーニング、イニシエータ認証、アクセス リストなどのメカニズムを使用すると、特定のイニシエータとターゲットの間の通信だけを許可することができます。 これにより、セキュリティが確保されるだけでなく、権限のないサーバからの偶発的なアクセスによるデータの破損も防止できるので、ダウンタイムを最小限に抑えることができます。

インフラストラクチャの「バック エンド」は、アベイラビリティとスケーラビリティに優れた情報ストレージ サブシステムで構成されている必要があります。また、それらのサブシステムは、キャパシティの拡張性、データ整合性サービス、およびデータ複製機能を備えている必要があります。 堅牢なソフトウェアとファームウェアを使用すれば、アプリケーションに関係なく、すべてのデータに常時アクセスできます。 ストレージ サブシステム アーキテクチャからシステム全体の停止につながる箇所を排除することが、システム アベイラビリティの向上につながります。 また、RAID レベル 1、5、0+1/1+0 などを使用して、データの冗長性を確保し、ディスクの物理的故障から重要な情報を保護する必要もあります。

シナリオ

この文書では、アベイラビリティの高い IP ストレージ エリア ネットワークを定義する要素について説明します。 また、アプリケーション インフラストラクチャ全体にわたって適切なレベルのアベイラビリティを設計して展開する方法についても説明します。 さらに、シスコのソリューションが、さまざまな規模の組織で、アベイラビリティの高いコンピューティング環境の実現にどのように貢献するかについても説明します。

Cisco MDS 9000 ファミリのマルチレイヤ スイッチでは、iSCSI サービスと FCIP サービスが内蔵された IP サービス モジュールがオプションとして提供されています。 IP サービス モジュールには、IP ストレージ ネットワークの冗長性を確保し、システムのアベイラビリティを向上させるためのサービスが用意されています。 この文書では、主に次の事項について説明します。

  • iSCSI と Cisco IP サービス モジュールを使用する場合の設計およびハイ アベイラビリティ構成
  • マルチパス ソフトウェアを使用しない場合の iSCSI SAN 設計に関するケース スタディ
  • マルチパス ソフトウェアをする場合の iSCSI SAN 設計に関するケース スタディ

この文書は、SAN の構成とオプションに重点を置いています。 ホストのクラスタリングに関する説明は、この文書の範囲から外れるため割愛します。 また、ストレージ サブシステムの実装と設定についても、この文書では説明しません。

ハードウェアおよびソフトウェア環境

次の表に、すべてのテストで使用したハードウェアおよびソフトウェアの環境を示します。

表 1  

ハードウェア バージョンと詳細
Dell PowerEdge 1650 Server

2GB の RAM

18GB のローカル ディスク

Windows 2000 Server SP3

Windows 2000 用 Cisco iSCSI ドライバ バージョン 3.1.1

Veritas Volume Manager 3.1 for Windows

内蔵型 Intel GE NIC

Intel ProSet Utility(アダプタ チーミング)

Catalyst 3550

IOS (C3550-I5Q3L2-M)12.1(8) EA1c

Cisco MDS 9216 ファブリック スイッチ

ファームウェア 1.1(1)

Xyratex RAID

2GB のコントローラ(LUN x 8)

テスト トポロジ 1

このトポロジでは、Cisco MDS 9000 ファミリの複数の iSCSI 関連機能を使用します。 その 1 つは、Virtual Redundancy Router Protocol(VRRP; 仮想ルータ冗長プロトコル)です。 VRRP は、冗長ルータ ゲートウェイ サービスを提供します。このサービスを使用すると、Cisco MDS 9000 IP ストレージ モジュールのギガビット イーサネット ポートで障害が発生した場合に、冗長 IP ストレージ モジュールのギガビット イーサネット ポートを使用して iSCSI サービスとそのアトリビュートが回復されるので、影響を受けた iSCSI セッションのアクセスは中断されません。 また、Cisco MDS 9000 ファミリの IP ストレージ モジュールには、EtherChannel という機能もあります。 EtherChannel を使用すると、2 つのギガビット イーサネット リンクを、帯域幅の広い 1 つの論理リンクとして統合することができます。 初期リリースでは、同じ IP ストレージ モジュール上の隣接する 2 つのギガビット イーサネット ポートに対してしか EtherChanel 機能を使用できません。 ただし、このテスト シナリオでは、EtherChannel を使用しません。

このテストで使用されている Cisco MDS 9000 のもう 1 つの IP ストレージ機能は、PWWN エイリアシングです。 PWWN エイリアシングは、このソリューションのファイバ チャネル側の復旧機能です。 PWWN エイリアシングを使用すると、物理ストレージ ターゲットに接続されているアクティブなファイバ チャネル ポートで障害が発生した場合に、冗長ファイバ チャネル ポートへのフェールオーバーが行われます。 これは、両方のファイバ チャネル ポートを同じ LUN に接続して、ファイバ チャネル SAN にある物理ストレージへのパスを冗長化するという方法です。 ただし、すべてのストレージ アレイが、複数のストレージ サブシステム インターフェイスにわたるアクティブ/アクティブ LUN 構成をサポートしているわけではありません。 この機能の詳細については、ストレージの製造元にお問い合せください。

環境によっては、すべてのサーバにマルチパス ソフトウェアをインストールすると、膨大なコストがかかる場合がありますが、 ロー エンドからミッド エンドのサーバを使用している場合は、Intel の NIC カードに組み込まれている「アダプタ チーミング」機能と、前述の MDS 9000 の機能を組み合わせることで、アベイラビリティの高いアーキテクチャを展開することができます。 「アダプタ チーミング」機能を使用すると、2 つのイーサネット ネットワーク インターフェイスを、1 つの論理インターフェイスとして使用できます。この論理インターフェイスで使用される IP アドレスと MAC アドレスは、それぞれ 1 つです。 「アダプタ チーミング」機能は、アクティブ/アクティブ モードまたはアクティブ/パッシブ モードで動作します。 詳細については、NIC のベンダーにお問い合せください。


図 1
テスト シナリオ #1 および障害シナリオの結果

セットアップと設定

各コンポーネントのセットアップおよび設定の詳細については、付録 2 を参照してください。

結果

次の表に、SAN 内部における一連の障害テストの結果を示します。 各障害シナリオの分析については、「説明」欄を参照してください。 ホスト側から見た I/O は、2 つのシナリオにおいて、完全に中断なく回復されます。

表 2  

障害テスト 障害発生前のアクティブ パス数 フェールオーバー時間 障害発生後のアクティブ パス数 復旧時間 説明
ホスト N1 の NIC の障害

2

0 秒

1

0 秒

NIC に障害が発生しても、NIC のチーミング機能によって、透過的にストレージへアクセスできます。

IP ストレージ モジュール ポートの障害

2

20 秒以下

2

手動によるスイッチバック

VRRP によってスタンバイ IPS GE ポートへのフェールオーバーが行われ、I/O が保持され、20 秒以内に復旧が完了します。

ストレージ ポートの障害

2

0 秒

2

0 秒

ストレージ ポートの pWWN エイリアシング機能により、スタンバイ ストレージ ポートへのフェールオーバーが透過的に行われます。

一方の MDS スイッチの障害

2

20 秒以下

2

手動によるスイッチバック

MDS スイッチまたは IPS ラインカードに障害が発生しても、VRRP および pWWN エイリアシング機能により、ストレージへアクセスできます。

テスト トポロジ 2

図 2 に示すように、サーバとストレージ ターゲットの間は、2 つのパスが存在する単純な構成によって接続されています。 このトポロジは、物理接続の点ではトポロジ 1 と同じです。 ただし、このトポロジでは、ホスト コンポーネントの「アダプタ チーミング」機能を使用しません。また、pWWN エイリアシング、EtherChannel、および VRRP も使用しません。 このトポロジでも pWWN エイリアシング、EtherChannel、および VRRP 機能を使用することはできますが、マルチパス ソフトウェアを使用するため、これらの機能は必要ありません。 マルチパス ソフトウェアは、ホストの接続およびストレージ アクセスに対して HA サービスを提供するために使用されています。 マルチパス ソフトウェアを使用する場合は、一部のソフトウェア ソリューションに付属するロード バランシング機能を使用すると、ストレージ ポートへのすべてのパスをフルに活用できます。


図 2
テスト シナリオ #2 および障害シナリオの結果

セットアップと設定

各コンポーネントのセットアップおよび設定の詳細については、付録 3 を参照してください。

結果

次の表に、SAN 内部における一連の障害テストの結果を示します。 各障害シナリオの分析については、「説明」欄を参照してください。 マルチパス ソフトウェアを使用している場合は、すべてのシナリオにおいて、ホスト側から見た I/O が完全に中断なく回復されます。

表 3  

障害テスト 障害発生前のアクティブ パス数 フェールオーバー時間 障害発生後のアクティブ パス数 復旧時間 説明
ホスト N1 の NIC の障害

4

0 秒

2

0 秒

N1 で障害が発生した場合、ストレージへのパスは 2 つとも残りますが、両方のストレージ ポートへのアクセスが、N2 から IP-P2 GE ポートへのパスを経由して行われます。

IPS IP-P1 の障害

4

0 秒

2

0 秒

IP-P1 の GE ポートで障害が発生した場合、ストレージへのパスは 2 つとも残りますが、両方のストレージ ポートへのアクセスが、N2 から IP-P2 GE ポートへのパスを経由して行われます。

ストレージ PWWN1 ポートの障害

4

0 秒

2

0 秒

PWWN1 ストレージ ポートで障害が発生した場合、NIC から IPS GE ポートへのパスは 2 つとも残りますが、ストレージ ポートへのパスは PWWN2 しか残りません。

一方の MDS スイッチの障害

4

0 秒

1

0 秒

このシナリオでは、IPS GE ポートとストレージ ポート PWWN1 の両方がダウンし、N2 から IP-P2 GE ポートおよび PWWN2 ストレージ ポートへのパスしか残らないため、ストレージへのパスは 1 つしか残りません。

テスト トポロジ 3

このトポロジでは、2 つの MDS 9216 スイッチがリンクされていないため、1 つのファブリックを形成していません。 2 つの MDS 9216 スイッチは、一方のファブリックがダウンした場合のアベイラビリティを確保するために、2 つの独立したファブリックとして展開されています。 このようなファブリックの分離は、MDS 9000 ファミリ スイッチの Virtual SAN 機能を使用して実現することもできます。 トポロジ 2 と同様に、このトポロジでは VRRP、EtherChannel、および PWWN エイリアシング機能を使用しません。 このテスト シナリオでは、ホスト ベースのマルチパス ソフトウェアを使用しています。


図 3
テスト シナリオ #3 および障害シナリオの結果

セットアップと設定

各コンポーネントのセットアップおよび設定の詳細については、付録 4 を参照してください。

結果

次の表に、SAN 内部における一連の障害テストの結果を示します。 各障害シナリオの分析については、「説明」欄を参照してください。 ホスト側から見た I/O は、すべてのシナリオにおいて、完全に中断なく回復されます。

表 4  

障害テスト 障害発生前のアクティブ パス数 フェールオーバー時間 障害発生後のアクティブ パス数 復旧時間 説明
ホスト N1 の NIC の障害

2

0 秒

1

0 秒

2 つ目のパスを使用して、引き続きストレージにアクセスできます。

IPS IP-P1 の障害

2

0 秒

1

0 秒

2 つ目のパスを使用して、引き続きストレージにアクセスできます。

ストレージ PWWN1 ポートの障害

2

0 秒

1

0 秒

2 つ目のパスを使用して、引き続きストレージにアクセスできます。

一方の MDS スイッチの障害

2

0 秒

1

0 秒

2 つ目のパスを使用して、引き続きストレージにアクセスできます。

結論

アベイラビリティは設計上の重要な要素であり、エンドツーエンドのソリューションが求められます。 高いアベイラビリティを実現するための第一歩は、ハイ アベイラビリティ機能を備えた製品を導入して、信頼性の高い堅牢なネットワーク基盤を構築することです。 サーバ、スイッチ、ファブリック、ストレージ デバイスなど、複数のコンポーネントで構成されるネットワークでは、冗長性を確保するだけでアベイラビリティが向上するとは限りません。 ネットワーク、ストレージ、およびサーバの管理者は、ネットワーク(LAN および SAN)のアーキテクチャを慎重に設計し、インフラストラクチャのあらゆる箇所でフェールオーバーがアプリケーションに及ぼす影響を検討する必要があります。 Cisco MDS 9000 ファミリは、ストレージ トランザクションを透過的に維持し、アプリケーション層への影響を最小限に抑える、迅速な復旧機能を備えた復元力の高いネットワーキング ソリューションです。

上記のテスト結果が示すように、IP サービス モジュールを装備した Cisco MDS 9000 ファミリの HA 機能を利用すると、マルチパス ソフトウェアなどのホスト ベース HA アプリケーションを補完する、アベイラビリティの高い IP SAN インフラストラクチャを構築できます。 企業アプリケーションの多くはビジネスに欠かせないものであるため、アベイラビリティは稼働率だけの問題ではなく、常に同水準のパフォーマンスを維持できるかどうかも重要になります。 Cisco MDS 9000 ファミリのスイッチと、ワイヤ速度の iSCSI パフォーマンスを実現する IP ストレージ モジュールを組み合わせれば、復元力の高いマルチプロトコル SAN インフラストラクチャを構築するための基盤が提供されます。

参考資料

1. Marc Farley、Building Storage Networks(Network Professionals Library)

付録 1: ハードウェア コンポーネント情報

サーバのセットアップ

このセットアップでは、2 つのギガビット イーサネット ポートを備えた SQL サーバを使用します。 各ギガビット イーサネット ポートは、別々の Catalyst 3500 スイッチに接続されています。 トポロジ 2 およびトポロジ 3 では、パスの制御に Veritas Volume Manager for Windows ソフトウェア バージョン 3.1 を使用します。トポロジ 1 では、Intel の「アダプタ チーミング」テクノロジーを使用します。 また、この環境内でエラーのシミュレーションを行っている間に iSCSI ターゲット上の SQL データベースに入力されたデータを検証するために、簡単な SQL スクリプトを作成します。

Catalyst 3500

このケースでは、2 台の Cisco Catalyst 3550 を使用して、冗長化されたイーサネット スイッチ構成を構築します。 これらのスイッチの主な利用目的は VLAN のブリッジングなので、最近のものであれば、どのバージョンの Catalyst ソフトウェアを使用しても構いません。

MDS 9216 の構成

アベイラビリティを強化するため、Xyratex Fibre Channel アレイ ストレージのポートを、別々の MDS 9216 スイッチに接続します。 MDS IP ストレージ モジュールの各ギガビット イーサネット ポートは、別々の Catalyst 3550 スイッチに接続します。 トポロジ 1 およびトポロジ 2 では、2 台の MDS9126 スイッチ間でファイバ チャネル ポートチャネルを作成し、1 つのファブリックおよび 1 つの VSAN を構築します。 トポロジ 3 では、ファブリックの論理的分離および物理的分離をテストするために、ポートチャネルは作成しません。

Xyratex ストレージ

冗長性を確保するために、2 つのファイバ チャネル ポートを利用する Xyratex RAID コントローラを使用します。 どのトポロジのテスト シナリオにおいても、各 Xyratex FC ポートは同一の LUN をエクスポートしています。 マルチパス ソリューションがサポートされている構成については、ストレージのベンダーにお問い合せください。

付録 2: トポロジ 1 のセットアップと設定


MDS 9000 の設定コマンドの詳細については、『Cisco MDS 9000 Configuration Guide』を参照してください。

サーバのセットアップ

トポロジ 1 では、取り付けられている Intel 製 NIC の「アダプタ チーミング」機能を使用する必要があります。 両方の NIC を使用できる「Adaptive Load Balancing」モードでアダプタ チームを作成します。 また、Cisco iSCSI ドライバ バージョン 3.1.1 を使用して、CHAP による認証を使用します。 MDS 9000 スイッチの設定では、サーバからストレージ デバイスへのアクセスを行うために、CHAP を有効にする必要があります。

Catalyst 3500

Catalyst スイッチの基本設定を使用し、2 台のイーサネット スイッチ間ではリンクのトランキングを行います。

MDS 9XXX の設定

このトポロジでは、次の MDS 機能を使用します。

  • 2 つの MDS スイッチ間のポート チャネル
  • VRRP:Virtual Router Redundancy Protocol(仮想ルータ冗長プロトコル)
  • 「仮想ターゲット」の作成に関連した pWWN エイリアシング

このトポロジを構築するために MDS 9216 スイッチで実行した手順を次に示します。

MDS 9216-1(スイッチ 1)

1. 2 つの MDS スイッチ間でポートチャネルを作成します。 この設定の出力を次に示します。

vsan 1 interface port-channel 1

interface fc1/7

channel-group 1

no shutdown

interface fc1/8

channel-group 1

no shutdown

2. iSCSI の設定を行います。 この作業を完了するための手順を次に示します。

a. 最初に、IP ストレージ モジュールのギガビット イーサネット ポートの設定を行います。 VRRP も使用するので、VRRP の設定もインターフェイス レベルで行います。 この設定の出力を次に示します。

interface GigabitEthernet2/1

ip address 10.10.10.3 255.255.255.0

no shutdown

vrrp 1

priority 100

address 10.10.10.1

no shutdown

interface iscsi2/1

mode store-and-forward

no shutdown

b. iSCSI イニシエータから MDS への通信を可能にするために、他の iSCSI パラメータも設定する必要があります。 この環境で必要なパラメータは、fc ターゲットのインポート パラーメータ、適切な VSAN に iSCSI イニシエータの IP アドレスを追加するパラメータ、および認証のパラメータです。 出力を次に示します。

iscsi authentication none

iscsi import target fc

iscsi initiator name 10.10.10.230

vsan 1

c. pWWN エイリアシングを使用するために、スイッチで「仮想ターゲット」を作成する必要があります。 このトポロジでは VRRP 機能を使用するので、セカンダリの MDS スイッチでもこの「仮想ターゲット」を作成する必要があります。 PWWN エイリアシングを使用する場合の「仮想ターゲット」の出力を次に示します。

iscsi virtual-target name JBOD1

pWWN 22:00:00:04:cf:e6:e1:5f secondary-pwwn 21:00:00:04:cf:e6:e1:5f

initiator 10.10.10.230 permit

3. MDS スイッチのセットアップを完了するために、iSCSI イニシエータおよびファイバ チャネル ターゲットのゾーン セットおよびゾーンを作成する必要があります。 このゾーニング設定の出力を次に示します。

zone name Path1 vsan 1

  member pwwn 21:00:00:04:cf:e6:e1:5f

 member symbolic-nodename 10.10.10.230

member pwwn 22:00:00:04:cf:e6:e1:5f

zoneset name ZS1 vsan 1

member Path1

zoneset activate name ZS1 vsan 1

MDS 9216-2(スイッチ 2):

トポロジ 1 で必要な 2 番目の MDS 9216 スイッチの設定を次に示します。

1. 2 つの MDS スイッチ間でポートチャネルを作成します。 この設定の出力を次に示します。

vsan 1 interface port-channel 1

interface fc1/7

channel-group 1

no shutdown

interface fc1/8

channel-group 1

no shutdown

2. 次に iSCSI の設定を行います。 この作業を完了するための手順を次に示します。

a. 最初に、IP ストレージ モジュールのギガビット イーサネット ポートの設定を行います。 VRRP も使用するので、VRRP の設定もインターフェイス レベルで行います。 この設定の出力を次に示します。

interface GigabitEthernet2/5

ip address 10.10.10.2 255.255.255.0

vrrp 1

address 10.10.10.1

no shutdown

interface iscsi2/5

mode store-and-forward

no shutdown

b. iSCSI イニシエータから MDS 9216 スイッチへの通信を可能にするには、他の iSCSI パラメータも設定する必要があります。 このシナリオで必要なパラメータは、fc ターゲットのインポート パラーメータ、適切な VSAN に iSCSI イニシエータの IP アドレスを追加するパラメータ、および認証のパラメータです。 出力を次に示します。

iscsi authentication none

iscsi import target fc

iscsi initiator name 10.10.10.230

vsan 1

c. pWWN エイリアシングを使用するには、スイッチで「仮想ターゲット」を作成する必要があります。

iscsi virtual-target name JBOD1

pWWN 22:00:00:04:cf:e6:e1:5f secondary-pwwn 21:00:00:04:cf:e6:e1:5f

initiator 10.10.10.230 permit

3. ゾーンセットの有効化は、プライマリ MDS 9216 スイッチ(スイッチ 1)からファブリックを介して伝搬されるため、iSCSI イニシエータおよびファイバ チャネル ターゲットのゾーンセットおよびゾーンを作成する必要はありません。 こちらのスイッチでは、ゾーニングに関して何も設定する必要はありません。

Xyratex ストレージ

2 つのパスを介した同じストレージ(LUN)へのアクセスを検証する必要があります。

付録 3: トポロジ 2 のセットアップと設定


設定コマンドについては、『MDS Configuration Guide』を参照してください。

サーバのセットアップ

Veritas Volume Manager 3.1 for Windows をインストールします。 Dynamic Multipathing(DMP)機能が適切に設定され、動作していることを検証します。 DMP に関しては、『Veritas Volume Manager Documentation』を参照してください。 また、ストレージ アクセスの障害をより早く検出するために、レジストリの設定を変更する必要があります。 このエントリがまだ追加されていない場合、デフォルトのタイムアウトは 90 秒になります。 このデフォルト値を使用すると、ストレージ障害の検出が遅くなる場合があるため、アプリケーションの復旧に影響します。 このエントリを追加または編集するには、「regedt32」を起動して、次の手順を実行します。

  1. HKEY_LOCAL_MACHINE に移動します。
  2. SYSTEM に移動します。
  3. CurrentControlSet に移動します。
  4. Services に移動します。
  5. iscsi に移動します。
  6. Parameters に移動し、DisconnectTimeOutValue というエントリがあるかどうかを確認します。
  7. エントリが存在する場合は、必要な変更を行います。
  8. エントリがない場合は、この値を新規で追加します。
  9. [Edit] -> [Add Value] をクリックします。
  10. [Value Name] セクションに「DisconnectTimeOutValue」と入力します。
  11. [Data Type] を [REG_DWORD] に設定します。
  12. 値を入力します。 デフォルトでは [Hex] に設定されているため、値を 10 秒に設定する場合は 16 進数の「A」を入力します。 または、[Decimal] を選択して「10」と入力します。

Catalyst 3500

Catalyst スイッチの基本設定を使用します。 ただし、このトポロジでは、2 台のイーサネット スイッチ間でリンクのトランキングは行いません。

MDS 9216 の設定

2 つの MDS 9216 スイッチ間で MDS 9000 の PortChanneling 機能を使用することにより、異なるスイッチのメンバーでゾーンを作成することができます。 これにより、ホストからストレージへのパスを 4 つ作成できるため、ポート数を増やさなくてもアベイラビリティが向上します。

この環境の構築に必要な設定を次に示します。 PortChanneling の設定はトポロジ 1 と同じです。PortChanneling の設定については、「付録 2」を参照してください。

MDS 9216-1(スイッチ 1)

最初に iSCSI の設定を行います。 この作業を完了するための手順を次に示します。

最初に、IP ストレージ モジュールのギガビット イーサネット ポートの設定を行います。 この設定の出力を次に示します。

interface GigabitEthernet2/1

ip address 10.10.10.1 255.255.255.0

no shutdown

interface iscsi2/1

mode store-and-forward

no shutdown

iSCSI イニシエータから MDS 9216 スイッチへの通信を可能にするために、他の iSCSI パラメータも設定する必要があります。 この環境で必要なパラメータは、fc ターゲットのインポート パラーメータ、適切な VSAN に iSCSI イニシエータの IP アドレスを追加するパラメータ、および認証のパラメータです。 出力を次に示します。

iscsi authentication none

iscsi import target fc

iscsi initiator name 10.10.10.230

vsan 1

MDS スイッチのセットアップを完了するために、iSCSI イニシエータおよびファイバ チャネル ターゲットのゾーン セットおよびゾーンを作成する必要があります。 このゾーニング設定の出力を次に示します。

zone name Path1 vsan 1

member pwwn 21:00:00:04:cf:e6:e1:5f

member symbolic-nodename 10.10.10.230

zone name Path2 vsan 1

member symbolic-nodename 10.10.10.230

member pwwn 22:00:00:04:cf:e6:e1:5f

zone name Path3 vsan 1

member pwwn 21:00:00:04:cf:e6:e1:5f

member symbolic-nodename 10.10.11.230

zone name Path4 vsan 1

member pwwn 22:00:00:04:cf:e6:e1:5f

member symbolic-nodename 10.10.11.230

zoneset name ZS1 vsan 1

member Path1

member Path2

member Path3

member Path4

MDS 9216-2(スイッチ 2)

トポロジ 2 に関連するこの MDS スイッチの設定を次に示します。 このトポロジで使用する PortChanneling の設定はトポロジ 1 と同じです。PortChanneling の設定については、「付録 2」を参照してください。

次に iSCSI の設定を行います。 この作業を完了するための手順を次に示します。

最初に、IP ストレージ モジュールのギガビット イーサネット ポートの設定を行います。 この設定の出力を次に示します。

interface GigabitEthernet2/5

ip address 10.10.11.1 255.255.255.0

no shutdown

interface iscsi2/5

mode store-and-forward

no shutdown

iSCSI イニシエータから MDS 9216 スイッチへの通信を可能にするために、他の iSCSI パラメータも設定する必要があります。 この環境で必要なパラメータは、fc ターゲットのインポート パラーメータ、適切な VSAN に iSCSI イニシエータの IP アドレスを追加するパラメータ、および認証のパラメータです。 出力を次に示します。

iscsi authentication none

iscsi import target fc

iscsi initiator name 10.10.11.230

vsan 1

ゾーンセットの有効化は、プライマリ MDS 9216 スイッチ(スイッチ 1)からファブリックを介して伝搬されるため、iSCSI イニシエータおよびファイバ チャネル ターゲットのゾーンセットおよびゾーンを作成する必要はありません。 こちらのスイッチでは、ゾーニングに関して何も設定する必要はありません。

Xyratex ストレージ

2 つのパスを介した同じストレージ(LUN)へのアクセスを検証する必要があります。

付録 4: トポロジ 3 のセットアップと設定


設定コマンドについては、『MDS Configuration Guide』を参照してください。

サーバのセットアップ

サーバの設定は、トポロジ 2 と同じです。設定の詳細については、トポロジ 2 の「付録 3」を参照してください。

Catalyst 3500

Catalyst スイッチの基本設定を使用します。2 台のイーサネット スイッチ間でリンクのトランキングは行いません。

MDS 9216 の設定

このトポロジでは、ファブリックを論理的にも物理的にも分離します。 この環境の構築に必要な設定を次に示します。

MDS 9216-1(スイッチ 1)

1. トポロジ 3 での iSCSI の設定は、トポロジ 2 と同じです。設定の詳細を次に示します。

a. 最初に、IP ストレージ モジュールのギガビット イーサネット ポートの設定を行います。 この設定の出力を次に示します。

interface GigabitEthernet2/1

ip address 10.10.10.1 255.255.255.0

no shutdown

interface iscsi2/1

mode store-and-forward

no shutdown

b. iSCSI イニシエータから MDS 9216 スイッチへの通信を可能にするために、他の iSCSI パラメータも設定する必要があります。 この環境で必要なパラメータは、fc ターゲットのインポート パラーメータ、適切な VSAN に iSCSI イニシエータの IP アドレスを追加するパラメータ、および認証のパラメータです。 出力を次に示します。

iscsi authentication none

iscsi import target fc

iscsi initiator name 10.10.10.230

vsan 1

2. MDS スイッチのセットアップを完了するために、iSCSI イニシエータおよびファイバ チャネル ターゲットのゾーン セットおよびゾーンを作成する必要があります。 ゾーニング設定の出力を次に示します。

zone name Path1 vsan 1

member symbolic-nodename 10.10.10.230

member pwwn 22:00:00:04:cf:e6:e1:5f

zoneset name ZS1 vsan 1

member Path1

MDS 9216-2(スイッチ 2)

1. 最初に iSCSI の設定を行います。 この作業を完了するための手順を次に示します。

a. 最初に、IP ストレージ モジュールのギガビット イーサネット ポートの設定を行います。 この設定の出力を次に示します。

interface GigabitEthernet2/5

ip address 10.10.11.1 255.255.255.0

no shutdown

interface iscsi2/5

mode store-and-forward

no shutdown

b. iSCSI イニシエータから MDS 9216 スイッチへの通信を可能にするために、他の iSCSI パラメータも設定する必要があります。 この環境で必要なパラメータは、fc ターゲットのインポート パラーメータ、適切な VSAN に iSCSI イニシエータの IP アドレスを追加するパラメータ、および認証のパラメータです。 出力を次に示します。

iscsi authentication none

iscsi import target fc

iscsi initiator name 10.10.11.230

vsan 1

2. このスイッチは独立したファブリックになっているため、iSCSI イニシエータから 2 つ目のパスへのアクセスを可能にするために、ゾーニング情報を作成する必要があります。 この環境でのこのスイッチの設定を次に示します。

zone name Path2 vsan 1

member symbolic-nodename 10.10.11.230

member pwwn 21:00:00:04:cf:e6:e1:5f

zoneset name ZS1 vsan 1

member Path2

Xyratex ストレージ

2 つのパスを介した同じストレージ(LUN)へのアクセスを検証する必要があります。


お問い合わせ