
Upgrading Cisco ONS 15454 SDH R4.x to R4.1.x 
Using the TCC2 Card

This document explains how to upgrade the Cisco ONS 15454 SDH Cisco Transport Controller (CTC) 
software from Software Release 4.x to Software R4.1.x using the TCC2 card.
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Before You Begin
Before beginning, write down the following information about your site: date, street address, site phone 
number, and dial-up number. The data will be useful during and after the upgrade.

Caution Read each procedure before you begin the upgrade.
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Before You Begin
Caution This document supports Software R4.x only. If you want to upgrade from Software R3.3.x or R3.4.x, 
you must first upgrade to Release 4.0 and perform the TCCI to TCC2 card upgrade. See the Cisco ONS 
15454 SDH Software Upgrade Guide, Release 4.0, to perform this upgrade.

Caution The XCVXL card on the ONS 15454 SDH allows the intermixing of VC12 and VC3 payloads within a 
single VC4. When a VC4 contains only one VC12 tributary and at least one VC3 tributary and the VC12 
is deleted, the database becomes corrupt.

The database load process on the ONS 15454 SDH occurs during a TCC2 reboot, TCC2 protection 
switch, software activation, or database restore. When the database is loaded containing this corruption 
the load process fails, causing the corrupt database to be deleted from the TCC2 flash memory. The 
previous saved database is then loaded instead. When all saved databases on a TCC2 contain the 
corruption, the TCC2 will load with the default provisioning, and all existing provisioning will be lost.

If this issue occurs you will see a loss of either some or all provisioning after a TCC2 switch or reset. To 
ensure that your network is not vulnerable to this issue, you must first determine if the issue already 
exists within your network, and if so, correct it. You can detect the issue by using the SDH Circuit Repair 
Utility (VcCheck) provided on the ONS 15454 SDH Release 4.1.3 and 4.6 software CDs. The VcCheck 
tool is also available for download from CCO. Once you have alleviated immediate risk from the issue, 
you must upgrade to Release 4.6, or maintenance Release 4.1.3 (or any later release) to avoid further risk. 
The VcCheck utility and its associated README file (in the same directory with the tool) provide 
details on how to temporarily alleviate this issue before upgrading to a release in which the issue is 
resolved.

Note Perform the procedures in this document in consecutive order unless otherwise noted. In general, you 
are not done with a procedure until you have completed it for each node that you are upgrading, and you 
are not done with the upgrade until you have completed each procedure that applies to your network. If 
you are new to upgrading the ONS 15454 SDH, you might want to check off each procedure on your 
printed copy of this document as you complete it. 

To upgrade Software R4.x to R4.1.x, you must complete the following tasks. Note that although some 
of these tasks do not appear in this document, they must still be completed in the order shown. Each 
section begins with an overview procedure, followed by a detailed procedure for each step.

1. NTP-U48 Prepare for Release 4.x to Release 4.1.x Upgrade, page 3—Review this critical 
information and complete these critical procedures before beginning the upgrade process.

2. NTP-U63 Back Up the Software R4.x Database, page 5—Complete the database backup to ensure 
that you have preserved your node and network provisioning in the event that you need to restore 
them.

3. NTP-U64 Upgrade Software R4.x to Software R4.1.x, page 7—Complete this procedure to upgrade 
the software. You must complete the entire procedure before the upgrade is finished.

4. NTP-U65 Install Public-Key Security Certificate, page 14—Complete this procedure only if the 
Java Plug-in Security Warning dialog box appears while logging into CTC (Software R4.1.x).

5. NTP-U66 Revert to Previous Software Load and Database, page 15—As needed, complete this 
procedure to return to the software load you were running before activating the R4.1.x software.
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NTP-U48 Prepare for Release 4.x to Release 4.1.x Upgrade
6. After performing the procedures in this document, upgrade any XC10G cards with XC-VXL cards, 
as necessary. For detailed instructions, refer to the Cisco ONS 15454 SDH Procedure Guide.

NTP-U48 Prepare for Release 4.x to Release 4.1.x Upgrade

Step 1 Read the Release Notes for Cisco ONS 15454 SDH Release 4.1.x.

Step 2 Log into the node that you will upgrade. For detailed instructions, refer to the Cisco ONS 15454 SDH 
Procedure Guide.

Step 3 Complete the “DLP-U106 Verify CTC PC or UNIX Workstation Requirements” task on page 3.

Step 4 Disable all other Ethernet devices (such as a dial-up adapter) on a PC or workstation that runs CTC. For 
more information, refer to the Cisco Technical Assistance Center (TAC) web site at 
http://www.cisco.com/tac. 

If you have multiple IP addresses on your PC or workstation, you should remove them; you cannot install 
Software R4.1.x if multiple IP addresses are configured. 

Step 5 Complete the “DLP-U72 Verify the LAN Connections” task on page 4.

Step 6 Complete the “DLP-U73 Verify Common Control Cards” task on page 5.

Step 7 When you have completed the procedures for this section, proceed with the “NTP-U63 Back Up the 
Software R4.x Database” procedure on page 5.

Stop. You have completed this procedure.

DLP-U106 Verify CTC PC or UNIX Workstation Requirements

Purpose This procedure steps you through the critical information checks and 
procedures you must complete before beginning an upgrade.

Tools/Equipment ONS 15454 SDH nodes to upgrade; PC or UNIX workstation; 
Cisco ONS 15454 SDH R4.1.x software

Prerequisite Procedures None

Required/As Needed Required

Onsite/Remote Onsite or remote

Security Level Superuser

Purpose This task verifies all PC or UNIX workstation hardware and software 
requirements. Use this task before upgrading the workstation to run CTC 
Software R4.1.x.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures None

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-U72 Verify the LAN Connections
Step 1 Ensure that your workstation is one of the following:

• IBM-compatible PC with a Pentium or higher processor, CD-ROM drive, and 128 MB RAM running 
Windows 95, Windows 98, Windows 2000, Windows NT (with service pack 4 or higher), or 
Windows XP

• UNIX workstation running Solaris 2.5.x or 2.6.x

Check your web browser software version and use one of the following:

• Netscape Navigator 4.73 or higher (Netscape Navigator is included on the ONS 15454 SDH 
software CD shipped with the node)

• Netscape Communicator 4.61 or higher

• Internet Explorer 4.0.x Service Pack 2 or higher 

Step 2 Verify the following: 

• The Java Version installed on your computer is Java Runtime Environment (JRE) Release 1.3.1_02. 

Tip You can check this on your browser window after entering the node IP address in the URL 
window under Java Version.

• The Java Policy file is installed on your computer.

Note If you need to install either the JRE 1.3.1_02 or the Java Policy file, they are included on the 
ONS 15454 SDH software CD. For detailed installation instructions, refer to the 
Cisco ONS 15454 SDH Procedure Guide.

Note If you must later revert to a release that can use a previous version of JRE, you need to reinstall 
Java and delete the JAR files from your PC or workstation’s system temp directory after 
reverting all of the nodes in the network. You can find the appropriate JRE version on the older 
Cisco software CD. If you are currently running a release that is also compatible with JRE 
1.3.1_02, the extra steps are not necessary. 

Step 3 Return to your originating procedure (NTP).

DLP-U72 Verify the LAN Connections

Purpose This task ensures that LAN connections are correct.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U106 Verify CTC PC or UNIX Workstation Requirements, page 3

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of a PC or UNIX workstation)

Security Level Superuser
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DLP-U73 Verify Common Control Cards
Step 1 If you have multiple ONS 15454 SDH nodes configured in the same IP subnet, ensure that only one is 
connected to a router. Otherwise, the remaining nodes might be unreachable. Refer to the 
Cisco ONS 15454 SDH Reference Manual for LAN-connection suggestions.

Step 2 Return to your originating procedure (NTP).

DLP-U73 Verify Common Control Cards

Step 1 In CTC node (default) view, ensure that TCC2 cards are installed in Slots 7 and 11 and that the XC10G, 
XC-VXL-10G, or XC-VXL-2.5G cross-connect cards are installed in Slots 8 and 10. Software R4.x does 
not support simplex operation.

Step 2 Repeat Step 1 at every node in the network.

Step 3 Return to your originating procedure (NTP).

NTP-U63 Back Up the Software R4.x Database

Step 1 Log into CTC. For detailed instructions, refer to the Cisco ONS 15454 SDH Procedure Guide. If you are 
already logged in, continue with Step 2.

Step 2 In the node (default) view, click the Maintenance > Database tabs.

Step 3 Click Backup.

Purpose This task checks for duplex common control cards. The node must have 
two TCC2 cards and two XC10G, XC-VXL-10G, or XC-VXL-2.5G cards.

Tools/Equipment PC or UNIX workstation with CTC installed

Prerequisite Procedures DLP-U106 Verify CTC PC or UNIX Workstation Requirements, page 3
DLP-U72 Verify the LAN Connections, page 4

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of a PC or UNIX workstation)

Security Level Superuser

Purpose This procedure preserves all configuration data for your network before 
performing the upgrade.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U48 Prepare for Release 4.x to Release 4.1.x Upgrade, page 3

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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NTP-U63 Back Up the Software R4.x Database
Step 4 Save the database on the workstation's hard drive or on network storage. Use an appropriate file name 
with the file extension .db. (Cisco recommends that you use the IP address of the node and the date, for 
example 1010120192061103.db.)

Step 5 Click Save. A message appears indicating that the backup is complete.

Step 6 Click OK.

Step 7 Repeat Steps 1 through 6 for each node in the network.

Step 8 (Optional) Cisco recommends that you manually log critical information by either writing it down or 
printing screens where applicable. Use Table 1 to determine the information you should log; complete 
the table (or your own version) for every node in the network.

Stop. You have completed this procedure.

Table 1 Manually Recorded Data

Item Record Data Here (If Applicable)

IP address of the node.

Node name.

Timing settings.

DCC1 connections; list all optical ports that have DCCs activated.

1. DCC = data communications channel

User IDs; list all, including at least one Superuser.

Inventory; do a print screen from the Inventory window.

Active TCC2. Slot 7 or Slot 11 (circle one)

Active XC10G, XC-VXL-10G, or XC-VXL-2.5G Slot 8 or Slot 10 (circle one)

Network information; do a print screen from the Provisioning tab in 
the network view.

Current configuration (MS-SPRing2, linear, etc.); do print screens 
as needed.

2. MS-SPRing = multiplex section-shared protection ring

List all Protection groups in the system; do a print screen from the 
protection group window.

List alarms; do a print screen from the Alarm window.

List circuits; do a print screen from the Circuit window.
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NTP-U64 Upgrade Software R4.x to Software R4.1.x
NTP-U64 Upgrade Software R4.x to Software R4.1.x

Step 1 Insert the Release 4.1.x software CD into the workstation CD-ROM (or otherwise acquire access to the 
software) to begin the upgrade process.

Note Inserting the software CD activates the CTC Setup Wizard. You can use the setup wizard to 
install components or click Cancel to continue with the upgrade.

Caution Do not perform maintenance or provisioning activities during the activation task.

Step 2 Complete the “DLP-U109 Download Release 4.1.x Software” task on page 8 for all nodes (or groups of 
eight or less nodes) you are upgrading.

Step 3 Complete the “DLP-U110 Perform an MS-SPRing Lockout” task on page 9 (MS-SPRing nodes only).

Step 4 Complete the “DLP-U111 Activate the New Load” task on page 10.

Note Step 5 is only necessary after upgrading the first node in a network because cached files only 
need to be removed from your workstation once. For the remaining nodes, you will still be 
disconnected and removed to the network view during the node reboot, but after the reboot is 
complete, CTC restores connectivity to the node.

Step 5 As needed, complete the “DLP-U148 Delete Cached JAR Files” task on page 11.

Step 6 Repeat Step 4 (activation) for all nodes in the network that need to be upgraded. Allow each node to 
finish (all alarms cleared for 10 minutes) before activating the next node.

Step 7 Complete the “DLP-U113 Remove the MS-SPRing Lockout” task on page 12 for all MS-SPRing nodes 
in the network.

Note Leave the MS-SPRing in the lockout state until you have finished upgrading all nodes.

Step 8 Complete the “DLP-U79 Set the Date and Time” task on page 13 (any nodes not using Simple Network 
Time Protocol [SNTP]).

Step 9 As needed, upgrade any spare TCC2 cards by installing the spare in the standby slot of a Release 4.1.x 
node.

Purpose This procedure upgrades your CTC software to Software R4.1.x.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U63 Back Up the Software R4.x Database, page 5

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-U109 Download Release 4.1.x Software
Note The standby TCC2 card will copy one or both software releases from the active TCC2 card, as 
needed. Each software copy takes about 5 minutes, and the TCC2 card will reset after each copy. 
Thus, for a TCC2 card that has no matching software with the active TCC2 card, you should 
expect to see two TCC2 card resets and software copying lasting about 10 minutes total.

Step 10 If you need to return to the software and database you had before activating Software R4.1.x, proceed 
with the “NTP-U66 Revert to Previous Software Load and Database” procedure on page 15.

Stop. You have completed this procedure.

DLP-U109 Download Release 4.1.x Software

Note The TCC2 card has two flash RAMs. An upgrade downloads the software to the backup RAM on both 
the backup and active TCC2 cards. The download task does not affect traffic because the active software 
continues to run at the primary RAM location; therefore, you can download the software at any time.

Step 1 From the View menu, choose Go to Network View.

Step 2 Verify that the alarm filter is not on:

a. Click the Alarms tab.

b. Click the Filter tool at the lower-right side of the bottom toolbar. Alarm filtering is enabled if the 
tool is depressed (selected) and disabled if the tool is raised (not selected). 

Step 3 On the Alarms tab, check all nodes for existing alarms. Resolve any outstanding alarms before 
proceeding.

Note During the software download process, the SWFTDWN alarm indicates that the software 
download is taking place. The alarm is normal and clears when the download is complete.

Step 4 Return to node view and click the Maintenance > Software tabs.

Step 5 Click Download. The Download Selection dialog box appears.

Step 6 Browse to locate the software files on the ONS 15454 SDH software CD or on your hard drive, if you 
are working from a local copy.

Step 7 Open the Cisco15454SDH folder. 

Step 8 Select the file with the .pkg extension and click Open. 

Purpose This task downloads Software R4.1.x to the ONS 15454 SDH nodes prior 
to activation.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U63 Back Up the Software R4.x Database, page 5

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser or Maintenance
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DLP-U110 Perform an MS-SPRing Lockout
Step 9 In the list of compatible nodes, select the check boxes for all nodes you are downloading the software to. 

Note Cisco advises that you limit concurrent software downloads on an SDCC to eight nodes at once, 
using the central node to complete the download.

Step 10 Click OK. The Download Status column monitors the progress of the download. 

Note The software download process can take typically less than10 minutes per node.

Step 11 Return to your originating procedure (NTP).

DLP-U110 Perform an MS-SPRing Lockout

Note During the lockout, MS-SPRing spans are not protected. You must leave the MS-SPRing in the lockout 
state until you have finished activating (or reverting) all nodes in the ring, but then you must be sure to 
remove the lockout after you are finished.

Note To prevent ring or span switching, perform the lockout on both the east and west spans of each node.

Step 1 In node view, click the Maintenance > MS-SPRing tabs.

Step 2 For each of the MS-SPRing trunk (span) cards (STM-4, STM-16, or STM-64), perform the following 
steps:

a. Next to the trunk card row, click the East Switch column to show the pull-down menu.

b. From the menu options, choose Lockout Span.

c. Click Apply.

d. In the same row, click the West Switch column to show the pull-down menu.

e. From the menu options, choose Lockout Span.

f. Click Apply. 

Note Ignore any Default K alarms that occur on the protect VC4 timeslots during this lockout period.

Purpose This task performs an MS-SPRing lockout. If you have an MS-SPRing 
provisioned, you must use this task before beginning an upgrade or revert.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U63 Back Up the Software R4.x Database, page 5

Required/As Needed Required for MS-SPRing only

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-U111 Activate the New Load
Step 3 Return to your originating procedure (NTP).

DLP-U111 Activate the New Load

Note Cisco recommends that the first node you activate be a LAN-connected node. This ensures that the new 
CTC JAR files download to your workstation as quickly as possible.

Note Ensure that all cards that are part of a protection group (1+1, 1:1, or 1:N) are active on the working card 
of that protection group and that no protection switches are occurring. In other words, ensure that the 
protect cards are in standby before proceeding. Move your mouse cursor over a card in node view to see 
its active or standby status.

Step 1 Record the IP address of the node. The IP address can be obtained either on the LCD or on the upper left 
corner of the CTC window.

Step 2 Verify that the alarm filter is not on:

a. Click the Alarms tab.

b. Click the Filter tool at the lower-right side of the bottom toolbar.

Alarm filtering is enabled if the tool is depressed (selected) and disabled if the tool is raised (not 
selected). 

Step 3 On the Alarms tab, check all nodes for existing alarms. Resolve any outstanding alarms before 
proceeding.

Step 4 Click the Maintenance > Software tabs.

Step 5 Verify that the protect version is 4.1.x.

Step 6 Click Activate. The Activate dialog box appears with a warning message.

Step 7 Click Yes to proceed with the activation. The “Activation Successful” message appears when the 
software is successfully activated. Click OK in the message box.

Note When you click Yes, CTC loses connection to the node and displays the network view.

Purpose This task activates Software R4.1.x in each node in the network.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U109 Download Release 4.1.x Software, page 8

DLP-U110 Perform an MS-SPRing Lockout, page 9 (if required)

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-U148 Delete Cached JAR Files
Step 8 After activating the node, wait until the software upgrade reboot finishes at that node before continuing. 
The following occurs:

• Each card in the node reboots, beginning with the standby TCC2 card.  When the standby TCC2 
comes back up, it signals to the active TCC2 that it is ready to take over. When the active TCC2 
receives this signal, it resets itself, and the standby TCC2 takes over and transitions to active. The 
originally active TCC2 then comes back up as the standby TCC2.

• While the second TCC2 is rebooting, the cross-connect card in Slot 8 reboots, and then the 
cross-connect card in Slot 10 reboots. 

• Next, the Ethernet cards reset simultaneously; then the traffic cards boot consecutively from left to 
right. 

• A system reboot (SYSBOOT) alarm is raised while activation is in progress. When all cards have 
reset, this alarm clears. The activation process can take up to 30 minutes, depending on how many 
cards are installed. 

When all the cards finish rebooting and all alarms clear, you can safely proceed to the next step. If you 
are upgrading remotely and cannot see the nodes, wait for 30 minutes for the process to complete, then 
check to ensure that all alarms have cleared before proceeding.

Step 9 Return to your originating procedure (NTP).

DLP-U148 Delete Cached JAR Files

Step 1 In your browser window, click Delete CTC Cache.

Note You must ensure that CTC is closed before clicking the Delete CTC Cache button. CTC behavior 
is unreliable if the button is clicked while the software is still running.

Step 2 Reconnect to CTC using the IP address you recorded in the “DLP-U111 Activate the New Load” task on 
page 10. The new CTC applet for Software R4.1.x uploads. During this login, type the user name 
CISCO15. A password is not required. If you cannot connect to CTC, perform Steps 3 through 6 and try 
again. Once you have connected to CTC, go to Step 7. 

Step 3 Manually delete cache files from your browser directory.

Purpose This task deletes cached Jar files. When you upgrade or revert to a 
different CTC software load, you must reload CTC to your browser. 
Before you can reload CTC, you must ensure that previously cached files 
are cleared from your browser and hard drive.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U111 Activate the New Load, page 10

Required/As Needed You need to complete this task only after you activate the first node in the 
network.

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-U113 Remove the MS-SPRing Lockout
In Netscape:

a. Choose Edit > Preferences > Advanced > Cache.

b. Click Clear Memory Cache.

c. Click OK.

d. Click Clear Disk Cache.

e. Click OK twice.

In Microsoft Internet Explorer:

a. Choose Tools > Internet Options > General.

b. Choose Delete Files.

c. Select the Delete all offline content check box.

d. Click OK twice.

Step 4 Close your browser.

Note You will not be able to delete cached JAR files from your hard drive until you have closed your 
browser. If you have other applications open that use JAR files, you must also close them.

Step 5 Delete cached files from your workstation (Windows systems only).

a. In your Windows start menu, choose Settings > Control Panel > System > Advanced.

b. Click Environment Variables. This will show you a list of user variables and a list of system 
variables.

c. In the list of user variables, look for the TEMP variable. The value associated with this variable is 
the path to your temporary directory where JAR files are stored.

d. Open the TEMP directory located in the discovered path.

e. Select View > Details.

f. Select and delete all files with “jar” in the Name or Type field.

Step 6 Reopen your browser. You should now be able to connect to CTC.

Step 7 Return to your originating procedure (NTP).

DLP-U113 Remove the MS-SPRing Lockout

Purpose This task releases the span lockouts on all MS-SPRing nodes after the 
software is activated (or reverted) on all nodes.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures None

Required/As Needed Required for MS-SPRing

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-U79 Set the Date and Time
Step 1 In CTC node view, click the Maintenance > MS-SPRing tabs.

Step 2 For each of the MS-SPRing trunk (span) cards (STM-4, STM-16, or STM-64), perform the following 
steps: 

a. Next to the trunk card row, click the West Switch column to show the pull-down menu.

b. From the menu options, choose Clear.

c. Click Apply to activate the command. 

Note When removing a lockout, be sure to apply your changes each time you choose the Clear option. 
If you try to select Clear for more than one lockout at a time, you risk traffic loss on the first ring 
switch.

d. In the same row, click the East Switch column to show the pull-down menu.

e. From the menu options, choose Clear.

f. Click Apply to activate the command. 

Step 3 Repeat this task as many times as necessary to remove all MS-SPRing span lockouts on the nodes.

Step 4 Return to your originating procedure (NTP).

DLP-U79 Set the Date and Time

Note If you are using SNTP, you do not need this task.

Step 1 In CTC node view, click the Provisioning > General tabs.

Step 2 Set the correct date and time, then click Apply. 

Step 3 Repeat Steps 1 and 2 for each remaining node.

Step 4 Return to your originating procedure (NTP).

Purpose This task sets the date and time. If you are not using SNTP, the upgrade 
procedure can cause the Date/Time setting to change. Perform this task to 
reset the date and time at each node.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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NTP-U65 Install Public-Key Security Certificate
NTP-U65 Install Public-Key Security Certificate

Step 1 Log into CTC.

Step 2 If the Java Plug-in Security Warning dialog box appears, choose one of the following options:

• Grant This Session—Installs the public-key certificate to your PC only for the current session. After 
the session is ended, the certificate is deleted. This dialog box will appear the next time you log into 
the ONS 15454 SDH.

• Deny—Denies permission to install the certificate. If you choose this option, you cannot log into the 
ONS 15454 SDH. 

• Grant always—Installs the public-key certificate and does not delete it after the session is over. 
Cisco recommends this option.

• View Certificate—Allows you to view the public-key security certificate.

Step 3 If the Login dialog box appears, you have completed this procedure. If the Change Java Policy File 
dialog box appears, complete this step. The Change Java Policy File dialog box appears if CTC finds a 
modified Java policy file .java.policy on your computer. In Software R4.0 and earlier, the Java policy file 
was modified to allow CTC software files to be downloaded to your computer. Choose one of the 
following options:

• Yes—Removes CTC-related entries from the modified Java policy file from your computer. Choose 
this option only if you will log into ONS 15454 SDH nodes running Software R4.1 or later.

• No—Does not remove CTC-related entries from the modified Java policy file from your computer. 
Choose this option if you will log into ONS 15454 SDH nodes running Software R4.0 or earlier. If 
you choose No, this dialog box will appear every time you log into the node. If you do not want it 
to appear, check the Do not show the message again check box.

Caution If you delete CTC-related files from the Java policy file, you cannot log into nodes running 
Software R4.0 and earlier. If you want to log into an ONS 15454 SDH node running an earlier release, 
insert the software CD for the release into your PC CD-ROM and run the CTC setup wizard to reinstall 
the Java policy file. In the CTC setup wizard, choose the custom installation option.

After you complete the security certificate dialog boxes, the web browser displays information about 
your Java and system environments. If this is the first login, CTC downloading message appears while 
CTC files are downloaded to your computer. The first time you connect to an ONS 15454 SDH node, 
this process can take several minutes. After the download, the CTC Login dialog box appears.

Step 4 If you need to return to the software and database you had before activating Software R4.1.x, proceed 
with the “NTP-U66 Revert to Previous Software Load and Database” procedure on page 15.

Purpose This procedure installs the ITU Recommendation X.509 public-key 
security certificate. The public-key certificate is required to run Software 
R4.1 or later.

Tools/Equipment None

Prerequisite Procedures This procedure is performed when logging into CTC. You cannot perform 
it at any other time.

Required/As Needed This procedure is required to run ONS 15454 SDH Software R4.1 or later.

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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NTP-U66 Revert to Previous Software Load and Database
Stop. You have completed this procedure.

NTP-U66 Revert to Previous Software Load and Database

Note The tasks to revert to a previous load are not a part of the upgrade. They are provided here as a 
convenience to those wishing to perform a revert after an upgrade. If you have performed all necessary 
procedures up to this point, you have finished the software upgrade.

Note Before you upgraded to Software R4.1.x, you should have backed up the existing database at all nodes 
in the network (this is part of the “NTP-U63 Back Up the Software R4.x Database” procedure on page 5). 
Cisco recommends that you record or export all critical information to your hard drive. If you need to 
revert to the backup database, use the following tasks, in order. 

Step 1 Log into the node. For detailed instructions, refer to the Cisco ONS 15454 SDH Procedure Guide. If you 
are already logged in, continue with Step 2.

Step 2 Complete the “DLP-U110 Perform an MS-SPRing Lockout” task on page 9 (MS-SPRing only).

Step 3 Complete the “DLP-U114 Revert to Protect Load” task on page 16.

Step 4 Complete the “DLP-U113 Remove the MS-SPRing Lockout” task on page 12 (MS-SPRing only).

Step 5 If the software revert to your previous release failed, complete the “DLP-U115 Manually Restore the 
Database” task on page 17.

Stop. You have completed this procedure.

Purpose This procedure returns you to the software and database provisioning you 
had before you activated Software R4.1.x.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U48 Prepare for Release 4.x to Release 4.1.x Upgrade, page 3
NTP-U63 Back Up the Software R4.x Database, page 5
NTP-U64 Upgrade Software R4.x to Software R4.1.x, page 7

Required/As Needed As needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-U114 Revert to Protect Load
DLP-U114 Revert to Protect Load

Note To perform a supported (non-service-affecting) revert from Software R4.1.x, the release you want to 
revert to must have been working at the time you activated to Software R4.1.x on that node. Also, a 
supported revert automatically restores the node configuration at the time of the previous activation. 
Thus, any configuration changes made after activation will be lost when you revert the software.

Step 1 From the node view, click the Maintenance > Software tabs.

Step 2 Verify that the protect software displays the release you upgraded from.

Step 3 Click Revert. Revert activates the protect software and restores the database from the previous load. A 
dialog box asks you to confirm the choice.

Step 4 Click OK. This begins the revert and drops the connection to the node. 

Step 5 Wait until the software revert finishes before continuing.

Note The system reboot might take up to 30 minutes to complete.

Step 6 Close your Netscape or Internet Explorer browser.

Step 7 Wait one minute before restoring another node.

Note After you upgrade to JRE 1.4.2, you cannot log into an ONS 15454, ONS 15454 SDH, or 
ONS 15327 node until you reconfigure the Java Plug-in to use JRE 1.3.1. If you are reverting to 
a release that uses JRE 1.3.1_02 and you retained JRE 1.3.1_02 during the upgrade, you do not 
need to do anything.

Step 8 After reverting all of the nodes in the network, restart the browser and log back into the last node that 
was reverted. This uploads the appropriate CTC applet to your workstation.

Note It might also be necessary to delete cached files from your browser’s directory or from the TEMP 
directory on your MS Windows workstation. If you have trouble reconnecting to CTC, see the 
“DLP-U148 Delete Cached JAR Files” task on page 11.

Step 9 Return to your originating procedure (NTP).

Purpose This task reverts to the software you were running prior to the last 
activation and to restore your database to the provisioning you had prior to 
the activation.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures None

Required/As Needed Required for revert

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-U115 Manually Restore the Database
DLP-U115 Manually Restore the Database

Caution Do not perform these steps unless the software revert failed.

Caution This process is service affecting and should be performed during a maintenance window.

Step 1 In the CTC node view, click the Maintenance > Database tabs.

Step 2 Click Restore. The Open dialog box appears.

Step 3 Select the previously saved file and choose Open.

The database is restored and the TCC2 cards reboot.

Step 4 When the TCC2 cards have rebooted, log back into CTC and verify that the database is restored.

Wait one minute before restoring the next node.

Step 5 Repeat Steps 1 to 4 for each node in the network.

You have now completed the manual database backup.

Step 6 Return to your originating procedure (NTP).

Related Documentation

Release-Specific Documents
• Release Notes for the Cisco ONS 15454 SDH, Release 4.1.x

• Release Notes for the Cisco ONS 15327, Release 4.1.x

• Release Notes for the Cisco ONS 15454, Release 4.1.x

Platform-Specific Documents
• Cisco ONS 15454 SDH Procedure Guide, Release 4.1 and 4.5

• Cisco ONS 15454 SDH Reference Guide, Release 4.1 and 4.5

Purpose This task manually restores the database. Use this task if you were unable 
to perform a revert successfully and need to restore the database.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U114 Revert to Protect Load, page 16
DLP-U113 Remove the MS-SPRing Lockout, page 12 (if required)

Required/As Needed As needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-Obtaining Documentation
• Cisco ONS 15454 SDH Troubleshooting Guide, Release 4.1 and 4.5

Obtaining Documentation
Cisco documentation and additional literature are available on Cisco.com. Cisco also provides several 
ways to obtain technical assistance and other technical resources. These sections explain how to obtain 
technical information from Cisco Systems.

Cisco.com
You can access the most current Cisco documentation on the World Wide Web at this URL:

http://www.cisco.com/univercd/home/home.htm

You can access the Cisco website at this URL:

http://www.cisco.com

International Cisco websites can be accessed from this URL:

http://www.cisco.com/public/countries_languages.shtml

Ordering Documentation
You can find instructions for ordering documentation at this URL:

http://www.cisco.com/univercd/cc/td/doc/es_inpck/pdi.htm

You can order Cisco documentation in these ways:

• Registered Cisco.com users (Cisco direct customers) can order Cisco product documentation from 
the Ordering tool:

http://www.cisco.com/en/US/partner/ordering/index.shtml

• Nonregistered Cisco.com users can order documentation through a local account representative by 
calling Cisco Systems Corporate Headquarters (California, USA) at 408 526-7208 or, elsewhere in 
North America, by calling 800 553-NETS (6387).

Cisco Optical Networking Product Documentation CD-ROM
Optical networking-related documentation, including Cisco ONS 15454 SDH product documentation, is 
available in a CD-ROM package that ships with your product. The Optical Networking Product 
Documentation CD-ROM is updated periodically and may be more current than printed documentation. 

Documentation Feedback
You can submit e-mail comments about technical documentation to bug-doc@cisco.com.
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DLP-Obtaining Technical Assistance
You can submit comments by using the response card (if present) behind the front cover of your 
document or by writing to the following address:

Cisco Systems
Attn: Customer Document Ordering
170 West Tasman Drive
San Jose, CA 95134-9883

We appreciate your comments.

Obtaining Technical Assistance
For all customers, partners, resellers, and distributors who hold valid Cisco service contracts, the Cisco 
Technical Assistance Center (TAC) provides 24-hour-a-day, award-winning technical support services, 
online and over the phone. Cisco.com features the Cisco TAC website as an online starting point for 
technical assistance. If you do not hold a valid Cisco service contract, please contact your reseller.

Cisco TAC Website
The Cisco TAC website provides online documents and tools for troubleshooting and resolving technical 
issues with Cisco products and technologies. The Cisco TAC website is available 24 hours a day, 365 
days a year. The Cisco TAC website is located at this URL:

http://www.cisco.com/tac

Accessing all the tools on the Cisco TAC website requires a Cisco.com user ID and password. If you 
have a valid service contract but do not have a login ID or password, register at this URL: 

http://tools.cisco.com/RPF/register/register.do

Opening a TAC Case
Using the online TAC Case Open Tool is the fastest way to open P3 and P4 cases. (P3 and P4 cases are 
those in which your network is minimally impaired or for which you require product information.) After 
you describe your situation, the TAC Case Open Tool automatically recommends resources for an 
immediate solution. If your issue is not resolved using the recommended resources, your case will be 
assigned to a Cisco TAC engineer. The online TAC Case Open Tool is located at this URL:

http://www.cisco.com/tac/caseopen

For P1 or P2 cases (P1 and P2 cases are those in which your production network is down or severely 
degraded) or if you do not have Internet access, contact Cisco TAC by telephone. Cisco TAC engineers 
are assigned immediately to P1 and P2 cases to help keep your business operations running smoothly.

To open a case by telephone, use one of the following numbers:

Asia-Pacific: +61 2 8446 7411 (Australia: 1 800 805 227) 
EMEA: +32 2 704 55 55 
USA: 1 800 553-2447

For a complete listing of Cisco TAC contacts, go to this URL:

http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml
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DLP-TAC Case Priority Definitions
TAC Case Priority Definitions
To ensure that all cases are reported in a standard format, Cisco has established case priority definitions.

Priority 1 (P1)—Your network is “down” or there is a critical impact to your business operations. You 
and Cisco will commit all necessary resources around the clock to resolve the situation. 

Priority 2 (P2)—Operation of an existing network is severely degraded, or significant aspects of your 
business operation are negatively affected by inadequate performance of Cisco products. You and Cisco 
will commit full-time resources during normal business hours to resolve the situation.

Priority 3 (P3)—Operational performance of your network is impaired, but most business operations 
remain functional. You and Cisco will commit resources during normal business hours to restore service 
to satisfactory levels.

Priority 4 (P4)—You require information or assistance with Cisco product capabilities, installation, or 
configuration. There is little or no effect on your business operations.

Obtaining Additional Publications and Information
Information about Cisco products, technologies, and network solutions is available from various online 
and printed sources.

• Cisco Marketplace provides a variety of Cisco books, reference guides, and logo merchandise. Go 
to this URL to visit the company store:

http://www.cisco.com/go/marketplace/

• The Cisco Product Catalog describes the networking products offered by Cisco Systems, as well as 
ordering and customer support services. Access the Cisco Product Catalog at this URL:

http://cisco.com/univercd/cc/td/doc/pcat/

• Cisco Press publishes a wide range of general networking, training and certification titles. Both new 
and experienced users will benefit from these publications. For current Cisco Press titles and other 
information, go to Cisco Press online at this URL:

http://www.ciscopress.com

• Packet magazine is the Cisco quarterly publication that provides the latest networking trends, 
technology breakthroughs, and Cisco products and solutions to help industry professionals get the 
most from their networking investment. Included are networking deployment and troubleshooting 
tips, configuration examples, customer case studies, tutorials and training, certification information, 
and links to numerous in-depth online resources. You can access Packet magazine at this URL:

http://www.cisco.com/packet

• iQ Magazine is the Cisco bimonthly publication that delivers the latest information about Internet 
business strategies for executives. You can access iQ Magazine at this URL:

http://www.cisco.com/go/iqmagazine

• Internet Protocol Journal is a quarterly journal published by Cisco Systems for engineering 
professionals involved in designing, developing, and operating public and private internets and 
intranets. You can access the Internet Protocol Journal at this URL:

http://www.cisco.com/ipj
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DLP-Obtaining Additional Publications and Information
• Training—Cisco offers world-class networking training. Current offerings in network training are 
listed at this URL:

http://www.cisco.com/en/US/learning/index.html

This document is to be used in conjunction with the documents listed in the “Related Documentation” section.

Copyright © 2004, Cisco Systems, Inc.
All rights reserved.

CCVP, the Cisco logo, and Welcome to the Human Network are trademarks of Cisco Systems, Inc.; Changing the Way We Work, Live, Play, and Learn is
a service mark of Cisco Systems, Inc.; and Access Registrar, Aironet, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, Cisco, the Cisco
Certified Internetwork Expert logo, Cisco IOS, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity,
Enterprise/Solver, EtherChannel, EtherFast, EtherSwitch, Fast Step, Follow Me Browsing, FormShare, GigaDrive, HomeLink, Internet Quotient, IOS,
iPhone, IP/TV, iQ Expertise, the iQ logo, iQ Net Readiness Scorecard, iQuick Study, LightStream, Linksys, MeetingPlace, MGX, Networkers,
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and TransPath are registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries. 

All other trademarks mentioned in this document or Website are the property of their respective owners. The use of the word partner does not imply a
partnership relationship between Cisco and any other company. (0711R)
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