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Monitoring Properties

This chapter contains the following topics:

• AAA Servers, page 32-1

• Device Access, page 32-2

• Connection Graphs, page 32-4

• CRL, page 32-6

• DNS Cache, page 32-7

• System Resources Graphs, page 32-8

AAA Servers
This pane allows you to view and refresh AAA server statistics.

Fields

• Server Group—Displays a configured server group, or LOCAL if none have been configured.

• Protocol—Displays what protocol the server group uses for AAA.

• IP Address—Displays the IP address of the configured AAA server.

• Status—Displays the status (Active or Inactive) of the configured AAA server.

Below the list of AAA servers are the statistics for each configured server. You can clear the statistics 
by clicking Clear Server Statistics. You can refresh the server status by clicking Update Server Status

Modes

The following table shows the modes in which this feature is available:

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —
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Device Access
This pane lets you monitor management sessions, AAA locked out users, and authenticated users. This 
section includes the following topics:

• AAA Local Locked Out Users

• Authenticated Users

• ASDM/HTTPS Sessions

• Secure Shell Sessions

• Telnet Sessions

AAA Local Locked Out Users
The AAA Local Locked Out Users pane lets you view a list of users who have been locked out of ASDM 
because of failed login attempts. You can also clear selected lockout conditions or all lockouts.

Fields

• Currently locked out users—Displays a list of the currently locked out users.

• Lock Time—Specifies the amount of time that the user has been locked out of the system.

• Failed Attempts—Specifies the number of failed login attempts.

• User—The user name identified with the failed login attempts.

• Clear lockout—Click to clear the selected user lockout condition.

• Clear all lockouts—Click to clear all user lockout conditions. It is good practice to refresh the list 
of lockout conditions before clearing all lockouts.

Modes

The following table shows the modes in which this feature is available:

Authenticated Users
This pane lets you view which users have been authenticated to use the FWSM. Each row represents one 
user.

Fields

• User—Displays the username of the person authenticated to use the FWSM. 

• IP Address—Displays the IP address of the user authenticated to use the FWSM. 

• Dynamic ACL—Displays the dynamic access list of the user authenticated to use the FWSM. 

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —
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• Inactivity Timeout—Displays the amount of time that the selected user must remain inactive before 
the session times out and the user is disconnected.

• Absolute Timeout—Displays the amount of time that the selected user can remain connected before 
the session closes and the user is disconnected. 

Modes

The following table shows the modes in which this feature is available:

ASDM/HTTPS Sessions
The ASDM/HTTPS pane lets you view currently connected ASDM/HTTPS sessions. 

Fields

• Session ID—Displays the name of a connected ASDM/HTTPS session.

• IP Address—Displays the IP address of each host or network that is allowed to connect to this 
FWSM. 

• Disconnect—Select to disconnect a connected ASDM/HTTPS session. 

Modes

The following table shows the modes in which this feature is available:

Secure Shell Sessions
The Secure Shell Sessions pane lets you view hosts connected to the FWSM for administrative access 
using the SSH protocol. 

Fields

• Client—Displays the client type for the selected SSH session. 

• User—Displays the user name for the selected SSH session. 

• State—Displays the state of the selected SSH session. 

• Version—Displays the version of SSH used to connect to the FWSM. 

• Encryption (in)—Displays the inbound encryption method used for the selected session. 

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —
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• Encryption (out)—Displays the outbound encryption method used for the selected session. 

• HMAC (in)—Displays the configured HMAC for the selected inbound SSH session.

• HMAC (out)—Displays the configured HMAC for the selected outbound SSH session.

• SID—Displays the secure ID of the selected session.

• Disconnect—Click to disconnect a connected SSH session. 

Modes

The following table shows the modes in which this feature is available:

Telnet Sessions
The Telnet Sessions pane lets you view currently connected Telnet sessions. 

Fields

• Session ID—Displays the name of a connected Telnet session.

• IP Address—Displays the IP address of each host that is allowed to connect to this FWSM over 
Telnet. 

• Disconnect—Click to disconnect a connected Telnet session. 

Modes

The following table shows the modes in which this feature is available:

Connection Graphs
The Connection Graphs pane lets you view connection information about the FWSM in graph format. 
You can view information about NAT and performance monitoring information, including UDP 
connections, AAA performance, and inspection information. This section includes the following topics:

• Perfmon

• Xlates

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —
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Perfmon
The Perfmon pane lets you view certain performance information in a graphical or tabular format. You 
can choose up to four types of statistics to show in one graph.

To view performance information, perform the following steps:

Step 1 Choose an existing graph window name to which you want to add a graph type from the Graph Window 
Title drop-down list. To display graphs in a newly named window, enter a new window title.

Step 2 In the Available Graphs list, choose the performance information you want to graph. The available 
statistics include the following:

• AAA Perfmon, which displays the FWSM AAA performance information.

• Inspection Perfmon, which displays the FWSM inspection performance information.

• Web Perfmon, which displays the FWSM web performance information, including URL access and 
URL server requests.

• Connections Perfmon, which displays the FWSM connections performance information.

• Xlate Perfmon, which displays the FWSM NAT performance information.

Step 3 Click Add to move the selection from the Available Graphs list to the Selected Graphs list, and then click 
Show Graphs.

The performance information appears in a new window in graphical format. Click the Table tab to view 
the performance information in tabular format. From the View drop-down list, choose the update 
frequency of the statistics that you want to display. Available options are: 

• Real-time data, every 10 seconds

• Last 10 minutes, data every 10 seconds

• Last 60 minutes, data every 1 minute

• Last 12 hours, data every 12 minutes

• Last 5 days, data every 2 hours

Click Export in the toolbar to export the statistics to a Microsoft Excel file that you can save on your PC.

Click Print to print the performance information for future use.

Step 4 Click Remove to move the selected statistics type from the Selected Graphs list to the Available Graphs 
list.

Modes

The following table shows the modes in which this feature is available:

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —
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Xlates
The Xlate pane lets you view the active network address translations in a graphical or tabular format. 
You can choose up to four types of statistics to show in one graph. 

To view NAT information, perform the following steps:

Step 1 Choose an existing graph window name to which you want to add a graph type from the Graph Window 
Title drop-down list. To display graphs in a newly named window, enter a new window title.

Step 2 In the Available Graphs list, choose the NAT information you want to graph. The available statistics 
include the following:

• Xlate Utilization, which displays the FWSM NAT utilization information.

Step 3 Click Add to move the selection from the Available Graphs list to the Selected Graphs list, and then click 
Show Graphs.

The performance information appears in a new window in graphical format. Click the Table tab to view 
the performance information in tabular format. From the View drop-down list, choose the update 
frequency of the statistics that you want to display. Available options are: 

• Real-time data, every 10 seconds

• Last 10 minutes, data every 10 seconds

• Last 60 minutes, data every 1 minute

• Last 12 hours, data every 12 minutes

• Last 5 days, data every 2 hours

Click Export in the toolbar to export the statistics to a Microsoft Excel file that you can save on your PC.

Click Print to print the performance information for future use.

Step 4 Click Remove to move the selected statistics type from the Selected Graphs list to the Available Graphs 
list.

Modes

The following table shows the modes in which this feature is available:

CRL
The CRL pane allows you to view or clear associated certificate revocation lists of selected CA 
certificates. 

To view or clear associated CRLs of selected CA certificates, perform the following steps:

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —
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Step 1 Choose the name of the selected certificate from the CA Certificate Name drop-down list.

Step 2 Click View CRL to view the selected CRL. 

The CRL Info area displays detailed CRL information.

Step 3 Click Clear CRL to clear the selected CRL from the cache.

Modes

The following table shows the modes in which this feature is available:

DNS Cache
The FWSM provides a local cache of DNS information from external DNS queries that are sent for 
certain clientless SSL VPN and certificate commands. Each DNS translation request is first looked for 
in the local cache. If the local cache has the information, the resulting IP address is returned. If the local 
cache can not resolve the request, a DNS query is sent to the various DNS servers that have been 
configured. If an external DNS server resolves the request, the resulting IP address is stored in the local 
cache along with its corresponding hostname.

DNS cache entries are time stamped. The time stamp will be used to age out unused entries. When the 
entry is added to the cache, the time stamp is initialized. Each time the entry is accessed, the timestamp 
is updated. At a configured time interval, the DNS cache will check all entries and purge those entries 
whose time exceeds a configured age-out timer.

If new entries arrive but there is no room in the cache because the size was exceeded or no more memory 
is available, the cache will be thinned by one third, based on the entries age. The oldest entries will be 
removed.

To view DNS cache information, perform the following steps:

Step 1 Choose a row from the DNS Cache table. The table displays the following information:

• Host, the DNS name of the host. 

• IP Address, the address that resolves to the hostname. 

• Permanent, which indicates whether the entry was made though a name command. 

• Idle Time, the time elapsed since the FWSM last referred to that entry.

• Active, which indicates whether the entry has aged out. If there is not adequate space in cache, this 
entry may be deleted.

Step 2 Click Clear Cache to clear the entire DNS cache.

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —
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Modes

The following table shows the modes in which this feature is available:

System Resources Graphs
The System Resources Graphs panes let you view the status of the FWSM memory, CPU, and block 
utilization. This section includes the following topics:

• Blocks

• CPU

• Memory

Blocks
The Blocks pane lets you view the free and used memory blocks in graphical or tabular format. You can 
choose up to four types of statistics to show in one graph window. 

To view the free and used memory blocks, perform the following steps:

Step 1 Choose an existing graph window name to which you want to add a graph type from the Graph Window 
Title drop-down list. To display graphs in a newly named window, enter a new window title.

Step 2 In the Available Graphs list, choose the resource information you want to graph for monitoring. The 
available statistics include the following:

• Blocks Used displays the FWSM used memory blocks.

• Blocks Free displays the FWSM free memory blocks.

Step 3 Click Add to move the selection from the Available Graphs list to the Selected Graphs list, and then click 
Show Graphs.

The memory block information appears in a new window in graphical format. Click the Table tab to view 
the memory block information in tabular format. From the View drop-down list, choose the update 
frequency of the statistics that you want to display. Available options are: 

• Real-time data, every 10 seconds

• Last 10 minutes, data every 10 seconds

• Last 60 minutes, data every 1 minute

• Last 12 hours, data every 12 minutes

• Last 5 days, data every 2 hours

Click Export in the toolbar to export the statistics to a Microsoft Excel file that you can save on your PC.

Click Print to print the performance information for future use.

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —
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Step 4 Click Remove to move the selected statistics type from the Selected Graphs list to the Available Graphs 
list.

Modes

The following table shows the modes in which this feature is available:

CPU
The CPU pane lets you view the CPU utilization. You can choose up to four types of statistics to show 
in one graph window. 

To view the CPU utilization, perform the following steps:

Step 1 Choose an existing graph window name to which you want to add a graph type from the Graph Window 
Title drop-down list. To display graphs in a newly named window, enter a new window title.

Step 2 In the Available Graphs list, choose the resource information you want to graph for monitoring. The 
available statistics include the following:

• CPU Utilization displays the FWSM CPU utilization.

Step 3 Click Add to move the selection from the Available Graphs list to the Selected Graphs list, and then click 
Show Graphs.

The CPU utilization information appears in a new window in graphical format. Click the Table tab to 
view the CPU utilization information in tabular format. From the View drop-down list, choose the update 
frequency of the statistics that you want to display. Available options are: 

• Real-time data, every 10 seconds

• Last 10 minutes, data every 10 seconds

• Last 60 minutes, data every 1 minute

• Last 12 hours, data every 12 minutes

• Last 5 days, data every 2 hours

Click Export in the toolbar to export the statistics to a Microsoft Excel file that you can save on your PC.

Click Print to print the performance information for future use.

Step 4 Click Remove to move the selected statistics type from the Selected Graphs list to the Available Graphs 
list.

Modes

The following table shows the modes in which this feature is available:

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —
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Memory
The Memory pane lets you view the memory utilization in graphical or tabular format. You can choose 
up to four types of statistics to show in one graph window. 

To view the memory utilization, perform the following steps:

Step 1 Choose an existing graph window name to which you want to add a graph type from the Graph Window 
Title drop-down list. To display graphs in a newly named window, enter a new window title.

Step 2 In the Available Graphs list, choose the resource information you want to graph for monitoring. The 
available statistics include the following:

• Free Memory displays the FWSM free memory.

• Used Memory displays the FWSM used memory.

Step 3 Click Add to move the selection from the Available Graphs list to the Selected Graphs list, and then click 
Show Graphs.

The CPU utilization information appears in a new window in graphical format. Click the Table tab to 
view the CPU utilization information in tabular format. From the View drop-down list, choose the update 
frequency of the statistics that you want to display. Available options are: 

• Real-time data, every 10 seconds

• Last 10 minutes, data every 10 seconds

• Last 60 minutes, data every 1 minute

• Last 12 hours, data every 12 minutes

• Last 5 days, data every 2 hours

Click Export in the toolbar to export the statistics to a Microsoft Excel file that you can save on your PC.

Click Print to print the performance information for future use.

Step 4 Click Remove to move the selected statistics type from the Selected Graphs list to the Available Graphs 
list.

Modes

The following table shows the modes in which this feature is available:

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —

Firewall Mode Security Context

Routed Transparent Single

Multiple

Context System

• • • • —
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