CHAPTER

Welcome to ASDM

Welcome to ASDM, a browser-based, Java applet that you use to configure and monitor the software on
the FWSM. ASDM is loaded by the FWSM, and enables you to configure, monitor, and manage the
device.

Note  If you change the color scheme of your operating system while ASDM is running, you should restart
ASDM, because some ASDM panes might not display correctly.

This chapter includes the following sections:

New Device Manager Features, page 2-2
Multiple ASDM Session Support, page 2-2
Caveats, page 2-2

Unsupported Commands, page 2-2

About the ASDM Interface, page 2-4
About the Help Window, page 2-13

Home Pane, page 2-13

System Home Pane, page 2-15
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B New Device Manager Features

New Device Manager Features

Version 6.1F includes the following enhancements:

Table 2-1 Version 6.1F Features
Feature Description
Redesigned interface Information has been reorganized to provide greater logical

consistency and ease of navigation.

Expanded on-screen help ASDM describes features and configuration options on screen,
which reduces the need to consult other information sources.

Visual policy editor The visual policy editor lets an administrator configure access
control policies and posture checking.

Accessibility Features such as keyboard navigation, alternate text for graphics,
and improved screen reader support have been added.

Complex configuration support | You can move between panes without applying changes, allowing
you to enter multi-pane configurations before applying that
configuration to the device.

Device list ASDM maintains a list of recently accessed devices, allowing you
to switch between devices and contexts.

Certificate management The certificate management GUI has been reorganized and

enhancements simplified.

Multiple ASDM Session Support

ASDM allows multiple PCs or workstations to each have one browser session open with the same FWSM
software. A single FWSM can support up to five concurrent ASDM sessions in single, routed mode. Only
one session per browser per PC or workstation is supported for a specified FWSM. In multiple context
mode, five concurrent ASDM sessions are supported per context, up to a maximum of 32 total connections
for each FWSM.

Caveats

Use the Bug Toolkit on Cisco.com to view current caveat information. You can access the Bug Toolkit
at the following URL:

http://www.cisco.com/cgi-bin/Support/Bugtool/launch_bugtool.pl

Unsupported Commands

This section includes the following topics:
e Ignored and View-Only Commands, page 2-3
e Effects of Unsupported Commands, page 2-4
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Unsupported Commands

ASDM supports almost all commands available for the FWSM, but ASDM ignores some commands in
an existing configuration. Most of these commands can remain in your configuration; see Show
Commands Ignored by ASDM on Device for more information.

In addition, ASDM does not support discontinuous subnet masks such as 255.255.0.255. For example,

do not use the following:

ip address inside 192.168.2.1 255.255.0.255

Ignored and View-Only Commands

Table 2-2 lists commands that ASDM supports in the configuration when added through the CLI, but that
cannot be added or edited in ASDM. If ASDM ignores the command, it does not appear in the ASDM
GUI at all. If the command is view-only, then it appears in the GUI, but you cannot edit it.

Table 2-2 List of Unsupported Commands

Unsupported Commands

ASDM Behavior

access-list

Ignored if not used

capture Ignored
dns-guard Ignored
eject Unsupported
established Ignored.
failover timeout Ignored
ipv6, any IPv6 addresses Ignored
pager Ignored

pim accept-register route-map

Ignored. You can configure only the list option
using ASDM.

prefix-list

Ignored if not used in an OSPF area

route-map

Ignored

route-monitor

Ignored

service-policy global

Ignored if it uses a match access-list class. For
example:

access-list myacl line 1 extended permit ip
any any

class-map mycm

match access-list mycl

policy-map mypm

class mycm

inspect ftp

service-policy mypm global

sysopt nodnsalias Ignored
sysopt uauth allow-http-cache Ignored
terminal Ignored
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Effects of Unsupported Commands

Note

If ASDM loads an existing running configuration and finds IPv6-related commands, ASDM displays a
dialog box informing you that it does not support IPv6. You cannot configure any IPv6 commands in
ASDM, but other configurations are available.

If ASDM loads an existing running configuration and finds other unsupported commands, ASDM
operation is unaffected. To view the list of unsupported commands, choose Tools > Show Commands
Ignored by ASDM on Device.

If you load an existing running configuration that includes the alias command, ASDM enters
Monitor-only mode. This mode allows you to access the following functions:

e The Monitoring area
e The CLI tool. To access the CLI tool, choose Tools > Command Line Interface.

To exit Monitor-only mode, use the CLI tool or access the FWSM console, and remove the alias
command. You can use outside NAT instead of the alias command. See the Catralyst 6500 Series Switch
and Cisco 7600 Series Router Firewall Services Module Command Reference for more information.

You might also be in Monitor-only mode because your user account privilege level, indicated in the
status bar at the bottom of the main ASDM window, was set as less than or equal to three by your system
administrator. For more information, choose Configuration > Properties > Device Administration >
User Accounts and Configuration > Device Access > AAA Access.

About the ASDM Interface

~

Note

The ASDM interface is designed to provide easy access to the many features that the FWSM supports.
The ASDM interface includes the following components:

¢ Menu Bar—Provides quick access to files, tools, wizards, and online help. Many menu items also
have keyboard shortcuts.

e Toolbar—Lets you navigate ASDM. On the toolbar you can access the Home, Configuration, and
Monitoring panes. You can also obtain online help and navigate between panes.

e Status Bar—Shows the time, connection status, user, and access privilege level.

e Device List—Displays a list of devices that you can access through ASDM. For more information,
see the “Device List” section on page 2-9.

e Addresses/Services/Time Ranges—Displays a dockable pane that shows various objects you can use
in the rules tables when you create access, filter, and service rules.

e Navigation—Displays a dockable pane that lets you navigate the Configuration and Monitoring
panes.

Tool tips have been added to various parts of the GUI, including wizards, and the Configuration and
Monitoring panes.

This section includes the following topics:
e Menus, page 2-5
e Toolbar, page 2-8
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Status Bar, page 2-9

Common Buttons, page 2-10

Keyboard Shortcuts, page 2-10

Enabling Extended Screen Reader Support, page 2-12

Menus
You can access the ASDM menus using the mouse or keyboard. For more information about accessing
the menu bar from the keyboard, see the “Keyboard Shortcuts” section on page 2-10. ASDM has the
following menus:

e File Menu, page 2-5

e View Menu, page 2-6

e Tools Menu, page 2-6

e Wizards Menu, page 2-7

¢ Window Menu, page 2-7

e Help Menu, page 2-7

File Menu
The File menu manages FWSM configurations, and includes the following items:

e Refresh ASDM with the Running Configuration on the Device—Loads a copy of the running
configuration to ASDM. Click Refresh to make sure ASDM has a current copy of the running
configuration.

¢ Show Running Configuration in New Window—Displays the current running configuration in a new
window.

¢ Save Running Configuration to Flash—Writes a copy of the running configuration to flash memory.

¢ Save Running Configuration to TFTP Server—Stores a copy of the current running configuration
file on a TFTP server. See the “Save Running Configuration to TFTP Server” section on page 3-3
for more information.

¢ Save Running Configuration to Standby Unit—Sends a copy of the running configuration file on the
primary unit to the running configuration of a failover standby unit.

¢ Save All Running Configurations to Flash (Multiple mode only)—Werites a copy of all running
configurations to flash memory.

e Save Internal Log Buffer to Flash—Saves the internal log buffer to flash memory.

e Print—Prints the current page. We recommend landscape page orientation when you print rules. If
ASDM is running in Firefox and you have not yet granted print privileges to the Java applet, a
security dialog box appears to request that you grant printing privileges. Click Grant to grant the
applet printing privileges. When you use Internet Explorer, permission to print is already granted
when you originally accepted the signed applet.

e (Clear ASDM Cache—Removes local ASDM images. ASDM downloads images locally when you
connect to ASDM.

¢ C(Clear Internal Log Buffer—Empties the syslog message buffer.

e Exit—Closes ASDM.
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View Menu

The View menu lets you display various parts of the ASDM interface. Certain items are dependent on
the current view. You cannot select items that cannot be displayed in the current view. For example, the
Latest ASDM Syslog Messages pane is only available when the home view is displayed.

Tools Menu

Home—Displays the home view.
Configuration—Displays the configuration view.
Monitoring—Displays the monitoring view.

Device List—Displays a list of devices in a dockable pane. For more information, see the “Device
List” section on page 2-9.

Navigation—Shows and hides the display of the Navigation pane in the configuration and
monitoring views.

ASDM Assistant—Displays a dockable pane that lets you search for information in ASDM. See the
“ASDM Assistant” section on page 3-17 for more information.

Latest ASDM Syslog Messages—Shows and hides the display of the Latest ASDM Syslog
Messages pane in the home view.

Addresses—Shows and hides the display of the Addresses pane. The Addresses pane is only
available for the Access Rules, NAT Rules, Service Policy Rules, AAA Rules, and Filter Rules panes
in the configuration view.

Services—Shows and hides the display of the Services pane. The Services pane is only available for
the Access Rules, NAT Rules, Service Policy Rules, AAA Rules, and Filter Rules panes in the
configuration view.

Time Ranges—Shows and hides the display of the Time Ranges pane. The Time Ranges pane is only
available for the Access Rules, Service Policy Rules, AAA Rules, and Filter Rules panes in the
configuration view.

Global Pools—Shows and hides the display of the Global Pools pane. The Global Pools pane is only
available for the NAT Rules pane in the configuration view.

Select Next Pane—Moves to the next pane in the sequence.

Select Previous Pane—Moves to the prior pane in the sequence.

Back—See the “Common Buttons” section on page 2-10 for more information.
Forward—See the “Common Buttons” section on page 2-10 for more information.

Find in ASDM—Locates an item for which you are searching, such as a feature or the ASDM
Assistant.

Reset Layout—Returns the layout to the default configuration.

Office Look and Feel—Changes the screen fonts and colors to the Microsoft Office settings.

The Tools menu provides you with the following series of tools to use with ASDM:

Command Line Interface—Provides a text-based tool for sending commands to the FWSM and
viewing the results. See the “Command Line Interface” section on page 3-4 for more information.

Show Commands Ignored by ASDM on Device—Displays unsupported commands that have been
ignored by ASDM. See the “Show Commands Ignored by ASDM on Device” section on page 3-5
for more information.
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Wizards Menu

Window Menu

Help Menu

About the ASDM Interface

Ping—Lets you verify the configuration and operation of the FWSM and surrounding
communications links, as well as perform basic testing of other network devices. See the “Ping”
section on page 3-6 for more information.

File Management—Lets you view, move, copy, and delete files stored in flash memory. You can also
create a directory in flash memory. See the “File Management” section on page 3-13 for more
information. You can also display the File Transfer dialog box to transfer files between various file
systems, including TFTP, flash memory, and your local PC.

Upgrade Software from Local Computer—Lets you choose an FWSM image, ASDM image, or
another image on your PC, and upload the file to flash memory. See the “Upgrade Software from
Local Computer” section on page 3-14 for more information.

Upgrade Software from Cisco.com—Lets you upgrade FWSM software and ASDM software
through a wizard. See the “Upgrade Software from Cisco.com Wizard” section on page 3-16 for
more information.

System Reload—Lets you restart the FWSM and reload the saved configuration into memory. See
the “System Reload” section on page 3-18 for more information.

Preferences—Changes the behavior of specified ASDM functions between sessions. See the
“Preferences” section on page 3-1 for more information.

ASDM Java Console—Shows the Java console. See the “ASDM Java Console” section on page 3-8
for more information.

The Wizards menu lets you run a wizard to configure multiple features.

Startup Wizard—This wizard walks you, step-by-step, through the initial configuration of your
FWSM. For more information, see Chapter 6, “Using the Startup Wizard.”.

High Availability and Scalability Wizard— This wizard allows you to configure failover on your
FWSM. For more information, see Chapter 13, “Configuring Failover.”.

The Window menu enables you to move between ASDM windows. The active window appears as the
selected window.

The Help menu provides links to online help, as well as information about ASDM and the FWSM.

Help Topics—Opens a new browser window with help organized by contents, pane name, and
indexed in the left frame. Use these methods to find help for any topic, or search using the Search
tab.

Help for Current Screen—Opens context-sensitive help about that screen. The wizard runs the
screen, pane, or dialog box that is currently open. You can also click the question mark (?) help icon
for context-sensitive help.

Release Notes—Opens the most current version of the Cisco ASDM Release Notes on Cisco.com.
The release notes contain the most current information about ASDM software and hardware
requirements, and the most current information about changes in the software.

Getting Started—Opens the Getting Started help topic to help you begin using ASDM.
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e ASDM Assistant—Opens the ASDM Assistant, which lets you search downloadable content from
Cisco.com, with details about performing certain tasks. Includes feature search for a function in
ASDM. You can also use the Look For field in the right-hand corner of the main ASDM application
window.

e About Cisco Firewall Services Module—Displays information about the FWSM, including the
software version, hardware set, configuration file loaded at startup, and software image loaded at
startup. This information is helpful in troubleshooting.

e About Cisco ASDM 6.1F—Displays information about ASDM such as the software version,
hostname, privilege level, operating system, device type, and Java version.

Toolbar

The Toolbar provides access to the home view, configuration view, and monitoring view. It also lets you
choose between the system and security contexts in multiple context mode, and provides navigation and
other commonly used functions.

e System/Contexts—Click the down arrow to open the context list in a left-hand pane, and click the
up arrow to restore the context drop-down list. After you have expanded this list, click the left arrow
to collapse the pane, and the right arrow to restore the pane. To manage the system, choose System
from the list. To manage a context, choose one from the list.

e Home—Displays the Home Pane, which lets you view important information about the FWSM such
as the status of your interfaces, the version you are running, licensing information, and performance.
See the Home pane for more information. In multiple mode, the system does not have a Home pane.

¢ Configuration—Configures the FWSM. Choose a feature button in the left-hand pane to configure
that feature.

¢ Monitoring—Monitors the FWSM. Choose a feature button in the left-hand pane to monitor that
feature.

e Back—Returns you to the last ASDM pane that you visited.
e Forward—Moves you forward to the last ASDM pane that you visited.

¢ Look For—Lets you search for a feature in ASDM. The Search function looks through the titles of
each pane and presents you with a list of matches, and gives you a hyperlink directly to that pane.
If you need to switch quickly between two different panes that you found, click Back or Forward.
See the “ASDM Assistant” section on page 2-8 for more information.

e Refresh—Refreshes ASDM with the current running configuration, except for graphs in any of the
monitoring graphs.

e Save—Saves the running configuration to the startup configuration for write-accessible contexts
only.

e Help—Shows context-sensitive help for the pane that is currently open.

ASDM Assistant

The ASDM Assistant pane lets you search for useful ASDM procedural help about certain tasks. See the
“ASDM Assistant” section on page 3-17 for more information. You enter queries; the ASDM Assistant lists
the available links to information that result from those queries, and then displays the information that
you selected or additional links in the same pane.

The How Do 1? section lists specific links related to your search query. The Search field lets you enter
terms about which you want more information.
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The status bar appears at the bottom of the ASDM window, and shows the following areas from left to
right.

e Status—Shows the status of the configuration (for example, “Device configuration loaded
successfully.”).

e User Name—Shows the username of the ASDM user. If you logged in without a username, the
username is “admin.”

e User Privilege—Shows the privilege of the ASDM user.

¢ Commands Ignored by ASDM—Click the icon to show a list of commands from your configuration
that ASDM did not process. These commands are not removed from the configuration. See the
“Show Commands Ignored by ASDM on Device” section on page 3-5 for more information.

e Status of Connection to Device—Shows the ASDM connection status to the FWSM. See the
“Connection to Device” section on page 2-9 for more information.

¢ Save to Flash Needed—Shows that you made configuration changes in ASDM, but that you still
must save the running configuration to the startup configuration.

¢ Refresh Needed—Shows that you need to refresh the configuration from the FWSM to ASDM,
because the configuration on the FWSM changed (for example, you made a change to the
configuration through the CLI).

e SSL Secure—Shows that the connection to ASDM is secure because it uses SSL.

¢ Date and Time—Shows the date and time that are set on the switch that includes the FWSM.

Connection to Device

Device

List

Note

Step 1

Step 2

ASDM maintains a constant connection to the FWSM to maintain up-to-date Monitoring and Home pane
data. This dialog box shows the status of the connection. When you make a configuration change, ASDM
opens a second connection for the duration of the configuration, and then closes it; however, this dialog
box does not represent the second connection.

The Device List is a dockable pane. You can click one of the three buttons in the header to maximize or
restore this pane, make it a floating pane that you can move, hide the pane, or close the pane. The Device
List pane is available in the home, configuration, monitoring, and system views. You can use this pane
to switch to another device; however, that device must run the same version of ASDM that you are
currently running. To display the pane fully, you must have at least two devices listed.

You cannot switch to another device that runs a different version of ASDM.

To use the Device List pane to connect to another device, perform the following steps:

Click Add to add another device to the list.
The Add Device dialog box appears.

In the Device/IP Address/Name field, type the device name or IP address of the device, and then click
OK.
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Step3  Click Delete to remove a selected device from the list.

Step4  Click Connect to connect to another device.

The Enter Network Password dialog box appears.

Step5  Type your username and password in the applicable fields, and then click Login.

Modes

The following table shows the modes in which this feature is available:

Firewall Mode Security Context
Multiple
Routed Transparent |Single Context System

Common Buttons

The following buttons appear in many ASDM panes:

Apply—Sends changes made in ASDM to the FWSM and applies them to the running configuration.
Save—Writes a copy of the running configuration to flash memory.

Reset—Discards changes and reverts to the information displayed before changes were made or the
last time you clicked Refresh or Apply. After you click Reset, click Refresh to make sure that
information from the current running configuration is displayed.

Refresh—Refreshes ASDM with the current running configuration, except for graphs in any of the
monitoring graphs. When the startup configuration and the running configuration are out-of-sync,
the button turns pink to notify you that you need to resynchronize the startup and running
configurations.

Restore Default—Clears the selected settings and returns to the default settings.
Cancel—Discards changes and returns to the previous pane.

Enable—Displays read-only statistics for a feature.

Close—Closes an open dialog box.

Clear—Removes information from a field or box, or removes a check from a check box.
Back—Returns you to the previous pane.

Forward—Takes you to the next pane.

Help—Displays help for the selected pane.

Keyboard Shortcuts

You can use the keyboard to navigate the ASDM interface.

Table 2-3 lists the keyboard shortcuts you can use to move across the three main areas of the ASDM
interface.
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Table 2-3 Navigating ASDM

To display the Windows/Linux 0S Mac0S

Home Pane Ctrl+H Shift+Command+H

Configuration Pane Cul+G Shift+Command+G

Monitoring Pane Ctrl+M Shift+Command+M

Help F1 Command+?

Back Alt+Left Arrow Command+]

Forward Alt+Right Arrow Command+]

Refresh the display F5 Command+R

Cut Ctrl+X Command+X

Copy Ctrl+C Command+C

Paste Ctrl+V Command+V

Save the configuration Ctrl+S Command+S

Popup menus Shift+F10 —

Close a secondary window Alt+F4 Command+W

Find Ctrl+F Command+F

Exit Alt+F4 Command+Q

Exit a table or text area Ctrl_Shift or Ctril+Shift or
Ctrl+Shift+Tab Ctrl+Shift+Tab

Table 2-4 lists the keyboard shortcut you can use to navigate within a pane.

Table 2-4 Moving the Focus

To move the focus to the Press

next field Tab
previous field Shift+Tab
next field when the focus is in a table Ctrl+Tab
previous field when the focus is in a table Shift+Ctrl+Tab
next tab (when a tab has the focus) Right Arrow
previous tab (when a tab has the focus) Left Arrow
next cell in a table Tab
previous sell in a table Shift+Tab
next pane (when multiple panes are displayed) F6

previous pane (when multiple panes are displayed) Shift+F6

Table 2-5 lists the keyboard shortcuts you can use with the Log Viewers.
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Table 2-5 Log Viewer Keyboard Shortcuts

To display the Windows/Linux 0S Mac0S

Pause and Resume Real-Time Log Viewer Ctrl+U Command+.
Refresh Log Buffer Window F5 Command+R
Clear Internal Log Buffer Ctrl+Delete Command+Delete
Copy Selected Log Entry Ctrl+C Command+C
Save Log Ctrl+S Command+S
Print Ctrl+P Command+P
Close a secondary window Alt+F4 Command+W

Table 2-6 lists the keyboard shortcuts you can use to access menu items.

Table 2-6 Log Viewer Keyboard Shortcuts

To access the Windows/Linux 0S
Menu Bar Alt

Next Menu Right Arrow
Previous Menu Left Arrow

Next Menu Option

Down Arrow

Previous Menu Option

Up Arrow

Selected Menu Option

Enter

Enabling Extended Screen Reader Support

Step 1

Step 2
Step 3
Step 4

By default, labels and descriptions are not included in tab order when you press the Tab key to navigate
a pane. Some screen readers, such as JAWS, only read screen objects that have the focus. You can include
the labels and descriptions in the tab order by enabling extended screen reader support.

To enable extended screen reader support, perform the following steps:

In the main ASDM application window, choose Tools > Preferences.

The Preferences dialog box appears.

On the General tab, check the Enable screen reader support check box.

Click OK.

Restart ASDM to activate screen reader support.
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Organizational Folder

Some nodes in the navigation tree for the configuration and monitoring views do not have associated
Configuration or Monitoring panes. Folders are used to organize related configuration and monitoring
items. Clicking these folders displays a list of sub-items in the right-hand pane. You can click the name
of a sub-item to go to that item.

About the Help Window

This section includes the following topics:
e Header Buttons, page 2-13
e Browser Window, page 2-13

Header Buttons

Click the applicable button to obtain the information you need.

e About ASDM—Displays information about ASDM, including the hostname, version number,
device type, FWSM software version number, privilege level, username, and operating system being
used.

e Search—Searches for information among online help topics.
e Using Help—Describes the most efficient methods for using online help.
¢ Glossary—Lists terms found in ASDM and FWSM.
Left-Pane Links—Moves through online help topics.
¢ Contents—Displays a table of contents.
e Screens—Lists help files by pane name.
e Index—Provides an index of ASDM online help topics.
Right-Pane Help Content—Displays the selected help topic.

Browser Window

When you open help and a help page is already open, the new help page will appear in the same browser
window. If no help page is open, then the help page will appear in a new browser window.

When you open help and Netscape Communicator is the default browser, the help page will appear in a
new browser window. If Internet Explorer is the default browser, the help page may appear either in the
last-visited browser window or in a new browser window, according to the browser settings. You can
control this behavior in Internet Explorer by choosing Tools > Internet Options > Advanced > Reuse
windows for launching shortcuts.

Home Pane

The ASDM Home pane lets you view important information about the FWSM. Status information on the
Home pane is updated every ten seconds.
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Fields

¢ Device Information—Includes two tabs to show device information.

General—Shows the following information:

Host Name—Display only. Shows the FWSM hostname. See the “Device Name/Password”
section on page 7-7 to set the hostname.

FWSM Version—Display only. Shows the FWSM software version.

ASDM Version—Display only. Shows the ASDM version.

Device Uptime—Display only. Shows how long the FWSM has been running.
Device Type—Display only. Shows the device number.

Firewall Mode—Display only. Shows the firewall mode (Routed or Transparent). See
Chapter 18, “Firewall Mode Overview,” for more information.

Total Flash—Display only. Shows the total amount of available flash memory in MB.

Context Mode—Display only. Shows the context mode (Single or Multiple). For more
information, see the “Security Context Overview” section on page 9-1.

Total Memory—Display only. Shows the total amount of available RAM in MB.

License—Display only. Shows the level of support for licensed features on the FWSM. Shows
the following information:

Failover—Display only. Shows the failover configuration, either Active/Active or
Active/Standby.

Security Contexts—Display only. Shows the maximum numbers of security contexts allowed.
GTP/GPRS—Display only. Shows whether GTP/GPRS is enabled or disabled.

VPN Peers—Display only. Shows the number of VPN connections allowed.
Encryption—Display only. Shows the type of encryption enabled (for example, BGP).

Click More Licenses to open the Configuration > Device Management > Activation Key pane.

e System Resources Status—Shows the following CPU and memory usage statistics:

CPU—Display only. Shows the current percentage of CPU being used.
CPU Usage (percent)—Display only. Shows the CPU usage for the last five minutes.
Memory—Display only. Shows the current amount of memory being used in MB.

Memory Usage (MB)—Display only. Shows the memory usage for the last five minutes.

¢ Interface Status—Shows the status of each interface. If you select an interface row, the input and
output throughput in Kbps shows under the table.

Interface—Display only. Shows the interface name.

IP Address/Mask—Display only. Routed mode only. Shows the IP address and subnet mask of
the interface.

Line—Display only. Shows the administrative status of the interface. A red icon is displayed if
the line is down, and a green icon is displayed if the line is up.

Link—Display only. Shows the link status of the interface. A red icon is displayed if the link is
down, and a green icon is displayed if the link is up.

Kbps—Display only. Shows the current number of throughput in Kbps that cross the interface.

e Traffic Status—Shows graphs for connections per second for all interfaces and for the traffic
throughput of the lowest security interface.
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Connections per Second Usage—Display only. Shows the UDP and TCP connections per
second during the last five minutes. This graph also shows the current number of connections
by type, UDP, TCP, and the total.

Name Interface Traffic Usage (Kbps)—Display only. Shows the traffic throughput for the lowest
security interface. If you have multiple interfaces at the same level, then ASDM shows the first
interface alphabetically. This graph also shows the current throughput by type, input Kbps, and
output Kbps.

e Latest ASDM Syslog Messages—Shows the most recent system messages generated by the FWSM,
up to a maximum of 100 messages.

Modes

Click the square icon in the header to expand the logging pane. Click the double-square icon in
the header to return to the default size. Drag the divider up or down to resize the pane. You can
also right-click an event and choose Clear Content, to clear the current messages; Save
Content, to save the current messages to a file on your PC, Copy, to copy the content; and Color
Settings, to change the background and foreground colors of syslog messages according to their
severity. Click one of the four buttons in the header on the right-hand side to maximize or restore
the pane, make it a floating pane that you can move, hide the pane, or close the pane.

Enable Logging—Click to enable logging and display syslog messages.

Stop message display—Click the red icon on the right-hand side to stop updating the display of
syslog messages.

Resume message display—Click the green icon on the right-hand side to continue updating the
display of syslog messages.

Configure ASDM Syslog Filters—Click the filters icon on the right-hand side to open the
Logging Filters pane.

The following table shows the modes in which this feature is available:

Firewall Mode Security Context
Multiple
Routed Transparent |Single Context System

System Home Pane

The ASDM System Home pane lets you view important status information about the FWSM. Many of
the details available on the ASDM System Home pane are available elsewhere in ASDM, but this pane
shows at-a-glance how the FWSM is running. Status information on the System Home pane is updated
every ten seconds.

Note

The ASDM Home pane is available only in the security context.

Fields

e Device List

Displays the list of devices to which you can connect. For more information, see the

“Device List” section on page 2-9.
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Interface Status—Shows the following information:

Interface—Display only. Shows the type of interface to which you are connected. Choose an

interface to view the total amount of traffic through the interface.

Contexts—Display only. Shows the current contexts of users (for example, admin).

Line—Display only. Shows the line status, which can be Up or Down.

Link—Display only. Shows the link status, which can be Up or Down.

Kbps—Display only. Shows the current connection speed in kilobits per second.

CPU Status—Shows the following CPU and context usage statistics:

— Total Usage tab—Display only. Shows the total percentage of CPU usage and the total

— Context Usage tab—Display only. Shows the total percentage of context usage in three formats:
a table, or a pie or bar chart. The tabular view provides a filtering feature to show only the top

percentage of CPU usage history in seconds.

five or top ten users of a specific resource. In addition, this view can show peak usage.

e Connection Status—Shows the following connection usage and context connection usage statistics:

— Total Connections tab—Display only. Shows the total number of connections.

— Context Connections tab—Display only. Shows the total number of context connections in three
formats: a table, or a pie or bar chart. The tabular view provides a filtering feature to show only
the top five or top ten users of a specific resource. In addition, this view can show peak usage.

- Total Usage tab—Display only. Shows the total amount of memory usage in MB and the total

— Context Usage tab—Display only. Shows the total amount of memory usage in various contexts
in MB in three formats: a table, or a pie or bar chart. The tabular view provides a filtering feature
to show only the top five or top ten users of a specific resource. In addition, this view can show

Modes

amount of memory usage history in MB.

peak usage.

The following table shows the modes in which this feature is available:

Firewall Mode

Security Context

Routed

Transparent

Single

Multiple

Context

System

Memory Status—Shows the following CPU and context usage statistics:

i Catalyst 6500 Series Switch and Cisco 7600 Series Router Firewall Services Module Configuration Guide

0L-16645-01



| Chapter2 Welcome to ASDM

System Home Pane 1l

Catalyst 6500 Series Switch and Cisco 7600 Series Router Firewall Services Module Configuration Guide
[ oL-16645-01 .m



Chapter2  Welcome to ASDM |

W System Home Pane

Catalyst 6500 Series Switch and Cisco 7600 Series Router Firewall Services Module Configuration Guide
[ 218 | 0L-16645-01 |



	Welcome to ASDM
	New Device Manager Features
	Multiple ASDM Session Support
	Caveats
	Unsupported Commands
	Ignored and View-Only Commands
	Effects of Unsupported Commands

	About the ASDM Interface
	Menus
	File Menu
	View Menu
	Tools Menu
	Wizards Menu
	Window Menu
	Help Menu

	Toolbar
	ASDM Assistant

	Status Bar
	Connection to Device

	Device List
	Common Buttons
	Keyboard Shortcuts
	Enabling Extended Screen Reader Support
	Organizational Folder

	About the Help Window
	Header Buttons
	Browser Window

	Home Pane
	System Home Pane


