Cisco Nexus 6000 Series NX-OS Unicast Routing Command Reference
R Commands
Downloads: This chapterpdf (PDF - 88.0KB) The complete bookPDF (PDF - 7.33MB) | Feedback

Table of Contents

R Commands

redistribute (RIP)

restart (RIP)

router rip

R Commands

This chapter describes the Cisco NX-OS Routing Information Protocol (RIP) commands that begin with R.

redistribute (RIP)

To redistribute routes from another routing domain into the Routing Information Protocol (RIP), use the redistribute command. To restore the system to its default condition in which the software does not redistribute routes, use the no form of this command.

redistribute { bgp id | direct | eigrp id | ospf id | static } route-map map-name

 
Syntax Description

bgp id

Redistributes routes from the Border Gateway Protocol (BGP). The ID is an autonomous system number. The range for 2-byte numbers is from 1 to 65535. The range for 4-byte numbers is from 1.0 to 65535.65535.

direct

Redistributes routes from directly connected routes only.

eigrp id

Redistributes routes from the Enhanced Interior Gateway Routing Protocol (EIGRP). The ID is an EIGRP instance name from which routes are to be redistributed. The value takes the form of a string. You can enter a decimal number, but Cisco Nexus 6000 stores it internally as a string.

ospf id

Redistributes routes from the Open Shortest Path First (OSPF) protocol. The ID is an OSPF instance name from which routes are to be redistributed. The value takes the form of a string. A decimal number can be entered, but it is stored internally as a string.

static

Redistributes routes from IP static routes.

route-map map-name

Associates a route map to set the redistribution policy for RIP.

 
Command Default

Route redistribution is disabled.

 
Command Modes

Router address-family configuration mode

 
Command History

Release
Modification

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

Cisco Nexus 6000 filters redistributed routing information using a route map. You can configure the route map to set the RIP metric used for redistributed routes. If you do not set the RIP metric with a route map, Cisco Nexus 6000 determines the metric based on the redistributed protocol or by the default-metric command. If Cisco Nexus 6000 cannot determine a valid metric, then it does not redistribute the routes.

Examples

This example shows how to redistribute BGP routes into a RIP process:

switch(config)# router rip Enterprise
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# redistribute bgp 64496
switch(config-router-af)#
 

 
Related Commands

Command
Description

address-family

Enters address-family configuration mode.

default-information originate

Generates a default route for routes redistributed into RIP.

default-metric

Sets default metric values for routes redistributed from other protocols into RIP.

show ip rip

Displays a summary of RIP information for all RIP instances.

restart (RIP)

To restart a Routing Information Protocol (RIP) instance and remove all associated neighbors, use the restart command.

restart eigrp instance-tag

 
Syntax Description

instance-tag

Name for an RIP routing instance. The name can be a maximum of 20 alphanumeric characters.

 
Command Default

None

 
Command Modes

Global configuration mode

 
Command History

Release
Modification

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

This command requires the LAN Base Services license.

Examples

This example shows how to restart the RIP instance and remove all neighbors:

switch(config)# restart rip Enterprise
switch(config)#
 

 
Related Commands

Command
Description

copy running-config startup-config

Saves the configuration in the startup configuration file.

show ip eigrp interfaces

Displays information about EIGRP interfaces.

router rip

To configure the Routing Information Protocol (RIP) routing process, use the router rip command. To turn off the RIP routing process, use the no form of this command.

router rip instance-tag

no router rip

 
Syntax Description

instance-tag

Name for this RIP instance.

 
Command Default

No RIP routing process is defined.

 
Command Modes

Global configuration mode

 
Command History

Release
Modification

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to begin the RIP routing process:

switch(config)# router rip Enterprise
 

 
Related Commands

Command
Description

ip router rip

Specifies a RIP instance for an interface.