Cisco Nexus 6000 Series NX-OS Unicast Routing Command Reference
R Commands
Downloads: This chapterpdf (PDF - 123.0KB) The complete bookPDF (PDF - 7.33MB) | Feedback

Table of Contents

R Commands

redistribute (EIGRP)

redistribute maximum-prefix (EIGRP)

restart eigrp (EIGRP)

router eigrp

router-id (EIGRP)

R Commands

This chapter describes the Cisco NX-OS Enhanced Interior Gateway Routing Protocol (EIGRP) commands that begin with R.

redistribute (EIGRP)

To inject routes from one routing domain into the Enhanced Interior Gateway Routing Protocol (EIGRP), use the redistribute command. To remove the redistribute command from the configuration file and restore the system to its default condition in which the software does not redistribute routes, use the no form of this command.

redistribute { bgp as-number | direct | eigrp id | ospf instance-tag | rip instance-tag | static } [ route-map map-name ]

no redistribute { bgp as-number | direct | eigrp as-number | ospf instance-tag | rip instance-tag | static }

 
Syntax Description

bgp as-number

Distributes routes from Border Gateway Protocol (BGP). The as-number is a 2-byte or 4-byte autonomous system number. The range for 2-byte numbers is from 1 to 65535. The range for 4-byte numbers is from 1.0 to 65535.65535.

direct

Distributes routes that are directly connected on an interface.

eigrp id

Specifies the name of an EIGRP instance. The id can be any case-sensitive, alphanumeric string up to 20 characters.

ospf instance-tag

Distributes routes from the OSPF protocol. This protocol is supported in the IPv4 address family. The instance-tag can be a maximum of 20 alphanumeric characters.

rip instance-tag

Distributes routes from the RIP protocol. The instance-tag can be a maximum of 20 alphanumeric characters.

static

Redistributes IP static routes.

route-map map-name

(Optional) Specifies the identifier of a configured route map. Use a route map to filter which routes are redistributed into EIGRP.

 
Command Default

Disabled

 
Command Modes

Address family configuration mode
Router configuration mode
Router VRF configuration mode

 
Command History

Release
Modification

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

Use the redistribute command to import routes from other routing protocols into EIGRP. You should always use a route map to filter these routes to ensure that EIGRP redistributes only the routes that you intend to redistribute.

You must configure a default metric to redistribute routes from another protocol into EIGRP. You can configure the default metric with the default-metric command or with the route map configured with the redistribute command.

This command requires the LAN Base Services license.

Examples

This example shows how to redistribute cause BGP routes into an EIGRP autonomous system:

switch(config)# router eigrp 209
switch(config-router) address-family ipv4 unicast
switch(config-router-af)# redistribute bgp 64496
switch(config-router-af)
 

 
Related Commands

Command
Description

default-metric (EIGRP)

Sets the default metrics for routes redistributed into EIGRP.

show ip eigrp

Displays EIGRP information.

redistribute maximum-prefix (EIGRP)

To limit the number of routes redistributed into Enhanced Interior Gateway Routing Protocol (EIGRP), use the redistribute maximum-prefix command. To return to the default setting, use the no form of this command.

redistribute maximum-prefix max [ threshold ] [ warning-only | withdraw [ num-retries timeout ]]

no redistribute maximum-prefix max [ threshold ] [ warning-only | withdraw [ num-retries timeout ]

 
Syntax Description

max

Maximum number of prefixes that EIGRP will distribute. The range is from 0 to 65536.

threshold

(Optional) Percentage of maximum prefixes that triggers a warning message. The range is from 1 to 100. The default is 75 percent.

warning-only

(Optional) Logs a warning message when the maximum number of prefixes is exceeded.

widthdraw

(Optional) Withdraws all redistributed routes.

num-retries

(Optional) Number of times EIGRP tries to retrieve the redistributed routes. The range is from 1 to 12. The default is 1.

timeout

(Optional) Time between retry attempts. The range is from 60 to 600 seconds. The default is 300.

 
Command Default

No limit

 
Command Modes

Router configuration mode
VRF configuration mode

 
Command History

Release
Modification

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

Use the redistribute maximim-prefix command to limit the number of routes redistributed into EIGRP. Use the clear ip eigrp redistribute command if all routes are withdrawn.

Examples

This example shows how to limit the number of redistributed routes into EIGRP:

switch# configure terminal

switch(config)# router eigrp 201

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# redistribute bgp route-map FilterExternalBGP

switch(config-router-af)# redistribute maximum-prefix 1000 75

switch(config-router-af)#

 
Related Commands

Command
Description

copy running-config startup-config

Saves the configuration changes to the startup configuration file.

feature eigrp

Enables the EIGRP feature.

redistribute (EIGRP)

Configures route redistribution for EIGRP.

show running-config eigrp

Displays the EIGRP running configuration.

 

restart eigrp (EIGRP)

To restart an Enhanced Interior Gateway Routing Protocol (EIGRP) instance and remove all associated neighbors, use the restart command.

restart eigrp instance-tag

 
Syntax Description

instance-tag

Name for an EIGRP routing instance. The name can be a maximum of 20 alphanumeric characters.

 
Command Default

None

 
Command Modes

Global configuration mode

 
Command History

Release
Modification

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

This command requires the LAN Base Services license.

Examples

This example shows how to restart the OSPFv2 instance and remove all neighbors:

switch# configure terminal
switch(config)# restart eigrp Test1
switch(config)#
 

 
Related Commands

Command
Description

copy running-config startup-config

Saves the configuration in the startup configuration file.

show ip eigrp interfaces

Displays information about EIGRP interfaces.

 

router eigrp

To configure a routing process and enter router configuration mode for Enhanced Interior Gateway Routing Protocol (EIGRP), use the router eigrp command. To turn off the EIGRP routing process, use the no form of this command.

router eigrp instance-tag

no router eigrp instance-tag

 
Syntax Description

instance-tag

Name of an EIGRP instance. The instance-tag can be any case-sensitive, alphanumeric string up to 20 characters.

 
Command Default

None

 
Command Modes

Global configuration mode

 
Command History

Release
Modification

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

This command requires the LAN Base Services license.

Examples

This example shows how to configure a routing process for EIGRP:

switch(config)# router eigrp 1
switch(config-router)#

 
Related Commands

Command
Description

default-information

Controls the distribution of a default route.

default-metric

Configures the default metric for routes redistributed into EIGRP.

distance

Configures the administrative distance.

maximum-paths

Configures the maximum number of equal-cost paths.

redistribute

Configures route redistribution for EIGRP.

router-id

Configures the router ID.

timers

Configures the EIGRP timers.

router-id (EIGRP)

To configure a router ID for an Enhanced Interior Gateway Routing Protocol (EIGRP) process, use the router-id command. To cause the software to use the default method of determining the router ID, use the no form of this command.

router-id router-id

no router-id

 
Syntax Description

router-id

32-bit router ID value specified in four-part, dotted-decimal notation.

 
Command Default

If this command is not configured, EIGRP chooses an IPv4 address as the router ID from one of its interfaces.

 
Command Modes

Address family configuration mode
Router configuration mode
Router VRF configuration mode

 
Command History

Release
Modification

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

Use the router-id command to manually specify a unique 32-bit numeric value for the router ID. This action ensures that EIGRP can function regardless of the interface address configuration.

This command requires the LAN Base Services license.

Examples

This example shows how to assign the IP address of 192.0.2.1 to the EIGRP process 1:

switch(config)# router eigrp 1
switch(config-router) address-family ipv4
switch(config-router-af)# router-id 192.0.2.1
 

 
Related Commands

Command
Description

show ip eigrp

Displays a summary of the EIGRP processes.