Guest

Asymmetric Digital Subscriber Line (ADSL)

Cisco DSL Router Configuration and Troubleshooting Guide - Step-by-Step Configuration of PPPoE with a Dynamic IP Address

Document ID: 71119

Updated: Oct 05, 2006

   Print

Introduction

Your Internet Service Provider (ISP) has assigned a dynamic public IP address to your Cisco Digital Subscriber Line (DSL) Router.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configuration Procedures

Important: Before you begin, close all programs on the PC that might be monitoring your COM port. Devices such as PDAs and digital cameras often place programs in the system tray that render your COM port unusable for the configuration of your Cisco DSL Router.

Connect the Cisco DSL Router and Your PC

A console connection is made with a rolled cable and connects the console port of the Cisco DSL Router to a COM port on a PC. The console cable that is included with the Cisco DSL Router is a flat light blue cable. For more information on the pinouts of a rolled cable, or the pinouts of an RJ-45 to DB9 converter, refer to Cabling Guide for Console and AUX Ports.

  1. Connect the RJ-45 connector on one end of a Cisco console cable to the console port of the Cisco DSL Router.

  2. Connect the RJ-45 connector at the other end of the console cable to an RJ-45 to DB9 converter.

  3. Connect the DB9 connector to an open COM port on your PC.

Start and Set Up HyperTerminal

Complete these steps:

  1. Start the HyperTerminal program on the PC.

  2. Set up your HyperTerminal session.

    1. Assign a name to your session and click OK.

    2. In the Connect To window, click Cancel.

    3. Choose File > Properties.

    4. From the Properties window, go to the Connect Using list and select the COM port where you connect the DB9 end of the console cable.

    5. From the Properties window click Configure and fill in these values:

      • Bits per second: 9600

      • Data bits: 8

      • Parity: None

      • Stop bits: 1

      • Flow Control: None

    6. Click OK.

    7. From the Call menu, click Disconnect.

    8. From the Call menu, click Call.

    9. Press Enter until you see a router prompt on your HyperTerminal window.

Clear Existing Configurations on the Cisco DSL Router

Complete these steps:

  1. Type enable at the router prompt in order to enter privileged mode.

    Router>enable
    Router#
    
    !--- The # symbol indicates that you are in privileged mode.
    
    
  2. Clear existing configurations on the router.

    Router#write erase
    
  3. Reload the router so that it boots with a blank startup configuration.

    Router#reload
    System configuration has been modified. Save? [yes/no]:no
    Proceed with reload? [confirm]yes
    
    !--- The router reload can take a few minutes.
    
    
  4. After the router has reloaded, enter enable mode again.

    Router>enable
    Router#

Configure the Cisco DSL Router

Complete these steps.

  1. Configure service timestamp to properly log and display debug output in the troubleshooting section.

    Router#configure terminal
    Router(config)#service timestamps debug datetime msec
    Router(config)#service timestamps log datetime msec
    Router(config)#end
    
  2. Disable the logging console on your Cisco DSL Router in order to suppress console messages that might be triggered while you configure the router.

    Router#configure terminal
          Router(config)#no logging console
          Router(config)#end
    
  3. Configure ip routing, ip subnet-zero, and ip classless in order to provide flexibility in routing configuration options.

    Router#configure terminal
    Router(config)#ip routing
    
    Router(config)#ip subnet-zero
    Router(config)#ip classless
    Router(config)#end
    
  4. Configure global Point-to-Point Protocol over Ethernet (PPPoE) parameters.

    Router#configure terminal
    Router(config)#vpdn enable
    Router(config)#no vpdn logging
    Router(config)#vpdn-group pppoe
    Router(config-vpdn)#request-dialin
    Router(config-vpdn-req-in)#protocol pppoe
    Router(config-vpdn-req-in)#end
    
  5. Configure an IP address and subnet mask on the Cisco DSL Router Ethernet interface.

    For Network Address Translation (NAT): (Optional) Enable NAT inside on the Ethernet interface.

    Router#configure terminal
    Router(config)#interface ethernet 0
    Router(config-if)#ip tcp adjust-mss 1452
    
    !--- If the ip tcp adjust-mss 1452 command is not supported, try 
    !--- ip adjust-mss 1452. If this command is not supported, 
    !--- upgrade to the latest Cisco DSL Router software or follow the 
    !--- procedure in the Possible Required Configuration Steps on the PC.
    
    Router(config-if)#ip address <ip address> <subnet mask>
    
    !--- For NAT:
    
    Router(config-if)#ip nat inside
    Router(config-if)#no shut
    Router(config-if)#end
    
  6. Configure the ATM interface of your Cisco DSL Router with an ATM permanent virtual circuit (PVC), encapsulation type, and Dialer pool.

    Router#configure terminal
    Router(config)#interface atm 0
    Router(config-if)#pvc <vpi/vci>
    Router(config-if-atm-vc)#pppoe-client dial-pool-number 1
    Router(config-if-atm-vc)#no shut
    Router(config-if-atm-vc)#end
    
  7. Configure the Dialer interface of your Cisco DSL Router for Point-to-Point Protocol over ATM (PPPoA) in order to enable a dynamic IP address to be assigned.

    For NAT: (Optional) Enable NAT outside on the Dialer interface.

    Router#configure terminal
    Router(config)#interface dialer 1
    Router(config-if)#ip address negotiated
    Router(config-if)#mtu 1492
    Router(config-if)#no ip directed-broadcast
    
    !--- For NAT:
     
    Router(config-if)#ip nat outside
    Router(config-if)#encapsulation ppp
    Router(config-if)#dialer pool 1  
    Router(config-if)#ppp chap hostname <username>
    Router(config-if)#ppp chap password <password>
    Router(config-if)#ppp pap sent-username <username> password <password>
    Router(config-if)#end
    
  8. Configure a default route using Dialer1 as the outbound interface.

    Router#configure terminal
    Router(config)#ip route 0.0.0.0 0.0.0.0 dialer1
    Router(config)#end
    
  9. For NAT: Configure global NAT commands on the Cisco DSL Router to allow sharing of the dynamic public IP address of the Dialer interface.

    Router#configure terminal
    Router(config)#ip nat inside source list 1 interface dialer1 overload
    Router(config)#access-list 1 permit <ip network address of ethernet0> 
     <wildcard mask>
    Router(config)#end
    

    Optional Configurations

    NAT Pool, if additional IP addresses have been provided by your ISP.

    Router(config)#ip nat inside source list 1 interface dialer1 overload 
    Router(config)#ip nat pool <nat pool name> <first ip address> 
     <last ip address> netmask <subnet mask>
    Router(config)#end
    

    Static NAT, if Internet users require access to internal servers.

    Router(config)#ip nat inside source static tcp <inside ip address of server> 
     {80 or 25} <outside well-known ip address of server> {80 or 25} extendable
    Router(config)#end
    
  10. For Dynamic Host Configuration Protocol (DHCP): (Optional) Configure the Cisco DSL Router as a DHCP server with a pool of IP addresses to assign to hosts connected to the Ethernet interface of the Cisco DSL Router. The DHCP server dynamically assigns an IP address, Domain Name Server (DNS), and the default gateway IP address to your hosts.

    Router#configure terminal
    Router(config)#ip dhcp excluded-address <ip address of ethernet0>
    Router(config)#ip dhcp pool <dhcp pool name>
    Router(dhcp-config)#network <ip network address of ethernet0> <subnet mask>  
    Router(dhcp-config)#default-router <ip address of ethernet0> 
    Router(dhcp-config)#dns-server <ip address of primary dns server> 
     <ip address of secondary dns server>
    Router(dhcp-config)#end
    
  11. Enable the logging console on the Cisco DSL Router, and write all the changes to memory.

    Router#configure terminal
    Router(config)#logging console
    Router(config)#end
    *Jan 1 00:00:00.100: %SYS-5-CONFIG_I: Configured from console by console
    Router#write memory
    Building configuration... [OK]
    Router#

Configuration

This is the configuration that is built after you have completed the procedures in the Configuration Procedures section of this document.

Cisco DSL Router with a Dynamic IP Address

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
vpdn enable
 no vpdn logging
 vpdn-group pppoe
  request-dialin
   protocol pppoe
!
!
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server> 
!
interface ethernet0  
 no shut  
 ip address <ip address> <subnet mask> 
 ip tcp adjust-mss 1452 
 
!--- If the ip tcp adjust-mss 1452 command is not supported, try 
 !--- this configuration statement:
 !--- ip adjust-mss 1452

   

 
!--- If this command is not supported in your current Cisco DSL Router software
 !--- release, either upgrade to the latest Cisco DSL Router software or follow the 
 !--- procedure in Possible Required Configuration Steps on the PC.

 

!--- For NAT:

ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 bundle-enable
 dsl operating-mode auto
!
interface atm0.1 point-to-point
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
 pppoe-client dial-pool-number 1
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!
interface dialer1
 ip address negotiated
 mtu 1492

!--- For NAT:

 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username>
 ppp chap password <password>
 ppp pap sent-username <username> password <password>
!

!--- For NAT:

ip nat inside source list 1 interface dialer1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> 
!---  <last ip address> netmask <subnet mask>



!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless
ip route 0.0.0.0 0.0.0.0 interface dialer 1

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Verify

Your Cisco DSL Router is now operational for Asymmetric Digital Subscriber Line (ADSL) service. You can issue a show run command in order to see the configuration.

Router#show run
Building configuration...

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

Troubleshoot

Refer to PPPoE Troubleshooting if your ADSL service does not work properly.

Related Information

Updated: Oct 05, 2006
Document ID: 71119