Guest

IP Routing

Sample Configuration of Triggered Extensions to RIP

Cisco - Sample Configuration of Triggered Extensions to RIP

Document ID: 13720

Updated: Jan 28, 2008

   Print

Introduction

This document shows sample configurations using the ip rip triggered interface configuration command.

Triggered extensions to Routing Information Protocol (RIP) increase efficiency on point-to-point, serial links. This feature is supported on all platforms running Cisco IOS® Software Release 12.0(1)T and higher. Triggered extensions help avoid two common problems with using RIP to connect to a WAN:

  • Periodic broadcasting by RIP can prevent WAN circuits from being closed.

  • Even on fixed, point-to-point links, the overhead of periodic RIP transmissions can seriously interrupt normal data transfer.

To enable this feature, use the ip rip triggered interface configuration command on both the sides of the link. See the configurations below for an example.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

51a.gif

Configurations

This document uses the configurations shown below.

S3-3640
interface Serial1/0 
  ip address 172.16.1.1 255.255.255.0
  ip rip triggered
 ! 
 router rip
  network 172.16.0.0 

S3-3620
interface Loopback8
 ip address 172.19.1.1 255.255.255.0
!
interface Ethernet0/3
 ip address 172.18.1.1 255.255.255.0
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.0
 ip rip triggered
!
router rip
 network 172.16.0.0
 network 172.18.0.0
 network 172.19.0.0

Verify

This section provides information you can use to confirm your configuration is working properly.

Routes learned by an interface that is configured with ip rip triggered is shown as a permanent entry in the RIP database and routing table.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show ip route - Displays the current state of the routing table.

  • show ip rip database - Displays summary address entries in the RIP routing database entries if relevant routes are being summarized based upon a summary address.

S3-3640#show ip route
C       172.16.1.0/24 is directly connected, Serial1/0
R    172.19.0.0/16 [120/1] via 172.16.1.2, Serial1/0
R    172.18.0.0/16 [120/1] via 172.16.1.2, Serial1/0

S3-3640#show ip rip database
172.18.0.0/16    auto-summary
172.18.0.0/16
    [1] via 172.16.1.2, 00:02:44 (permanent), Serial1/0
	* Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0
172.19.0.0/16    auto-summary
172.19.0.0/16
    [1] via 172.16.1.2, 00:02:45 (permanent),Serial1/0
  	* Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, please see Important Information on Debug Commands.

  • debug ip rip events - Displays information on RIP routing transactions.

S3-3640#debug ip rip events
RIP: received v1 triggered request from 172.16.1.2 on Serial1/0
RIP: start retransmit timer of 172.16.1.2
RIP: received v1 triggered ack from 172.16.1.2 on Serial1/0
RIP: Stopped retrans timer for 172.16.1.2
RIP: sending v1 ack to 172.16.1.2 via Serial1/0 (172.16.1.1),

Conclusion

When you enable triggered extensions to RIP, routing updates are transmitted on the WAN only if one of the following events occurs:

  • The router receives a specific request for a routing update, which causes the full database to be sent.

  • Information from another interface modifies the routing database, which causes only the latest changes to be sent.

  • The interface comes up or goes down, which causes a partial database to be sent.

  • The router is powered on for the first time to ensure that at least one update is sent, which causes the full database to be sent.

Related Information

Updated: Jan 28, 2008
Document ID: 13720