The documentation set for this product strives to use bias-free language. For the purposes of this documentation set, bias-free is defined as language that does not imply discrimination based on age, disability, gender, racial identity, ethnic identity, sexual orientation, socioeconomic status, and intersectionality. Exceptions may be present in the documentation due to language that is hardcoded in the user interfaces of the product software, language used based on RFP documentation, or language that is used by a referenced third-party product. Learn more about how Cisco is using Inclusive Language.
This chapter describes the Cisco NX-OS Layer 3 interfaces commands that begin with I.
To set a primary or secondary IP address for an interface, use the ip address command. To remove an IP address or disable IP processing, use the no form of this command.
ip address ip-address mask [secondary]
no ip address ip-address mask [secondary]
No IP address is defined for the interface.
Interface configuration mode
Subinterface configuration mode
|
|
---|---|
5.0(3)N1(1) |
This command was introduced. |
Note Before you use this command, make sure that you use the no switchport command on the interface to use the Layer 3 features.
An interface can have one primary IP address and one secondary IP address.
You can disable IP processing on a particular interface by removing its IP address with the no ip address command.
The optional secondary keyword allows you to specify a secondary IP address. Secondary addresses are treated like primary addresses, except the system never generates datagrams other than routing updates with secondary source addresses. IP broadcasts and Address Resolution Protocol (ARP) requests are handled, as are interface routes in the IP routing table.
Note When you are routing using the Open Shortest Path First (OSPF) algorithm, ensure that the secondary address of an interface fall into the same OSPF area as the primary addresses.
This example shows how to configure the IP address 192.168.0.27 as the primary address and 192.168.0.5 as the secondary address for Ethernet interface 1/5:
switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# ip address 192.168.0.27 255.255.255.0
switch(config-if )# ip address 192.168.0.5 255.255.255.0 secondary
switch(config-if)#
To configure a static Address Resolution Protocol (ARP) entry, use the ip arp command. To remove a static ARP entry, use the no form of this command.
ip arp ip-address mac-address
no ip arp ip-address
ip-address |
IPv4 address, in A.B.C.D format. |
mac-address |
MAC address in one of the following formats: • • • • |
None
|
|
---|---|
5.0(3)N1(1) |
This command was introduced. |
Use this command on Layer 3 interfaces and Layer 3 subinterfaces.
This example shows how to configure a static ARP entry on interface Ethernet 1/2:
switch(config)# interface ethernet 1/2
switch(config-if)# no switchport
switch(config-if)# ip arp 192.0.2.1 0150.5a03.efab
switch(config-if)#
This example shows how to configure a static ARP entry on a subinterface:
switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# interface ethernet 1/1.1
switch(config-subif)# ip arp 192.0.2.1 0150.5a03.efab
switch(config-subif)#
|
|
---|---|
show ip arp |
Displays ARP entries. |
To enable gratuitous Address Resolution Protocol (ARP), use the ip arp gratuitous command. To disable gratuitous ARP, use the no form of this command.
ip arp gratuitous {request | update}
no ip arp gratuitous {request | update}
request |
Enables sending gratuitous ARP requests when a duplicate address is detected. |
update |
Enables ARP cache updates for gratuitous ARP. |
Enabled
|
|
---|---|
5.0(3)N1(1) |
This command was introduced. |
This example shows how to disable gratuitous ARP request on interface Ethernet 2/1:
switch(config)# interface ethernet 1/2
switch(config-if)# no switchport
switch(config-if)# ip arp gratuitous
switch(config-if)#
|
|
ip arp |
Configures a static ARP entry. |
show ip arp |
Displays ARP configuration information. |
To configure an Address Resolution Protocol (ARP) timeout, use the ip arp timeout command. To revert to the default value, use the no form of this command.
ip arp timeout timeout-value
no ip arp timeout
timeout-value |
Time (in seconds) that an entry remains in the ARP cache. Valid values are from 60 to 28800, and the default is 1500. |
1500 seconds
Global configuration mode
|
|
---|---|
5.0(2)N1(1) |
This command was introduced. |
This example shows how to configure the ARP timeout value to 120 seconds:
switch(config)# ip arp timeout 120
switch(config)#
This example shows how to revert to the default ARP timeout value of 1500 seconds:
switch(config)# no ip arp timeout
switch(config)#
|
|
---|---|
show running-config arp all |
Displays the ARP configuration, including the default configurations. |
To enable the translation of a directed broadcast to physical broadcasts, use the ip directed-broadcast command. To disable this function, use the no form of this command.
ip directed-broadcast
no ip directed-broadcast
This command has no arguments or keywords.
Disabled; all IP directed broadcasts are dropped.
|
|
---|---|
5.0(3)N1(1) |
This command was introduced. |
An IP directed broadcast is an IP packet whose destination address is a valid broadcast address for some IP subnet but which originates from a node that is not itself part of that destination subnet.
A device that is not directly connected to its destination subnet forwards an IP directed broadcast in the same way it would forward unicast IP packets destined to a host on that subnet. When a directed broadcast packet reaches a device that is directly connected to its destination subnet, that packet is broadcast on the destination subnet. The destination address in the IP header of the packet is rewritten to the configured IP broadcast address for the subnet, and the packet is sent as a link-layer broadcast.
If directed broadcast is enabled for an interface, incoming IP packets whose addresses identify them as directed broadcasts intended for the subnet to which that interface is attached are broadcast on that subnet.
If the no ip directed-broadcast command has been configured for an interface, directed broadcasts destined for the subnet to which that interface is attached are dropped, rather than being broadcast.
Note Because directed broadcasts, and particularly Internet Control Message Protocol (ICMP) directed broadcasts, have been abused by malicious persons, we recommend that you disable the ip directed-broadcast command on any interface where directed broadcasts are not needed. We also recommend that you use access lists to limit the number of broadcast packets.
This example shows how to enable forwarding of IP directed broadcasts on Ethernet interface 2/1:
switch(config)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip directed-broadcast
switch(config-if)#
|
|
---|---|
show ip interface |
Displays IP information for an interface. |
To configure a Layer 3 Ethernet IEEE 802.3 routed interface, use the interface ethernet command.
interface ethernet [chassis_ID/] slot/port[.subintf-port-no]
None
Global configuration mode
Interface configuration mode
|
|
---|---|
5.0(3)N1(1) |
This command was introduced. |
You must use the no switchport command in the interface configuration mode to configure the interface as a Layer 3 routed interface. When you configure the interface as a Layer 3 interface, all Layer 2 specific configurations on this interface are deleted.
Use the switchport command to convert a Layer 3 interface into a Layer 2 interface. When you configure the interface as a Layer 2 interface, all Layer 3 specific configurations on this interface are deleted.
This example shows how to enter configuration mode for a Layer 3 Ethernet interface 1/5:
switch(config)#
interface ethernet 1/5
switch(config-if)#
no switchport
switch(config-if)#
ip address 10.1.1.1/24
switch(config-if)#
This example shows how to enter configuration mode for a host interface on a Fabric Extender:
switch(config)#
interface ethernet 101/1/1
switch(config-if)#
no switchport
switch(config-if)#
ip address 10.1.1.1/24
switch(config-if)#
This example shows how to configure a Layer 3 subinterface for Ethernet interface 1/5 in the global configuration mode:
switch(config)#
interface ethernet 1/5.2
switch(config-if)#
no switchport
switch(config-subif)#
ip address 10.1.1.1/24
switch(config-subif)#
This example shows how to configure a Layer 3 subinterface in interface configuration mode:
switch(config)#
interface ethernet 1/5
switch(config-if)#
interface ethernet 1/5.1
switch(config-if)# no switchport
switch(config-subif)#
ip address 10.1.1.1/24
switch(config-subif)#
This example shows how to convert a Layer 3 interface to a Layer 2 interface:
switch(config)#
interface ethernet 1/5
switch(config-if)#
no switchport
switch(config-if)#
ip address 10.1.1.1/24
switch(config-if)#
switchport
switch(config-if)#
To enable the local proxy Address Resolution Protocol (ARP) feature, use the ip local-proxy-arp command. To disable this feature, use the no form of this command.
ip local-proxy-arp
no ip local-proxy-arp
This command has no arguments or keywords.
Disabled
Interface configuration mode
Subinterface configuration mode
|
|
5.0(3)N1(1) |
This command was introduced. |
Before the local proxy ARP feature can be used, you must enable the IP proxy ARP feature by using the ip proxy-arp command. The IP proxy ARP feature is disabled by default.
Note This command is not applicable to Layer 3 loopback interfaces.
This example shows how to enable the local proxy ARP:
switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# ip arp local-proxy-arp
switch(config-if)#
To create a loopback interface and enter interface configuration mode, use the interface loopback command. To remove a loopback interface, use the no form of this command.
interface loopback number
no interface loopback number
number |
Interface number; valid values are from 0 to 1023. |
None
Global configuration mode
|
|
---|---|
5.0(3)N1(1) |
This command was introduced. |
Use the interface loopback command to create or modify loopback interfaces.
From the loopback interface configuration mode, the following parameters are available:
•description—Provides a description of the purpose of the interface.
•ip—Configures IP features, such as the IP address for the interface, Address Resolution Protocol (ARP) attributes, load balancing, Unicast Reverse Path Forwarding (RPF) or IP Source Guard.
•logging—Configure logging of events.
•shutdown—Shut down traffic on the interface.
This command does not require a license.
This example shows how to create a loopback interface:
switch(config)# interface loopback 50
switch(config-if)# ip address 10.1.1.1/24
switch(config-if)#
|
|
---|---|
show interface loopback |
Displays information about the traffic on the specified loopback interface. |
To create an EtherChannel interface and enter interface configuration mode, use the interface port-channel command. To remove an EtherChannel interface, use the no form of this command.
interface port-channel channel-number[.subintf-channel-no]
no interface port-channel channel-number[.subintf-channel-no]
None
Global configuration mode
Interface configuration mode
|
|
---|---|
4.0(0)N1(1a) |
This command was introduced. |
5.0(3)N1(1) |
Support for Layer 3 interfaces and subinterfaces was added. |
A port can belong to only one channel group.
When you use the interface port-channel command for Layer 2 interfaces, follow these guidelines:
•If you are using CDP, you must configure it only on the physical interface and not on the EtherChannel interface.
•If you do not assign a static MAC address on the EtherChannel interface, a MAC address is automatically assigned. If you assign a static MAC address and then later remove it, the MAC address is automatically assigned.
•The MAC address of the EtherChannel is the address of the first operational port added to the channel group. If this first-added port is removed from the channel, the MAC address comes from the next operational port added, if there is one.
You must use the no switchport command in the interface configuration mode to configure the EtherChannel interface as a Layer 3 interface. When you configure the interface as a Layer 3 interface, all Layer 2 specific configurations on this interface are deleted.
Use the switchport command to convert a Layer 3 EtherChannel interface into a Layer 2 interface. When you configure the interface as a Layer 2 interface, all Layer 3 specific configurations on this interface are deleted.
You can configure one or more subinterfaces on a port channel made from routed interfaces.
This example shows how to create an EtherChannel group interface with channel-group number 50:
switch(config)# interface port-channel 50
switch(config-if)#
This example shows how to create a Layer 3 EtherChannel group interface with channel-group number 10:
switch(config)# interface port-channel 10
switch(config-if)# no switchport
switch(config-if)# ip address 192.0.2.1/24
switch(config-if)#
This example shows how to configure a Layer 3 EtherChannel subinterface with channel-group number 1 in interface configuration mode:
switch(config)# interface port-channel 10
switch(config-if)# no switchport
switch(config-if)# interface port-channel 10.1
switch(config-subif)# ip address 192.0.2.2/24
switch(config-subif)#
This example shows how to configure a Layer 3 EtherChannel subinterface with channel-group number 20.1 in global configuration mode:
switch(config)# interface port-channel 20.1
switch(config-subif)# ip address 192.0.2.3/24
switch(config-subif)#
To enable the generation of Internet Control Message Protocol (ICMP) port unreachable messages, use the ip port-unreachable command. To disable this function, use the no form of this command.
ip port-unreachable
no ip port-unreachable
This command has no arguments or keywords.
Enabled
|
|
5.0(3)N1(1) |
This command was introduced. |
This example shows how to enable the generation of ICMP port unreachable messages, as appropriate, on an interface:
switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip port-unreachable
|
|
---|---|
ip unreachables |
Sends ICMP unreachable messages. |
To enable proxy Address Resolution Protocol (ARP) on an interface, use the ip proxy-arp command. To disable proxy ARP on the interface, use the no form of this command.
ip proxy-arp
no ip proxy-arp
This command has no arguments or keywords.
Disabled
|
|
5.0(3)N1(1) |
This command was introduced. |
This example shows how to enable proxy ARP:
switch(config)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip proxy-arp
switch(config-if)#
|
|
---|---|
copy running-config startup-config |
Saves the configuration to the startup configuration file. |
show ip arp |
Displays ARP configuration information. |
To enable path maximum transmission unit (MTU) discovery on an IPv4 interface, use the ip tcp path-mtu discovery command. To disable this feature, use the no form of this command.
ip tcp path-mtu discovery
no ip tcp path-mtu discovery
This command has no arguments or keywords.
Disabled
|
|
5.0(3)N1(1) |
This command was introduced. |
This example shows how to enable path MTU discovery for IPv4:
switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip tcp path-mtu-discovery
switch(config-if)#
|
|
---|---|
show ip arp |
Displays ARP configuration information. |
To set a period of time the Cisco NX-OS software waits while attempting to establish a TCP connection before it times out, use the ip tcp synwait-time command. To restore the default time, use the no form of this command.
ip tcp synwait-time seconds
no ip tcp synwait-time
seconds |
Time, in seconds, the software waits while attempting to establish a TCP connection. It can be an integer from 5 to 300 seconds. |
5 seconds
Global configuration mode
|
|
5.1(3)N1(1) |
This command was introduced. |
This command does not require a license.
This example shows how to configure the switch software to continue attempting to establish a TCP connection for 10 seconds:
switch# configure terminal
switch(config)# ip tcp synwait-time 10
Setting syn time to 10 seconds
switch(config)#
This example shows how to disable TCP synchronization on interfaces:
switch# configure terminal
switch(config)# no ip tcp synwait-time
switch(config)#
|
|
---|---|
show running-config |
Displays the running system configuration information. |
To enable the generation of Internet Control Message Protocol (ICMP) unreachable messages, use the ip unreachables command. To disable this function, use the no form of this command.
ip unreachables
no ip unreachables
This command has no arguments or keywords.
Enabled
|
|
5.0(3)N1(1) |
This command was introduced. |
This example shows how to enable the generation of ICMP unreachable messages on an interface:
switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# no switchport
switch(config-if)# ip unreachables
|
|
---|---|
ip port-unreachable |
Sends ICMP port unreachable messages. |
To configure IPv6 neighbor discovery (ND), use the ipv6 nd command. To remove the IPv6 ND configuration, use the no form of this command.
ipv6 nd {hop-limit hop-limit | managed-config-flag | mtu | ns-interval ns-interval | other-config-flag | prefix {A:B::C:D/LEN | default {0-4294967295 | infinite {infinite [no-autoconfig | no-onlink | off-link]}| no-advertise}} | ra-interval ra-interval | ra-lifetime ra-lifetime | reachable-time reachable-time | redirects | retrans-timer retrans-timer | suppress-ra [mtu]}
no ipv6 nd {hop-limit hop-limit | managed-config-flag | mtu mtu-size | ns-interval ns-interval | other-config-flag | prefix {A:B::C:D/LEN | default {0-4294967295 | infinite {infinite [no-autoconfig | no-onlink | off-link]}| no-advertise}} | ra-interval ra-interval | ra-lifetime ra-lifetime | reachable-time reachable-time | redirects | retrans-timer retrans-timer | suppress-ra [mtu]}
hop-limit-64
mtu-1500
ns-interval-1000
ra-interval-600
reachable-time-0
retrans-timer-0
Interface configuration mode
|
|
5.2(1)U3(1) |
This command was introduced. |
This command does not require a license.
This example shows how to configure IPv6 neighbor discovery:
switch# configure terminal
switch(config)# interface ethernet 1/5
switch(config-if)# ipv6 nd
switch(config-if)# ipv6 nd reachable time 30
This example shows how to remove IPv6 neighbor discovery:
switch(config-if)# no ipv6 nd reachable time 30
switch(config-if)#
|
|
---|---|
show ipv6 nd interface |
Displays neighbor discovery interface information. |