Configuring the Fabric Extender
This chapter describes how to configure a Cisco Nexus 2000 Series Fabric Extender with a Cisco Nexus 5000 Series switch and includes the following sections:
Associating a Fabric Extender to a Fabric Interface
A Fabric Extender is connected to the switch through physical Ethernet interfaces or an EtherChannel. By default, the switch does not allow the attached Fabric Extender to connect until it has been assigned a chassis ID and is associated with the connected interface.
Note The Fabric Extender may connect to the switch through a number of separate physical Ethernet interfaces or at most one EtherChannel interface.
Caution In Release 4.0(1a)N2(1), you cannot connect the Ethernet interfaces of the Expansion Modules in the Cisco Nexus 5000 Series switch to a Fabric Extender. Only the Ethernet interfaces on the switch chassis (slot 1) can be used as fabric interfaces.
This section includes the following topics:
Associating a Fabric Extender to an Ethernet Interface
To associate the Fabric Extender to an Ethernet interface, perform this task:
|
|
|
Step 1
|
switch#
configure terminal
|
Enters configuration mode.
|
Step 2
|
switch(config)#
interface ethernet
slot
/
port
|
Specifies an Ethernet interface to configure.
|
Step 3
|
switch(config-if)#
switchport mode fex-fabric
|
Sets the interface to support an external Fabric Extender.
|
Step 4
|
switch(config-if)#
fex associate
chassis
|
Associates the chassis ID to the Fabric Extender unit attached to the interface. The range of the chassis ID is from 100 to 199.
|
Step 5
|
switch#
show interface ethernet
port
/
slot
fex-intf
|
(Optional) Displays the association of a Fabric Extender to an Ethernet interface.
|
This example shows how to associate the Fabric Extender to an Ethernet interface on the switch:
switch# configure terminal
switch(config)# interface ethernet 1/40
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
This example shows how to display the association of the Fabric Extender and the switch:
switch# show interface ethernet 1/40 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/40 Eth100/1/48 Eth100/1/47 Eth100/1/46 Eth100/1/45
Eth100/1/44 Eth100/1/43 Eth100/1/42 Eth100/1/41
Eth100/1/40 Eth100/1/39 Eth100/1/38 Eth100/1/37
Eth100/1/36 Eth100/1/35 Eth100/1/34 Eth100/1/33
Eth100/1/32 Eth100/1/31 Eth100/1/30 Eth100/1/29
Eth100/1/28 Eth100/1/27 Eth100/1/26 Eth100/1/25
Eth100/1/24 Eth100/1/23 Eth100/1/22 Eth100/1/21
Eth100/1/20 Eth100/1/19 Eth100/1/18 Eth100/1/17
Eth100/1/16 Eth100/1/15 Eth100/1/14 Eth100/1/13
Eth100/1/12 Eth100/1/11 Eth100/1/10 Eth100/1/9
Eth100/1/8 Eth100/1/7 Eth100/1/6 Eth100/1/5
Eth100/1/4 Eth100/1/3 Eth100/1/2 Eth100/1/1
Associating a Fabric Extender to an EtherChannel
To associate the Fabric Extender to an EtherChannel, perform this task:
|
|
|
Step 1
|
switch#
configure terminal
|
Enters configuration mode.
|
Step 2
|
switch(config)#
interface port-channnel
channel
|
Specifies an EtherChannel to configure.
|
Step 3
|
switch(config-if)#
switchport mode fex-fabric
|
Sets the EtherChannel to support an external Fabric Extender.
|
Step 4
|
switch(config-if)#
fex associate
chassis
|
Associates the chassis ID to the Fabric Extender unit attached to the interface. The range of the chassis ID is from 100 to 199.
|
Step 5
|
switch#
show interface port-channel
channel
fex-intf
|
(Optional) Displays the association of a Fabric Extender to an EtherChannel interface.
|
This example shows how to associate the Fabric Extender to an EtherChannel interface on the switch:
switch# configure terminal
switch(config)# interface port-channel 4
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# exit
switch(config)# interface ethernet 1/37
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# channel-group 4
switch(config-if)# exit
switch(config)# interface ethernet 1/38
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# channel-group 4
switch(config-if)# exit
switch(config)# interface ethernet 1/39
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# channel-group 4
switch(config-if)# exit
switch(config)# interface ethernet 1/40
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 100
switch(config-if)# channel-group 4
Note You have to associate each Ethernet interface that is a members of the EtherChannel as a fabric interface as shown in the above example.
This example shows how to display the association of the Fabric Extender and the switch:
switch# show interface port-channel 4 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Po4 Eth100/1/48 Eth100/1/47 Eth100/1/46 Eth100/1/45
Eth100/1/44 Eth100/1/43 Eth100/1/42 Eth100/1/41
Eth100/1/40 Eth100/1/39 Eth100/1/38 Eth100/1/37
Eth100/1/36 Eth100/1/35 Eth100/1/34 Eth100/1/33
Eth100/1/32 Eth100/1/31 Eth100/1/30 Eth100/1/29
Eth100/1/28 Eth100/1/27 Eth100/1/26 Eth100/1/25
Eth100/1/24 Eth100/1/23 Eth100/1/22 Eth100/1/21
Eth100/1/20 Eth100/1/19 Eth100/1/18 Eth100/1/17
Eth100/1/16 Eth100/1/15 Eth100/1/14 Eth100/1/13
Eth100/1/12 Eth100/1/11 Eth100/1/10 Eth100/1/9
Eth100/1/8 Eth100/1/7 Eth100/1/6 Eth100/1/5
Eth100/1/4 Eth100/1/3 Eth100/1/2 Eth100/1/1
Disassociating a Fabric Extender from an Interface
To disassociate the Fabric Extender from an interface, perform this task:
|
|
switch(config-if)#
no fex associate
|
Disassociates the Fabric Extender unit attached to the interface.
|
Configuring the Fabric Extender
To configure global features for a Fabric Extender, perform this tasks:
|
|
|
Step 1
|
switch#
configure terminal
|
Enters configuration mode.
|
Step 2
|
switch(config)#
fex
chassis
|
Enters configuration mode for the specified Fabric Extender chassis ID. The range of the chassis ID is from 100 to 199.
|
Step 3
|
switch(config-fex)#
description
desc
|
Specifies the description. The default is the string FEX
xxxx
where
xxxx
is the chassis ID. If the chassis ID is 123, the description is FEX0123.
|
switch(config-fex)#
no description
|
Deletes the description.
|
switch(config-fex)#
pinning max-links
uplinks
|
Defines the number of uplinks. The default is 1. The range is from 1 to 4.
This command is only applicable if the Fabric Extender is connected to its parent switch using one or more statically pinned fabric interfaces. There can only be one EtherChannel connection.
|
switch(config-fex)#
no pinning max-links
|
Resets the number of uplinks to the default.
|
switch(config-fex)#
serial
serial
|
Defines a serial number string. If this command is configured, then a switch will only allow the corresponding chassis ID to associate (using the
fex associate
command) if the Fabric Extender reports a matching serial number string.
Configuring a serial number other than that of the given Fabric Extender will force the Fabric Extender offline.
|
switch(config-fex)#
no serial
|
Deletes the serial number string.
|
switch(config-fex)#
beacon
|
Turns on the beacon LED. This LED allows you to locate a specific Fabric Extender in a rack.
|
switch(config-fex)#
no beacon
|
Turns off the beacon LED.
|
Caution Changing the number of uplinks with the
pinning max-links command or the
no pinning max-links command disrupts all the host interface ports of the Fabric Extender.
Redistributing the Links
When you provision the Fabric Extender with statically pinned interfaces (see the “Static Pinning Fabric Interface Connection” section), the downlink host interfaces on the Fabric Extender are pinned to the fabric interfaces in the order they were initially configured. If you want to maintain a specific relationship of host interfaces to fabric interface across reboots, you should re-pin the links.
You may want to perform this function in these two situations:
-
A change in the max-links configuration.
-
If you need to maintain the pinning order of host interfaces to fabric interfaces.
Changing the Number of Links
If you initially configured port 33 on the parent switch as your only fabric interface, all 48 host interfaces are pinned to this port. If you provision another port, for example 35, then you must enter the
pinning max-links 2
command to redistribute the host interfaces. All host interfaces are brought down and host interfaces 1 to 24 are pinned to fabric interface 33 and host interfaces 25 to 48 are pinned to fabric interface 35.
Maintaining the Pinning Order
The pinning order of the host interfaces is initially determined by the order in which the fabric interfaces were configured. In this example, four fabric interfaces were configured in the following order:
switch# show interface ethernet 1/35 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/35 Eth100/1/12 Eth100/1/11 Eth100/1/10 Eth100/1/9
Eth100/1/8 Eth100/1/7 Eth100/1/6 Eth100/1/5
Eth100/1/4 Eth100/1/3 Eth100/1/2 Eth100/1/1
switch# show interface ethernet 1/33 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/33 Eth100/1/24 Eth100/1/23 Eth100/1/22 Eth100/1/21
Eth100/1/20 Eth100/1/19 Eth100/1/18 Eth100/1/17
Eth100/1/16 Eth100/1/15 Eth100/1/14 Eth100/1/13
switch# show interface ethernet 1/38 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/38 Eth100/1/36 Eth100/1/35 Eth100/1/34 Eth100/1/33
Eth100/1/32 Eth100/1/31 Eth100/1/30 Eth100/1/29
Eth100/1/28 Eth100/1/27 Eth100/1/26 Eth100/1/25
switch# show interface ethernet 1/40 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/40 Eth100/1/48 Eth100/1/47 Eth100/1/46 Eth100/1/45
Eth100/1/44 Eth100/1/43 Eth100/1/42 Eth100/1/41
Eth100/1/40 Eth100/1/39 Eth100/1/38 Eth100/1/37
The next time that you reboot the Fabric Extender, the configured fabric interfaces are pinned to the host interfaces in an ascending order by port number of the fabric interface. If you want to configure the same fixed distribution of host interfaces without restarting the Fabric Extender, enter the
fex pinning redistribute
command (see the “Static Pinning Fabric Interface Connection” section).
To redistribute the host interfaces on the Fabric Extender, perform this task:
|
|
switch#
fex pinning redistribute
chassis
|
Redistributes the host connections. The range of the chassis ID is from 100 to 199.
|
This example shows how to redistribute the host interfaces on a Fabric Extender:
switch# fex pinning redistribute 100
Caution The
fex pinning redistribute command disrupts all the host interface ports of the Fabric Extender.
Upgrading the Fabric Extender
To upgrade a Cisco Nexus 2000 Series Fabric Extender, perform these steps:
Step 1
Download the new kickstart and system images to the parent switch.
Step 2
Enter the
install all
command.
While the installation is in progress, the Fabric Extender remains online.
The new image is pushed to the Fabric Extender by the parent switch. Once the software image has successfully been installed, the parent switch reboots. The Fabric Extender is also rebooted automatically to maintain the software version compatibility between the parent switch and the Fabric Extender. When the parent switch comes up, it rediscovers the Fabric Extender and brings it online.
This process is the least disruptive process for the hosts and servers connected to the Fabric Extender.
Displaying Fabric Extender Information
This section describes the
show
commands that are available to display the configuration and status of the Fabric Extender and includes the following topics:
Displaying Configuration Information
To display configuration information about the defined interfaces, perform one of these tasks:
|
|
switch#
show fex
[
chassis
[
detail
]
|
Displays information about a specific Fabric Extender or all attached units.
|
switch#
show interface
type
number
fex-intf
|
Displays the Fabric Extender ports pinned to a specific switch interface.
|
switch#
show interface
fex-fabric
|
Displays the switch interfaces that have detected a Fabric Extender uplink.
|
This example shows how to display all the attached Fabric Extender units:
switch# show fex
FEX FEX FEX FEX
Number Description State Model Serial
------------------------------------------------------------------------
100 FEX0100 Online N5K-C5110T-BF-1GE FOX1242GJSQ
This example shows how to display the detailed status of a specific Fabric Extender:
switch# show fex 100 detail
FEX: 100 Description: FEX0100 state: Online
FEX version: 4.0(1a)N2(0.101) [Switch version: 4.0(1a)N2(0.101)]
Extender Model: N5K-C5110T-BF-1GE, Extender Serial: JAF1241BLFN
Part No: 73-12009-02
Card Id: 70, Mac Addr: 00:0d:ec:b1:28:42, Num Macs: 64
Module Sw Gen: 17 [Switch Sw Gen: 17]
pinning-mode: static Max-links: 1
Fabric port for control traffic: Eth1/40
Fabric interface state:
Eth1/40 - Interface Up. State: Active
Fex Port State Fabric Port Primary Fabric
Eth100/1/1 Up Eth1/40 Eth1/40
Eth100/1/2 Down Eth1/40 Eth1/40
Eth100/1/3 Down Eth1/40 Eth1/40
Eth100/1/4 Down Eth1/40 Eth1/40
Eth100/1/5 Down Eth1/40 Eth1/40
Eth100/1/6 Down Eth1/40 Eth1/40
Eth100/1/7 Down Eth1/40 Eth1/40
Eth100/1/8 Down Eth1/40 Eth1/40
Eth100/1/9 Down Eth1/40 Eth1/40
Eth100/1/10 Down Eth1/40 Eth1/40
Eth100/1/11 Down Eth1/40 Eth1/40
Eth100/1/12 Down Eth1/40 Eth1/40
Eth100/1/13 Down Eth1/40 Eth1/40
Eth100/1/14 Down Eth1/40 Eth1/40
Eth100/1/15 Up Eth1/40 Eth1/40
Eth100/1/16 Down Eth1/40 Eth1/40
Eth100/1/17 Down Eth1/40 Eth1/40
Eth100/1/18 Down Eth1/40 Eth1/40
Eth100/1/19 Down Eth1/40 Eth1/40
Eth100/1/20 Down Eth1/40 Eth1/40
Eth100/1/22 Down Eth1/40 Eth1/40
Eth100/1/24 Down Eth1/40 Eth1/40
Eth100/1/25 Down Eth1/40 Eth1/40
Eth100/1/26 Down Eth1/40 Eth1/40
Eth100/1/27 Down Eth1/40 Eth1/40
Eth100/1/28 Down Eth1/40 Eth1/40
Eth100/1/29 Down Eth1/40 Eth1/40
Eth100/1/30 Down Eth1/40 Eth1/40
Eth100/1/31 Up Eth1/40 Eth1/40
Eth100/1/32 Down Eth1/40 Eth1/40
Eth100/1/33 Down Eth1/40 Eth1/40
Eth100/1/34 Down Eth1/40 Eth1/40
Eth100/1/35 Down Eth1/40 Eth1/40
Eth100/1/36 Down Eth1/40 Eth1/40
Eth100/1/37 Down Eth1/40 Eth1/40
Eth100/1/38 Down Eth1/40 Eth1/40
Eth100/1/39 Down Eth1/40 Eth1/40
Eth100/1/40 Down Eth1/40 Eth1/40
Eth100/1/41 Down Eth1/40 Eth1/40
Eth100/1/42 Down Eth1/40 Eth1/40
Eth100/1/43 Down Eth1/40 Eth1/40
Eth100/1/44 Down Eth1/40 Eth1/40
Eth100/1/45 Down Eth1/40 Eth1/40
Eth100/1/46 Down Eth1/40 Eth1/40
Eth100/1/47 Up Eth1/40 Eth1/40
Eth100/1/48 Down Eth1/40 Eth1/40
Logs:
[12/10/2008 00:11:40.698999] Module timed out
[12/10/2008 00:11:44.501221] Module register received
[12/10/2008 00:11:44.502240] Registration response sent
[12/10/2008 00:11:44.587581] Module Online Sequence
[12/10/2008 00:11:49.140170] Module Online
[12/10/2008 00:18:46.662135] Module disconnected
[12/10/2008 00:18:46.663222] Offlining Module
[12/10/2008 00:18:46.663856] Module Offline Sequence
[12/10/2008 00:18:49.317584] Module Offline
[12/10/2008 00:19:30.427864] Module register received
[12/10/2008 00:19:30.428875] Registration response sent
[12/10/2008 00:19:30.456882] Module Online Sequence
[12/10/2008 00:19:32.62827] Module Online
[12/10/2008 00:20:37.196648] Module disconnected
[12/10/2008 00:20:37.197782] Offlining Module
[12/10/2008 00:20:37.199299] Module Offline Sequence
[12/10/2008 00:20:39.859971] Module Offline
[12/10/2008 00:21:13.945372] Module register received
[12/10/2008 00:21:13.946435] Registration response sent
[12/10/2008 00:21:13.974962] Module Online Sequence
[12/10/2008 00:21:15.737667] Module Online
This example shows how to display the Fabric Extender interfaces pinned to a specific switch interface:
switch# show interface ethernet 1/40 fex-intf
Fabric FEX
Interface Interfaces
---------------------------------------------------
Eth1/40 Eth100/1/48 Eth100/1/47 Eth100/1/46 Eth100/1/45
Eth100/1/44 Eth100/1/43 Eth100/1/42 Eth100/1/41
Eth100/1/40 Eth100/1/39 Eth100/1/38 Eth100/1/37
Eth100/1/36 Eth100/1/35 Eth100/1/34 Eth100/1/33
Eth100/1/32 Eth100/1/31 Eth100/1/30 Eth100/1/29
Eth100/1/28 Eth100/1/27 Eth100/1/26 Eth100/1/25
Eth100/1/24 Eth100/1/22 Eth100/1/20 Eth100/1/19
Eth100/1/18 Eth100/1/17 Eth100/1/16 Eth100/1/15
Eth100/1/14 Eth100/1/13 Eth100/1/12 Eth100/1/11
Eth100/1/10 Eth100/1/9 Eth100/1/8 Eth100/1/7
Eth100/1/6 Eth100/1/5 Eth100/1/4 Eth100/1/3
Eth100/1/2 Eth100/1/1
This example shows how to display the switch interfaces that are connected to a Fabric Extender uplink:
switch# show interface fex-fabric
Fabric Fabric Fex FEX
Fex Port Port State Uplink Model Serial
---------------------------------------------------------------
--- Eth1/1 Discovered 1 N5K-C5110T-BF-1GE FOX1242GJSQ
--- Eth1/2 Discovered 4 N5K-C5110T-BF-1GE FOX1242GJSQ
--- Eth1/3 Discovered 2 N5K-C5110T-BF-1GE FOX1242GJSQ
100 Eth1/40 Active 3 N5K-C5110T-BF-1GE FOX1242GJSQ
Note The above example shows a Fabric Extender with four uplink connections, only one of which is currently active.
This example shows how to display the SFP+ transceiver and diagnostic optical monitoring (DOM) information for Fabric Extender uplinks:
switch# show interface ethernet 1/40 transceiver
Ethernet1/40
sfp is present
name is CISCO-EXCELIGHT
part number is SPP5101SR-C1
revision is A
serial number is ECL120901AV
nominal bitrate is 10300 MBits/sec
Link length supported for 50/125mm fiber is 82 m(s)
Link length supported for 62.5/125mm fiber is 26 m(s)
cisco id is --
cisco extended id number is 4
switch# show interface ethernet 1/40 transceiver fex-fabric
Ethernet1/40
sfp is present
name is CISCO-EXCELIGHT
part number is SPP5101SR-C1
revision is A
serial number is ECL120601U0
nominal bitrate is 10300 MBits/sec
Link length supported for 50/125mm fiber is 82 m(s)
Link length supported for 62.5/125mm fiber is 26 m(s)
cisco id is --
cisco extended id number is 4
Note The first show command above shows the SFP+ transceiver that is plugged into the parent switch interface. The second show command displays the SFP+ transceiver that is plugged into the uplink port on the Fabric Extender.
Displaying Chassis Management Information
To display configuration information used on the switch supervisor to manage the Fabric Extender, perform one of these tasks:
|
|
switch#
show diagnostic result fex
chassis
|
Displays results from the diagnostic test for a Fabric Extender chassis.
|
switch#
show inventory fex
chassis
|
Displays inventory information for a Fabric Extender chassis.
|
switch#
show module fex
chassis
|
Displays module information about a Fabric Extender chassis.
|
This example shows how to display the module information about all connected Fabric Extender units:
switch# show module fex
FEX Mod Ports Card Type Model Status.
--- --- ----- ---------------------------------- ------------------ -----------
100 1 48 Fabric Extender 48x1GE Module N2K-C2148T-1GE ok
FEX Mod Sw Hw World-Wide-Name(s) (WWN)
--- --- -------------- ------ -----------------------------------------------
100 1 4.0(1a)N2(1) 0.2 --
FEX Mod MAC-Address(es) Serial-Num
--- --- -------------------------------------- ----------
100 1 000d.ecb1.3f00 to 000d.ecb1.3f2fff JAF1244ATER
This example shows how to display the module information about a specific Fabric Extender unit:
switch# show module fex 100
FEX Mod Ports Card Type Model Status.
--- --- ----- ---------------------------------- ------------------ -----------
100 1 48 Fabric Extender 48x1GE Module N2K-C2148T-1GE ok
FEX Mod Sw Hw World-Wide-Name(s) (WWN)
--- --- -------------- ------ -----------------------------------------------
100 1 4.0(1a)N2(1) 0.2 --
FEX Mod MAC-Address(es) Serial-Num
--- --- -------------------------------------- ----------
100 1 000d.ecb1.3f00 to 000d.ecb1.3f2fff JAF1244ATER
This example shows how to display the inventory information about a specific Fabric Extender unit:
switch# show inventory fex 100
NAME: "FEX 100 CHASSIS", DESCR: "N2K-C2148T-1GE CHASSIS"
PID: N2K-C2148T-1GE , VID: V00 , SN: JAF1244ATER
NAME: "FEX 100 Module 1", DESCR: "Fabric Extender Module: 48x1GE, 4X10GE Supervisor"
PID: N2K-C2148T-1GE , VID: V00 , SN: FOX1242GJT4
NAME: "FEX 100 Fan 1", DESCR: "Fabric Extender Fan module"
PID: N2K-C2148-FAN , VID: N/A , SN: N/A
NAME: "FEX 100 Power Supply 1", DESCR: "Fabric Extender AC power supply"
PID: N5K-PAC-200W , VID: 00V0, SN: PAC12473L2J
This example shows how to display diagnostic test results for a specific Fabric Extender unit:
switch# show diagnostic result fex 100
FEX-100: 48x1GE/Supervisor SerialNo : JAF1241BLFN
Overall Diagnostic Result for FEX-100 : OK
Test results: (. = Pass, F = Fail, U = Untested)
TestPlatform:
0) SPROM: ---------------> .
1) MV88E6095: ---------------> .
2) Fan: ---------------> .
3) PowerSupply: ---------------> F
4) TempSensor: ---------------> .
TestForwardingPorts:
Eth 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24
Port ------------------------------------------------------------------------
. . . . . . . . . . . . . . . . . . . . . . . .
Eth 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
Port ------------------------------------------------------------------------
. . . . . . . . . . . . . . . . . . . . . . . .
TestFabricPorts:
Fabric 1 2 3 4
Port ------------
. . . .
This example shows how to display the environment status for a specific Fabric Extender unit:
switch# show environment fex 100
Temperature Fex 100:
-----------------------------------------------------------------
Module Sensor MajorThresh MinorThres CurTemp Status
(Celsius) (Celsius) (Celsius)
-----------------------------------------------------------------
1 Outlet-1 60 50 29 ok
1 Inlet-1 50 40 21 ok
Fan Fex: 100:
------------------------------------------------------
Fan Model Hw Status
------------------------------------------------------
Chassis N2K-C2148-FAN -- ok
PS-1 N5K-PAC-200W -- failure
PS-2 N5K-PAC-200W -- ok
Power Supply Fex 100:
---------------------------------------------------------------------------
Voltage: 12 Volts
-----------------------------------------------------
PS Model Power Power Status
(Watts) (Amp)
-----------------------------------------------------
1 -- -- -- fail/shutdown
2 N5K-PAC-200W 200.04 16.67 ok
Mod Model Power Power Power Power Status
Requested Requested Allocated Allocated
(Watts) (Amp) (Watts) (Amp)
--- ------------------- ------- ---------- --------- ---------- ----------
1 N5K-C5110T-BF-1GE 96.00 8.00 96.00 8.00 powered-up
Power Usage Summary:
--------------------
Power Supply redundancy mode: redundant
Total Power Capacity 200.04 W
Power reserved for Supervisor(s) 96.00 W
Power currently used by Modules 0.00 W
-------------
Total Power Available 104.04 W
-------------
This example shows how to display the SPROM for a specific Fabric Extender unit:
switch# show sprom fex 100 all
DISPLAY FEX 100 SUP sprom contents
Common block:
Block Signature : 0xabab
Block Version : 3
Block Length : 160
Block Checksum : 0x1774
EEPROM Size : 4096
Block Count : 3
FRU Major Type : 0x6002
FRU Minor Type : 0x0
OEM String : Cisco Systems, Inc.
Product Number : N2K-C2148T-1GE
Serial Number : JAF1244ATER
Part Number : 73-12009-02
Part Revision : 07
Mfg Deviation : 0
H/W Version : 0.2
Mfg Bits : 0
Engineer Use : 0
snmpOID : 9.12.3.1.9.72.8.0
Power Consump : -800
RMA Code : 0-0-0-0
CLEI Code : COMEB00ARA
VID : V00
Supervisor Module specific block:
Block Signature : 0x6002
Block Version : 2
Block Length : 103
Block Checksum : 0x592
Feature Bits : 0x0
HW Changes Bits : 0x2
Card Index : 11011
MAC Addresses : 00-00-00-00-00-00
Number of MACs : 0
Number of EPLD : 0
Port Type-Num : 1-48;2-4
Sensor #1 : 60,50
Sensor #2 : 60,50
Sensor #3 : 60,50
Sensor #4 : 60,50
Sensor #5 : 50,40
Sensor #6 : 50,40
Sensor #7 : 50,40
Sensor #8 : 50,40
Max Connector Power: 1000
Cooling Requirement: 300
Ambient Temperature: 40
DISPLAY FEX 100 backplane sprom contents:
Common block:
Block Signature : 0xabab
Block Version : 3
Block Length : 160
Block Checksum : 0x173f
EEPROM Size : 65535
Block Count : 5
FRU Major Type : 0x6001
FRU Minor Type : 0x0
OEM String : Cisco Systems, Inc.
Product Number : N2K-C2148T-1GE
Serial Number : FOX1242GJT4
Part Number : 68-3342-02
Part Revision : 05
Mfg Deviation : 0
H/W Version : 0.0
Mfg Bits : 0
Engineer Use : 0
snmpOID : 9.12.3.1.3.820.0.0
Power Consump : 0
RMA Code : 0-0-0-0
CLEI Code : COMEB00ARA
VID : V00
Chassis specific block:
Block Signature : 0x6001
Block Version : 3
Block Length : 39
Block Checksum : 0x2b6
Feature Bits : 0x0
HW Changes Bits : 0x2
Stackmib OID : 0
MAC Addresses : 00-0d-ec-b1-3f-00
Number of MACs : 64
OEM Enterprise : 0
OEM MIB Offset : 0
MAX Connector Power: 0
WWN software-module specific block:
Block Signature : 0x6005
Block Version : 1
Block Length : 0
Block Checksum : 0x66
wwn usage bits:
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
00 00
License software-module specific block:
Block Signature : 0x6006
Block Version : 1
Block Length : 16
Block Checksum : 0x77
lic usage bits:
00 00 00 00 00 00 00 00
DISPLAY FEX 100 power-supply 1 sprom contents:
Common block:
Block Signature : 0xabab
Block Version : 3
Block Length : 124
Block Checksum : 0x1610
EEPROM Size : 124
Block Count : 1
FRU Major Type : 0xab01
FRU Minor Type : 0x1
OEM String : Cisco Systems, Inc.
Product Number : N5K-PAC-200W
Serial Number : PAC12473L2J
Part Number : 341-0335-01
Part Revision : 01
CLEI Code : COUPADSBAA
VID : 00V0
snmpOID : 0.0.0.0.0.0.0.0
H/W Version : 0.1
Current : 1667
RMA Code : 0-0-0-0
DISPLAY FEX 100 power-supply 2 sprom contents:
Common block:
Block Signature : 0x0
Block Version : 0
Block Length : 0
Block Checksum : 0x0
EEPROM Size : 0
Block Count : 0
FRU Major Type : 0x0
FRU Minor Type : 0x0
OEM String :
Product Number :
Serial Number :
Part Number :
Part Revision :
CLEI Code :
VID : V00
snmpOID : 0.0.0.0.0.0.0.0
H/W Version : 0.0
Current : 0
RMA Code : 0-0-0-0