Perform these tasks to configure the EVPN Bridging and VPWS Services over BGP-LU Underlay feature.
-
Configure IGP
-
Configure BGP
-
Configure EVPN instance and ESI
-
Configure BVI (IRB) Interface
-
Configure VRF
-
Configure BVI with VRF
-
Configure VRF under BGP
-
Configure bridge domain and associate with attachment circuits and EVPN instance
-
Configure bridge domain and associate with attachment circuits, EVPN instance and BVI
-
Configure EVPN VPWS
Configuration Example
/* Configure IGP */
IGP configuration is a pre-requisite to configure EVPN. IGP can be OSPF or ISIS.
Router# configure
Router(config)#router ospf 1
Router(config-ospf)#router-id 209.165.201.1
Router(config-ospf)#area 10
Router(config-ospf-ar)#interface loopback0\
Router(config-ospf-ar-if)#exit
Router(config-ospf-ar)#interface TenGigE0/0/0/1\
Router(config-ospf-ar-if)#exit
Router(config-ospf-ar)#interface TenGigE0/0/0/17\
Router(config-ospf-ar-if)#commit
/* Configure BGP */
Router# configure
Router(config)#router bgp 100
Router(config-bgp)#router-id 209.165.201.1
Router(config-bgp)#bgp graceful-restart
Router(config-bgp)#address-family ipv4 unicast
Router(config-bgp-af)#redistribute connected
Router(config-bgp-af)#network 209.165.200.225/27
Router(config-bgp-af)#allocate-label all
Router(config-bgp-af)#exit
Router(config-bgp)#address-family ipv6 unicast
Router(config-bgp-af)#allocate-label all
Router(config-bgp-af)#exit
Router(config-bgp)#neighbor-group spines
Router(config-bgp-nbrgrp)#remote-as 100
Router(config-bgp-nbrgrp)#update-source loopback0
Router(config-bgp-nbrgrp)#address-family ipv4 labeled-unicast multipath
Router(config-bgp-nbrgrp-af)#exit
Router(config-bgp-nbrgrp)#address-family ipv6 labeled-unicast multipath
Router(config-bgp-nbrgrp-af)#exit
Router(config-bgp-nbrgrp)#address-family l2vpn evpn
Router(config-bgp-nbrgrp-af)#advertise vpnv4 unicast re-originated
Router(config-bgp-nbrgrp-af)#advertise vpnv6 unicast re-originated
Router(config-bgp-nbrgrp-af)#exit
Router(config-bgp-nbrgrp)exit
Router(config-bgp)neighbor 209.165.200.225
Router(config-bgp-nbr)#use neighbor-group spines
Router(config-bgp-nbr)#commit
/* Configure VPN4 address-family */
Router(config)#router bgp 100
Router(config-bgp)#router-id 209.165.201.1
Router(config-bgp)#ibgp policy out enforce-modifications
Router(config-bgp)#address-family vpnv4 unicast
Router(config-bgp-af)#commit
/* Configure EVPN instance and ESI */
Router#configure
Router(config)#evpn
Router(config-evpn)#evi 100
Router(config-evpn-instance)#advertise-mac
Router(config-evpn-instance-mac)#exit
Router(config-evpn-instance)#exit
Router(config-evpn)#interface Bundle-Ether1
Router(config-evpn-ac)#ethernet-segment identifier type 0 aa.aa.aa.aa.aa.aa.aa.aa.ac
Router(config-evpn-ac-es)#bgp route-target 0011.0011.0012
Router(config-evpn-ac)#commit
/* Configure BVI (IRB) Interface */
Router#configure
Router(config)#interface BVI200
Router(config-if)#ipv4 address 192.0.2.1 255.255.255.0
Router(config-if)#commit
/* Configure VRF */
Router# configure
Router(config)# vrf vpn2
Router(config-vrf)# address-family ipv4 unicast
Router(config-vrf-af)# import route-target 81:2
Router(config-vrf-af)# exit
Router(config-vrf)# address-family ipv6 unicast
Router(config-vrf-af)# import route-target 81:2
Router(config-vrf-af)# commit
/* Configure BVI with VRF */
Router(config)# interface BVI200
Router(config-if)# host-routing
Router(config-if)# vrf vpn72
Router(config-if-vrf)# ipv4 address ipv4 address 192.0.2.1 255.255.255.0
Router(config-if-vrf)# mac-address 10.1111.1
Router(config-if)# commit
/* Configure VRF under BGP */
Router(config)# router bgp 100
Router(config-bgp)# vrf vpn2
Router(config-bgp-vrf)# rd 102:2
Router(config-bgp-vrf)# address-family ipv4 unicast
Router(config-bgp-vrf-af)# label mode per-vrf
Router(config-bgp-vrf-af)# maximum-paths ibgp 8
Router(config-bgp-vrf-af)# redistribute connected
Router(config-bgp-vrf-af)# exit
Router(config-bgp-vrf)# address-family ipv6 unicast
Router(config-bgp-vrf-af)# label mode per-vrf
Router(config-bgp-vrf-af)# maximum-paths ibgp 8
Router(config-bgp-vrf-af)# redistribute connected
Router(config-bgp-vrf-af)# commit
/* Configure bridge domain and associate with attachment circuits and EVPN instance */
Router(config)#l2vpn
Router(config-l2vpn)#bridge group bg1
Router(config-l2vpn-bg)#bridge-domain bd1
Router(config-l2vpn-bg-bd)#interface BundleEther1.100
Router(config-l2vpn-bg-bd-ac)#evi 100
Router(config-l2vpn-bg-bd-evi)#commit
/* Configure bridge domain and associate with attachment circuits, EVPN instance and BVI */
Router(config)#l2vpn
Router(config-l2vpn)#bridge group bg2
Router(config-l2vpn-bg)#bridge-domain bd2
Router(config-l2vpn-bg-bd)#interface TenGigE0/0/0/38.200
Router(config-l2vpn-bg-bd-ac)#routed interface BVI200
Router(config-l2vpn-bg-bd-bvi)#evi 200
Router(config-l2vpn-bg-bd-bvi)#commit
Router(config-l2vpn-bg-bd-bvi)#exit
Router(config)#l2vpn
Router(config-l2vpn)#bridge group bg3
Router(config-l2vpn-bg)#bridge-domain bd3
Router(config-l2vpn-bg-bd)#interface TenGigE0/0/0/38.202
Router(config-l2vpn-bg-bd-ac)#routed interface BVI202
Router(config-l2vpn-bg-bd-bvi)#evi 202
Router(config-l2vpn-bg-bd-bvi)#commit
/* Configure EVPN VPWS */
Router#configure
Router(config)#router bgp 100
Router(config-bgp)#neighbor-group spines
Router(config-bgp-nbrgrp)#remote-as 100
Router(config-bgp-nbrgrp)#update-source loopback0
Router(config-bgp-nbrgrp)#address-family ipv4 labeled-unicast multipath
Router(config-bgp-nbrgrp-af)#exit
Router(config-bgp-nbrgrp)#address-family ipv6 labeled-unicast multipath
Router(config-bgp-nbrgrp-af)#exit
Router(config-bgp-nbrgrp)#address-family l2vpn evpn
Router(config-bgp-nbrgrp-af)#exit
Router(config-bgp-nbrgrp)exit
Router(config-bgp)neighbor 209.165.200.225
Router(config-bgp-nbr)#use neighbor-group spines
Router(config-bgp-nbr)#commit
Router(config-bgp-af)#exit
Router(config-bgp)#exit
Router(config)#l2vpn
Router(config-l2vpn)#xconnect group aa-evpn-vpws
Router(config-l2vpn-xc)#p2p vpws_513
Router(config-l2vpn-xc-p2p)#interface Bundle-Ether1.513
Router(config-l2vpn-xc-p2p)#neighbor evpn evi 513 target 513 source 513
Router(config-l2vpn-xc-p2p)# commit
Running Configuration
This section shows flooding disable running configuration.
/* Configure IGP */
router ospf 1
router-id 209.165.201.1
area 10
interface Loopback0
!
interface TenGigE0/0/0/1
!
interface TenGigE0/0/0/17
!
!
/* Configure BGP */
router bgp 100
router-id 209.165.201.1
bgp graceful-restart
address-family ipv4 unicast
redistribute connected
network 209.165.200.225/27
allocate-label all
address-family ipv6 unicast
allocate-label all
neighbor-group spines
remote-as 100
update-source loopback0
address-family ipv4 labeled-unicast multipath
!
address-family ipv6 labeled-unicast multipath
!
address-family l2vpn evpn
advertise vpnv4 unicast re-originated
advertise vpnv6 unicast re-originated
!
neighbor 209.165.200.225
use neighbor-group spines
!
/* Configure VPN4 address-family */
router bgp 100
router-id 209.165.201.1
ibgp policy out enforce-modifications
address-family vpnv4 unicast
!
/* Configure EVPN instance and ESI */
evpn
evi 100
advertise-mac
!
interface Bundle-Ether1
ethernet-segment
identifier type 0 aa.aa.aa.aa.aa.aa.aa.aa.ac
bgp route-target 0011.0011.0012
!
!
!
/* Configuring BVI (IRB) Interface */
configure
interface BVI200
ipv4 address 192.0.2.1 255.255.255.0
/* Configure VRF */
vrf vpn2
address-family ipv4 unicast
import route-target 81:2
!
!
!
address-family ipv6 unicast
import route-target 81:2
!
!
!
/* Configure BVI with VRF */
interface BVI200
host-routing
vrf vpn72
ipv4 address ipv4 address ipv4 address 192.0.2.1 255.255.255.0
mac-address 10.1111.1
!
/* Configure VRF under BGP */
router bgp 100
vrf vpn2
rd 102:2
address-family ipv4 unicast
label mode per-vrf
maximum-paths ibgp 8
redistribute connected
!
address-family ipv6 unicast
label mode per-vrf
maximum-paths ibgp 8
redistribute connected
!
!
/* Configure bridge domain and associate with attachment circuits and EVPN instance */
l2vpn
bridge group bg1
bridge-domain b1
interface Bundle-Ether1.100
!
evi 100
/*
bridge group bg2
bridge-domain bd2
interface TenGigE0/0/0/38.200
!
routed interface BVI200
!
evi 200
!
!
/* Configurige bridge domain and associate with attachment circuits, EVPN instance and BVI */
bridge group bg3
bridge-domain bd3
interface TenGigE0/0/0/38.202
!
routed interface BVI202
!
evi 202
!
!
!
/* Configure EVPN VPWS */
configure
router bgp 100
neighbor-group spines
remote-as 100
update-source Loopback0
address-family ipv4 labeled-unicast multipath
!
address-family ipv6 labeled-unicast multipath
!
address-family l2vpn evpn
neighbor 209.165.200.225
use neighbor-group spines
!
!
l2vpn
xconnect group aa-evpn-vpws
p2p vpws_513
interface Bundle-Ether1.513
neighbor evpn evi 513 target 513 source 513
Verification
Verify that you have configured EVPN Bridging and VPWS Services over BGP-LU Underlay feature successfully.
Note
|
Load Balancing is not supported for EVPN Bridging over BGP-LU with Multipaths.
|
Router#show cef vrf AIM9 10.0.0.1
Tue Jan 20 22:00:56.233 UTC
10.0.0.1/8, version 4, internal 0x5000001 0x0 (ptr 0x97d34b44) [1], 0x0 (0x0), 0x208 (0x98bef0f0)
Updated Mar 18 06:01:46.175
Prefix Len 32, traffic index 0, precedence n/a, priority 3
via 10.0.0.3/8, 7 dependencies, recursive, bgp-multipath [flags 0x6080]
path-idx 0 NHID 0x0 [0x972c6f08 0x0]
recursion-via-/32
next hop VRF - 'default', table - 0xe0000000
next hop 10.0.0.3/8 via 16448/0/21
next hop 192.0.2.1/24 BE128 labels imposed {16111 64013 80002}
via 100.0.0.88/32, 7 dependencies, recursive, bgp-multipath [flags 0x6080]
path-idx 1 NHID 0x0 [0x972c6d68 0x0]
recursion-via-/32
next hop VRF - 'default', table - 0xe0000000
next hop 10.0.0.4/8 via 16488/0/21
next hop 192.0.2.1/24 BE128 labels imposed {16111 64009 80002}
Router#show l2vpn xconnect group aa-evpn-vpws xc-name vpws_513 detail
Wed Jan 22 13:14:05.878 GMT+4
Group aa-evpn-vpws, XC vpws_513, state is up; Interworking none
AC: Bundle-Ether1.513, state is up
Type VLAN; Num Ranges: 1
Rewrite Tags: []
VLAN ranges: [513, 513]
MTU 1500; XC ID 0xa00005f7; interworking none
Statistics:
packets: received 0, sent 0
bytes: received 0, sent 0
drops: illegal VLAN 0, illegal length 0
EVPN: neighbor 24000, PW ID: evi 513, ac-id 513, state is up ( established )
XC ID 0xc0000001
Encapsulation MPLS
Source address 209.165.200.225
Encap type Ethernet, control word enabled
Sequencing not set
LSP : Up
EVPN Local Remote
-----------------------------------
Label 29045 1048577
MTU 1500 1500
Control word enabled enabled
AC ID 513 513
EVPN type Ethernet Ethernet
------------------------------------
Router# show evpn internal-label vpn-id 513 detail
Tue Jan 28 13:22:19.110 GMT+4
VPN-ID Encap Ethernet Segment Id EtherTag Label
--------------------------------------------------------------
513 MPLS 0099.9900.0000.0000.9999 0 None
Multi-paths resolved: FALSE (Remote all-active)
Multi-paths Internal label: None
EAD/ES 10.0.0.5 0
513 MPLS 0099.9900.0000.0000.9999 513 24000
Multi-paths resolved: TRUE (Remote all-active)
Multi-paths Internal label: 24000
EAD/ES 10.0.0.5 0
EAD/EVI (P) 10.0.0.5 29104
Summary pathlist:
0xffffffff (P) 10.0.0.5 29104
-----------------------------------------------------------------
Router# show mpls forwarding labels 24000 hardware egress detail location 0/0/CPU0
Tue Jan 28 13:22:19.110 GMT+4
Label Label or ID Interface Switched
------------------------------------------------------------------
24000 29104 EVPN:513 10.0.0.5 N/A
Updated: Oct 18 13:14:02.193
Version: 137839, Priority: 3
Label Stack (Top -> Bottom): { 29104 }
NHID: 0x0, Encap-ID: 0x140ea00000002, Path idx: 0, Backup path idx: 0, Weight: 0
MAC/Encaps: 0/4, MTU: 0
Packets Switched: 0
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:0, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308de88fb8 PD:0x308de89058 rev:5554240 type: MPLS (2)
LEAF location: LEM
FEC key: 0x23e0220000d71
label action: MPLS_NOP
LWLDI:
PI:0x309faa82c8 PD:0x309faa8308 rev:5554239 p-rev:5459825 5459825 ldi type:EOS0_EOS1
FEC key: 0x23e0220000d71 fec index: 0x0(0) num paths:2, bkup paths: 0
Collpased IMP LDI: ECD_MARKED
IMP pattern:3
PI:0x309faa82c8 PD:0x309faa8308 rev:5554239 p-rev:5459825 5459825
FEC key: 0x257c720000d71 fec index: 0x20000003(3) num paths:2
Path:0 fec index: 0x20018f14(102164) DSP fec index: 0x200001f8(504),
MPLS encap key: 0xf1b00000400140ea MPLS encap id: 0x400140ea Remote: 0
Label Stack: 29104 16012 dpa-rev:55458217
Path:1 fec index: 0x20018f15(102165) DSP fec index: 0x200001f9(505),
MPLS encap key: 0xf1b00000400140eb MPLS encap id: 0x400140eb Remote: 0
Label Stack: 29104 16012 dpa-rev:55458218
REC-SHLDI HAL PD context :
ecd_marked:10, collapse_bwalk_required:0, load_shared_lb:0
RSHLDI:
PI:0x3093d16af8 PD:0x3093d16bc8 rev:5494421 dpa-rev:36033167 flag:0x1
FEC key: 0x249e440000d71 fec index: 0x2001c169(115049) num paths: 1
p-rev:5459825
Path:0 fec index: 0x2001c169(115049) DSP fec index: 0x200001f8(504),
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308de433b8 PD:0x308de43458 rev:5459864 type: MPLS (2)
LEAF location: LEM
FEC key: 0
LWLDI:
PI:0x309ffe9798 PD:0x309ffe97d8 rev:5459825 p-rev:4927729 4927729 ldi type:IMP_EOS0_EOS1
FEC key: 0x1a1c740000d71 fec index: 0x0(0) num paths:2, bkup paths: 0
IMP LDI: ECD_MARKED SERVICE_MARKED
IMP pattern:3
PI:0x309ffe9798 PD:0x309ffe97d8 rev:5459825 p-rev:4927729 4927729
FEC key: 0x23e0220000d71 fec index: 0x20000002(2) num paths:2
Path:0 fec index: 0x2001f8b4(129204) DSP fec index: 0x200001f8(504),
MPLS encap key: 0xf1b0000040013ef0 MPLS encap id: 0x40013ef0 Remote: 0
Label Stack: 16012 dpa-rev:35993054. <<< LU Label>>>>
Path:1 fec index: 0x2001f8b5(129205) DSP fec index: 0x200001f9(505),
MPLS encap key: 0xf1b0000040013ef2 MPLS encap id: 0x40013ef2 Remote: 0
Label Stack: 16012 dpa-rev:35993055 <<< LU Label>>>>
REC-SHLDI HAL PD context :
ecd_marked:10, collapse_bwalk_required:0, load_shared_lb:0
RSHLDI:
PI:0x308dd32c38 PD:0x308dd32d08 rev:4927729 dpa-rev:35005343 flag:0x3
FEC key: 0x1a1c740000d71 fec index: 0x20000813(2067) num paths: 2
p-rev:4926086
Path:0 fec index: 0x2001eefd(126717) DSP fec index: 0x200001f8(504),
Path:1 fec index: 0x2001eefe(126718) DSP fec index: 0x200001f9(505),
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308dde33b8 PD:0x308dde3458 rev:4924403 type: MPLS (2)
LEAF location: LEM
FEC key: 0
LWLDI:
PI:0x308b04ea58 PD:0x308b04ea98 rev:4924400 p-rev:4924389 4924389 4924389 4924389 ldi type:IMP_EOS0_EOS1
FEC key: 0x1a75340000d71 fec index: 0x0(0) num paths:4, bkup paths: 0
IMP LDI: ECD_MARKED
IMP pattern:3
PI:0x308b04ea58 PD:0x308b04ea98 rev:4924400 p-rev:4924389 4924389 4924389 4924389
FEC key: 0x1a74720000d71 fec index: 0x200001f8(504) num paths:4
Path:0 fec index: 0x2001ee86(126598) DSP:0x21
MPLS encap key: 0xf1b0000040015878 MPLS encap id: 0x40015878 Remote: 0
Label Stack: 16005 dpa-rev:34999715
Path:1 fec index: 0x2001ee87(126599) DSP:0x22
MPLS encap key: 0xf1b000004001587a MPLS encap id: 0x4001587a Remote: 0
Label Stack: 16005 dpa-rev:34999716
Path:2 fec index: 0x2001ee88(126600) DSP:0xc000002
MPLS encap key: 0xf1b0000040016980 MPLS encap id: 0x40016980 Remote: 0
Label Stack: 16005 dpa-rev:34989935
Path:3 fec index: 0x2001ee89(126601) DSP:0xc000003
MPLS encap key: 0xf1b00000400157fc MPLS encap id: 0x400157fc Remote: 0
Label Stack: 16005 dpa-rev:34989936
SHLDI:
PI:0x30927740c8 PD:0x3092774198 rev:4924389 dpa-rev:34999705 flag:0x0
FEC key: 0x1a75340000d71 fec index: 0x200001ff(511) num paths: 4 bkup paths: 0
p-rev:4924311 4924329 8779 4920854
Path:0 fec index: 0x2001ee8f(126607) DSP:0x21 Dest fec index: 0x0(0)
Path:1 fec index: 0x2001ee90(126608) DSP:0x22 Dest fec index: 0x0(0)
Path:2 fec index: 0x2001ee91(126609) DSP:0xc000002 Dest fec index: 0x0(0)
Path:3 fec index: 0x2001ee92(126610) DSP:0xc000003 Dest fec index: 0x0(0)
TX-NHINFO:
PI: 0x308dc51298 PD: 0x308dc51318 rev:4924311 dpa-rev:34994174 Encap hdl: 0x3091632e98
Encap id: 0x40010003 Remote: 0 L3 int: 1670 flags: 0x3
npu_mask: 0x1 DMAC: 84:78:ac:2d:f8:1f
TX-NHINFO:
PI: 0x308dc51c20 PD: 0x308dc51ca0 rev:4924329 dpa-rev:34994264 Encap hdl: 0x30916332c8
Encap id: 0x40010001 Remote: 0 L3 int: 1679 flags: 0x3
npu_mask: 0x1 DMAC: d4:6d:50:7c:f9:4d
TX-NHINFO:
PI: 0x308dc51ff0 PD: 0x308dc52070 rev:8779 dpa-rev:61964 Encap hdl: 0x308e9f4980
Encap id: 0x40010007 Remote: 0 L3 int: 1728 flags: 0x807
npu_mask: 0x1 DMAC: 84:78:ac:2d:f8:22
TX-NHINFO:
PI: 0x308dc51480 PD: 0x308dc51500 rev:4920854 dpa-rev:34989846 Encap hdl: 0x308e9f4db0
Encap id: 0x40010005 Remote: 0 L3 int: 1727 flags: 0x807
npu_mask: 0x1 DMAC: 40:55:39:11:37:39
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308dde35b8 PD:0x308dde3658 rev:4926089 type: MPLS (2)
LEAF location: LEM
FEC key: 0
LWLDI:
PI:0x308b04eb48 PD:0x308b04eb88 rev:4926086 p-rev:4924389 4924389 4924389 4924389 ldi type:IMP_EOS0_EOS1
FEC key: 0x1a75340000d71 fec index: 0x0(0) num paths:4, bkup paths: 0
IMP LDI: ECD_MARKED
IMP pattern:3
PI:0x308b04eb48 PD:0x308b04eb88 rev:4926086 p-rev:4924389 4924389 4924389 4924389
FEC key: 0x1a74820000d71 fec index: 0x200001f9(505) num paths:4
Path:0 fec index: 0x2001ee81(126593) DSP:0x21
MPLS encap key: 0xf1b000004001587c MPLS encap id: 0x4001587c Remote: 0
Label Stack: 16006 dpa-rev:35002526
Path:1 fec index: 0x2001ee82(126594) DSP:0x22
MPLS encap key: 0xf1b000004001588a MPLS encap id: 0x4001588a Remote: 0
Label Stack: 16006 dpa-rev:35002527
Path:2 fec index: 0x2001ee83(126595) DSP:0xc000002
MPLS encap key: 0xf1b0000040016964 MPLS encap id: 0x40016964 Remote: 0
Label Stack: 16006 dpa-rev:34991843
Path:3 fec index: 0x2001ee84(126596) DSP:0xc000003
MPLS encap key: 0xf1b00000400157fe MPLS encap id: 0x400157fe Remote: 0
Label Stack: 16006 dpa-rev:34991844
SHLDI:
PI:0x30927740c8 PD:0x3092774198 rev:4924389 dpa-rev:34999705 flag:0x0
FEC key: 0x1a75340000d71 fec index: 0x200001ff(511) num paths: 4 bkup paths: 0
p-rev:4924311 4924329 8779 4920854
Path:0 fec index: 0x2001ee8f(126607) DSP:0x21 Dest fec index: 0x0(0)
Path:1 fec index: 0x2001ee90(126608) DSP:0x22 Dest fec index: 0x0(0)
Path:2 fec index: 0x2001ee91(126609) DSP:0xc000002 Dest fec index: 0x0(0)
Path:3 fec index: 0x2001ee92(126610) DSP:0xc000003 Dest fec index: 0x0(0)
TX-NHINFO:
PI: 0x308dc51298 PD: 0x308dc51318 rev:4924311 dpa-rev:34994174 Encap hdl: 0x3091632e98
Encap id: 0x40010003 Remote: 0 L3 int: 1670 flags: 0x3
npu_mask: 0x1 DMAC: 84:78:ac:2d:f8:1f
TX-NHINFO:
PI: 0x308dc51c20 PD: 0x308dc51ca0 rev:4924329 dpa-rev:34994264 Encap hdl: 0x30916332c8
Encap id: 0x40010001 Remote: 0 L3 int: 1679 flags: 0x3
npu_mask: 0x1 DMAC: d4:6d:50:7c:f9:4d
TX-NHINFO:
PI: 0x308dc51ff0 PD: 0x308dc52070 rev:8779 dpa-rev:61964 Encap hdl: 0x308e9f4980
Encap id: 0x40010007 Remote: 0 L3 int: 1728 flags: 0x807
npu_mask: 0x1 DMAC: 84:78:ac:2d:f8:22
TX-NHINFO:
PI: 0x308dc51480 PD: 0x308dc51500 rev:4920854 dpa-rev:34989846 Encap hdl: 0x308e9f4db0
Encap id: 0x40010005 Remote: 0 L3 int: 1727 flags: 0x807
npu_mask: 0x1 DMAC: 40:55:39:11:37:39
3 Label Collapse for L2 EVPN over BGP-LU on NCS57 Line Cards
3 label collapse for L2 EVPN VPWS over BGP-LU is not supported, and hence there is no significance of using the show l2vpn xconnect command on NCS57 line cards operating in native and compatibility modes.
The following is the show output for 3 label collapse for L2 EVPN ELAN over BGP-LU on NCS57 line cards operating in native
mode.
Router#show evpn internal-label
VPN-ID Encap Ethernet Segment Id EtherTag Label
---------- ------ --------------------------- ---------- --------
201 MPLS 0000.0001.8848.0019.0001 0 28307
← 28307 is the internal label for the VPN-ID 201 . This internal label will be used to push the EVPN label .
Summary pathlist:
0xffffffff (P) 100.0.0.48 28115 ← these are evpn labels to reach the peer
0xffffffff (P) 100.0.0.88 28116 ← these are evpn labels to reach the peer
202 MPLS 0000.0001.8848.0019.0001 0 28308
Summary pathlist:
0xffffffff (P) 100.0.0.48 28116
0xffffffff (P) 100.0.0.88 28117
203 MPLS 0000.0001.8848.0019.0001 0 28309
Summary pathlist:
0xffffffff (P) 100.0.0.48 28117
0xffffffff (P) 100.0.0.88 28118
→ Using this internal label( which is created per EVI) Chain is formed in the L3 FIB and notified to the L2FIB using ECD and L2FIB programs the FEC from the ECD chain to the MAC address.
Router#sh cef ext-client
Client Name : l2fib_mgr (comp-id: 0x7e6d) (0x90ed04b0)
Protocol : ipv4
Prefix : 100.0.0.48 (0x90f05c08)
Gateway array : 908f26a8 (0x40b8/1)
Loadinfo : 9192a7a8 (0x404441/1)
Number of notifs : 0
Interest type : Per-Prefix registration for EOS0 LDI updates
Table Id : 0xe0000000
Cookie Value : 6c326669625f6d67720000000
State : resolved
Via : MPLS::16448/0
Added to pend list: Never
Client Name : l2fib_mgr (comp-id: 0x7e6d) (0x90ed04b0)
Protocol : ipv4
Prefix : 100.0.0.88 (0x90f05d10)
Gateway array : 908f2790 (0x40b8/1)
Loadinfo : 9192a818 (0x404441/1)
Number of notifs : 0
Interest type : Per-Prefix registration for EOS0 LDI updates
Table Id : 0xe0000000
Cookie Value : 6c326669625f6d67720000000
State : resolved
Via : MPLS::16488/0
Added to pend list: Never
Client Name : l2fib_mgr (comp-id: 0x7e6d) (0x90ed04b0)
Protocol : ipv4
Prefix : 0.0.0.0 (0x90f05e18)
Local Label : 0
Route Version : 0
Gateway array : 908f2c18 (0x40b8/1)
Loadinfo : 9192ae38 (0x404441/1)
Number of notifs : 0
Interest type : Per Local-Label registration for EOS0 LDI updates
Table Id : 0xe0000000
Cookie Value : 6c326669625f6d67720000000
State : resolved
Via : MPLS::28307/0 ← Internal Label
Added to pend list: Never
→ When it is reachable on 2 paths .
Router#show mpls forwarding labels 28307 hardware egress detail location 0/0/CPU0
Local Outgoing Prefix Outgoing Next Hop Bytes
Label Label or ID Interface Switched
------ ----------- ------------------ ------------ --------------- ------------
28307 28115 EVPN:201 100.0.0.48 N/A
Version: 411, Priority: 3
Label Stack (Top -> Bottom): { 28115 }
NHID: 0x0, Encap-ID: 0x14c1300000002, Path idx: 0, Backup path idx: 0, Weight: 0
MAC/Encaps: 0/4, MTU: 0
Packets Switched: 0
28116 EVPN:201 100.0.0.88 N/A
Updated: Sep 24 16:12:05.573
Version: 411, Priority: 3
Label Stack (Top -> Bottom): { 28116 }
NHID: 0x0, Encap-ID: 0x14c1500000002, Path idx: 1, Backup path idx: 0, Weight: 0
MAC/Encaps: 0/4, MTU: 0
Packets Switched: 0
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:0, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308d0eec28 PD:0x308d0eecd0 rev:4776 type: MPLS (2)
LEAF location: LEM
FEC key: 0x1e3400011cb0
label action: MPLS_NOP
LWLDI:
PI:0x308e5487f8 PD:0x308e548840 rev:8098 p-rev:8095 8095 ldi type:EOS0_EOS1
FEC key: 0x1e4200011cb fec index: 0x20000802(2050) num paths: 2 bkup paths: 0 <--- this FEC KEY and FEC will be used to program the MAC under that EVI
IMP pattern:3, ECD_MARKED
PI:0x308e5487f8 PD:0x308e548840 rev:8098 p-rev:8095 8095
FEC key: 0x1e4200011cb0 fec index: 0x20000802(2050) num paths: 2 bkup paths: 0
Path:0 fec index: 0x2000cce2(52450) DSP fec index: 0x20001003(4099),
MPLS encap key: 0xf1b0000040014c13 MPLS encap id: 0x40014c13 Remote: 0
Label Stack(Top -> Bottom): { 28115 } dpa-rev: 205573
Path:1 fec index: 0x2000cce3(52451) DSP fec index: 0x20001002(4098),
MPLS encap key: 0xf1b0000040014c15 MPLS encap id: 0x40014c15 Remote: 0
Label Stack(Top -> Bottom): { 28116 } dpa-rev: 205574
REC-SHLDI HAL PD context :
ecd_marked:8, collapse_bwalk_required:0, load_shared_lb:0
RSHLDI:
PI:0x308cfe1598 PD:0x308cfe1670 rev:8095 dpa-rev:293493 flag:0x3
FEC key: 0x1e3400011cb fec index: 0x20000801(2049) num paths: 2
p-rev:7279 6055
Path:0 fec index: 0x2000cce0(52448) DSP fec index: 0x20001003(4099),
Path:1 fec index: 0x2000cce1(52449) DSP fec index: 0x20001002(4098),
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308d0ed5d8 PD:0x308d0ed680 rev:8093 type: MPLS (2)
LEAF location: LEM
FEC key: 00
LWLDI:
LSP pattern:0, IMP_LSP shared
PI:0x308e547988 PD:0x308e5479d0 rev:7279 p-rev:6054 6054 ldi type:IMP_EOS0_EOS1
FEC key: 0x2b3200011ca fec index: 0x20001003(4099) num paths: 2 bkup paths: 0
Path:0 fec index: 0x20080012(524306) DSP fec index:0x20053771(341873)
MPLS encap key: 0xf1b0000040014c06 MPLS encap id: 0x40014c06 Remote: 0
Label Stack(Top -> Bottom): { 24006 } dpa-rev: 205469 BGP-LU label
Path:1 fec index: 0x20080013(524307) DSP fec index:0x20053774(341876)
MPLS encap key: 0xf1b0000040015261 MPLS encap id: 0x40015261 Remote: 0
Label Stack(Top -> Bottom): { 16448 } dpa-rev: 291082 BGP-LU label
IMP pattern:3, ECD_MARKED
PI:0x308e547988 PD:0x308e5479d0 rev:7279 p-rev:6054 6054
FEC key: 0x2b3200011ca0 fec index: 0x20001003(4099) num paths: 2 bkup paths: 0
Path:0 fec index: 0x20080012(524306) DSP fec index: 0x20053771(341873),
MPLS encap key: 0xf1b0000040014c06 MPLS encap id: 0x40014c06 Remote: 0
Label Stack(Top -> Bottom): { 24006 } dpa-rev: 205469 <- BGP-LU label
Path:1 fec index: 0x20080013(524307) DSP fec index: 0x20053774(341876),
MPLS encap key: 0xf1b0000040015261 MPLS encap id: 0x40015261 Remote: 0
Label Stack(Top -> Bottom): { 16448 } dpa-rev: 291082 <- BGP-LU label
REC-SHLDI HAL PD context :
ecd_marked:8, collapse_bwalk_required:0, load_shared_lb:0
RSHLDI:
PI:0x308cfe4e38 PD:0x308cfe4f10 rev:6054 dpa-rev:287463 flag:0x1
FEC key: 0x2b1400011ca fec index: 0x20001001(4097) num paths: 2
p-rev:4690 6039
Path:0 fec index: 0x2008000e(524302) DSP fec index: 0x20053771(341873),
Path:1 fec index: 0x2008000f(524303) DSP fec index: 0x20053774(341876),
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308d0ed2a8 PD:0x308d0ed350 rev:4693 type: MPLS (2)
LEAF location: LEM
FEC key: 00
LWLDI:
LSP pattern:0, IMP_LSP shared
PI:0x308e547598 PD:0x308e5475e0 rev:4690 p-rev:4689 ldi type:IMP_EOS0_EOS1
FEC key: 0x1d0400011c9 fec index: 0x20053771(341873) num paths: 1 bkup paths: 0
Path:0 fec index: 0x20053771(341873) DSP:0xe000000
MPLS encap key: 0xf1b0000040014c03 MPLS encap id: 0x40014c03 Remote: 0
Label Stack(Top -> Bottom): { 16111 } dpa-rev: 205175
IMP pattern:3, ECD_MARKED
PI:0x308e547598 PD:0x308e5475e0 rev:4690 p-rev:4689
FEC key: 0x1d0400011c90 fec index: 0x20053771(341873) num paths: 1 bkup paths: 0
Path:0 fec index: 0x20053771(341873) DSP:0xe000000
MPLS encap key: 0xf1b0000040014c03 MPLS encap id: 0x40014c03 Remote: 0
Label Stack(Top -> Bottom): { 16111 } dpa-rev: 205175
SHLDI:
PI:0x308cfdefd8 PD:0x308cfdf0b0 rev:4689 dpa-rev:205174 cbf_enabled:0 pbts_enabled:0 flag:0x0
FEC key: 0x1cf400011c9 fec index: 0x20053770(341872) num paths: 1 bkup paths: 0
p-rev:4672
Path:0 fec index: 0x20053770(341872) DSP:0xe000000 Dest fec index: 0x0(0)
TX-NHINFO:
PI: 0x308e72f2a8 PD: 0x308e72f330 rev:4672 dpa-rev:205166 Encap hdl: 0x308e7ab670
Encap id: 0x40010003 Remote: 0 L3 int: 9 flags: 0x407
npu_mask: 0x1 DMAC: 00:8a:96:64:74:dc
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308d10a0d8 PD:0x308d10a180 rev:6042 type: MPLS (2)
LEAF location: LEM
FEC key: 00
LWLDI:
LSP pattern:0, IMP_LSP shared
PI:0x308e559508 PD:0x308e559550 rev:6039 p-rev:4689 ldi type:IMP_EOS0_EOS1
FEC key: 0x2b0400011c9 fec index: 0x20053774(341876) num paths: 1 bkup paths: 0
Path:0 fec index: 0x20053774(341876) DSP:0xe000000
MPLS encap key: 0xf1b000004001525d MPLS encap id: 0x4001525d Remote: 0
Label Stack(Top -> Bottom): { 16112 } dpa-rev: 286585
IMP pattern:3, ECD_MARKED
PI:0x308e559508 PD:0x308e559550 rev:6039 p-rev:4689
FEC key: 0x2b0400011c90 fec index: 0x20053774(341876) num paths: 1 bkup paths: 0
Path:0 fec index: 0x20053774(341876) DSP:0xe000000
MPLS encap key: 0xf1b000004001525d MPLS encap id: 0x4001525d Remote: 0
Label Stack(Top -> Bottom): { 16112 } dpa-rev: 286585
SHLDI:
PI:0x308cfdefd8 PD:0x308cfdf0b0 rev:4689 dpa-rev:205174 cbf_enabled:0 pbts_enabled:0 flag:0x0
FEC key: 0x1cf400011c9 fec index: 0x20053770(341872) num paths: 1 bkup paths: 0
p-rev:4672
Path:0 fec index: 0x20053770(341872) DSP:0xe000000 Dest fec index: 0x0(0)
TX-NHINFO:
PI: 0x308e72f2a8 PD: 0x308e72f330 rev:4672 dpa-rev:205166 Encap hdl: 0x308e7ab670
Encap id: 0x40010003 Remote: 0 L3 int: 9 flags: 0x407
npu_mask: 0x1 DMAC: 00:8a:96:64:74:dc
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308d0ed7f8 PD:0x308d0ed8a0 rev:6867 type: MPLS (2)
LEAF location: LEM
FEC key: 00
LWLDI:
LSP pattern:0, IMP_LSP shared
PI:0x308e547ad8 PD:0x308e547b20 rev:6055 p-rev:6054 6054 ldi type:IMP_EOS0_EOS1
FEC key: 0x2b2200011ca fec index: 0x20001002(4098) num paths: 2 bkup paths: 0
Path:0 fec index: 0x20080010(524304) DSP fec index:0x20053771(341873)
MPLS encap key: 0xf1b0000040014c07 MPLS encap id: 0x40014c07 Remote: 0
Label Stack(Top -> Bottom): { 24014 } dpa-rev: 205473
Path:1 fec index: 0x20080011(524305) DSP fec index:0x20053774(341876)
MPLS encap key: 0xf1b0000040015260 MPLS encap id: 0x40015260 Remote: 0
Label Stack(Top -> Bottom): { 16488 } dpa-rev: 287465
IMP pattern:3, ECD_MARKED
PI:0x308e547ad8 PD:0x308e547b20 rev:6055 p-rev:6054 6054
FEC key: 0x2b2200011ca0 fec index: 0x20001002(4098) num paths: 2 bkup paths: 0
Path:0 fec index: 0x20080010(524304) DSP fec index: 0x20053771(341873),
MPLS encap key: 0xf1b0000040014c07 MPLS encap id: 0x40014c07 Remote: 0
Label Stack(Top -> Bottom): { 24014 } dpa-rev: 205473
Path:1 fec index: 0x20080011(524305) DSP fec index: 0x20053774(341876),
MPLS encap key: 0xf1b0000040015260 MPLS encap id: 0x40015260 Remote: 0
Label Stack(Top -> Bottom): { 16488 } dpa-rev: 287465
REC-SHLDI HAL PD context :
ecd_marked:8, collapse_bwalk_required:0, load_shared_lb:0
RSHLDI:
PI:0x308cfe4e38 PD:0x308cfe4f10 rev:6054 dpa-rev:287463 flag:0x1
FEC key: 0x2b1400011ca fec index: 0x20001001(4097) num paths: 2
p-rev:4690 6039
Path:0 fec index: 0x2008000e(524302) DSP fec index: 0x20053771(341873),
Path:1 fec index: 0x2008000f(524303) DSP fec index: 0x20053774(341876),
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308d0ed2a8 PD:0x308d0ed350 rev:4693 type: MPLS (2)
LEAF location: LEM
FEC key: 00
LWLDI:
LSP pattern:0, IMP_LSP shared
PI:0x308e547598 PD:0x308e5475e0 rev:4690 p-rev:4689 ldi type:IMP_EOS0_EOS1
FEC key: 0x1d0400011c9 fec index: 0x20053771(341873) num paths: 1 bkup paths: 0
Path:0 fec index: 0x20053771(341873) DSP:0xe000000
MPLS encap key: 0xf1b0000040014c03 MPLS encap id: 0x40014c03 Remote: 0
Label Stack(Top -> Bottom): { 16111 } dpa-rev: 205175
IMP pattern:3, ECD_MARKED
PI:0x308e547598 PD:0x308e5475e0 rev:4690 p-rev:4689
FEC key: 0x1d0400011c90 fec index: 0x20053771(341873) num paths: 1 bkup paths: 0
Path:0 fec index: 0x20053771(341873) DSP:0xe000000
MPLS encap key: 0xf1b0000040014c03 MPLS encap id: 0x40014c03 Remote: 0
Label Stack(Top -> Bottom): { 16111 } dpa-rev: 205175
SHLDI:
PI:0x308cfdefd8 PD:0x308cfdf0b0 rev:4689 dpa-rev:205174 cbf_enabled:0 pbts_enabled:0 flag:0x0
FEC key: 0x1cf400011c9 fec index: 0x20053770(341872) num paths: 1 bkup paths: 0
p-rev:4672
Path:0 fec index: 0x20053770(341872) DSP:0xe000000 Dest fec index: 0x0(0)
TX-NHINFO:
PI: 0x308e72f2a8 PD: 0x308e72f330 rev:4672 dpa-rev:205166 Encap hdl: 0x308e7ab670
Encap id: 0x40010003 Remote: 0 L3 int: 9 flags: 0x407
npu_mask: 0x1 DMAC: 00:8a:96:64:74:dc
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308d10a0d8 PD:0x308d10a180 rev:6042 type: MPLS (2)
LEAF location: LEM
FEC key: 00
LWLDI:
LSP pattern:0, IMP_LSP shared
PI:0x308e559508 PD:0x308e559550 rev:6039 p-rev:4689 ldi type:IMP_EOS0_EOS1
FEC key: 0x2b0400011c9 fec index: 0x20053774(341876) num paths: 1 bkup paths: 0
Path:0 fec index: 0x20053774(341876) DSP:0xe000000
MPLS encap key: 0xf1b000004001525d MPLS encap id: 0x4001525d Remote: 0
Label Stack(Top -> Bottom): { 16112 } dpa-rev: 286585
IMP pattern:3, ECD_MARKED
PI:0x308e559508 PD:0x308e559550 rev:6039 p-rev:4689
FEC key: 0x2b0400011c90 fec index: 0x20053774(341876) num paths: 1 bkup paths: 0
Path:0 fec index: 0x20053774(341876) DSP:0xe000000
MPLS encap key: 0xf1b000004001525d MPLS encap id: 0x4001525d Remote: 0
Label Stack(Top -> Bottom): { 16112 } dpa-rev: 286585
SHLDI:
PI:0x308cfdefd8 PD:0x308cfdf0b0 rev:4689 dpa-rev:205174 cbf_enabled:0 pbts_enabled:0 flag:0x0
FEC key: 0x1cf400011c9 fec index: 0x20053770(341872) num paths: 1 bkup paths: 0
p-rev:4672
Path:0 fec index: 0x20053770(341872) DSP:0xe000000 Dest fec index: 0x0(0)
TX-NHINFO:
PI: 0x308e72f2a8 PD: 0x308e72f330 rev:4672 dpa-rev:205166 Encap hdl: 0x308e7ab670
Encap id: 0x40010003 Remote: 0 L3 int: 9 flags: 0x407
npu_mask: 0x1 DMAC: 00:8a:96:64:74:dc
The following is the show output for 3 label collapse for L2 EVPN ELAN over BGP-LU on NCS57 line cards operating in compatibility
mode.
Router#show cef vrf AIM9 10.0.0.1
Tue Jan 20 22:00:56.233 UTC
10.0.0.1/8, version 4, internal 0x5000001 0x0 (ptr 0x97d34b44) [1], 0x0 (0x0), 0x208 (0x98bef0f0)
Updated Mar 18 06:01:46.175
Prefix Len 32, traffic index 0, precedence n/a, priority 3
via 10.0.0.3/8, 7 dependencies, recursive, bgp-multipath [flags 0x6080]
path-idx 0 NHID 0x0 [0x972c6f08 0x0]
recursion-via-/32
next hop VRF - 'default', table - 0xe0000000
next hop 10.0.0.3/8 via 16448/0/21
next hop 192.0.2.1/24 BE128 labels imposed {16111 64013 80002}
via 100.0.0.88/32, 7 dependencies, recursive, bgp-multipath [flags 0x6080]
path-idx 1 NHID 0x0 [0x972c6d68 0x0]
recursion-via-/32
next hop VRF - 'default', table - 0xe0000000
next hop 10.0.0.4/8 via 16488/0/21
next hop 192.0.2.1/24 BE128 labels imposed {16111 64009 80002}
Router# show evpn internal-label vpn-id 513 detail
Tue Jan 28 13:22:19.110 GMT+4
VPN-ID Encap Ethernet Segment Id EtherTag Label
--------------------------------------------------------------
513 MPLS 0099.9900.0000.0000.9999 0 None
Multi-paths resolved: FALSE (Remote all-active)
Multi-paths Internal label: None
EAD/ES 10.0.0.5 0
513 MPLS 0099.9900.0000.0000.9999 513 24000
Multi-paths resolved: TRUE (Remote all-active)
Multi-paths Internal label: 24000
EAD/ES 10.0.0.5 0
EAD/EVI (P) 10.0.0.5 29104
Summary pathlist:
0xffffffff (P) 10.0.0.5 29104
-----------------------------------------------------------------
Router# show mpls forwarding labels 24000 hardware egress detail location 0/0/CPU0
Tue Jan 28 13:22:19.110 GMT+4
Label Label or ID Interface Switched
------------------------------------------------------------------
24000 29104 EVPN:513 10.0.0.5 N/A
Updated: Oct 18 13:14:02.193
Version: 137839, Priority: 3
Label Stack (Top -> Bottom): { 29104 }
NHID: 0x0, Encap-ID: 0x140ea00000002, Path idx: 0, Backup path idx: 0, Weight: 0
MAC/Encaps: 0/4, MTU: 0
Packets Switched: 0
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:0, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308de88fb8 PD:0x308de89058 rev:5554240 type: MPLS (2)
LEAF location: LEM
FEC key: 0x23e0220000d71
label action: MPLS_NOP
LWLDI:
PI:0x309faa82c8 PD:0x309faa8308 rev:5554239 p-rev:5459825 5459825 ldi type:EOS0_EOS1
FEC key: 0x23e0220000d71 fec index: 0x0(0) num paths:2, bkup paths: 0
Collpased IMP LDI: ECD_MARKED
IMP pattern:3
PI:0x309faa82c8 PD:0x309faa8308 rev:5554239 p-rev:5459825 5459825
FEC key: 0x257c720000d71 fec index: 0x20000003(3) num paths:2
Path:0 fec index: 0x20018f14(102164) DSP fec index: 0x200001f8(504),
MPLS encap key: 0xf1b00000400140ea MPLS encap id: 0x400140ea Remote: 0
Label Stack: 29104 16012 dpa-rev:55458217
Path:1 fec index: 0x20018f15(102165) DSP fec index: 0x200001f9(505),
MPLS encap key: 0xf1b00000400140eb MPLS encap id: 0x400140eb Remote: 0
Label Stack: 29104 16012 dpa-rev:55458218
REC-SHLDI HAL PD context :
ecd_marked:10, collapse_bwalk_required:0, load_shared_lb:0
RSHLDI:
PI:0x3093d16af8 PD:0x3093d16bc8 rev:5494421 dpa-rev:36033167 flag:0x1
FEC key: 0x249e440000d71 fec index: 0x2001c169(115049) num paths: 1
p-rev:5459825
Path:0 fec index: 0x2001c169(115049) DSP fec index: 0x200001f8(504),
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308de433b8 PD:0x308de43458 rev:5459864 type: MPLS (2)
LEAF location: LEM
FEC key: 0
LWLDI:
PI:0x309ffe9798 PD:0x309ffe97d8 rev:5459825 p-rev:4927729 4927729 ldi type:IMP_EOS0_EOS1
FEC key: 0x1a1c740000d71 fec index: 0x0(0) num paths:2, bkup paths: 0
IMP LDI: ECD_MARKED SERVICE_MARKED
IMP pattern:3
PI:0x309ffe9798 PD:0x309ffe97d8 rev:5459825 p-rev:4927729 4927729
FEC key: 0x23e0220000d71 fec index: 0x20000002(2) num paths:2
Path:0 fec index: 0x2001f8b4(129204) DSP fec index: 0x200001f8(504),
MPLS encap key: 0xf1b0000040013ef0 MPLS encap id: 0x40013ef0 Remote: 0
Label Stack: 16012 dpa-rev:35993054. <<< LU Label>>>>
Path:1 fec index: 0x2001f8b5(129205) DSP fec index: 0x200001f9(505),
MPLS encap key: 0xf1b0000040013ef2 MPLS encap id: 0x40013ef2 Remote: 0
Label Stack: 16012 dpa-rev:35993055 <<< LU Label>>>>
REC-SHLDI HAL PD context :
ecd_marked:10, collapse_bwalk_required:0, load_shared_lb:0
RSHLDI:
PI:0x308dd32c38 PD:0x308dd32d08 rev:4927729 dpa-rev:35005343 flag:0x3
FEC key: 0x1a1c740000d71 fec index: 0x20000813(2067) num paths: 2
p-rev:4926086
Path:0 fec index: 0x2001eefd(126717) DSP fec index: 0x200001f8(504),
Path:1 fec index: 0x2001eefe(126718) DSP fec index: 0x200001f9(505),
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308dde33b8 PD:0x308dde3458 rev:4924403 type: MPLS (2)
LEAF location: LEM
FEC key: 0
LWLDI:
PI:0x308b04ea58 PD:0x308b04ea98 rev:4924400 p-rev:4924389 4924389 4924389 4924389 ldi type:IMP_EOS0_EOS1
FEC key: 0x1a75340000d71 fec index: 0x0(0) num paths:4, bkup paths: 0
IMP LDI: ECD_MARKED
IMP pattern:3
PI:0x308b04ea58 PD:0x308b04ea98 rev:4924400 p-rev:4924389 4924389 4924389 4924389
FEC key: 0x1a74720000d71 fec index: 0x200001f8(504) num paths:4
Path:0 fec index: 0x2001ee86(126598) DSP:0x21
MPLS encap key: 0xf1b0000040015878 MPLS encap id: 0x40015878 Remote: 0
Label Stack: 16005 dpa-rev:34999715
Path:1 fec index: 0x2001ee87(126599) DSP:0x22
MPLS encap key: 0xf1b000004001587a MPLS encap id: 0x4001587a Remote: 0
Label Stack: 16005 dpa-rev:34999716
Path:2 fec index: 0x2001ee88(126600) DSP:0xc000002
MPLS encap key: 0xf1b0000040016980 MPLS encap id: 0x40016980 Remote: 0
Label Stack: 16005 dpa-rev:34989935
Path:3 fec index: 0x2001ee89(126601) DSP:0xc000003
MPLS encap key: 0xf1b00000400157fc MPLS encap id: 0x400157fc Remote: 0
Label Stack: 16005 dpa-rev:34989936
SHLDI:
PI:0x30927740c8 PD:0x3092774198 rev:4924389 dpa-rev:34999705 flag:0x0
FEC key: 0x1a75340000d71 fec index: 0x200001ff(511) num paths: 4 bkup paths: 0
p-rev:4924311 4924329 8779 4920854
Path:0 fec index: 0x2001ee8f(126607) DSP:0x21 Dest fec index: 0x0(0)
Path:1 fec index: 0x2001ee90(126608) DSP:0x22 Dest fec index: 0x0(0)
Path:2 fec index: 0x2001ee91(126609) DSP:0xc000002 Dest fec index: 0x0(0)
Path:3 fec index: 0x2001ee92(126610) DSP:0xc000003 Dest fec index: 0x0(0)
TX-NHINFO:
PI: 0x308dc51298 PD: 0x308dc51318 rev:4924311 dpa-rev:34994174 Encap hdl: 0x3091632e98
Encap id: 0x40010003 Remote: 0 L3 int: 1670 flags: 0x3
npu_mask: 0x1 DMAC: 84:78:ac:2d:f8:1f
TX-NHINFO:
PI: 0x308dc51c20 PD: 0x308dc51ca0 rev:4924329 dpa-rev:34994264 Encap hdl: 0x30916332c8
Encap id: 0x40010001 Remote: 0 L3 int: 1679 flags: 0x3
npu_mask: 0x1 DMAC: d4:6d:50:7c:f9:4d
TX-NHINFO:
PI: 0x308dc51ff0 PD: 0x308dc52070 rev:8779 dpa-rev:61964 Encap hdl: 0x308e9f4980
Encap id: 0x40010007 Remote: 0 L3 int: 1728 flags: 0x807
npu_mask: 0x1 DMAC: 84:78:ac:2d:f8:22
TX-NHINFO:
PI: 0x308dc51480 PD: 0x308dc51500 rev:4920854 dpa-rev:34989846 Encap hdl: 0x308e9f4db0
Encap id: 0x40010005 Remote: 0 L3 int: 1727 flags: 0x807
npu_mask: 0x1 DMAC: 40:55:39:11:37:39
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308dde35b8 PD:0x308dde3658 rev:4926089 type: MPLS (2)
LEAF location: LEM
FEC key: 0
LWLDI:
PI:0x308b04eb48 PD:0x308b04eb88 rev:4926086 p-rev:4924389 4924389 4924389 4924389 ldi type:IMP_EOS0_EOS1
FEC key: 0x1a75340000d71 fec index: 0x0(0) num paths:4, bkup paths: 0
IMP LDI: ECD_MARKED
IMP pattern:3
PI:0x308b04eb48 PD:0x308b04eb88 rev:4926086 p-rev:4924389 4924389 4924389 4924389
FEC key: 0x1a74820000d71 fec index: 0x200001f9(505) num paths:4
Path:0 fec index: 0x2001ee81(126593) DSP:0x21
MPLS encap key: 0xf1b000004001587c MPLS encap id: 0x4001587c Remote: 0
Label Stack: 16006 dpa-rev:35002526
Path:1 fec index: 0x2001ee82(126594) DSP:0x22
MPLS encap key: 0xf1b000004001588a MPLS encap id: 0x4001588a Remote: 0
Label Stack: 16006 dpa-rev:35002527
Path:2 fec index: 0x2001ee83(126595) DSP:0xc000002
MPLS encap key: 0xf1b0000040016964 MPLS encap id: 0x40016964 Remote: 0
Label Stack: 16006 dpa-rev:34991843
Path:3 fec index: 0x2001ee84(126596) DSP:0xc000003
MPLS encap key: 0xf1b00000400157fe MPLS encap id: 0x400157fe Remote: 0
Label Stack: 16006 dpa-rev:34991844
SHLDI:
PI:0x30927740c8 PD:0x3092774198 rev:4924389 dpa-rev:34999705 flag:0x0
FEC key: 0x1a75340000d71 fec index: 0x200001ff(511) num paths: 4 bkup paths: 0
p-rev:4924311 4924329 8779 4920854
Path:0 fec index: 0x2001ee8f(126607) DSP:0x21 Dest fec index: 0x0(0)
Path:1 fec index: 0x2001ee90(126608) DSP:0x22 Dest fec index: 0x0(0)
Path:2 fec index: 0x2001ee91(126609) DSP:0xc000002 Dest fec index: 0x0(0)
Path:3 fec index: 0x2001ee92(126610) DSP:0xc000003 Dest fec index: 0x0(0)
TX-NHINFO:
PI: 0x308dc51298 PD: 0x308dc51318 rev:4924311 dpa-rev:34994174 Encap hdl: 0x3091632e98
Encap id: 0x40010003 Remote: 0 L3 int: 1670 flags: 0x3
npu_mask: 0x1 DMAC: 84:78:ac:2d:f8:1f
TX-NHINFO:
PI: 0x308dc51c20 PD: 0x308dc51ca0 rev:4924329 dpa-rev:34994264 Encap hdl: 0x30916332c8
Encap id: 0x40010001 Remote: 0 L3 int: 1679 flags: 0x3
npu_mask: 0x1 DMAC: d4:6d:50:7c:f9:4d
TX-NHINFO:
PI: 0x308dc51ff0 PD: 0x308dc52070 rev:8779 dpa-rev:61964 Encap hdl: 0x308e9f4980
Encap id: 0x40010007 Remote: 0 L3 int: 1728 flags: 0x807
npu_mask: 0x1 DMAC: 84:78:ac:2d:f8:22
TX-NHINFO:
PI: 0x308dc51480 PD: 0x308dc51500 rev:4920854 dpa-rev:34989846 Encap hdl: 0x308e9f4db0
Encap id: 0x40010005 Remote: 0 L3 int: 1727 flags: 0x807
npu_mask: 0x1 DMAC: 40:55:39:11:37:39
3 Label Collapse for L3 EVPN over BGP-LU on NCS57 Line Cards
The following is the show output for 3 label collapse for L3 EVPN over BGP-LU on NCS57 line cards operating in compatibility
mode.
Router#show cef vrf AIM9 70.8.0.10 hardware egress detail location 0/0/CPU0
70.8.0.10/32, version 103, internal 0x5000001 0x30 (ptr 0x8d082888) [1], 0x0 (0x0), 0xa08 (0x8cb625c0)
Prefix Len 32, traffic index 0, precedence n/a, priority 3
gateway array (0x8bc2ede8) reference count 500, flags 0x2038, source rib (7), 0 backups
[1 type 1 flags 0x48441 (0x8cb9d2f0) ext 0x0 (0x0)]
LW-LDI[type=0, refc=0, ptr=0x0, sh-ldi=0x0]
gateway array update type-time 1 Sep 27 02:02:09.144
LDI Update time Sep 27 02:02:09.144
via 100.0.0.88/32, 13 dependencies, recursive [flags 0x6000]
path-idx 0 NHID 0x0 [0x8cca5c38 0x0]
recursion-via-/32
next hop VRF - 'default', table - 0xe0000000
next hop 100.0.0.88/32 via 16488/0/21
next hop 128.1.1.1/32 BE128 labels imposed {16111 24012 28101}
next hop 128.1.1.1/32 BE128 labels imposed {16112 16488 28101}
LEAF - HAL pd context :
sub-type : IPV4, ecd_marked:0, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308d082888 PD:0x308d082930 rev:6037 type: IPV4 (0)
LEAF location: LEM
FEC key: 0x312400011d20
REC-SHLDI HAL PD context :
ecd_marked:0, collapse_bwalk_required:0, load_shared_lb:0
RSHLDI:
PI:0x308cb9d2f0 PD:0x308cb9d3c8 rev:6031 dpa-rev:36590 flag:0x1
FEC key: 0x312400011d2 fec index: 0x2000006f(111) num paths: 2
p-rev:2740 16909060 Collapsed: TRUE
Path:0 fec index: 0x200801ab(524715) DSP fec index: 0x20053453(341075),
MPLS encap key: 0xf1b0000040015272 MPLS Encap Id: 0x40015272
Label Stack(Top -> Bottom): { 24012 28101 } dpa-rev: 36588
Path:1 fec index: 0x200801ac(524716) DSP fec index: 0x20053452(341074),
MPLS encap key: 0xf1b0000040015273 MPLS Encap Id: 0x40015273
Label Stack(Top -> Bottom): { 16488 28101 } dpa-rev: 36589
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308cca5c38 PD:0x308cca5ce0 rev:2743 type: MPLS (2)
LEAF location: LEM
FEC key: 00
LWLDI:
LSP pattern:3
PI:0x308bf91488 PD:0x308bf914d0 rev:2740 p-rev:2739 2739 ldi type:IMP_EOS0_EOS1
FEC key: 0x46200011d2 fec index: 0x20000003(3) num paths: 2 bkup paths: 0
Path:0 fec index: 0x20080005(524293) DSP fec index:0x20053453(341075)
MPLS encap key: 0xf1b0000040014c11 MPLS encap id: 0x40014c11 Remote: 0
Label Stack(Top -> Bottom): { 24012 } dpa-rev: 19642 <- BGP-LU label
Path:1 fec index: 0x20080006(524294) DSP fec index:0x20053452(341074)
MPLS encap key: 0xf1b0000040014c13 MPLS encap id: 0x40014c13 Remote: 0
Label Stack(Top -> Bottom): { 16488 } dpa-rev: 19644 <- BGP-LU label
IMP pattern:3, ECD_MARKED
PI:0x308bf91488 PD:0x308bf914d0 rev:2740 p-rev:2739 2739
FEC key: 0x45200011d20 fec index: 0x20000002(2) num paths: 2 bkup paths: 0
Path:0 fec index: 0x20080003(524291) DSP fec index: 0x20053453(341075),
MPLS encap key: 0xf1b0000040014c10 MPLS encap id: 0x40014c10 Remote: 0
Label Stack(Top -> Bottom): { 24012 } dpa-rev: 19641
Path:1 fec index: 0x20080004(524292) DSP fec index: 0x20053452(341074),
MPLS encap key: 0xf1b0000040014c12 MPLS encap id: 0x40014c12 Remote: 0
Label Stack(Top -> Bottom): { 16488 } dpa-rev: 19643
REC-SHLDI HAL PD context :
ecd_marked:8, collapse_bwalk_required:0, load_shared_lb:0
RSHLDI:
PI:0x308cb96668 PD:0x308cb96740 rev:2739 dpa-rev:19640 flag:0x1
FEC key: 0x44400011d2 fec index: 0x20000001(1) num paths: 2
p-rev:2702 2697
Path:0 fec index: 0x20080001(524289) DSP fec index: 0x20053453(341075),
Path:1 fec index: 0x20080002(524290) DSP fec index: 0x20053452(341074),
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308cca56e8 PD:0x308cca5790 rev:2705 type: MPLS (2)
LEAF location: LEM
FEC key: 00
LWLDI:
PI:0x308bf90b58 PD:0x308bf90ba0 rev:2702 p-rev:2691 ldi type:IMP_EOS0_EOS1
FEC key: 0x41400011d1 fec index: 0x20053453(341075) num paths: 1 bkup paths: 0
IMP pattern:3, ECD_MARKED
PI:0x308bf90b58 PD:0x308bf90ba0 rev:2702 p-rev:2691
FEC key: 0x41400011d10 fec index: 0x20053453(341075) num paths: 1 bkup paths: 0
Path:0 fec index: 0x20053453(341075) DSP:0xe000000
MPLS encap key: 0xf1b0000040014c08 MPLS encap id: 0x40014c08 Remote: 0
Label Stack(Top -> Bottom): { 16111 } dpa-rev: 19387
SHLDI:
PI:0x308cb96fd8 PD:0x308cb970b0 rev:2691 dpa-rev:19378 cbf_enabled:0 pbts_enabled:0 flag:0x0
FEC key: 0x3e400011d1 fec index: 0x20053450(341072) num paths: 1 bkup paths: 0
p-rev:2674
Path:0 fec index: 0x20053450(341072) DSP:0xe000000 Dest fec index: 0x0(0)
TX-NHINFO:
PI: 0x308d99a0b0 PD: 0x308d99a138 rev:2674 dpa-rev:19371 Encap hdl: 0x308de2b670
Encap id: 0x40010002 Remote: 0 L3 int: 9 flags: 0x407
npu_mask: 0x1 DMAC: 00:8a:96:64:74:db
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308cca54c8 PD:0x308cca5570 rev:2700 type: MPLS (2)
LEAF location: LEM
FEC key: 00
LWLDI:
PI:0x308bf90a08 PD:0x308bf90a50 rev:2697 p-rev:2691 ldi type:IMP_EOS0_EOS1
FEC key: 0x40400011d1 fec index: 0x20053452(341074) num paths: 1 bkup paths: 0
IMP pattern:3, ECD_MARKED
PI:0x308bf90a08 PD:0x308bf90a50 rev:2697 p-rev:2691
FEC key: 0x40400011d10 fec index: 0x20053452(341074) num paths: 1 bkup paths: 0
Path:0 fec index: 0x20053452(341074) DSP:0xe000000
MPLS encap key: 0xf1b0000040014c06 MPLS encap id: 0x40014c06 Remote: 0
Label Stack(Top -> Bottom): { 16112 } dpa-rev: 19383
SHLDI:
PI:0x308cb96fd8 PD:0x308cb970b0 rev:2691 dpa-rev:19378 cbf_enabled:0 pbts_enabled:0 flag:0x0
FEC key: 0x3e400011d1 fec index: 0x20053450(341072) num paths: 1 bkup paths: 0
p-rev:2674
Path:0 fec index: 0x20053450(341072) DSP:0xe000000 Dest fec index: 0x0(0)
TX-NHINFO:
PI: 0x308d99a0b0 PD: 0x308d99a138 rev:2674 dpa-rev:19371 Encap hdl: 0x308de2b670
Encap id: 0x40010002 Remote: 0 L3 int: 9 flags: 0x407
npu_mask: 0x1 DMAC: 00:8a:96:64:74:db
Load distribution: 0 (refcount 1)
Hash OK Interface Address
0 Y recursive 16488/0
The following is the show output for 3 label collapse for L3 EVPN over BGP-LU on NCS57 line cards operating in native mode.
Router#show cef vrf AIM9 70.8.0.10 hardware egress detail location 0/0/CPU0
70.8.0.10/32, version 103, internal 0x5000001 0x30 (ptr 0x8d3e6888) [1], 0x0 (0x0), 0xa08 (0x8cfaaa38)
Updated Sep 26 04:38:12.607
Prefix Len 32, traffic index 0, precedence n/a, priority 3
gateway array (0x8b6ccde8) reference count 1000, flags 0x2038, source rib (7), 0 backups
[1 type 1 flags 0x48441 (0x8cfe52f0) ext 0x0 (0x0)]
LW-LDI[type=0, refc=0, ptr=0x0, sh-ldi=0x0]
gateway array update type-time 1 Sep 26 04:38:12.600
LDI Update time Sep 26 04:38:12.600
via 100.0.0.88/32, 9 dependencies, recursive [flags 0x6000]
path-idx 0 NHID 0x0 [0x8d0edc38 0x0]
recursion-via-/32
next hop VRF - 'default', table - 0xe0000000
next hop 100.0.0.88/32 via 16488/0/21
next hop 128.1.1.1/32 BE128 labels imposed {16111 24012 28101}
next hop 128.1.1.1/32 BE128 labels imposed {16112 16488 28101}
LEAF - HAL pd context :
sub-type : IPV4, ecd_marked:0, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308d3e6888 PD:0x308d3e6930 rev:10281 type: IPV4 (0)
LEAF location: LEM
FEC key: 0x391400011cb0
EEI Push Label: 28101 <-- IRB VRF label in the TCAM itself
REC-SHLDI HAL PD context :
ecd_marked:0, collapse_bwalk_required:0, load_shared_lb:0
RSHLDI:
PI:0x308cfe52f0 PD:0x308cfe53c8 rev:10267 dpa-rev:589223 flag:0x1
FEC key: 0x391400011cb fec index: 0x2000cd53(52563) num paths: 1
p-rev:8134
Path:0 fec index: 0x2000cd53(52563) DSP fec index: 0x20000002(2),
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308d0edc38 PD:0x308d0edce0 rev:8137 type: MPLS (2)
LEAF location: LEM
FEC key: 00
LWLDI:
LSP pattern:0, IMP_LSP shared
PI:0x308e4ce168 PD:0x308e4ce1b0 rev:8134 p-rev:8133 8133 ldi type:IMP_EOS0_EOS1
FEC key: 0x253200011ca fec index: 0x20000002(2) num paths: 2 bkup paths: 0
Path:0 fec index: 0x20080003(524291) DSP fec index:0x200535e3(341475)
MPLS encap key: 0xf1b000004001483c MPLS encap id: 0x4001483c Remote: 0
Label Stack(Top -> Bottom): { 24012 } dpa-rev: 185366 <- BGP-LU label
Path:1 fec index: 0x20080004(524292) DSP fec index:0x200535e2(341474)
MPLS encap key: 0xf1b000004001483d MPLS encap id: 0x4001483d Remote: 0
Label Stack(Top -> Bottom): { 16488 } dpa-rev: 185367. <- BGP-LU label
IMP pattern:3, ECD_MARKED
PI:0x308e4ce168 PD:0x308e4ce1b0 rev:8134 p-rev:8133 8133
FEC key: 0x253200011ca0 fec index: 0x20000002(2) num paths: 2 bkup paths: 0
Path:0 fec index: 0x20080003(524291) DSP fec index: 0x200535e3(341475),
MPLS encap key: 0xf1b000004001483c MPLS encap id: 0x4001483c Remote: 0
Label Stack(Top -> Bottom): { 24012 } dpa-rev: 185366
Path:1 fec index: 0x20080004(524292) DSP fec index: 0x200535e2(341474),
MPLS encap key: 0xf1b000004001483d MPLS encap id: 0x4001483d Remote: 0
Label Stack(Top -> Bottom): { 16488 } dpa-rev: 185367
REC-SHLDI HAL PD context :
ecd_marked:8, collapse_bwalk_required:0, load_shared_lb:0
RSHLDI:
PI:0x308cfdeb20 PD:0x308cfdebf8 rev:8133 dpa-rev:185365 flag:0x1
FEC key: 0x252400011ca fec index: 0x20000001(1) num paths: 2
p-rev:8096 8091
Path:0 fec index: 0x20080001(524289) DSP fec index: 0x200535e3(341475),
Path:1 fec index: 0x20080002(524290) DSP fec index: 0x200535e2(341474),
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308d0ed6e8 PD:0x308d0ed790 rev:8099 type: MPLS (2)
LEAF location: LEM
FEC key: 00
LWLDI:
LSP pattern:0, IMP_LSP shared
PI:0x308e4cd838 PD:0x308e4cd880 rev:8096 p-rev:8085 ldi type:IMP_EOS0_EOS1
FEC key: 0x24f400011c9 fec index: 0x200535e3(341475) num paths: 1 bkup paths: 0
Path:0 fec index: 0x200535e3(341475) DSP:0xe000000
MPLS encap key: 0xf1b0000040014c36 MPLS encap id: 0x40014c36 Remote: 0
Label Stack(Top -> Bottom): { 16111 } dpa-rev: 185238
IMP pattern:3, ECD_MARKED
PI:0x308e4cd838 PD:0x308e4cd880 rev:8096 p-rev:8085
FEC key: 0x24f400011c90 fec index: 0x200535e3(341475) num paths: 1 bkup paths: 0
Path:0 fec index: 0x200535e3(341475) DSP:0xe000000
MPLS encap key: 0xf1b0000040014c36 MPLS encap id: 0x40014c36 Remote: 0
Label Stack(Top -> Bottom): { 16111 } dpa-rev: 185238
SHLDI:
PI:0x308cfe0c28 PD:0x308cfe0d00 rev:8085 dpa-rev:185229 cbf_enabled:0 pbts_enabled:0 flag:0x0
FEC key: 0x24c400011c9 fec index: 0x200535e0(341472) num paths: 1 bkup paths: 0
p-rev:8068
Path:0 fec index: 0x200535e0(341472) DSP:0xe000000 Dest fec index: 0x0(0)
TX-NHINFO:
PI: 0x308e3722a8 PD: 0x308e372330 rev:8068 dpa-rev:185221 Encap hdl: 0x308dbdc670
Encap id: 0x40010005 Remote: 0 L3 int: 53 flags: 0x407
npu_mask: 0x1 DMAC: 00:8a:96:64:74:db
LEAF - HAL pd context :
sub-type : MPLS, ecd_marked:1, has_collapsed_ldi:0
collapse_bwalk_required:0, ecdv2_marked:0,
HW Walk:
LEAF:
PI:0x308d0ed4c8 PD:0x308d0ed570 rev:8094 type: MPLS (2)
LEAF location: LEM
FEC key: 00
LWLDI:
LSP pattern:0, IMP_LSP shared
PI:0x308e4cd6e8 PD:0x308e4cd730 rev:8091 p-rev:8085 ldi type:IMP_EOS0_EOS1
FEC key: 0x24e400011c9 fec index: 0x200535e2(341474) num paths: 1 bkup paths: 0
Path:0 fec index: 0x200535e2(341474) DSP:0xe000000
MPLS encap key: 0xf1b0000040014c35 MPLS encap id: 0x40014c35 Remote: 0
Label Stack(Top -> Bottom): { 16112 } dpa-rev: 185234
IMP pattern:3, ECD_MARKED
PI:0x308e4cd6e8 PD:0x308e4cd730 rev:8091 p-rev:8085
FEC key: 0x24e400011c90 fec index: 0x200535e2(341474) num paths: 1 bkup paths: 0
Path:0 fec index: 0x200535e2(341474) DSP:0xe000000
MPLS encap key: 0xf1b0000040014c35 MPLS encap id: 0x40014c35 Remote: 0
Label Stack(Top -> Bottom): { 16112 } dpa-rev: 185234
SHLDI:
PI:0x308cfe0c28 PD:0x308cfe0d00 rev:8085 dpa-rev:185229 cbf_enabled:0 pbts_enabled:0 flag:0x0
FEC key: 0x24c400011c9 fec index: 0x200535e0(341472) num paths: 1 bkup paths: 0
p-rev:8068
Path:0 fec index: 0x200535e0(341472) DSP:0xe000000 Dest fec index: 0x0(0)
TX-NHINFO:
PI: 0x308e3722a8 PD: 0x308e372330 rev:8068 dpa-rev:185221 Encap hdl: 0x308dbdc670
Encap id: 0x40010005 Remote: 0 L3 int: 53 flags: 0x407
npu_mask: 0x1 DMAC: 00:8a:96:64:74:db
Load distribution: 0 (refcount 1)
Hash OK Interface Address
0 Y recursive 16488/0