You need to enable
segment routing on all the routers with prefix SIDs configured for all the
nodes. Use the following topology as a reference to understand the
configuration.
Figure 5. Configuration
Example
Let us take the
device R2 which is protecting the link between R2 and R3. The configuration at
R2:
router ospf 10
fast-reroute per-prefix enable prefix-priority low
fast-reroute per-prefix ti-lfa
segment-routing mpls
segment-routing area 0 mpls
fast-reroute per-prefix enable prefix-priority low
fast-reroute per-prefix ti-lfa
fast-reroute per-prefix ti-lfa area 0
fast-reroute per-prefix tie-break node-protecting index 60
fast-reroute per-prefix tie-break srlg index 70
mpls traffic-eng router-id Loopback1
mpls traffic-eng area 0
interface GigabitEthernet4 //interface connecting to the router 4
ip address 100.101.4.4 255.255.255.0
ip ospf 10 area 0
ip ospf network point-to-point
srlg gid 10
negotiation auto
interface GigabitEthernet3 //interface connecting to the router 3
ip address 100.101.3.3 255.255.255.0
ip ospf 10 area 0
ip ospf network point-to-point
srlg gid 10
negotiation auto
interface GigabitEthernet5 //interface connecting to the router 2
ip address 100.101.5.5 255.255.255.0
ip ospf 10 area 0
ip ospf network point-to-point
srlg gid 20
negotiation auto
interface loopback2
ip address 2.2.2.2/32
ip ospf 10 area 0
 Note |
In all the other
devices, configuration of segment routing and assignment of connected prefix
SIDs need to be done.
|
How Node Protection
Works: Using the same topology as an example, let us take the case where
you are protecting the link between R2 and R3 and also the prefix which is
leant from R6. In that case, let us assume that the primary path for the prefix
is via R2-R3. So, our primary path is R2---R3---R6 and we are protecting the
link R2---R3.
In this scenario, only
link-protection is configured and enabled. When you enable TI-LFA under OSPF
process, then you get the following paths provided the cost for all the paths
are equal:
R2----R4----R5---R6
R2---R5----R3---R6
R2----R5---R6
If you have only link
protection configured, then all the three paths will be chosen and they will
share the load amongst them.
If you wish to
configure node protection, then the backup would be calculated in such a way
that the back up path does not contain the node that you are protecting. In
this example, the node R3 in the back up is not required. As a result, only the
following two paths would be chosen as the back up paths:
R2----R4----R5---R6
R2----R5---R6
It is possible that
R2---R5---R3---R6 have the lesser cost than the above two paths. But since the
node protection is configured, only the paths amongst the above two will be
considered.
How SRLG Protection
Works: SRLG protection further eliminates the back up paths in a such a way
that the primary path and the backup does not share the same SRLG ID. Suppose
the following back up paths are available:
R2----R4----R5---R6
R2----R5---R6
Then, the SRLG ID of
(R2----R4) and (R2----R5) are compared against the primary interface (R2----R3)
which is 10. It is noticed that only the interface R2----R5 has different SRLG
ID which is 20. So, only the backup path R2---R5---R6 will be chosen.