The documentation set for this product strives to use bias-free language. For the purposes of this documentation set, bias-free is defined as language that does not imply discrimination based on age, disability, gender, racial identity, ethnic identity, sexual orientation, socioeconomic status, and intersectionality. Exceptions may be present in the documentation due to language that is hardcoded in the user interfaces of the product software, language used based on RFP documentation, or language that is used by a referenced third-party product. Learn more about how Cisco is using Inclusive Language.
This document describes the Intermediate-System to Intermediate-System (IS-IS) protocol adjacency and area types.
This document is not restricted to specific software and hardware versions.
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, ensure that you understand the potential impact of any command.
IS-IS protocol is extensively used as Interior Gateway Protocol (IGP) in Internet Service Provider (ISP) environment. The scope of this document is to provide information which regards IS-IS area types, configuration, and troubleshooting. It shows a sample network scenario and its configuration, some debugs, captures, and outputs for better understanding.
In this document, IS-IS means Integrated IS-IS. Integrated IS-IS is deployed, which means that IS-IS is routing Internet Protocol (IP). The real power of IS-IS lies in its use of Type-Length-Value (TLVs) which makes IS-IS highly extensible protocol. As new features come in, they can be added to protocol with TLVs.
In OSPF protocol, any of the router’s interfaces can be assigned to a particular area. However, the concept of area in IS-IS is different. Here in general, every single router belongs to an Area.
This idea stems from the initial creation of IS-IS to route Connectionless Network Protocol (CLNP) where the address belongs to a device (Router), whereas in Internet Protocol (IP), the address belongs to the particular interface.
IS-IS protocol has two levels or hierarchy, Level 1 and Level 2.
Level 1 corresponds to OSPF intra-area routing, whereas Level 2 corresponds with the OSPF backbone Area 0 routing.
Level 2 areas join all the areas with the backbone area.
Every Cisco router comes by default as a Level 1-2 (L1/L2) router..
A Level 1 router can become adjacent with the Level 1 and Level 1-2 (L1/L2) router.
A Level 2 router can become adjacent with Level 2 or Level 1-2 (L1/L2) router.
There is no adjacency between L1 only and L2 only router.
An IS-IS Level 1 router has the link state information of its own area for all the intra-area topology. To route packets to other areas, it uses the closest Level 2 capable (L1/L2) router. Level 1 Area behaves pretty much as a OSPF totally stubby area. L1 is the only router to send L1 Hellos.
An IS-IS L1/L2 router maintains two link state database information.
One is for Level 1 and the other for Level 2.
Two distinct Shortest Path First (SPF) calculations are run; one on Level 1 link state database and other on the Level 2 link state database.
IS-IS Level 1-2 router behaves very close to OSPF Area Border Router (ABR). L1/L2 router sends both L1 and L2 hellos.
By default, the L1/L2 router allows one way passage of prefixes from L1 Area to L2 Area, but not in reverse.
However, if it is required to move prefixes from L2 Area to L1 Area, a redistribute command under IS-IS configuration is required.
An IS-IS Level 2 router has the link state information for the intra-area as well as inter-area routing.
L2 router sends only L2 hellos. IS-IS Level 2 area can be compared with OSPF backbone area 0.
IS-IS Adjacency Table
Router Type |
L1 |
L1/L2 |
L2 |
L1 |
L1 Adjacency if Area Id Matches, else no Adjacency |
L1 Adjacency if Area Id Matches, else no Adjacency |
No Adjacency |
L1/L2 |
L1 Adjacency if Area Id Matches, else no Adjacency |
L1 and L2 Adjacency if Area id Matches , else only L2 Adjacency |
L2 Adjacency , Area Id does not matter |
L2 |
No Adjacency |
L2 Adjacency , Area Id does not matter |
L2 Adjacency , Area Id does not matter |
MTU |
If one IS-IS router receives an ISIS hello packet with higher MTU than it can support (on the interface), it discards the hello hence the adjacency does not come up. In best practice, MTU must be same on both the ends. |
Circuit-Type |
This attribute is configured on interface and defines what type of hellos, that is, L1 or L2 are sent on a particular interface. A L1/L2 router can selectively send L1 only hellos on one interface and L2 only hellos on its other interface. If L1/L2 router tries to peer with an L1 only router and L1/L2 interface is configured with isis circuit-type level-2, it sends only L2 hellos out to the interface and the adjacency with the L1 router does not come up. Routers must send compatible type hellos. |
Authentication |
IS-IS can separately authenticate hellos and Link State Protocol Data Units (LSP). If hellos are authenticated correctly, and LSP authentication fails, the adjacency comes up, but updates do not exchange. Authentication, if configured for IS-IS hellos or PDUs (Protocol Data Unit), must match on both the ends. |
Capability TLV |
If an IS-IS Router does not support the Capability TLV from the other IS-IS Router, it silently ignores the TLV. However, there are events due to capability mismatch when one router reaches INIT state, whereas the other one discards the packets and does not form adjacency. As a general recommendation, Capability TLV must match for successful adjacency formation. The discussion of details for Capability TLV is beyond the scope of this document. |
Network Type |
There are two network types in IS-IS; Broadcast and Point-to-Point. Broadcast is default network type. If one end is configured with isis network point-to-point, and other end is default network type, the hellos are discarded and adjacency does not come up. Network type must match on both the ends. |
Hellos |
Hello timers need not match for the adjacency to come up. |
There are only three adjacency states in IS-IS.
Subnets are of type 192.168.X.0 where X is shown between interfaces in the diagram.
The loopbacks are of type 192.168.YY.YY, where Y is 1 when Router is R1. So for R1 loopback ip is 192.168.11.11.
L1, L1/L2 and L2 are Level 1, Level 1-2 and Level 2 routers respectively.
IS-IS protocol requires configuration both at interface level and globally.
!
interface Loopback1
ip address 192.168.11.11 255.255.255.255
ip router isis 1
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip router isis 1
interface FastEthernet1/0
ip address 192.168.2.1 255.255.255.0
ip router isis 1
!
router isis 1
net 49.0000.0000.0001.00
is-type level-1
!
!
interface Loopback1
ip address 192.168.22.22 255.255.255.255
ip router isis 1
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
ip router isis 1
interface FastEthernet1/0
ip address 192.168.3.2 255.255.255.0
ip router isis 1
!
router isis 1
net 49.0000.0000.0002.00
is-type level-1
!
!
interface Loopback1
ip address 192.168.33.33 255.255.255.255
ip router isis 1
!
interface FastEthernet0/0
ip address 192.168.2.3 255.255.255.0
ip router isis 1
interface FastEthernet1/0
ip address 192.168.4.3 255.255.255.0
ip router isis 1
!
router isis 1
net 49.0000.0000.0003.00
is-type level-1
!
!
interface Loopback1
ip address 192.168.44.44 255.255.255.255
ip router isis 1
!
interface FastEthernet0/0
ip address 192.168.3.4 255.255.255.0
ip router isis 1
!
interface FastEthernet1/0
ip address 192.168.4.4 255.255.255.0
ip router isis 1
!
interface FastEthernet1/1
ip address 192.168.5.4 255.255.255.0
ip router isis 1
!
interface FastEthernet2/0
ip address 192.168.6.4 255.255.255.0
ip router isis 1
!
router isis 1
net 49.0000.0000.0004.00
!
!
interface Loopback1
ip address 192.168.55.55 255.255.255.255
ip router isis 1
!
interface FastEthernet0/0
ip address 192.168.5.5 255.255.255.0
ip router isis 1
!
interface FastEthernet1/0
ip address 192.168.7.5 255.255.255.0
ip router isis 1
!
router isis 1
net 50.0000.0000.0005.00
is-type level-2-only
!
!
interface Loopback1
ip address 192.168.66.66 255.255.255.255
ip router isis 1
!
interface FastEthernet0/0
ip address 192.168.6.6 255.255.255.0
ip router isis 1
!
interface FastEthernet1/0
ip address 192.168.8.6 255.255.255.0
ip router isis 1
!
router isis 1
net 50.0000.0000.0006.00
is-type level-2-only
!
!
interface Loopback1
ip address 192.168.77.77 255.255.255.255
ip router isis 1
!
interface FastEthernet0/0
ip address 192.168.7.7 255.255.255.0
ip router isis 1
!
interface FastEthernet1/0
ip address 192.168.8.7 255.255.255.0
ip router isis 1
!
router isis 1
net 50.0000.0000.0007.00
is-type level-2-only
!
Area ID is the same in R1 and R2. Both are Level 1 routers. L1 adjacency exists between them.
R1#show isis neighbors
Tag 1:
System Id Type Interface IP Address State Holdtime Circuit Id
R2 L1 Fa0/0 192.168.1.2 UP 7 R2.01
Since R1 and R2 are both L1 Routers and belong to the same area, only L1 type IS-IS hellos are sourced on the LAN segment between R1 and R2.
R1#debug isis adj-packets fastEthernet 0/0
*Nov 25 19:25:53.995: ISIS-Adj: Sending L1 LAN IIH on FastEthernet0/0, length 1497
*Nov 25 19:25:54.071: ISIS-Adj: Rec L1 IIH from ca02.1c80.0000 (FastEthernet0/0), cir type L1, cir id 0000.0000.0002.01, length 1497
-- The highlighted portion shows the Mac Address and the circuit id of R2, it also shows that L1 IS-IS hello packet was received from R2 --
*Nov 25 19:25:54.075: ISIS-Adj: New adjacency, level 1 for ca02.1c80.0000
-- The above line shows that R1 has discovered a new neighbour capable of L1 adjacency, having the mac address ca02.1c80.0000 R2 --
*Nov 25 19:25:54.991: ISIS-Adj: Sending L1 LAN IIH on FastEthernet0/0, length 1497
*Nov 25 19:25:55.047: ISIS-Adj: Rec L1 IIH from ca02.1c80.0000 (FastEthernet0/0), cir type L1, cir id 0000.0000.0002.01, length 1497
*Nov 25 19:25:55.051: ISIS-Adj: L1 adj count 1
*Nov 25 19:25:55.055: ISIS-Adj: L1 adjacency state goes to Up
-- Once both the routers mutually agree on interface settings and other global parameters (e.g. authentication, circuit-type, mtu etc.) the L1 adjacency finally comes up --
ISIS HELLO
.... ..01 = Circuit type: Level 1 only (0x01) >>> Circuit type is Level 1
0000 00.. = Reserved: 0x00
SystemID {Sender of PDU}: 0000.0000.0002 >>> Identification of R2
Holding timer: 10 >>> Hold timer for hellos
PDU length: 1497 >>> Entire PDU in bytes
.100 0000 = Priority: 64 >>> Default Priority for DR election
0... .... = Reserved: 0
SystemID {Designated IS}: 0000.0000.0002.01 >>> SystemID + Pseudonode ID
Protocols Supported (1)
NLPID(s): IP (0xcc) >>> IS-IS is routing IP
Area address(es) (2)
Area address (1): 49 >>> Area id of R2
IP Interface address(es) (4)
IPv4 interface address: 192.168.1.2 (192.168.1.2) >>> IP of R2’s fa0/0
Restart Signaling (3)
Restart Signaling Flags: 0x00
.... .0.. = Suppress Adjacency: False
.... ..0. = Restart Acknowledgment: False
.... ...0 = Restart Request: False
IS Neighbor(s) (6)
IS Neighbor: ca:01:1d:a4:00:00 (ca:01:1d:a4:00:00) >>> Mac of R2 ( fa0/0 )
Padding (255)
Padding (255)
Padding (255)
Padding (255)
Padding (255)
Padding (157)
ISIS HELLO
.... ..01 = Circuit type: Level 1 only (0x01) >>> Circuit type is Level 1
0000 00.. = Reserved: 0x00
SystemID {Sender of PDU}: 0000.0000.0001 >>> Identification of R1
Holding timer: 30 >>> Hold time for hellos
PDU length: 1497 >>> Entire PDU in bytes
.100 0000 = Priority: 64 >>> Default Priority for DR election
0... .... = Reserved: 0
SystemID {Designated IS}: 0000.0000.0001.01 >>> SystemID + Pseudonode Id
Protocols Supported (1)
NLPID(s): IP (0xcc) >>> IS-IS is routing IP
Area address(es) (2)
Area address (1): 49 >>> Area id of R1
IP Interface address(es) (4)
IPv4 interface address: 192.168.1.1 (192.168.1.1) >>> IP of R1 fa0/0 interface
Restart Signaling (3)
Restart Signaling Flags: 0x00
.... .0.. = Suppress Adjacency: False
.... ..0. = Restart Acknowledgment: False
.... ...0 = Restart Request: False
IS Neighbor(s) (6)
IS Neighbor: ca:02:1c:80:00:00 (ca:02:1c:80:00:00)>>> Mac of R1 fa0/0 interface
Padding (255)
Padding (255)
Padding (255)
Padding (255)
Padding (255)
Padding (157)
Cisco IOS® implements a mechanism to detect the MTU on interface before adjacency is established.
After the adjacency is established, packet drops do not occur due the MTU issues and hence prevents the database from corruption.
Padding a IS-IS hello increases its size until the MTU of the interface and it is observed whether the other end is able to accept hello packet with this MTU.
If on the other end, lower MTU exits, that end drops the hellos and hence adjacency does not come up.
In IS-IS, the DR in the broadcast LAN segment always sends the hellos one-third of the normal hello time, that is, 10 seconds. From the perspective of DR, the hello time is 3.33 seconds and hold time is 10 seconds. In the earlier capture example, R2 is the DR. This can also be verified from the output below.
R2#sh clns interface fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 31 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x1
Level-1 Metric: 10, Priority: 64, Circuit ID: R2.01
DR ID: R2.01
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 1 seconds
The area ID is the same between R2 and R4. R2 is Level 1 and R4 is Level 1-2.
Since R4 is L1/L2 router, it sends both L1 and L2 hellos, as mentioned earlier.
R2 is L1 only router and area id is same so L1 adjacency forms.
R2#show isis neighbors
Tag 1:
System Id Type Interface IP Address State Holdtime Circuit Id
R4 L1 Fa1/0 192.168.3.4 UP 8 R4.01
*Nov 26 03:56:25.299: ISIS-Adj: Sending L1 LAN IIH on FastEthernet1/0, length 1497
*Nov 26 03:56:25.355: ISIS-Adj: Rec L1 IIH from ca04.0cf4.0000 (FastEthernet1/0), cir type L1L2, cir id 0000.0000.0004.01, length 1497
*Nov 26 03:56:25.355: ISIS-Adj: New adjacency, level 1 for ca04.0cf4.0000
*Nov 26 03:56:26.299: ISIS-Adj: Sending L1 LAN IIH on FastEthernet1/0, length 1497
*Nov 26 03:56:26.339: ISIS-Adj: Rec L1 IIH from ca04.0cf4.0000 (FastEthernet1/0), cir type L1L2, cir id 0000.0000.0004.01, length 1497
*Nov 26 03:56:26.343: ISIS-Adj: L1 adj count 1
*Nov 26 03:56:26.343: ISIS-Adj: L1 adjacency state goes to Up
*Nov 26 03:56:26.347: ISIS-Adj: Run level-1 DR election for FastEthernet1/0
*Nov 26 03:56:26.351: ISIS-Adj: New level-1 DR 0000.0000.0004 on FastEthernet1/0
*Nov 26 03:56:26.467: ISIS-Adj: Rec L2 IIH from ca04.0cf4.0000 (FastEthernet1/0), cir type L1L2, cir id 0000.0000.0004.01, length 1497
*Nov 26 03:56:26.471: ISIS-Adj: is-type mismatch
-- The above line in output is due to the fact that R2 is L1 only and hence does not understand the L2 hellos from the L1/L2 Router R2 --
ISO 10589 ISIS InTRA Domain Routing Information Exchange Protocol
Intra Domain Routing Protocol Discriminator: ISIS (0x83)
PDU Header Length: 27
Version: 1
System ID Length: 0
...1 0000 = PDU Type: L2 HELLO (16)
000. ... = Reserved: 0x00
Version2 (==1): 1
Reserved (==0): 0
Max.AREAs: (0==3): 0
ISIS HELLO
.... ..11 = Circuit type: Level 1 and 2 (0x03)
0000 00.. = Reserved: 0x00
SystemID {Sender of PDU}: 0000.0000.0004
Holding timer: 30
PDU length: 1497
.100 0000 = Priority: 64
0... .... = Reserved: 0
SystemID {Designated IS}: 0000.0000.0004.01
Protocols Supported (1)
NLPID(s): IP (0xcc)
Area address(es) (2)
Area address (1): 49
IP Interface address(es) (4)
IPv4 interface address: 192.168.3.4 (192.168.3.4)
Restart Signaling (3)
Restart Signaling Flags: 0x00
.... .0.. = Suppress Adjacency: False
.... ..0. = Restart Acknowledgment: False
.... ...0 = Restart Request: False
Padding (255)
Padding (255)
Padding (255)
Padding (255)
Padding (255)
Padding (165)
ISO 10589 ISIS InTRA Domain Routing Information Exchange Protocol
Intra Domain Routing Protocol Discriminator: ISIS (0x83)
PDU Header Length: 27
Version: 1
System ID Length: 0
...0 1111 = PDU Type: L1 HELLO (15)
000. .... = Reserved: 0x00
Version2 (==1): 1
Reserved (==0): 0
Max.AREAs: (0==3): 0
ISIS HELLO
.... ..11 = Circuit type: Level 1 and 2 (0x03)
0000 00.. = Reserved: 0x00
SystemID {Sender of PDU}: 0000.0000.0004
Holding timer: 30
PDU length: 1497
.100 0000 = Priority: 64
0... .... = Reserved: 0
SystemID {Designated IS}: 0000.0000.0004.01
Protocols Supported (1)
NLPID(s): IP (0xcc)
Area address(es) (2)
Area address (1): 49
IP Interface address(es) (4)
IPv4 interface address: 192.168.3.4 (192.168.3.4)
Restart Signaling (3)
Restart Signaling Flags: 0x00
.... .0.. = Suppress Adjacency: False
.... ..0. = Restart Acknowledgment: False
.... ...0 = Restart Request: False
IS Neighbor(s) (6)
Padding (255)
Padding (255)
Padding (255)
Padding (255)
Padding (255)
Padding (157)
ISO 10589 ISIS InTRA Domain Routing Information Exchange Protocol
Intra Domain Routing Protocol Discriminator: ISIS (0x83)
PDU Header Length: 27
Version: 1
System ID Length: 0
...0 1111 = PDU Type: L1 HELLO (15)
000. .... = Reserved: 0x00
Version2 (==1): 1
Reserved (==0): 0
Max.AREAs: (0==3): 0
ISIS HELLO
.... ..01 = Circuit type: Level 1 only (0x01)
0000 00.. = Reserved: 0x00
SystemID {Sender of PDU}: 0000.0000.0002
Holding timer: 30
PDU length: 1497
.100 0000 = Priority: 64
0... .... = Reserved: 0
SystemID {Designated IS}: 0000.0000.0002.02
Protocols Supported (1)
NLPID(s): IP (0xcc)
Area address(es) (2)
Area address (1): 49
IP Interface address(es) (4)
IPv4 interface address: 192.168.3.2 (192.168.3.2)
Restart Signaling (3)
Restart Signaling Flags: 0x00
.... .0.. = Suppress Adjacency: False
.... ..0. = Restart Acknowledgment: False
.... ...0 = Restart Request: False
IS Neighbor(s) (6)
Padding (255)
Padding (255)
Padding (255)
Padding (255)
Padding (255)
Padding (157)
The area ID is different between R4 and R5. R4 is Level 1-2 and R5 is Level 2. So L2 adjacency forms.
R4#show isis neighbors
Tag 1:
System Id Type Interface IP Address State Holdtime Circuit Id
R2 L1 Fa0/0 192.168.3.2 UP 19 R4.01
R5 L2 Fa1/1 192.168.5.5 UP 4 R5.01
The area ID is same between R5 and R7. R5 is Level 2 and R7 is Level 2. So L2 adjacency forms.
R5#show isis neighbors
Tag 1:
System Id Type Interface IP Address State Holdtime Circuit Id
R4 L2 Fa0/0 192.168.5.4 UP 29 R5.01
R7 L2 Fa1/0 192.168.7.7 UP 4 R7.01
As mentioned earlier, L1 router has only intra area LSA and uses the nearest L1/L2 router to reach other parts of network. L1 Area behaves as an OSPF totally stubby area. A default route generated by the L1/L2 router R4 is seen in the routing table. With this default route, outside destinations can be reached.
R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is 192.168.2.3 to network 0.0.0.0
i*L1 0.0.0.0/0 [115/20] via 192.168.2.3, 00:25:31, FastEthernet1/0
[115/20] via 192.168.1.2, 00:25:31, FastEthernet0/0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, FastEthernet0/0
L 192.168.1.1/32 is directly connected, FastEthernet0/0
192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.2.0/24 is directly connected, FastEthernet1/0
L 192.168.2.1/32 is directly connected, FastEthernet1/0
i L1 192.168.3.0/24 [115/20] via 192.168.1.2, 00:25:31, FastEthernet0/0
i L1 192.168.4.0/24 [115/20] via 192.168.2.3, 03:17:05, FastEthernet1/0
i L1 192.168.5.0/24 [115/30] via 192.168.2.3, 00:25:31, FastEthernet1/0
-----------Output Omitted -----------
L1/L2 Router maintains two link state databases, one for L1 area and on for L2 area. Hence, two distinct SPF calculations are required.
L1/L2 router sends the default route in L1 Area, so that the L1 routers can reach the other parts of the network. Here, both L1 and L2 routes are observed.
R4#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
i L1 192.168.1.0/24 [115/20] via 192.168.3.2, 00:30:18, FastEthernet0/0
i L1 192.168.2.0/24 [115/20] via 192.168.4.3, 03:21:58, FastEthernet1/0
192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.3.0/24 is directly connected, FastEthernet0/0
L 192.168.3.4/32 is directly connected, FastEthernet0/0
192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.4.0/24 is directly connected, FastEthernet1/0
L 192.168.4.4/32 is directly connected, FastEthernet1/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, FastEthernet1/1
L 192.168.5.4/32 is directly connected, FastEthernet1/1
192.168.6.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.6.0/24 is directly connected, FastEthernet2/0
L 192.168.6.4/32 is directly connected, FastEthernet2/0
i L2 192.168.7.0/24 [115/20] via 192.168.5.5, 00:00:57, FastEthernet1/1
i L2 192.168.8.0/24 [115/20] via 192.168.6.6, 00:00:32, FastEthernet2/0
-----------Output Omitted -----------
L2 routers are like OSPF backbone routers. All the information is present in L2 routers. The loopbacks from L1 Area are present as L2 routes in routing table of the L2 Router.
R7#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
i L2 192.168.1.0/24 [115/40] via 192.168.8.6, 00:31:54, FastEthernet1/0
[115/40] via 192.168.7.5, 00:31:54, FastEthernet0/0
i L2 192.168.2.0/24 [115/40] via 192.168.8.6, 03:23:23, FastEthernet1/0
[115/40] via 192.168.7.5, 03:23:23, FastEthernet0/0
i L2 192.168.3.0/24 [115/30] via 192.168.8.6, 03:23:23, FastEthernet1/0
[115/30] via 192.168.7.5, 03:23:23, FastEthernet0/0
i L2 192.168.4.0/24 [115/30] via 192.168.8.6, 03:23:23, FastEthernet1/0
[115/30] via 192.168.7.5, 03:23:23, FastEthernet0/0
i L2 192.168.5.0/24 [115/20] via 192.168.7.5, 00:02:35, FastEthernet0/0
i L2 192.168.6.0/24 [115/20] via 192.168.8.6, 00:02:10, FastEthernet1/0
192.168.7.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.7.0/24 is directly connected, FastEthernet0/0
L 192.168.7.7/32 is directly connected, FastEthernet0/0
192.168.8.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.8.0/24 is directly connected, FastEthernet1/0
L 192.168.8.7/32 is directly connected, FastEthernet1/0
192.168.11.0/32 is subnetted, 1 subnets
i L2 192.168.11.11 [115/50] via 192.168.8.6, 03:23:23, FastEthernet1/0
[115/50] via 192.168.7.5, 03:23:23, FastEthernet0/0
192.168.22.0/32 is subnetted, 1 subnets
i L2 192.168.22.22 [115/40] via 192.168.8.6, 00:31:54, FastEthernet1/0
[115/40] via 192.168.7.5, 00:31:54, FastEthernet0/0
-----------Output Omitted -----------
There is currently no specific troubleshooting information available for this configuration.
Revision | Publish Date | Comments |
---|---|---|
3.0 |
25-Jun-2024 |
Updated Alt Text, Machine Translation, and Formatting. |
2.0 |
09-Jan-2023 |
Recertification |
1.0 |
14-Dec-2015 |
Initial Release |