Cisco Catalyst 6500 シリーズ

Cisco Catalyst 6500 Supervisor Engine 2T における仮想プライベート LAN サービス

ホワイト ペーパー





Cisco Catalyst 6500 Supervisor Engine 2T における仮想プライベート LAN サービス



仮想プライベート LAN サービスの概要


Cisco® Catalyst® 6500 Supervisor Engine 2T は、Virtual Private LAN Service(VPLS; 仮想プライベート LAN サービス)を新しい PFC4 でネイティブにサポートします。VPLS は、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ネットワークでレイヤ 2 イーサネット サービスの提供を可能にするテクノロジーです。ポイントツーポイントの Ethernet over MPLS(EoMPLS)ではなく、マルチポイントのイーサネット サービスを提供します。VPLS は、仮想 IEEE イーサネット ブリッジ ネットワークをエミュレートします。

レイヤ 3 VPN とは異なり、顧客ネットワークとサービス プロバイダー ネットワークの間にルーティング インタラクションがありません(図 1 を参照)。

図 1 仮想ポート(Pseudo Wire(PW; 疑似配線))でリンクされた仮想ブリッジ

図 1 仮想ポート(Pseudo Wire(PW; 疑似配線))でリンクされた仮想ブリッジ

  • マルチポイントツーマルチポイント構成
  • 学習した MAC アドレスに基づくフレーム転送
  • Virtual Forwarding Instance(VFI; 仮想転送インスタンス、VLAN と同様)による顧客の分離

VPLS のコンポーネント


企業とサービス プロバイダーに共通する VPLS の概念とコンポーネント


  • User-facing PE(U-PE; ユーザ側 PE):U-PE は、プロバイダー ネットワークの入力時に機能によって転送またはスイッチングを決定する必要のあるデバイスです。
  • Network PE(N-PE; ネットワーク PE):N-PE は、VPLS-PE が複数のボックスに分散される場合にシグナリングおよび制御機能が割り当てられるデバイスです。
  • Virtual Switching Instance(VSI; 仮想スイッチング インスタンス):1 つの VPLS A VSI を処理する VSI は、標準の LAN(イーサネット)ブリッジング機能を実行します(MAC アドレスと VLAN タグに基づいて VSI が行う転送など)。
  • Pseudo Wire(PW; 疑似配線):PWE3 は、電気通信サービスに不可欠な属性(T1 専用回線やフレーム リレーなど)を PSN 上でエミュレートするメカニズムです。
  • Attachment Circuit(AC; 接続回線):CE を PE に接続する物理または仮想回線です。接続回線には、フレーム リレー DLCI、ATM VPI/VCI、イーサネット ポート、VLAN、MPLS LSP などがあります。1 つまたは複数の AC が同じ VFI に属することができます。
  • Virtual Circuit(VC; 仮想回線):Martini ベースのデータ カプセル化で、トンネル ラベルを使用してリモート PEに到達し、VC ラベルを使用して VFI を識別します。1 つまたは複数の VC が同じ VFI に属することができます(図 2 を参照)。
  • Virtual Forwarding Instance(VFI; 仮想転送インスタンス):
    • VFI は、すべての AC および VC 間に L2 マルチポイント ブリッジングを作成します。これは、VLAN などの L2 ブロードキャスト ドメインです。
    • VLAN などのユーザ トラフィックを分離するために、複数の VFI を同じ PE ボックスに配置できます。
図 2 VPLS の概念とコンポーネント

図 2 VPLS の概念とコンポーネント


シグナリング


シグナリングは、LDP を使用して PW を確立および切断します。シグナリング VPLS コントロール プレーンとして LDP を使用した場合、自動検出は本質的にサポートされません。そのため、LDP-VPLS では、手動設定によって、すべての PE ルータを識別します。

コアの MPLS、ホップごとの通常 LDP セッションでトンネル ラベルまたは IGP ラベルを交換します。PE 間のターゲットまたはダイレクト LDP セッションで VC ラベルを交換します。トンネル ラベルを使用して、PE から PE VC ラベルにパケットを転送し、L2VPN 回線を識別します。

エミュレートされた VC のシグナリングは、PE 間のダイレクト LDP セッションを使用して行われます。VC タイプ、VC ID、インターフェイス パラメータなどの情報は、VC シグナリングを使用してネゴシエートされます。c6500 プラットフォーム上の VPLS は、VC タイプ 4(イーサネット VLAN)と VC タイプ 5(イーサネット)の両方の VC タイプをサポートします。6500 では、デフォルトで VC タイプ 5 を使用しますが、ピアの要求に応じて VC タイプ 4 にネゴシエートできます。同様に、CW は c6500 プラットフォームでサポートされますが、ピア プラットフォームでサポートされない場合は CW 以外にネゴシエートできます (図 3 を参照)。

図 3 LDP を使用する VPLS シグナリング

図 3 LDP を使用する VPLS シグナリング


データ転送


Supervisor Engine 2T 上の VPLS は、スイッチがスイッチド ポート間で転送を行う場合とまったく同じ方法でデータを転送します。

  • フラッディングおよび転送:
    • 転送は、VLAN、宛先 MAC アドレスに基づきます。
    • 不明なユニキャスト、マルチキャスト、およびブロードキャストは、すべてのポートにフラッディングされます(マルチキャスト フラッディングを制限するには IGMP スヌーピングを使用し、その他のタイプのフラッディングを制限するにはストーム制御を使用することができます)。
  • MAC ラーニング、エージング、および取り消し:
    • 送信元 MAC および VLAN に基づく動的ラーニング
    • 着信パケットによるエージング タイマーの更新
    • トポロジの変更に応じた MAC 取り消し

ループ防止


VPLS では、スプリットホライズン(図 4)を使用してループを回避します(スパニング ツリーも使用できますが、ループ回避には適していません)。

  • VPLS VC で受信したパケットは、AC にのみ転送でき、他の VPLS VC には転送できません。
  • すべての PE 間でフル メッシュ VC が必要です。
  • PE の冗長性のために、アクティブ/アクティブ VSS にはループ防止機能が備わっています(STP、EEM、BGP などのアクティブ/バックアップ スキームは不要です)。
図 4 ネットワークでのループを防止する VPLS スプリットホライズン

図 4 ネットワークでのループを防止する VPLS スプリットホライズン


H-VPLS


Cisco Catalyst 6500 Supervisor Engine 2T は、Hierarchical VPLS(H-VPLS; 階層型 VPLS)を新しい PFC4 でネイティブにサポートします。H-VPLS では、フルメッシュ構成とハブアンドスポーク構成を使用して、シグナリングとレプリケーションのオーバーヘッドを削減します。ハブアンドスポーク構成をスプリット ホライズンと併用すると、Pseudo Wire(PW; 疑似配線)間でパケットを切り替えて、PE 間の PW 数を効果的に削減できます (図 5 を参照)。

  • シグナリング オーバーヘッドの最小化
  • コア デバイス間のみのフル PW メッシュ
  • コアのみで実行されるパケット レプリケーション
図 5 H-VPLS による VPLS の拡張

図 5 H-VPLS による VPLS の拡張
※画像をクリックすると、大きな画面で表示されますpopup_icon


表 1 に、VPLS IETF 適合標準規格を示します。

表 1 VPLS IETF 適合標準規格

RFC カテゴリ 説明
RFC4026 情報 プロバイダーが提供する VPN の用語
RFC3809 情報 レイヤ 2 プロバイダーが提供する VPN の要件
draft-martini-l2circuit-trans-mpls-19.txt ドラフト MPLS でのレイヤ 2 フレームの転送
RFC3985 情報 疑似配線エミュレーション エッジツーエッジ(PWE3)アーキテクチャ
RFC4385 標準化過程 MPLS PSN 上で使用する疑似配線エミュレーション エッジツーエッジ(PWE3)コントロール ワード
RFC4447 標準化過程 Label Distribution Protocol(LDP; ラベル配布プロトコル)を使用する疑似配線セットアップおよびメンテナンス
RFC 4448 標準化過程 MPLS ネットワークでのイーサネット転送のカプセル化方式


Cisco Catalyst Supervisor Engine 2T における VPLS サポート


PE として稼動している Cisco Catalyst 6500 は、Supervisor Engine 2T で 4,000 もの VPLS インスタンスを実行できます。複数のローカル レイヤ 2 ポートを備えることが可能で、フラッディング ドメインには 256 もの VC を配置できます。リモート(ピア)MAC が学習されると、パケットの送信にユニキャスト VC が使用されます。着信レイヤ 2 フレームは、VLAN モード用に dot1q タグを付けるか、ポート モード用にタグ付きフレームとネイティブ フレームにすることができます。

CFC モードでは、VPLS カプセル化は Supervisor Engine 2T で実行されます。DFC モードでは、VPLS カプセル化はダウンリンク 68XX または 69XX シリーズ カードによって実行され、VPLS 機能の実行に SIP または ES+ も必要とする Supervisor Engine 720 に備わっているようなアップリンク側カードでは実行されません (図 6 を参照)。

Catalyst SUP2T での VPLS パケット転送は、次のように動作します。

入力:MAC テーブルをルックアップして、ピア ID を取得します(MAC アドレスが存在しない場合)。その後、PFC4 でブリッジ ドメインとピア ID のルックアップを実行して、PW の書き換えをポイントします。ピア ID が 0x3ff(フラッディング ケース)の場合、TCAM は Multicast Replication Table(MET; マルチキャスト レプリケーション テーブル)をポイントして、最初にパケットを複製し、次に各 PW 用に書き換えます。

出力:出力では、最初のルックアップは通常のレイヤ 3 MPLS ルックアップと同様です。TCAM でのラベル ルックアップによって EoM カプセル化解除の隣接性がポイントされ、MPLS ラベルおよびコントロール ワードが削除されます。内部 DMAC から開始された内部パケットが再循環されます。2 番目のパスでのレイヤ 2 ルックアップによって発信ポートが提供されます。

図 6 Cisco Catalyst 6500 SUP2T

図 6 Cisco Catalyst 6500 SUP2T


詳細については、『Catalyst 6500 Supervisor 2T のアーキテクチャ』のホワイト ペーパーを参照してください。

Cisco Catalyst 6500 Supervisor Engine 2T における VPLS の設定と導入


Supervisor Engine 2T 上の VPLS は、Supervisor Engine 720 と同じ Cisco IOS® ソフトウェア コードを使用し、さらにスケーラビリティの利点が加わっています。設定プロセスは Supervisor Engine 2T でも Supervisor Engine 720 の場合と同じです。

    l2 vfi vpls-300 manual
     vpn id 300
     neighbor 130.0.0.2 encapsulation mpls
     neighbor 130.0.0.3 201 encapsulation mpls
 
    interface Vlan300
     no ip address
     xconnect vfi vpls-300
     ! 
    ! Access port
    interface GigabitEthernet2/1
     switchport
     switchport access vlan 300
     switchport mode access
 
    ! Trunk port
    interface GigabitEthernet6/3
     switchport
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 300,3001
     switchport mode trunk

GRE での VPLS


Cisco Catalyst 6500 Supervisor Engine 2T では、GRE での VPLS に対応した導入モデルがサポートされているので、柔軟な転送オプションを利用して VPLS を導入できます。これにより、ユーザは IP ネットワーク上で VPLS を設定して、MPLS またはレイヤ 2 マルチポイント暗号化への段階的移行に使用することができます。

    !
    Interface tunnel 1
    tunnel mode gre 
    mpls ip 
    tunnel source 11.11.11.11
    tunnel destination 22.22.22.22
    !
    Interface tunnel 2
    tunnel mode gre 
    mpls ip 
    tunnel source 11.11.11.12
    tunnel destination 33.33.33.33
    !
    Interface TenGigabitEthernet1/1/3/0
      ip address 10.1.1.1  255.255.255.0
    ! 

VPLS による統合ルーティングおよびブリッジングまたはルーテッド PW


Cisco Catalyst 6500 Supervisor Engine 2T は、VPLS 機能のための統合ルーティングおよびブリッジングとともに、Xconnect が設定されているインターフェイス上での IP アドレスと VRF の設定をサポートします。これにより、キャンパスおよびデータセンター ネットワークのアグリゲーション レイヤで VPLS をより柔軟に設定できます。

    !
    Interface VLAN 10
    ip vrf forwarding vrf_1
    ip address 12.12.12.1 255.255.255.0 
    xconnect vfi vpls-300
    !

Supervisor Engine 2T による VPLS PE の冗長性


Cisco Catalyst 6500 Supervisor Engine 2T は、PE の冗長性のための NSF/SSO を完全にサポートするとともに、VSS モードの VPLS をサポートします。これにより、MCEC ベースのデュアル ホーミングを VPLS で利用できます (図 7 を参照)。

図 7 VSS による N-PE VPLS 冗長性の簡素化

図 7 VSS による N-PE VPLS 冗長性の簡素化


導入の使用事例


Cisco Catalyst Supervisor Engine 2T は、VPLS でのスケーラビリティと柔軟性が非常に高いため、さまざまな使用事例に対応した導入が可能です。

  • データセンターのレイヤ 2 ドメインの拡張
    • 1 つの大規模データセンターのさまざまなポッド内
    • MPLS および レイヤ 3 境界を越えて地理的に分散しているデータセンター間
  • 大規模キャンパス ネットワークでの STP ドメインの削減とレイヤ 2 の拡張
  • サービス プロバイダーによるマルチポイント レイヤ 2 イーサネット サービスの提供

1 つの大規模データセンターのさまざまなポッド内でレイヤ 2 ドメインを拡張

大規模データセンター、特にマルチテナント データセンター ホスティング プロバイダーでは、クライアント数が増加すると新しいデータセンター ポッドを追加します。これによって VLAN のオーバーラップの課題が発生し、4,000 の VLAN では拡張に対応できなくなります。

VPLS では、MPLS/IP コア上の不連続 LAN セグメントへの接続が可能です。各 LAN セグメント上の VLAN 数は異なります。ラベル領域の場合は 20 ビットでブリッジ ドメインにマッピングするのに対して、VLAN 領域の場合は 12 ビットです。

図 8 に示すように、VPLS を使用してデータセンターのレイヤ 2 ドメインを拡張できます。

  • 各サブグループで 256,000 のクライアントをサポート可能
    • サブグループ ルータに 256,000 のサブネット(256,000 は、ブリッジング制限ではなく、ルーティング テーブルのサイズに基づく)
    • 各ポッドで最大 4,000 のクライアントをサポート
    • 各サブグループ内に 64 以上のポッド
  • データセンター全体で 256,000 × m のクライアントをサポート
    • m = サブグループの数
  • クライアントは任意のポッドから別のポッドに移動または拡張可能(サブグループ内またはサブグループ間)
  • VPLS(VFI/VC)は、ポッド Cisco Catalyst 6k へのクライアントの初回追加時に、ポッド上で設定
図 8 VPLS による大規模 DC 内 VLAN 拡張

図 8 VPLS による大規模 DC 内 VLAN 拡張
※画像をクリックすると、大きな画面で表示されますpopup_icon


次のセクションでは、データセンター間で同じ概念をどのように使用するかについて説明します。

地理的に分散している大規模データセンター間またはレイヤ 3 境界を越えるデータセンター間でレイヤ 2 ドメインを拡張

レイヤ 2 を複数のサイトに拡張する必要があり、ポイントツーポイント接続では不十分な場合は、VPLS によって MPLS または IP インフラストラクチャを使用したマルチポイント接続を利用できます。VPLS では、レイヤ 2 ドメインを拡張しながら各データセンターの STP を分離することが可能です (図 9 を参照)。

図 9 VPLS を使用したデータセンター相互接続

図 9 VPLS を使用したデータセンター相互接続
※画像をクリックすると、大きな画面で表示されますpopup_icon


詳細については、『Data Center Interconnect』のホワイト ペーパー [英語] を参照してください。

大規模キャンパス ネットワークでの STP ドメインの削減とレイヤ 2 の拡張

アプリケーション要件によっては、キャンパス サイト間でレイヤ 2 でのネットワーク仮想化が必要になる場合もあります。これは L3VPN への代替かつ補完的なソリューションであり、アプリケーション ニーズに応じてレイヤ 2 拡張が求められます。こうしたアプリケーションとしては、レイヤ 3 ゲートウェイへのインタラクションが不要な、固定 IP アドレッシングが組み込まれた、特定のレイヤ 2 マルチキャスト(トレーディング アプリケーションやマーケット データ アプリケーション)またはレガシー クライアント サーバ アプリケーションが挙げられます (図 10 を参照)。

図 10 キャンパスでの導入における VPLS

図 10 キャンパスでの導入における VPLS
※画像をクリックすると、大きな画面で表示されますpopup_icon


サービス プロバイダーによるマルチポイント レイヤ 2 イーサネット サービスの提供

サービス プロバイダーは、独自の MPLS コア経由で L2VPN マルチポイント接続を提供できます。MPLS をエッジへ、またはアクセス ネットワークで拡張することが可能です。サービス プロバイダーは顧客ルーティング ポリシーや IP アドレッシング スキームを心配する必要がなくなります。転送ネットワーク アグリゲーションとしての使用も可能です。その他の VPLS 導入シナリオには、モバイル事業者による VPLS または VPLSoGRE を使用したバックホール転送や、マルチテナント DC サービス プロバイダーによる顧客へのレイヤ 2 データセンター相互接続の提供などがあります (図 11 を参照)。

図 11 サービス プロバイダーによる VPLS を使用したイーサネット提供

図 11 サービス プロバイダーによる VPLS を使用したイーサネット提供
※画像をクリックすると、大きな画面で表示されますpopup_icon


まとめ


Cisco Catalyst 6500 Supervisor Engine 2T には、次の利点があります。

  • SIP または ES+ カード不要のネイティブ ハードウェア フォワーディング
  • STP 不要の VPLS スプリット ホライズンによるループ防止
  • VLAN スケーラビリティ
  • MAC スケーラビリティ:ホスト MAC エントリは特定の顧客用のアグリゲーション ボックスのみに存在。コア ルータと他のアグリゲーション ボックスへの公開はなし
  • VLAN 相互運用性:同一顧客が複数のサイトのさまざまなサーバに異なる VLAN を設定可能
  • VPLSoGRE が使用される場合にコア ルータで MPLS が不要 BGP 自動検出により、VPLS ネイバー探索を簡素化
  • ハードウェアでの MAC アドレス ラーニングにより、ソフトウェア MAC ラーニングでのパケット損失を排除
  • 不明な宛先のハードウェア フラッディングでレートを制限
  • VPLS のための Integrated Routing Bridge(IRB; 統合ルーティング ブリッジ)