Guest

IBM Networking

Enterprise Extender (HPR/IP) Sample Configuration

Table Of Contents

Enterprise Extender (HPR/IP) Sample Configuration

Overview

SNASw Configurations

SNASw Router

DSPU Router

CIP Router

Host Definitions

SNASw Verification Commands


Enterprise Extender (HPR/IP) Sample Configuration


Overview

This sample configuration illustrates HPR using IP. Figure C-1 shows how SNASw can be used to connect to downstream devices. In this case, a downstream physical unit (DSPU) router is simulating a downstream PU connected to CS/390 through the DLUR. The DSPU router is configured as a downstream PU. The PU connects to the virtual Token Ring interface on the SNASw router by means of SRB over the physical Token Ring interface. The upstream connection to the host is done through IP. The CIP router is configured to run Cisco MultiPath Channel Plus (CMPC+).

Figure C-1 Network Topology

To implement this configuration, you need to have the following host definitions:

An external communications adapter (XCA) major node in CS/390 with "MEDIUM=HPRIP" defined

A switch major node for the SNASw CP

A switch major node for the downstream PU

A Transport Resource List (TRL)

A Profile TCP/IP with device name matching CS/390 TRL entry

Note: The downstream devices are not limited to LAN-based connections; therefore, you can use SDLC and so on. You can also use DLSw+ for downstream devices and connect into the SNASw using a VDLC port.

SNASw Configurations

SNASw Router

 Current configuration:
 !
 version 12.0
 hostname SNASW
 !
 boot system flash slot0:rsp-a3jsv-mz.120-5.XN
 enable password lab
 !
 ip subnet-zero
 !
 source-bridge ring-group 100
 !
 interface Ethernet0/0/0
  ip address 172.18.49.37 255.255.255.128
  no ip directed-broadcast
  no ip route-cache distributed
 !
 interface TokenRing2/0/2
  no ip address
  no ip directed-broadcast
  no ip route-cache distributed
  ring-speed 16
  source-bridge 200 1 100
  source-bridge spanning
 interface Virtual-TokenRing2
 description this interface is used to connect in the downstream PU
 mac-address 4000.eeee.0000
  no ip address
  no ip directed-broadcast
  ring-speed 16
  source-bridge 222 1 100
  source-bridge spanning
snasw cpname NETA hostname
 snasw port HPRIP hpr-ip Ethernet0/0/0 vnname NETMD.EEJEB
 snasw port VTOK2 Virtual-TokenRing2 vnname NETMD.EEJEB
 snasw link HPRMVSD port HPRIP ip-dest 172.18.1.41 
 router eigrp 109
  network 172.18.0.0
  no auto-summary
 !
 ip classless
 line con 0
  exec-timeout 0 0
  transport input none
 line aux 0
 line vty 0 4
  login
 !
 end
 SNASW#

DSPU Router

 !
 hostname DSPU
 !
 boot system flash 
 enable password lab
 !
 ip subnet-zero
 !
 source-bridge ring-group 300

 dspu host TOKEN xid-snd 02201002 rmac 4000.eeee.0000 rsap 4 lsap 12 
 dspu pool pool_lu host TOKEN lu 2 2
 !         

 interface TokenRing0/0
  no ip address
  no ip directed-broadcast
  ring-speed 16
  source-bridge 200 1 300
  dspu enable-host lsap 12
  dspu start TOKEN
 !
 line con 0
  exec-timeout 0 0
  transport input none
 line aux 0
 line vty 0 4
  password lab
  login    
 !
 end
 DSPU#

CIP Router

 Current configuration:
 !
 version 12.0
 hostname CIPRouter
 !
 enable password lab
 !
 microcode CIP flash slot0:cip27-6
 microcode reload
 ip subnet-zero
 source-bridge ring-group 80
 interface Ethernet0/0
  ip address 172.18.49.17 255.255.255.128
  no ip directed-broadcast
  no ip mroute-cache
 interface Channel1/0
  no ip address
  no ip directed-broadcast
  no keepalive
 !
 interface Channel1/1
  no ip address
  no ip directed-broadcast
  no keepalive
  cmpc E160 92 EETGJEB READ
  cmpc E160 93 EETGJEB WRITE
 !
 interface Channel1/2
  ip address 172.18.1.42 255.255.255.248
  no ip directed-broadcast
  no ip mroute-cache
  no keepalive
  lan TokenRing 0
   source-bridge 70 1 80
   adapter 0 4000.dddd.aaaa    
  tg EETGJEB  ip 172.18.1.43 172.18.1.42
 router eigrp 109
  network 172.18.0.0
  no auto-summary
 !
 ip classless
 ip route 172.18.1.41 255.255.255.255 172.18.1.43
 !
 line con 0
  exec-timeout 0 0
  transport input none
 line aux 0
 line vty 0
  exec-timeout 0 0
  password lab
  login
  length 75
  width 114
 line vty 1 4
  exec-timeout 0 0
  password lab
  login
 !
 end
 CIPRouter# 

Host Definitions

 CISCO.NETMD.VTAMLST(XCAEEJEB) 
 ------------------------------------------------------------------------------- 
 EEXCAJ VBUILD TYPE=XCA                                  
 EETGJ PORT MEDIUM=HPRIP,                                X
 VNNAME=EEJEB,                                           X 
 VNGROUP=EEGRPJ,                                         X 
 LIVTIME=15,                                             X 
 SRQTIME=15,                                             X 
 SRQRETRY=9,                                             X  
 SAPADDR=04 
 * 
 EEGRPJ GROUP ANSWER=ON,                                 X  
 AUTOGEN=(64,L,P),                                       X  
 CALL=INOUT,                                             X 
 DIAL=YES,                                               X  
 DYNPU=YES,                                              X  
 DYNPUPFX=$E,                                            X 
 ISTATUS=ACTIVE 

 CISCO.NETMD.VTAMLST(EETGJEB) 
 ----------------------------------------------------------------------------- 
 EETGJEBV VBUILD TYPE=TRL 
 EETGJEB TRLE LNCTL=MPC,MAXBFRU=16,                      X  
 READ=(4F92),                                            X  
 WRITE=(4F93) 



 PROFILE.TCPIP 

 DEVICE IUTSAMEH MPCPTP AUTORESTART 
 LINK samehlnk MPCPTP IUTSAMEH 
 ; 
 DEVICE EETGJEB MPCPTP 
 LINK EELINK2 MPCPTP EETGJEB 
 ; 
 DEVICE VIPADEV2 VIRT 0 
 LINK VIPALNK2 VIRT 0 VIPADEV2 
 ; 
 HOME 
 172.18.1.43 EELINK2  ; This corresponds to the host-ip-addr for the CIPRouter tg 
command.
 172.18.1.41 VIPALNK2 ; This corresponds to the ip-dest specified in the SNASW router 
link command.
 GATEWAY 
 172.18 = EELINK2 4468 0.0.255.248 0.0.1.40 
 172.18 172.18.1.42 EELINK2 4468 0.0.255.0 0.0.49.0 
 ; 
 START IUTSAMEH 
 START EETGJEB 



 VIEW       CISCO.NETMD.VTAMLST(SNASWCP) - 01.02             Columns 00001 00072
 ****** ***************************** Top of Data ******************************
 ==MSG> -Warning- The UNDO command is not available until you change
 ==MSG>           your edit profile using the command RECOVERY ON.
 000001 *        SNASWITCH CONTROL POINT
 000002          VBUILD TYPE=SWNET
 000003 *
 000004 R7507PU  PU    ADDR=01,ANS=CONTINUE,DISCNT=NO,                         X
 000005                PUTYPE=2,ISTATUS=ACTIVE,                                X
 000006                NETID=NETA,CPCP=YES,CONNTYPE=APPN,CPNAME=SNASW,HPR=YES
 000007 
 ****** **************************** Bottom of Data ****************************



 VIEW       CISCO.NETMD.VTAMLST(SNASWPUS) - 01.02           Columns 00001 00072
 ****** ***************************** Top of Data *****************************
 ==MSG> -Warning- The UNDO command is not available until you change
 ==MSG>           your edit profile using the command RECOVERY ON.
 000001 *        SNASWITCH DOWNSTREAM PU
 000002          VBUILD TYPE=SWNET
 000003 *
 000004 DSPU02   PU    ADDR=01,ANS=CONTINUE,DISCNT=NO,                         X
 000005                PUTYPE=2,ISTATUS=ACTIVE,                                X
 000006                DLOGMOD=D4C32782,MODETAB=ISTINCLM,USSTAB=USSTCPMF,      X
 000007                IDBLK=022,IDNUM=01002                                   X
 000008 DSPU02LU LU    LOCADDR=02

 ****** **************************** Bottom of Data ****************************

SNASw Verification Commands

Table C-1 lists some of the commands for verifying that SNASw is running in the router. For a full list, see the Cisco IOS Bridging and IBM Networking Command Reference.

Table C-1  SNASw Show and Trace Commands

Command
Description

show snasw session

To see the session and partner details

show snasw dlus

To verify if the DLUS is active

show snasw pu

To verify if the PU is active

show snasw link

To verify which port the link uses, the node type, and if the link is active

snasw dlctrace

To trace frames arriving and leaving SNASw

show dlctrace

To display a trace on the console; alternatively, you can dump the trace onto a server