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C H A P T E R 18

Managing the VFrame System

This chapter describes various management tasks related to maintaining the VFrame system, as opposed 
to managing a server farm, and includes the following sections:

• Backing Up and Recovering the VFrame Database, page 18-1

• Backing Up and Recovering the Golden Image Repository, page 18-4

• Configuring System Settings, page 18-6

• Migrating the Golden Image Repository, page 18-10

• Managing High Availability, page 18-13

• Server Administration Reference, page 18-15

Backing Up and Recovering the VFrame Database
Data backup is critical to reducing the risk of unexpected outages. The following topics describe VFrame 
backup and recovery:

• Understanding How VFrame Creates Automatic Backups, page 18-1

• Creating Your Own Database Backup, page 18-2

• Recovering Your Own Database Backup, page 18-2

Understanding How VFrame Creates Automatic Backups 
VFrame automatically backs up its database at regular intervals. You also can create your own backups 
whenever you want to take a snapshot of your data, in case you need to recover the database to the 
version that existed at that time.

There are two types of automatic backup:

• Logical backup—Each time the database is changed, whether from your direct actions or from data 
collection, the changes are logged in log files that reside in the /nwdisks/2/ directory in the backup 
location that you configured during initial VFrame setup. When a log file fills, it is appended to the 
lbackup file in the same directory.

• Physical backup—When the log files from logical backups are 65% full, or when one hour passes 
since the last physical backup (whichever comes first), a new physical backup of the database is 
created (the backup file), and a new lbackup is started. Before this is done, the backup and lbackup 
files are also copied to the /nwdisks/1/ directory.
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Because VFrame replaces these files at least every hour, you should not rely on them for maintaining 
your system. Periodically create your own backup files at critical milestones to ensure that you can 
recover your system to a state that is meaningful to your organization.

Note When you backup the database and if the images have changed since the last backup, it is recommended 
that you also backup the Golden Image Repository (GIR) so that the golden images on the GIR file 
system can be restored along with the database restore. This ensures that the images in the repository 
match what is in the database

Creating Your Own Database Backup
To guard against accidental data corruption (through user error) or general system problems, you should 
periodically back up the database. Create backups at significant milestones so that you can recover your 
system to a known and desirable configuration.

Procedure

Step 1 Using an SSH client, log in to the VFrame server using the admin username and password.

Step 2 Enter the db backup command with the filename that you want to use to create a backup.

The following example shows how to create a backup:

vframe# db backup scp://192.0.2.4:/root/vframeback
The DB backup file will be saved as scp://192.0.2.4:/root/vframeback.v1.2.0.84
Physical backup is completed.
Save backup file
Username: root
root Password:

The backup location must be specified. You must specify an external file path for the backup file. 
However, the directory must either reside in the location identified as the backup location during initial 
system configuration or be mounted on it.

Related Topics

• Understanding How VFrame Creates Automatic Backups, page 18-1

• Recovering Your Own Database Backup, page 18-2

Recovering Your Own Database Backup
If you find that you need to return to a previous version of the database, due to data corruption or other 
system problems, recover a previous backup file that you created. 

Before You Begin

Users should not be logged in to VFrame. The recovery process stops system services, so users will be 
disconnected during the recovery.
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Procedure

Step 1 Using an SSH client, log in to the VFrame server using the admin username and password.

Step 2 If you are using the VFrame server in a high-availability setup with another VFrame server, disable 
redundancy before recovering the database by using the no redundancy enable command in 
configuration mode.

The following example shows how to disable redundancy:

vframe# config
Enter configuration commands, one per line. End with CNTL/Z.
vframe(config)# no redundancy enable

Step 3 Enter exit to return to user EXEC mode.

Step 4 Enter the db restore command with the filename you want to use to create a backup. VFrame stops 
system services before replacing the database.

Note The host should not be the identical VFrame hostname or any interface IP of that VFrame, 
otherwise the db restore command will be rejected.

The following example shows how to restore the database:

vframe# db restore scp://192.0.2.4:/root/vframeback.v1.2.0.84
Username: root
root Password: 
Copying external files
DB restore will cause all services to restart.
Would you like to proceed? (yes/no) [no] ? y
Please enter yes or no: yes
Stopping services
Waiting for 13 out of 16 processes to shutdown
Waiting for 11 out of 16 processes to shutdown
Waiting for 9 out of 16 processes to shutdown
Waiting for 8 out of 16 processes to shutdown
Waiting for 6 out of 16 processes to shutdown
Waiting for 4 out of 16 processes to shutdown
Waiting for 3 out of 16 processes to shutdown
Waiting for 1 out of 16 processes to shutdown
Waiting for 0 out of 16 processes to shutdown
Restore from /var/log/ext_backup/backup
Thu Mar 27 12:15:07 PDT 2008 Physical Restore DB from file...
Thu Mar 27 12:15:07 PDT 2008 Bring up
Thu Mar 27 12:15:07 PDT 2008 Wait for DB on-line...
Shutdown DB.
Start ids ...
Starting services
vframe# 

In the preceding example, the scp://192.0.2.4:/root/vframeback.v1.2.0.84 directory is the location of the 
backup file. 
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Note If the backup file is generated by a release that is different from the current VFrame release, the 
backup file extension is different, and the restore is not allowed. If the backup file is generated 
by the same release, but the database schema from the backup file is different from the existing 
database schema, then the database restore is not allowed. If the VFrame release is the same but 
the build is different, the backup file is generated by a different build, and in such a case an 
attempt to restore the database is possible, but it might not be successful if the database schema 
has changed.

Step 5 If you are using redundancy, reenable it.

The following example shows how to reenable redundancy:

vframe# config
Enter configuration commands, one per line. End with CNTL/Z.
vframe(config)# redundancy enable

Related Topics

• Understanding How VFrame Creates Automatic Backups, page 18-1

• Creating Your Own Database Backup, page 18-2

• Recovering Your Own Database Backup, page 18-2

Backing Up and Recovering the Golden Image Repository
This section describes how to back up and recover the Golden Image Repository (GIR).

The command gir backup backs up the GIR to a remote storage device, and the command gir restore 
restores the GIR from a previous backup. Typically, the backup and restore GIR commands are used 
along with the database backup and restore. When the user backs up the database, the user must also 
backup the GIR so that the golden images on the GIR file system can be restored along with the database 
restore. This ensures that the image list matches what is in the database.

Requirements for backup are similar to those of GIR migrate. That is, the user must have a dedicated 
LUN or NFS volume, of sufficient size, on which to back up. In the case of LUN, the user should have 
completed the necessary masking and zoning outside the VFDC appliance so that VFDC can see the 
LUN. The command prompts the user to select from the list of LUNs currently visible to VFDC. The 
command automatically prepares the LUN for usage by creating a partition and an ext3 file system on 
the partition. In the case of NFS volume, the command prompts the user to enter the Filer IP, credentials, 
and the volume to be utilized. VFDC automatically configures the export rules to allow VFDC to access 
the volume. A qtree named vfdc_gir is created on the volume.

When the gir restore command is being executed, the user must enter details of the storage device to 
which GIR was previously backed up. VFDC will simply change the GIR mount point to this backed up 
device. 
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The following is sample output for the gir backup command:

vframe host(config)# gir backup 
Warning: Backing up Golden Image Repository will require
         shutting down all system services and copy
         of golden images might take a long time.

Would you like to backup the GIR now (yes/no) [no] ? yes

Enter the backup GIR location type: NFS or SAN (N/S) ? N
Enter the Filer IP: 192.188.2.57 Enter the Volume Name: vfdcvol1 
Migrating to a NetApp filer.
Please enter a username for 192.188.2.57: root 
Please enter a password for 192.188.2.57: 
Java and image management need to be down to run gir backup.
Is it ok to shut down these services? (yes/no): yes 
Attempting to mount backup GIR to a temporary place.
Mount successful.
Waiting for services to shutdown...
Stopped 2 of 2 services
Services are down.
Copying 32840 KB from /gir to /mnt/girtemp... copy is 100% complete 
Attempting to unmount backup GIR local.
Unmount successful.
Starting VCC services.

The following is sample output for the gir restore command:

vframe host(config)# gir restore
Warning: Restoring Golden Image Repository will require
         shutting down all system services and 
         remounting gir

Would you like to restore the GIR now (yes/no) [no] ? yes

Enter the backup GIR location type: NFS or SAN (N/S) ? N 
Enter the Filer IP: 192.188.2.57 
Enter the Volume Name: vfdcvol1 
Migrating to a NetApp filer.
Please enter a username for 192.188.2.57: root 
Please enter a password for 192.188.2.57: 
Would you like to cleanup the old GIR after restore is complete? (yes/no): yes 
Java and image management need to be down to run gir restore.
Is it ok to shut down these services? (yes/no): yes 
Attempting to mount backup GIR to a temporary place.
Mount successful.
Waiting for services to shutdown...
Stopped 2 of 2 services
Services are down.
Attempting to unmount the old GIR.
Removing 32840 KB from /gir/*... remove is 100% complete 
Unmount successful.
Remounting new GIR to permanent location.
Remount successful.
Starting VCC services.
Updating System Configuration to reflect new GIR.
GIR restore is complete 
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Configuring System Settings
Several system-level settings affect how the product functions. This section describes how to configure 
these settings, and includes the following topics:

• Configuring General System Preferences, page 18-6

• Configuring Device Managers, page 18-7

• Configuring SMTP Credentials, page 18-8

• Configuring Notifications, page 18-9

• Configuring Static Routes, page 18-10

Configuring General System Preferences
This section describes how to configure the general system preferences.

Before You Begin

Log in to the Admin context to configure general system preferences.

Procedure

Step 1 Choose Tools > VFrame Administration > General (see the “General Dialog Box” section on 
page 18-15).

Step 2 Click the General tab (see the “General Tab, General Dialog Box” section on page 18-15).

Step 3 To configure the general system preferences, perform the following steps:

The existing configurations are listed against each item. Enter or change the values as required. The 
following items are available for configuration:

a. Database Pruning

– Keep jobs history for (days)—Configure the number of days that VFrame keeps job-related 
information such as the job information shown in the Job Log GUI. Jobs that have outstanding 
error results associated with them are not deleted even if they are older than the threshold. 

– Keep reporting history for (days)—Configure the number of days that VFrame keeps 
report-related information. 

Run Database Pruning at (HH:MM:[AM/PM])—Configure the daily time at which the prune job 
runs. If the specified time has already passed, the job is scheduled for the next day. The time 
must be specified as server time. The current server time can be found in the lower, right corner 
of the main VFrame GUI in the 24-hour format. However, it must be entered in the 12-hour 
format in the preferences GUI.

There is an automatically scheduled job (DB Pruner) that runs on a daily basis and removes old 
data from the database. When the VFrame Java process starts for the first time, the job is 
scheduled to run at 2:00AM and every 24 hours thereafter. The following scheduled runtime for 
the job appears in the Tools > Job Logs window. The user can configure what time the job runs 
and for how long data is available by choosing Tools > VFrame Administration > General 
and editing the preferences under 
Tools > VFrame Administration > General > Database Pruning.
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b. SNMP Settings

Timeout (seconds)— The time, in seconds, for VFrame to stop waiting for an answer to an 
SNMP query.

Retries—The number of times VFrame should retry a failed SNMP query.

c. SSH Session Settings

LOM Manager Timeout (in milliseconds)—How long to wait for the reply to each request to a 
LOM manager during an SSH session or Perl macro execution, in milliseconds.

Storage Manager Timeout (in milliseconds)—How long to wait for the reply to each request to 
a storage manager during an SSH session or Perl macro execution, in milliseconds.

FWSM Timeout (in milliseconds)—How long to wait for the reply to each request to an FWSM 
during an SSH session, in milliseconds.

Ethernet Switch Timeout (in milliseconds)—How long to wait for the reply to each request to a 
Catalyst 6500 supervisor engine during an SSH session, in milliseconds.

Socket Connection Timeout (in milliseconds)—How long to wait when trying to establish an 
SSH connection before ending the attempt, in milliseconds.

d. User Defined CLI Prompt Settings

CLI Prompt—The prompts defined on Ethernet switches and service modules. Enter all prompts 
that are configured on the devices you will manage, for user EXEC and privileged (enable) 
mode. Separate the prompts with commas, spaces, or both. The default prompts are > and #.

e. Discovery

List of VSANs to be excluded from SAN Discovery—The user can specify a list of VSANs that 
should be excluded from SAN discovery. This list is user configurable.

Configuring Device Managers
When you view devices, for example, by choosing View > Resources or Tools > Resource Pools, you 
can right-click the device to get a shortcut menu. One of the commands on the menu, Device Manager, 
allows you to start an external program to connect to that device. For example, you could start an SSH 
client session with a Catalyst switch.

Before you use the Device Manager command, you must configure the applications from which users 
can select.

Before You Begin

Log in to the Admin context to configure device managers.

Procedure

Step 1 Choose Tools > VFrame Administration > General (see the “General Dialog Box” section on 
page 18-15).

Step 2 Click the Device Managers tab (see the “Device Managers Tab, General Dialog Box” section on 
page 18-17).

Step 3 To add a device manager, perform the following steps:

a. Click the New button. The Assign Device Manager dialog box opens.

b. Enter this information:
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• Device Type—Choose the type of device from the drop-down list, for which this application can 
be used. For example, Catalyst 6K Switches. When users choose the Device Manager for the 
selected device, they are presented only with device managers defined for the type of device 
selected. 

• Display Name—Enter the name of the device manager. The name appears in the device 
managers table and also is the name users will choose when they use the Device Manager for 
the selected device. 

• Application—Choose the application to use for the device manager, if it is already defined in 
the list. Otherwise, choose Browse an Application from the drop-down list. You must choose 
the list item, not the item that appears in the combo box.

To choose a Windows command-line utility, find it in the Windows/system32 (or equivalent) 
folder.

• Parameters and Variables—Choose the variables to include as parameters on the application 
executable command (if any). Type in hard-coded parameters (such as -h) and add variables 
where appropriate.

To add variables to the parameters list, choose them in the variables list in the order in which 
they should appear on the command. The available variables differ depending on the device 
type, so you must first choose a device type before choosing variables. VFrame replaces the 
variables with the specific properties of the device chosen when the Device Manager command 
is used. You must choose only those variables that your device manager is expecting. For an 
explanation of the available variables, see the “Device Managers Parameter Variables” section 
on page 18-18.

c. Click OK. VFrame adds the device manager to the device managers table, but the information is not 
yet saved.

Step 4 To modify the device manager properties, choose it in the table and click Edit. Modify the Assign Device 
Manager dialog box and click OK. VFrame changes the device manager properties in the device 
managers table, but the information is not yet saved.

Step 5 To delete a device manager, choose it in the table and click Delete. VFrame deletes the device manager 
from the device managers table, but the deletion is not yet permanent.

Step 6 Click Apply in the General dialog box to save all changes you have made in the device managers list.

Related Topics

• Action and Shortcut Menu Commands, page 7-32

Configuring SMTP Credentials
You can configure fault notifications for resources or service networks to send e-mail notifications to 
selected users. For VFrame to send these notifications, you must configure an e-mail address in the 
SMTP settings.

Before You Begin

• Log in to the Admin context to change SMTP settings.

• Create the e-mail account you want VFrame to use in your SMTP server.
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Procedure

Step 1 Choose Tools > VFrame Administration > General (see the “General Dialog Box” section on 
page 18-15).

Step 2 Click the SMTP tab (see “SMTP Tab, General Dialog Box” section on page 18-20).

Step 3 Enter the SMTP mail server and e-mail account name that VFrame should use for sending e-mail 
notifications. If the port number is different from the default (25), enter that number. If the SMTP server 
requires authentication, enter the required login name and password for logging in to the server.

Step 4 Click Test Settings to ensure that VFrame can use the specified account. In the send email to dialog box, 
you are prompted for an e-mail address to receive the test message, for example, email@example.com. 
Specify the e-mail address and click OK.

Step 5 Click Apply to save your settings. 

Configuring Notifications
You can identify a syslog server that should receive messages from VFrame. You can then use your 
syslog server to monitor the VFrame system.

Before You Begin

Log in to the Admin context to change syslog notification settings.

Make sure that the syslog server exists and is configured. VFrame does not configure or manage the 
syslog server.

Procedure

Step 1 Choose Tools > VFrame Administration > General (see the “General Dialog Box” section on 
page 18-15).

Step 2 Click the Notification tab (see “Notification Tab, General Dialog Box” section on page 18-21).

Step 3 Enter the IP address or DNS name of the syslog server in the Server IP Address/FQDN field.

Step 4 Choose the module and severity for syslog notifications. For each module you choose, also choose the 
severity of the message. 

Messages with your selected severity (or worse) are sent to the syslog server. The levels of severity are 
Fatal, Error, Warning, Info, Debug.

Step 5 Click Apply to save your changes.
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Configuring Static Routes
VFrame must have a route to any address range it manages, that is, any address range you include in IP 
Address Range resource pools and DHCP Ranges. If the default gateway you configure for VFrame has 
routes to all of these address ranges, you do not need to configure any static routes. Configure static 
routes only if VFrame is unable to route packets to a managed network.

To configure static routes, you can use this procedure, or you can use the ip route command in a VFrame 
CLI session, as described in the Cisco VFrame Data Center Command Reference. There is no difference 
between the methods.

Before You Begin

Log in to the Admin context to change the routing table.

Procedure

Step 1 Choose Tools > VFrame Administration > Network (see “Network Dialog Box” section on 
page 18-22).

Step 2 Click the Routing tab (see “Routing Tab, Network Dialog Box” section on page 18-22).

Step 3 To add a route:

a. Click the New button. The Add New Route dialog box opens.

b. Enter this information:

• Network Address—The network address for the network containing the IP address range that 
needs a static route. For example, 10.100.50.0.

• Netmask—Choose the subnet mask for the network address from the drop-down list.

• Gateway—Enter the IP address of the gateway that VFrame should use when communicating 
with the network.

• Metric—Enter the relative weight for this gateway, from 0 (the highest) to 32767.

c. Click OK. VFrame tests the route and adds it to the routing table if it is usable.

Step 4 To delete a route, choose it in the table and click the Delete button.

Related Topics

• Adding IP Address Resources, page 9-8

Migrating the Golden Image Repository
The golden image repository is the disk space that you use to store golden images. Eventually, you might 
need to move the repository from its current location to a new one. For example, you might be replacing 
the physical storage device, or you might be running out of space in the current repository.

To view the current older image of the repository setup, and its available space, choose 
Tools > Golden Images and click Repository Properties to open the Golden Image Repository Setup 
dialog box. 

This displays the type, total size (MB), used size (MB), total inodes and used inodes of the current image 
of the repository setup.
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The options for the golden image repository are as follows:

• Local—On the VFrame Data Center Director.

• SAN—On a logical unit in a storage array. For new repositories, VFrame removes all partitions from 
the logical unit, creates a new single partition covering the entire disk, and creates the appropriate 
file systems. Before migrating the repository to a LUN, the LUN must be accessible from the 
VFrame Data Center Director. The LUN must be zoned with one or both of the VFrame Data Center 
Director HBAs and mapped on the storage array.

• NFS—On a volume in a NAS filer. For new repositories, VFrame creates a new Qtree named 
vfdc_gir and modifies the export rule for the Qtree and volume.

If you are configuring VFrame for high availability, you must configure the golden image repository on 
a LUN or volume on the primary VFrame. It is not necessary to set up the golden image repository on 
the second VFrame.

If you wish to store a large number of golden images, it is also best to use a LUN or volume because of 
the relatively limited space on the VFrame Data Center Director. We recommend that you do not use the 
repository volume or LUN for other purposes. Instead, devote its use to the repository.

Because golden image repository configuration requires the shutdown of some services, it is a disruptive 
process. It is best to choose a location with sufficient storage during initial system configuration.

Note Setup of the golden image repository does not affect any operational servers, which continue to function 
normally. During setup, the VFrame user interface is not available. Setup the repository during off hours 
to minimize user disruption.

Before You Begin

You cannot use a volume or LUN that is currently managed in VFrame.

Create or locate a location for the repository, and gather the information you will need to identify the 
location. You will be asked for this information:

• For NAS filer volumes:

– IP address of the NAS filer.

– Volume name.

– User name and password.

• For storage array LUNs:

– Port World-Wide Name (WWN) for the storage array port.

– Logical unit number.

Procedure

Step 1 Using an SSH client, log in to the VFrame server using the admin username and password.

Step 2 In user EXEC mode, enter the config command to enter configuration mode:

vframehost# config 
Enter configuration commands, one per line. End with CNTL/Z.
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Step 3 Enter the gir setup command. Enter yes when asked if you want to setup the repository:

vframehost(config)# gir setup 
Warning: Golden Image Repository setup will require shutting down
         system services, making VFDC temporarily unavailable and
         migration of golden images might take a long time.

Would you like to setup the GIR now (yes/no) [no] ? yes 

Step 4 Follow the prompts to specify the storage location of the repository. This command migrates the 
repository from its existing location to the new location. 

The following example specifies a NAS filer volume: 

Enter the new GIR location type: Local, NFS or SAN (L/N/S) ? N
Enter the Filer IP: 192.168.0.57
Enter the Volume Name: vfdcvol1
Migrating to a NetApp filer.
Please enter a username for 192.168.0.57: root
Please enter a password for 192.168.0.57: 

Step 5 If the repository is not currently on the local system, you are asked for the login information for the 
current repository. Enter the required information. 

The following prompts appear if the repository is on a NAS filer volume:

Migrating to a NetApp filer.
Please enter a username for 192.168.0.57: root
Please enter a password for 192.168.0.57: 

Step 6 You are next asked whether you want the old repository cleaned up. If you respond yes, all files in the 
old repository are deleted:

Would you like to cleanup the old GIR after migration is complete? (yes/no): yes 

Step 7 You are next asked to confirm that you want to shut down services and reconfigure the repository. If you 
answer no, your configuration changes are not applied, and no changes are made to the repository. After 
shutting down services, VFrame copies the golden images to the new location, deletes the contents of 
the old repository if you elected to do so, and restarts services.

The following example shows how migration is run:

Proceed with shutting down of system services? (yes/no): yes
Attempting to mount new GIR to a temporary place.
Mount successful.
Waiting for services to shutdown...
Stopped 2 of 2 services
Services are down.
Copying 847668 KB from /gir to /mnt/girtemp... copy is 100% complete
Attempting to unmount the old GIR.
Removing 847668 KB from /gir/*... remove is 100% complete
Unmount successful.
Remounting new GIR to permanent location.
Remount successful.
Starting VCC services.
Updating System Configuration to reflect new GIR.
GIR migrate is complete.
vframehost(config)#

Step 8 To verify the repository configuration, you can enter the show gir command in user EXEC mode.

The following example shows how to use the show gir command:

vframehost(config)# exit
vframehost# show gir
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Current GIR Information: NFS - Filer: 192.168.0.57 Volume: vfdcvol1
Size Total (MB): 32768
Size Used (MB): 5806
Inodes Total:    5383528
Inodes Used:     177560

Related Topics

• Managing Golden Images, page 8-1

• Understanding the Golden Image Repository, page 8-3

Managing High Availability
You can configure two VFrame Data Center Directors as a redundant pair. This high-availability 
configuration ensures that there is a backup system available in case the primary system fails. These 
sections help you understand and manage redundancy. Redundancy must be configured during initial 
system setup, as explained in the Cisco VFrame Data Center Installation and Configuration Guide. 

This section gives you further information about redundancy and how to manage it in a functioning 
system, and includes the following topics:

• Understanding VFrame High Availability, page 18-13

• Setting up VFrame High Availability, page 18-14

• Changing the Active Status of a System, page 18-14

Understanding VFrame High Availability
You can configure two VFrame Data Center Directors as peers in a single redundant pair. In a redundant 
pair, only one member of the pair is the active system; the other member is the standby. If the active peer 
stops functioning, the standby takes over for it, so that the time the VFrame system is down is minimized. 
This provides a high-availability setup required by many data centers.

When configured as a redundant pair, any update to the VFrame database requires a concurrent update 
to the database of the standby system. This maintains consistent databases and minimizes data loss 
caused by system problems.

During initial system configuration, the first system that you configure becomes the active peer. If the 
active system reboots, shuts down, or otherwise becomes unavailable, the standby system takes over and 
becomes the active system. It remains active unless it becomes unavailable for some reason. No member 
of the pair is the “default” active member. If you reboot the systems, whichever finishes booting first 
becomes the active member (in case both finish rebooting at the same time, the system with the higher 
IP address becomes the active member). However, if required, you can force a system to become the 
active or standby peer if you need to for any reason (see Changing the Active Status of a System, 
page 18-14).

From a user perspective, there is one difference between a system running as a redundant pair and one 
running standalone. Instead of logging in to the system using the system management interface IP 
address, users log in using the virtual IP (VIP) address of the management interface. The VIP address is 
the same for both members of the redundant pair, so user connections are completed no matter which 
device is active. If you need to use the CLI, however, you need to log in to the management interface IP 
address to ensure that you are configuring the expected system.
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If you need to reboot or shut down the active member of a redundant pair, first use the redundancy 
resign command to give up active status. Explicit resignation prevents a delay in the standby member 
taking over active status.

Setting up VFrame High Availability
This section describes how to set up VFrame high availability.

To setup a VFrame Data Center high availability pair, the user must enable high availability in both 
VFrame Data Centers.

In the first VFrame Data Center, before issuing the redundancy peer < > command, perform the gir 
migrate command to use the remote GIR first. Then use redundancy peer <any-peer-ipaddress> to 
enable high availability.

In the second VFrame Data Center, use the local GIR. Use redundancy peer <any-peer-ipaddress> to 
enable high availability.

Caution Never use the remote GIR on the secondary VFrame Data Center before you turn on the high availability 
feature.

The following is an example to set up high availability between vfdc-1 and vfdc-2: 

If the vfdc-2 interface IP addresses are 172.16.0.2, 192.168.0.16, and 10.0.0.8, then the command is as 
follows for vfdc-1:

vfdc-1 (config)# redundancy peer 172.16.0.2

or

vfdc-1 (config)# redundancy peer 192.168.0.16

or

vfdc-1 (config)# redundancy peer 10.0.0.8

Once high availability is setup, use the no redundancy enable command to disable HA. The system 
remembers it's peer, if no configuration changes have taken place on the peer. Later on, the redundancy 
enable command can be used to enable HA.

Changing the Active Status of a System
In a redundant pair, one peer is active, the other is standby. You can force the active/standby status to 
change if necessary. For example, you might want to change the active peer to the standby peer to do 
system maintenance or to recover the database.

Procedure

Step 1 Log in to the system whose status you want to change. Use the management interface IP address, not the 
virtual IP (VIP) address.

If you are not sure about the status of the system, use the show redundancy status command to 
determine if the system is the active or the standby system.
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Step 2 Use the config command to enter configuration mode:

vframehost# config 
Enter configuration commands, one per line. End with CNTL/Z.

Step 3 Do one of the following:

• If the system you are logged in to is the active peer, use the redundancy resign command to change 
the status from active to standby, and give active control to the peer.

vframehost(config)# redundancy resign 

• If the system is the standby peer, use the redundancy coup command to change the status from 
standby to active, taking control from the peer.

vframehost(config)# redundancy coup 

Related Topics

• Understanding VFrame High Availability, page 18-13

Server Administration Reference
This section describes the dialog box you use for VFrame server administration, and includes the 
following topics:

• General Dialog Box, page 18-15

• Network Dialog Box, page 18-22

General Dialog Box
The General dialog box includes tabs for various system-level settings, which affect system-wide 
behaviors. You can configure these settings only in the Admin context. This section includes the 
following topics:

• General Tab, General Dialog Box, page 18-15

• SMTP Tab, General Dialog Box, page 18-20

• Notification Tab, General Dialog Box, page 18-21

• Device Managers Tab, General Dialog Box, page 18-17

• Device Managers Parameter Variables, page 18-18

General Tab, General Dialog Box

Use the General tab in the General dialog box to configure or change the system preferences.

How to Get to This Dialog Box

Choose Tools > VFrame Administration > General. You may click the General tab, the Device 
Managers tab, the SMTP tab, or the Notification tab.
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Related Topics

• Configuring General System Preferences, page 18-6

Field Reference

Table 18-1 General Dialog Box

Element Description

General tab

Various system property preferences are stored here.

Database Pruning Properties that control how long certain types of data is kept in the database.

• Keep job history (days)—The number of days to keep information about 
the job run status and logs for jobs.

• Keep reporting history (days)—The number of days to keep information 
for user-generated reports, such as resource utilization reports.

• Run Database Pruning at (HH:MM:[AM/PM])—The configured time to 
run database pruning jobs.

SNMP Settings Properties that control how SNMP queries are handled.

• Timeout (seconds)—The time, in seconds, for VFrame to stop waiting 
for an answer to an SNMP query.

• Retries—The number of times VFrame should retry a failed SNMP 
query.

SSH Session Settings Properties that control how SSH sessions from VFrame are handled.

• LOM Manager Timeout (in milliseconds)—How long to wait for the 
reply to each request to a LOM manager during an SSH session or Perl 
macro execution, in milliseconds.

• Storage Manager Timeout (in milliseconds)—How long to wait for the 
reply to each request to a storage manager during an SSH session or Perl 
macro execution, in milliseconds.

• FWSM Timeout (in milliseconds)—How long to wait for the reply to 
each request to an FWSM during an SSH session, in milliseconds.

• Ethernet Switch Timeout (in milliseconds)—How long to wait for the 
reply to each request to a Catalyst 6500 supervisor engine during an SSH 
session, in milliseconds.

• Socket Connection Timeout (in milliseconds)—How long to wait when 
trying to establish an SSH connection before ending the attempt, in 
milliseconds.
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Device Managers Tab, General Dialog Box 

Use the Device Managers tab to configure programs that you access using the Device Manager command 
by choosing, for example, the View > Resources or Tools > Resource Pools. You can define different 
device managers for each type of device that VFrame supports. When you choose a device, and then 
choose the Device Manager command from the right-click shortcut menu, you can choose a program that 
you configured for the device, and VFrame starts the program for you. For example, you can configure 
an SSH client as a device manager for Catalyst switches, and start an SSH connection to the switch from 
the VFrame interface.

How to Get to This Tab

Choose Tools > VFrame Administration > General, and then click the Device Managers tab.

Related Topics

• Configuring Device Managers, page 18-7

Field Reference

User Defined CLI 
Prompt Settings

Properties that identify the prompts for the command-line interface (CLI) for 
devices. These settings are required for VFrame to connect to the devices 
using SSH. If you configure prompts that are different from the Cisco IOS 
software defaults, you must update this preference:

• CLI Prompt—The prompts defined on Ethernet switches and service 
modules. Enter all prompts that are configured on the devices you will 
manage, for user EXEC and privileged (enable) mode. Separate the 
prompts with commas, spaces, or both. The default prompts are > and #.

Discovery Properties that identify list that should be excluded from SAN discovery:

• List of VSANs to be excluded from SAN Discovery—The user can 
specify a list of VSANs that should be excluded from SAN discovery. 
This list is user configurable.

Table 18-1 General Dialog Box (continued)

Element Description

Table 18-2 Device Managers Tab, General Dialog Box

Element Description

Device Type The type of device for which this device manager is defined.

Display Name The name for this device manager. The name appears here and also in the 
selection list when you choose the Device Manager command by clicking 
View > Resources or clicking Tools > Resource Pools

Application The path and filename of the application that will be started if the user 
chooses this device manager.

Parameters The parameters that will be added to the application executable command 
when it is started. For example, the management IP address ($MgmtAddr).
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Device Managers Parameter Variables

When you configure a device manager as described in Configuring Device Managers, page 18-7, you can 
include variables as parameters on the application executable. For example, with an SSH client, you can 
pass it an IP address as a parameter, which makes a connection directly to the device, instead of just 
starting the SSH client.

The parameters you can use depend on what the application can accept and on what variables VFrame 
makes available to you (they are limited by device type). Choose only those variables that your 
application can accept.

When configuring device manager parameters, the following variables are available for use. Unless 
otherwise noted, the variables are available for all device types.

Keep in mind that you must follow the parameter rules of the application. For example, if you must 
include a keyword parameter to pass one of these variables, type in the parameter before adding the 
variable. For example, an SSH client might require the -h parameter to pass the $MgmtAddr variable: -h 
$MgmtAddr.

To see the values of these variables for a specific device, right-click the device on the Resources or Pools 
tabs, or on the Acquired Resources tab on the Operations tab, and choose Properties. On the Properties 
dialog box, choose the Device Managers tab, and the variables with their values are listed in the bottom 
part of the dialog box.

New button Click this button to add a device manager to the table. You are prompted to 
enter the information described above for the route. Keep the following tips 
in mind:

• When selecting an application, you must choose Browse an 
Application from the drop-down list. You must choose the list item, not 
the item that appears in the combo box.

• To add variables to the parameters list, choose them in the variables list 
in the order in which they should appear on the command (if any). The 
available variables differ depending on the device type, so you must first 
choose a device type before choosing variables. VFrame replaces the 
variables with the specific properties of the device selected when the 
Device Manager command is used. You must choose only those 
variables that your device manager is expecting. For an explanation of 
the available variables, see the “Device Managers Parameter Variables” 
section on page 18-18.

You must also type in any nonvariable keywords required by the 
application. For example, if you are configuring an SSH client and want 
to pass the client the switch IP address, you probably need to pass the 
$MgmtAddr variable on the -h parameter. To do this, type in -h and then 
insert $MgmtAddr:

-h $MgmtAddr 

Edit button Click this button to edit the selected device manager properties.

Delete button Click this button to delete the selected device manager.

Apply button Click this button to save any changes that you made to the device manager 
table. Making changes in the table is not sufficient to save your changes.

Table 18-2 Device Managers Tab, General Dialog Box (continued)

Element Description
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The following variables are available for use as device manager parameters:

• $MgmtAddr—The management IP address of the selected device or service module.

– For Content Switching Modules (CSM), the address is the IP address of the containing switch 
supervisor engine.

– For FWSM security contexts, the address is the IP address of the FWSM module in which the 
context is defined.

– For physical (hardware) servers, the address is the IP address of the LOM interface.

– For logical servers (based on operating system), the address is the IP address of the interface 
that PXE booted.

– For LOM managers, the address is the IP address or hostname for the primary manager.

• $AltMgmtAddr—The alternate management IP address. To set this IP address for a device, choose 
View > Resources or Tools > Resource Pools and right-click the specific device, and then click 
Properties. In the Properties dialog box, click the Device Managers tab, choose the $AltMgmtAddr 
variable and click Edit. You are presented with a dialog box in where you can enter the alternate IP 
address. 

• $AltMgmtPort—The alternate management port. To set this port for a device, right-click the device 
on the Resources or Pools tabs, or on the Acquired Resources tab on the Operations tab, and choose 
Properties. On the Properties dialog box, choose the Device Managers tab, choose the 
$AltMgmtPort variable and click Edit. You are presented a dialog box in which you can enter the 
alternate port.

• $BladeId—For physical (hardware) servers, if the server is a blade server, the blade identifier. You 
should also evaluate the $IsABlade variable to determine if the blade identifier is a valid value. 
Ignore the blade ID if $IsABlade is false.

• $getMgmtIPAddr—For storage managers, the IP address or hostname of the primary storage 
manager.

• $ImageName—For logical servers (based on operating system), the name of the golden image that 
is configured for the server.

• $InterfaceName—For Ethernet switch ports, the name of the interface, for example, gi3/24.

• $IsABlade—For physical (hardware) servers, whether the server is a blade server. Possible values 
are true or false.

• $Label—The name of the device as it appears in the VFrame interface, which is not necessarily the 
same as anything configured on the device.

• $LOMGatewayAddr—The LOM gateway IP address.

• $LOMLabel—The display name of the LOM

• $LOMType—The LOM type

• $LomUserAttribute1, 2, 3, 4—For physical (hardware) servers, these are user-defined attributes that 
are configured in the LOM manager inventory file, as described in Creating LOM Inventory File for 
Application Servers, page 3-17.

• $Model—For physical (hardware) servers, the server model. For example, ProLiant DL360 G4p.

• $NetAppLabel—For Qtrees, the label for the NAS filer that hosts the Qtree as it appears in the 
VFrame interface.

• $ServerMacAddr—For physical (hardware) servers, the MAC address for the server. If the server 
has more than one MAC address, VFrame selects one of them.
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• $SlotNumber—Service module slot number for content service modules and firewall service 
modules.

• $SnName—For logical servers (based on operating system), the name of the service network in 
which the server is running.

• $SwitchLabel—For Ethernet switch ports, the label for the switch that hosts the port as it appears 
in the VFrame interface.

• $Vendor—For physical (hardware) servers, the name of the company that made the server. For 
example, HP.

• $VsgName—For logical servers (based on operating system), the name of the server group in which 
the server is defined.

SMTP Tab, General Dialog Box 

Click the SMTP tab in the General dialog box to identify the e-mail account that VFrame should use to 
send e-mail. VFrame can send e-mail notifications for various reports and monitoring policies. To create 
notifications, you must configure the e-mail address and SMTP credentials for the product.

How to Get to This Tab

Choose Tools > VFrame Administration > General, and then click the SMTP tab.

Related Topics

• Configuring SMTP Credentials, page 18-8

Field Reference

Table 18-3 SMTP Tab, General Dialog Box

Element Description

Mail Serv (SMTP) The IP address or DNS name of the SMTP server the product should use to 
send e-mails, for example, mailserver.example.com.

Port (default 25) The SMTP server port for sending e-mail. The default is 25. Change this only 
if your SMTP server is configured to use a different port.

From The existing e-mail account name that the product should use when sending 
e-mail, for example, vframe@example.com.

Email Notification for 
System Errors

The e-mail address of the person or group who should be notified in the case 
of VFrame system errors. For information on the system faults that can result 
in a notification being sent to this address, see the show fault command in 
the Cisco VFrame Data Center Command Reference.

You can enter only one e-mail address in this field.
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Notification Tab, General Dialog Box 

Use the Syslog tab in the General dialog box to identify the syslog server that should receive messages 
from the product. You can then use your syslog server to monitor the VFrame system.

How to Get to This Tab

Choose Tools > VFrame Administration > General, and then click the Notification tab.

Related Topics

• Configuring Notifications, page 18-9

Field Reference

Server Requires 
Authentication

Whether the SMTP server is configured to require users to log in before 
sending e-mail. If you choose this, you must fill in the following fields:

• Login—The account name required to log in to the SMTP server, for 
example, vframe.

• Password—The password for the selected account. Asterisks are 
displayed instead of the password.

Test Settings Click this button to test whether the product can use the SMTP credentials 
you entered. You are prompted to enter an e-mail address to receive the test 
message.

Table 18-3 SMTP Tab, General Dialog Box (continued)

Element Description

Table 18-4 Notification Tab, General Dialog Box

Element Description

Server IP 
Address/FQDN

The IP address or DNS name of the syslog server.

Module selection and 
severity table

This table lists the types of messages you can send to the syslog server. For 
each type, you also choose the VFrame severity level for the messages that 
should be sent to the syslog server. The selectable modules are as follows:

• Audit Logs—Record of user actions

• Jobs—Logs for all running actions like discovery, snapshot, replication, 
deploy, start server, etc.

• Notifications—Alerts generated based on health and status monitoring

• Server Mgmt Services—Managed Server related services like DHCP, 
image management, Host Agent Interface

• VFrame System Services—Various system services like Authentication, 
CDP, High Availability, System Configuration, System Manager etc.

Messages of the severity level that you choose, plus any worse severities, are 
sent to syslog. The severities, highest first, are Fatal, Error, Warning, Info, 
Debug.
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Network Dialog Box
The Network dialog box includes the Routing setting that affects system-wide behavior. You can 
configure these settings only in the Admin context. This section includes the following topic:

• Routing Tab, Network Dialog Box, page 18-22

How to Get to This Dialog Box

Choose Tools > VFrame Administration > Network. Click the Routing tab.

Related Topics

• Configuring System Settings, page 18-6

Field Reference

Routing Tab, Network Dialog Box 

Use the Routing tab to configure static routes for networks or hosts that VFrame manages. VFrame must 
have a route to any address range you include in IP Address Range resource pools and DHCP Ranges. 
The default gateway is initially specified when the user configures the VFDC director using the setup 
CLI. Additional routing can be configured either from the CLI, logged in as the admin user to the VFDC 
CLI shell or from the GUI. If the default gateway you configure for VFrame has routes to all of these 
address ranges, you do not need to configure any static routes. Configure static routes only if VFrame is 
unable to route packets to a managed network.

Configuring static routes in this table is equivalent to using the ip route command in a VFrame CLI 
session, as described in the Cisco VFrame Data Center Command Reference.

How to Get to This Tab

Choose Tools > VFrame Administration> > Network, and then click the Routing tab.

Related Topics

• Configuring Static Routes, page 18-10

Table 18-5 Network Dialog Box

Element Description

Routing Tab

The VFrame routing table contains static routes for managed networks (those included in the IP 
Address Range resource pool).

For information about these fields, see the “Routing Tab, Network Dialog Box” section on page 18-22.
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Field Reference

Table 18-6 Routing Tab, Network Dialog Box

Element Description

Network Address The network address for the network containing the IP address range that 
needs a static route. For example, 10.100.50.0.

You can also enter a host address to define a route to a single host.

Netmask The subnet mask for the network address.

Use 255.255.255.255/32 for a host address.

Gateway The IP address of the gateway that VFrame should use when communicating 
with the network or host.

Metric The relative weight for this gateway, from 0 (the highest) to 32767. If more 
than one route exists for a network, VFrame tries the highest priority route 
first before trying other routes.

New button Click this button to add a static route to the table. You are prompted to enter 
the information described above for the route.

Delete button Click this button to delete the selected route.
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