CHAPTER 1

Viewing Reports

This chapter provides information about creating and using reports, and includes the following sections:
e Understanding Reports, page 16-1
e Working with Reports, page 16-4
e Troubleshooting Reports, page 16-12
¢ Field Reference Reports, page 16-12

Understanding Reports

Generate the reports using a wizard. You can generate the report immediately or later at a scheduled date
and time and view them in chart or table format. You can choose to send scheduled reports in PDF format
to specified e-mail addresses. Scheduled reports are sent as a ZIP file that contains the chart in PDF
format and the table in csv format.

This section describes the available report types, and includes the following topics:
e Understanding the Logged In Users Report, page 16-1
¢ Understanding the Audit Report, page 16-2
e Understanding Service Network Availability Reports, page 16-2
e Understanding Resource Utilization Reports, page 16-2
¢ Understanding Logical Server Report, page 16-3

Understanding the Logged In Users Report

The logged in users report displays the date and time users logged in to VFrame. The report provides
details such as the hostname, IP address, username, context, session ID, and type of client.

Related Topics
e Generating the Logged in Users Report, page 16-4

e Logged In Users Report, page 16-12
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Understanding the Audit Report

You can view a log of various actions taken in the system by users, including any action that results in a
change to the VFrame database.

Related Topics
e Generating the Audit Report, page 16-5

e Audit Report, page 16-13

Understanding Service Network Availability Reports

You can generate reports to determine when the service network was running, which resources were
used, and which network elements used which resources.

You can generate three types of service network availability reports:

¢ Running history—How often the service network was running during a selected time period. For
example, between 8:00 a.m. and 5:00 p.m., the service network was running for four hours.

e Usage by resource type—How the resources were used on average in a given network for a selected
time period. For example, service network X on average used one FWSM, three servers, and two
Ethernet switches.

e Resource usage by logical network element—The number of resources that were acquired by the
logical network elements when the service network started during a selected time period. For
example, when the service network started, a Layer 2 switch (network element) acquired an IP
address, a logical server (network element) acquired a QTree, and so on.

Related Topics
e Generating Service Network Availability Reports, page 16-5

e Service Network Availability Reports, page 16-14
e Service Network Availability—Results, page 16-23

Understanding Resource Utilization Reports

You can generate three types of resource utilization reports to see how the resources are used in the
network.

e Resource Pool Size—The size of the selected resource pool at a specified time period. The size of a
resource pool changes if the resources are deleted or removed, or if the network loses visibility of
those resources. For example, at 5:00 p.m. you had five resources, then at 7:00 p.m. the resource
pool size changed to two because three resources were deleted or removed, or the network lost
visibility of those resources.

¢ Resource Pool Utilization—The amount of resources in the pool that were used by all networks or
by a particular network for a selected time period. For example, at a particular time across three
networks, network 1 used five resources, network 2 used six resources, and network 3 used two
resources.

By default, the report generates data for all networks. To generate a report for a particular network,
select that network from the drop-down list.
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e Resource Pool Utilization by Service Networks—The percentage of resources in the pool that were
used by particular service networks in a selected time period.

This report is presented in graph or table formats. The graph provides an at-a-glance view of the
percentage of resources used by different networks and the percentage of resources that are still
available. For example, 20% of the resources were used by network 1, 60% was used by network 2,
and 20% was unused.

Related Topics

¢ Generating Resource Utilization Reports, page 16-7
¢ Resource Utilization Reports, page 16-15

e Service Network Availability—Results, page 16-23

Understanding Logical Server Report

Note

You can schedule, generate, and save a report for selected server variables. The preselected variables in
the Trend Report Wizard are directly related to the variables you selected in the Monitoring/Trend
policies dialog box. You can choose to generate a report for all the pre-selected variables, or for only
those variables for which you need information.

You cannot select variables that are not a subset of variables in the policies dialog box.

You define the Monitoring/Trend variables in virtual context in the Monitoring Trend dialog box (choose
View > Operations and choose an item from the Service Network list. Click Policies and wait for the
dialog box to load. Choose a server group from the LN Elements list and click the Monitoring/Trend
tab; see Monitoring and Trend Policies, page 14-11). From the Monitoring/Trend policies dialog box,
you set the time interval for VFrame to poll the servers (in a selected server group) for specific data
called trend variables. The trend variables are grouped into four categories: system, interface, HBA
ports, and NFS statistics.

VFrame monitors and collects periodic information for the server trend variables that you select in the
Monitoring/Trend policies dialog box and saves it in the database. Data is collected only for the servers
that are running. You can then generate the following reports to display the server trend information:

e Reporton top N servers per variable—Based on the number you choose to represent <N>, this report
displays the top N servers for the selected variable.

For example, if the CPU variable is selected and N=2, the report shows data for the top two servers
that have the greatest CPU values.

e Report Per Server Group—Data about all servers in a selected server group for all selected variables
in one table or chart. For example, the CPU and memory information for server 1, the CPU and
memory information for server 2, and so on.

To generate a report for a particular server, choose that server from the drop-down list in chart view.

~

Note  The drop-down list is only available when you click the Run Now radio button in the Run
Type Selection and Recurring Settings dialog box.

e Report Per Variable—Data for each selected variable. For example, the CPU for server 1, the CPU
for server 2, the CPU for server 3, and so on.

To generate a report for a different variable, choose that variable from the drop-down list.
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e Report of Averaged Variable—The average usage of each variable across all servers in the server
group. For example, if the selected server group has two servers, the report displays the average CPU
usage for server 1 and for server 2.

Related Topics
e Generating Logical Server Reports, page 16-8

e Logical Server Report, page 16-16
e Logical Server Report—Results, page 16-25

Working with Reports

This section provides detailed procedures for working with reports, and includes the following topics:
e Generating the Logged in Users Report, page 16-4
e Generating the Audit Report, page 16-5
e Generating Service Network Availability Reports, page 16-5
e Generating Resource Utilization Reports, page 16-7
e Generating Logical Server Reports, page 16-8
e Deleting a Scheduled Report, page 16-10

Generating the Logged in Users Report

You can view a list of all the users that have logged in to VFrame including details such as the hostname,
IP address, username, context, and session ID.

Procedure

Step 1 Choose Tools > VFrame Administration > User and click the Logged In Users tab to show a list of
users logged in to the VFrame system.

Step2  View the report. For details about reading the report, see Logged In Users Report, page 16-12.
Step3  Click OK to exit.

Related Topics
e Understanding Reports, page 16-1

e Understanding the Logged In Users Report, page 16-1
e Logged In Users Report, page 16-12
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Generating the Audit Report

Step 1
Step 2

Step 3

You can view a log of various actions taken in the system by users, including any action that results in a
change to the VFrame database. If you are logged in to the admin context, you will see log entries for
all contexts. If you are logged in to a specific virtual context, you will see log entries for only that
context.

Procedure

Choose Tools > VFrame Administration > User and click the Audit tab to open the Audit dialog box.

In the Filter Attributes pane, choose the beginning and ending dates and times for the period you want
to analyze.

Click Show Audit Logs.

All log messages from the selected period are shown in the window. You can sort these messages by
clicking the column headings of the table to toggle between alphabetic and reverse alphabetic sorting.

For more details about reading the information in this report, see Audit Report, page 16-13.

Related Topics
e Understanding Reports, page 16-1

e Understanding the Audit Report, page 16-2
e Audit Report, page 16-13

Generating Service Network Availability Reports

Step 1

Step 2

You can generate reports to determine when the service network was running, which resources were
used, which network elements used which resources, and how many resources are still available. For
details, see Understanding Service Network Availability Reports, page 16-2.

Before You Begin
Verify the following:

*  You have created a service network.

e The service network was running during the time interval for which you are generating the report.

Procedure

Choose Reports > Service Network Availability to open the Service Network Availability dialog box
(see Service Network Availability Reports, page 16-14).

From the Service Network selector list, choose a service network for which you want to generate a
report.
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Step3  Click New to open the Service Network Availability Wizard. The wizard opens and the Report Type
Selection dialog box appears by default (see Report Type Selection Dialog Box, page 16-18). Perform
the following steps:

a. Click the type of report to generate: running history, usage by resource type, or resource usage by
logical network element.

b. Click Next to open the next dialog box.
Step4  In the Report Duration dialog box (see Report Duration Dialog Box, page 16-18):
a. Perform one of the following tasks:

— Click the Report duration radio button, and then specify the date and time to start and end the
data included in the report.

— Click the Report last radio button, and then specify the time duration (in minutes, hours, or
days) to include data in the report. This radio button is selected by default.

b. Click Next to open the next dialog box.
Step5  In the Report Schedule dialog box (see Report Schedule Dialog Box, page 16-19):
a. Perform one of the following tasks:
— Click the Run Now radio button to start generating the report immediately.

— Click the Schedule radio button to start generating the report on a specified schedule, and then
specify the schedule. If you choose to schedule the report, you can also choose the Repeat check
box and a time interval. When you choose this check box, VFrame continues to run the report
at each specified time interval.

b. Click Next to open the next pane or dialog box.

Step6  If you clicked the Run Now radio button in Step 5, proceed to Step 7. If you clicked the Schedule radio
button, the Reports Retainment and E-mail Subscriptions Settings dialog box opens (see Reports
Retainment and E-mail Subscriptions Settings Dialog Box, page 16-20). Perform the following steps:

a. Inthe Keep Reports pane, enter the number of copies of reports to save or the amount of time to save
the reports.

b. (Optional) In the E-mail Subscriptions pane, enter the e-mail addresses to send the reports.

~

Note = Make sure that your mail server is set up correctly, otherwise the subscribers will not get
e-mail notifications.

Step7  In the Summary Page (see Summary Page, page 16-22), verify parameters you defined. To change any
of the parameters, click Back to return to the appropriate wizard screen, and then make the necessary
changes.

Step8  Click Finish.

If you chose to run the report now, the report is generated and displayed immediately. If you chose to
schedule the report, it is listed in the Scheduled reports pane of the Service Network Availability dialog
box.

For details about the report results, see Service Network Availability—Results, page 16-23.
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Related Topics
e Understanding Service Network Availability Reports, page 16-2

e Service Network Availability Reports, page 16-14
e Service Network Availability—Results, page 16-23

Generating Resource Utilization Reports

You can generate reports to see how the resources are used in the network. For more information about
this report, see Understanding Resource Utilization Reports, page 16-2.

Procedure

Step 1 Choose Reports > Resource Utilization to open the Resource Utilization dialog box (see Resource
Utilization Reports, page 16-15).

Step2  From the Resource Pool List selector, choose a resource pool for which you want to generate a report.

Step3  Click New to open the Resource Utilization Report Wizard. The wizard opens and the Report Type
Selection dialog box appears (see Report Type Selection Dialog Box, page 16-18). Perform the
following steps:

a. Choose the type of report to generate: resource pool size, resource pool utilization, or resource pool
utilization by service networks.

b. Click Next to open the next dialog box.
Step4  In the Report Duration dialog box (see Report Duration Dialog Box, page 16-18):
a. Perform one of the following tasks:

— Click the Report duration radio button, and then specify the date and time to start and end the
data included in the report by selecting your preferences from the drop-down lists.

— Click the Report last radio button, and then specify the time duration (in minutes, hours, or
days) to include data in the report by selecting your preference from the drop-down list. This
radio button is selected by default.

b. Click Next to open the next dialog box.
Step5 In the Report Schedule dialog box (see Report Schedule Dialog Box, page 16-19):
a. Perform one of the following tasks:
— Click the Run Now radio button to start generating the report immediately.

— Click the Schedule radio button to start generating the report on a specified schedule, and then
specify the schedule. If you choose to schedule the report, you can also check the Repeat check
box and a time interval. When you check this box, VFrame continues to run the report at each
specified time interval.

b. Click Next to open the next pane.

Step6  In the Summary Page (see Summary Page, page 16-22), verify parameters you defined. To change any
of the parameters, click the Back button to the appropriate wizard dialog box, and then make the
necessary changes.

Step 7 Click Finish.
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If you chose to run the report now, the report is generated and displayed immediately. If you chose to
schedule the report, it is listed in the Scheduled reports pane of the Resource Utilization Report dialog
box.

For details about the report results, see Service Network Availability—Results, page 16-23.

Related Topics
e Understanding Resource Utilization Reports, page 16-2

e Resource Utilization Reports, page 16-15
e Service Network Availability—Results, page 16-23

Generating Logical Server Reports

Step 1

Step 2

Step 3

Step 4

VFrame monitors and collects periodic information for the server trend variables that you selected in the
Monitoring/Trend policies dialog box and saves it in the database. You can then generate the following
reports to display the server trend information:

e Report on top N servers per variable

e Report per server group

e Report per variable

e Report of averaged variables across all servers

For more information about this report, see Understanding Logical Server Report, page 16-3.

Before You Begin

e Make sure that you have defined the server trend variables in the Monitoring/Trend policies dialog
box (see Monitoring and Trend Policies, page 14-11).

Procedure

Choose Reports > Logical Server Report to open the Logical Server Report dialog box (see Logical
Server Report, page 16-16).

From the Logical Network List selector, choose the service network for which you want to generate a
report.

Click New to open the Trend Report Wizard. The wizard opens and the Report Type Selection dialog
box appears (see Report Type Selection Dialog Box, page 16-18). Perform the following steps:

a. Click the type of report to generate: report on top N servers per variable, report per server group,
report per variable, or report of averaged variables across all servers.

b. Click Next to open the next dialog box.
In the Report Duration dialog box (see Report Duration Dialog Box, page 16-18):
a. Perform one of the following steps:

— Click the Report duration radio button, and then specify the date and time to start and end the
data included in the report by selecting your preferences from the drop-down list.
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— Click the Report last radio button, and then specify the time duration (in minutes, hours, or
days) to include data in the report by selecting your preference from the drop-down list. This
radio button is selected by default.

b. Click Next to open the next dialog box.
Step5  In the Report Schedule dialog box (see Report Schedule Dialog Box, page 16-19):
a. Perform one of the following steps:
— Click the Run Now radio button to start generating the report immediately.

— Click the Schedule radio button to start generating the report on a specified schedule, and then
specify the schedule. If you choose to schedule the report, you can also check the Repeat check
box and a time interval. When you check this box, VFrame continues to run the report at each
specified time interval.

b. Click Next to open the next dialog box.

Step6  If you clicked the Run Now radio button in Step 5, proceed to Step 8. If you clicked the Schedule radio
button, the Reports Retainment and E-mail Subscriptions Settings dialog box opens (see Reports
Retainment and E-mail Subscriptions Settings Dialog Box, page 16-20). Perform the following steps:

a. Inthe Keep Reports pane, enter the number of copies of reports to save or the amount of time to save
the reports.

b. (Optional) In the E-mail Subscriptions pane, enter the e-mail addresses to send the reports.

~

Note = Make sure that your mail server is set up correctly, otherwise the subscribers will not get
e-mail notifications.

c. Click Next to open the next dialog box.

Step7  In the Server Group Selection and Reports Variable Selections dialog box (see Server Group Selection
and Report Variables Selection Dialog Box, page 16-21):

a. From the Reporting Interval drop-down list, choose the reporting interval.
b. From the Server Groups drop-down list, choose a server group.
c. In the Trend Variables pane, check or uncheck the variables to generate the report.

S

Note The preselected variables are the ones that you selected in the Monitoring/Trend dialog box
(see Monitoring and Trend Policies, page 14-11).

d. Click Next to open the next pane.

Step8 In the Summary Page (see Summary Page, page 16-22), verify parameters you defined. To change any
of the parameters, click Back to return to the appropriate wizard screen, and then make the necessary
changes.

Step9  Click Finish.

If you chose to run the report now, the report is generated and displayed immediately. If you chose to
schedule the report, it is listed in the Scheduled reports pane of the Logical Server Report dialog box.

For details about the report results, see Logical Server Report—Results, page 16-25.
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Related Topics
e Understanding Logical Server Report, page 16-3

e Logical Server Report, page 16-16
e Logical Server Report—Results, page 16-25

Viewing Properties of a Scheduled Report

Step 1

Step 2

Step 3

Step 4

You can view the properties of a scheduled report.

Procedure

Depending on the type of scheduled report for which you want to view properties, perform one of the
following tasks:

e Choose Reports > Service Network Availability to open the Service Network Availability dialog
box.

¢ Choose Reports > Resource Utilization to open the Resource Utilization dialog box.
¢ Choose Reports > Logical Server Report to open the Logical Server Report dialog box.
Select the specific report for which you want to view properties in the Scheduled Reports table.

S

Note Properties can be viewed only for a scheduled report.

Click Properties, in the Scheduled reports pane, to view the report parameters and their values.

Some properties that can be viewed are name, type, report start time, report stop time, repeats, next run,
and number of reports to keep.

Click Close in the window, to close the window.

Related Topics
e Service Network Availability Reports, page 16-14
e Resource Utilization Reports, page 16-15

e Logical Server Report, page 16-16

Deleting a Scheduled Report

Step 1

You can delete a report that is scheduled to be generated.

Procedure

Depending on the type of report you want to delete, perform one of the following tasks:

¢ Choose Reports > Service Network Availability to open the Service Network Availability dialog
box.

e Choose Reports > Resource Utilization to open the Resource Utilization dialog box.
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e Choose Reports > Logical Server Report to open the Logical Server Report dialog box.
Select the report to delete in the Scheduled Reports table.
Click Delete.

Click Yes in the Confirm Unschedule window that asks if you want to unschedule the selected report
schedule.

Related Topics
e Service Network Availability Reports, page 16-14

¢ Resource Utilization Reports, page 16-15

e Logical Server Report, page 16-16

Deleting an Executed Report Run

Step 1

Step 2

Step 3
Step 4
Step 5
Step 6

You can delete an executed report run of a scheduled report.

Procedure

Depending on the type of report you want to delete, perform one of the following tasks:

e Choose Reports > Service Network Availability to open the Service Network Availability dialog
box.

¢ Choose Reports > Resource Utilization to open the Resource Utilization dialog box.
¢ Choose Reports > Logical Server Report to open the Logical Server Report dialog box.

Select the scheduled report in the Scheduled Reports table for which you want to delete an executed
report run.

Select the executed report run in the Executed report runs table.
Click Delete.
Click Yes in the Confirm Delete window that asks if you want to delete the selected report.

Click Close in the window, to close the window.

Related Topics
e Service Network Availability Reports, page 16-14

e Resource Utilization Reports, page 16-15

e Logical Server Report, page 16-16
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Troubleshooting Reports

This section describes some problems you might encounter when generating reports and their solutions,
and includes the following topics:

e Problem Users do not receive e-mail notifications for Service Network Availability, Resource
Utilization, and Logical Server Report reports.

e Problem Logical Server Report does not show any data.

Problem Users do not receive e-mail notifications for Service Network Availability, Resource
Utilization, and Logical Server Report reports.

Solution If you configured notification settings for these reports, and a report was successfully generated
that should have generated an e-mail but did not, the problem is probably that the SMTP settings for
VFrame are not configured correctly. Choose Tools > VFrame Administration > General, and click
the SMTP tab. Ensure that a valid, existing e-mail address and SMTP server are specified. Click

Test Settings to verify that VFrame can use the account.

Problem Logical Server Report does not show any data.

Solution For the Logical Server Report to show any data, VFrame must collect data from the servers. If
you run this report and no data is shown, the problem is probably that you did not configure the
Monitoring and Trend policies for the servers in your service network. Choose View > Operations, then
choose the desired service network and click Policies, then wait for the Secure Networks Policy
Management page to load. Choose the desired server group and click the Monitoring/Trend tab. Ensure
that data to track and download at monitoring intervals has been specified.

Field Reference Reports

This section describes the dialog boxes and lists you use when working with reports, and includes the
following topics:

e Logged In Users Report, page 16-12

e Audit Report, page 16-13

e Service Network Availability Reports, page 16-14
¢ Resource Utilization Reports, page 16-15

e Logical Server Report, page 16-16

e Report Wizard, page 16-17

e Service Network Availability—Results, page 16-23
e Service Network Availability—Results, page 16-23
e Logical Server Report—Results, page 16-25

Logged In Users Report

Use the Logged In Users report to view the date and time users logged in to VFrame. The report provides
details such as the hostname, IP address, username, context, session ID, and type of client.
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How to Get to This Tab

Choose Tools > VFrame Administration > User and click the Logged In Users tab to open the Logged
In Users report.

Related Topics
e Understanding the Logged In Users Report, page 16-1

e Generating the Logged in Users Report, page 16-4

Field Reference

Table 16-1 Logged In Users Report

Element Description

Login Date/Time Date and time the user logged in to VFrame.

Hostname Hostname of the system that was used to log in to VFrame.

IP Address IP address of the system that was used to log in to VFrame.

User Username used for logging in to VFrame.

Context Virtual context in which the user logged in to VFrame.

Session ID ID number of the client-server communication. Each time a user logs into
VFrame a new session ID number is generated for that user, which is
displayed in this column.

Type Type of client that is logged in to VFrame.

Audit Report

Use the Audit report dialog box to generate and view an audit log, which is a log of various actions taken
in the system by users, including any action that results in a change to the VFrame database.

If you are logged in as a user in the admin context, then you can view the log entries for all contexts and
for all users in the system.

If you are logged in as a user in the virtual context, then you can only view your own log entries and not
those for any other users in the system, irrespective of the context.

How to Get to This Tab
Choose Tools > VFrame Administration > User and click the Audit tab to open the Audit dialog box.

Related Topics
¢ Understanding the Audit Report, page 16-2

e Generating the Audit Report, page 16-5
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Table 16-2 Audit Report

Element Description
Filter Attributes Pane

Use this pane to define the scope of the log entries you want to view.

Begin Date Date (month, day, and year) from which you want to include audit log
entries.

Begin Time Time from which you want to include audit log entries.

End Date Date (month, day, and year) to which you want to include audit log entries.

End Time Time to which you want to include audit log entries.

Show Audit Logs button |Click this button to generate and display the audit report based on your date
and time selections.

Audit Logs table

This table displays the log entries. You can sort these messages by selecting the column headings of
the table to toggle between alphabetic and reverse alphabetic sorting in the selected column.

Time Day and time when the log entry was made.

User User account whose action generated the log entry.

Context Virtual context in which the action took place.

Description Action that took place.

Service Network Service network that was involved in the action, if applicable.

Resource Resource (such as a switch or server) that was involved in the action, if
applicable.

Service Network Availability Reports

Use the Service Network Availability dialog box to generate the following reports:
e Running history
e Usage by resource type

e Resource usage by logical network element (User can view table only.)

How to Get to This Tab

Choose Reports > Service Network Availability to open the Service Network Availability dialog box.

Related Topics
e Understanding Service Network Availability Reports, page 16-2

e Report Wizard, page 16-17
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Service Network Availability Report

Element

Description

Service Network List

List of all service networks created in VFrame.

Scheduled Reports table—List of scheduled reports.

Name Name of the report.

Repeats Report generation interval schedule. For example, every <x> seconds, a
report is generated.

New button Choose a service network from the Service Network List and click this

button to define parameters to generate the service network availability
report (see Report Wizard, page 16-17).

Delete button

Click this button to cancel the selected report generation.

Properties button

Click this button to open the Report Wizard where you can modify the report
parameters that you previously entered and reschedule the report generation.

Executed report runs—List

of reports that have been generated.

Generation Time

Time that the report was generated.

Report Start Time

Time from which you want to include report data.

Report End Time

Time to which you want to include report data.

Status

Status indicating whether the report was successfully run or not.

Download Chart (pdf)
button

Click this button to download the report in chart format. Navigate to the
directory where you want to store the report and click Save.

Download Table (csv)
button

Click this button to download the report in table format. Navigate to the
directory where you want to store the report and click Save.

Delete button

Click this button to cancel the selected report generation.

Resource Utilization Reports

Use the Resource Utilization Reports dialog box to generate the following reports:

e Resource pool size

e Resource pool utilization

e Resource pool utilization by service networks

How to Get to This Tab

Choose Reports > Resource Utilization to open the Resource Utilization dialog box.

Related Topics

e Understanding Resource Utilization Reports, page 16-2

e Report Wizard, page 16-17
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Field Reference

Table 16-4 Resource Utilization Report
Element Description
Resource Pool List List of all the resource pools created in the VFrame database.

Scheduled Reports—List of scheduled reports.

Name Name of the report.

Repeats Report generation interval schedule. For example, every <x> seconds, a
report is generated.

New button Choose a resource pool from the Resource Pool List and click this button to
define parameters to generate the utilization reports (see Report Wizard,
page 16-17).

Delete button Click this button to cancel the selected report generation.

Properties button Click this button to open the Report Wizard where you can modify the report

parameters that you previously entered and reschedule the report generation.

Executed report runs—List of reports that have been generated.

Generation Time Time that the report was generated.

Report Start Time Time from which you want to include report data.

Report End Time Time to which you want to include report data.

Status Status indicating whether the report was successfully run or not.
Download Chart (pdf) |Click this button to download the report in chart format. Navigate to the
button directory where you want to store the report and click Save.

Download Table (csv) |Click this button to download the report in table format. Navigate to the
button directory where you want to store the report and click Save.

Delete button Click this button to cancel the selected report generation.

Logical Server Report

Use the Logical Server Report dialog box to generate these four types of reports:
e Report on top N servers per variable
e Report per server group
e Report per variable

e Report of averaged variables across all servers

How to Get to This Tab
Choose Reports > Logical Server Report to open the Logical Server Report dialog box.

Related Topics
e Understanding Logical Server Report, page 16-3

e Report Wizard, page 16-17
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Table 16-5

Field Reference Reports Il

Logical Server Report

Element

Description

Logical Network List

List of all the service networks created in the VFrame database.

Scheduled Reports table—List of scheduled reports.

Name Name of the report.

Repeats Report generation interval schedule. For example, every <x> seconds, a
report is generated.

New button Choose a service network from the Logical Network List and click this

button to define parameters to generate the logical server trend report (see
Report Wizard, page 16-17).

Delete button

Click this button to cancel the selected report generation.

Properties button

Click this button to open the Report Wizard where you can modify the report
parameters that you previously entered and reschedule the report generation.

Executed report runs—List

of reports that have been generated.

Generation Time

Time that the report was generated.

Report Start Time

Time from which you want to include report data.

Report End Time Time to which you want to include report data.

Status Status indicates whether the report was successfully run or not.
Download Chart (pdf) |Click this button to download the report in chart format. Navigate to the
button directory where you want to store the report and click Save.

Download Table (csv)
button

Click this button to download the report in table format. Navigate to the
directory where you want to store the report and click Save.

Delete button

Click this button to cancel the selected report generation.

Report Wizard

Use the Report Wizard to

generate Logical Server Trend, Resource Utilization, and Service Network

Availability reports. The dialog boxes that appear in the wizard depend on the type of report you are

generating.

This section describes the dialog boxes and summary in the Report Wizard, and includes the following

topics:

e Report Type Selection Dialog Box, page 16-18

e Report Duration Dialog Box, page 16-18

e Report Schedule Dialog Box, page 16-19

e Reports Retainment and E-mail Subscriptions Settings Dialog Box, page 16-20

e Server Group Selection and Report Variables Selection Dialog Box, page 16-21

e Summary Page, page

16-22
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Report Type Selection Dialog Box
Use the Report Type Selection dialog box to choose the type of report to generate.

How to Get to This Wizard Screen

Perform one of the following steps:

¢ In the Service Network Availability Reports, choose a service network in the Service Network List
and click New.

¢ Inthe Resource Utilization Reports, choose a resource pool in the Resource Pool List and click New.

¢ In the Logical Server Report, choose a service network in the Logical Network List and click New.

Related Topics
e Understanding Service Network Availability Reports, page 16-2
e Understanding Resource Utilization Reports, page 16-2

e Understanding Logical Server Report, page 16-3

Field Reference

Table 16-6 Report Type Selection Dialog Box — Report

Element Description
Report Name System-generated report name.
Report Type Depends on the report you are running, as follows:

e Logical Server Trend report

Report of top N servers per variable

Report per server group

Report per variable

Report of averaged variable across all servers
e Resource Utilization report

— Resource pool size

— Resource pool utilization

— Resource pool utilization by service networks
e Service Network Availability report

— Running history

- Usage by resource type

— Resource usage by logical network element

Report Duration Dialog Box

Use the Report Duration dialog box to specify the time period for the report. You can choose a range of
time (the date and time to start and end the report generation) or a time period over the most recent
number of minutes, hours, or days.
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How to Get to This Wizard Screen

From the Report Type Selection Dialog Box, click Next.

Related Topics
e Service Network Availability Reports, page 16-14

e Resource Utilization Reports, page 16-15
e Logical Server Report, page 16-16

Field Reference

Table 16-7 Report Duration
Element Description
Report Name System-generated report name.

Report duration radio Click this radio button to specify the date and time to start and end the report
button generation.

Report last radio button |Click this radio button to specify a time period to generate the report for the
last <n> minutes, last <n> hours, or the last <n> days.

Report Schedule Dialog Box

Use the Report Schedule dialog box to specify whether to generate the report immediately or later, on a
specified schedule.

How to Get to This Wizard Screen
In the Report Duration Dialog Box, click Next.

Related Topics
e Service Network Availability Reports, page 16-14

e Resource Utilization Reports, page 16-15
e Logical Server Report, page 16-16
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Field Reference

Table 16-8 Run Type Selection and Recurring Settings Dialog Box
Element Description
Report Name System-generated report name.

Run Now radio button |Click this radio button to start generating the report immediately.

Schedule radio button  |Click this radio button to schedule the generation of the report, and then
specify the following items:

e Start date time—Date and time to begin generating the report.

e Repeat check box—Check this check box to generate the report at
subsequent intervals, then perform the following tasks:

— In the Every field, enter the frequency for generating the report.
Default is 20 minutes.

— In the corresponding field, select the interval in terms of minutes,
hours, days, or weeks.

S,

Note If you do not check the Repeat check box, the report is generated
according to the start date and time you selected.

Reports Retainment and E-mail Subscriptions Settings Dialog Box

Use the Reports Retainment and E-mail Subscriptions Settings dialog box to specify the number of last
reports to save and the amount of time to save them. You can also specify e-mail addresses to which a
PDF of the report will be sent by e-mail.

How to Get to This Wizard Screen
In the Report Schedule Dialog Box, click the Schedule radio button and click Next.

Related Topics
e Service Network Availability Reports, page 16-14

¢ Resource Utilization Reports, page 16-15
e Logical Server Report, page 16-16
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Field Reference

Table 16-9 Reports Retainment and E-mail Subscriptions Settings Dialog Box
Element Description

Report Name System-generated report name.

Keep Reports Saves generated reports. Provides two options:

e Keep Last radio button—Click this radio button, then specify the
number of last reports to save. The old reports are purged.

e Keep For radio button—Click this radio button, then specify the amount
of time to save the generated report in terms of minutes, hours, days, or
weeks. Default is 15 minutes.

E-mail Subscriptions Specify one or more e-mail addresses to receive a PDF of the report.
Separate multiple e-mail addresses with commas.

Note  Make sure that your mail server is set up correctly. Otherwise, the
subscribers will not get e-mail notifications.

Server Group Selection and Report Variables Selection Dialog Box

Use the Server Group Selection and Report Variables Selection dialog box to check or uncheck the server
trend variables for generating a Logical Server report.

~

Note  This wizard screen applies only to the Logical Server report.

The preselected variables in this dialog box are directly related to the variables you selected in the
Monitoring/Trend policies dialog box (see Monitoring and Trend Policies, page 14-11). You can choose
to generate a report for all preselected variables, or for only those variables for which you need
information (see Understanding Logical Server Report, page 16-3).

How to Get to This Wizard Screen

In the Report Schedule Dialog Box (if you chose to run the report immediately) or in the Reports
Retainment and E-mail Subscriptions Settings Dialog Box (if you chose to schedule the report), click
Next.

Related Topics
e Logical Server Report, page 16-16
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Field Reference

Table 16-10 Server Group Selection and Report Variables Selection Dialog Box
Element Description
Monitoring Interval Choose the monitoring interval from the drop-down list. Options are
1 minute or 1 hour. The default value is 1 minute.
Server Groups Lists the server groups in the selected service network.
Trend Variables Lists the following categories of variables: system, interface, HBA port, and

NFS stats. The variables that you chose in the Monitoring/Trend dialog box
are selected by default (see Monitoring and Trend Policies, page 14-11).

You can check or uncheck the variables and generate a report for only those
variables for which you want information. This will not change the variables
you already selected in the Monitoring/Trend dialog box. Your selection of
the variables in this dialog box affects only the report you are generating.

Summary Page

Use the Summary Page to verify the parameters you defined for generating the report.

How to Get to This Wizard Screen

Perform one of the following tasks, depending on the type of report you are generating:

e Logical Server Trend reports—In the Server Group Selection and Report Variables Selection Dialog
Box, click Next.

e For Resource Utilization or Service Network Availability reports—In the Report Schedule Dialog
Box (if you chose to run the report immediately) or in the Reports Retainment and E-mail
Subscriptions Settings Dialog Box (if you chose to schedule the report), click Next.

Related Topics
e Service Network Availability Reports, page 16-14

e Resource Utilization Reports, page 16-15
e Logical Server Report, page 16-16
Field Reference

Table 16-11 Summary Page

Element Description

Summary Page Summarizes the parameters you defined in all of the wizard steps. To make
changes, click Back to return to the appropriate dialog box.
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Service Network Availability—Results

The Service Network Availability report results depend on the type of report you have generated:
e Running history
e Usage by resource type

e Resource usage by logical network element

How to Get to This Tab

Choose Reports > Service Network Availability and proceed through the reports wizard.

Related Topics
e Understanding Service Network Availability Reports, page 16-2
e Generating Service Network Availability Reports, page 16-5

Field Reference

Table 16-12 Service Network Availability —Results

Element Description

Chart tab Report data is shown in chart format depending on the type of report:
¢ Running History—Time is shown along the horizontal axis.

e Usage by Resource Type—Resource types are shown along the
horizontal axis and average availability is shown along the vertical axis.

Table tab Report data is shown in table format depending on the type of report:
e Running History

— Start Time—Time the service network started running.

— End Time—Time the service network stopped running.

— Duration—Total number of hours, minutes, and seconds that the
service network was running.

e Usage by Resource Type

— Resource Type—Type of resource, such as load balancer, Layer 2
switch, Firewall Services Module.

— Average—Average usage of the resource.

Cisco VFrame Data Center Administration Guide
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Table 16-12 Service Network Availability— Results (continued)

Element Description

e Resource Usage by Logical Network Element
— LNE Name—Name of the element.
— Resource Name—Name of the resource.

— Resource Type—Type of resource, such as load balancer, Layer 2
switch, Firewall Services Module.

— Acquire Time—Time that the resource was acquired by the service
network.

- Release Time—Time that the resource was released by the service
network.

— Usage—Total number of hours, minutes, and seconds that the
resource was used.

Download Chart (pdf) |Click this button to download the report in chart format. Navigate to the

button directory where you want to store the report and click Save.

Download Table (csv)  |Click this button to download the report in table format. Navigate to the
button directory where you want to store the report and click Save.

Resource Types Choose aresource type from the drop-down list to display report data for that

particular resource type. (Appears only if you are generating a Resource
usage by logical network element report.)

Resource Pool Size Report—Results

The Resource Pool Size report results depend on the type of report you have generated:
e Resource pool size
e Resource pool utilization

e Resource pool utilization by service networks

How to Get to This Tab
Choose Reports > Resource Utilization and proceed through the reports wizard.

Related Topics
e Understanding Resource Utilization Reports, page 16-2

e Generating Resource Utilization Reports, page 16-7
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Table 16-13 Resource Utilization Report—Results

Element Description
Chart tab Report data is shown in chart format depending on the type of report:

e Resource Pool Size—Line graph showing time along the horizontal axis
and pool size along the vertical axis.

e Resource Pool Utilization—Line graph showing time along the
horizontal axis and both pool utilization and pool size along the vertical
axis.

e Resource Pool Utilization by Service Networks—Bar graph showing
service networks along the horizontal axis and pool utilization along the
vertical axis. For each network, a bar depicting the appropriate
percentage is shown.

Table tab Report data is shown in table format depending on the type of report:

e Resource Pool Size
— Pool Size—Number of devices in use.

— Timestamp—Date and time when a change in resource utilization
took place.

e Resource Pool Utilization

— Pool Used—Name of the resource pool.

— Timestamp—Date and time when the pool was in use.
e Resource Pool Utilization by Service Networks

— Service Network Name—Name of the service network.

— Utilization—Percentage of the resource pool used during the
selected report time period.

Download Chart (pdf)

Click this button to download the report in chart format. Navigate to the

button directory where you want to store the report and click Save.
Download Table (csv) |Click this button to download the report in table format. Navigate to the
button directory where you want to store the report and click Save.

Logical Server Report—Results

The Logical Server report results depend on the type of report you have generated:

e Report on top N servers per variable

e Report per server group

e Report per variable

e Report of averaged variables across all servers

How to Get to This Tab

Choose Reports > Logical Server Report and proceed through the reports wizard.
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Related Topics
e Understanding Logical Server Report, page 16-3

e Generating Logical Server Reports, page 16-8

Field Reference

Table 16-14 Logical Server Report—Results

Element Description

Chart tab Report data is shown in chart format with time shown along the horizontal
axis and the value shown along the vertical axis.

Table tab Report data is shown in table format with the following columns:
e Time—Time that the variable was used.

e Value—Value of the variable.

e Variable—Variable name.

e Unit—Variable unit.

e Server Name (Appears only if you are generating the report of top n
servers per variable, trends per server group, or the trends per variable

report.)
Download Chart (pdf) |Click this button to download the report in chart format. Navigate to the
button directory where you want to store the report and click Save.
Download Table (csv)  |Click this button to download the report in table format. Navigate to the
button directory where you want to store the report and click Save.
Select Server Choose a server from the drop-down list to display report data for that

particular server. (Appears only if you are generating a Trends Per Server
Group report.)

Select Variables Choose a variable from the drop-down list to display report data for that
particular variable. (Appears only if you are generating a Report per variable
report.)
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