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C H A P T E R 17

Maintaining Devices

During normal network operation, you might need to perform maintenance tasks on the physical devices 
in your network. For example, you might need to upgrade (or downgrade) the OS version of a switch or 
server or replace defective service modules (FWSM, CSM). However, before beginning, it is important 
that you understand how maintenance tasks can affect the physical devices in your network now that 
VFrame manages them.

This chapter provides detailed information to help you understand and perform maintenance tasks on 
devices that VFrame manages, and includes the following sections:

• Understanding Device Maintenance, page 17-1

• Maintaining Devices, page 17-7

Understanding Device Maintenance
This section describes concepts you should understand before performing maintenance on devices that 
VFrame manages, and includes the following topics:

• Understanding the Difference Between Managed and Unmanaged Resources, page 17-1

• Understanding Maintenance Modes, page 17-2

Understanding the Difference Between Managed and Unmanaged Resources
Maintenance procedures depend on several factors, including whether the resource is managed or 
unmanaged:

• Managed resources—Managed resources are those that have been discovered by VFrame and 
manually selected to be managed. After a resource has been discovered and managed, it is available 
to be used by service networks, as needed. 

You can perform maintenance on managed resources; however, the manner in which you proceed 
depends on whether the resource has been acquired or not. See Understanding the Difference 
Between Managed Acquired and Managed Unacquired Resources, page 17-2.

• Unmanaged resources—Unmanaged resources are those that have been discovered by VFrame, but 
have not been manually selected to be managed. These resources are in the VFrame database; 
however, they are not available to be used by service networks. 

You can perform maintenance on unmanaged resources without affecting any running service 
network. After you are done performing maintenance, you need to rediscover the resource. Doing 
so updates the VFrame inventory with any new information about the resource.
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Understanding the Difference Between Managed Acquired and Managed 
Unacquired Resources

The way you go about performing maintenance on managed acquired and managed unacquired resources 
is different. This section describes what defines these types of resources before performing maintenance 
on them:

• Managed unacquired resources are not in use by a service network. To perform maintenance, you 
can either unmanage the resource or place it in Maintenance mode on the Resources tab.

Unmanaging the resource removes it from any resource pool to which it belongs. After performing 
maintenance and rediscovering the resource, if the resource belongs to a static resource pool, you 
need to manually read it to the pool. 

Alternatively, you can place the resource in Maintenance mode on the Resources tab, perform 
maintenance on it, and then take the resource out of Maintenance mode. Among other things, 
placing a managed unacquired resource in Maintenance mode does not remove it from any resource 
pool to which it belongs. So, this is typically the preferred method. For more details, see 
Maintenance Mode for Managed Unacquired Resources, page 17-2. 

• Managed acquired resources are those that are in use by a service network. After a managed resource 
is acquired, you cannot unmanage that resource to perform maintenance on it. The alternative is to 
place the resource in Maintenance mode on the Resources tab. For details, see Maintenance Mode 
for Managed Acquired Resources, page 17-3.

Note Managed resources can also be in a state where they are assigned to a service network, but not 
yet acquired. This happens when you choose a specific resource (as opposed a resource pool) for 
a service network during network design, but the service network has not yet been deployed so 
the resource is not yet acquired. These resources cannot be unmanaged either, but they can be 
placed in Maintenance mode on the Resources tab.

Understanding Maintenance Modes
You can place only managed resources in Maintenance mode. The behavior of Maintenance mode and 
how you place a managed resource in Maintenance mode depends on whether the resource has been 
acquired or not. For details, see Understanding the Difference Between Managed Acquired and Managed 
Unacquired Resources, page 17-2.

This section describes the two Maintenance modes, and includes the following topics:

• Maintenance Mode for Managed Unacquired Resources, page 17-2

• Maintenance Mode for Managed Acquired Resources, page 17-3

Maintenance Mode for Managed Unacquired Resources

Use this form of Maintenance mode when you need to change or repair a physical device that is managed 
but has not been acquired by a service network. 

You place a managed unacquired resource in maintenance mode on the Resources tab. For details, see 
Maintaining Managed Unacquired Resources, page 17-7.
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When you place a managed unacquired resource in Maintenance mode the following happens:

• VFrame stops monitoring the resource.

• VFrame does not log any faults against the resource.

• The resource is not removed from any resource pools to which it belongs.

• The resource cannot be acquired by a service network.

Note You can also place an acquired resource in Maintenance mode on the Resources tab. However, VFrame 
does not immediately place the resource in Maintenance mode. VFrame places the resource in the 
Marked for Maintenance state, waits until the service network releases the resource, and then places it 
in Maintenance mode. If needed, you can cancel the Marked for Maintenance state, and the resource will 
not be placed in Maintenance mode after the service network releases it.

While the resource is in Maintenance mode, you can perform any maintenance task (reboot the resource, 
change hardware, upgrade OS, and so on), as necessary. If you rediscover a resource while it is in 
Maintenance mode, VFrame discovers the device but does not log faults if they are detected.

After you remove a resource from Maintenance mode, you must rediscover it. Doing so causes VFrame 
to detect any hardware or configuration changes and update its database with the new information.

After a resource exits Maintenance mode the following happens: 

• VFrame resumes monitoring the resource.

• VFrame logs faults against the resource, if detected.

• The resource is available to be acquired by a service network.

Maintenance Mode for Managed Acquired Resources

The Maintenance mode used for managed acquired resources is more complex than the one used for 
managed unacquired resources, because the resource is being used in a running service network. This 
section helps you understand this form of Maintenance mode, and includes the following topics:

• When to Use Maintenance Mode on Managed Acquired Resources, page 17-3

• Restrictions for Maintenance Mode on Managed Acquired Resources, page 17-4

• State Flow for Maintenance Mode on Managed Acquired Resources, page 17-4

• What Happens to Resources and Service Networks in Maintenance Mode, page 17-7

• Exceptions to Standard Maintenance Mode Procedures, page 17-7

When to Use Maintenance Mode on Managed Acquired Resources

Use this form of Maintenance mode when you need to perform one of the following tasks on a resource 
that is managed and has been acquired by a service network:

• Update device configurations by executing macros attached to the Maintenance event.

• Change or repair physical devices without having to stop your service network. 

When you stop your service network, all resources are released. After you make the necessary 
changes or repairs to the physical devices, you will need to restart the service network and acquire 
resources. This process can take much longer than placing the resource (and service network) in and 
out of Maintenance mode. Also, when you restart your service network, you might acquire different 
resources, if they are part of a resource pool, and this might or might not be desirable.
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Restrictions for Maintenance Mode on Managed Acquired Resources

To place a resource in Maintenance mode on the Resources tab, the resource must be in the Running 
state. Placing a resource in Maintenance mode places any of its parent elements, including the service 
network, in Maintenance mode as well.

You cannot place specific endpoints in Maintenance mode. However, placing a resource in maintenance 
mode, places its endpoints in Maintenance mode. The exception to this rule is any resource in 
high-availability mode. When a resource in high-availability mode is placed in Maintenance mode, its 
subelements are not placed in Maintenance mode.

Currently, you can place only one resource per service network in Maintenance mode at a time, except 
for servers. You can place multiple servers for a particular server group in maintenance mode.

State Flow for Maintenance Mode on Managed Acquired Resources

The following sections explain the state flow of managed acquired resources when entering and exiting 
maintenance mode. For detailed descriptions of these and other states, see Service Network and Logical 
Element States, page 14-2.

Entering Maintenance Mode

There are several states that a resource can pass through when entering Maintenance mode, as shown in 
Figure 17-1.

Some logical elements require configuration changes to be made on them and/or other logical elements 
to enter Maintenance mode. The logical element that initiates the configuration changes is referred to as 
the source. The other logical elements are referred to as target logical elements.

When you place a logical element in Maintenance mode, a Maintenance event occurs on the service 
network. VFrame checks if there are macros attached to the Maintenance event. If there are no macros, 
VFrame places the logical element and service network in Maintenance mode.

If there are macros, VFrame executes the macros on the source logical element (the one you selected for 
Maintenance mode). If the configuration fails, VFrame places the logical element in the Configuration 
(For Maintenance) Failed state. Because the service network always assumes the state of the source 
logical element, it enters this state also. Because of this failure, VFrame does not execute any additional 
macros on other logical elements attached to the Maintenance event.
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Figure 17-1 Enter Maintenance State Flow Diagram

If the configuration is successful on the source logical element (or if there are no configuration changes 
required on the source logical element), VFrame checks if there are other macros that need to be 
executed on other logical elements. If there are no additional macros that need to be executed, VFrame 
places the source logical element and service network in Maintenance mode. 

If there are other macros that need to be executed, VFrame executes them. If the configuration on the 
other logical elements is successful, VFrame places the source and target logical elements and the 
service network in Maintenance mode.

If the configuration on the other logical elements fails, VFrame places these logical elements in the 
Configuration (For Maintenance) Failed on Element state. In addition, VFrame places the source logical 
element and the service network in the Configuration (For Maintenance) Failed on Other state.

To clear this state, do one of the following:

• Clear the status of the error: Right-click the error and then click Clear Status. The logical element 
and service network return to their previous states.

• Stop the network.

Exiting Maintenance Mode

There are several states that a resource can pass through when exiting Maintenance mode, as shown in 
Figure 17-2.

Some logical elements require configuration changes to be made on them and/or other logical elements 
to exit Maintenance mode. The logical element that initiates the configuration changes is referred to as 
the source logical element. The other logical elements are referred to as target logical elements.
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Figure 17-2 Exit Maintenance State Flow Diagram

When you exit Maintenance mode, an Exit Maintenance event occurs on the service network. VFrame 
checks if there are macros attached to the Exit Maintenance event. If there are no macros, VFrame places 
the logical element and service network in the Running state.

If there are macros, VFrame executes the macros on the source logical element (the one you selected for 
exiting Maintenance mode). If the configuration fails, VFrame places the logical element in the 
Configuration (For Exiting Maintenance) Failed state. Because the service network always assumes the 
state of the source logical element, it enters this state also. Because of this failure, VFrame does not 
execute any additional macros on other logical elements attached to the Exit Maintenance event.

If the configuration is successful on the source logical element (or if there are no configuration changes 
required on the source logical element), VFrame checks if there are other macros that need to be 
executed on other logical elements. If there are no additional macros that need to be executed, VFrame 
places the source logical element and service network in the Running state. 

If there are other macros that need to be executed, VFrame executes them. If the configuration on the 
other logical elements is successful, VFrame places the source and target logical elements and the 
service network in the Running state.

If the configuration on the other logical elements fails, VFrame places these logical elements in the 
Configuration (For Exiting Maintenance) Failed on Element state. In addition, VFrame places the source 
logical element and the service network in the Configuration (For Exiting Maintenance) Failed on Other 
state.

To clear this state, do one of the following:

• Clear the status of the error: Right-click the error then click Clear Status. The logical element and 
service network go back to their previous states.

• Stop the network.
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What Happens to Resources and Service Networks in Maintenance Mode

Once in maintenance mode, the service network stops receiving events and faults. The service network 
cannot be stopped and no server can be added to the service network. Basically, all the functions of the 
service network stop while in Maintenance mode.

Exceptions to Standard Maintenance Mode Procedures

In most cases, you can use the standard procedure for placing place a managed acquired resource in and 
out Maintenance mode (see Maintaining Managed Acquired Resources, page 17-8). 

However, in some cases, placing a managed acquired resource in Maintenance mode is unavailable. In 
addition, there are resources (such as high-availability resources) that require additional steps to be 
performed when placing the resource in and out of Maintenance mode. For these cases, the following 
specific maintenance procedures are provided:

• Maintaining Managed Acquired Service Modules Running in High-Availability Mode, page 17-9

• Maintaining LOM Managers, page 17-12

Maintaining Devices
This section provides procedures for maintaining devices, and includes the following topics:

• Maintaining Managed Unacquired Resources, page 17-7

• Maintaining Managed Acquired Resources, page 17-8

• Maintaining Managed Acquired Service Modules Running in High-Availability Mode, page 17-9

• Maintaining LOM Managers, page 17-12

• Replacing a Non-Stackable Ethernet Switch, page 17-15

Maintaining Managed Unacquired Resources
Regardless of the type of device, the procedure for performing maintenance on managed unacquired 
resources is the same.

Procedure

Step 1 Place the resource in Maintenance mode:

a. Choose View > Resources.

b. Right-click the appropriate resource and then click Enter Maintenance.

c. Click Yes.

Step 2 Perform maintenance on the device according to the manufacturer guidelines.
17-7
Cisco VFrame Data Center Administration Guide

OL-15450-01



 

Chapter 17      Maintaining Devices
Maintaining Devices
Step 3 Remove the resource from Maintenance mode:

a. Choose View > Resources.

b. Right-click the appropriate resource and then click Exit Maintenance.

Step 4 Rediscover the resource (see Discovering Devices, page 6-4).

Related Topics

• Understanding Device Maintenance, page 17-1

Maintaining Managed Acquired Resources
In most cases, you can use the following procedure for placing place a managed acquired resource in and 
out Maintenance mode. 

However, in some cases, placing a managed acquired resource in Maintenance mode is unavailable. In 
addition, there are resources (such as high-availability resources) that require additional steps to be 
performed when placing the resource in and out of Maintenance mode. For these cases, the following 
specific maintenance procedures are provided:

• Maintaining Managed Acquired Service Modules Running in High-Availability Mode, page 17-9

• Maintaining LOM Managers, page 17-12

Procedure

Step 1 Place the resource you want to upgrade in Maintenance mode:

a. Choose View > Operations.

The Operations tab opens.

b. Open the appropriate service network.

c. Right-click the appropriate logical element and then click Enter Maintenance.

If the service network template has macros attached to the Maintenance event, these macros are 
executed, and then the logical element or service network enters Maintenance mode. If not, the logical 
element and service network enter Maintenance mode immediately.

Step 2 Perform maintenance on the device according to the manufacturer guidelines.

Note After upgrading the OS on any device, you also need to update any macros associated with the 
device that specify a specific OS version. Check the OS Versions field in the Edit Macro dialog 
box. For details, see Edit Macro Dialog Box, page 11-81.

Step 3 Verify the service network. On the Service Network Operations tab, click Verify Release Resources and 
check the Auto Correct Detected Changes check box.

Step 4 Resume normal operation on the logical element that you placed in Maintenance mode. On the Service 
Network Operations tab, right-click the logical element and then click Exit Maintenance.
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Related Topics

• Understanding Device Maintenance, page 17-1

Maintaining Managed Acquired Service Modules Running in High-Availability 
Mode

Sometimes you might need to perform maintenance tasks on service modules that are in high-availability 
mode. This section provides detailed steps for performing these tasks on high-availability service 
modules that are managed and have been acquired by a service network, and includes the following 
topics:

• Upgrading the Operating System on High-Availability Service Modules, page 17-9

• Replacing a Failing High-Availability Service Module, page 17-10

• Moving a High-Available Service Module to Another Switch, page 17-11

• Moving a High-Availability Service Module to Another Slot in the Same Switch, page 17-12

Upgrading the Operating System on High-Availability Service Modules

If necessary, you can upgrade the operating systems on service modules running in HA mode with 
another service module.

Procedure

Step 1 Place the element you want to upgrade in Maintenance mode:

a. Choose View > Operations.

The Operations tab opens.

b. Open the appropriate service network.

c. Right-click the appropriate service module element and then click Enter Maintenance.

Step 2 Upgrade the operating system on the service module. Follow the upgrade procedures in the appropriate 
service module document.

Step 3 Turn preempt off on both service modules, if it is configured.

Step 4 Rediscover both service modules. 

This process is actually a reinventory process where VFrame compares the information in its database 
with what is present on the physical device and updates its database, if necessary. For details, see 
Discovering Ethernet Switches and Service Modules, page 6-4.

VFrame updates its database with the latest operating system versions of both service modules and logs 
a DeviceOSVersionChange fault on both the active and standby service module elements. You need to 
clear these faults manually.

Step 5 Verify the service network. On the Operations tab, click Verify Release Resources and check the Auto 
Correct Detected Changes check box.

VFrame verifies the configurations on both service modules and corrects any discrepancies.
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Step 6 Turn preempt back on, if necessary.

Step 7 Resume normal operation on the service module element that you placed in Maintenance mode. On the 
Operations tab, right-click the appropriate service module element and then click Exit Maintenance.

Related Topics

• Understanding Device Maintenance, page 17-1

Replacing a Failing High-Availability Service Module

If necessary, you can replace a failing service module that is part of an HA pair in your service network. 

Before You Begin

• VFrame monitoring might have detected the service module is failure. However, you should log in 
to the switch and verify the hardware failure.

• Obtain a new service module. Make sure it meets the following criteria:

– The new service module must be the same type as the failing service module. For example, if 
the failing service module is a CSM, you need to replace it with a CSM. If the failing service 
module is a CSM-S, you need to replace it with a CSM-S.

– The new service module must be configured with the same operating system version as the 
failing service module.

Procedure

Step 1 Place the failing HA service module element in Maintenance mode:

a. Choose View > Operations. 

The Operations tab opens.

b. Open the appropriate service network.

c. Right-click the appropriate service module HA element and then click Enter Maintenance.

Step 2 Turn off preempt on the active service module, if it is configured.

Step 3 Remove the failed service module and install the new service module in the same slot on the switch. 
Follow the installation procedures in the appropriate service module document.

Note Make sure it is the same type of service module and that it is configured with the same operating 
system version as the failing service module.

Step 4 Rediscover the new service module. For details, see Discovering Ethernet Switches and Service 
Modules, page 6-4.

Step 5 Verify the service network containing the new service module. On the Service Network Operations tab, 
click Verify Release Resources and check the Auto Correct Detected Changes check box.

VFrame verifies the configurations on both service modules in the HA pair and corrects any 
discrepancies.
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Step 6 Turn preempt back on, if necessary.

Step 7 Resume normal operation on the service module element. On the Operations tab, right-click the 
appropriate service module element and then click Exit Maintenance.

Related Topics

• Understanding Device Maintenance, page 17-1

Moving a High-Available Service Module to Another Switch

If a switch fails or you want to reconfigure your high-availability service module in a different switch, 
you can move the service module from one switch to another.

Procedure

Step 1 Place the service module HA element in Maintenance mode:

a. Choose View > Operations.

The Operations tab opens.

b. Open the appropriate service network.

Step 2 Turn off preempt on the active service module, if it is configured.

Step 3 If necessary, install a new switch in your network. Follow the installation procedures in the appropriate 
switch document.

Step 4 Remove the service module from the failing switch and install it in the new switch. Follow the 
installation procedures in the appropriate service module document.

Step 5 If you are using a CSM service module in HA mode, configure the service module to be the HA peer of 
the active service module. Follow the procedures in the appropriate service module configuration guide.

Step 6 Rediscover the new switch and the service module. For details, see Discovering Ethernet Switches and 
Service Modules, page 6-4.

Step 7 Manage the new switch and the service module. For details, see Managing and Unmanaging Ethernet 
Switches, page 7-8 and Managing Service Modules, page 7-12.

Step 8 Verify the service network. On the Service Network Operations tab, click Verify Release Resources and 
check the Auto Correct Detected Changes check box.

VFrame verifies the configurations on the new switch and on the service module and corrects any 
discrepancies.

Step 9 Turn on preempt on the active service module, if it is configured.

Step 10 Resume normal operation on the service module HA element.

Related Topics

• Understanding Device Maintenance, page 17-1
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Moving a High-Availability Service Module to Another Slot in the Same Switch

If necessary, you can move your high-availability service module to a different slot within the same 
switch.

Procedure

Step 1 Place the service module HA element in Maintenance mode:

a. Choose View > Operations.

The Operations tab opens.

b. Open the appropriate service network.

c. Right-click the appropriate element and then click Enter Maintenance.

Step 2 Turn off preempt on both service modules, if it is configured.

Step 3 Move the service module to the appropriate slot, and leave the old slot empty.

Step 4 Rediscover both service modules. For details, see Discovering Ethernet Switches and Service Modules, 
page 6-4.

Step 5 Manage the new switch and the service module. For details, see Managing and Unmanaging Ethernet 
Switches, page 7-8 and Managing Service Modules, page 7-12.

Step 6 Verify the service network. On the Service Network Operations tab, click Verify Release Resources and 
check the Auto Correct Detected Changes check box.

VFrame verifies the configuration on the new switch and on the service module and corrects any 
discrepancies.

Step 7 Turn on preempt on the active service module, if it is configured.

Step 8 If desired, install a new service module in the empty slot. Follow the installation and configuration 
procedures in the appropriate service module document.

Step 9 Resume normal operation on the service module HA element. On the Operations tab, right-click the 
appropriate element and then click Exit Maintenance.

Related Topics

• Understanding Device Maintenance, page 17-1

Maintaining LOM Managers
This section provides procedures to maintain LOM managers and servers, and includes the following 
topics:

• Replacing a Failed LOM Manager, page 17-13

• Upgrading Third-Party Software on a LOM Manager, page 17-14
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Replacing a Failed LOM Manager

A LOM manager can fail at any time when VFrame needs to perform a power on, power off, or power 
status operation. These operations occur whenever VFrame attempts to connect to a LOM manager to 
perform an operation, such as an inventory, snapshot, or deployment operation.

If VFrame cannot reach the LOM manager due to the device or network being down or other network 
issues, the operation fails.

If the primary LOM manager is not reachable and you do not have a secondary LOM manager 
configured, the operation fails. If you have a secondary LOM manager configured, VFrame attempts to 
connect with the secondary LOM manager. If successful, the operation proceeds. 

In either case, a warning message is recorded in the log file that triggered the operation. For example, if 
you are attempting to create a snapshot of a server and VFrame fails to connect to the designated LOM 
manager, a warning message is recorded in the job log for snapshot status. In addition, a warning is 
recorded in the global jobs log. Choose Tools > Jobs Logs to view the warning.

If necessary, you must replace the failing LOM manager with a new LOM manager. This procedure 
assumes that you are using an independent LOM manager, not VFrame as the LOM manager. 

Before You Begin

• Make sure that the failure is not due to a misconfiguration by checking that the LOM manager has 
been set up properly. For details, see Creating LOM Inventory File for Application Servers, 
page 3-17 and Setting Up Independent LOM Managers, page 3-21.

Procedure

Step 1 Replace the LOM manager server according to the manufacturer guidelines.

Step 2 Verify or set up SSH connectivity between VFrame and the LOM manager (see Setting Up Independent 
LOM Managers, page 3-21).

Step 3 Create or update the LOM interface and server inventory file that VFrame requires on the LOM manager 
(see Creating LOM Inventory File for Application Servers, page 3-17).

Step 4 Define or update IP address and port settings for the LOM manager (see Defining LOM Managers, 
page 11-67).

Step 5 Configure or update the LOM manager credentials in VFrame (see Configuring Server Credentials, 
page 4-11).

Step 6 Run discovery to discover the LOM interfaces through the new LOM manager (see Discovering LOM 
Interfaces and the Server Inventory Through LOM Managers, page 6-11).

Step 7 Verify that the LOM manager is working by performing a LOM manager operation, for example, an 
Update Power Status.

a. Choose View > Resources.

b. Right-click the LOM manager and then click Show Details Table.

c. Right-click a LOM interface and then click Update Power Status.

The Last Status column shows an hour glass icon as the power status is being obtained. Then, the 
power status changes to either red dot icon (power off) or a yellow light bulb icon (power on). This 
behavior indicates that the LOM manager is able to communicate to the selected LOM interface.
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Related Topics

• Understanding Device Maintenance, page 17-1

Upgrading Third-Party Software on a LOM Manager

If necessary, you can upgrade the third-party software on your LOM manager.

Procedure

Step 1 If you have only a primary LOM manager designated for use, temporarily change the IP address to a 
different LOM manager IP address, if possible. Doing so avoids unnecessary failures due to the LOM 
manager not being able to process operation requests that might occur during the upgrade process. For 
details, see Defining LOM Managers, page 11-67.

If you have a primary and a secondary LOM manager designated for use, you can upgrade them without 
making any changes. No failures should occur because any LOM manager operation requests are 
automatically forwarded to the alternate LOM manager.

Step 2 Upgrade the third-party software on the LOM manager according to the manufacturers guidelines.

Step 3 Edit macros to be compatible with the new software, if necessary. For details, see Creating and 
Modifying LOM Manager Templates, page 11-65.

Step 4 If you changed the primary LOM manager IP address to a different LOM manager IP address, change 
the IP address back to the original LOM manager IP address.

Step 5 Verify that the LOM manager is working by performing a LOM manager operation, for example, an 
Update Power Status operation:

a. Choose View > Resources.

b. Right-click the LOM manager and then click Show Details Table.

c. Right-click a LOM interface and then click Update Power Status. 

The Last Status column shows an hour glass icon as the power status is being obtained. Then, the 
power status changes to either a red dot icon (power off) or a yellow light bulb icon (power on). This 
behavior indicates that the LOM manager is able to communicate to the selected LOM interface.

Related Topics

• Understanding Device Maintenance, page 17-1

Replacing an Ethernet Switch
Depending on whether the Ethernet switch you want to replace is non-stackable or stackable, perform 
one of the following procedures:

• Replacing a Non-Stackable Ethernet Switch, page 17-15

• Replacing a Stackable Ethernet Switch, page 17-16
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Replacing a Non-Stackable Ethernet Switch

You can physically replace an Ethernet switch being managed by Cisco VFrame Data Center while 
maintaining its managed status. After you replace the switch and then schedule or run a discovery, 
VFrame detects the new replacement switch and provides you with the option of making it accessible to 
Cisco VFrame Data Center.

Note We recommend that you replace a switch with a device that is in the same Cisco Ethernet switch family. 
For example, you can replace a 3-slot Catalyst 6503 with 9-slot Catalyst 6509.

Cisco VFrame Data Center does not enforce OS versions between the previous switch and the 
replacement switch.

Before You Begin

Record the IP address of the switch being replaced. You will need to configure the replacement switch 
with the same IP address.

Procedure

Step 1 Replace the switch.

Step 2 Configure the replacement switch with the IP address of the switch being replaced. Ensure that the 
replacement switch is set up with the same configuration as the switch being replaced.

Step 3 Choose Tools > Discovery.

Step 4 Run a discovery using the IP address of the replacement switch.

You do not need to set a distance for this discovery because you are only interested in discovering the 
replaced switch. After it is discovered, two warning messages appear in the Jobs Log:

A new device with IP address 209.165.200.225 (identity: MarComm) was not discovered 
because a different device (209.165.200.225) with the same IP address already exists.

If you replaced the hardware of the device 209.165.200.225, please use the feature 
“Replace Device.”

Note The discovery is also marked failed in the top log on the Discovery tab.

Step 5 Choose View > Resources.

Step 6 In the Discovered Devices pane, place your mouse cursor over the switch.

A tool tip appears. In the tool tip, the fault state should read Error.

Step 7 Choose Tools > Alarms.

The following message appears in the Summary field:

A different device with the same IP address was discovered. If you replaced the hardware 
of this switch, please use the feature 'Replace Device.'

Step 8 Choose View > Resources.
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Step 9 Perform one of the following:

• In the Discovered Devices pane, right-click the switch.

• Click Actions.

Step 10 Click Replace Device.

A pop-up appears with the following message:

A hardware change has been detected. Do you want to rediscover this device without losing 
the VFrame Data Center configuration?

Step 11 Click OK.

The replacement operation begins. The replacement operation is essentially a rediscovery of the switch. 
However, if the previous switch was managed, the replacement switch will be managed.

When the replacement operation begins, a new entry appears on the Logs tab. When the replacement 
operation finishes and it is successful, the word Success appears in the Status field. The switch is now 
accessible by VFrame.

Replacing a Stackable Ethernet Switch

In VFrame Data Center, stackable switches connected together in a stack are displayed and managed as 
a single switch device with each stackable switch chassis represented as a module. Stackable switch 
chassis replacement is treated in the same way as line card replacement. 

Procedure

Step 1 If the switch is operational and has not failed, place it in maintenance mode. However, if the switch has 
failed, you do not need to place it in maintenance mode.

Step 2 Replace the failed switch chassis and connect the new switch into the stack (if any). 

Step 3 If you are replacing one of the switches in a stack, change the ID of the new switch to the ID of the 
previous switch.

The following example shows the CLI commands used to change the switch ID:

switch# config
switch(config)# switch 2 renumber 9
switch(config)#

Note We recommend changing the switch ID offline before adding the switch to the stack. If you do 
not change the switch ID offline, avoid running discovery, otherwise VFrame discovers the new 
ID and retains old ID, causing the switch replacement to fail.

Step 4 Choose Tools > Discovery.

Step 5 Run a discovery by using either the IP address of the chassis or by rediscovering all managed devices.

Step 6 Choose View > Resources.

Step 7 In the left pane, place your mouse cursor over the switch and right-click.

Step 8 Choose Properties.

Step 9 Verify that the properties of the switch have been updated.
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Step 10 Choose Tools > Alarms.

Step 11 Verify that the faults for the previous switch are cleared.

Related Topics

Discovering Devices, page 6-4
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