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Managing Global Libraries and Variables

This chapter provides detailed information about the Global Libraries, variable groups and variables, and 
how to manage them, and includes the following sections:

• Understanding Global Libraries and Variables, page 12-1

• Managing Global Libraries, page 12-2

• Working With Variables On the Variables Tab, page 12-7

• Global Libraries and Variable Reference, page 12-9

Understanding Global Libraries and Variables
This section describes roles and local users in more detail, and includes the following topics:

• Global Libraries Overview, page 12-1

• Variables Overview, page 12-1

Global Libraries Overview
Use the Global Libraries tab to view default variable groups and variables, and to manage user-defined 
variable groups and variables. The Global Libraries tab contains the following libraries:

• System_VGT_Library—View the default variable groups and variables in this library.

• User_VGT_Library—Manage variable groups and variables in this library.

Variables Overview
Variables are representations of values to use in macros within VFrame. For added flexibility, you can 
define variable and variable groups. 

Sometimes you might want to use the same types of variables for several different macros. VFrame 
allows you to create variables and variable groups, which are basically templates of variables and 
variable groups that you can use repeatedly. 
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For example, if you repeatedly use the following three variables:

• IP address

• Subnet mask

• Gateway IP address

You can create three variables and a variable group type to contain them. Later, when you create macros 
and service network templates that reference these variables, you only need to reference the variable 
group, and all three variables also will be referenced. If needed, you can modify the variables to meet 
your specific requirements.

Managing Global Libraries
This section provides information about how access the Global Libraries from different templates and 
how to create user-defined variable groups and variables, and includes the following topics:

• Accessing the Global Libraries, page 12-2

• Using the User_VGT_Library, page 12-4

Accessing the Global Libraries
You can access the global libraries in a number of different ways. The way you access the global libraries 
depends in part on what type of template you are working on.

This section explains how to access the global libraries when working with various templates, and 
includes the following topics:

• Accessing the Global Libraries From a Service Network Template, page 12-2

• Accessing the Global Libraries From a LOM Managers Template, page 12-3

• Accessing the Global Libraries From a Storage Managers Template, page 12-3

Accessing the Global Libraries From a Service Network Template

Procedure

Step 1 Choose View > Templates.

Step 2 Double-click a template.

Step 3 Do one of the following:

• Click Properties, click Macros & Variables, then click Global Libraries.

The Global Libraries tab opens.

• Click a logical element, click Macros & Variables, then click Global Libraries.

The Global Libraries tab opens.
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Related Topics

• Global Libraries Tab, page 12-10

• Accessing the Global Libraries From a LOM Managers Template, page 12-3

Accessing the Global Libraries From a LOM Managers Template

Procedure

Step 1 Choose Tools > LOM Managers.

Step 2 Click a template.

Step 3 Click Macros & Variables.

Step 4 Click Global Libraries.

The Global Libraries tab opens.

Related Topics

• Global Libraries Tab, page 12-10

• Accessing the Global Libraries From a Storage Managers Template, page 12-3

Accessing the Global Libraries From a Storage Managers Template

Procedure

Step 1 Choose Tools > Storage Managers.

Step 2 Click a template.

Step 3 Click Macros & Variables.

Step 4 Click Global Libraries.

The Global Libraries tab opens.

Related Topics

• Global Libraries Tab, page 12-10

• Accessing the Global Libraries From a Service Network Template, page 12-2
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Using the User_VGT_Library
You can create, edit and delete variable groups and variables in the User_VGT_Library.

This section helps you work with the User_VGT_Library, and includes the following topics:

• Creating User_VGT_Library Variable Groups, page 12-4

• Editing and Deleting User_VGT_Library Variable Groups, page 12-5

• Creating User_VGT_Library Variables, page 12-5

• Editing and Deleting User_VGT_Library Variables, page 12-6

Creating User_VGT_Library Variable Groups

Procedure

Step 1 Choose View > Templates.

Step 2 Create a new template or double-click an existing template.

Step 3 Click Properties and then click Macros & Variables.

Step 4 Click Global Libraries.

The Global Libraries tab opens.

Step 5 Right-click User_VGT_Library and the click Create Variable Group Type.

The Variable Group dialog box appears.

Step 6 Enter a name and description in the fields and then click OK.

The newly created variable group type appears under User_VGT_Library. 

Step 7 Right-click the newly created variable group type and do one of the following:

• To add a previously created variable group type, click Add Variable Group Type. The Variable 
Group Type Selector dialog box opens. Click the appropriate variable group type and then click OK. 
The variable group type and its contents are added to the variable group type you just created. For 
details, see Variable Group Type Selector Dialog Box, page 12-13.

• To add a variable type, click Add Variable Type, enter the appropriate information in the Variable 
dialog box and then click OK. For details, see Variable Dialog Box, page 12-15.

Step 8 Click OK.

Step 9 Click Save.

Related Topics

• Global Libraries Tab, page 12-10

• Understanding Global Libraries and Variables, page 12-1
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Editing and Deleting User_VGT_Library Variable Groups

Procedure

Step 1 Choose View > Templates.

Step 2 Create a new template or double-click an existing template.

Step 3 Click Properties then click Macros & Variables.

Step 4 Click Global Libraries.

The Global Libraries tab opens.

Step 5 Navigate to the variable group type to edit or delete.

Step 6 Right-click the variable group type and do one of the following:

• To edit it, click Edit Variable Group Type, change the name and description as desired, and then 
click OK. 

• To delete it, click Delete Variable Group Type.

Step 7 Click OK.

Step 8 Click Save.

Related Topics

• Global Libraries Tab, page 12-10

• Understanding Global Libraries and Variables, page 12-1

Creating User_VGT_Library Variables

Procedure

Step 1 Choose View > Templates.

Step 2 Create a new template or double-click an existing template.

Step 3 Click Properties then click Macros & Variables.

Step 4 Click Global Libraries.

The Global Libraries tab opens.

Step 5 Navigate to an existing variable group type or create a new one (see Creating Variable Groups On the 
Variables Tab, page 12-7).

Step 6 Right-click the variable group type and click Add Variable Type.

Step 7 Enter the following information in the fields:

• Enter a name and description in the appropriate fields.

• In the Type field, click the type of variable that you are creating.

• Click the Advanced check box to define any of the following parameters:

– Shared—Check the Shared check box to allow the variable value to be used by child elements, 
such as servers in a server group.
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– Multivalued—Check the Multivalued check box to specify that the variable contains more than 
one value. If multivalue is checked, resource pools (not single values) must be assigned as the 
value. For more information, see Understanding Global Libraries and Variables, page 12-1.

If you check the Multivalued and Assign a Default Value check boxes, you can define multiple 
default values.

– Optional—Check the Optional check box to indicate that a value is not required for the 
variable.

– Allow Pool Assignment—Check the Allow Pool Assignment check box to allow a resource 
pool to be assigned to the variable. Left unchecked, only one resource can be assigned to the 
variable.

– Restrict Values—Check the Restrict Values check box to enumerate specific values or identify 
a range of values from which to choose when defining the variable value. (Applies only to 
Integer or String variable types.)

– Assign a Default Value—Check the Assign a Default Value check box to show the value as the 
default value for the variable. When you check this check box, the Assign a Default Value area 
appears. 

Step 8 Click OK.

Step 9 Click Save.

Related Topics

• Global Libraries Tab, page 12-10

• Understanding Global Libraries and Variables, page 12-1

Editing and Deleting User_VGT_Library Variables

Procedure

Step 1 Choose View > Templates.

Step 2 Create a new template or double-click an existing template.

Step 3 Click Global Libraries.

The Global Libraries tab opens.

Step 4 Navigate to the variable type that you want to edit or delete.

Step 5 Right-click the variable type and do one of the following:

• To edit it, click Edit Variable Type, make the desired changes, and click OK. For information about 
the fields in this dialog box, see Variable Dialog Box, page 12-15.

• To delete it, click Delete Variable Type.

Step 6 Click OK.

Step 7 Click Save.
12-6
Cisco VFrame Data Center Administration Guide

OL-15450-01



 

Chapter 12      Managing Global Libraries and Variables
Working With Variables On the Variables Tab
Related Topics

• Global Libraries Tab, page 12-10

• Understanding Global Libraries and Variables, page 12-1

Working With Variables On the Variables Tab
This section helps you work with variable and variable groups, and includes the following topics:

• Creating Variable Groups On the Variables Tab, page 12-7

• Editing and Deleting Variable Groups On the Variables Tab, page 12-8

• Creating Variables On the Variables Tab, page 12-8

• Editing and Deleting Variables On the Variables Tab, page 12-9

Creating Variable Groups On the Variables Tab
You can create variable group types, which are templates of variable groups that you can use over and 
over.

Procedure

Step 1 Choose View > Templates.

Step 2 Create a new template or double-click an existing template.

Step 3 Click Properties then click Macros & Variables.

Step 4 Click Variables.

The Variables tab opens.

Step 5 Right-click a macro container and then click New or click the variable group then click New.

The Variable Group dialog box appears.

Step 6 Use the Variable Group dialog box to create a variable group. See Creating User_VGT_Library Variable 
Groups, page 12-4.

Related Topics

• Understanding Global Libraries and Variables, page 12-1

• Variables, page 11-12

• Global Libraries Tab, page 12-10
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Editing and Deleting Variable Groups On the Variables Tab
You can edit variable group types, or delete them if they are no longer necessary.

Procedure

Step 1 Choose View > Templates.

Step 2 Create a new template or double-click an existing template.

Step 3 Click Properties and then click Macros & Variables.

Step 4 Click Variables.

The Variables tab opens.

Step 5 Do one of the following:

• Right-click a variable group and click Edit or click the variable group then click Edit. The Variable 
Group dialog box appears. Edit the variable group using the Variable Group dialog box and then 
click OK.

• Right-click a variable group and then click Delete or click the variable group and then click Delete. 
The variable group is deleted.

Related Topics

• Understanding Global Libraries and Variables, page 12-1

• Variables, page 11-12

• Global Libraries Tab, page 12-10

Creating Variables On the Variables Tab
You can create variable types, which are templates of variables that you can use repeatedly.

Procedure

Step 1 Choose View > Templates.

Step 2 Create a new template or double-click an existing template.

Step 3 Click Properties then click Macros & Variables.

Step 4 Click Variables.

The Variables tab opens.

Step 5 Right-click a macro container and then click New or click the variable group and then click New.

The Variable Group dialog box appears.

Step 6 Use the Variable Group dialog box to create a variable group. See Creating User_VGT_Library Variable 
Groups, page 12-4.
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Related Topics

• Understanding Global Libraries and Variables, page 12-1

• Variables, page 11-12

• Global Libraries Tab, page 12-10

Editing and Deleting Variables On the Variables Tab
You can edit variable types, or delete them if they are no longer necessary.

Procedure

Step 1 Choose View > Templates.

Step 2 Create a new template or double-click an existing template.

Step 3 Click Properties then click Macros & Variables.

Step 4 Click Variables.

The Variables tab opens.

Step 5 Do one of the following:

• Right-click a variable and then click Edit or click the variable and then click Edit. The Variable 
Group dialog box appears. Edit the variable group using the Variable Group dialog box and then 
click OK.

• Right-click a variable and then click Delete or click the variable and then click Delete. The variable 
group is deleted.

Related Topics

• Understanding Global Libraries and Variables, page 12-1

• Variables, page 11-12

• Global Libraries Tab, page 12-10

Global Libraries and Variable Reference
This section describes the tabs and dialog boxes you use when managing global libraries, and includes 
the following topics:

• Global Libraries Tab, page 12-10

• Variables Tab, page 12-12

• Variable Group Dialog Box, page 12-13

• Variable Group Type Selector Dialog Box, page 12-13

• Variable Dialog Box, page 12-15
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Global Libraries Tab
Use the Global Libraries tab to display information about default variable groups and default variables. 
You can also create, edit, and delete user-defined variable types and variable group types.

How to Get to This Tab

See Accessing the Global Libraries, page 12-2, for information about how to access this tab.

Related Topics

• Understanding Global Libraries and Variables, page 12-1

• Working With Variables On the Variables Tab, page 12-7

Field Reference

Table 12-1 Global Libraries Tab

Element Description

Actions button Click an item and then click Actions to open a context-sensitive drop-down 
menu of actions that you can perform.

Note The Actions button is used with the User_VGT_Library. You cannot 
make changes to the System_VGT_Library.

When you choose the library, the following options appear on the drop-down 
menu:

• Create Variable Group Type—Click Create Variable Group Type to 
create a variable group.

When you choose a group, the following options appear on the drop-down 
menu:

• Add Variable Group Type—Click Add Variable Group Type to add a 
variable group.

• Edit Variable Group Type—Click Edit Variable Group Type to edit a 
variable group.

• Delete Variable Group Type—Click Delete Variable Group Type to 
delete a variable group.

• Add Variable Type—Click Add Variable Type to add a variable.

Save button Click Save to save the changes you made to the library.

Move up button Click the move up button to move a variable up one position.

Move down button Click the move down button to move a variable down one position.
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Name The names of variable group types and variable types. Variable group types 
are divided into two libraries: 

• User_VTG_Library—User-definable variable group types and variable 
types.

• System_VTG_Library—Predefined variable group types and variable 
types.

In these libraries, variable group types and variable types are displayed as a 
hierarchical tree to show relationships between items. Items in the tree are 
identified by icons.

Description The word or phrase describing the variable or variable group type.

Type Following are the variable types in the global libraries:

• Boolean—True or False.

• Date—Date in the format YY-MM-DD.

• Double—Double precision number, which can be defined as an integer, 
fixed-point number, or floating-point number.

• Float—Floating point number.

• IPAddrResourceType—IP address.

• Integer—Integer. You can define variable value restrictions that define 
minimum and maximum values or enumerate specific values.

• Long—Long integer.

• String—Sequence of simple objects. You can define variable value 
restrictions that define regular expressions or the enumerated values.

• Vlan—Name or number of VLANs discovered or created by VFrame.

• SGDefGatewayStr—IP address for the default gateway.

• GatewayMetric—Metric for the default gateway.

• DiscoveredVLAN—Add or remove VLANs dynamically in service 
network operations.

• ESXCluster—Add to the ESX cluster.

• StringPrefix—Host name of the logical server.

IsShared Indicates whether the variable value can be used by child elements, if any 
exist, such as servers in a server group. True means the variable can be 
shared, and False means the variable cannot be shared.

Multivalued Indicates whether the variable is set to multivalue. True means the variable 
is set to multivalue, and False means it is not set to multivalue.

Optional Indicates that a value is not required for the variable.

Default Value Indicates that the value for the variable is the default value.

Restricted Value Indicates that the value for the variable is the restricted value.

Table 12-1 Global Libraries Tab (continued)

Element Description
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Variables Tab
Use the Variables tab to display information about system variable group types. You can also create, edit, 
and delete user-defined variable types and variable group types

Table 12-2 Variables Tab

Element Description

Name The names of variable group types and variable types. Variable group types 
are divided into two libraries: 

• User_VTG_Library—User-definable variable group types and variable 
types.

• System_VTG_Library—Predefined variable group types and variable 
types.

In these libraries, variable group types and variable types are displayed as a 
hierarchical tree to show relationships between items. Items in the tree are 
identified by icons.

Description The word or phrase describing the variable or variable group type.

Type Following are the types of variables in the global libraries:

• Boolean—True or False.

• Date—Date in the format YY-MM-DD.

• Double—Double precision number, which can be defined as an integer, 
fixed-point number, or floating-point number.

• Float—Floating point number.

• IPAddrResourceType—IP address.

• Integer—Integer. You can define variable value restrictions that define 
minimum and maximum values or enumerate specific values.

• Long—Long integer.

• String—Sequence of simple objects. You can define variable value 
restrictions that define regular expressions or the enumerated values.

• Vlan—Name or number of VLANs discovered or created by VFrame.

• SGDefGatewayStr—IP address for the default gateway.

• GatewayMetric—Metric for the default gateway.

• DiscoveredVLAN—Add or remove VLANs dynamically in service 
network operations.

• ESXCluster—Add to the ESX cluster.

• StringPrefix—Host name of the logical server.

IsShared Indicates whether the variable value can be used by child elements, if any 
exist, such as servers in a server group. True means the variable can be 
shared, and False means the variable cannot be shared.

Multivalued Indicates whether the variable is set to multivalue. True means the variable 
is set to multivalue, and False means it is not set to multivalue.

Optional Indicates that a value is not required for the variable.
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Variable Group Dialog Box
Use the Variable Group dialog box to create variable groups or variable group types.

How to Get to This Dialog Box

Click the library name, click Action, and then click Create Variable Group Type.

Related Topics

• Variables, page 11-12

• Understanding Global Libraries and Variables, page 12-1

Field Reference

Variable Group Type Selector Dialog Box
Use the Variable Group Type Selector dialog box to add existing variable group types to the selected 
variable group.

How to Get to This Dialog Box

Click a variable group, click Action, and then click Add Variable Group Type.

Related Topics

• Understanding Global Libraries and Variables, page 12-1

• Variable Group Dialog Box, page 12-13

Default Value Indicates that the value for the variable is the default value.

Restricted Value Indicates that the value for the variable is the restricted value.

Move up button Click this button to move a variable up one position.

Move down button Click this button to move a variable down one position.

New button Click this button to create a new variable group or variable.

Edit button Click this button to edit a variable group or variable.

Delete button Click this button to delete a variable group or variable.

Table 12-2 Variables Tab (continued)

Element Description

Table 12-3 Variable Group Dialog Box

Element Description

Group Name The name of the variable group.

Description The word or phrase that describes the variable group.
12-13
Cisco VFrame Data Center Administration Guide

OL-15450-01



 

Chapter 12      Managing Global Libraries and Variables
Global Libraries and Variable Reference
Field Reference

Table 12-4 Variable Group Type Selector Dialog Box

Element Description

Name The names of variable group types and variable types. Variable group types 
are divided into two libraries:

• User_VTG_Library—User-definable variable group types and variable 
types.

• System_VTG_Library—Predefined variable group types and variable 
types.

In these libraries, variable group types and variable types are displayed as a 
hierarchical tree to show relationships between items. Items in the tree are 
identified by icons.

Description The word or phrase describing the variable or variable group type.

Type Following are the types of variables in the global libraries:

• Boolean—True or False.

• Date—Date in the format YY-MM-DD.

• Double—Double precision number, which can be defined as an integer, 
fixed-point number, or floating-point number.

• Float—Floating point number.

• IPAddrResourceType—IP address.

• Integer—Integer. You can define variable value restrictions that define 
minimum and maximum values or enumerate specific values.

• Long—Long integer.

• String—Sequence of simple objects. You can define variable value 
restrictions that define regular expressions or the enumerated values.

• Vlan—Name or number of VLANs discovered or created by VFrame.

• SGDefGatewayStr—IP address for the default gateway.

• GatewayMetric—Metric for the default gateway.

• DiscoveredVLAN—Add or remove VLANs dynamically in service 
network operations.

• ESXCluster—Add to the ESX cluster.

• StringPrefix—Host name of the logical server.

IsShared Indicates whether the variable value can be used by child elements, if any 
exist, such as servers in a server group. True means the variable can be 
shared, and False means the variable cannot be shared.

Multivalued Indicates whether the variable is set to multivalue. True means the variable 
is set to multivalue, and False means it is not set to multivalue.

Optional Indicates that a value is not required for the variable.

Default Value Indicates that the value for the variable is the default value.

Restricted Value Indicates that the value for the variable is the restricted value.
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Variable Dialog Box
Use the Variable dialog box to create variable types.

How to Get to This Dialog Box

Click a variable group, click Action, and then click Add Variable Type.

Related Topics

• Variables, page 11-12

• Understanding Global Libraries and Variables, page 12-1

Field Reference

Table 12-5 Variable Dialog Box

Element Description

Variable Name The name of the variable.

Description The word or phrase that describes the variable.

Type Following are the types of variables in the global libraries:

• Boolean—True or False.

• Date—Date in the format YY-MM-DD.

• Double—Double precision number, which can be defined as an integer, 
fixed-point number, or floating-point number.

• Float—Floating point number.

• IPAddrResourceType—IP address.

• Integer—Integer. You can define variable value restrictions that define 
minimum and maximum values or enumerate specific values.

• Long—Long integer.

• String—Sequence of simple objects. You can define variable value 
restrictions that define regular expressions or the enumerated values.

• Vlan—Name or number of VLANs discovered or created by VFrame.

• SGDefGatewayStr—IP address for the default gateway.

• GatewayMetric—Metric for the default gateway.

• DiscoveredVLAN—Add or remove VLANs dynamically in service 
network operations.

• ESXCluster—Add to the ESX cluster.

• StringPrefix—Host name of the logical server.
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Show advanced settings Click this button to show advanced settings. Applicable settings are activated 
based on the type of variable you are creating. You can choose multiple 
settings for a variable. These settings affect what you or another user is 
allowed to enter when defining values for the variables.

• Shared—Check the Shared check box to allow the variable value to be 
used by child elements, such as servers in a server group.

• Multivalued—Check the Multivalued check box to specify that the 
variable contains more than one value. If multivalue is selected, resource 
pools (not single values) must be assigned as the value. For more 
information, see Understanding Global Libraries and Variables, 
page 12-1.

If you check the Multivalued and Assign default value check boxes, you 
can assign multiple default values.

• Optional—Check the Optional check box to indicate that a value is not 
required for the variable.

• Allow Pool Assignment—Check the Allow Pool Assignment check box 
to allow a resource pool to be assigned to the variable. Left unchecked, 
only one resource can be assigned to the variable.

• Restrict Values—Check the Restrict Values check box to enumerate 
specific values or to identify a range of values from which to choose 
when defining the variable value. (Applies only to Integer or String 
variable types.)

• Assign a Default Value—Check the Assign a Default Value check box 
to enter a default value for the variable.

• Value—Click either True or False. The Value scroll list appears when 
you check the Assign a Default Value check box.

Table 12-5 Variable Dialog Box (continued)

Element Description
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