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C H A P T E R 13

Designing Service Networks

This chapter provides detailed information about service network design, and includes the following 
sections:

• Designing Service Networks—Basic Workflow, page 13-1

• Understanding Service Network Design, page 13-2

• Designing a Service Network—Scenario, page 13-3

• Working with Service Networks, page 13-8

• Service Networks Reference, page 13-16

Designing Service Networks—Basic Workflow
Table 13-1 is an overview of the steps you take to design a service network in VFrame.

Table 13-1 Designing Service Networks—Basic Workflow

Task

Step 1 Create a service network (see Creating and Modifying Service Networks, 
page 13-8).

As part of this task and depending on your service network design, define the 
following element and endpoint parameters, as required:

• Network variables (see Defining Network Variables, page 13-9).

• Block variables (see Defining Block Variables, page 13-9).

• Port variable values (see Defining Port Variable s, page 13-10).

• Assigning resource pools (see Assigning Resource Pools, page 13-11).

• NAS storage (see Adding NAS Storage, page 13-11).

• SAN storage (see Adding SAN Storage, page 13-12).

• Settings (see Configuring Settings, page 13-12).

• Teaming parameters (see Defining Teaming Parameters, page 13-13).

Step 2 Save your service network design (see Saving Service Networks, page 13-15).
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Understanding Service Network Design
You create service networks based on service network templates. The template identifies generic 
information, and the service network identifies the actual resources (resource pools, variable values, 
server configuration, and so on) that are required to start and operate your service network.

In some service network designs, there are special considerations pertaining to network virtualization. 

This section describes key concepts that help you design your service network, and includes the 
following topics:

• Understanding Service Network Design Elements, page 13-2

• Changing Service Networks, page 13-2

Understanding Service Network Design Elements
Before designing your service network, it is helpful to understand the following service network design 
elements:

• Block Variables—Most logical elements have system actions or macros associated with them, and 
these system actions or macros have variables. You must supply the values for these variables. The 
values are substituted for the variables in the system actions or macros at run time.

An example of a block variable is the VLAN variable required for defining a VLAN in a service 
network.

• Pool Selection— All logical elements, except VLAN and Storage, require that you choose the 
resource or resource pool to use when the service network is deployed. When you deploy your 
service network, resources are acquired based on the resource or resource pool you have selected. 
For more details about resource pools, see Resource Pool Overview, page 9-1.

Note A server will automatically acquire any Layer 2 switch connected to it.

• Server Group Definition—For VFrame to create and image the servers in your service network, you 
must define the server group parameters such as the storage type, location and golden image. This 
information is used to create, image, and start your servers when you deploy your service network.

Changing Service Networks
After you define and deploy a service network, you can add and remove resources and resource pools. 
However, the change does not take effect until the next time the service network tries to acquire a 
resource from the assigned resources or resource pools.

You can change certain variable values in a service network while the network is running. The variable 
values you can change are those to which VFrame does not attach any specific meanings or relationships, 
for example, strings, numbers, or Boolean values. These are called primitive variables.

Another variable type, called resource variables, can also be changed; however, changes do not take 
effect until the next time the service network attempts to acquire resources. Resource variables are those 
that require a resource, such as an IP address, VLAN, or storage resource (LUN or Qtree).
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Designing a Service Network—Scenario
This scenario builds upon the service network template you created in Chapter 11, “Designing 
Templates.” The template is based on a sample network design in which you have a switch with a CSM 
connected in single subnet (bridge) mode to a group of servers, as shown in Figure 11-12.

This scenario assumes that the VFrame administrator has already completed all of the prerequisites for 
creating a service network template and created the CSM service network template. For details on these 
prerequisites, see Creating a Service Network Template—Scenario, page 11-33.

This section provides a scenario for building a service network, and includes the following topics:

• Define Resource Pools, page 13-3

• Create the Service Network, page 13-3

• Define Service Network Settings, page 13-4

Define Resource Pools

Following are the resource pools you will use when you design the service network. Ensure that all of 
them are fully defined:

• Cisco Catalyst 6500 (Layer 3 Enabled)

• IP Address Range

• VLAN (VFrame Created)

Note You create these VLANs using the Resource Pools tab.

• Content Switching Module

• Server

• NFS Volume

Create the Service Network

You create service networks based on service network templates. The template identifies the logical 
elements and connections, and the service network uses cthe configured logical elements to identify the 
actual resources (resource pools, variable values, server configuration) that are required to deploy your 
service network.

In this scenario, you create a service network called csmNetwork from the template called csmTemplate. 
When you first create the network, you will see small red icons next to most of the logical elements in 
the network. These icons indicate that the element they are next to is not configured properly. Use the 
fields and drop-down lists on the pages that appear when you chose an element to configure that element.

Procedure

Step 1 Choose View > Service Networks.

Step 2 Click csmTemplate and then click New.

The Input dialog box appears.
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Step 3 Enter csmNetwork in the Network name field.

Step 4 Click OK.

The service network opens, and it appears in the Service Networks selector, in the Opened Service 
Network selector, and in a tab above the work area.

Define Service Network Settings

Service Network Settings

Procedure

Step 1 (Optional) Check the Enable Root Bridge Setting check box to enable root bridging.

Step 2 (Optional) Enter a description of the network in the Service Network Description field.

Step 3 Click Save.

Note By enabling the root bridge feature, VFrame will find a switch that will be the root bridge.

ServerGroup Logical Element

Procedure

Step 1 Click the ServerGroup logical element.

Step 2 Click the Settings tab.

Step 3 Choose a golden image in the Image scroll-down list:

a. Click the down arrow.

b. Choose an image.

The image appears in the Image scroll-down list.

Step 4 Click the Block Variables tab.

Step 5 Enter a name in the HostName field.

Step 6 Click the Pool Selection tab.

Step 7 Choose one or more servers from the server resource pool:

a. Click the Select button.

The Resource Selection dialog box appears.

b. Choose one or more servers from the Available area.

c. Click the move-right button.

d. Click OK..

The server(s) appear in the Element Name : ServerGroup area.
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Step 8 Click the To_VLAN port group under the ServerGroup logical element.

Step 9 Click the Port Variables tab.

Step 10 Choose an IP address range in the IPAddress (Primary) scroll-down list:

a. Click the down arrow.

b. Choose an IP address range.

c. Click the move-right button.

d. Click OK.

Step 11 Click Save.

The IP address range appears in the IPAddress (Primary) scroll-down list. The ServerGroup logical 
element is defined.

LoadBalancer Logical Element

Step 1 Click the LoadBalancer logical element.

Step 2 Click the Pool Selection tab.

Step 3 Choose a load balancer from the load balancer resource pool:

a. Click the Select button.

The Resource Selection dialog box appears.

b. Choose one load balancer from the Available area.

c. Click the move-right button.

d. Click OK.

The load balancer appears in the Element Name : LoadBalancer area.

Step 4 Click the Block Variables tab.

Step 5 Enter VS1 in the VServerName text box.

Step 6 Enter SF1 in the ServerFarmName text box.

Step 7 Choose an IP address range in the IPAddress (Primary) scroll-down list in the VServerIP area:

a. Click the down arrow.

b. Choose an IP address range.

c. Click the move-right button.

a. Click OK..

Step 8 Click the To_Layer3Switch endpoint.

Step 9 Choose Admin Context: ALL VLAN (VFrame Created) in the Vlan (Primary) scroll-down list:

a. Click the down arrow.

b. Choose the Admin Context: ALL VLAN (VFrame Created) folder.

c. Click the move-right button.

d. Click OK.

The name of the folder appears in the Vlan (Primary) scroll-down list.
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Step 10 Enter client in the InterfaceType (Primary) text box.

Step 11 Click the To_VLAN endpoint under the LoadBalancer logical element.

Step 12 Choose Admin Context: ALL VLAN (VFrame Created) in the Vlan (Primary) scroll-down list:

a. Click the down arrow.

b. Choose the Admin Context: ALL VLAN (VFrame Created) folder.

c. Click the move-right button.

d. Click OK.

The name of the folder appears in the Vlan (Primary) scroll-down list.

Step 13 Enter server in the InterfaceType (Primary) text box.

Step 14 Choose an IP address range in the IPAddress (Primary) scroll-down list:

a. Click the down arrow.

b. Choose an IP address. range

c. Click the move-right button.

d. Click OK.

Step 15 Click Save.

The IP address range appears in the IPAddress (Primary) scroll-down list. The LoadBalancer logical 
element is defined.

NAS Storage Logical Element

Procedure

Step 1 Click the NAS Storage logical element.

Step 2 Click the storage definition in the Storage Definitions area.

Step 3 Click the edit button.

Step 4 Choose a partition from the volumes resource pool:

a. Click the Select button.

The Select Volumes dialog box appears.

b. Choose kennethvol1 | vcc-filer2:/vol/kennethvol1 from the Available area.

c. Click the move-right button.

d. Click OK then click OK to close the Edit NAS Group RootStorageEelement dialog box.

Step 5 Click Save.

The volume appears in the Storage Definitions area.
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Layer3Switch Logical Element

Procedure

Step 1 Click the Layer3Switch logical element.

Step 2 Choose a Layer 3 switch from the Layer 3 switch resource pool:

a. Click the Select button.

The Resource Selection dialog box appears.

b. Choose 10.100.0.2 from the Available area.

c. Click the move-right button.

d. Click OK.

The IP address appears in the Element Name : Layer3Switch area.

Step 3 Click the To_LoadBalancer endpoint.

Step 4 Choose an IP address in the IPAddress (Primary) scroll-down list in the SviIpAddressGroup area:

a. Click the down arrow.

b. Choose 10.100.40.20 from the Available area.

c. Click the move-right button.

d. Click OK.

Step 5 Click Save.

The IP address range appears in the IPAddress (Primary) scroll-down list. The Layer3Switch logical 
element is defined.

The service network is designed.

Verify Your Service Network Definitions

Procedure

Step 1 Click Details.

The Service Network Summary dialog box appears.

Step 2 Verify that the variable values you selected are correct.

Step 3 Click OK.

Step 4 Click Save.

Step 5 See Operating a Service Network—Scenario, page 14-12 to continue to design your service network.

The service network is verified.
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Working with Service Networks
This section helps you work with and design service network templates, and includes the following 
topics:

• Creating and Modifying Service Networks, page 13-8

• Saving Service Networks, page 13-15

• Displaying Summary Information for Service Networks, page 13-16

Creating and Modifying Service Networks
You can create service networks based on the published templates, and when necessary, you can modify 
them.

Before You Begin

• Determine which template best fits your service network design. If necessary, create a template that 
meets your needs. For more information, see Creating and Modifying Service Network Templates, 
page 11-49.

• Determine the variable values you will need to supply.

Procedure

Step 1 Choose View > Service Networks.

Step 2 On the Service Networks tab, do one of the following:

• To create a new service network, click the template that you want to use as a base and click New. 
The Input dialog box appears. Enter the service network name in Network name field. The service 
network opens, and its name appears in the Service Networks selector, in the service network 
elements selector (specified by the service network name), and in a tab above the work area.

• To modify an existing service network, double-click the appropriate service network in the Service 
Network selector. The service network opens, and its name appears in the Service Networks selector, 
in the service network elements selector (specified by the service network name), and in a tab above 
the work area.

Step 3 Depending on your service network design, define variables, and element and end-point parameters by 
selecting elements or endpoints in the Elements selector or in the service network map and doing any of 
the following:

Note Tabs that are displayed depend on what is selected.

• Click the Block Variables tab to define the variables for logical elements within your service 
network. For details, see Defining Block Variables, page 13-9.

• Click the Port Variables tab to define the variables for endpoints within your service network. For 
details, see Defining Port Variable s, page 13-10.

• Click the Pool Selection tab to select resources available to your service network when you deploy 
it. For details, see Assigning Resource Pools, page 13-11.

• Click the NAS Storage tab to add NAS storage groups. For details, see Adding NAS Storage, 
page 13-11.
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• Click the Settings tab to define parameters for the SAN Fabric, SAN Storage, ServerGroup with a 
VLAN connection (To_VLAN), Virtual Switch logical elements, and ESX server port groups. For 
details, see Adding SAN Storage, page 13-12, Configuring Settings, page 13-12, and Defining Port 
Groups, page 13-15.

• Click the Teaming tab to define teaming parameters for multiple Ethernet connections. For details, 
see Defining Teaming Parameters, page 13-13.

Note Red X icons appear next to each required tab and parameter. As you define these required 
parameters, these icons disappear. When all red icons are gone, your service network template 
is ready to be deployed.

Step 4 After you finish defining or modifying your service network, click Save. The service network is saved 
to the database.

Related Topics

• Understanding Service Network Design, page 13-2

• Service Networks Tab, page 13-16

Defining Network Variables

You can define values for network variables according to your service network design.

Procedure

Step 1 Choose View > Service Network. 

Step 2 Open a service network, then click the service network in the Service Network Elements selector.

The Network Settings tab opens. For details, see Network Settings Tab, page 13-20.

Step 3 Check the Enable Root Bridge Setting check box to enable the root bridge setting, if desired. 
Otherwise, leave it unchecked.

If the check box is checked, VFrame configures a switch to become the root for the specified VLAN.

Related Topics

• Understanding Service Network Design, page 13-2

• Creating and Modifying Service Networks, page 13-8

• Service Networks Tab, page 13-16

Defining Block Variables 

When the template associated to your service network was created, variables were created for the service 
network. You can define the actual values for these variables according to your service network design. 
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Procedure

Step 1 Choose View > Service Network. 

Step 2 Open a service network and click an element.

Step 3 Click the Block Variables tab.

Step 4 For each variable, click the appropriate value into the variable drop-down list.

Step 5 (Optional in ESX) Configure the following variables:

• VMKernelDefaultGateway

• EsxCluster

• EsxLicenseServerGroup

Related Topics

• Understanding Service Network Design, page 13-2

• Creating and Modifying Service Networks, page 13-8

• Block Variables Tab, page 13-21

Defining Port Variable s

When the template associated to your service network was created, variables were defined for the 
endpoints. You can define the actual values for these endpoints according to your service network design. 

Procedure

Step 1 Choose View > Service Networks.

Step 2 Open a service network and click an endpoint.

Step 3 Click the Port Variables tab. 

Step 4 For each variable, click the appropriate value into the variable drop-down list.

Step 5 (Optional in ESX) Configure the following:

Step 6 Enter a switch port description in SwitchportDescription for the layer2Etherchannel and layer2Ports 
variables.

Step 7 Check the CDP Enabled check box to enable CDP.

Step 8 Click the ip logical elements.

Step 9 Click an IP address range in the IPAddress drop-down list.

Related Topics

• Understanding Service Network Design, page 13-2

• Creating and Modifying Service Networks, page 13-8

• Port Variables Tab, page 13-21
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Assigning Resource Pools

You can select resources or resource pools that will be available to your service network when it is 
deployed.

Procedure

Step 1 Choose View > Service Networks. 

Step 2 Open a service network and click an element.

Step 3 Click on the Pool Selection tab.

Step 4 Click Selection.

The Resource Selection dialog box appears.

Step 5 Click a resource pool or group of resource pools then click the > button to move the resources from the 
Available area to the Selected area.

Tip Click a resource to display additional information about it.

Step 6 Click OK.

Related Topics

• Understanding Service Network Design, page 13-2

• Creating and Modifying Service Networks, page 13-8

• Pool Selection Tab, page 13-22

Adding NAS Storage

You can add NAS storage to your service network.

Procedure

Step 1 Choose Design > Service Networks. 

Step 2 Open a service network and click a NAS Storage logical element.

The NAS Storage tab opens.

Step 3 Do any of the following:

• Enter a description of a storage group in Description.

• Click New.

The New NAS Storage Group dialog box appears. Use the various elements to define a new storage 
group.

• Click Edit.

The Edit NAS Storage Group dialog box appears. Use the various elements to edit an existing 
storage group.
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• Click Delete to delete a NAS storage group.

Related Topics

• Understanding Service Network Design, page 13-2

• Creating and Modifying Service Networks, page 13-8

• Block Variables Tab, page 13-21

Adding SAN Storage

You can add SAN storage to your service network.

Step 1 Choose Design > Service Networks.

Step 2 Open a service network and click the SAN Storage logical element.

The Settings tab opens.

Step 3 Do any of the following:

• Enter a description of a storage group in Description.

• Click New.

The New SAN Storage Group dialog box appears. Use the various elements to define a new storage 
group.

• Click Edit.

The Edit SAN Storage Group dialog box appears. Use the various elements to edit an existing 
storage group.

• Click Delete to delete a SAN storage group.

Note You can add or remove resources in a LUN group at any time.

Configuring Settings

You can configure server group and To_VLAN settings for your service network.

Procedure

Step 1 Choose View > Service Networks.

Step 2 Open a service network and click a ServerGroup or To_VLAN logical element.

The Settings tab opens.

Step 3 For each setting, click the appropriate value into the variable drop-down list.

Related Topics

• Understanding Service Network Design, page 13-2
13-12
Cisco VFrame Data Center Administration Guide

OL-15450-01



 

Chapter 13      Designing Service Networks
Working with Service Networks
• Creating and Modifying Service Networks, page 13-8

• Block Variables Tab, page 13-21

Defining Teaming Parameters

Teaming mode is enabled if you designate more than one Ethernet link for your server group. When 
teaming mode is enabled, you can define teaming parameters. This section describes how to define 
teaming parameters for a server group, and includes the following topics:

• Defining Teaming Parameters For a Linux or Windows Server Group, page 13-13

• Defining Teaming Parameters For An ESX Server Group, page 13-14

Defining Teaming Parameters For a Linux or Windows Server Group

When you designate more than one Ethernet link for your Linux or Windows server group, you can 
define teaming parameters it.

Before You Begin

You can only define teaming parameters after teaming mode has been enabled for your server group. To 
enable teaming mode, choose Design > Service Networks, open a service network, click the To_VLAN 
logical element, click the Settings tab, and from the Ethernet Links drop-down list choose a value of 2, 
3, or 4.

Procedure

Step 1 Choose Design > Service Networks. 

Step 2 Open a service network and click a To_VLAN logical element. The Settings tab opens by default.

Step 3 Click the Teaming tab.

Step 4 On the Teaming tab, do any of the following:

• From the Teaming Mode drop-down list, choose one of the following teaming modes:

– Active Backup

– Balance TLB

– 802.3ad Dynamic

• Check the Switch HA Required check box.

• Check the Enable NIC HA Required check box.

Note If NIC HA is enabled, the acquired server Ethernet ports must be on separate NIC cards.

• Add or edit the value of a parameter:

– Click a parameter in the Parameter Name field.

– Click Add to add a parameter or click Edit to edit a parameter.

• Click Remove to delete a parameter.
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Note Only user-defined entries can be deleted.

Related Topics

• Understanding Service Network Design, page 13-2

• Creating and Modifying Service Networks, page 13-8

• Teaming Tab, page 13-29

Defining Teaming Parameters For An ESX Server Group

When you designate more than one Ethernet link for your ESX server group, you can define teaming 
parameters it.

Before You Begin

You can only define teaming parameters after teaming mode has been enabled for your server group. To 
enable teaming mode, choose Design > Service Networks, open a service network, click the To_VLAN 
logical element, click the Settings tab, and from the Ethernet Links drop-down list choose a value of 2, 
3, or 4.

Procedure

Step 1 Choose Design > Service Networks. 

Step 2 Open a service network and click a vSwitch logical element. The Settings tab opens by default.

Step 3 Click the Teaming tab.

Step 4 On the Teaming tab, do any of the following:

• From the Teaming Mode drop-down list, choose one of the following teaming modes:

– Active Backup

– N Active Links

– 802.3ad Static

• Check the Switch HA Required check box.

• Check the Enable Switch HA check box.

Note If switch HA is enabled, the acquired server ports must be connected to different Layer 2 
switches.

• Check the Notify Switches check box

• Check the Check Beacon check box.

• Check the Rolling Failover check box.

• Check the Error Percent check box and specify a percent value.

Related Topics

• Understanding Service Network Design, page 13-2
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• Creating and Modifying Service Networks, page 13-8

• Teaming Tab, page 13-29

Defining Port Groups

Step 1 Choose Design > Service Networks. 

Step 2 Open a service network and click a port group logical element.

The Settings tab opens.

Step 3 Do any of the following on the Settings tab:

• Configure security in the Security area.

• Configure Quality of Service in the QoS area.

• Expand the server group by right-clicking it and then clicking Expand Block.

Step 4 Click the VMKernel port group.

Step 5 Click Port Variables.

Step 6 Check the Server VMotion Enabled check box if you want to enable VMotion on this interface.

Related Topics

• Understanding Service Network Design, page 13-2

• Creating and Modifying Service Networks, page 13-8

• Block Variables Tab, page 13-21

Saving Service Networks
You can save your service network template when you are done making changes, and open it again later 
to make additional changes.

Before You Begin

Provide values and definitions for the required fields. Red X icons appear next to each required tab and 
parameter. As you define these required parameters, these icons disappear. When all red icons have 
disappeared, your service network is ready to be deployed.

Procedure

Step 1 Choose View > Service Networks.

Step 2 On the Service Networks tab, create a new or open an existing service network (see Creating and 
Modifying Service Networks, page 13-8). 

Step 3 Click Save.
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Related Topics

• Understanding Service Network Design, page 13-2

• Service Networks Tab, page 13-16

Displaying Summary Information for Service Networks
You can display a summary of the network elements and their current configuration settings.

Procedure

Step 1 Choose View > Service Networks.

Step 2 On the Service Networks tab, create a new or open an existing service network (see Creating and 
Modifying Service Networks, page 13-8).

Step 3 Right-click the service network.

Step 4 Click Details.

The Service Network Summary dialog box appears.

Related Topics

• Understanding Service Network Design, page 13-2

• Service Networks Tab, page 13-16

Service Networks Reference
This section describes the tabs and dialog boxes you use when managing service networks, and includes 
the following topics:

• Service Networks Tab, page 13-16

• Network Settings Tab, page 13-20

• Block Variables Tab, page 13-21

• Port Variables Tab, page 13-21

• Pool Selection Tab, page 13-22

• NAS Tab, page 13-22

• Settings Tab, page 13-26

• Teaming Tab, page 13-29

Service Networks Tab
Use the Service Networks tab to create service networks.

How to Get to This Tab

Choose View > Service Networks to open the Service Networks tab.
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Related Topics

• Understanding Service Network Design, page 13-2

• Working with Service Networks, page 13-8

Field Reference

Table 13-2 Service Networks Tab

Element Description

Buttons

New button Click this button to create a new service network.

Open button Click this button to open a service network.

Save button Click this button to save changes made to the selected service network.

Delete button Click this button to delete the selected service network.

Details button Click this button to list the service network elements and their configuration 
settings.

Selectors

Service Networks 
selector

Lists the service network templates and service networks that have been 
created. Click a service network to open the element selector, the service 
network map tab, and the Network Settings tab.

Elements selector Lists elements such as Firewall Services Modules, switches, load balancers, 
and links that have been assigned to the selected service network.
13-17
Cisco VFrame Data Center Administration Guide

OL-15450-01



 

Chapter 13      Designing Service Networks
Service Networks Reference
Service Networks Work Area—Displays the service network map.

Tools Click a button to perform the appropriate action:

• Pan button—Click this button to move the viewable area of the template. 
Click Pan and then click and hold the left mouse button and drag the 
image to the desired position.

• Select button—Click Select to choose the template or an item (element 
or link) within the template. 

Click Select and then right-click the template topology work area to 
choose the template or the desired item. To select multiple items within 
a template, right-click the item then hold down the Shift key while 
right-clicking additional items.

• Select the template or an element within the template to display its 
corresponding information in the tabs below. Select multiple elements to 
display corresponding information for the last element selected. No 
information is provided for links.

• Zoom In Rect button—Click this button to zoom in on a selected area. 

Click Zoom In Rect and then click and hold the left mouse button and 
drag it. A rectangle forms. Select the items you want to zoom in on. 
Release the left mouse button. The view zooms into the area contained 
by the rectangle.

• Zoom In button—Click this button to increase the size of the items 
displayed.

• Zoom Out button—Click this button to decrease the size of the items 
displayed.

• Fit to View button—Click this button to resize all items and display them 
them within the viewable work area.

Table 13-2 Service Networks Tab (continued)

Element Description
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• Page Setup button—Click this button to set up the template topology 
work area for printing.

Use the Page Layout tab to set up the page layout:

– Orientation—Use the Orientation area to set the orientation of the 
printed page.

Check either the Portrait or Landscape check box.

– Margins—Use the Margins area to set the margins for the printed 
page.

Enter in inches the left, right, top and bottom margins.

– Paper—Use the Paper area to set the size of the printed page.

Click either Letter, Legal, Invoice, Executive, A0 (ISO/DIN & 
JIS), A1 (ISO/DIN & JIS), A2 (ISO/DIN & JIS), or A3 (ISO/DIN 
& JIS).

Use the Header/Footer tab to create custom headers and footers:

– Header—Your custom header will appear in this area once it is 
created.

– Custom Header—Click Custom Header to create a custom header. 
The Header dialog box appears. Use the Font, Page, Pages, Time, 
Date and File tools to create a custom header. When you click the 
Font tool, the Font dialog box appears. Use it to set the appropriate 
font. Use the Right Section, Center Section and Left Section areas 
to manually edit your header.

– Footer—Your custom footer will appear in this area once it is 
created.

– Custom Footer—Click Custom Footer to create a custom footer. 
The Footer dialog box appears. Use the Font, Page, Pages, Time, 
Date and File tools to create a custom footer. When you click the 
Font tool, the Font dialog box appears. Use it to set the appropriate 
font. Use the Right Section, Center Section and Left Section areas 
to manually edit your footer.

Use the Sheet tab to set the network map paging parameters:

– Area—Click Full Area or use the Left, Top, Right and Bottom fields 
to manually set the area.

– Scaling—Use the Fit To fields to set the scaling of the network map.

– Page Order—Click Down, Then Over or Over, Then Down to 
specify the page order.

• Print—Click this button to print the template topology work area.

Table 13-2 Service Networks Tab (continued)

Element Description
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Network Settings Tab
Use the Network Variables tab to enable or disable the root bridge setting on your service network.

How to Get to This Tab

Choose View > Service Networks, and create a new service network or open an existing service 
network.

Related Topics

• Understanding Service Network Design, page 13-2

• Working with Service Networks, page 13-8

Parameters— Define parameters for the service network or selected element.

Element Click a service network in the Elements selector, and then click the desired 
tab to open and define parameters:

Note You cannot select endpoints in the work area. Attempting to select 
the endpoints in the work area selects the link and displays template 
information, not link or end-point information.

• Network Settings tab—Enables you to enable or disable the root bridge 
setting.

• Block Variables tab—Enables you to define the variable values of 
devices within your service network. For detailed reference information, 
see Block Variables Tab, page 13-21.

• Pool Selection tab—Enables you to select resources that will be 
available to your service network when it is deployed. For detailed 
reference information, see Pool Selection Tab, page 13-22.

• Port Variables tab—Enables you to define the variable values of 
endpoints within your service network. For detailed reference 
information, see Port Variables Tab, page 13-21.

• NAS Storage tab—Enables you to add NAS storage to your network. For 
detailed reference information, see NAS Tab, page 13-22.

• Settings tab—Enables you add SAN storage to your network, and 
configure server group settings. For detailed reference information, see 
Settings Tab, page 13-26.

• Teaming tab—Enables you to configure teaming modes. For detailed 
reference information, see Teaming Tab, page 13-29.

Table 13-2 Service Networks Tab (continued)

Element Description
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Field Reference

Block Variables Tab
Certain logical elements have system actions associated with them. These system actions might include 
default variables. In addition, the template designer might have included additional user macros with 
their own set of variables.

Use this tab to define the values for these variables as they pertain to the devices within your service 
network.

How to Get to This Tab

On the Service Networks tab, open a service network and click a logical element. If applicable, the Block 
Variables tab opens.

Related Topics

• Service Networks Tab, page 13-16

• Understanding Service Network Design, page 13-2

Field Reference

The variable value is a blank field. For each variable, click or enter the appropriate value into the variable 
value field that corresponds to your service network design.

For details about the default variables associated with each logical element, see Appendix A, “System 
Actions, Default Variables, and Resource Attribute Variables.”

Port Variables Tab
Certain logical elements have default system actions associated with them. These system actions might 
include default variables. In addition, the template designer might have included additional user macros 
with their own set of variables.

Use this tab to define the values for these variables as they pertain to endpoints within your service 
network.

How to Get to This Tab

On the Service Networks tab, open a service network and click an endpoint. If applicable, the Port 
Variables tab opens.

Table 13-3 Network Variables Tab

Element Description

Enable Root Bridge 
Setting

Check this check box for VFrame to configure the root bridge setting for all 
Layer 2 switches in your service network. If the check box is checked, 
VFrame configures a switch to become the root for the specified VLAN.

Service Network 
Description

See a features list for the service network in this drop-down list.
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Related Topics

• Service Networks Tab, page 13-16

• Understanding Service Network Design, page 13-2

Field Reference

The variable value is a blank field. For each variable, click the appropriate value in the variable value 
field that corresponds to your service network design.

For details about the default variables associated with each logical element, see Appendix A, “System 
Actions, Default Variables, and Resource Attribute Variables.”

Pool Selection Tab
Use this tab to choose the resources you want to be available to your service network when it is deployed.

How to Get to This Tab

On the Service Networks tab, open a service network and click a logical element. If applicable, the Pool 
Selection tab opens, or click Pool Selection.

Related Topics

• Service Networks Tab, page 13-16

• Understanding Service Network Design, page 13-2

Field Reference

NAS Tab
Use this tab to add NAS storage to your network.

Table 13-4 Pool Selection Tab

Element Description

Select button Click Select to choose servers for your pool. When you click the button, the 
Resource Selection dialog box appears.

Resource Selection 
dialog box

Use the Resource Selection dialog box to choose servers for your pool:

• Available area—This is an area for the Admin Context: All Servers 
drop-down list.

• Admin Context: All Servers list—This is a drop-down list of all the 
available servers.

• Double arrows button (left and right)—Click these buttons to move all 
the servers left or right.

• Single arrows button (left and right)—Click this button to move a server 
left or right.

• Selected area—This is an area for all the servers chosen for the pool.
13-22
Cisco VFrame Data Center Administration Guide

OL-15450-01



 

Chapter 13      Designing Service Networks
Service Networks Reference
How to Get to This Tab

On the Service Networks tab, open a service network and click the NAS logical element. The NAS tab 
opens.

Related Topics

• Service Networks Tab, page 13-16

• Understanding Service Network Design, page 13-2

Field Reference

Table 13-5 NAS Tab

Element Description

Description Enter a description of the storage group.

Storage Groups This area contains the following fields that are automatically filled when you 
add or edit a NAS storage group:

• Name—The name of the NAS storage group.

• Type—The storage type.

• Mode—The storage mode.

• Storage Type—The storage protocol type.

• Part/Server—The initial partitions per server.

• Description—The description of the NAS storage group.
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Add Click this button to add NAS storage. When you click this button, the New 
NAS Storage Group dialog box appears:

• Type—Click either Shared or Additional.

• Mode—Click either Create Storage or Use Existing Storage.

• Group Name—Enter the name of the NAS storage group.

• Description—Enter a description of the NAS storage group.

• Volumes—This area shows the volume type chosen.

• Select—Click Select to choose a volume type.

When you click Select the Select Volumes dialog box appears:

– Available area—This is an area for the Admin Context: All Servers 
drop-down list.

– Admin Context: All Servers list—This is a drop-down list of all the 
available servers.

– Double arrows button (left and right)—Click these buttons to move 
all the servers left or right.

– Single arrows button (left and right)—Click this button to move a 
server left or right.

– Selected area—This is an area for all the servers chosen for the pool.

• Mount Interfaces—Use the Mount Interfaces area to choose interfaces:

– For a standard operating system service network, check the 
To_VLAN check box to choose an interface.

– For an ESX operating system, check the IP_0 or IP_1 check box to 
choose an interface.

• Permissions—Use this area to set permissions:

– Root—Check the Root check box to set the permissions to Root.

– Read Only—Check the Read Only check box to set the permissions 
to Read Only.

– Read/Write—Check the Read/Write check box to set the 
permissions to Read/Write.

• Protocol—Click either NFS or CIFS.

• Init/Partitions Server—Enter the number of partitions.

• Max Size/Partition—Click the maximum size of the partition. The 
default is Unlimited.

• Max Files/Partition—Click the maximum number of files per partition. 
The default is Unlimited.

Table 13-5 NAS Tab (continued)

Element Description
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Edit Click this button to edit existing NAS storage. When you click this button, 
the Edit NAS Storage Group dialog box appears:

• Description—Enter a description of the NAS storage group.

• Volumes—This area shows the volume type chosen.

• Select—Click Select to choose a volume type.

When you click Select, the Select Volumes dialog box appears:

– Available area—This is an area for the Admin Context: All Servers 
drop-down list.

– Admin Context: All Servers list—This is a drop-down list of all the 
available servers.

– Double arrows button (left and right)—Click these buttons to move 
all the servers left or right.

– Single arrows button (left and right)—Click this button to move a 
server left or right.

– Selected area—This is an area that displays all the servers chosen 
for the pool.

• Mount Interfaces—Use the Mount Interfaces area to choose interfaces:

– For a standard operating system service network, check the 
To_VLAN check box to choose an interface.

– For an ESX operating system, check the IP_0 or IP_1 check box to 
choose an interface.

• Permissions—Use this area to set permissions:

– Root—Check the Root check box to set the permissions to Root.

– Read Only—Check the Read Only check box to set the permissions 
to Read Only.

– Read/Write—Check the Read/Write box to set the permissions to 
Read/Write.

• Protocol—Click either NFS or CIFS.

• Init/Partitions Server—Enter the number of partitions.

• Max Size/Partition—Click the maximum size of the partition. The 
default is Unlimited.

• Max Files/Partition—Click the maximum number of files per partition. 
The default is Unlimited.

Delete Click this button to delete a storage group.

Table 13-5 NAS Tab (continued)

Element Description
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Settings Tab
Use this tab to configure SAN and server group settings.

How to Get to This Tab

On the Service Networks tab, open a service network and click either the SAN Fabric, SAN Storage, 
Server Group, To_VLAN or Virtual Switch logical elements. The Settings tab opens.

Related Topics

• Service Networks Tab, page 13-16

• Understanding Service Network Design, page 13-2

Field Reference

Table 13-6 Settings Tab

Element Description
Settings Tab for SAN Fabric

Description Enter a description of the SAN fabric.

SAN Mode Click a SAN mode. The default is VFrame Configured and is the only choice.

Fabric 1 VSAN Choose a fabric from the VSAN Selection drop-down list.

Fabric 2 VSAN Choose a second fabric from the VSAN Selection drop-down list.

Settings Tab for SAN Storage

Description Enter a description of the SAN storage.

Storage Groups This area contains the following fields that are automatically filled when you 
add or edit SAN storage:

• Name—The name of the storage.

• Type—The type of storage.

• LUN/Server—The number of LUNs or servers.

• Description—The description of the storage.
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Add button Click this button to add a SAN storage group. When you click this button, 
the New SAN Storage Group dialog box appears:

• Type—Click either Additional or Shared.

• Group Name—Enter a group name.

• Description—Enter a description of the storage group.

• Initial LUNs/Server—Enter the number of initial LUNs or servers.

• LUNs—This area shows the LUNs chosen.

• Fabric 1 Array Ports—This area shows the Fabric 1 ports chosen.

• Fabric 2 Array Ports—This area shows the Fabric 2 ports chosen.

• Select—Click this button to choose LUNs, Fabric Array 1 Ports, or 
Fabric Array 2 Ports.

When you click Select, the Select LUNs, Select Array Ports Fabric 1, or 
the Select Array Ports Fabric 2 dialog box appears:

– Available area—This is an area for the Admin Context: All Storage 
LUN drop-down list or the Admin Context: All Storage Port 
drop-down list.

Admin Context: All Storage LUN list—This is a drop-down list of 
all the available LUNs.

Admin Context: All Storage Port list—This is a drop-down list of 
all the available ports.

– Double arrows button (left and right)—Click these buttons to move 
all the LUNs or ports left or right.

– Single arrows button (left and right)—Click this button to move a 
LUN or port left or right.

– Selected area—This is an area that displays all the LUNs or ports 
chosen for the SAN storage group.

Table 13-6 Settings Tab (continued)

Element Description
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Edit button Click this button to edit a SAN storage group. When you click this button, 
the Edit SAN Storage Group dialog box appears:

• Description—Enter a description of the storage group.

• Initial LUNs/Server—Enter the number of initial LUNs or servers.

• LUNs—This area shows the LUNs chosen.

• Fabric 1 Array Ports—This area shows the Fabric 1 ports chosen.

• Fabric 2 Array Ports—This area shows the Fabric 2 ports chosen.

• Select—Click Select to choose LUNs, Fabric Array 1 Ports, or Fabric 
Array 2 Ports.

When you click Select, the Select LUNs, Select Array Ports Fabric 1, or 
the Select Array Ports Fabric 2 dialog box appears:

– Available area—This is an area for the Admin Context: All Storage 
LUN drop-down list or the Admin Context: All Storage Port 
drop-down list.

Admin Context: All Storage LUN list—This is a drop-down list of 
all the available LUNs.

Admin Context: All Storage Port list—This is a drop-down list of 
all the available ports.

– Double arrows button (left and right)—Click these buttons to move 
all the LUNs or ports left or right.

– Single arrows button (left and right)—Click this button to move a 
LUN or port left or right.

– Selected area—This is an area that displays all the LUNs or ports 
chosen for the SAN storage group.

Delete button Click this button to delete storage.

Settings Tab for Server Group

Description Enter a description of the server group.

Image Click a Linux, Windows or ESX image.

Sysprep File Click a sysprep file.

Service Console 
Routing Table

Click this button to add, edit or delete service console routes.

VMKernel Routing 
Table

Click this button to add, edit or delete VM kernel routes.

Settings Tab for To_VLAN (Server Group connection to a Layer 2 switch)

Description Enter a description of the connection.

Ethernet Links Click a value from 1 to 4.

Minimum Interface 
Speed

Click a value, either 100, 1000, or 10000.

On PXE Boot Interface Check the On PXE Boot Interface check box to boot on the PXE interface.

Table 13-6 Settings Tab (continued)

Element Description
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Teaming Tab
Use this tab to configure teaming modes (grouping adapters together).

How to Get to This Tab

On the Service Networks tab, open a service network and click the To_VLAN logical element. From the 
Ethernet Links drop-down list, click 2, 3 or 4, and then click the Teaming tab.

Related Topics

• Service Networks Tab, page 13-16

• Understanding Service Network Design, page 13-2

Enable Port Fast on 
Switchport

Check this check box to enable Port Fast on Switch Port.

Settings Tab for vSwitch (ESX service network)

Description Enter a description of the connection.

Ethernet Links Click a value from 1 to 4.

Minimum Interface 
Speed

Click a value, either 100, 1000, or 10000.

On PXE Boot Interface Check this check box to boot on the PXE interface.

Enable Port Fast on 
Switchport

Check this check box to enable Port Fast on Switch Port.

Virtual Switch This is an area where you can configure a virtual switch:

• Number of Ports—Click the number of ports for the virtual switch.

• Security—This is an area where you can set the security profile for the 
ports on the virtual switch:

– Allow Promiscuous Mode—Check this check box to set the virtual 
switch to pass all traffic it receives.

– Allow MAC Address Changes—Check this check box to protect 
against MAC impersonation.

– Allow Forged Transmits—Check this check box to protect against 
MAC impersonation.

• QoS—This ia an area where you can set up Quality of Service:

– Enable Traffic Shaping—Check this check box to enable the QoS 
options.

– Average Bandwidth—Click an appropriate value.

– Peak Bandwidth—Click an appropriate value.

– Burst Size—Click an appropriate value.

Table 13-6 Settings Tab (continued)

Element Description
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Field Reference

Table 13-7 Teaming Tab

Element Description

Teaming Mode From the Teaming Mode drop-down list, choose one of the following 
teaming modes:

• Active Backup—Provides link backup. The backup link becomes active 
only when the first active link fails.

• Balance TLB—Transmit load balancing. Outgoing traffic is load 
balanced across the links. This mode is available only for Linux or 
Windows server groups.

• 802.3ad Dynamic (Linux or Windows only)—Creates one or more teams 
using dynamic link aggregation. This mode is available only for Linux 
or Windows server groups.

• N Active Links (ESX only)—Creates a team with multiple, 
non-aggregated links. This mode is available only for ESX server 
groups.

• 802.3ad Static (ESX only)—Creates a single team using static link 
aggregation. This mode is available only for ESX server groups.

Switch HA Required Check this check box to require that the acquired server Ethernet ports must 
be connected to different layer 2 switches.

Enable NIC HA 
Required

Check this check box to require that the acquired server Ethernet ports must 
be on separate NICs.

Add Click this button to add teaming parameters. When you click this button, the 
New Teaming Parameter Entry dialog box appears:

• Parameter Name—Enter the name of the parameter.

• Value—Enter the value of the parameter.

This button is available only for Linux and Windows server groups.

Remove Click this button to delete a teaming parameter entry. This button is available 
only for Linux and Windows server groups.
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Edit Click this button to add teaming parameters. When you click this button, the 
Modify Teaming Parameter Entry dialog box appears:

• Parameter Name—Enter the name of the parameter.

• Value—Enter the value of the parameter.

This button is available only for Linux and Windows server groups.

NIC Teaming Properties 
group

Check any of the following check boxes:

• Notify Switches—If a failover event occurs, notification is sent to 
update the lookup tables on physical switches.

• Check Beacon—Checks for beacon probes to detect upstream link 
failures.

• Rolling Failover—Leaves a failed link in an inactive state even after 
recovery until another currently active links fails.

• Check Error Percent—Determines that a link failure occurs when the 
error percentage exceeds the value that you specify.

The NIC Teaming Properties group is available only for ESX server groups.

Table 13-7 Teaming Tab (continued)

Element Description
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