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Managing Golden Images

Golden images are the combination of operating system and application software that you will deploy 
on application servers when you create service networks. They are the core of your services.

There are two steps to golden image management: the creation and management of a repository of golden 
images, and the actual use of the images. For information on using these images, see Designing Service 
Networks, page 13-1. 

This chapter describes how to create a repository of golden images, and includes the following sections:

• Understanding Golden Image Management, page 8-1

• Installing the VHA on Model Servers, page 8-5

• Working with Golden Images, page 8-9

• Troubleshooting Golden Image Management, page 8-21

• Golden Image Management Reference, page 8-21

Understanding Golden Image Management
This section explains what golden images are and how you manage them in VFrame, and includes the 
following topics:

• Understanding Model Servers and Golden Images, page 8-1

• Understanding Golden Image Variables, page 8-2

• Understanding Sysprep Requirements for Windows Images, page 8-3

• Understanding the Golden Image Repository, page 8-3

Understanding Model Servers and Golden Images
The main purpose of VFrame is to help you create service-based networks. These networks run the 
specific applications that you need to deploy to your user community. Because applications run on 
servers, deploying a service network is in part getting the right applications loaded onto the servers in 
the network.

Golden images are the way that you deploy applications onto the servers in a service network. A golden 
image is simply a collection of operating system software and applications configured to run on specific 
server hardware. You need to create golden images for each unique collection of operating system, 
software application, and server hardware feature set that you will use in each of your service networks.
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In general, this is the process you use to create a new golden image:

1. Choose a server that you will use as a model server. This server should have the same hardware 
features as the application servers that you will use in the service network, or they should at least be 
compatible with them. Otherwise, your application servers might not be able to run the golden image 
created from the model server, or not run it well. As you replace application servers with servers that 
have different hardware features, you need to periodically create a new model server to create a new 
golden image.

2. Install all desired operating system and application software on the model server, and configure it 
as required. The model server should function exactly as you expect your servers to function.

3. Install the VFDC Host Agent (VHA) on the model server and start it so that VFrame becomes aware 
of the model server. For detailed information, see Installing the VHA on Model Servers, page 8-5.

4. Using VFrame, copy the image from the model server into the golden image repository. For detailed 
information, see Creating a Golden Image, page 8-10.

After a golden image has been assigned and used in a server group, you may need to update it with the 
latest application patches or make other modifications and then use the updated image for deployment. 
To allow you to change the golden image assigned to a running server group, VFrame supports the notion 
of golden image versions organized in a version hierarchy, where the image at the top is the parent image 
and all others below are the child images. With multiple golden image versions, you can dynamically 
change the golden being used by a running server group from one version to another. When changing the 
golden image version, you can only select a version from within the same version hierarchy; you cannot 
select a version from a different hierarchy.

You can also import golden images that were created by a different VFrame system, or export golden 
images that you create. Using export and import, you can share golden images among VFrame systems, 
thus standardizing server deployments within your organization. For more information, see Exporting a 
Golden Image, page 8-13 and Importing a Golden Image, page 8-14.

You cannot use golden images that you created using other programs.

Related Topics

• Understanding Golden Image Variables, page 8-2

• Understanding Sysprep Requirements for Windows Images, page 8-3

• Understanding the Golden Image Repository, page 8-3

• Installing the VHA on Model Servers, page 8-5

• Working with Golden Images, page 8-9

Understanding Golden Image Variables
After you create or import a golden image, you can optionally define variables for it. These variables are 
values users can set when they select the golden image for a server group in a service network.

VFrame does not use golden image variables for processing. Instead, they are written to a file on the 
server, and you can write scripts to process the file during server bootup and perform various actions 
based on the variable settings. The variables allow you to customize how an golden image is used by 
various service networks.

The interface for creating golden image variables shares the same dialog boxes that are used for creating 
variables in the global libraries. However, you cannot assign variables from the global library to golden 
images. All variables defined for a golden image are unique to that golden image and all its versions.
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When you select the golden image in the Golden Images dialog box (Tools > Golden Images), you can 
create and edit variables for the selected golden image. In addition, you can also view and change the 
attributes for individual servers before they are imaged. From the Operations tab (View > Operations), 
right-click the server and click Server Details.

When you create an application server using the golden image, the variables are written to a file on that 
server. Your scripts must process the file during system boot to use the variables. Depending on the 
operating system used, the file is written to one of the following locations:

• Linux and ESX servers—The parameter file is /opt/cisco_vfdc/conf/parameter_file.

• Windows servers—The parameter file is C:\Vframe_Cisco_Systems\parameter_file.

Related Topics

• Working with Golden Image Variables, page 8-16

Understanding Sysprep Requirements for Windows Images
Windows 2003 servers require the use of the System Preparation tool (sysprep.exe) to reliably allow the 
creation of golden images. This tool is part of the Windows 2003 package from Microsoft, and there 
might be updates to the tool on the support.microsoft.com website.

Read the Microsoft documentation for creating sysprep.inf answer files and for using the sysprep.exe 
program to prepare a Windows model server for golden image creation. VFrame relies on your proper 
use of these tools.

After you create a Windows golden image in VFrame, you must add at least one sysprep.inf answer file 
to it before you can deploy the image to a server.

Related Topics

• Creating a Golden Image, page 8-10

• Importing a Golden Image, page 8-14

• Working with Sysprep Files, page 8-17

Understanding the Golden Image Repository
When you create or import a golden image, you are creating a file in the VFrame golden image 
repository. The repository is an area of disk space and can be any of the following types:

• Local—The repository is on the hard disk drive of the VFrame Data Center Director.

• SAN or LUN—The repository is on a logical unit in a storage array.

• NFS or Volume—The repository is on a volume in a NAS filer.

You can determine the repository type by clicking Repository Properties in the Golden Images dialog 
box (choose Tools > Golden Images). If you need to migrate the repository to a different location (for 
example, if you start running out of space), see Migrating the Golden Image Repository, page 18-10.

The repository is organized hierarchically in folders like any other file system, as shown in Figure 8-1.
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Figure 8-1 Golden Image Repository Folder Structure

The following are some key things to understand when organizing and using the repository:

• At the top of the hierarchy is a folder named for each virtual context defined in VFrame. You cannot 
delete the context folders. Consider creating golden images in the context folder that corresponds to 
the virtual context for the service networks that will use the golden image.

• You can create any number of subfolders within a hierarchy to create the logical organization you 
require.

• Within each folder, you can have a single standalone golden image, or you can have a hierarchy of 
multiple golden image versions. The image at the top of the hierarchy is the parent image and all 
others below are the child images, all of which belong to the same golden image version hierarchy.

• When you select an image in the Golden Images selector (in the Golden Images dialog box), the 
properties related to that image appear on the tabs in the right pane.

• You cannot copy golden images from one folder to another folder. If you need to copy an image, you 
must first export it, then import it into the desired folder.

• You cannot delete the root parent image in a version hierarchy if it has children. Child images can 
be deleted regardless of whether they have their own children; if a child image is deleted the 
grandchildren are adopted by their grandparent.

Related Topics

• Understanding Model Servers and Golden Images, page 8-1

• Viewing the Golden Image Repository Setup, page 8-9

• Creating a Folder in the Golden Image Repository, page 8-10
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Installing the VHA on Model Servers
You must install the VHA, also known as the migration agent, on model servers. The VHA collects the 
model server properties and contacts VFrame with the information, making it possible for you to create 
a golden image from the model server. There are different VHAs depending on the operating system that 
is running on the server. This section describes the installation steps, and includes the following topics:

• Installing the VHA on ESX Servers, page 8-5

• Installing the VHA on Linux Servers, page 8-6

• Installing the VHA on Windows Servers, page 8-8

Installing the VHA on ESX Servers
Before you can create a golden image from a model server that is running VMware ESX, you must install 
the ESX version of the VHA, vha-esx.i386.rpm.

Before You Begin

• Set up the model server (see Setting Up Model Servers, page 3-16).

• Verify that a DHCP range is configured for the subnet or VLAN where the model server is 
connected, and that VFrame is configured to respond to DHCP requests from the subnet. For more 
information about setting up DHCP, see Configuring DHCP Relay Agents in Ethernet Switches, 
page 5-2 and Configuring DHCP in VFrame, page 5-4.

• Verify that the model server can be PXE booted.

Procedure

Step 1 Log in to VFrame and use a file transfer program, such as SCP, to download the VHA package to the 
ESX model server using the model server IP address or DNS name. For example, if the model server IP 
address is 10.100.30.10, and using the admin user account, enter the following command to download 
the VHA package to the model server:

scp /tftpboot/vha-esx.i386.rpm admin@10.100.30.10:/tmp

Step 2 Use an SSH client to log in to the model server using a non-root user account.

Note Do not use the root user account to log in to the model server because ESX blocks root access 
through SSH.

Step 3 Enter the su command to gain root access.

Step 4 From the model server ESX service console command line, change directories to the one where you 
downloaded the VHA package and install it using the following command (if the name of the file you 
downloaded is different from the one in the example, use your filename):

rpm -i --nodeps vha-esx.i386.rpm 
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Note Ensure that you install the VHA from the ESX service console and not from inside a virtual 
machine.

To uninstall the VHA, use the rpm --erase vha-esx command.

Step 5 Change to the vha directory by entering the following command:

cd /opt/cisco_vfdc/bin/

Step 6 Run the VHA by entering the following command:

./vha {VFrame_IP_address | VFrame_host_name} 

where you enter one of the following:

• VFrame_IP_address is the IP address of VFrame server communication interface.

• VFrame_host_name is the DNS host name for that IP address.

For example, enter ./vha 10.100.30.10 if VFrame IP address is 10.100.30.10.

After the VHA runs successfully, VFrame obtains the model server information and displays the model 
server in the following two locations:

• Resources tab, in the Device selector under Model Servers.

• New Golden Image dialog box.

You can now create a golden image from the model server. For more information, see Creating a Golden 
Image, page 8-10.

Related Topics

• Understanding Model Servers and Golden Images, page 8-1

• Setting Up Application Servers, page 3-15

• Configuring Server Credentials, page 4-11

Installing the VHA on Linux Servers
Before you can create a golden image from a model server that is running the Linux operating system, 
you must install the Linux version of the VHA, vha-lnx.i386.rpm.

Before You Begin

• Set up the model server (see Setting Up Model Servers, page 3-16).

• Verify that a DHCP range is configured for the subnet or VLAN where the model server is 
connected, and that VFrame is configured to respond to DHCP requests from the subnet. For more 
information about setting up DHCP, see Configuring DHCP Relay Agents in Ethernet Switches, 
page 5-2 and Configuring DHCP in VFrame, page 5-4.

• Verify that the model server can be PXE booted.
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Procedure

Step 1 Use one of the following methods to download the VHA to the model server:

• From the model server, use a web browser to connect to the VFrame home page. For example, if the 
DNS name of the VFrame system is vframe.example.com, open the http://vframe.example.com 
URL. Click the link to download the VHA package, and then click the link for the Linux VHA. 
Download the VHA to the server.

• Log in to VFrame and use a file transfer program, such as SCP, to download the VHA package to 
the ESX model server using the model server IP address or DNS name. For example, if the model 
server IP address is 10.100.30.10, and using the admin user account, enter the following command 
to download the VHA package to the model server:

scp /tftpboot/vha-lnx.i386.rpm admin@10.100.30.10:/tmp

Step 2 Use an SSH client to log in to the model server.

Step 3 From the model server command line, change directories to the one where you downloaded the VHA and 
install it using the following command (if the name of the file you downloaded is different from the one 
in the example, use your filename):

rpm -i --nodeps vha-lnx.i386.rpm 

Note To uninstall the VHA, use the rpm --erase vha-lnx command.

Step 4 Change to the vha directory by entering the following command:

cd /opt/cisco_vfdc/bin/

Step 5 Prepare the model server for creating a golden image by entering the following command:

./vfdc-linux-osprep --prepare-os

Note For more information about preparing the model server, see the 
/opt/cisco_vfdc/VHA_Readme.txt file that is installed as part of the VHA.

Step 6 Run the VHA by entering the following command:

./vha {VFrame_IP_address | VFrame_host_name} 

where you enter one of the following:

• VFrame_IP_address is the IP address of VFrame server communication interface.

• VFrame_host_name is the DNS host name for that IP address.

For example, enter ./vha 10.100.30.10 if VFrame IP address is 10.100.30.10.

After the VHA runs successfully, VFrame obtains the model server information and displays the model 
server in the following two locations:

• Resources tab, in the Device selector under Model Servers.

• New Golden Image dialog box.

You can now create a golden image from the model server. For more information, see Creating a Golden 
Image, page 8-10.
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Related Topics

• Understanding Model Servers and Golden Images, page 8-1

• Setting Up Application Servers, page 3-15

• Configuring Server Credentials, page 4-11

Installing the VHA on Windows Servers
Before you can create a golden image from a model server that is running the Windows operating system, 
you must install the Windows version of the VHA, setup.exe, which is packaged as a self-extracting 
executable file.

Before You Begin

• Set up the model server (see Setting Up Model Servers, page 3-16).

• Verify that a DHCP range is configured for the subnet where the model server is connected, and that 
VFrame is configured to respond to DHCP requests from the subnet. For more information about 
setting up DHCP, see Configuring DHCP Relay Agents in Ethernet Switches, page 5-2 and 
Configuring DHCP in VFrame, page 5-4.

• Verify that the model server can be PXE booted.

Procedure

Step 1 Use one of the following methods to download the VHA to the model server:

• From the model server, use a web browser to connect to the VFrame home page. For example, if the 
DNS name of the VFrame system is vframe.example.com, open the http://vframe.example.com 
URL. Click the link to download the VHA package, and then click the link for the Windows VHA. 
Download the Windows VHA (setup.exe) to the server.

• Download the file to another server that has an accessible shared directory and then map that 
directory to the model server. Copy the file to the model server.

Step 2 Run the setup.exe command. Follow the instructions in the installation wizard to install the VHA. On 
the final page of the wizard, select to run the VHA, and then click Finish.

If you do not choose to run the VHA, you can start it yourself by choosing Cisco Systems, Inc. > Cisco 
Virtual Host Agent > Launch GUI Console from the Start menu. You can also uninstall it using the 
uninstall command in this folder.

Note The Windows VHA files are installed in C:\VFrame_Cisco_Systems directory and VHA is 
registered as a service called Cisco_VHA.

For more information about the Windows VHA installation, see the 
C:\VFrame_Cisco_Systems\VHA_Readme.txt file that is installed as part of the VHA.

Step 3 On the VHA console, enter the IP address of VFrame server communication interface, and click Run 
VHA. A command-line window opens and runs the VHA.
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Note You can also run the VHA from the command line. Change directories to the installation 
directory (C:\VFrame_Cisco_Systems), and run the WinVha.exe VFrame_IP_address 
command, replacing VFrame_IP_address with the IP address of the VFrame server 
communication interface.

After the VHA runs successfully, VFrame obtains the model server information and displays the model 
server in the following two locations:

• Resources tab, in the Device selector under Model Servers.

• New Golden Image dialog box.

You can now create a golden image from the model server. For more information, see Creating a Golden 
Image, page 8-10.

Related Topics

• Understanding Model Servers and Golden Images, page 8-1

• Setting Up Application Servers, page 3-15

• Configuring Server Credentials, page 4-11

Working with Golden Images
This section provides detailed procedures for working with golden images, and includes the following 
topics:

• Viewing the Golden Image Repository Setup, page 8-9

• Creating a Folder in the Golden Image Repository, page 8-10

• Creating a Golden Image, page 8-10

• Restarting an Image Management Job, page 8-15

• Exporting a Golden Image, page 8-13

• Importing a Golden Image, page 8-14

• Working with Golden Image Variables, page 8-16

• Working with Sysprep Files, page 8-17

• Deleting Items from the Repository, page 8-19

• Changing the Golden Image Version for a Server Group, page 8-20

Viewing the Golden Image Repository Setup
You can view information about the physical storage setup for the golden image repository. This 
information can help you determine if the repository needs to be moved to a larger storage location, or 
if you need to start deleting old images.
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Procedure

Step 1 Choose Tools > Golden Images to open the Golden Images dialog box (see Golden Images Dialog Box, 
page 8-21).

Step 2 Click Repository Properties to open the Repository Setup dialog box. For information on the fields, see 
Repository Setup Dialog Box, page 8-32.

Tip You can also view information about the physical storage setup for the golden image repository 
from the CLI by entering the show gir command.

Related Topics

• Understanding the Golden Image Repository, page 8-3

Creating a Folder in the Golden Image Repository
The golden image repository automatically includes a top-level folder for each VFrame virtual context 
that exists. To organize your golden images, you can create folders to create a multilevel hierarchy within 
each of these top-level folders.

Procedure

Step 1 Choose Tools > Golden Images to open the Golden Images dialog box (see Golden Images Dialog Box, 
page 8-21).

Step 2 In the Golden Images selector, right-click the folder in which you want to create the new folder and click 
New Folder to open the New Folder dialog box.

In the New Folder dialog box, enter a name for the folder. The name must be unique within the folder in 
which you are adding the new folder. The name can include only alphanumeric characters (a-z, A-Z, 0-9) 
and the underscore (_).

Step 3 Click OK.

Related Topics

• Understanding the Golden Image Repository, page 8-3

• Deleting Items from the Repository, page 8-19

Creating a Golden Image
After you configure a model server with the operating system and application software to create the 
desired operational environment, you can create a golden image from the model server. 

Later, when you create a service network, you can select the golden image you created as the image 
VFrame should deploy to the servers in the service network.
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Before you Begin

Install and run the VHA on the model server as described in Installing the VHA on Model Servers, 
page 8-5.

Procedure

Step 1 Choose Tools > Golden Images to open the Golden Images dialog box (see Golden Images Dialog Box, 
page 8-21).

Step 2 In the Golden Images selector, do one of the following:

• To create a standalone golden image, select the folder in which you want to create the image and 
click New Images to open the New Golden Image dialog box. 

• To create a child version of an existing golden image, select the image and click New Images to 
open the New Golden Image dialog box.

Step 3 In the New Golden Image dialog box (see New Golden Image Dialog Box, page 8-25), enter the 
following information:

• Parent Image—From the drop-down menu, choose the golden image for which you want to make a 
child version. This option is only available if you selected a folder before opening the New Golden 
Image dialog box. If you are creating a standalone golden image, select None.

• Image Name—Enter a unique name for the golden image. You can use only alphanumeric 
characters, underscores, and hyphens in the image name; you cannot include spaces in the name. 
This option is only available if you selected a folder before opening the New Golden Image dialog 
box. The name you enter here will be used as the name shown in the golden image repository for all 
parent and standalone golden images, and it will be the name used to select any image within a 
golden image version hierarchy when configuring server groups in their service networks. Make 
sure the name is meaningful.

• Label—Enter a tag for identifying the version of the golden image. You can use only alphanumeric 
characters, underscores, and hyphens in the label; you cannot include spaces in the label. Because 
all golden images in the same golden image version hierarchy use the same image name, you can 
use the label to differentiate the golden images in the same version hierarchy. In the golden image 
repository, the parent image shows the image name and the label; all child images only show the 
label.

• Description—(Optional.) Enter a description for the image. A description will help users identify 
the purpose of the image when viewing it in the golden image repository.

• Job Name—(Optional.) Enter a unique name for the job that helps you distinguish it from other 
image management jobs.

• Image Type—Choose the image physical characteristics. The image type determines what types of 
storage can be used when setting up a server group in a service network. Your options are as follows:

– Block Based—For creating a golden image that will be replicated only on SAN LUNs. These 
images cannot be replicated on NAS filer volumes, but can be used for application servers that 
boot off the SAN. ESX, Linux, and Windows images can be block based.

– File Based—For creating golden images that will be replicated on NAS filer volumes. These 
images can be used for application servers that boot off a NAS filer volume. Only Linux images 
can be file based.

• Model Server—From the drop-down list, choose one of the available model servers to use for 
creating the golden image.
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When you choose a model server, you can view physical details about the selected server in the 
Model Server Properties group. Before starting a golden image snapshot job, use the information 
shown in the Model Server Properties group to ensure that there is enough space in the repository 
to store the golden image being created from the model server. For block-based images, the disk 
span attribute displayed in the Model Server Properties group indicates the amount of space from 
the disk that will be copied and stored in the repository. VFrame compresses the disk image before 
storing it in the repository. For file-based images, the amount of space required will be equal to the 
sum of the used disk space for each of the partitions in the model server.

Step 4 Click OK to save your changes and create the golden image snapshot job.

To view the status of the job, click the Logs tab (see Logs Tab, page 8-26), select the job from the jobs 
list, and then click Logs to see the list of job messages for the selected job. The most recent message 
should indicate that you need to PXE boot the model server to continue the snapshot job.

Step 5 (Windows only) log in to the Windows model server and do the following:

a. Create a folder named C:\sysprep. Ensure that the folder name is all lower-case letters. Download 
and install the System Preparation (sysprep) package from Microsoft in to the C:\sysprep directory.

b. Run setupmgr.exe to create a sysprep.inf file that you must later upload to VFrame and associate 
with the golden image.

c. Run the System Preparation (sysprep.exe) program. Select the Reboot option, then the Reseal 
option. See the Microsoft System Preparation Tool documentation for detailed information on using 
the program.

Step 6 PXE boot the model server. You might need to manually invoke PXE boot during the boot process based 
on how the boot order is configured in the BIOS of the server.

After the server boots up, the following occurs:

• VFrame responds to the server PXE boot message and provides the model server an IP address from 
one of the DHCP IP address ranges you defined.

• The inventory operating system (OS) is loaded on the model server.

• VFrame copies the contents of the model server to the golden image repository with the help of the 
inventory OS. The time required to complete the copy is related to the size of the image. You can 
track the process by watching the log messages for the job.

Step 7 After completing the golden image creation process, VFrame tries to reboot the model server by sending 
a message to the inventory OS and by resetting the power using the LOM interface. If VFrame cannot 
find appropriate LOM credentials for the server in the device credentials list (see Configuring Server 
Credentials, page 4-11), the server might not reboot. You should reboot the server manually to release 
the IP address VFrame leased to the server.

Step 8 (Optional) When the snapshot job is finished, open the Golden Images dialog box (Tools > Golden 
Images) if it is not already open, select the golden image you created, and verify the image properties 
are what you expected them to be.

Step 9 If the image is for the Windows operating system, you must create at least one sysprep file. For 
information on how to create a sysprep file, see Working with Sysprep Files, page 8-17.

Step 10 (Optional) You can define special parameters for a golden image. If you write a program to process the 
parameters, you can customize the deployment of a golden image when it is used by a server. For 
information on how to create and use these parameters, see Working with Golden Image Variables, 
page 8-16.
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Tips

• If you want to stop the golden image creation process, click the Logs tab, select the job from the 
jobs list, and then click Stop.

Related Topics

• Understanding Model Servers and Golden Images, page 8-1

• Restarting an Image Management Job, page 8-15

• Deleting Items from the Repository, page 8-19

Exporting a Golden Image
You can export any golden image from the golden image repository to another server. You can then 
import the exported image into another VFrame system, or import it back into your VFrame system (for 
example, into another folder). Exporting golden images allows you to share them among VFrame 
systems, standardizing your golden images.

Procedure

Step 1 Choose Tools > Golden Images to open the Golden Images dialog box (see Golden Images Dialog Box, 
page 8-21).

Step 2 In the Golden Images selector, select the golden image to export.

Step 3 Click Export to open the Export Golden Image dialog box (see Export Golden Image Dialog Box, 
page 8-28). 

Step 4 In the Export Golden Image dialog box, enter the following required information:

• Server—The name or IP address of the server to which you are exporting the image.

• Directory—The full directory path for the exported image.

• File—The base name of the golden image you are creating. The image will include one or more 
compressed files, and VFrame will add a numbered suffix to each file, such as _000, _001, and so 
on. For example, if you enter LinuxImage, the resulting export file might be named 
LinuxImage_000.

• Username—Enter a username that can log in to the server to which you are exporting the file.

• Password—Enter a password for the username used to log in to the server.

• Protocol—Choose the protocol you want to use for exporting the image. You can select scp or sftp. 
The server to which you are exporting the image must support the selected protocol.

Step 5 Click OK to start the export process. 

Tips

• If you want to stop the golden image export process, click the Logs tab, select the job from the jobs 
list, and then click Stop.

• If you are exporting a Windows golden image, be aware that the sysprep files are not included in the 
export process. You might want to select each sysprep file defined for the image, select the contents 
of the file, and copy and paste it into a text file. You can use the text files to redefine the sysprep 
files when you import the image.
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Related Topics

• Understanding Model Servers and Golden Images, page 8-1

• Understanding the Golden Image Repository, page 8-3

• Creating a Golden Image, page 8-10

Importing a Golden Image
If you export a golden image from a VFrame system (either this system or another system), you can 
import it into the golden image repository. Importing golden images from other systems allows you to 
share them among VFrame systems. You can also use the import feature to move a golden image from 
one folder to another in the same repository (you must first export the golden image).

Procedure

Step 1 Choose Tools > Golden Images to open the Golden Images dialog box (see Golden Images Dialog Box, 
page 8-21).

Step 2 In the Golden Images selector, do one of the following

• Select the folder into which you want to import the golden image.

• Select a golden image under which you want to import a child image.

Create a new folder if you want to import the image into a new location (for information on creating 
folders, see Creating a Folder in the Golden Image Repository, page 8-10).

Step 3 Click Import to open the Import Golden Image dialog box (see Import Golden Image Dialog Box, 
page 8-29). 

Step 4 In the Import Golden Image dialog box, Enter the following required information:

• Server—The name or IP address of the server.

• Directory—The full directory path to the image.

• File—The base name of the golden image. If the name includes a numbered suffix (such as _000, 
_001, and so on), do not include the suffix. For example, if the image is named LinuxImage_000, 
enter LinuxImage.

• Username—Enter a username that can log in to the server that is hosting the image you are 
importing.

• Password—Enter a password for the username used to log in to the server.

• Protocol—Choose the protocol you want to use for importing the image. You can select scp or sftp. 
The server that hosts the image you are importing must support the selected protocol.

• Parent Image—From the drop-down menu, choose the golden image for which you want to import 
a child version. This option is only available if you selected a folder before opening the Import 
Golden Image dialog box. If you are importing a standalone golden image, select None.

• Image Name—Enter a unique name for the golden image. You cannot include spaces in the name. 
This option is only available if you selected a folder before opening the Import Golden Image dialog 
box.

• Label—Enter a tag for identifying the version of the golden image. You can use only alphanumeric 
characters, underscores, and hyphens in the label; you cannot include spaces in the label. Because 
all golden images in the same golden image version hierarchy use the same image name, you can 
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use the label to differentiate the golden images in the same version hierarchy. In the golden image 
repository, the parent image shows the image name and the label; all child images only show the 
label.

• Job Name—Enter a unique name for the job.

Step 5 Click OK to start the import process. 

Step 6 If the image is for the Windows operating system, it must have at least one sysprep file. Imported images 
do not include sysprep files. For information on how to create a sysprep file, see Working with Sysprep 
Files, page 8-17.

Step 7 (Optional) You can define special parameters for a golden image. If you write a program to process the 
parameters, you can customize the deployment of a golden image when it is used by a server. For 
information on how to create and use these parameters, see Working with Golden Image Variables, 
page 8-16.

Tips

• If you want to stop the golden image import process, click the Logs tab, select the job from the jobs 
list, and then click Stop.

Related Topics

• Understanding Model Servers and Golden Images, page 8-1

• Understanding the Golden Image Repository, page 8-3

Restarting an Image Management Job
You can restart jobs you created for creating a golden image, importing one, or exporting one. You can 
restart these jobs, whether they have succeeded or failed, to create new images or replace existing 
images.

For information on creating the initial jobs, see the following sections:

• Creating a Golden Image, page 8-10

• Exporting a Golden Image, page 8-13

• Importing a Golden Image, page 8-14

Procedure

Step 1 Choose Tools > Golden Images to open the Golden Images dialog box (see Golden Images Dialog Box, 
page 8-21).

Step 2 Click the Logs tab (see Logs Tab, page 8-26).

Step 3 Choose the image management job you want to restart and click Restart.

Step 4 The appropriate dialog box opens with the same settings that were used when the job was first run. You 
can keep these settings, or you can make any changes you require. See the following topics based on the 
job type:

• For snapshot jobs (new golden images), see New Golden Image Dialog Box, page 8-25.

• For export jobs, see Export Golden Image Dialog Box, page 8-28.

• For import jobs, see Import Golden Image Dialog Box, page 8-29.
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Step 5 Click OK to restart the job.

VFrame creates a new job. For snapshot jobs, you must follow the same process described in Creating a 
Golden Image, page 8-10, to PXE boot the server and complete the golden image creation process.

Related Topics

• Understanding Model Servers and Golden Images, page 8-1

Working with Golden Image Variables
You can create and edit variable groups and variables associated with a golden image. The variables 
processed with your own scripts to customize a server that uses the golden image. Your script should 
process the variables during server boot.

For a more detailed explanation of golden image variables and the purpose they serve, see Understanding 
Golden Image Variables, page 8-2.

You cannot add, edit, or delete variables or variable groups for a golden image if the golden image, or 
any image in the same version hierarchy, is assigned to a server group in a service network.

When a golden image is exported, the image variable groups and variables associated with it are also 
exported as part of the image, so you do not need to spend time recreating the variables when you import 
that image in to the same or another VFrame.

If the image is imported as a child of an existing golden image, VFrame verifies that the variable groups 
and variables associated with the new image do not conflict with the existing variable group and variable 
definitions in the image version hierarchy. All non-conflicting variables are automatically added to the 
variable set for that image version hierarchy.

Before You Begin

You must have a good understanding of what you want to accomplish with your script. After planning 
out your script, you should have a list of the types of variables you need.

You also need to understand how to create variables and variable groups, as described in Managing 
Global Libraries and Variables, page 12-1. However, keep in mind that you cannot assign variables from 
the global library to a golden image. All golden image parameters are unique to each golden image.

Procedure

Step 1 Choose Tools > Golden Images to open the Golden Images dialog box (see Golden Images Dialog Box, 
page 8-21).

Step 2 In the Golden Images selector, select the image whose parameters you want to modify.

Step 3 Click the Properties tab if it is not already open.

Step 4 To add a variable group:

a. In the Image Variables group, select the Golden Image Variables folder and click the New button to 
open the Variable Group dialog box (see Variable Group Dialog Box, page 12-13).

b. Enter a variable group name and optionally a description.

c. Check the Multivalued check box if you want to add a multivalued variable group.

d. Click OK to add the variable group to the variables list.
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e. Click Apply on the Golden Images dialog box to save your changes.

Step 5 To add a variable:

a. Choose the variable group in which you want to define the variable and click the New button to open 
the Variable dialog box (see Variable Dialog Box, page 12-15).

b. Enter a variable name and optionally a description.

c. Choose the appropriate variable type.

d. Check the Show advanced settings check box to view and optionally select additional variable 
characteristics. For example, you can make the parameter optional, set default values, restrict values, 
and so forth. The variable type determines which settings are available. When you select an 
advanced option, the dialog box might expand to display additional fields related to your selection.

e. Click OK to add the variable to the variable group.

f. Click Apply in the Golden Image dialog box to save your changes.

Step 6 To modify an existing variable group:

a. Select the variable group and click the Edit button. You can change the group name, description, 
and whether the group allows multiple values for its variables. 

b. Click Apply in the Golden Image dialog box to save your changes.

Step 7 To modify an existing variable:

a. Select the variable and click the Edit button. You can modify all variable attributes. 

b. Click Apply in the Golden Image dialog box to save your changes.

Step 8 To delete a variable group or a variable:

a. Select it and click the Delete button. 

b. Click Apply on the Golden Image dialog box to save your changes.

Related Topics

• Understanding Model Servers and Golden Images, page 8-1

• Understanding Golden Image Variables, page 8-2

• Understanding Sysprep Requirements for Windows Images, page 8-3

• Creating a Golden Image, page 8-10

• Importing a Golden Image, page 8-14

Working with Sysprep Files
Before you can use a Windows golden image, you must attach at least one sysprep.inf file to the golden 
image. The best way to create syspref.inf files is to use the Setup Manager tool (setupmgr.exe) as 
instructed in the Microsoft documentation. Use the Sysprep Answer File option during the System Setup 
wizard to generate the file.

Explaining the contents and creation of sysprep.inf files is outside the scope of the VFrame 
documentation. See the Microsoft System Preparation Tool documentation for complete information. 
The following procedure explains how to get the file you created into the VFrame system to create a 
deployable Windows golden image.
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Before You Begin

Use the Microsoft System Preparation tool to create the sysprep.inf file for the model server.

If you log in to VFrame from the model server, you can upload the file directly. Otherwise, copy the 
sysprep.inf file to the workstation you are using to run VFrame.

Procedure

Step 1 Choose Tools > Golden Images to open the Golden Images dialog box (see Golden Images Dialog Box, 
page 8-21).

Step 2 In the Golden Images selector, select the Windows golden image to which you are adding a sysprep file.

Step 3 Click the Properties tab if it is not already open (see Properties Tab, page 8-23).

Step 4 To add a sysprep file:

a. In the Sysprep Files group, click the New button to open the New Sysprep File dialog box (see New 
Sysprep File Dialog Box, page 8-31).

b. Enter a name and optionally a description for this sysprep configuration. The name is used in the 
repository and is also the name users will select when configuring server groups during service 
network design.

c. Enter the contents of the sysprep file in the Sysprep Template edit field. The easiest way to do this 
is to click Import from File and select the sysprep.inf file you created using the Microsoft tools. 
You can edit the contents of the file you upload.

Note You must enter the name and the contents for a sysprep file before you can save it. If the 
Name or Sysprep Template edit field is empty, the Apply and OK buttons are dimmed.

To create variables in the sysprep file, which users can configure during server group configuration, 
enclose the desired variable name in two sets of brackets. For example, the following line creates 
the variable named system_host_name and assigns it to the ComputerName attribute:

ComputerName = [[system_host_name]]

d. Click Validate to verify that your variables are correctly constructed.

e. Click OK when you are satisfied with the contents of the sysprep file. VFrame adds the sysprep file 
to the repository, assigning it to the selected Windows golden image.

f. Click Apply in the Golden Image dialog box to save your changes.

Step 5 To modify an existing sysprep file:

a. In the Sysprep Files group, select the sysprep file and click the Edit button to open the Edit Sysprep 
File dialog box. You can modify the sysprep file attributes. 

Note If the sysprep file you select is in use, the Edit Sysprep File dialog box opens in read-only 
mode, with the Apply and OK buttons dimmed.

b. Click Validate to verify that your variables are correctly constructed.

c. Click OK when you are satisfied with the changes you have made to the sysprep file. 

d. Click Apply in the Golden Image dialog box to save your changes.
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Step 6 To delete a sysprep file:

a. In the Sysprep Files group, select the sysprep file and click the Delete button. 

b. Click Apply in the Golden Image dialog box to save your changes.

Related Topics

• Understanding Sysprep Requirements for Windows Images, page 8-3

• Creating a Golden Image, page 8-10

• Importing a Golden Image, page 8-14

Deleting Items from the Repository 
You can delete the following items from the golden image repository, with certain restrictions:

• Folders—You cannot delete a folder that contains a golden image that is in use.

• Golden images—You cannot delete a golden image that is configured for a server group, even if the 
image is not deployed on a server. 

Procedure

Step 1 Choose Tools > Golden Images to open the Golden Images dialog box (see Golden Images Dialog Box, 
page 8-21).

Step 2 In the Golden Images selector, right-click the folder or golden image to delete, and then click Delete. 
You are asked to confirm that you want to delete the item. If you click Yes, VFrame creates a job to delete 
the item, and if the job completes successfully, it is deleted.

Step 3 To view the status of the job, and its log messages, click the Logs tab and select the deletion job from 
the jobs list.

Related Topics

• Understanding Model Servers and Golden Images, page 8-1

• Creating a Folder in the Golden Image Repository, page 8-10

• Creating a Golden Image, page 8-10

• Working with Sysprep Files, page 8-17
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Changing the Golden Image Version for a Server Group
When designing a service network, you can configure a server group to use any golden image in the 
golden image repository. However, when a server group is deployed, you can only change its golden 
image to another golden image within the same image version hierarchy.

Procedure

Step 1 Change the golden image version for the server group:

a. Choose View > Service Networks to open the Service Networks tab (see Golden Images Dialog 
Box, page 8-21).

b. From the Service Networks selector, double-click the desired service network containing the server 
group for which you want to change the golden image version. The service network opens and its 
definitions are displayed in the right panes.

c. From the service network elements selector, click the server group.

d. Click the Settings tab if it is not already open.

e. From the Image drop-down list, select the new golden image version and click Save.

When the server group golden image version changes, all new logical servers that are deployed from that 
server group will use the new golden image version. However, the logical servers that were already 
deployed when the golden image version was changed will continue to use the previous version, and 
additionally, VFrame generates the Designed Image Version Mismatch alarm indicating that the there is 
a mismatch between the new server group golden image version and the logical server golden image 
version. To clear the Designed Image Version Mismatch alarm for a deployed logical server, complete 
Step2 and Step 3.

Step 2 Change the golden image version for the applied logical server:

a. Patch the applied logical server with the new operating system and application software as 
appropriate.

b. Update the opt/cisco_vfdc/gi_version VHA file with the new golden image version. The VHA 
reports the new golden image version for the applied logical server.

Step 3 Change the golden image version for the designed logical server:

a. Choose View > Operation to open the Operations tab.

b. From the Service Networks selector, double-click the desired service network containing the logical 
server for which you want to change the golden image version. The service network opens.

c. From the service network elements selector, click the server group. The server group expands to 
show all logical servers for that server group.

d. Right-click the logical server and click Change Design Image Version. The design image version 
updates to match the image version for the server group, and the Designed Image Version Mismatch 
alarm is cleared.
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Troubleshooting Golden Image Management
This section describes some problems you might encounter when creating and managing golden images 
and their solutions, and includes the following topics:

• Problem You reimaged a model server but VFrame does not recognize the changes.

• Problem An imported Windows golden image did not include sysprep files.

Problem You reimaged a model server but VFrame does not recognize the changes.

Solution You can reuse model servers to create images for different software setups. To enable VFrame 
to recognize drastic changes, such as changing the operating system from Linux to Windows, you must 
restart the VHA (migration agent) on the model server. VFrame will rediscover the model server with its 
current configuration and you can proceed to create a golden image. 

Problem An imported Windows golden image did not include sysprep files.

Solution When you export a Windows golden image, the sysprep files are not exported with it. When you 
import the image into another VFrame system, you must recreate the sysprep files for the image.

Golden Image Management Reference
This section describes the tabs and dialog boxes you use when managing golden images, and includes 
the following topics:

• Golden Images Dialog Box, page 8-21

• Properties Tab, page 8-23

• New Golden Image Dialog Box, page 8-25

• Logs Tab, page 8-26

• Export Golden Image Dialog Box, page 8-28

• Import Golden Image Dialog Box, page 8-29

• New Sysprep File Dialog Box, page 8-31

• Repository Setup Dialog Box, page 8-32

Golden Images Dialog Box
Use the Golden Images dialog box to manage the golden image repository, to create golden images, and 
to view properties of existing golden images, including the servers that are using the images. You can 
also create and delete folders and import, export, or delete images.

How to Get to This Dialog Box

Choose Tools > Golden Images to open the Golden Images dialog box.

Related Topics

• Understanding Golden Image Management, page 8-1

• Working with Golden Images, page 8-9

• Troubleshooting Golden Image Management, page 8-21
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Field Reference

Table 8-1 Golden Images Dialog Box

Element Description

New Images button Click this button to open the New Golden Image dialog box, which allows 
you to create a new golden image in the selected folder or golden image 
hierarchy.

The golden image name can include only alphanumeric characters (a-z, A-Z, 
0-9) and the underscore (_).

Import button Click this button to import a golden image into the selected folder or golden 
image hierarchy. The Import Golden Image dialog box opens so that you can 
select the image to import. For more information about using this dialog box, 
see Import Golden Image Dialog Box, page 8-29. 

Export button Click this button to export the selected golden image. The Export Golden 
Image dialog box opens so that you can select the location where you want 
to export the image. For more information about using this dialog box, see 
Export Golden Image Dialog Box, page 8-28.

Repository Properties 
button

Click this button to open the Repository Setup dialog box where you can see 
details about the golden image repository. For more information about using 
this dialog box, see Repository Setup Dialog Box, page 8-32.

Golden Images selector The Golden Images selector shows folders and golden images organized in 
a hierarchical structure. At the top of the hierarchy, there is a folder for each 
VFrame virtual context, with all subfolders and golden images for a 
particular virtual context within each virtual context folder. You can use 
golden images from a virtual context other than the one in which you are 
working. You can also create additional subfolders (within each virtual 
context folder) to organize your golden images.

The selector also shows multiple golden image versions in a hierarchy, with 
the parent golden image at the top of the structure, and all child images 
(newer versions) below.

When you select a golden image in the selector, properties associated with 
the image are displayed in the Properties, Usage, and OS Details tabs in right 
pane.

Properties tab Allows you to view image properties, view ESX credentials, manage image 
variables, and manage sysprep files for golden images in the repository. For 
more information about using this tab, see Properties Tab, page 8-23.
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Properties Tab
Use the Properties tab to view image properties, manage image variables, and manage sysprep files for 
the golden images in the repository.

How to Get to This Tab

Choose Tools > Golden Images to open the Golden Images Dialog Box and click the Properties tab if 
it is not already open.

Related Topics

• Understanding Model Servers and Golden Images, page 8-1

• Understanding the Golden Image Repository, page 8-3

• Viewing the Golden Image Repository Setup, page 8-9

• Creating a Folder in the Golden Image Repository, page 8-10

• Exporting a Golden Image, page 8-13

• Importing a Golden Image, page 8-14

• Working with Golden Image Variables, page 8-16

• Working with Sysprep Files, page 8-17

• Deleting Items from the Repository, page 8-19

Usage tab Lists the servers that are using the selected golden image. The following 
information is displayed for each server:

• Context—The name of the virtual context that contains the service 
network that is using the golden image.

• Template—The template on which the service network that is using the 
golden image is based.

• Service Network—The service network that is using the golden image.

• Server Group—The server group in the service network that is using the 
golden image.

• Server—The name of the logical server in the service network that is 
using the golden image.

• Status—The status of the logical server.

OS Details tab Lists the properties of the Linux or Windows operating system, the model 
server from which the image was created, and the defined partitions.

Logs tab Allows you to view the status of golden image management jobs, stop jobs, 
and restart jobs. For more information about using this tab, see Logs Tab, 
page 8-26.

Table 8-1 Golden Images Dialog Box (continued)

Element Description
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Table 8-2 Properties Tab

Element Description

Image Name The filename for the golden image, which determines the name used in the 
golden image repository for all parent and standalone golden images, and is 
the name used to select any image within a golden image version hierarchy 
when configuring a server groups in a service network.

Label The description for the golden image version. Because all golden images in 
the same golden image version hierarchy use the same image name, you can 
use the label to differentiate the golden images. In the golden image 
repository, only the parent image shows the image name; all child images 
only show the label.

Description A description for the golden image.

Location The golden image repository folder in which the golden image is saved. 

State The current state of the golden image, such as Creating, Available, In Use, 
Deleting, Deletion Failed, and Sysprep Missing.

Type The method used for copying image data, which can be any of the following:

• Block—Images can be replicated in LUNs only.

• File Based—Images can be replicated in LUNs or NAS filer volumes.

Checksum A calculated value used by VFrame during image import or creation that is 
used to test the data integrity of the image.

Image Variables group Allows you to perform the following actions on variable groups and 
variables. 

• New—Click this button to open the Variable Group dialog box or 
Variable dialog box and create a new variable group or variable. 

• Edit—Click this button to open the Variable Group dialog box or 
Variable dialog box and change the settings for the selected variable 
group or variable.

• Delete—Click this button to delete the selected variable group or 
variable.

Sysprep Files group Allows you to perform the following actions on Sysprep files. 

• New—Click this button to open the New Sysprep File dialog box and 
create a new Sysprep file, which is used with Windows golden images. 
For more information about using this dialog box, see New Sysprep File 
Dialog Box, page 8-31.

• Edit—Click this button to open the Edit Sysprep File dialog box and 
change the settings for the selected Sysprep file. The fields that you can 
change in the Edit Sysprep File dialog box are the same as the fields in 
the New Sysprep File dialog box.

• Delete—Click this button to delete the selected Sysprep file.

Note The Sysprep Files group is available only when a Windows golden 
image is selected.
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New Golden Image Dialog Box
Use the New Golden Image dialog box to create a golden image and to see the properties of the available 
model servers.

How to Get to This Dialog Box

Choose Tools > Golden Images to open the Golden Images Dialog Box and click New Images.

Related Topics

• Understanding Model Servers and Golden Images, page 8-1

• Installing the VHA on Model Servers, page 8-5

• Creating a Golden Image, page 8-10

Field Reference

Table 8-3 New Golden Image Dialog Box

Element Description

Folder The golden image repository folder in which the golden image is saved. The 
folder location is determined by which folder or golden image you selected 
before opening the New Golden Image dialog box.

Parent Image A drop-down list of golden images for which you can make a child image 
version. The pull-down list is only available if you selected a folder before 
opening the New Golden Image dialog box. If you selected a golden image 
before opening the New Golden Image dialog box, the Parent Image field 
automatically contains the name of the golden image you selected, and the 
new golden image you are creating will be a child of that image. If you are 
creating a standalone golden image, select None.

Image Name The filename for the image, which is used as the name shown in the golden 
image repository for all parent and standalone golden images, and will be the 
name used to select any image within a golden image version hierarchy when 
configuring server groups in their service networks. You can use only 
alphanumeric characters, underscores, and hyphens in the image name; you 
cannot include spaces in the name.

You can specify the image name only if you selected a folder before opening 
the New Golden Image dialog box; otherwise, this field contains the parent 
image name.

Label A description for the golden image version. You can use only alphanumeric 
characters, underscores, and hyphens in the label; you cannot include spaces 
in the label. Because all golden images in the same golden image version 
hierarchy use the same image name, you can use the label to differentiate the 
golden images. In the golden image repository, only the parent image shows 
the image name; all child images only show the label.

Description (Optional) A description for the image that helps users identify the purpose 
of the image when viewing it in the golden image repository.

Job Name (Optional.) A name for the image snapshot job. Enter a name that will help 
you find the job on the Logs tab.
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Logs Tab
Use the Logs tab to see the status of golden image management jobs.

How to Get to This Tab

Choose Tools > Golden Images to open the Golden Images Dialog Box and click the Logs tab.

Image Type The method used for copying image data. The image type determines what 
types of storage can be used when setting up a server group in a service 
network. Your options are:

• Block Based—For creating a golden image that will be replicated only 
on SAN LUNs. These images cannot be replicated on NAS filer 
volumes, but can be used for application servers that boot off the SAN. 
ESX, Linux, and Windows images can be block based.

• File Based—For creating golden images that will be replicated on NAS 
filer volumes. These images can be used for application servers that boot 
off a NAS filer volume. Only Linux images can be file based.

Model Server A drop-down list of the model servers that you can use when creating golden 
images.

Model Server Properties 
group

A group of tabs that provide details about the model server. The tabs are as 
follows:

• General—Includes the model server information, such as the type of 
server, model number, serial number, the state of the model server, 
memory size, MAC address, CPU, and so on. 

• Partition—Lists the partitions on the model server, and provides detailed 
information for each partition.

• Disk—Lists the disk drives installed on the model server, and provides 
detailed information about each disk drive. You can use the information 
about partition and disk size to estimate how large the golden image will 
be.

• Fibre Channel HBA—Lists the HBAs installed on the model server, and 
provides detailed information about each HBA.

• Ethernet NIC—Lists the Ethernet NICs installed on the model server, 
and provides detailed information about each Ethernet NIC.

Before starting a golden image snapshot job, use the information shown in 
the Model Server Properties group to ensure that there is enough space in the 
repository to store the golden image being created from the model server. For 
block-based images, the disk span attribute displayed in the Model Server 
Properties group indicates the amount of space from the disk that will be 
copied and stored in the repository. VFrame compresses the disk image 
before storing it in the repository. For file-based images, the amount of space 
required will be equal to the sum of the used disk space for each of the 
partitions in the model server.

Table 8-3 New Golden Image Dialog Box (continued)

Element Description
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Related Topics

• Creating a Golden Image, page 8-10

• Restarting an Image Management Job, page 8-15

• Exporting a Golden Image, page 8-13

• Importing a Golden Image, page 8-14

Field Reference

Table 8-4 Logs Tab

Element Description

Filter button

If a filter is applied to 
the list, the button name 
is shown as:

Filter... (filtered)

Click this button to create a filter so that the list shows only the jobs that you 
want to see. The Filter dialog box is opened, and you can use the following 
fields to set a filter:

• Job Type—The type of job you want to see, related to the action 
performed by the job, arranged hierarchically in folders. Choose a folder 
to select all job types in the folder. If you want to select only one or two 
job types, first deselect All, then make your selections.

• Status—The job status. For example, you can elect to view jobs that are 
currently running.

• Time Range—Whether to view all jobs no matter when they ran (All), 
or to view jobs that ran on specific dates within specific times.

• Max Results—The maximum number of results you want to see. For 
past jobs, the most recent ones are selected over older jobs.

• Apply button—Click this button to apply your filter to the list without 
closing the Filter dialog box. Click OK to apply the filter and close the 
dialog box.

• Reset—Click this button to reset all filter values to their defaults (which 
is to view all jobs without date and time restrictions).

Show All button Click this button to display all jobs, removing any filter that is currently set. 
To reapply the filter, click Filter to open the Filter dialog box (which retains 
the previous filter values), and click OK.

Logs button Click this button to open the Logs dialog box, which shows the messages for 
the job you select in the Logs tab. The following information is shown for 
each message:

• Severity—The severity level of the message.

• Time—The date and time the message was logged.

• Resource—The resource associated with the event that generated the job 
log message.

• Entry—The job log message received from the server that describes the 
event.
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Export Golden Image Dialog Box
Use the Export Golden Image dialog box to export a golden image from the golden image repository to 
another server. You can then import that image into another VFrame system.

How to Get to This Tab

Choose Tools > Golden Images to open the Golden Images dialog box. In the Golden Images selector, 
select the golden image you want to export and click Export.

Related Topics

• Golden Images Dialog Box, page 8-21

• Exporting a Golden Image, page 8-13

• Restarting an Image Management Job, page 8-15

• Understanding Model Servers and Golden Images, page 8-1

• Understanding the Golden Image Repository, page 8-3

Details button Click this button to open the Log Record Details dialog box, which shows 
the information only for the job you select in the Logs tab.

Click the previous record (<) or next record (>) button in the Log Record 
Details dialog box to see the details information for the previous or next 
record.

Restart button Click this button to restart the selected snapshot job if the job is completed. 
A dialog box with the job details is opened. You can change the job 
characteristics before rerunning the job.

Stop button Click this button to stop the selected snapshot job if the job is currently in 
progress. 

Name The name of the image management job.

Type The type of job. Jobs are created for taking a snapshot of a golden image 
(creating a golden image), exporting one, importing one, or deleting either 
an image or a repository folder.

Status The status of the job, for example, Success or Failed.

Start Time The date and time the job started.

Percent Complete How much of the job has finished.

Duration The amount of time the job took to finish.

Resources The resource that was being operated on when the message was issued.

Table 8-4 Logs Tab (continued)

Element Description
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Field Reference

Import Golden Image Dialog Box
Use the Import Golden Image dialog box to import a golden image into the golden image repository.

How to Get to This Dialog Box

Choose Tools > Golden Images to open the Golden Images dialog box. In the Golden Images selector, 
select the folder or golden image under which you want to import a golden image, then click Import.

Related Topics

• Golden Images Dialog Box, page 8-21

• Importing a Golden Image, page 8-14

• Restarting an Image Management Job, page 8-15

Table 8-5 Export Golden Image Dialog Box

Element Description

Export From group This group contains the following information about the golden image being 
exported:

• Folder—The folder in the repository that contains the image being 
exported. 

• Image—The image name.

• Label—The image label (version).

• Description—The image description.

• Job Name—A name for the export job. You can replace the system 
generated name with a name that will make it easier for you find the job 
in the Logs tab list.

Export To group This group contains the following information about the location to where 
you are exporting the golden image:

• Server—The name or IP address of the server to where you want to 
export the golden image. 

• Directory—The directory to where you want to export the image. 
Include the full path, for example, /ServerImages/Linux.

• File—The name you want to use for the exported golden image. VFrame 
uses the name as the base name of the file, and appends a numeric suffix, 
such as _000, _001 and so on. For example, if you specify LinuxImage 
as the archive name, the export file might be named LinuxImage_000. 
The exported golden image consists of one or more compressed files.

• Username—A username that can log in to the server to where you are 
exporting the image.

• Password—The password for the username.

• Protocol—The protocol you want to use for exporting the image. The 
server to which you are exporting the must support the protocol you 
select. You can choose SCP or SFTP.
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• Understanding Model Servers and Golden Images, page 8-1

• Understanding the Golden Image Repository, page 8-3

Field Reference

Table 8-6 Import Golden Image Dialog Box

Element Description

Import From group This group contains the following information about the location from where 
you are importing the golden image:

• Server—The name or IP address of the server from where you want to 
import the golden image. 

• Directory—The directory from where you want to import the image. 
Include the full path, for example, /ServerImages/Linux.

• File—The name you want to use for the imported golden image. VFrame 
uses the name as the base name of the file, and appends a numeric suffix, 
such as _000, _001 and so on. For example, if you specify LinuxImage 
as the archive name, the imported file might be named LinuxImage_000. 
The imported golden image consists of one or more compressed files.

• Username—A username that can log in to the server from where you are 
importing the image.

• Password—The password for the username.

• Protocol—The protocol you want to use for importing the image. The 
server from which you are importing the must support the protocol you 
select. You can choose SCP or SFTP.

Import To group This group contains the following information about the golden image being 
imported:

• Folder—The folder in the repository where the golden image is to be 
imported. 

• Parent Image—The name of the parent image in a golden image version 
hierarchy. This field is blank if you are importing a standalone golden 
image (a golden image without any parent versions).

• Image—The image name.

• Label—The image label (version).

• Description—The image description.

• Job Name—A name for the import job. You can replace the system 
generated name with a name that will make it easier for you find the job 
in the Logs tab list.
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New Sysprep File Dialog Box
Use the New Sysprep dialog box to add a sysprep file to a Windows golden image. You must add at least 
one sysprep file to a Windows golden image to make it deployable to servers.

How to Get to This Dialog Box

Choose Tools > Golden Images, select a Windows golden image in the selector, click the Properties 
tab if it is not already open, and click the New button in the Sysprep Files group.

Related Topics

• Understanding Sysprep Requirements for Windows Images, page 8-3

• Creating a Golden Image, page 8-10

• Importing a Golden Image, page 8-14

• Working with Sysprep Files, page 8-17

Field Reference

Table 8-7 New Sysprep File Dialog Box

Element Description

Name The name of the sysprep settings as it will appear in the VFrame interface. 
This is used as the name displayed in the Golden Images selector, and is also 
the name users will select when configuring a server group during service 
network design.

Description The description of the purpose of the sysprep file.

Filename The name of the sysprep file, normally sysprep.inf. This is the name of the 
file that will be installed on the Windows server.

Input Area

(unlabeled edit box)

The contents of the sysprep file. You can upload a Sysprep file, type in the 
contents of the sysprep file, or do a combination of both.

Import from File button Click this button to select a sysprep file from your workstation. To select the 
sysprep.inf file from a Windows model server, either start VFrame from the 
model server, or copy the model server sysprep file to your workstation.

Validate button Click this button to validate the variables in the sysprep file contents. 
VFrame determines if the variables you defined are properly delimited with 
matching two matching sets of brackets.

Apply button Click this button to save the sysprep file to your workstation. 

Variables A display-only list of the variables defined in the sysprep file. Edit the 
sysprep file contents to make changes to this list. Use this list to verify that 
your variable definitions in the sysprep file are grammatically correct. To 
create a variable, enclose a text string in two sets of brackets. For example, 
the following string creates a variable named system_host_name and assigns 
it to the ComputerName attribute:

ComputerName = [[system_host_name]] 
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Repository Setup Dialog Box
Use the Repository Setup dialog box to see details about the golden image repository physical storage.

How to Get to This Dialog Box

Choose Tools > Golden Images and click Repository Properties.

Related Topics

• Viewing the Golden Image Repository Setup, page 8-9

• Understanding the Golden Image Repository, page 8-3

• Golden Images Dialog Box, page 8-21

Field Reference

Table 8-8 Repository Setup Dialog Box

Element Description

Type The type of storage on which the repository resides: local, SAN, or NAS 
filer.

Total Size (MB) The total size of the repository.

Used Size (MB) The amount of storage used by golden images.

Total Inodes The total number of Inodes in the repository.

An Inode is an operating system data structure that holds information about 
a file. Each file within a file system has at least one or possibly more Inodes. 
The repository has a limited number of Inodes based on the physical size of 
the storage device and the type of file system. (For NAS filers, you can 
specify the Inode size for each volume, although you cannot do this from 
within VFrame).

Used Inodes The number of Inodes that are being used.

If you are using NAS filers for the repository, and you need to migrate the 
repository to a new filer, you can use the used and total Inode counts to help 
you determine an appropriate number of Inodes to allocate to the target NAS 
filer volume.

Description The description of the golden image repository. For example, the NAS filer 
IP address and volume name.
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