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C H A P T E R6

Discovering Devices

After you configure device credentials, you can run discovery to bring the 
physical resources into the VFrame database. After you run discovery, the 
discovered devices appear on the Resources tab. 

The following topics provide more information: 

• Understanding Discovery, page 6-1

• Discovering Devices, page 6-6

• Troubleshooting Discovery, page 6-19

• Discovery Reference, page 6-20

Understanding Discovery
These topics describe the basic concepts of resource discovery:

• Understanding Discovery Jobs, page 6-2

• Understanding How Discovery, Rediscovery, and Reinventory Differ, 
page 6-4

• Device Rediscovery Tips, page 6-5
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Understanding Discovery Jobs
Discovery brings the physical resources of the data center into the VFrame 
database. Physical resources are network devices, such as Ethernet switches and 
service modules; storage devices, such as NAS filers, MDS switches, storage 
managers, and storage arrays; and servers, such as application servers and LOM 
managers. When you run discovery, use the Schedule Editor dialog box to specify 
the scope of discovery as well as the type of elements you want discovered. The 
result is a discovery job, which you can rerun whenever you want.

You can discover the following elements:

Network

• Network Devices—Cisco Discovery Protocol (CDP) is used for network 
discovery. Enter the DNS name or IP address of a CDP seed device (any 
device on which the CDP protocol is enabled and an SNMP read community 
string is configured). VFrame discovers all neighboring switches (in the 
specified distance) starting with the ones directly connected to the seed 
device and obtains information about those devices.

Storage

• NAS filers—Enter the IP address or DNS name of the NAS filer; VFrame 
discovers the NAS filer, its volumes, Quota Trees (QTrees), and Common 
Internet File System (CIFS) shares. 

• SAN Fabric Devices—You can use one or two physical SAN fabrics. Enter 
the IP address or DNS name of the seed MDS switch for each physical fabric. 
VFrame discovers all neighboring MDS switches in each fabric that have 
member ports in the same active VSANs as the seed switch. VFrame also 
discovers the connected device World Wide Names (WWN) for each 
discovered MDS switch. For details about SAN fabric devices, see SAN 
Fabric Devices, page 3-5).

• Storage Managers—When you select a storage manager and run discovery, 
VFrame discovers the storage arrays configured to be discovered through the 
storage manager and the related port and logical unit information.

Before you run storage manager discovery to discover storage arrays and their 
components, you must use a storage manager template to define macros. With 
macros, you control the logical units and ports that should be visible to a 
particular server. You can use these macros for inventory of storage array 
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ports and logical units and for logical unit masking and unmasking. For 
details about storage manager templates, see Storage Manager Templates, 
page 11-73. 

For details about storage managers, see Storage Managers, page 3-5.

Servers

Application servers are discovered using the inventory operating system (OS). 
Running the inventory OS is a process through which VFrame obtains hardware 
details about the server. When a server is PXE booted, VFrame responds to the 
PXE boot request by providing an IP address and the inventory OS. After the 
inventory OS runs on the server, VFrame obtains the server’s hardware inventory, 
such as its CPU, speed, memory, and system partitions. 

• DHCP—You must configure a Dynamic Host Configuration Protocol 
(DHCP) range in VFrame to provide a pool of IP addresses VFrame can use 
during server discovery or golden image creation from model servers. For the 
procedure on how to configure the DHCP range, see Adding or Modifying 
DHCP IP Address Ranges, page 5-6.

In order for VFrame to discover application or model servers, you must PXE 
boot the servers. During PXE boot, the server sends a DHCP request. VFrame 
responds to the DHCP request only on its server communication interface, so 
make sure that the server is set up correctly, otherwise the server will not be 
discovered (see Setting Up Servers, page 3-20).

For more information about DHCP, see Understanding How VFrame Uses 
DHCP, page 5-1. 

• LOM Managers—You must select a lights-out management (LOM) manager 
and run discovery to obtain the IP addresses of the LOM interfaces.

VFrame uses LOM managers and LOM configuration macros to control the 
power of the servers.VFrame runs the macros on the specified LOM manager 
to retrieve a list of LOM interfaces associated with the physical servers, to 
power on and power off the servers, and to obtain the power status of the 
servers. 

For details about LOM manager templates, see LOM Manager Templates, 
page 11-81.
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Understanding How Discovery, Rediscovery, and Reinventory 
Differ

When you create a discovery job, you can specify that the job run multiple times 
on a regular schedule. For example, you could have the job run every week.

The benefit of rerunning discovery jobs is that it allows VFrame to notice changes 
in the network. For example, if you run a network discovery job using 2 as the 
CDP distance, and you add a new switch to the network within that distance to the 
CDP seed device defined in the discovery job, the rediscovery of the CDP seed 
will notice the new switch and add it to the VFrame database. You can then select 
it in the device selector on the Resources tab and manage it.

Additionally, discovery jobs reevaluate the resources that were previously 
discovered. It is this activity of reexamining known devices that is called 
rediscovery. During a discovery job, if VFrame evaluates an already known 
device, it runs the inventory process on the device. (Inventory is initially run when 
you first manage a device, and subsequent inventories are considered 
reinventories.)

During rediscovery and reinventory, VFrame can identify many configuration 
changes, such as the addition of security contexts to a managed FWSM or new 
VLANs on managed switches. These changes are reflected in the database, and 
you can manage the new resources.

After rediscovery and reinventory, the database will reflect the current state of the 
resource configuration. However, if you made configuration changes that VFrame 
cannot accommodate (such as deleting a managed VLAN from a switch), the 
process will raise fault alarms identifying the problematic changes.
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Device Rediscovery Tips
These are some tips that might help you understand what happens during 
rediscovery, and how to avoid some pitfalls:

• Network Rediscovery—When the Ethernet switches and service modules are 
rediscovered, the device inventory is updated and the updated list is displayed 
in the device selector in the Resources tab. You can manage any new VLANs 
or FWSM security contexts.

• SAN Fabric Rediscovery—When the SAN fabric devices, such as the MDS 
switches in the fabric, and the VSANs, switch ports, targets, and initiators 
associated with the switches are rediscovered, the device inventory is updated 
and the updated list is displayed in the device selector in the Resources tab. 

We recommend that you do not move the seed switch from one fabric to 
another. If you need to move it, first select another switch to serve as the seed 
switch for that fabric, and then move it, otherwise discovery will fail. 

VFrame supports two fabrics, for example, Fabric 1 and Fabric 2. If you need 
to discard the existing physical switch topology and use a new topology as 
Fabric 1 or Fabric 2, we recommend that you do the following:

– Delete the existing Fabric 1 and Fabric 2 from the Resources tab.

– Specify a new seed device and reschedule discovery.

We highly recommend that you follow these steps. VFrame does not enforce 
it to accommodate extreme hardware failures. For example, if all switches in 
Fabric 2 failed, and you had to replace them with new switches and cable 
them exactly the same way.

• LOM Manager Rediscovery— When the LOM managers are rediscovered, 
any changes in the server inventory are reflected in the LOM manager’s 
associated details table on the Resources tab. If you added servers to the 
inventory, discover the new servers using the procedure described in 
Discovering Application Servers for Unassociated LOM Interfaces, 
page 6-15.
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Discovering Devices
The following topics describe how to discover devices: 

• Discovering Ethernet Switches and Service Modules, page 6-6

• Discovering Storage Devices, page 6-8

• Discovering Servers, page 6-13

• Viewing the Discovery Status, page 6-17

• Rescheduling or Unscheduling Discovery Jobs, page 6-18

Discovering Ethernet Switches and Service Modules
You can discover network devices such as an Ethernet switch and its service 
modules.

Before You Begin

• Set up the Ethernet switch and service modules (see Setting Up Ethernet 
Switches, page 3-11 and Setting Up Network Services, page 3-13).

• Configure Ethernet switch and network services credentials in VFrame (see 
Configuring Network Credentials, page 4-8 and Configuring Network 
Services Credentials, page 4-9).

• Make sure that the seed device is connected to the network and can be reached 
(pinged) from the VFrame Data Center Director.

Procedure

Step 1 Select Tools > Discovery to open the Discovery tab (see Discovery Tab, 
page 6-21).

Step 2 Click New to open the Schedule Editor dialog box. The Network tab is selected 
by default (see Network Tab, page 6-25). 

Step 3 (Optional) To change the system-assigned job name, select the name and enter a 
new one.
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Step 4 Do one of the following:

• To use the devices that you have already managed as CDP seeds, select the 
Rediscover Currently Managed Devices check box.

• To use a new device as the CDP seed, or to control which devices are used, 
enter the DNS name or the IP address of a device that is running CDP in the 
Seeds field. A seed device is used as the root device for network discovery.

Step 5 In the Distance field, select the number of CDP hops to use in the discovery. This 
number defines the scope of the discovery. For example, if you select 1, then any 
device running CDP that is connected to your specified seeds is also discovered 
and added to VFrame. The default is 0, which means that only the devices you 
specify are discovered.

Step 6 In the Type of Discovery field, select one of the following:

• Run Now—To start the discovery job immediately when you click OK.

• Schedule—To select a schedule for the job to run it in the future. Select the 
date and time when you want the job to run.

If you schedule the discovery job, you can also select Enable Repeat to 
schedule the job to be rerun until you cancel the job. Select the frequency time 
period (such as hour or day), and enter the number of time periods for the 
recurrence schedule. For example, selecting 2 Weeks causes the discovery 
job to be rerun every 2 weeks until canceled.

Step 7 Click OK.

VFrame creates a discovery job and adds it to the jobs list on the Discovery tab. 
When the job starts, you can view its progress by selecting it in the upper pane. 
The messages generated during the job’s progress appear in the Job Logs pane 
(the lower pane).

If discovery is successful, the discovered Ethernet switches, line cards, supervisor 
engine, and service modules in the switch are displayed in the device selector on 
the Resources tab under Network Devices. 

If a device is unsupported, it appears under Unsupported Devices in the device 
selector on the Resources tab. 
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Next Step

After you discover the Ethernet switch and service modules, you can manage 
them (see Managing and Unmanaging Ethernet Switches, page 7-11 and 
Managing and Unmanaging Service Modules, page 7-17). 

Related Topics

• Understanding Discovery, page 6-1

• Configuring Network Credentials, page 4-8

Discovering Storage Devices
The following topics describe how to discover storage devices: 

• Discovering SAN Fabric Devices and Their Components, page 6-8

• Discovering NAS Filers and Their Components, page 6-10

• Discovering Storage Arrays and Their Components Through Storage 
Managers, page 6-11

Discovering SAN Fabric Devices and Their Components

You can discover the MDS switches and their VSANs in one or two physical SAN 
fabrics. For each physical fabric the active VSANs in the seed switch determine 
which additional MDS switches are discovered.

Before You Begin

• Set up the MDS switch (see Setting Up MDS Switches, page 3-16).

• Configure SAN Fabric credentials in VFrame (see Configuring SNMP 
Credentials for SAN Fabric Devices, page 4-11).

Procedure

Step 1 Select Tools > Discovery to open the Discovery tab (see Discovery Tab, 
page 6-21).

Step 2 Click New to open the Schedule Editor dialog box.

Step 3 Click the SAN Fabric Devices tab (see SAN Fabric Devices Tab, page 6-27).
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Step 4 (Optional) To change the system-assigned job name, select the name and enter a 
new one.

Step 5 Do one of the following:

• To use the seed devices that you used previously, select Rediscover 
Currently Managed Fabrics.

• To discover a single physical SAN fabric, enter the IP address or DNS name 
of the seed MDS switch in the Seed 1 field.

• To discover two physical SAN fabrics, enter the IP address or DSN name of 
the seed MDS switch for the first fabric in the Seed 1 and the one for the 
second fabric in the Seed 2 field.

Step 6 In the Type of Discovery field, select one of the following:

• Run Now—To start the discovery job immediately when you click OK.

• Schedule—To select a schedule for the job to run it in the future. Select the 
date and time when you want the job to run.

If you schedule the discovery job, you can also select Enable Repeat to 
schedule the job to be rerun until you cancel the job. Select the frequency time 
period (such as hour or day), and enter the number of time periods for the 
recurrence schedule. For example, selecting 2 Weeks causes the discovery 
job to be rerun every 2 weeks until canceled.

Step 7 Click OK.

VFrame creates a discovery job and adds it to the jobs list on the Discovery tab. 
When the job starts, you can view its progress by selecting it in the upper pane. 
The messages generated during the job’s progress appear in the Job Logs pane 
(the lower pane).

If discovery is successful, then for each physical SAN fabric the seed MDS 
switch, its active VSANs, and all of the MDS switches that participate in those 
VSANs are discovered and appear in the device selector on the Resources tab. The 
switch ports are also discovered, but they appear in the details table. 

Next Step

After you discover the SAN fabric seed MDS switch, you can manage its 
components, such as its VSANs, storage array target ports, and LUNs (see 
Managing and Unmanaging SAN Fabric Components, page 7-22). 
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Related Topics

• Understanding Discovery, page 6-1

• Configuring SNMP Credentials for SAN Fabric Devices, page 4-11

Discovering NAS Filers and Their Components

You can discover NAS filers and its volumes, QTrees, and CIFS shares.

Before You Begin

• Set up the NAS filer (see Setting Up NAS Filers, page 3-16).

• Configure NAS credentials in VFrame (see Configuring NAS Credentials, 
page 4-10).

Procedure

Step 1 Select Tools > Discovery to open the Discovery tab (see Discovery Tab, 
page 6-21).

Step 2 Click New to open the Schedule Editor dialog box.

Step 3 Click the NAS Filers tab (see NAS Filers Tab, page 6-26).

Step 4 (Optional) To change the system-assigned job name, select the name and enter a 
new one.

Step 5 Do one of the following:

• To use the IP address or DNS name of a previously discovered NAS filer, 
select the Rediscover Currently Managed NAS Filers check box, then 
select the NAS filer from the displayed list.

• In the IP Address/DNS Name field, enter the IP address or DNS name of the 
NAS filer.

Step 6 In the Type of Discovery field, select one of the following:

• Run Now—To start the discovery job immediately when you click OK.

• Schedule—To select a schedule for the job to run it in the future. Select the 
date and time when you want the job to run.
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If you schedule the discovery job, you can also select Enable Repeat to 
schedule the job to be rerun until you cancel the job. Select the frequency time 
period (such as hour or day), and enter the number of time periods for the 
recurrence schedule. For example, selecting 2 Weeks causes the discovery 
job to be rerun every 2 weeks until canceled.

Step 7 Click OK.

VFrame creates a discovery job and adds it to the jobs list on the Discovery tab. 
When the job starts, you can view its progress by selecting it in the upper pane. 
The messages generated during the job’s progress appear in the Job Logs pane 
(the lower pane).

If discovery is successful, the discovered NAS filer appears in the device selector 
on the Resources tab. The volumes, QTrees, and CIFS shares appear in the details 
table.

Next Step

After you discover the NAS filer, you can manage its volumes, QTrees and CIFS 
shares (see Managing and Unmanaging NAS Filer Components, page 7-20). 

Related Topics

• Understanding Discovery, page 6-1

• Configuring NAS Credentials, page 4-10

Discovering Storage Arrays and Their Components Through Storage Managers

You can discover storage arrays and their port and logical unit information by 
discovering storage managers.

Before You Begin

You must do the following tasks before you run storage manager discovery to 
discover storage arrays and their components:

1. Set up the storage manager (see Setting Up Storage Managers, page 3-18).

2. Create storage manager templates (see Creating and Modifying Storage 
Manager Templates, page 11-77).
6-11
Cisco VFrame Data Center 1.1 Administration Guide

OL-10400-01



 

Chapter 6      Discovering Devices
    Discovering Devices
3. Define the storage managers for the storage manager templates (see Defining 
Storage Managers, page 11-80).

4. Configure the storage manager credentials in VFrame (see Configuring 
Storage Manager Credentials, page 4-13).

Procedure

Step 1 Select Tools > Discovery to open the Discovery tab (see Discovery Tab, 
page 6-21).

Step 2 Click New to open the Schedule Editor dialog box.

Step 3 Click the Storage Manager tab (see Storage Managers Tab, page 6-29).

Step 4 (Optional) To change the system-assigned job name, select the name and enter a 
new one.

Step 5 Select the storage managers you want to discover.

Step 6 In the Type of Discovery field, select one of the following:

• Run Now—To start the discovery job immediately when you click OK.

• Schedule—To select a schedule for the job to run it in the future. Select the 
date and time when you want the job to run.

If you schedule the discovery job, you can also select Enable Repeat to 
schedule the job to be rerun until you cancel the job. Select the frequency time 
period (such as hour or day), and enter the number of time periods for the 
recurrence schedule. For example, selecting 2 Weeks causes the discovery 
job to be rerun every 2 weeks until canceled.

Step 7 Click OK.

VFrame creates a discovery job and adds it to the jobs list on the Discovery tab. 
When the job starts, you can view its progress by selecting it in the upper pane. 
The messages generated during the job’s progress appear in the Job Logs pane 
(the lower pane).

If discovery is successful, the storage arrays that are configured to be discovered 
through the selected storage managers and their port and logical unit information 
appear in the device selector on the Resources tab. 
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Next Steps

After you discover the storage manager, you can manage the LUNs and ports in 
the storage array (see Managing and Unmanaging Storage Arrays and Their 
Components, page 7-27). 

Related Topics

• Understanding Discovery, page 6-1

• Configuring Storage Manager Credentials, page 4-13

Discovering Servers
Table 6-1 is an overview of the steps you must take before you discover servers.

Discovering LOM Interfaces and the Server Inventory Through LOM Managers

Before you can discover servers, you must discover the server inventory as it is 
defined on the LOM managers. The inventory includes information about the 
LOM interfaces on each server. VFrame discovers and manages the server by 
controlling it through the LOM interface.

Table 6-1 Workflow for Server Discovery

Task

Step 1 Configure a DHCP IP address range and configure DHCP helpers if necessary. 
See these topics:

• Configuring DHCP in VFrame, page 5-6

• Configuring DHCP Relay Agents in Ethernet Switches, page 5-4

Step 2 Discover the LOM interfaces and server inventory defined on the LOM 
managers.

See Discovering LOM Interfaces and the Server Inventory Through LOM 
Managers, page 6-13.

Step 3 Discover the servers for unassociated LOM interfaces. 

See Discovering Application Servers for Unassociated LOM Interfaces, 
page 6-15.
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Before You Begin

You must do the following tasks before you discover LOM interfaces and the 
server inventory:

1. Set up the LOM manager. See these topics:

– Creating the LOM Interface and Application Server Inventory File, 
page 3-24

– Configuring VFrame as a LOM Manager, page 3-26

– Setting Up Independent LOM Managers, page 3-28

2. (Optional) Create LOM manager templates (see Creating and Modifying 
LOM Manager Templates, page 11-84). If the predefined templates fit your 
needs, you can use them instead of creating your own.

3. Define the LOM managers based on the LOM manager templates (see 
Defining LOM Managers, page 11-87).

4. Configure the LOM Manager and LOM interface credentials in VFrame (see 
Configuring Server Credentials, page 4-14).

Procedure

Step 1 Select Tools > Discovery to open the Discovery tab (see Discovery Tab, 
page 6-21).

Step 2 Click New to open the Schedule Editor dialog box.

Step 3 Click the LOM Managers tab (see LOM Managers Tab, page 6-30).

Step 4 (Optional) To change the system-assigned job name, select the name and enter a 
new one.

Step 5 Select the LOM managers whose inventory you want to discover.

Step 6 In the Type of Discovery field, select one of the following:

• Run Now—To start the discovery job immediately when you click OK.

• Schedule—To select a schedule for the job to run it in the future. Select the 
date and time when you want the job to run.
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If you schedule the discovery job, you can also select Enable Repeat to 
schedule the job to be rerun until you cancel the job. Select the frequency time 
period (such as hour or day), and enter the number of time periods for the 
recurrence schedule. For example, selecting 2 Weeks causes the discovery 
job to be rerun every 2 weeks until canceled.

Step 7 Click OK.

VFrame creates a discovery job and adds it to the jobs list on the Discovery tab. 
When the job starts, you can view its progress by selecting it in the upper pane. 
The messages generated during the job’s progress appear in the Job Logs pane 
(the lower pane).

If discovery is successful, the LOM interfaces and server inventory appear in the 
Details Table associated with each discovered LOM manager on the Resources tab 
(right-click the LOM manager in the device selector and click Show Details 
Table). 

Related Topics

• Understanding Discovery, page 6-1

• LOM Manager Templates, page 11-81

• Configuring Server Credentials, page 4-14

Discovering Application Servers for Unassociated LOM Interfaces

After you discover a LOM manager, the details table for the LOM manager lists 
all LOM interfaces contained in the LOM manager’s inventory. Any LOM 
interfaces that belong to undiscovered servers are listed in the Unassociated 
LOMs section of the table. These are the servers that you need to discover. After 
discovering a server, the server is added to the Servers folder in the device 
selector.

Before You Begin

• Set up the server (see Setting Up Application Servers, page 3-20).

• Discover the LOM managers (see Discovering LOM Interfaces and the Server 
Inventory Through LOM Managers, page 6-13).
6-15
Cisco VFrame Data Center 1.1 Administration Guide

OL-10400-01



 

Chapter 6      Discovering Devices
    Discovering Devices
• Create an appropriate DHCP IP address range for use during server discovery 
(see Adding or Modifying DHCP IP Address Ranges, page 5-6).

• Configure the LOM interface credentials in VFrame (see Configuring Server 
Credentials, page 4-14).

Procedure

Step 1 From the Resources tab (select View > Resources), right-click the LOM manager 
in the device selector and select Show Details Table. 

The details table lists the LOM interface information for each server listed in the 
LOM manager’s inventory file.

Step 2 From the filter field, select Unassociated LOMs. This list contains all of the 
servers that have not yet been discovered, based on their LOM interfaces.

Step 3 Select one or more unassociated LOM interfaces, right-click and select Power 
Off. This action ensures that all servers are powered off. 

Tip We recommend that you select a maximum of 10 interfaces at a time to 
keep resource utilization reasonable. You should also not select more 
servers than you have IP addresses in your DHCP IP address range table.

Step 4 Right-click the unassociated LOM interfaces you powered off and select 
Power On.

Powering on the server boots it. If the server is configured correctly, it PXE boots. 
VFrame acts as the DHCP server and responds to the boot message with these 
items:

• IP address from the appropriate DHCP IP address range.

• The inventory OS. After the inventory OS runs on the server, VFrame obtains 
the server’s hardware inventory, such as its CPU type, speed, memory, and 
system partitions.

It will take some time for the servers to finish booting and sending their physical 
attributes to VFrame. When the process finishes, the servers appear in the Servers 
folder in the device selector.
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Tips

• You can also discover the server by PXE booting it directly (outside of the 
VFrame interface). We recommend that you use a serial terminal connection 
to connect to the servers. Messages that are not displayed on the LOM web 
interface are displayed on the serial terminal.

Next Step

After you discover the servers, you can manage them (see Managing and 
Unmanaging Application Servers, page 7-30). 

Related Topics

• Understanding Discovery, page 6-1

• Configuring Server Credentials, page 4-14

Viewing the Discovery Status
You can view the status of discovery jobs on the Discovery tab. If there are a large 
number of jobs, you can filter the list to show only those jobs that interest you, 
such as those scheduled to run in the future or those currently running.

Procedure

Step 1 Select Tools > Discovery to open the Discovery tab (see Discovery Tab, 
page 6-21).

The upper pane includes a list of discovery jobs with summary information about 
each job.

To reduce the number of jobs displayed, click Filter, select the job characteristics 
that interest you, and click OK. Jobs that do not satisfy the filter are not displayed.

Click Show All to remove the filter.

Step 2 To view the detailed log messages for a job, select the job in the upper pane. The 
log for the job appears in the Job Logs pane in the lower half of the window. The 
job log includes all messages returned during the job. It is continually updated for 
currently running jobs.

You can filter this list by selecting a severity level, which shows you only 
messages of the selected severity level.
6-17
Cisco VFrame Data Center 1.1 Administration Guide

OL-10400-01



 

Chapter 6      Discovering Devices
    Discovering Devices
Click the Task Results tab to view messages related to macro execution for LOM 
manager and storage manager discovery jobs.

Related Topics

• Understanding Discovery, page 6-1

• Schedule Editor Dialog Box, page 6-24

Rescheduling or Unscheduling Discovery Jobs
You can reschedule or unschedule discovery jobs from the Discovery tab (select 
Tools > Discovery). Changing the job schedule is typically done for jobs that are 
scheduled to recur, that is, to perform periodic rediscovery. Rediscovery updates 
the device inventory and identifies changes to resources that VFrame already 
knows about.

These are your options for discovery job management:

• Reschedule—You can reschedule any job, even one that is not scheduled to 
repeat. Select the job, and click Reschedule. You can then change any 
characteristic of the job. This activity is essentially the same as creating the 
initial discovery job, and in some cases rescheduling actually creates a new 
discovery job. For detailed information on creating discovery jobs, see these 
topics:

– Discovering Ethernet Switches and Service Modules, page 6-6

– Discovering Storage Devices, page 6-8

– Discovering Servers, page 6-13

• Unschedule—You can unschedule any job that is scheduled to start at some 
future time. These jobs have the Scheduled status. Select the desired job and 
click Unschedule. This prevents the job from running. If you change your 
mind, you can reschedule the job. Note that you cannot delete a discovery job 
after you create it.
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Related Topics

• Understanding Discovery Jobs, page 6-2

• Understanding How Discovery, Rediscovery, and Reinventory Differ, 
page 6-4

• Device Rediscovery Tips, page 6-5

Troubleshooting Discovery
These are some problems you might encounter when discovering devices and their 
solutions: 

• You cannot discover the Ethernet switch.

• VFrame did not save the DHCP range that you just created.

• The switch port’s MAC address reported by SNMP is invalid.

• Service modules are getting module missing faults, but they are physically 
present and functional.

Problem You cannot discover the Ethernet switch.

Solution This problem can occur if you did not configure the SNMP read 
community string on the physical switch. Configure the SNMP credentials on the 
switch, enter the same credentials in VFrame, then try to discover the switch 
again.

Problem VFrame did not save the DHCP range that you just created.

Solution This occurs if after entering the DHCP range in the DHCP entry dialog 
box, you did not click the OK button in the DHCP dialog box. Even though the 
address range appears in the DHCP table, you must click the OK button in the 
DHCP dialog box to save your additions, deletions, or changes to the table.
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Problem The switch port’s MAC address reported by SNMP is invalid.

Solution This occurs if the switch port that is connected to the server is down or 
is not associated with a VLAN. To resolve this, make sure that the switch port that 
is connected to the server is up, then run switch discovery again. The switch port 
configuration must contain the following commands: 

switchport
switchport access vlan <vlan #>
no ip address 

Make sure that the switch port configuration does not contain the shutdown 
command.

Problem Service modules are getting module missing faults, but they are 
physically present and functional.

Solution Check the SNMP community string settings on the switch. If you 
configured the same name for read and trap community strings, VFrame cannot 
identify that the discovery or inventory problem is the fact that VFrame does not 
have a valid SNMP read community string. Therefore, VFrame generates module 
missing faults. Reenable the read community string. Cisco recommends that you 
use unique read community strings, ones that are not the same as a trap 
community string. If you change the string name, you also need to update the 
device credentials in VFrame (select Tools > Device Credentials).

Discovery Reference
These topics describe the main tab and dialog boxes you use when discovering 
devices:

• Discovery Tab, page 6-21

• Schedule Editor Dialog Box, page 6-24
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Discovery Tab
Use the Discovery tab to view the status of the discovery job, to specify the DHCP 
range for server discovery, and to initiate or schedule discovery for network 
devices, NAS filers, SAN fabric devices, storage managers, and LOM managers. 

How to Get to This Page

Select Tools > Discovery to open the Discovery tab.

Related Topics

• Understanding Discovery, page 6-1

• Discovering Devices, page 6-6

• Viewing the Discovery Status, page 6-17

• Rescheduling or Unscheduling Discovery Jobs, page 6-18

• Troubleshooting Discovery, page 6-19

Field Reference

Table 6-2 Discovery Tab

Element Description

DHCP button Click this button to open the DHCP dialog box, in which you enter the DHCP 
IP address ranges for server discovery or golden image creation (see DHCP 
Dialog Box, page 5-9). 

New button Click this button to open the Schedule Editor dialog box, which enables you 
to schedule discovery for Ethernet switches, NAS filers, SAN fabric devices, 
storage managers, and LOM managers (see Schedule Editor Dialog Box, 
page 6-24).

Reschedule button Click this button to reschedule the selected discovery job. The Schedule 
Editor dialog box opens for you to reschedule the job (see Rescheduling or 
Unscheduling Discovery Jobs, page 6-18).

When the devices are rediscovered, the device inventory is updated and the 
updated list is displayed in the device selector in the Resources tab.

Unschedule button Click this button to unschedule a scheduled discovery job, which effectively 
cancels the job. You cannot cancel a running job.
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Upper Pane

Filter button

If a filter is applied to 
the list, the button name 
is shown as:

Filter... (filtered)

Opens the Filter dialog box, where you can select a job type to reduce the 
size of the job list and display only those jobs that you want to see. The 
following are filter elements:

• Job Type—The type of job you want to see, related to the action 
performed by the job, arranged hierarchically in folders. Select a folder 
to select all job types in the folder. If you want to select only one or two 
job types, first deselect All, then make your selections.

• Status—The job status. For example, you can elect to view jobs that are 
currently running or that are scheduled to run in the future.

• Time Range—Whether to view all jobs no matter when they ran (All), 
or to view jobs that ran on specific dates within specific times (Range).

• Max Results—The maximum number of results you want to see. For 
past jobs, the most recent ones are selected over older jobs.

• Apply button—Click this button to apply your filter to the list without 
closing the Filter dialog box. Click OK to apply the filter and close the 
dialog box.

• Reset—Click this button to reset all filter values to their defaults (which 
is to view all jobs without date and time restrictions).

Show All Click this button to display all jobs, removing any filter that is currently set. 
To reapply the filter, click Filter to open the Filter dialog box (which retains 
the previous filter values), then click OK.

Name The name assigned to the discovery job.

Type The type of discovery job.

Status The status of the job. The status Scheduled indicates the job is scheduled to 
run in the future. Scheduled and Unscheduled jobs do not have job log 
entries (in the bottom pane).

Start Time The date and time the job started. For scheduled jobs, when it is scheduled 
to run next.

Percent Complete How much of the job has finished.

Duration The amount of time the job took to finish.

Table 6-2 Discovery Tab (continued)

Element Description
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Job Logs Tab (Lower Pane)

The log shows the messages for the job you select from the upper pane. To change the sorting order of 
the messages, click the column title on which you want to sort.

Job Log Filters Use the filter to reduce the size of the list and show only those messages you 
want to see. Filter elements include:

• Severity—The severity level of the message.

Time The date and time the message was logged.

Severity The severity level of the message. 

Entry The job log message received from the server.

Task Results Tab (Lower Pane)

The Task Results tab shows the messages for the macro events for the LOM manager or storage 
manager discovery job you select from the upper panel, if any macros were executed during the job. 
To change the sorting order of the messages, click on the column title on which you want to sort.

Each task has an associated job log you can view to see detailed execution information.

Details button Click this button to open the Log Record Details dialog box for the selected 
row, which is the same as double-clicking the row or selecting Show Details 
from the right-click shortcut menu.

The Log Record Details dialog box displays the message information in a 
more readable format. You can use the < and > buttons to scroll through the 
task result summaries.

Logs button Click this button to open the macro execution log for the selected row, if 
there is a log associated with the action. The log includes the commands sent 
to the device and the device prompts and responses. Logs are only available 
for user-defined macros.

Perl Routine button Click this button to open the Perl file that was generated before running the 
macro for the selected row. This button is active only for user-defined 
macros.

Variable File button Click this button to view the variable values that were generated before 
running the macro for the selected row. This button is active only for 
user-defined macros.

Status The status of the action, indicating whether it was successful.

Table 6-2 Discovery Tab (continued)

Element Description
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Schedule Editor Dialog Box
Use the Schedule Editor dialog box to initiate or schedule discovery for network 
devices, NAS filers, SAN fabric devices, storage managers, and LOM managers. 
See these topics for detailed information:

• Network Tab, page 6-25

• NAS Filers Tab, page 6-26

• SAN Fabric Devices Tab, page 6-27

Last Update Time Time the action was completed.

Event Type The type of event that occurred. Use the information in the Event Name field 
instead of this field.

Event Name The type of event that occurred. For a complete list of event types, see 
Events, page 11-6.

Action The name of the action.

Action Type Whether the action was system- or user-initiated. User-defined events or 
macros have the User action type.

Message The error or informational message issued after the action occurred.

Resource The physical resource associated with the target element.

Source SNE Name The name of the service network element that performed the action. Because 
these are discovery jobs, which are not related to a specific service network, 
the service network element is typically the LOM manager or storage 
manager, and the source and target SNE names are the same.

Target SNE Name The name of the target service network element on which the action 
occurred.

Prev. Reset Status The status of the error before it was cleared. If there is no previous status, 
NA is displayed.

Reset By The username of the person who cleared the error. If there is no previous 
error reset, NA is displayed.

Table 6-2 Discovery Tab (continued)

Element Description
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• Storage Managers Tab, page 6-29

• LOM Managers Tab, page 6-30

How to Get to This Dialog Box

Select Tools > Discovery to open the Discovery tab, then click New to open the 
Schedule Editor dialog box. Click the appropriate tabs to initiate or schedule 
discovery. 

Network Tab

Use the Network tab for network device discovery. Enter the IP address of the 
CDP seed device. VFrame discovers all the neighboring switches (in the specified 
distance) that are directly connected to the seed device (Ethernet switch) and 
obtains information about those devices. 

How to Get to This Tab

Select Tools > Discovery to open the Discovery tab, click New to open the 
Schedule Editor dialog box, and then click Network. 

Related Topics

• Discovering Ethernet Switches and Service Modules, page 6-6

• Understanding Discovery, page 6-1

Field Reference

Table 6-3 Network Tab

Element Description

Name The name of the discovery job.

Rediscover Currently 
Managed Devices

Whether to use the devices that you have already managed as CDP seeds. 
You cannot enter additional CDP seeds if you select this check box.

Seeds The DNS name or the IP address of CDP seed devices to which neighboring 
devices are connected. The seed device is used as the root device for network 
discovery.
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NAS Filers Tab

Use the NAS Filers tab for NAS filer discovery. When you provide the IP address 
or DNS name of the NAS filer, VFrame discovers the NAS filer, its volumes, 
QTrees, and CIFS shares. 

How to Get to This Tab

Select Tools > Discovery to open the Discovery tab, click New to open the 
Schedule Editor dialog box, and then click NAS Filers.

CDP Distance Determines the extent of discovery and applies to all seed devices. 

If CDP distance is 1, only the immediate neighbors of the seed device are 
discovered. If CDP distance is 2, devices A and B that are directly connected 
to the seed devices are discovered and the immediate neighbors of A and B 
are also discovered. Default is 0.

Select Type of Discovery

Run Now radio button Click this radio button, and then click OK to start discovery immediately.

Schedule radio button Click this radio button, set the start date and time, and then click OK to start 
discovery on the scheduled date and time. The time zone is the same as the 
one configured on VFrame.

Start Date The date to begin discovery. 

Start Time The time to begin discovery.

Enable Repeat Whether you want the discovery job to be rerun at the defined interval until 
the job is canceled.

Every The frequency of time periods for repeating the discovery job. The default is 
1. 

In the corresponding field, select the frequency time period: minutes, hours, 
days, or weeks. For example, selecting 2 Weeks causes the discovery job to 
be rerun every 2 weeks until canceled.

Table 6-3 Network Tab (continued)

Element Description
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Related Topics

• Discovering NAS Filers and Their Components, page 6-10

• Understanding Discovery, page 6-1

Field Reference

SAN Fabric Devices Tab

Use the SAN Fabric Devices tab for MDS switch and VSAN discovery. When you 
provide the IP address or DNS name of a seed MDS switch for a physical fabric, 
VFrame discovers the switch’s active VSANs and all neighboring MDS switches 
in that physical fabric that have member ports in the same active VSANs.

Table 6-4 NAS Filers Tab

Element Description

Name The name of the discovery job.

Rediscover Currently 
Managed NAS Filers

Whether to use the IP address or DNS name that you used previously for 
NAS filer discovery. You cannot enter additional IP addresses or DNS names 
if you select this check box.

IP Address/DNS Name The IP address or the DNS name of the NAS filer.

Select Type of Discovery

Run Now radio button Click this radio button, and then click OK to start discovery immediately.

Schedule radio button Click this radio button, set the start date and time, and then click OK to start 
discovery on the scheduled date and time. The time zone is the same as the 
one configured on VFrame.

Start Date The date to begin discovery. 

Start Time The time to begin discovery.

Enable Repeat Whether you want the discovery job to be rerun at the defined interval until 
the job is canceled.

Every The frequency of time periods for repeating the discovery job. The default is 
1. 

In the corresponding field, select the frequency time period: minutes, hours, 
days, or weeks. For example, selecting 2 Weeks causes the discovery job to 
be rerun every 2 weeks until canceled.
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How to Get to This Tab

Select Tools > Discovery to open the Discovery tab, click New to open the 
Schedule Editor dialog box, and then click SAN Fabric Devices.

Related Topics

• Discovering SAN Fabric Devices and Their Components, page 6-8

• Understanding Discovery, page 6-1

Field Reference

Table 6-5 SAN Fabric Devices Discovery Tab

Element Description

Name The name of the discovery job.

Rediscover Currently 
Managed Fabrics

Whether to use the seed MDS switch IP addresses or DNS names that you 
had used previously for SAN fabric device discovery. You cannot enter 
additional seeds if you select this check box.

SAN Fabric Seed 1 The IP address or DNS name of the seed MDS switch in the first physical 
SAN fabric. If you have only one physical fabric, use only the Seed 1 field.

SAN Fabric Seed 2 The IP address or DNS name of the seed MDS switch in the second physical 
SAN fabric, if you have two fabrics. 

Select Type of Discovery

Run Now radio button Click this radio button, and then click OK to start discovery immediately.

Schedule radio button Click this radio button, set the start date and time, and then click OK to start 
discovery on the scheduled date and time. The time zone is the same as the 
one configured on VFrame.

Start Date The date to begin discovery. 

Start Time The time to begin discovery.

Enable Repeat Whether you want the discovery job to be rerun at the defined interval until 
the job is canceled.

Every The frequency of time periods for repeating the discovery job. The default is 
1. 

In the corresponding field, select the frequency time period: minutes, hours, 
days, or weeks. For example, selecting 2 Weeks causes the discovery job to 
be rerun every 2 weeks until canceled.
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Storage Managers Tab

Use the Storage Manager tab to discover storage arrays through storage managers. 
When you select a storage manager and run discovery, VFrame discovers storage 
arrays that are configured to be discovered through that storage manager and the 
related port and logical unit information.

How to Get to This Tab

Select Tools > Discovery to open the Discovery tab, click New to open the 
Schedule Editor dialog box, and then click Storage Managers.

Related Topics

• Discovering Storage Arrays and Their Components Through Storage 
Managers, page 6-11

• Understanding Discovery, page 6-1

Field Reference

Table 6-6 Storage Manager Tab

Element Description

Name The name of the discovery job.

Managers Lists the storage managers you defined. Select the storage managers whose 
storage arrays you want to discover. For information on defining storage 
managers, see Defining Storage Managers, page 11-80.

Select Type of Discovery

Run Now radio button Click this radio button, and then click OK to start discovery immediately.

Schedule radio button Click this radio button, set the start date and time, and then click OK to start 
discovery on the scheduled date and time. The time zone is the same as the 
one configured on VFrame.

Start Date The date to begin discovery. 

Start Time The time to begin discovery.

Enable Repeat Whether you want the discovery job to be rerun at the defined interval until 
the job is canceled.
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LOM Managers Tab

Use the LOM Managers tab to discover LOM interfaces in a server through LOM 
managers. 

How to Get to This Tab

Select Tools > Discovery to open the Discovery tab, click New to open the 
Schedule Editor dialog box, and then click LOM Managers.

Related Topics

• Discovering LOM Interfaces and the Server Inventory Through LOM 
Managers, page 6-13

• Understanding Discovery, page 6-1

Field Reference

Every The frequency of time periods for repeating the discovery job. The default is 
1. 

In the corresponding field, select the frequency time period: minutes, hours, 
days, or weeks. For example, selecting 2 Weeks causes the discovery job to 
be rerun every 2 weeks until canceled.

Table 6-6 Storage Manager Tab (continued)

Element Description

Table 6-7 LOM Managers Tab

Element Description

Name The name of the discovery job.

Managers LOM managers you defined. Select a LOM manager to run discovery. For 
information on defining LOM managers, see Defining LOM Managers, 
page 11-87.

Select Type of Discovery

Run Now radio button Click this radio button, and then click OK to start discovery immediately.
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Schedule radio button Click this radio button, set the start date and time, and then click OK to start 
discovery on the scheduled date and time. The time zone is the same as the 
one configured on VFrame.

Start Date The date to begin discovery. 

Start Time The time to begin discovery.

Enable Repeat Whether you want the discovery job to be rerun at the defined interval until 
the job is canceled.

Every The frequency of time periods for repeating the discovery job. The default is 
1. 

In the corresponding field, select the frequency time period: minutes, hours, 
days, or weeks. For example, selecting 2 Weeks causes the discovery job to 
be rerun every 2 weeks until canceled.

Table 6-7 LOM Managers Tab (continued)

Element Description
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