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C H A P T E R13

Common Monitoring Console Tasks

These topics explain how to perform typical operator tasks from the 
Monitoring Console. Related tasks are categorized as follows:

• Opening the Monitoring Console, page 13-2

• Closing the Monitoring Console, page 13-3

• Domain Manager Tasks, page 13-4

• Alarm Log Tasks, page 13-5

• Managing the Monitoring Console Layout, page 13-13

• Displaying the DFM Inventory with the Inventory Browser, page 13-16

• Changing Your Subscription Profile, page 13-22

• Invoking User Actions for Notifications, page 13-27

For information on starting or configuring a domain manager, see 
Chapter 11, “Administering DFM.”

Note All times displayed on the Monitoring Console represent the server time adjusted 
to the client time zone.
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Opening the Monitoring Console
These topics describe how to open your Monitoring Console:

• Opening the Monitoring Console from the CiscoWorks Desktop, page 13-2

• Opening the Monitoring Console from Any Running Console, page 13-2

• Opening the Monitoring Console from a Remote Saved Console Running 
DFM, page 13-3

Opening the Monitoring Console from the CiscoWorks Desktop
To open a Monitoring Console, select Device Fault Manager > Monitoring 
Console. This opens a Monitoring Console that, by default, does not display the 
Inventory Browser.

Opening the Monitoring Console from Any Running Console
You can also open a new Monitoring Console from any running console in a 
session. From any running console, select File > New  > Monitoring Console (or, 
from the Administration Console, click the Monitoring Console toolbar button).

This opens a Monitoring Console that, by default, does display the Inventory 
Browser, and attaches it to the same domain manager as the running console. The 
Monitoring Console automatically receives notifications. The new Monitoring 
Console is part of the same session as the running console.
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Opening the Monitoring Console from a Remote Saved Console 
Running DFM

You can open a console saved on the host where the domain manager is running.

Step 1 From any running console, select File  > Open >  Open Remote, or click the 
Open Remote toolbar button. This displays the Open Remote Console dialog.

Step 2 In the Open Remote Console dialog, click the Console drop-down box to display 
the list of available consoles.

Step 3 Select a console and click the OK button. This opens the console.

Closing the Monitoring Console
Three methods exist to close your Monitoring Console (closing the console does 
not affect the operation of the domain manager):

• Select File  > Close in the open Monitoring Console. 

The Close command closes an individual console and the session continues. 
When you close the last Monitoring Console, you end the DFM session. 

• Select File  > Exit.

The Exit command closes all consoles that are part of the session and the 
session ends. 

• Close your Web browser.

Note When you log out of CiscoWorks, the Monitoring Console remains displayed for 
continuous viewing. To close the console, you must explicitly close it or the Web 
browser.
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Domain Manager Tasks
These topics describe typical domain manager tasks:

• Attaching to the Domain Manager, page 13-4

• Detaching from the Domain Manager, page 13-5

• Checking Domain Manager Status, page 13-5

Attaching to the Domain Manager
When you open a Monitoring Console from the Device Fault Manager drawer of 
the CiscoWorks desktop, you automatically attach to the domain manager at the 
hostname entered as the URL in the address field of your browser. If you detach 
from this domain manager, you can attach to it again at any time.

The attach operation connects your console to a domain manager. You attach the 
Monitoring Console to a domain manager to receive notifications, to examine the 
cause of failures, and to view the DFM inventory of a domain manager. You 
should note that different consoles attached to the same domain manager can 
display different views of the same managed domain. 

Step 1 To attach to the domain manager, select Attach from the Domain menu or click 
the Attach toolbar button. This displays the Attach Domain Manager dialog.

Step 2 For the Broker field, enter the hostname of the URL where the domain manager 
is running and port 9002 (in the format hostname:9002).

Step 3 For the Domain field, select DFM from the drop-down box.

Step 4 Click the OK button.
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Detaching from the Domain Manager
Detach from a domain manager when you no longer want to interact with it. The 
detach operation does not stop the domain manager.

Step 1 To detach from a domain manager, select Detach from the Domain menu or click 
the Detach toolbar button in the Monitoring Console.

Step 2 Click the Yes button to confirm the detach.

Checking Domain Manager Status
The Browse button in the Attach Domain Manager dialog lists the domain 
manager and its status. The status listed for your domain manager should be 
Running. If your domain manager is not running, contact your administrator or 
consult Chapter 11, “Administering DFM,” for instructions on how to start the 
domain manager. 

Alarm Log Tasks
These topics describe how to use the Alarm Log:

• Removing (Clearing) Notifications, page 13-6

• Customizing the Alarm Log View with Filters, page 13-7

• Rearranging Alarm Log Columns, page 13-12

• Sorting Alarm Log Contents (Notifications), page 13-12

Note Although the Log > Save to File command appears in the Monitoring Console, it 
is greyed-out because it is not supported. Use the File Notifier Adapter instead. 
For more information, see the Configuring the File Notifier Adapter, page 10-17.
13-5
User Guide for Device Fault Manager

78-14235-01



 

Chapter 13      Common Monitoring Console Tasks
Alarm Log Tasks
Removing (Clearing) Notifications
Several methods exist to remove notifications from an Alarm Log:

• Select Remove Cleared Events from the Log menu to remove inactive 
notifications (transparent or white). You can also right-click on the cleared 
event and select Delete.

• Select the check box for the automatic removal option in the Alarm Filter 
Criteria dialog to remove notifications as soon as they become inactive. To 
open the Alarm Filter Criteria dialog, select Filter from the Log menu or 
right-click and select Filter from the popup menu (right-click the log’s title 
bar).

• Select Clear Log from the Log menu to remove all notifications. You can also 
right-click on the Alarm Log and select Clear Log from the popup menu.

• Select an active notification in an Alarm Log or property sheet. (To select 
multiple notifications, press the Ctrl key while making your selections.) 
Then, click the ACK toolbar button or select Acknowledge from the Event 
menu to remove the notification from all Alarm Logs. This will remove the 
notification from your Monitoring Console instance, but not from other 
Monitoring Console instances. Note the following:

– If the acknowledged alarm continues to occur, it will continue to appear 
in other Monitoring Console instances.

– If the alarm becomes inactive (does not recur for ten minutes) and then 
becomes active, it will reappear in your Monitoring Console instance, 
and its count will continue to increment.

• Right-click on the inactive notification you wish to delete in an Alarm Log 
and select Delete from the popup menu. To remove all inactive alarms, select 
Log > Remove Cleared Events.
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Customizing the Alarm Log View with Filters
The Alarm Log view displays a list of notifications. You can customize the view 
using filters. Filters are used to control information in the Alarm Log view so you 
can immediately recognize the important messages. Only incoming notifications 
that match your filter criteria are displayed.

To customize an Alarm Log, perform these steps:

Step 1 Click on the Alarm Log to activate it. The active view has a dark gray border.

Step 2 Open the Alarm Filter Criteria dialog. Select Filter from the Log menu or from 
the popup menu (right-click the log’s title bar). 

Step 3 Complete one or more of the four tabs in the Alarm Filter Criteria dialog: General, 
Numerical, Choices, and Expressions. The options under each tab control the 
display of notifications in the Alarm Log. Only incoming notifications that match 
your filter criteria specified in all four tabs are displayed.

Note When filtering is enabled, a small box icon appears in the upper left corner of the 
log.

Figure 13-1 Alarm Filter Criteria Dialog
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General Tab

The General tab (Figure 13-1) provides a field for naming the Alarm Log, a field 
for setting the update interval for notifications, and a check box for automatically 
removing cleared events from the Alarm Log.

• The Title field enables you to provide a name for the Alarm Log. This is 
useful when you have multiple Alarm Logs, each with different filtering 
criteria.

• The Update period field controls how often the Alarm Log is updated. You 
should balance the update period between timely updates and the processing 
resources required to continually update the Alarm Logs. The default update 
period is 30 seconds. Check with your systems administrator about an 
appropriate setting.

• The check box Automatically remove cleared events determines whether the 
console removes events after they are no longer active. By default, this is 
disabled so that cleared events, which appear white, remain listed in the 
Alarm Log.
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Numerical Tab

Numerical filtering (Figure 13-2) sets criteria that incoming notifications must 
meet before they are displayed in the Alarm Log.

Figure 13-2 Alarm Filter Criteria Dialog–Numerical

• Enable Numerical Filtering enables or disables numerical filtering. 
Numerical Filtering is enabled by default.

• Minimum count is a threshold for how many times an event must recur before 
it is displayed. The default value of zero (0) specifies that events are displayed 
the first time they occur.

• Minimum certainty is the certainty a notification must have to be displayed. 
Symptomatic event and compound event notifications are always assigned a 
certainty of 100%. The certainty is a value between 1 and 100, where 100 is 
the highest level of certainty. The default Minimum Certainty of 1 means that 
all notifications with a certainty of at least 1% are displayed. 
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Choices Tab

The Choices tab (Figure 13-3) enables you to filter notifications by type, domain, 
and class. The dialog is divided into three sections: Show Types, Show Domains, 
and Show Classes. The items that are selected in each section determine which 
notifications are displayed. You can select any combination of items. (To select 
multiple items, press the Ctrl key while making your selections.) 

Figure 13-3 Alarm Filter Criteria Dialog–Choices Tab

• Show Types determines the type of notifications that are displayed. As noted 
earlier, there are two types of notifications: symptomatic events and 
compound events. 

• Show Domains determines which domain managers to display events from. 
When the console is attached to one or more domain managers, they are 
selected by default.

• Show Classes determines which events are displayed on a per-class basis. 
Because each managed object is a member of a class, you can choose to 
display notifications of selected classes. Only events that occur in objects of 
those types (classes) are displayed.
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Expressions Tab

The Expressions tab (Figure 13-4) enables you to filter notifications using 
wildcard expressions. For a list of acceptable wildcard expressions, see the 
“Wildcard Patterns” section on page 8-24.

Figure 13-4 Alarm Filter Criteria Dialog–Expressions Tab

• The check box Enable Expression Filtering enables or disables filtering with 
expressions. When enabled, expressions are used in conjunction with other 
filters that you have specified. Expression Filtering is disabled by default.

• Domain uses wildcard expressions to specify which domain managers to 
show. 

• Class uses wildcard expressions to specify which classes to show.

• Name uses wildcard expressions to specify which instances (managed 
objects) to show.

• Event uses wildcard expressions to specify which events to show.
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Rearranging Alarm Log Columns
An Alarm Log contains eight columns: Class, Name, Event, Certainty, Count, 
Last Change, First Notify, and Domain. Table 13-1 describes some of the Alarm 
Log columns.

You can change the column width or the order of columns.

• To adjust the width of a column, select the divider between column titles and 
drag it with the mouse. 

• To rearrange the order of columns, select a column title and drag it to the left 
or right.

• To hide a column, move it to the right side of the Alarm Log and pull the right 
console edge to the left until the column is hidden.

Sorting Alarm Log Contents (Notifications)
An Alarm Log uses several factors to sort notifications. Two factors are fixed and 
cannot be changed. 

• Compound events are listed above symptomatic events.

• Within each event type, active events always appear above inactive events. 

Table 13-1 Alarm Log Columns

Column Description

Certainty Describes how reliable the alarm is.

Certainty is always 100%.

Count Describes how many times the alarm has 
recurred after becoming inactive (an inactive 
alarm is one that has not recurred for ten 
minutes).

Last Change Describes when the alarm was last generated, 
relative to the current time.

First Notify Describes when the alarm was first generated.
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The third factor is a user-specified sort criterion. To sort notifications, click on the 
column title of the column you wish to use for sorting. Notice that a triangle 
marker appears in the column title. Click again to change sort order of the column. 

• Descending sort order—The triangle marker points down.

• Ascending sort order—The triangle marker points up.

The default sort column is First Notify. Columns that are moved and hidden from 
display continue to affect the sort order.

Managing the Monitoring Console Layout
This section describes how to manipulate the Monitoring Console:

• Changing the Monitoring Console’s Layout of Views, page 13-13

• Creating Multiple Views in the Monitoring Console, page 13-14

• Deleting a View from the Monitoring Console, page 13-15

• Saving a Remote Monitoring Console, page 13-15

Changing the Monitoring Console’s Layout of Views
To change the Monitoring Console layout of views in a panel, select Layout from 
the File menu to display the Console Layout dialog. In the Console Panel Layout 
section of the dialog, two drop-down menus appear:

• Panel determines which panel the Tile operation affects.

• Tile controls how multiple views in a panel are displayed. Right To Left 
places the views in a row. Top To Bottom stacks them one on top of the next.

Note You can also use the Console Layout dialog to change the name that appears in 
the title bar of the Monitoring Console. Type the new name in the Title field.
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Creating Multiple Views in the Monitoring Console
The Monitoring Console provides two views: 

• The Alarm Log view displays notifications as they occur. 

• The DFM Inventory Browser view displays the classes, their instances, and 
their relationships. 

You can display multiple copies of the views and customize each copy. To add a 
view, perform the following steps: 

Step 1 Select Add View from the View menu or click the Add View toolbar button. This 
displays the Add View dialog (Figure 13-5).

Figure 13-5 Add View Dialog

Step 2 Click the View Type drop-down menu to list the available views. Select the view 
you want to add to the console.

Step 3 Use the Console Panel drop-down menus to arrange views within the console. 

• The Panel drop-down menu determines where the view appears within the 
console.

• The Tile drop-down menu determines how multiple views within the same 
panel are arranged. Views that are oriented horizontally, such as Alarm Logs, 
usually display better when they are tiled Top To Bottom.

Step 4 Click the OK button. To add multiple views without reopening the Add View 
dialog, use the Apply button.
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To customize an Alarm Log view, refer to the “Customizing the Alarm Log View 
with Filters” section on page 13-7. To change the layout of multiple views, see the 
“Changing the Monitoring Console’s Layout of Views” section on page 13-13.

Deleting a View from the Monitoring Console
To delete a view from the Monitoring Console:

Step 1 Select the view you want to delete. The active view has a dark gray border.

Step 2 Select Delete View from the View menu or click the Delete View toolbar button.

Saving a Remote Monitoring Console
After you customize your Monitoring Console with views and filter settings, you 
can save it remotely on the host where the domain manager is running. 

Note Only your customized console is saved; notifications that are displayed are not 
saved. 

Step 1 To save a console, select File  > Save As  > Save Remote As, or click the Save 
Remote toolbar button. This displays the Save Remote Console dialog.

Step 2 In the Broker field, specify the hostname you entered as the URL for CiscoWorks 
and port number 9002 (in the format hostname:9002). By default, this information 
is automatically provided.

Step 3 In the Console field, specify the name of the console without the extension .iccon 
or select an existing console to overwrite from the pull-down menu.
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Step 4 Click the OK button.

Step 5 (Optional) To share the console with other users, from a Windows command line 
or in a Unix shell, copy the console file from the 
NMSROOT/objects/smarts/consoles/userid directory to the 
NMSROOT/objects/smarts/consoles directory on the remote host.

Note Write permission to the remote host directory is required for the copy operation.

Displaying the DFM Inventory with the Inventory 
Browser

The DFM Inventory Browser view enables you to traverse your DFM inventory. 
The view displays the domain manager, its classes, instances of each class, and 
their relations. For each object you select, a corresponding property sheet with 
tabs for Attributes, Events, and Groups is also displayed.

This section describes:

• Accessing the DFM Inventory Browser, page 13-17

• Browsing the DFM Inventory, page 13-18

• Customizing the Contents of the DFM Inventory Browser, page 13-20
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Accessing the DFM Inventory Browser
To access the DFM Inventory Browser, use one of the common methods:

• Add a DFM Inventory Browser view to your Monitoring Console. Click the 
Add View toolbar button or select Add View from the View menu. In the Add 
View dialog, click the View Type drop-down box and select Inventory 
Browser. Click the OK button. (For more information on the Add View 
dialog, see the “Creating Multiple Views in the Monitoring Console” section 
on page 13-14.)

• From the Alarm Log view, right-click on a notification and select Browse 
from the popup menu. 

• From the Notification Properties window, click the Browse button. (For more 
information on the Notification Properties window, see the “Displaying 
Notification Properties on the Monitoring Console” section on page 12-8.)

• In the DFM Inventory Browser view, select an instance, right-click, and select 
Browse from the popup menu. 

• In the DFM Inventory Browser view, select an instance and double-click on it.

• In the Find Instances dialog (from the Edit menu in the Monitoring Console), 
select an instance and click the Browse button.

If you use the first method which adds a view, only classes with instances are 
displayed. For the last five methods which involve selecting either a notification 
or an instance, the object is displayed as the tree root in a separate, new window. 
Also, you can specify an instance as a tree root by right-clicking and selecting 
Make Root in the popup menu.
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Browsing the DFM Inventory
To traverse your DFM inventory, perform these steps:

Step 1 Access the DFM Inventory Browser view. Use one of the methods described in the 
“Accessing the DFM Inventory Browser” section on page 13-17.

Step 2 To expand individual objects in the DFM inventory browser, click the plus (+) 
sign. (On some systems, an open circle appears instead of a plus sign.)

• Click the plus sign next to the domain manager icon to view its contents. 

• Click the plus sign next to a class to view its instances. 

• Click the instance to view its properties.

• Click the plus sign next to an instance to view its relations. 

• Click the plus sign next to a relation to view the classes of the related object. 
Then, click the plus sign next to each class to view the actual related 
instances.

Note In the DFM Inventory Browser view, an individual object with a plus (+) sign does 
not open or expand if the object’s contents exceeds 1000 elements. Use the Find 
Instances option in the Edit menu to display the contents of an individual object. 
Also, the tool tip displays the correct number of elements. To activate the tool tip, 
hold the cursor on the object you wish to expand.
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For additional information about an individual object, use one of the tabs in the 
property sheet:

• Attributes tab to view more information about the object.

• Events tab to view all of the events that DFM can notify for this object.

• Groups tab to view the current settings used by DFM to monitor the object.

Note If a gray line appears in place of an attribute value, the value is derived by polling 
an external device which is currently unavailable to the domain manager. The gray 
line may appear in either the Details tab of the Notification Properties window or 
the Attribute tab of a property sheet in the DFM Inventory Browser view. For more 
information, see the “Details Tab” section on page 12-10.

In Figure 13-6, the DFM Inventory Browser view displays an instance of the 
Interface class (IF-RSM-10.1.1.4/10), the instance’s relation 
(NeighboringSystems, PartOF, and Underlying), and the classes of the related 
objects (RSM and IP).
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Figure 13-6 Example of a Monitoring Console Inventory Browser View

Customizing the Contents of the DFM Inventory Browser
The DFM Inventory Browser view displays the domain manager, its classes, 
instances of each class, and their relations. You can customize the DFM Inventory 
Browser view to show all of the classes for attached domain managers or only 
certain objects.
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To customize the DFM Inventory Browser contents, perform these steps:

Step 1 Right-click in the DFM inventory browser (tree portion of the view). 

Step 2 In the popup menu, select Select to display the Select tree content dialog 
(Figure 13-7).

Figure 13-7 Inventory Browser–Select Tree Content Dialog
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Step 3 In the Select tree content dialog, you can:

• Display all of the classes including classes without instances. Select the 
check box for Show classes with no instances.

• Display a specific domain manager. Click the radio button for Domain and 
select a domain manager from the pull-down menu.

• Display one or more specific classes. Select the class. To select multiple 
classes, press the Ctrl key while making your selections.

• If you select classes that have instances, you can also select specific 
instances.

Step 4 To make your changes take effect, you must click the OK button.

To undo changes and re-display the tree with classes that have instances, 
right-click in the DFM inventory browser and select Show All. Then expand the 
tree. Or, right-click and select Select again to make additional changes.

Changing Your Subscription Profile
A subscription profile is a saved list of events that have been subscribed to for 
notification. The events you subscribe to determine the notifications which are 
displayed on the DFM consoles. By editing a profile, you can change the 
notifications which are reported. All users automatically subscribe to the default 
profile, which subscribes to all types of events (symptoms and compounds). If a 
user edits the profile, the profile is named according to the user’s login and saved 
in the DFM inventory (when you save the inventory). If a user has edited the 
profile, it will be applied whenever they open a console.

Caution Be careful when modifying a subscription profile because changes can have a 
major effect on what is displayed by your consoles.
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Note You can also directly edit the DFM adapter configuration files to either use an 
existing subscription profile or establish specific classes, instances, and events 
you want the adapters to track. This information is provided in the “Changing 
Subscriptions for Notification Adapters” section on page 10-10.

You can subscribe to (and unsubscribe from) the events you wish to be notified of 
by changing your individual subscription profile, as described in these sections:

• Classes, Instances, and Events Supported by DFM, page 13-23

• Adding Subscriptions to Your Profile, page 13-24

• Removing Subscriptions from Your Profile, page 13-26

• Displaying Subscription Profiles, page 13-27

Classes, Instances, and Events Supported by DFM
DFM supports many classes, instances, and events in subscription profiles. 
Normally these are changed only when using the DFM adapters. For a complete 
list of the classes, instances, and events supported by DFM, refer to Appendix E, 
“Valid Classes, Instances, and Events.”
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Adding Subscriptions to Your Profile

Caution Be careful when modifying a subscription profile because changes can have a 
major effect on what is displayed by your consoles.

To add subscriptions to your profile, perform these steps:

Step 1 Select Maintain Profile from the Event menu in the Monitoring Console. This 
displays the Subscription Profile dialog (see Figure 13-8).

If you are attached to multiple domain managers, you are prompted to select one.

Figure 13-8 Monitoring Console–Subscription Profile Dialog
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Step 2 Edit the top portion of the dialog box:

• Use the Classes, Instances, and Events fields to subscribe to specific classes, 
instances, and events or subscribe to all with a period and asterisk (.*) 
expression. Appendix E, “Valid Classes, Instances, and Events” contains the 
classes, instances, and events supported by DFM.

Valid regular expressions may include:

Note Regular expressions used in the subscription profile should not be 
confused with wildcards used in Alarm Log filters.

• Select check boxes for the types of notifications you wish to receive 
(compound events and symptomatic events).

• Click the Add button.

Table 13-2 Valid Regular Expressions for Dialog Boxes

period . Matches any character.

asterisk * Matches zero or more occurrences of the previous 
character. Must be preceded by a character.

Note Use .* to select all.

plus + Matches one or more occurrences of the previous 
character.

question 
mark 

? Matches zero or one occurrence of the previous 
character.

brackets [abc] Matches any single character inside the brackets.

circumflex [^abc] Matches any single character except those inside the 
brackets.

tilde ~ Excludes any string that follows the tilde.
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Step 3 To make your changes take effect, you must click the OK or the Apply button. 

The OK button applies changes and closes the dialog. The Apply button applies 
changes and allows you to continue to make changes. The Cancel button cancels 
the changes that are not applied and closes the dialog.

Step 4 To save your changes, in the Admin Console, select Inventory > Save Inventory.

Removing Subscriptions from Your Profile

Caution Be careful when modifying a subscription profile because changes can have a 
major effect on what is displayed by your consoles.

Step 1 Select Maintain Profile from the Event menu in the Monitoring Console, if the 
Subscription Profile dialog is not already displayed.

If you are attached to multiple domain managers, you are prompted to select one. 

Step 2 To remove subscriptions, edit the bottom portion of the dialog. 

• Select one or more rows. (To sort a column, click the column title.)

• Click the Remove button.

Step 3 To make your changes take effect, you must click the OK or the Apply button. 

The OK button applies changes and closes the dialog. The Apply button applies 
changes and allows you to continue to make changes. The Cancel button cancels 
the changes that are not applied and closes the dialog.

Step 4 To save your changes, in the Admin Console, select Inventory > Save Inventory.
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Displaying Subscription Profiles
To display the subscription profiles that exist in the DFM inventory, use the 
sm_profile command (located in NMSROOT/objects/smarts/bin):

# sm_profile -s DFM show

Subscription profiles are always named PROFILE-username. The default 
subscription profile is PROFILE-default.

Invoking User Actions for Notifications
The choices Mail..., Page..., and Script... are not supported. To send an email or 
a page when certain alarms occur, use the Mail Notifier Adapter. See the 
“Configuring the Mail Notifier Adapter” section on page 10-27.
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