IP Mobility: Mobile Networks Configuration Guide, Cisco IOS Release 15M&T
Cisco Mobile Networks Tunnel Templates for Multicast
Downloads: This chapterpdf (PDF - 1.32MB) The complete bookPDF (PDF - 4.47MB) | The complete bookePub (ePub - 826.0KB) | Feedback

Cisco Mobile Networks Tunnel Templates for Multicast

Cisco Mobile Networks Tunnel Templates for Multicast

The Cisco Mobile Networks--Tunnel Templates for Multicast feature allows the configuration of multicast on statically created tunnels to be applied to dynamic tunnels brought up on the home agent and mobile router. A tunnel template is defined and applied to the tunnels between the home agent and mobile router. The mobile router can now roam and the tunnel template enables multicast sessions to be carried to the mobile networks.

Feature Specifications for Cisco Mobile Networks-Tunnel Templates for Multicast

Feature History

Release

Modification

12.2(15)T

This feature was introduced.

Supported Platforms

For platforms supported in Cisco IOS Release 12.2(15)T, consult Cisco Feature Navigator.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for Cisco Mobile Networks Tunnel Templates for Multicast

Reverse tunneling must be enabled from the mobile router to the home agent.

Restrictions for Cisco Mobile Networks Tunnel Templates for Multicast

Tunnels cannot be removed if they are being used as templates.

How to Configure Tunnel Templates for Multicast

Applying the Tunnel Template on the Home Agent

This task describes how to apply the tunnel template to the tunnels brought up at the home agent.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ip multicast-routing

    4.    interface tunnel interface-number

    5.    ip pim sparse-mode

    6.    exit

    7.    router mobile

    8.    exit

    9.    ip mobile mobile-networks

    10.    template tunnel interface-number

    11.    end

    12.    show ip mobile tunnel


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 ip multicast-routing


    Example:
    Router(config)# ip multicast-routing
     

    Enables IP multicast routing.

     
    Step 4 interface tunnel interface-number


    Example:
    Router(config)# interface tunnel 100
     

    Designates a tunnel interface and enters interface configuration mode.

    • This is the tunnel template that will be applied to the mobile networks.
     
    Step 5 ip pim sparse-mode


    Example:
    Router(config-if)# ip pim sparse-mode
     

    Enables Protocol Independent Multicast (PIM) on the tunnel interface in sparse mode.

     
    Step 6 exit


    Example:
    Router(config-if)# exit
     

    Returns to global configuration mode.

     
    Step 7 router mobile


    Example:
    Router(config)# router mobile
     

    Enables Mobile IP on the router.

     
    Step 8 exit


    Example:
    Router(config-router)# exit
     

    Returns to global configuration mode.

     
    Step 9 ip mobile mobile-networks


    Example:
    Router(config)# ip mobile mobile-networks
     

    Configures mobile networks for the mobile host and enters mobile networks configuration mode.

     
    Step 10 template tunnel interface-number


    Example:
    Router(mobile-networks)# template tunnel 100
     

    Designates the tunnel template to apply during registration.

    • The interface-number argument is set to the tunnel template defined in Step 4.
     
    Step 11 end


    Example:
    Router(mobile-networks)# end
     

    Exits to privileged EXEC mode.

     
    Step 12 show ip mobile tunnel


    Example:
    Router# show ip mobile tunnel
     

    Displays active tunnels.

    • Use this command to verify the configuration.
     

    Examples

    The following example displays the active Mobile IP tunnels and the template configuration for the tunnel on the home agent:

    Router# show ip mobile tunnel
    Mobile Tunnels:
    Total mobile ip tunnels 2 
    Tunnel1:
        src 1.1.1.1, dest 20.20.0.1 
        encap IP/IP, mode reverse-allowed, tunnel-users 1 
        IP MTU 1460 bytes 
        Path MTU Discovery, mtu:0, ager:10 mins, expires:never 
        outbound interface Tunnel0 
        HA created, fast switching enabled, ICMP unreachable enabled 
        27 packets input, 2919 bytes, 0 drops 
        24 packets output, 2568 bytes 
    Running template configuration for this tunnel:
    ip pim sparse-dense-mode 
    Tunnel0:
        src 1.1.1.1, dest 30.30.10.2 
        encap IP/IP, mode reverse-allowed, tunnel-users 1 
        IP MTU 1480 bytes 
        Path MTU Discovery, mtu:0, ager:10 mins, expires:never 
        outbound interface Ethernet1/3 
        HA created, fast switching enabled, ICMP unreachable enabled 
        0 packets input, 0 bytes, 0 drops 
        24 packets output, 3048 bytes 

    Applying the Tunnel Template on the Mobile Router

    This task describes how to apply the tunnel template to the tunnels brought up at the mobile router.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    ip multicast-routing

      4.    interface tunnel interface-number

      5.    ip pim sparse-mode

      6.    exit

      7.    router mobile

      8.    exit

      9.    ip mobile router

      10.    template tunnel interface-number

      11.    end

      12.    show ip mobile tunnel


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Router> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters global configuration mode.

       
      Step 3 ip multicast-routing


      Example:
      Router(config)# ip multicast-routing
       

      Enables IP multicast routing.

       
      Step 4 interface tunnel interface-number


      Example:
      Router(config)# interface tunnel 100
       

      Designates a tunnel interface and enters interface configuration mode.

      • This is the tunnel template that will be applied to the mobile networks.
       
      Step 5 ip pim sparse-mode


      Example:
      Router(config-if)# ip pim sparse-mode
       

      Enables PIM on the tunnel interface in sparse mode.

       
      Step 6 exit


      Example:
      Router(config-if)# exit
       

      Returns to global configuration mode.

       
      Step 7 router mobile


      Example:
      Router(config)# router mobile
       

      Enables Mobile IP on the router.

       
      Step 8 exit


      Example:
      Router(config-router)# exit
       

      Returns to global configuration mode.

       
      Step 9 ip mobile router


      Example:
      Router(config)# ip mobile router
       

      Enables the mobile router and enters mobile router configuration mode.

       
      Step 10 template tunnel interface-number


      Example:
      Router(mobile-router)# template tunnel 100
       

      Designates the tunnel template to apply during registration.

      • The interface numberargument is set to the tunnel template defined in Step 4.
       
      Step 11 end


      Example:
      Router(mobile-router)# end
       

      Exits to privileged EXEC mode.

       
      Step 12 show ip mobile tunnel


      Example:
      Router# show ip mobile tunnel
       

      Displays active tunnels.

      • Use this command to verify the configuration.
       

      Examples

      The following example displays the active Mobile IP tunnels and the template configuration for the tunnel on the mobile router:

      Router# show ip mobile tunnel
      Mobile Tunnels:
      Total mobile ip tunnels 1 
      Tunnel0:
          src 20.20.0.1, dest 1.1.1.1 
          encap IP/IP, mode reverse-allowed, tunnel-users 1 
          IP MTU 1480 bytes 
          Path MTU Discovery, mtu:0, ager:10 mins, expires:never 
          outbound interface Ethernet4/2 
          MR created, fast switching enabled, ICMP unreachable enabled 
          22 packets input, 2468 bytes, 0 drops 
          27 packets output, 2892 bytes 
      Running template configuration for this tunnel:
      ip pim sparse-mode 

      Configuration Examples for Tunnel Templates for Multicast

      Tunnel Templates for Multicast Example

      In the following example, a tunnel template is defined and configured to be brought up at the home agent and mobile router. The foreign agent does not require any additional configuration to support the Cisco Mobile Networks--Tunnel Templates for Multicast feature.

      Home Agent Configuration

      ! 
      ip multicast-routing 
      ! 
      interface Loopback0 
       ip address 1.1.1.1 255.255.255.255 
       ip pim sparse-mode 
      ! 
      ! 
      ! Tunnel template to be applied to mobile networks
      interface tunnel100 
       ip address 13.0.0.1 255.0.0.0 
       ip pim sparse-mode 
      ! 
      ! 
      router mobile 
      ip mobile mobile-networks 11.1.0.1 
       description jet 
       network 11.1.2.0 255.255.255.0 
       network 11.1.1.0 255.255.255.0 
      ! Select tunnel template to apply during registration 
       template tunnel100 
      ! 
      ip mobile secure host 11.1.0.1 spi 101 key hex 12345678123456781234567812345678 algorithm md5 mode prefix-suffix 
      ! 
      no ip mobile tunnel route-cache 
      ! 
      

      Mobile Router Configuration

      ! 
      ip multicast-routing 
      ! 
      interface Loopback0 
       ip address 11.1.0.1 255.255.255.255 
       ip pim sparse-mode 
      ! 
      ! 
      ! Tunnel template to be applied to mobile networks
      interface tunnel 100 
       no ip address 
       ip pim sparse-mode 
      ! 
      ! 
      interface Ethernet1/1 
       ip address 20.0.0.1 255.0.0.0 
       ip pim sparse-mode 
       ip mobile router-service roam 
      ! 
      router mobile 
      ip pim rp-address 7.7.7.7 
      ip mobile secure home-agent 1.1.1.1 spi 102 key hex 23456781234567812345678123456781 algorithm md5 mode prefix-suffix 
      ip mobile router 
       address 11.2.0.1 255.255.0.0 
       home-agent 1.1.1.1 
      ! Select tunnel template to apply during registration
       template tunnel 100 
       register extend expire 5 retry 2 interval 15 
       register lifetime 10000 
       reverse-tunnel 
      ! 

      Additional References

      For additional information related to Cisco Mobile Networks--Tunnel Templates for Multicast, see the following sections:

      Related Documents

      Related Topic

      Document Title

      Mobile IP configuration tasks

      "Configuring Mobile IP" chapter in the Cisco IOS IP Configuration Guide, Release 12.2

      Mobile IP commands: complete command syntax, command mode, defaults, usage guidelines, and examples

      "Mobile IP Comman ds" chapter in theCisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services, Release 12.2

      Multicast configuration tasks

      "Configuring IP Multicast Routing" chapter in the Cisco IOS IP Configuration Guide, Release 12.2

      Multicast commands: complete command syntax, command mode, defaults, usage guidelines, and examples

      "IP Multicast Routing Commands" chapter in theCisco IOS IP Command Reference, Volume 3 of 3: Multicast, Release 12.2

      Mobile IP commands related to Cisco Mobile Networks

      Cisco Mobile Networks feature document, Releases 12.2(4)T and 12.2(13)T.

      Standards

      Standards

      Title

      No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

      --

      MIBs

      MIBs

      MIBs Link

      None

      To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

      http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

      RFCs

      RFCs

      Title

      No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.

      --

      Technical Assistance

      Description

      Link

      Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

      http://www.cisco.com/public/support/tac/home.shtml

      Command Reference

      The following commands are introduced or modified in the feature or features documented in this module. For information about these commands, see the Cisco IOS IP Mobility Command Reference at http://www.cisco.com/en/US/docs/ios/ipmobility/command/reference/imo_book.html. For information about all Cisco IOS commands, go to the Command Lookup Tool at http:/​/​tools.cisco.com/​Support/​CLILookup or to the Cisco IOS Master Commands List .

      • show ip mobile tunnel
      • template tunnel (mobile networks)
      • template tunnel (mobile router)

      Glossary

      home agent --A router on a home network of the mobile node or that tunnels packets to the mobile node or mobile router while they are away from home. It keeps current location information for registered mobile nodes called a mobility binding .

      mobile network --A network that moves with the mobile router. A mobile network is a collection of hosts and routes that are fixed with respect to each other but are mobile, as a unit, with respect to the rest of the Internet.

      mobile router --A mobile node that is a router. It provides for the mobility of one or more entire networks moving together, perhaps on an airplane, a ship, a train, an automobile, a bicycle, or a kayak. The nodes connected to a network served by the mobile router may themselves be fixed nodes or mobile nodes or routers.


      Note


      Refer to Internetworking Terms and Acronyms for terms not included in this glossary.