IP Mobility: Mobile Networks Configuration Guide, Cisco IOS Release 15M&T
Mobile IP Policy and Application-Based Routing for MR Multipath
Downloads: This chapterpdf (PDF - 1.39MB) The complete bookPDF (PDF - 4.47MB) | The complete bookePub (ePub - 826.0KB) | Feedback

Mobile IP Policy and Application-Based Routing for MR Multipath

Contents

Mobile IP Policy and Application-Based Routing for MR Multipath

Mobile IP has increasingly become important because the public safety and public transportation are likely to adopt multiple wireless technologies to support their mission-critical applications and new services. Before the introduction of the Mobile IP--Mobile Router Multipath Support feature, the Cisco implementation of Mobile IP supported only one tunnel between the mobile router (MR) and the home agent (HA). You must use only one tunnel and one wireless technology at a given time. This feature provides support for multiple paths, and thus multiple wireless technologies, between the mobile router and the home agent and allows user traffic to be load-balanced over all available interfaces.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for Mobile IP Policy and Application-Based Routing for MR Multipath

  • Both the HA and the MR must be configured for multipath support.
  • The security association between the MR and the HA must be established in order for registrations to succeed.

Restrictions for Mobile IP Policy and Application-Based Routing for MR Multipath

Policy-based application routing has the following restrictions:

  • When you change the mobile-map configuration or ACL template configuration while a registration is active, the existing dynamic mobile maps and ACLs get deleted and new ones are generated. This occurs when the user exits the "mobile-map" configuration submode.
  • Priority-based multipath registration is enabled by default and is the only mode.
  • Label-based application routing is disabled by default on both the MR and the HA. It can be enabled separately on the MR and HA.
  • Application routing does not require multipath to be configured. It works in single-path mode too. Only one "match" clause is permited in each mobile-map entry.
  • ACL templates on the HA can be configured with a destination address. If such an ACL is used to generate a dynamic ACL, that dynamic ACL ignores the configured destination address and uses the MR’s mobile-network(s) instead.

Information About Mobile IP Policy and Application-Based Routing for MR Multipath

Mobile Router Multipath Support Feature Design

The Mobile Router Multipath Support feature extends the MR functionality to multiple interfaces. Before the introduction of this feature, the MR received agent advertisements or a collocated care-of address (CCoA) on multiple roaming interfaces. However, it would register through only one interface and set up the tunnel and routes based on that registration. During the routing or tunneling phase, packets arrived at the HA. The HA performed two encapsulations of the packets and tunneled them to the foreign agent or CCoA. The foreign agent or CCoA performed one de-encapsulation and sent the packets to the MR, which performed another de-encapsulation. The MR then sent the original packets to the IP devices on the mobile networks. See the figure below for an illustration of routing within a mobile network using a single tunnel.

Figure 1. Routing Within the Mobile Network Using a Single Tunnel

With the introduction of the Mobile Router Multipath support feature, the MR can register to the HA through all of its available roaming interfaces. Each registration is independent of the other registrations that occur on the other roaming interfaces. Once registered through more than one roaming interface, the MR has multiple routes to the HA. If a reverse tunnel is configured, the MR will have multiple paths--each tunnel going out its respective interface. Because the MR is registering independently on each of its roaming interfaces, it can use a foreign agent to register on one interface or a CCoA to register with another interface.

See the figure below for an illustration of the mobile router registering through multiple interfaces.

Figure 2. Mobile Router Registering Through Multiple Interfaces to the Home Agent

Upon successful registration, the HA maintains multiple care-of addresses, mobility bindings, tunnels, and routes to the same MR. Multiple bindings are not the same as simultaneous bindings. With multiple bindings, the traffic is not replicated on all tunnels but rather load-balanced across them, which means that the packets are sent through only one path.

Mobile Router Multipath Load-Balancing Behavior

When there are multiple paths between the MR and the HA, the traffic from the mobile networks that goes toward the HA is generally load-balanced. Per-destination load balancing is the default behavior. But you can also make use of an advanced behavior, policy-based application routing. Policy-based application routing allows you to identify a particular type of traffic from the mobile networks and then select the tunnel for routing this traffic.

Policy-based application routing allows you to control the roaming interface that is used by an application to route its traffic to the other end of a Mobile IP tunnel. This provides flexibility to control how the applications are routed over different mobile wireless networks based on a defined policy. The applications are policy-routed based on the roaming interface type. See the Routing Based on Policies and Selecting Roaming Interfaces for more information on policy-based application routing.

Setting Priority Levels and MR Registration

You can configure policy-based application routing and the MR roaming interfaces. You should set the priority levels when you enable the roaming interface. The MR registers on multiple roaming interfaces based on the roaming interface configuration. The MR registers only through the highest priority interface. If there is more than one interface with the same highest priority, then both interfaces are used by the MR during registration. If all highest priority interfaces are unavailable, then the MR switches to the next available highest priority interface. The interfaces have link-type labels configured on them. See Registering the MR Based on the Roaming Priority Example for an example.

A label is used to describe a link-type associated with a roaming interface. The label indicates the path such as, link type, actual bandwidth, or stability. You need to manually configure the label on a roaming interface using the ip mobile router-service link-typecommand.

Benefits of Mobile Router Multipath Support

Because multiple access technologies can be deployed in mobile networks, the Mobile Router Multipath support feature offers the ability to leverage all available links when Mobile IP is used. This multiple path support offers good investment protection for existing legacy wireless connections or any newly purchased or deployed wireless technologies.

How to Configure Mobile Router Multipath Support

The Mobile Router Multipath support feature is enabled by default on the MR but is disabled by default on the HA. For this feature to work, both the HA and the MR must be configured for multipath support. Because this feature is enabled by default on the MR, the MR will try for multiple registrations. However, if the MR determines that the HA is not configured for multipath support by receiving registration replies without multiple path support, the MR will switch to single-path mode. This feature is disabled by default on the HA so that during deployments, upgrading the software does not surprise the deployment engineer with multiple registrations.

After configuring the MR, you can configure the policy-based application routing and the MR roaming interfaces. You then need to enable the roaming interfaces and define the traffic policies. This allows you to identify a particular type of traffic from the mobile networks and then select the tunnel for routing the traffic. This provides flexibility to control how the applications are routed over different mobile wireless networks based on a policy.

This section contains the following tasks:

Configuring the Mobile Router for Multipath Support

This task shows how to configure the mobile router for multipath support.

Before You Begin

The security association between the MR and the HA should be established in order for registrations to succeed.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface type number

    4.    ip address ip-address mask

    5.    exit

    6.    router mobile

    7.    exit

    8.    ip mobile router

    9.    address address mask

    10.    home-agent ip-address

    11.    mobile-network interface-type interface number

    12.    multi-path [metric {bandwidth | hopcount}]

    13.    end


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface type number


    Example:
    Router(config)# interface loopback0
     

    Configures an interface and enters interface configuration mode.

     
    Step 4 ip address ip-address mask


    Example:
    Router(config-if)# ip address 209.165.200.225 255.255.255.224
     

    Sets a primary IP address of the interface.

    • This is the home address of the mobile router.
     
    Step 5 exit


    Example:
    Router(config-if)# exit
     

    Returns to global configuration mode.

     
    Step 6 router mobile


    Example:
    Router(config)# router mobile
     

    Enables Mobile IP on the router and enters router configuration mode.

     
    Step 7 exit


    Example:
    Router(config-router)# exit
     

    Returns to global configuration mode.

     
    Step 8 ip mobile router


    Example:
    Router(config)# ip mobile router 
     

    Enables the mobile router and enters mobile router configuration mode.

     
    Step 9 address address mask


    Example:
    Router(mobile-router)# address 209.165.200.225 255.255.255.224
     

    Sets the home IP address and network mask of the mobile router.

     
    Step 10 home-agent ip-address


    Example:
    Router(mobile-router)# home-agent 192.0.2.19
     

    Specifies the home agent that the mobile router uses during registration.

     
    Step 11 mobile-network interface-type interface number


    Example:
    Router(mobile-router)# mobile-network Ethernet3/0
     

    Specifies the mobile router interface that is connected to the mobile network.

     
    Step 12 multi-path [metric {bandwidth | hopcount}]


    Example:
    Router(mobile-router)# multi-path 
     

    Enables the mobile router to request multiple path support.

    • Bandwidth is the default metric.
     
    Step 13 end


    Example:
    Router(mobile-router)# end 
     

    Returns to privileged EXEC mode.

     
    What to Do Next

    Routing Based on Policies and Selecting Roaming Interfaces

    This section contains the following topics:

    Before You Begin

    Policy-based application routing occurs only when an ingress interface is configured for a mobile policy.

    Example:

    interface ethernet 1/0
     ip mobile router-service roam
     ip mobile router-service link-type 802.11g

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface type number

      4.    ip mobile router-service roam priority priority-level

      5.    end


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Router> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface type number


      Example:
      Router(config)# interface FastEthernet0/2
       

      Configures an interface and enters interface configuration mode.

       
      Step 4 ip mobile router-service roam priority priority-level


      Example:
      Router(config-if)# ip mobile router-service roam priority 101
       

      Enables the roaming interface and sets the priority level.

      The roaming interface priority defaults to 100 if priority is not specified while configuring the ip mobile router-service roam command.

       
      Step 5 end


      Example:
      Router(config-if)# end
       

      Returns to privileged EXEC mode.

       

      Enabling the Roaming Interfaces

      You can enable the roaming interfaces after setting the roaming priority level. The MR registers on multiple roaming interfaces based on the roaming-interface configuration.

      SUMMARY STEPS

        1.    enable

        2.    configure terminal

        3.    interface type number

        4.    ip mobile router-service roam priority priority-level

        5.    ip mobile router-service link-type label

        6.    end


      DETAILED STEPS
         Command or ActionPurpose
        Step 1 enable


        Example:
        Router> enable
         

        Enables privileged EXEC mode.

        • Enter your password if prompted.
         
        Step 2 configure terminal


        Example:
        Router# configure terminal
         

        Enters global configuration mode.

         
        Step 3 interface type number


        Example:
        Router(config)# interface FastEthernet0/2
         

        Configures an interface and enters interface configuration mode.

         
        Step 4 ip mobile router-service roam priority priority-level


        Example:
        Router(config-if)# ip mobile router-service roam priority 101
         

        Enables the roaming interface and sets the priority level.

        The roaming interface priority defaults to 100 if priority is not specified while configuring the ip mobile router-service roamcommand.

         
        Step 5 ip mobile router-service link-type label


        Example:
        Router(config-if)# ip mobile router-service link-type 802.11g
         

        Enables a link-type roaming interface.

         
        Step 6 end


        Example:
        Router(config-if)# exit
         

        Returns to privileged EXEC mode.

         

        Defining the Traffic Policies

        You can define the traffic policies by identifying the application traffic and selecting the path for routing based on policies. This section contains the following tasks:

        Identifying the Application Traffic

        You can use one or more extended named ACLs on both the MR and the HA to identify the application traffic. MR and HA named ACLs are used as templates at registration time to generate dynamic ACLs that are used in the dynamic route maps.

        SUMMARY STEPS

          1.    enable

          2.    configure terminal

          3.    ip access-list extended access-list name

          4.    permit udp any any eq port

          5.    end


        DETAILED STEPS
           Command or ActionPurpose
          Step 1 enable


          Example:
          Router> enable
           

          Enables privileged EXEC mode.

          • Enter your password if prompted.
           
          Step 2 configure terminal


          Example:
          Router# configure terminal
           

          Enters global configuration mode.

           
          Step 3 ip access-list extended access-list name


          Example:
          Router(config)# ip access-list extended WEB
           

          Configures an extended named ACL.

           
          Step 4 permit udp any any eq port


          Example:
          Router(config-ext-nacl)# permit udp any any eq 8080
           

          Identifies the application traffic to be policy routed. These are used as templates at registration time to generate dynamic ACLs that are used in the dynamic route-maps.

           
          Step 5 end


          Example:
          Router(config-ext-nacl)# end
           

          Returns to privileged EXEC mode.

           
          Selecting the Routing Path

          You can use one or more mobile-map mobile policy templates on the MR and HA to select the routing path.

          Multiple mobile policies can be configured on either the MR or the HA. On the MR, a separate dynamic route map is generated for each configured mobile policy. More than one MR ingress interface (mobile network interface) has a mobile policy and each interface has a different policy. On the HA there is only one dynamic route map generated, but it is applied on up to three ingress interfaces. If more than one mobile policy is configured on the HA, only one route map is dynamically generated and applied to the ingress interface(s).

          You need to apply the mobile map to access interfaces. The mobile map is associated with a mobile network interface on the MR in the "mobile-network" configuration. The mobile-map configuration on the HA can specify up to three "ingress" interfaces.

          When traffic from a mobile network is received by the MR, the traffic is compared against one of the ACLs. If there is a match, the MR finds the corresponding mobile-map entry that specifies the roaming interface on which to send the traffic. Similarly, on the HA when traffic for a mobile network is received on one of the specified ingress interfaces, it is matched against one of the ACLs and then against the corresponding mobile-map entry, which in turn decides the tunnel to send the traffic to.

          SUMMARY STEPS

            1.    enable

            2.    configure terminal

            3.    interface type number

            4.    ip mobile router-service roam priority priority level

            5.    ip mobile router-service link-type label

            6.    exit

            7.    ip access-list extended access-list-name

            8.    permit udp any any eq port

            9.    exit

            10.    ip mobile mobile-map map name

            11.    match access-list acl

            12.    set link-type label

            13.    set interface interface-type number

            14.    ip mobile router

            15.    exit


          DETAILED STEPS
             Command or ActionPurpose
            Step 1 enable


            Example:
            Router> enable
             

            Enables privileged EXEC mode.

            • Enter your password if prompted.
             
            Step 2 configure terminal


            Example:
            Router# configure terminal
             

            Enters global configuration mode.

             
            Step 3 interface type number


            Example:
            Router(config)# interface FastEthernet0/2
             

            Configures an interface and enters interface configuration mode.

             
            Step 4 ip mobile router-service roam priority priority level


            Example:
            Router(config-if)# ip mobile router-service roam priority 101
             

            Enables the roaming interface and sets the priority level.

            • The roaming interface priority defaults to 100 if priority is not specified while configuring the ip mobile router-service roamcommand.

             
            Step 5 ip mobile router-service link-type label


            Example:
            Router(config-if)# ip mobile router-service link-type 802.11g
             

            Enables a link-type roaming interface.

             
            Step 6 exit


            Example:
            Router(config-if)# exit
             

            Returns to global configuration mode.

             
            Step 7 ip access-list extended access-list-name


            Example:
            Router(config)# ip access-list extended WEB
             

            Configures an extended named ACL and enters interface configuration mode.

             
            Step 8 permit udp any any eq port


            Example:
            Router(config-ext-nacl)# permit udp any any eq 8080
             

            Identifies the application traffic to be policy routed. The extended named ACLs on both the MR and HA are used as templates at registration time to generate dynamic ACLs that are used in the dynamic route maps.

             
            Step 9 exit


            Example:
            Router(config-ext-nacl)# exit
             

            Returns to global configuration mode.

             
            Step 10 ip mobile mobile-map map name


            Example:
            Router(config)# ip mobile mobile-map MPATH_1 10
             

            Configures mobile policy templates on the MR and HA.

             
            Step 11 match access-list acl


            Example:
            Router(config)# match access-list WEB
             

            Specifies an ACL name.

             
            Step 12 set link-type label


            Example:
            Router(config)# set link-type 802.11a GPRS
             

            Specifies up to three link-type labels.

             
            Step 13 set interface interface-type number


            Example:
            Router(config)# set interface Ethernet1/0
             

            Specifies the interface for dropping traffic.

             
            Step 14 ip mobile router


            Example:
            Router(config)# ip mobile router
             

            Applies the mobile map to ingress interfaces in the MR and to up to three ingress interfaces in the HA.

             
            Step 15 exit


            Example:
            Router(config)# exit
             

            Returns to privileged EXEC mode.

             

            Configuring the Home Agent for Multipath Support

            This task shows how to configure the HA for multipath support.

            You can configure and unconfigure multipath support globally on the HA. Unconfiguring multiple paths takes the mobile router back to the existing single-path mode.

            SUMMARY STEPS

              1.    enable

              2.    configure terminal

              3.    router mobile

              4.    exit

              5.    ip mobile home-agent multi-path [metric {bandwidth | hopcount}]

              6.    ip mobile virtual-network net mask [address address]

              7.    ip mobile host lower [upper] {interfacename | virtual-network net mask}

              8.    ip mobile mobile-networks lower [upper]

              9.    register

              10.    multi-path [metric {bandwidth | hopcount}]

              11.    exit


            DETAILED STEPS
               Command or ActionPurpose
              Step 1 enable


              Example:
              Router> enable
               

              Enables privileged EXEC mode.

              • Enter your password if prompted.
               
              Step 2 configure terminal


              Example:
              Router# configure terminal
               

              Enters global configuration mode.

               
              Step 3 router mobile


              Example:
              Router(config)# router mobile
               

              Enables Mobile IP on the router and enters router configuration mode.

               
              Step 4 exit


              Example:
              Router(config-router)# exit
               

              Returns to global configuration mode.

               
              Step 5 ip mobile home-agent multi-path [metric {bandwidth | hopcount}]


              Example:
              Router(config)# ip mobile home-agent multi-path
               

              Enables the home agent to process registration requests with multiple path support for all mobile routers.

              • Bandwidth is the default metric.
               
              Step 6 ip mobile virtual-network net mask [address address]


              Example:
              Router(config)# ip mobile virtual-network 209.165.200.225 255.255.255.224
               

              Defines a virtual network. Specifies that the home network is a virtual network, which means that the mobile router is not physically attached to the home agent. Adds the network to the home agent’s forwarding table so that routing protocols can redistribute the subnet.

               
              Step 7 ip mobile host lower [upper] {interfacename | virtual-network net mask}


              Example:
              Router(config)# ip mobile host 209.165.200.219 255.255.255.224 virtual-network 209.165.200.225 255.255.255.224
               

              Configures the mobile router as a mobile host. The IP address is in the home network.

              • The interface name option configures a physical connection from the home agent to the mobile router.
               
              Step 8 ip mobile mobile-networks lower [upper]


              Example:
              Router(config)# ip mobile mobile-networks 209.165.200.219 209.165.200.225
               

              Configures mobile networks for the mobile host and enters mobile networks configuration mode. The upper range can be used only with dynamically registered networks and allows you to configure multiple mobile routers at once.

              • The range must be within the range configured in the ip mobile host command.
               
              Step 9 register


              Example:
              Router(mobile-networks)# register 
               

              Dynamically registers the mobile networks with the home agent.

               
              Step 10 multi-path [metric {bandwidth | hopcount}]


              Example:
              Router(mobile-networks)# multi-path
               

              Configures the global default setting and enables the home agent to process requests with multiple path support for a specific mobile router. Bandwidth is the default metric.

               
              Step 11 exit


              Example:
              Router(mobile-networks)# no multi-path
               

              Returns to privileged EXEC mode.

               

              What to Do Next

              After you configure the HA you can define the traffic policies. This enables you to identify a particular traffic from the mobile networks and then select the tunnel for routing the traffic. This provides flexibility to control how the applications are routed over different mobile wireless networks based on a policy. See the "Defining the Traffic Policies" for more information on how to define the traffic policies.

              Clearing the Mobility Binding on the Home Agent

              Perform this task to manually clear the mobility binding that is associated with the MR IP address and its care-of address.


              Note


              Use this clear command with care, because it will disrupt any sessions that are being used by the MR. After you use this command, the mobile router will need to re-register to continue roaming.

              >
              SUMMARY STEPS

                1.    enable

                2.    clear ip mobile binding mr-ip-address [coa care-of-address]


              DETAILED STEPS
                 Command or ActionPurpose
                Step 1 enable


                Example:
                Router> enable
                 

                Enables privileged EXEC mode.

                • Enter your password if prompted.
                 
                Step 2 clear ip mobile binding mr-ip-address [coa care-of-address]


                Example:
                Router# clear ip mobile binding 192.0.2.72
                 

                Removes mobility bindings.

                • You can remove a specific care-of address or all care-of addresses associated with a mobile router.
                 

                Verifying Mobile Router Multipath Support

                Perform this task to verify MR multipath support.

                SUMMARY STEPS

                  1.    enable

                  2.    show ip mobile binding [home-agent ip-address | nai string [session-id string] | summary]

                  3.    show ip mobile global

                  4.    show ip mobile mobile-networks

                  5.    show ip mobile tunnel [interface]

                  6.    show ip route

                  7.    show ip mobile router


                DETAILED STEPS
                   Command or ActionPurpose
                  Step 1 enable


                  Example:
                  Router> enable
                   

                  Enables privileged EXEC mode.

                  • Enter your password if prompted.
                   
                  Step 2 show ip mobile binding [home-agent ip-address | nai string [session-id string] | summary]


                  Example:
                  Router# show ip mobile binding
                   

                  Displays the mobility binding on the home agent.

                   
                  Step 3 show ip mobile global


                  Example:
                  Router# show ip mobile global
                   

                  Displays global information for mobile agents.

                   
                  Step 4 show ip mobile mobile-networks


                  Example:
                  Router# show ip mobile mobile-networks
                   

                  Displays a list of mobile networks that are associated with the mobile router.

                   
                  Step 5 show ip mobile tunnel [interface]


                  Example:
                  Router# show ip mobile tunnel
                   

                  Displays active tunnels.

                   
                  Step 6 show ip route


                  Example:
                  Router# show ip route
                   

                  Displays the current state of the routing table.

                   
                  Step 7 show ip mobile router


                  Example:
                  Router# show ip mobile router
                   

                  Displays configuration information and monitoring statistics about the mobile router.

                   

                  Configuration Examples for Mobile Router Multipath Support

                  Multipath Support on the Mobile Router Example

                  The following example shows how to configure multipath support on the mobile router:

                  interface Loopback0
                  ! MR home address
                   ip address 209.165.200.225 255.255.255.224
                  interface Tunnel101
                   keep 5 3
                  interface Ethernet1/0
                  ! MR roaming interface
                   ip address 209.165.200.239 255.255.255.224
                   ip mobile router-service roam
                  interface Ethernet2/0
                  ! MR roaming interface
                   ip address 209.165.200.246 255.255.255.224
                   ip mobile router-service roam
                  interface Ethernet3/0
                   ip address 209.165.200.247 255.255.255.224
                  router mobile
                  ip mobile router
                   address 209.165.200.251 255.255.255.224
                   home-agent 192.0.2.12
                   mobile-network Ethernet3/0
                   tunnel mode gre
                   multi-path
                   template Tunnel101
                  ip mobile secure home-agent 192.0.2.16 spi 101 key hex 12345678901234567890123456789012

                  Multipath Support on the Home Agent Example

                  The following example shows how to configure multipath support on the home agent:

                  interface Ethernet 0/0
                   ip address 209.165.200.251 255.255.255.224
                  !
                  router mobile
                   exit
                   ip mobile home-agent multi-path
                   ip mobile virtual-network 209.165.200.252 255.255.255.224
                   ip mobile host 192.0.2.10 192.0.2.15 virtual-network 209.165.200.254 255.255.255.224
                   ip mobile secure host 192.0.2.20 192.0.2.25 spi 101 key hex  12345678901234567890123456789012
                  ip mobile mobile-networks 192.0.2.40 192.0.2.44 
                   register
                  ip mobile mobile-networks 192.0.2.57
                   register
                   no multi-path
                  

                  Registering the MR Based on the Roaming Priority Example

                  The following example shows how roaming priority levels are selected during MR registration:

                  Consider the following four interfaces:

                  interface Fastethernet 1/0
                    ip mobile router-service roam priority 200
                    ip mobile router-service link-type 802.11g
                  interface Fastethernet 1/1
                    ip mobile router-service roam priority 200
                    ip mobile router-service link-type 802.11g
                  interface Fastethernet 2/0
                    ip mobile router-service roam priority 100
                    ip mobile router-service link-type 802.11g
                  interface Fastethernet 2/1
                    ip mobile router-service roam priority 100
                    ip mobile router-service link-type 802.11g
                  Fast Ethernet interfaces 1/0 and 1/1 have priority 200. Fast Ethernet interfaces 2/0 and 2/1 have priority 100. When you try enabling these four interfaces, the MR registers on both the Fast Ethernet interfaces 1/0 and 1/1 because they have the highest roaming priority. But when the interfaces Fastethernet 1/0 and 1/1 are not available, the MR registers on Fastethernet 2/0 and 2/1, the next available highest priority group.

                  Using mobile-map Mobile Policy Templates Example

                  The following example shows to use the mobile-map mobile policy templates on the MR and the HA to select the routing path.

                  ip mobile mobile-map MPATH_1 10
                   match access-list WEB
                   set link-type 802.11g UMTS
                   set interface null0

                  Generating Dynamic Route Maps in an HA Example

                  The following example shows how the dynamic route maps are generated in an HA:

                  Router# show route-map dynamic
                  route-map MIP-10/24/06-04:18:15.243-1-MP-HA, permit, sequence 0, identifier 53856096
                    Match clauses:
                      ip address (access-lists): VOICE-to-192.0.2.0/24 
                    Set clauses:
                      interface Tunnel0
                    Policy routing matches: 0 packets, 0 bytes
                   Current active dynamic routemaps = 1
                  Router# show ip access-lists dynamic 
                  Extended IP access list VOICE-to-192.0.2.0/24 
                      10 permit icmp any 209.165.200.225 255.255.255.224 tos max-reliability

                  Additional References

                  The following sections provide references related to the Mobile IP-- Policy and Application-Based Routing for MR Multipath Support feature.

                  Related Documents

                  Related Topic

                  Document Title

                  Mobile IP commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

                  Cisco IOS IP Mobility Command Reference

                  Standards

                  Standard

                  Title

                  No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

                  --

                  MIBs

                  MIB

                  MIBs Link

                  No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

                  To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

                  http:/​/​www.cisco.com/​go/​mibs

                  RFCs

                  RFC

                  Title

                  No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.

                  --

                  Technical Assistance

                  Description

                  Link

                  The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

                  To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

                  Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

                  http:/​/​www.cisco.com/​techsupport

                  Command Reference

                  The following commands are introduced or modified in the feature or features documented in this module. For information about these commands, see the Cisco IOS IP Mobility Command Reference at http://www.cisco.com/en/US/docs/ios/ipmobility/command/reference/imo_book.html. For information about all Cisco IOS commands, use the Command Lookup Tool at http:/​/​tools.cisco.com/​Support/​CLILookup or to the Cisco IOS Master Commands List, All Releases , at http:/​/​www.cisco.com/​en/​US/​docs/​ios/​mcl/​allreleasemcl/​all_​book.html .

                  • clear ip mobile binding
                  • debug ip mobile dyn-pbr
                  • ip mobile home-agent multi-path
                  • ip mobile router-service link-type
                  • ip mobile router-service roam
                  • multi-path (mobile networks)
                  • multi-path (mobile router)
                  • show ip mobile binding
                  • show ip mobile globals
                  • show ip mobile mobile-networks
                  • show ip mobile router interface
                  • show ip mobile router registration
                  • show ip mobile tunnel

                  Feature Information for Mobile IP - Policy and Application-Based Routing for MR Multipath

                  The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

                  Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

                  Table 1 Feature Information for Mobile IP-- Policy and Application-Based Routing for MR Multipath

                  Feature Name

                  Releases

                  Feature Information

                  Mobile IP--Mobile Router Multipath Support

                  12.4(9)T

                  This Mobile IP--Mobile Router Multipath Support feature provides support for multiple paths, and thus multiple wireless technologies, between the mobile router and the home agent and allows user traffic to be load-balanced over all available interfaces.

                  Mobile IP-- Policy and Application-Based Routing for MR Multipath

                  12.4(24)T

                  This feature provides support for mobile router multipath registration based on roaming interface priority; application routing based on link or path type; and multiple registrations based on roaming interface priority.

                  The following commands were introduced: ip mobile router-service link-type, ip mobile router-service roam.

                  The following commands were modified:

                  show ip mobile binding, show ip mobile router interface, show ip mobile router registration, show ip mobile tunnel

                  Glossary

                  agent advertisement --An advertisement message constructed by an attachment of a special extension to an ICMP Router Discovery Protocol (IRDP).

                  care-of address --The termination point of the tunnel to a mobile node or mobile router. This can be a collocated care-of address, by which the mobile node or mobile router acquires a local address and detunnels its own packets, or a foreign agent care-of address, by which a foreign agent detunnels packets and forwards them to the mobile node or mobile router.

                  foreign agent --A router on the visited network of a foreign network that provides routing services to the mobile node while registered. The foreign agent detunnels and delivers packets to the mobile node or mobile router that were tunneled by the home agent of the mobile node. For packets sent by a mobile node, the foreign agent may serve as a default router for registered mobile nodes.

                  home agent --A router on a home network of the mobile node or a router that tunnels packets to the mobile node or mobile router while they are away from home. The home agent keeps current location information for registered mobile nodes called a mobility binding .

                  home network --The network, possibly virtual, whose network prefix equals the network prefix of the home address of a mobile node.

                  mobile network --A network that moves with the mobile router. A mobile network is a collection of hosts and routes that are fixed with respect to each other but are mobile, as a unit, with respect to the rest of the Internet.

                  mobile node --A host or router that changes its point of attachment from one network or subnet to another. A mobile node may change its location without changing its IP address; it may continue to communicate with other Internet nodes at any location using its home IP address, assuming that link-layer connectivity to a point of attachment is available.

                  mobile router --A mobile node that is a router. It provides for the mobility of one or more entire networks moving together, perhaps on an airplane, a ship, a train, an automobile, a bicycle, or a kayak. The nodes connected to a network served by the mobile router may themselves be fixed nodes or mobile nodes or routers.

                  mobility binding --The association of a home address with a care-of address and the remaining lifetime.

                  registration --The process by which the mobile node is associated with a care-of address on the home agent while it is away from home. Registration may happen directly from the mobile node to the home agent or through a foreign agent.

                  roaming interface --An interface used by the mobile router to detect foreign agents and home agents while roaming. Registration and traffic occur on the interface.

                  tunnel --The path followed by a packet while it is encapsulated from the home agent to the mobile node. The model is that, while it is encapsulated, a packet is routed to a knowledgeable decapsulating agent, which de-encapsulates the datagram and then correctly delivers it to its ultimate destination.