IP Mobility: Mobile Networks Configuration Guide, Cisco IOS Release 15M&T
Mobile Networks Dynamic Collocated Care-of Address
Downloads: This chapterpdf (PDF - 1.28MB) The complete bookPDF (PDF - 4.5MB) | The complete bookePub (ePub - 826.0KB) | Feedback

Mobile Networks Dynamic Collocated Care-of Address

Mobile Networks Dynamic Collocated Care-of Address

Before the introduction of the Mobile Networks Dynamic Collocated Care-of Address feature, Cisco mobile networks supported foreign agent care-of address (CoA) registration and static collocated care-of address (CCoA) registration.

Static CCoA registration is considered a special case and applies to networks where the endpoint IP address is always fixed, such as in a Cellular Digital Packet Data (CDPD) wireless network. The Mobile Networks Static Collocated Care-of Address feature allows a mobile router with a static IP address to roam to foreign networks where foreign agents are not deployed.

The Mobile Networks Dynamic Care-of Address feature allows the mobile router to register with the home agent using a CCoA that is acquired dynamically via the IP Control Protocol (IPCP). Support for CCoAs acquired through the Dynamic Host Configuration Protocol (DHCP) is planned for a future release.

Feature History for the Mobile Networks Dynamic Collocated Care-of Address Feature

Release

Modification

12.3(4)T

This feature was introduced.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Restrictions for Mobile Networks Dynamic CCoA

The Mobile Networks Dynamic CCoA feature can be configured only on serial (point-to-point) interfaces.

Information About Mobile Networks Dynamic CCoA

Care-of Addresses

If a mobile router determines that it is connected to a foreign network, it acquires a care-of address. This care-of address is the exit point of the tunnel from the home agent toward the mobile router. The care-of address is included in the Mobile IP registration request and is used by the home agent to forward packets to the mobile router in its current location. There are two types of care-of addresses:

  • Care-of address acquired from a foreign agent
  • Collocated care-of address

A foreign agent care-of address is an IP address on a foreign agent that is advertised on the foreign network being visited by a mobile router. A foreign agent CoA can be shared by other mobile routers. A collocated care-of address is an IP address assigned to the interface of the mobile router itself. A collocated care-of address represents the current position of the mobile router on the foreign network and can be used by only one mobile router at a time.

Mobile Networks Dynamic CCoA Feature Design

The Mobile Networks Dynamic CCoA feature is very similar to the static CCoA implementation. Static CCoA uses the address configured on the roaming interface as the CCoA. Dynamic CCoA uses IPCP to obtain a CCoA for the roaming interface. See the http:/​/​www.cisco.com/​univercd/​cc/​td/​doc/​product/​software/​ios122/​122newft/​122t/​122t15/​ftcolloc.htm Cisco Mobile Networks - Static Collocated Care-of Address feature documentation for more information on the static CCoA implementation.

For both static and dynamic CCoA, the interface can be configured to exclusively use CCoAs for registration or to use a foreign agent CoA if one is available. In the foreign agent case, when an interface first comes up, it will attempt to discover foreign agents on the link by soliciting and listening for agent advertisements. If a foreign agent is found, the mobile router will register using the advertised CoA. The interface will continue to register using a CoA as long as a foreign agent is heard. When foreign agents are not heard, either because no advertisements are received or the foreign agent advertisement hold time expires, CCoA processing is enabled and the interface registers its CCoA. The CCoA is the interface’s statically configured or dynamically acquired primary IP address. If a foreign agent is heard again, the interface will again register the foreign agent CoA.

You can configure the interface to register only its CCoA and ignore foreign agent advertisements by using the ip mobile router-service collocated ccoa-only option.

When the mobile router registers a CCoA with a home agent, a single HA-CCoA tunnel is created and is used for traffic to the mobile router and its mobile networks.

The CCoA configured on the mobile router interface will become the endpoint of the HA-CCoA tunnel as the home agent tunnels packets to the mobile router. The mobile router will use this same tunnel to reverse tunnel packets back to the home agent if configured for reverse tunnel.

Benefits of Mobile Networks Dynamic CCoA

This feature allows a mobile router to roam to foreign networks where foreign agents are not deployed and to obtain a CCoA dynamically through IPCP.

How to Configure Mobile Networks Dynamic CCoA

Enabling Dynamic CCoA Processing on a Mobile Router Interface

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface type number

    4.    ip address negotiated

    5.    encapsulation ppp

    6.    ip mobile router-service roam

    7.    ip mobile router-service collocated

    8.    ip mobile router-service collocated registration retry seconds


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface type number


    Example:
    Router(config)# interface serial 1
     

    Configures an interface type and enters interface configuration mode.

    • Dynamic CCoAs can be acquired only on serial interfaces.
     
    Step 4 ip address negotiated


    Example:
    Router(config-if)# ip address negotiated
     

    Specifies that the IP address for a particular interface is obtained via IPCP address negotiation.

     
    Step 5 encapsulation ppp


    Example:
    Router(config-if)# encapsulation ppp
     

    Enables PPP enacapsulation on a specified serial interface.

     
    Step 6 ip mobile router-service roam


    Example:
    Router(config-if)# ip mobile router-service roam
     

    Enables roaming on an interface.

     
    Step 7 ip mobile router-service collocated


    Example:
    Router(config-if)# ip mobile router-service collocated 
     

    Enables CCoA processing on a mobile router interface.

    • The interface will first solicit foreign agent advertisements and register with a foreign agent CoA if an advertisement is heard. If no advertisements are received, CCoA registration is attempted.
     
    Step 8 ip mobile router-service collocated registration retry seconds


    Example:
    Router(config-if)# ip mobile router-service collocated registration retry 3
     

    (Optional) Configures the time period that the mobile router waits before sending another registration request after a registration failure.

    • The default value is 60 seconds. You need to use this command only when a different retry interval is desired.
     

    Enabling CCoA-Only Processing on a Mobile Router Interface

    Perform this task to configure a mobile router interface to ignore foreign agent advertisements and exclusively use CCoAs for registration to the home agent. This functionality works for both static and dynamic CCoA processing.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface type number

      4.    Do one of the following:

      • ip address ip-address mask
      • ip address negotiated

      5.    ip mobile router-service roam

      6.    ip mobile router-service collocated ccoa-only

      7.    ip mobile router-service collocated gateway ip-address ccoa-only

      8.    ip mobile router-service collocated registration retry seconds


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Router> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface type number


      Example:
      Router(config)# interface ethernet 1
       

      Configures an interface type and enters interface configuration mode.

       
      Step 4Do one of the following:
      • ip address ip-address mask
      • ip address negotiated


      Example:
      Router(config-if)# ip-address 172.71.6.23 255.255.255.0


      Example:
      
      
              


      Example:
                


      Example:
      Router(config-if)# ip address negotiated 
       

      Sets a primary IP address for an interface.

      • This is the static CCoA. Static CCoAs can be configured on serial or Ethernet interfaces.

      or

      Specifies that the IP address for a particular interface is obtained via IPCP address negotiation.

      • Use this command for dynamic CCoA processing. Dynamic CCoAs can be acquired only on serial interfaces.
       
      Step 5 ip mobile router-service roam


      Example:
      Router(config-if)# ip mobile router-service roam
       

      Enables roaming on an interface.

       
      Step 6 ip mobile router-service collocated ccoa-only


      Example:
      Router(config-if)# ip mobile router-service collocated ccoa-only
       

      Enables CCoA-only processing on a mobile router interface.

      • This command can be used on serial interfaces for dynamic or static CCoA processing.
      • This command disables foreign-agent CoA processing and limits the interface to CCoA processing only.
      • If you use this command on an interface already registered with a foreign agent CoA, the mobile router will re-register immediately with a CCoA.
       
      Step 7 ip mobile router-service collocated gateway ip-address ccoa-only


      Example:
      Router(config-if)# ip mobile router-service collocated gateway 10.21.0.2 ccoa-only
       

      (Optional) Enables CCoA-only processing on a mobile router interface.

      • This command can be used only on Ethernet interfaces for static CCoA processing.
      • The gateway IP address is the next hop IP address for the mobile router to forward packets. The gateway IP address is required only on Ethernet interfaces, and must be on the same logical subnet as the primary interface.
       
      Step 8 ip mobile router-service collocated registration retry seconds


      Example:
      Router(config-if)# ip mobile router-service collocated registration retry 3
       

      (Optional) Configures the time period that the mobile router waits before sending another registration request after a registration failure.

      • The default value is 60 seconds. You need to use this command only when a different retry interval is desired.
       

      Verifying the Dynamic CCoA Configuration

      Perform this task to verify the dynamic CCoA configuration:

      SUMMARY STEPS

        1.    show ip mobile router interface

        2.    show ip mobile router agent

        3.    show ip mobile router registration

        4.    show ip mobile router

        5.    show ip mobile binding


      DETAILED STEPS
         Command or ActionPurpose
        Step 1 show ip mobile router interface


        Example:
        Mobilerouter# show ip mobile router interface
         

        Displays information about the interface that the mobile router is using for roaming.

        • If the interface is configured for CCoA, the CCoA (IP address) is displayed even if the interface is down.
         
        Step 2 show ip mobile router agent


        Example:
        Mobilerouter# show ip mobile router agent
         

        Displays information about the agents for the mobile router.

        • If the interface configured for CCoA is up, an entry is shown.
         
        Step 3 show ip mobile router registration


        Example:
        Mobilerouter# show ip mobile router registration
         

        Displays the pending and accepted registrations of the mobile router.

         
        Step 4 show ip mobile router


        Example:
        Mobilerouter# show ip mobile router
         

        Displays configuration information and monitoring statistics about the mobile router.

         
        Step 5 show ip mobile binding


        Example:
        Homeagent# show ip mobile router
         

        Displays the mobility binding table.

        • If a CCoA is registered with the home agent, (D) direct-to-mobile node is displayed in the Routing Options field.
         

        Configuration Examples for Mobile Networks Dynamic CCoA

        Mobile Networks Dynamic CCoA Example

        The following example shows a mobile router configured to obtain a CCoA dynamically through IPCP:

        interface loopback 0
        ! MR home address
         ip address 10.1.0.1 255.255.255.255
        !
        ! Dynamic CCoA.
        interface Serial 3/1
         ip address negotiated
         encapsulation ppp
         ip mobile router-service roam
         ip mobile router-service collocated

        Mobile Networks with CCoA-Only Processing Example

        The following example shows a mobile router configured to obtain a static CCoA only. The interface will not listen to foreign agent advertisements.

        interface loopback1
         ip address 20.0.4.1 255.255.255.255
        !
        ! Static CCoA with CCoA-only option
        interface Ethernet 1/0
         ip address 10.0.1.1 255.255.255.0
         ip mobile router-service roam
         ip mobile router-service collocated gateway 10.0.1.2 ccoa-only
         ip mobile router-service collocated registration retry 30

        The following example shows a mobile router configured to obtain a dynamic CCoA only. The interface will not listen to foreign agent advertisements.

        interface loopback1
         ip address 20.0.4.1 255.255.255.255
        !
        ! Dynamic CCoA with CCoA-only option
        interface Serial 2/0
         ip address negotiated
         encapsulation ppp
         ip mobile router-service roam
         ip mobile router-service collocated ccoa-only
         ip mobile router-service collocated registration retry 30
        

        Additional References

        The following sections provide additional references related to the Mobile Networks Dynamic CCoA feature.

        Related Documents

        Related Topic

        Document Title

        Mobile IP commands: complete command syntax, command mode, defaults, usage guidelines, and examples

        Cisco IOS IP Command Reference, Volume 4 of 4: IP Mobility, Release 12.3 T

        Mobile IP commands and configuration tasks related to mobile networks

        http:/​/​www.cisco.com/​univercd/​cc/​td/​doc/​product/​software/​ios122/​122newft/​122t/​122t4/​ftmbrout.htm Cisco Mobile Networks feature document, Release 12.2(4)T and 12.2(13)T

        Static CCoA documentation

        http:/​/​www.cisco.com/​univercd/​cc/​td/​doc/​product/​software/​ios122/​122newft/​122t/​122t15/​ftcolloc.htm Cisco Mobile Networks - Static Collocated Care-of Address , Release 12.2(15)T

        Standards

        Standards

        Title

        No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

        --

        MIBs

        MIBs

        MIBs Link

        No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

        To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

        http:/​/​www.cisco.com/​go/​mibs

        RFCs

        RFCs

        Title

        No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.

        --

        Technical Assistance

        Description

        Link

        Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

        http:/​/​www.cisco.com/​public/​support/​tac/​home.shtml

        Command Reference

        The following commands are introduced or modified in the feature or features documented in this module. For information about these commands, see the Cisco IOS IP Mobility Command Reference at http://www.cisco.com/en/US/docs/ios/ipmobility/command/reference/imo_book.html. For information about all Cisco IOS commands, go to the Command Lookup Tool at http:/​/​tools.cisco.com/​Support/​CLILookup or to the Cisco IOS Master Commands List .

        • ip mobile router-service collocated
        • show ip mobile router agent
        • show ip mobile router interface

        Glossary

        care-of address --The termination point of the tunnel to a mobile node or mobile router. This can be a collocated care-of address, by which the mobile node or mobile router acquires a local address and detunnels its own packets, or a foreign agent care-of address, by which a foreign agent detunnels packets and forwards them to the mobile node or mobile router.

        collocated care-of address --The termination point of a tunnel toward a mobile node or mobile router. A CCoA is a local address that the mobile node or mobile router associated with one of its own network interfaces.

        foreign agent --A router on the visited network of a foreign network that provides routing services to the mobile node or mobile router while registered. The foreign agent detunnels and delivers packets to the mobile node or mobile router that were tunneled by the home agent of the mobile node. For packets sent by a mobile node, the foreign agent may serve as a default router for registered mobile nodes.


        Note


        Refer to Internetworking Terms and Acronyms for terms not included in this glossary.