IP Mobility: Mobile Networks Configuration Guide, Cisco IOS Release 15M&T
EIGRP Dynamic Metric Calculations
Downloads: This chapterpdf (PDF - 1.4MB) The complete bookPDF (PDF - 4.47MB) | The complete bookePub (ePub - 826.0KB) | Feedback

EIGRP Dynamic Metric Calculations

Contents

EIGRP Dynamic Metric Calculations

The EIGRP Dynamic Metric Calculations features enables the Enhanced Interior Gateway Routing Protocol (EIGRP) to use dynamic raw radio-link characteristics (current and maximum bandwidth, latency, and resources) to compute a composite EIGRP metric. A tunable hysteresis mechanism helps to avoid churn in the network as a result of the change in the link characteristics. In addition to the link characteristics, the L2/L3 API provides an indication when a new adjacency is discovered, or an existing unreachable adjacency is again reachable. When the Interior Gateway Routing Protocol (IGRP) receives the adjacency signals, it responds with an immediate Hello out the specified interface to expedite the discovery of the EIGRP peer.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for EIGRP Dynamic Metric Calculations

Complete the virtual template and the appropriate PPP over Ethernet (PPPoE) configurations before performing this tasks in this module.

Information About EIGRP Dynamic Metric Calculations

Link-Quality Metrics Reporting for EIGRP

The quality of a radio link has a direct impact on the throughput that can be achieved by device-to-device traffic. The PPP over Ethernet (PPPoE) provides a process by which a device can request, or a radio can report, link-quality metric information. With the Cisco Enhanced Interior Gateway Routing Protocol (EIGRP) implementation, the route cost to a neighbor is dynamically updated based on metrics reported by the radio, thus allowing the best route to be chosen within a given set of radio links and reducing the effect of frequent routing changes.

The routing protocols receive raw radio-link data and compute a composite quality metric for each link In computing these metrics, you should consider these factors:

  • Maximum data rate--the theoretical maximum data rate of the radio link, in scaled bits per second
  • Current data rate--the current data rate achieved on the link, in scaled bits per second
  • Resources--a percentage (0 to 100) that can represent the remaining amount of a resource (such as battery power)
  • Latency--the transmission delay packets encounter, in milliseconds
  • Relative link quality--a numeric value (0 to 100) representing relative quality, with 100 being the highest quality

You can weight metrics during the configuration process to emphasize or deemphasize particular characteristics. For example, if throughput is a particular concern, you can weight the throughput metric so that it is factored more heavily into the composite route cost. Similarly, a metric of no concern can be omitted from the composite calculation

Link metrics can change rapidly, often by very small degrees, which can result in a flood of meaningless routing updates. In a worst-case scenario, the network could churn almost continuously as it struggles to react to minor variations in link quality. To alleviate this concern, Cisco provides a tunable dampening mechanism that allows you to configure threshold values. Any metric change that falls below the threshold is ignored. The quality of a connection to a neighbor varies, based on various characteristics of the interface when EIGRP is used as the routing protocol. The routing protocol receives dynamic raw radio-link characteristics and computes a composite metric that is used to reduce the effect of frequent routing changes.

By using the tunable hysteresis mechanism, you can adjust the threshold to the routing changes that occur when the device receives a signal that a new peer has been discovered or that an existing peer is unreachable. The tunable metric is weighted and is adjusted dynamically to account for these characteristics:

  • Current and maximum bandwidth
  • Latency
  • Resources
  • Relative link quality (RLQ)

You can deconfigure individual weights, and you can clear all weights so that the cost returns to the default value for the interface type. Based on the routing changes that occur, you can determine the cost by applying these metrics.

EIGRP Cost Metrics for VMIs

When the Enhanced Interior Gateway Routing Protocol (EIGRP) is used as the routing protocol, metrics allow EIGRP to respond to routing changes. The link-state metric is advertised as the link cost in the device link advertisement. The reply sent to any routing query always contains the latest metric information. The exceptions that result in an immediate update being sent are:

  • A down interface
  • A down route
  • Any change in a metric that results in the device selecting a new next hop

EIGRP receives dynamic raw radio-link characteristics and computes a composite EIGRP metric based on a proprietary formula. To avoid churn in the network as a result of the change in the link characteristics, EIGRP uses a tunable dampening mechanism.

EIGRP uses the metric weights along with a set of vector metrics to compute the composite metric for local routing information base (RIB) installation and route selections. The EIGRP composite metric is calculated using the formula:

metric = [K1 * BW + (K2 * BW) / (256 - Load) + K3 * Delay] * [K5 / (Reliability + K4)]

If K5 = 0, the formula reduces to metric = [K1 * BW + (K2 * BW)/(256 - Load) + K3 * Delay]


Note


Use K values only after careful planning. Mismatched K values prevent a neighbor relationship from being built, which can cause your network to fail to converge.


The table below lists the EIGRP vector metrics and their descriptions.

Table 1 EIGRP Vector Metrics

Vector Metric

Description

BW

Minimum bandwidth of the route in kb/s. It can be 0 or any positive integer.

Delay

Route delay in tens of microseconds. It can be 0 or any positive number that is a multiple of 39.1 nanoseconds.

Reliability

Likelihood of successful packet transmission expressed as a number from 0 to 255. The value 255 means 100 percent reliability; 0 means no reliability.

Load

Effective load of the route expressed as a number from 0 to 255 (255 is 100 percent loading).

MTU

Minimum maximum transmission unit (MTU) size of the route in bytes. It can be 0 or any positive integer.

EIGRP monitors metric weights on an interface to allow for the tuning of EIGRP metric calculations and indicate the type of service (ToS). The table below lists the K-values and their default.

Table 2 EIGRP K-Value Defaults

Setting

Default Value

K1

1

K2

0

K3

1

K4

0

K5

0

Most configurations use the first two metrics—delay and bandwidth. The default formula of (BW + Delay) is the EIGRP metric. The bandwidth for the formula is scaled and inverted by this formula:

(10^7/minimum BW in kilobits per second)

You can change the weights, but these weights must be the same on all the devices.

For example, look at an EIGRP link where the bandwidth to a particular destination is 128k and the Relative Link Quality (RLQ) is 50 percent.

BW = (256 * 10000000) / 128 = 20000000

Delay = (((10000000000 / 128) * 100) / (50 * 1000)) * 256 = (40000000 / 10) = 4000000

Using the cut-down formula, the EIGRP metric calculation would simplify to 256*(BW + Delay), resulting in the following value:

Metric = (BW + Delay) = 20000000 + 4000000 = 240000000

VMI Metric to EIGRP Metric Conversion

The quality of connection to a virtual multipoint interface (VMI) neighbor varies based on various characteristics computed dynamically based on the feedback from Layer 2 to Layer 3. The table below lists the Enhanced Interior Gateway Routing Protocol (EIGRP) metrics and their significance.

Table 3 EIGRP MANET Metrics for VMI Interfaces

Metric

Significance

Current data rate

uint64_t

The current data rate reported from the radio. EIGRP converts the value into kilobits per second.

Max data rate

uint64_t

The maximum data rate reported from the radio. EIGRP converts the value into kilobits per second.

Latency

unsigned int

The latency computed and reported by the radio in milliseconds.

Resources

unsigned int

The resources computed by the radio. A representation of resources, such as battery power, ranges from 0 to 100. If a radio does not report dynamic resources, the value is always 100.

Relative link quality

unsigned int

An opaque number that ranges from 0 to 100 is computed by the radio, representing radio's view of link quality. 0 represents the worst possible link, 100 represents the best possible link.

Link-load

unsigned int

An opaque number that ranges from 0 to 100 is computed by VMI, representing the load on the Ethernet link. 0 represents an idle Ethernet link, 100 represents a fully loaded Ethernet link. Note that this is not associated with the radio link.

The table below shows how these EIGRP vector metric values map to the basic EIGRP interface parameters.

Table 4 Mapping of VMI Metric Values to EIGRP Vector Metrics Values

VMI Metric

EIGRP Metric

Mapping

Current data rate

Bandwidth

Calculated:

bandwidth = (256 * 10000000) / (current data rate / 1000)

Relative link quality resources

Reliability

Calculated:

reliability = (255 * (relative link quality) / 100)) *

(resources / 100)

Current data rate

Relative link quality

Delay

Calculated:

delay = 256 * (1E10 / (current data rate / 1000)) * ((100 / relative link quality) / 1000) / 10

Load

Load

Calculated:

load = ((255 * link-load) / 100)

EIGRP Metric Dampening for VMIs

Rapid changes in metric components can affect the network by requiring that prefixes learned though the virtual multipoint interface (VMI) be updated and sent to all adjacencies. This update can result in further updates and, in a worst-case scenario, cause network-wide churn. To prevent such effects, metrics can be dampened, or thresholds set, so that any change that does not exceed the dampening threshold is ignored.

Network changes that cause an immediate update include

  • A down interface
  • A down route
  • Any change in a metric that results in the device selecting a new next hop

Dampening the metric changes can be configured based on change or time intervals.

If the dampening method is change-based, changes in routes learned though a specific interface, or in the metrics for a specific interface, are not advertised to adjacencies until the computed metric changes from the last advertised value significantly enough to cause an update to be sent.

If this dampening method is interval-based, changes in routes learned though a specific interface, or in the metrics for a specific interface, are not advertised to adjacencies until the specified interval is met, unless the change results in a new route path selection.

When the timer expires, any routes that have outstanding changes to report are sent. If a route changes, such that the final metric of the route matches the last updated metric, no update is sent.

How to Configure EIGRP Dynamic Metric Calculations

Setting the EIGRP Change-based Dampening Interval Using Classic-Style Configuration

Perform this optional task to set the Enhanced Interior Gateway Routing Protocol (EIGRP) change-based dampening interval for virtual multipoint interfaces (VMIs) using classic-style configuration. Configuring the router eigrp autonomous-system-number command creates an EIGRP configuration referred to as autonomous system (AS) configuration. An EIGRP AS configuration creates an EIGRP routing instance that can be used for tagging routing information.

You can configure this feature with either an IPv4 or an IPv6 address, or you can use both. If you are using both IPv4 and IPv6, complete the entire configuration.

This configuration sets the threshold to 50 percent tolerance for routing updates involving VMIs and peers.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface type number

    4.    ip address address mask

    5.    no ip redirects

    6.    no ip split-horizon eigrp autonomous-system-number

    7.    ip dampening-change eigrp autonomous-system-number percentage

    8.    Enter one of the following commands:

    • ipv6 address address
    • ipv6 enable

    9.    ipv6 eigrp autonomous-system-number

    10.    no ipv6 split-horizon eigrp autonomous-system-number

    11.    ipv6 dampening-change eigrp autonomous-system-number percentage

    12.    router eigrp autonomous-system-number

    13.    network address

    14.    ipv6 router eigrp autonomous-system-number

    15.    end


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface type number


    Example:
    Device(config)# interface vmi 1
     

    Enters interface configuration mode and creates a VMI.

     
    Step 4 ip address address mask


    Example:
    Device(config-if)# ip address 209.165.200.225 255.255.255.224
     

    Specifies the IP address of the VMI.

     
    Step 5 no ip redirects


    Example:
    Device(config-if)# no ip redirects
    
     

    Prevents the device from sending redirects.

     
    Step 6 no ip split-horizon eigrp autonomous-system-number


    Example:
    Device(config-if)# no ip split-horizon eigrp 101
     

    Disables the EIGRP split horizon.

     
    Step 7 ip dampening-change eigrp autonomous-system-number percentage


    Example:
    Device(config-if)# ip dampening-change eigrp 1 50
     

    Sets a threshold percentage to minimize or dampen the effect of frequent routing changes for IPv4.

     
    Step 8Enter one of the following commands:
    • ipv6 address address
    • ipv6 enable


    Example:
    Device(config-if)# ipv6 address 2001:0DB8::/32


    Example:
    Device(config-if)# ipv6 enable
     

    Specifies the IPv6 address.

    or

    Enables IPv6 routing on the interface.

     
    Step 9 ipv6 eigrp autonomous-system-number


    Example:
    Device(config-if)# ipv6 eigrp 1
     

    Enables EIGRP for IPv6 on the interface.

     
    Step 10 no ipv6 split-horizon eigrp autonomous-system-number


    Example:
    Device(config-if)# no ipv6 split-horizon eigrp 1
     

    Disables the sending of IPv6 redirect messages on an interface.

     
    Step 11 ipv6 dampening-change eigrp autonomous-system-number percentage


    Example:
    Device(config-if)# ipv6 dampening-change eigrp 1 30
     

    Sets a threshold percentage to minimize or dampen the effect of frequent routing changes for IPv6.

     
    Step 12 router eigrp autonomous-system-number


    Example:
    Device(config-if)# router eigrp 1
     

    Configures the EIGRP address family process and enters router configuration mode.

     
    Step 13 network address


    Example:
    Device(config-router)# network 209.165.200.225
     

    Configures the network address.

     
    Step 14 ipv6 router eigrp autonomous-system-number


    Example:
    Device(config-router)# ipv6 router eigrp 1
     

    Configures an EIGRP routing process in IPv6.

     
    Step 15 end


    Example:
    Device(config-router)# end
     

    (Optional) Returns to privileged EXEC mode.

     

    Setting the EIGRP Change-based Dampening Interval Using Named-Style Configuration

    Perform this optional task to set the Enhanced Interior Gateway Routing Protocol (EIGRP) change-based dampening interval for virtual multipoint interfaces (VMIs) using named-style configuration. Configuring the router eigrp virtual-instance-name command creates an EIGRP configuration referred to as an EIGRP named configuration. An EIGRP named configuration does not create an EIGRP routing instance by itself. EIGRP named configuration is a base configuration that is required to define address-family configurations under it that are used for routing.

    You can configure this feature with either an IPv4 or an IPv6 address, or you can use both. If you are using both IPv4 and IPv6, then complete the entire configuration.

    This configuration sets the threshold to 50 percent tolerance for routing updates involving VMIs and peers.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface type number

      4.    ip address address mask

      5.    no ip redirects

      6.    Enter one of the following commands:

      • ipv6 address address
      • ipv6 enable

      7.    router eigrp virtual-instance-name

      8.    address-family ipv4 autonomous-system autonomous-system-number

      9.    network address

      10.    af-interface type number

      11.    dampening-change percentage

      12.    exit

      13.    exit

      14.    address-family ipv6 autonomous-system autonomous-system-number

      15.    af-interface type number

      16.    dampening-change percentage

      17.    end


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Device> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface type number


      Example:
      Device(config)# interface vmi 1
       

      Enters interface configuration mode and creates a VMI.

       
      Step 4 ip address address mask


      Example:
      Device(config-if)# ip address 209.165.200.225 255.255.255.224
       

      Specifies the IP address of the VMI.

       
      Step 5 no ip redirects


      Example:
      Device(config-if)# no ip redirects
      
       

      Prevents the device from sending redirects.

       
      Step 6 Enter one of the following commands:
      • ipv6 address address
      • ipv6 enable


      Example:
      Device(config-if)# ipv6 address 2001:0DB8::/32


      Example:
      Device(config-if)# ipv6 enable
       

      Specifies the IPv6 address.

      or

      Enables IPv6 routing on the interface.

       
      Step 7 router eigrp virtual-instance-name


      Example:
      Device(config-if)# router eigrp name
       

      Enables EIGRP for IPv6 on the interface, and enters router configuration mode.

       
      Step 8 address-family ipv4 autonomous-system autonomous-system-number


      Example:
      Device(config-router)# address-family ipv4 autonomous-system 1
      
       

      Enters address family configuration mode to configure an EIGRP routing instance.

       
      Step 9 network address


      Example:
      Device(config-router-af)# network 209.165.200.225
       

      Configures the network address.

       
      Step 10 af-interface type number


      Example:
      Device(config-router-af)# af-interface vmi 1
      
       

      Enters address family interface configuration mode.

       
      Step 11 dampening-change percentage


      Example:
      Device(config-router-af-interface)# dampening-change 50
      
       

      Sets a threshold percentage to minimize or dampen the effect of frequent routing changes through an interface in an EIGRP address family.

       
      Step 12 exit


      Example:
      Device(config-router-af-interface)# exit
       

      Exits address-family interface configuration mode.

       
      Step 13 exit


      Example:
      Device(config-router-af)# exit
       

      Exits address-family configuration mode and enters router configuration mode.

       
      Step 14 address-family ipv6 autonomous-system autonomous-system-number


      Example:
      Device(config-router)# address-family ipv6 autonomous-system 1
       

      Enters address family configuration mode to configure an EIGRP routing instance for IPv6.

       
      Step 15 af-interface type number


      Example:
      Device(config-router-af)# af-interface vmi 1
      
       

      Enters address family interface configuration mode.

       
      Step 16 dampening-change percentage


      Example:
      Device(config-router-af-interface)# dampening-change 50
       

      Sets a threshold percentage to minimize or dampen the effect of frequent routing changes through an interface.

       
      Step 17 end


      Example:
      Device(config-router-af-interface)# end
      
       

      (Optional) Returns to privileged EXEC mode.

       

      Setting the EIGRP Interval-based Dampening Interval Using Classic-Style Configuration

      Perform this optional task to set an Enhanced Interior Gateway Routing Protocol (EIGRP) interval-based dampening interval for virtual multipoint interfaces (VMIs) using classic-style configuration. Configuring the router eigrp autonomous-system-number command creates an EIGRP configuration referred to as autonomous system (AS) configuration. An EIGRP AS configuration creates an EIGRP routing instance that can be used for tagging routing information.

      This configuration sets the interval to 30 seconds at which updates occur for topology changes that affect VMIs and peers.

      SUMMARY STEPS

        1.    enable

        2.    configure terminal

        3.    interface type number

        4.    ip address address mask

        5.    no ip redirects

        6.    no ip split-horizon eigrp autonomous-system-number

        7.    ip dampening-interval eigrp autonomous-system-number interval

        8.    Enter one of the following commands:

        • ipv6 address address
        • ipv6 enable

        9.    ipv6 eigrp autonomous-system-number

        10.    no ipv6 split-horizon eigrp autonomous-system-number

        11.    ipv6 dampening-interval eigrp autonomous-system-number interval

        12.    router eigrp autonomous-system-number

        13.    network address

        14.    ipv6 router eigrp autonomous-system-number

        15.    end


      DETAILED STEPS
         Command or ActionPurpose
        Step 1 enable


        Example:
        Device> enable
         

        Enables privileged EXEC mode.

        • Enter your password if prompted.
         
        Step 2 configure terminal


        Example:
        Device# configure terminal
         

        Enters global configuration mode.

         
        Step 3 interface type number


        Example:
        Device(config)# interface vmi 1
         

        Enters interface configuration mode and creates a VMI.

         
        Step 4 ip address address mask


        Example:
        Device(config-if)# ip address 209.165.200.225 255.255.255.224
         

        Specifies the IP address of the VMI.

         
        Step 5 no ip redirects


        Example:
        Device(config-if)# no ip redirect
        
         

        Prevents the device from sending redirects.

         
        Step 6 no ip split-horizon eigrp autonomous-system-number


        Example:
        Device(config-if)# no ip split-horizon eigrp 101
         

        Disables the EIGRP split horizon.

         
        Step 7 ip dampening-interval eigrp autonomous-system-number interval


        Example:
        Device(config-if)# ip dampening-change eigrp 1 30
         

        Sets a threshold time interval to minimize or dampen the effect of frequent routing changes through an interface.

         
        Step 8 Enter one of the following commands:
        • ipv6 address address
        • ipv6 enable


        Example:
        Device(config-if)# ipv6 address 2001:0DB8::/32


        Example:
        Device(config-if)# ipv6 enable
         

        Specifies the IPv6 address.

        or

        Enables IPv6 routing on the interface.

         
        Step 9 ipv6 eigrp autonomous-system-number


        Example:
        Device(config-if)# ipv6 eigrp 1
         

        Enables EIGRP for IPv6 on the interface.

         
        Step 10 no ipv6 split-horizon eigrp autonomous-system-number


        Example:
        Device(config-if)# no ipv6 split-horizon eigrp 1
         

        Disables the sending of IPv6 redirect messages on an interface.

         
        Step 11 ipv6 dampening-interval eigrp autonomous-system-number interval


        Example:
        Device(config-if)# ipv6 dampening-interval eigrp 1 30
        
         

        Sets a threshold time interval to minimize or dampen the effect of frequent routing changes through an interface.

         
        Step 12 router eigrp autonomous-system-number


        Example:
        Device(config-if)# router eigrp 1
         

        Configures the EIGRP address family process and enters router configuration mode.

         
        Step 13 network address


        Example:
        Device(config-router)# network 209.165.200.225
         

        Configures the network address.

         
        Step 14 ipv6 router eigrp autonomous-system-number


        Example:
        Device(config-router)# ipv6 router eigrp 1
         

        Configures an EIGRP routing process in IPv6.

         
        Step 15 end


        Example:
        Device(config-router)# end
         

        (Optional) Returns to privileged EXEC mode.

         

        Setting the EIGRP Interval-based Dampening Interval Using Named-Style Configuration

        Perform this optional task to set an Enhanced Interior Gateway Routing Protocol (EIGRP) interval-based dampening interval for virtual multipoint interfaces (VMIs) using named-style configuration. Configuring the router eigrp eigrp virtual-instance-name command creates an EIGRP configuration referred to as an EIGRP named configuration. An EIGRP named configuration does not create an EIGRP routing instance by itself. EIGRP named configuration is a base configuration that is required to define address-family configurations under it that are used for routing.

        This configuration sets the interval to 30 seconds at which updates occur for topology changes that affect VMIs and peers.

        SUMMARY STEPS

          1.    enable

          2.    configure terminal

          3.    interface type number

          4.    ip address address mask

          5.    no ip redirects

          6.    Enter one of the following commands:

          • ipv6 address address
          • ipv6 enable

          7.    router eigrp virtual-instance-name

          8.    address-family ipv4 autonomous-system autonomous-system-number

          9.    network address

          10.    af-interface type number

          11.    dampening-interval interval

          12.    exit

          13.    exit

          14.    address-family ipv6 autonomous-system autonomous-system-number

          15.    af-interface type number

          16.    dampening-interval interval

          17.    end


        DETAILED STEPS
           Command or ActionPurpose
          Step 1 enable


          Example:
          Device> enable
           

          Enables privileged EXEC mode.

          • Enter your password if prompted.
           
          Step 2 configure terminal


          Example:
          Device# configure terminal
           

          Enters global configuration mode.

           
          Step 3 interface type number


          Example:
          Device(config)# interface vmi 1
           

          Enters interface configuration mode and creates a VMI.

           
          Step 4 ip address address mask


          Example:
          Device(config-if)# ip address 209.165.200.225 255.255.255.224
           

          Specifies the IP address of the VMI.

           
          Step 5 no ip redirects


          Example:
          Device(config-if)# no ip redirects
          
           

          Prevents the device from sending redirects.

           
          Step 6 Enter one of the following commands:
          • ipv6 address address
          • ipv6 enable


          Example:
          Device(config-if)# ipv6 address 2001:0DB8::/32


          Example:
          Device(config-if)# ipv6 enable
           

          Specifies the IPv6 address.

          or

          Enables IPv6 routing on the interface.

           
          Step 7 router eigrp virtual-instance-name


          Example:
          device(config-if)# router eigrp name
           

          Enables EIGRP for IPv6 on the interface, and enters router configuration mode.

           
          Step 8 address-family ipv4 autonomous-system autonomous-system-number


          Example:
          device(config-router)# address-family ipv4 autonomous-system 1
          
           

          Enters address family configuration mode to configure an EIGRP routing instance.

           
          Step 9 network address


          Example:
          device(config-router-af)# network 209.165.200.225
           

          Configures the network address.

           
          Step 10 af-interface type number


          Example:
          device(config-router-af)# af-interface vmi 1
          
           

          Enters address family interface configuration mode.

           
          Step 11 dampening-interval interval


          Example:
          device(config-router-af-interface)# dampening-interval 30
          
           

          Sets a threshold time interval to minimize or dampen the effect of frequent routing changes through an interface.

           
          Step 12 exit


          Example:
          device(config-router-af-interface)# exit
           

          Exits address family interface configuration mode.

           
          Step 13 exit


          Example:
          device(config-router-af)# exit
           

          Exits address family configuration mode and enters the router configuration mode.

           
          Step 14 address-family ipv6 autonomous-system autonomous-system-number


          Example:
          device(config-router)# address-family ipv6 autonomous-system 1
           

          Enters address family configuration mode to configure an EIGRP routing instance for IPv6.

           
          Step 15 af-interface type number


          Example:
          device(config-router-af)# af-interface vmi 1
          
           

          Enters address family interface configuration mode.

           
          Step 16 dampening-interval interval


          Example:
          device(config-router-af-interface)# dampening-interval 30
           

          Sets a threshold time interval to minimize or dampen the effect of frequent routing changes through an interface.

           
          Step 17 end


          Example:
          device(config-router-af-interface)# end
          
           

          (Optional) Returns to privileged EXEC mode.

           

          Configuration Examples for EIGRP Dynamic Metric Calculations

          Example: EIGRP Change-based Dampening for VMIs

          The following example configures the Enhanced Interior Gateway Routing Protocol (EIGRP) address-family Ethernet interface 0/0 to limit the metric change frequency to no more than one change in a 45-second interval:

          Device(config)# router eigrp virtual-name 
          Device(config-router)# address-family ipv4 autonomous-system 5400
          Device(config-router-af)# af-interface ethernet 0/0
          Device(config-router-af-interface)# dampening-interval 45
          

          Example: EIGRP Interval-based Dampening for VMIs

          The following example configures the Enhanced Interior Gateway Routing Protocol (EIGRP) address-family Ethernet interface 0/0 to limit the metric change frequency to no more than one change in a 45-second interval:

          Device(config)# router eigrp virtual-name 
          Device(config-router)# address-family ipv4 autonomous-system 5400
          Device(config-router-af)# af-interface ethernet 0/0
          

          Additional References

          Related Documents

          Related Topic

          Document Title

          Cisco IOS commands

          Cisco IOS Master Command List, All Releases

          Enhanced Interior Gateway Routing Protocol (EIGRP) configuration tasks and commands

          IP Routing: EIGRP Configuration Guide

          Cisco IOS IP Routing: EIGRP Command Reference

          IPv6 configuration tasks and commands

          IPv6 Configuration Library

          Cisco IOS IPv6 Command Reference

          Technical Assistance

          Description

          Link

          The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

          http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

          Feature Information for EIGRP Dynamic Metric Calculations

          The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

          Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

          Table 5 Feature Information for EIGRP Dynamic Metric Calculations

          Feature Name

          Releases

          Feature Information

          EIGRP Dynamic Metric Calculations

          12.4(15)XF

          12.4(15)T

          15.0(1)M

          The EIGRP Dynamic Metric Calculations features enables the Enhanced Interior Gateway Routing Protocol (EIGRP) to use dynamic raw radio-link characteristics (current and maximum bandwidth, latency, and resources) to compute a composite EIGRP metric. A tunable hysteresis mechanism helps to avoid churn in the network as a result of the change in the link characteristics.

          In addition to the link characteristics, the L2/L3 API provides an indication when a new adjacency is discovered, or an existing unreachable adjacency is again reachable. When the Interior Gateway Routing Protocol (IGRP) receives the adjacency signals, it responds with an immediate Hello out the specified interface to expedite the discovery of the EIGRP peer.

          The following commands were introduced or modified: dampening-change, dampening-interval, debug eigrp notifications, debug vmi.